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1

In the following sections, this chapter describes the models, options, and features available for Keysight E8257D/67D
and E8663D PSG signal generators. The modes of operation, front panel user interface, and front and rear panel

connectors are also described.

Signal Generator Overview

“Signal Generator Models and Features” on page 1

“Options” on page 7

“Firmware Upgrades” on page 7
“Modes of Operation” on page 8
“Front Panel” on page 10

“Front Panel Display” on page 17

“Rear Panel” on page 21

NOTE For more information about the PSG, such as data sheets, configuration guides, application notes, frequently
asked questions, technical support, software and more, visit the Keysight PSG web page at
http: //mww.keysi ght.com/find/psg.

Signal Generator Models and Features

Table 1-1 liststhe available PSG signal generator models and frequency—range options.

Table1-1 PSG Signal Generator Models

Model

Frequency Range Options

E8257D PSG analog signal generator

250 kHz to 20 GHz (Option 520)
10 MHz to 20 GHz (Option 521)
250 kHz to 31.8 GHz (Option 532)
250 kHz to 40 GHz (Option 540)
250 kHz to 50 GHz (Option 550)

250 kHz to 67 GHz (Option 567)2

E8267D PSG vector signal generator

250 kHz to 20 GHz (Option 520)
250 kHz to 31.8 GHz (Option 532)
250 kHz to 44 GHz (Option 544)

KEYSIGHT

TECHNOLOGIES
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Signal Generator Overview
Signal Generator Models and Features

Table 1-1 PSG Signal Generator Models

Model

Freguency Range Options

E8663D PSG analog signal generator

100 kHz to 3.2 GHz (Option 503)
100 kHz to 9 GHz (Option 509)

8 nstruments with Option 567 are functional, but unspecified, above 67 GHz to 70 GHz
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Signal Generator Models and Features

E8257D PSG Analog Signal Generator Features
The E8257D PSG includes the following standard features:

e asource module interface that is compatible with Keysight 83550 Series millimeter—wave source modules for
frequency extension up to 110 GHz and Oleson Microwave Labs (OML) AG-Series millimeter—wave modules for
frequency extensions up to 325 GHz

« automatic leveling control (ALC) on and off modes; power calibration in ALC—off mode is available, even without
power search

e CW output from 250 kHz to the highest operating frequency, depending on the option
* externa diode detector leveling

« frequency resolution to 0.001 Hz

e list and step sweep of frequency and amplitude, with multiple trigger sources

e optimized signal to noise ratio

¢ 10 MHz reference oscillator with external output

e RS-232, GPIB, and 10Base-T LAN 1/O interfaces

e user flatness correction

e attenuator burnout protection (with Option 521 instruments that have Option 1E1)
The E8257D PSG also offers the following optional features:

NOTE To provide analog frequency sweeps and for optimum swept scalar measurements with the 8757D scalar
analyzer, the E8257D requires 007 (analog ramp sweep).

Option 007—anal og ramp sweep

Option 008'—8 GB removable compact flash drive

Option 521—ultra high output power, frequency range from 0.1-20 GHz
Option 1E1—step attenuator

Option 1EA (Discontinued)—high output power

Option 1IED—Type-N female RF output connector

Option 1EH —improved harmonics below 2 GHz

Option 1IEU—high output power (standard with E8267D)

Option IEM—moves al front panel connectorsto the rear panel
Option 1SM—provides improved performance in Exponential (Log) AM mode
Option UK6—commercial calibration certificate and test data

Linstruments with serial prefix > US4928/SG4928/MY 4928.
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Signal Generator Models and Features

Option UNR (Discontinued)—enhanced phase noise performance

Option UNX—ultralow phase noise performance

Option UNY—enhanced ultralow phase noise performance

Option UNT—AM, FM, phase modulation, and LF output

oper- oop or closed-oop AM

dc—synthesized FM to 10 MHz rates; maximum deviation depends on the carrier frequency

external modulation inputs for AM, FM, and ®M

simultaneous modul ation configurations (except: FM with ®M or Linear AM with Exponential AM)
dual function generators that include the following:

— 50-ohm low—frequency output, 0 to 3 Vp, available through the LF output

— selectable waveforms: sine, dual—sine, swept—sine, triangle, positive ramp, negative ramp, square, uniform
noise, Gaussian noise, and dc

— adjustable frequency modulation rates

— selectabletriggering in list and step sweep modes: free run (auto), trigger key (single), bus (remote), and
external

Option UNU—pulse modulation

internal pulse generator
external modulation inputs

selectable pulse modes: internal square, internal free—run, internal triggered, internal doublet, internal gated, and
external pulse; internal triggered, internal doublet, and internal gated require an externa trigger source

adjustable pulse rate

adjustable pulse period

adjustable pulse width (150 ns minimum)

adjustable pulse delay

selectable external pulse triggering: positive or negative

Option UNW—narrow pulse modulation

generate narrow pulses across the operational frequency band of the PSG
includes all the same functionality as Option UNU

E8267D PSG Vector Signal Generator Features

The E8267D PSG provides the same standard functionality as the E8257D PSG, plus the following:
¢ interna 1/Q modulator
* external analog I/Q inputs

« single-ended and differential analog I/Q outputs

Keysight PSG Signal Generators User’s Guide
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high output power (optional for the E8257D & E8663D)
step attenuator (optional for the E8257D)

The E8267D PSG offers the same options as the E8257D PSG, plus the following:

Option 003—PSG digital output connectivity with N5102A

Option 004—PSG digital input connectivity with N5102A

Option 005% (Discontinued)—6 GB internal hard drive

Option 009°—8 GB removable compact flash drive

Option 015 (Discontinued)—single—ended wideband external 1/Q inputs

Option 016—differential wideband external 1/Q inputs

Option 018—wideband 1Q/FM mode (<3.2 GHz)

Option 403—calibrated noise, AWGN

Option 601 (Discontinued)—internal baseband generator with 8 megasamples of memory

Option 602—internal baseband generator with 64 megasamples of memory

EB663D PSG Analog Signal Generator Features
The E8663D PSG includes the following standard features:

a source module interface that is compatible with Keysight 83550 Series millimeter—wave source modules for
frequency extension up to 110 GHz and Oleson Microwave Labs (OML) AG-Series millimeter—wave modules for
frequency extensions up to 325 GHz

automatic leveling control (ALC) on and off modes; power calibration in ALC—-off mode is available, even without
power search

CW output from 100 kHz to the highest operating frequency, depending on the option
external diode detector leveling

frequency resolution to 0.001 Hz

list and step sweep of frequency and amplitude, with multiple trigger sources
optimized signal to noiseratio

10 MHz reference oscillator with external output

RS-232, GPIB, and 10Base-T LAN I/O interfaces

user flatness correction

pulse modulation

Linstruments with serial prefix < US4829/SG4829/MY 4829.

2Instruments with serial prefix > US4829/SG4829/MY 4829.
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— internal pulse generator
— externa modulation inputs

— selectable pulse modes: internal square, internal free—run, internal triggered, internal doublet, internal gated, and
external pulse; internal triggered, internal doublet, and internal gated require an external trigger source

— adjustable pulse rate

— adjustable pulse period

— adjustable pulse width (150 ns minimum)

— adjustable pulse delay

— selectable external pulse triggering: positive or negative
The E8663D PSG also offers the following optional features:

NOTE To provide analog frequency sweeps and for optimum swept scalar measurements with the 8757D scalar
analyzer, the E8663D requires 007 (analog ramp sweep).

Option 007—anal og ramp sweep

Option 008'—8 GB removable compact flash drive

Option 503—frequency range from 100 kHz to 3.2 GHz

Option 509—frequency range from 100 kHz to 9.0 GHz

Option 521—ultra 0.1-3.2 GHz (with Option 503) or 0.1-9 GHz (with Option 509) power
Option 1E1—step attenuator

Option 1EA (Discontinued)—high output power

Option 1IED—Type-N female RF output connector

Option 1EH —improved harmonics below 2 GHz

Option 1IEU—high output power (standard with E8267D)

Option IEM—moves al front panel connectorsto the rear panel

Option 1EZ—extended support life

Option 1SM—provides improved performance in Exponentia (Log) AM mode
Option UK6—commercial calibration certificate and test data

Option UNX—ultralow phase noise performance

Option UNY—enhanced ultralow phase noise performance

Option UNT—AM, FM, phase modulation, and LF output

Linstruments with serial prefix > US4928/SG4928/MY 4928.
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« open-oop or closed-oop AM
e dc—synthesized FM to 10 MHz rates; maximum deviation depends on the carrier frequency
e externa modulation inputsfor AM, FM, and ®M
e simultaneous modulation configurations (except: FM with ®M or Linear AM with Exponential AM)
e dual function generators that include the following:
— 50-ohm low—frequency output, 0 to 3 Vp, available through the LF output

— selectable waveforms: sine, dual—sine, swept—sine, triangle, positive ramp, negative ramp, square, uniform
noise, Gaussian noise, and dc

— adjustable frequency modulation rates
— selectable triggering in list and step sweep modes: free run (auto), trigger key (single), bus (remote), and
external
Option UNW—narrow pulse modulation
e generate narrow pulses across the operational frequency band of the PSG
e includes all the same functionality as Option UNU

Options

PSG signal generators have hardware, firmware, software, and documentation options. The Data Sheet shipped with
your signal generator provides an overview of available options. For more information, visit the Keysight PSG web page
at http://mww.keysight.convfind/psg, select the desired PSG model, and then click the Options tab.

Firmware Upgrades

You can upgrade the firmware in your signal generator whenever new firmware is released. New firmware rel eases,
which can be downloaded from the Keysight website, may contain signal generator features and functionality not
availablein previous firmware releases.

To determine the availability of new signal generator firmware, visit the Signal Generator Firmware Upgrade Center
web page at http://Mmww.keysight.convfind/upgradeassistant, or call the number listed at
http: //mww.keysight.com/find/assist.

To Upgrade Firmware

The following procedure shows you how to download new firmware to your PSG using aLAN connection and a PC. For
information on equipment reguirements and alternate methods of downloading firmware, such as GPIB, refer to the
Firmware Upgrade Guide, which can be accessed at http://mww.keysight.com/find/upgradeassistant.

1. Notethe P address of your signal generator. To view the | P address on the PSG, press Utility > GPIB/RS-232 LAN
> L AN Setup.

Use an internet browser to visit http://mww.keysight.convfind/upgradeassistant.

Scroll down to the “ Documents and Downloads’ table and click the link in the “Latest Firmware Revision” column
for the E8257D/67D or E8663D PSG.

4. Inthe File Download window, select Run.
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In the Welcome window, click Next and follow the on—screen instructions. The firmware files download to the PC.

In the “Documents and Downloads’ table, click thelink in the “Upgrade Assistant Software” column for the
E8257D/67D or E8663D PSG to download the PSG/ESG Upgrade Assistant.

In the File Download window, select Run.
In the Welcome window, click OK and follow the on—screen instructions.
At the desktop shortcut prompt, click Yes.

10. Once the utility downloads, close the browser and double—click the PSG/ESG Upgrade Assistant icon on the
desktop.

11. Inthe upgrade assistant, set the connection type you wish to use to download the firmware, and the parameters for
the type of connection selected. For LAN, enter the instrument’s | P address, which you recorded in step 1.

NOTE If the PSG’'s dynamic host configuration protocol (DHCP) is enabled, the network assigns the instrument an |P
address at power on. Because of this, when DHCP is enabled, the | P address may be different each time you
turn on the instrument. DHCP does not affect the hostname.

12. Click Browse, and double—click the firmware revision to upgrade your signal generator.
13. Inthe Upgrade Assistant, click Next.
14. Once connection to the instrument is verified, click Next and follow the on—screen prompts.

NOTE Oncethe download starts, it cannot be aborted.
When the User Attention message appears, you must first cycle the instrument’s power, then click OK.

When the upgrade completes, the Upgrade Assistant displays a summary.
15. Click OK and close the Upgrade Assistant.

Modes of Operation

Depending on the model and installed options, the PSG signal generator provides up to four basic modes of operation:
continuous wave (CW), swept signal, analog modulation, and digital modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to a single frequency
and power level. The E8257D, E8267D, and E8663D can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over arange of frequencies and/or power levels. The E8257D, E8267D, and
E8663D provide list and step sweep functionality. Option 007 adds analog ramp sweep functionality.

Analog M odulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog modulation types available
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depend on the installed options.

Option UNT provides amplitude, frequency, and phase modulations. Some of these modulations can be used together.
Options UNU and UNW provide standard and narrow pulse modulation capability, respectively. Option UNU is
standard on the E8663D.

Option 1SM provides improved Exponential (Log) AM mode.

Digital Modulation

In this mode, the signal generator modulates a CW signal with either areal-time 1/Q signal or arbitrary 1/Q waveform.
1/Q modulation is only available on the E8267D. An internal baseband generator (Option 601/602) adds the following
digital modulation formats:

Custom Arb Waveform Generator mode can produce a single-modulated carrier or multiple-modulated carriers.
Each modulated carrier waveform must be cal culated and generated before it can be output; this signal generation
occurs on theinternal baseband generator. Once a waveform has been created, it can be stored and recalled, which
enables repeatable playback of test signals. To learn more, refer to “Custom Arb Waveform Generator” on
page 157.

Custom Real Time I/Q Baseband mode produces a single carrier, but it can be modulated with real—time data that
allows real-time control over al of the parameters that affect the signal. The single—carrier signal that is produced
can be modified by applying various data patterns, filters, symbol rates, modulation types, and burst shapes. To learn
more, refer to “Custom Real Time 1/Q Baseband” on page 179.

Two Tone mode produces two separate continuous wave signals (or tones). The frequency spacing between the two
signals and the amplitudes are adjustable. To learn more, refer to “ Two-Tone Waveform Generator” on
page 227.

Multitone mode produces up to 64 continuous wave signals (or tones). Like Two Tone mode, the frequency spacing
between the signals and the amplitudes are adjustable. To learn more, refer to “Multitone Waveform Generator”
on page 217.

Dual ARB mode is used to control the playback sequence of waveform segments that have been written into the
ARB memory located on the internal baseband generator. These waveforms can be generated by the internal
baseband generator using the Custom Arb Waveform Generator mode, or downloaded through a remote interface
into the ARB memory. To learn more, refer to “Using the Dual ARB Waveform Player” on page 89.
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Front Panel

This section describes each item on the PSG front panel. Figure 1-1 shows an E8267D front panel, which includes all

items available on the E8257D and E8663D.

Figure1-1 Sandard E8267D Front Panel Diagram

Irba fopw: Comirucus (Fres Pt
Trig Source: BL FRLt TFip I 1)

E8267D only

O— E8257N, 8257D, and E8267D

1. Display 10. Help 19. SYNC OUT 28. Local
2. Softkeys 11. EXT 1 INPUT 20. VIDEO OUT 29. Preset
3. Knob 12. EXT 2 INPUT 21. Incr Set 30. Line Power LED
4. Amplitude 13. LF OUTPUT 22. GATE/ PULSE/ TRIGGER INPUT 31. LINE
5. Frequency 14. Mod On/Off 23. Arrow Keys 32. Standby LED
6. Save 15. ALC INPUT 24. Hold 33. SYMBOL SYNC
7. Recall 16. RF On/Off 25. Return 34. DATA CLOCK
8. Trigger 17. Numeric Keypad 26. Contrast Decrease 35. DATA
9. MENUS 18. RF OUTPUT 27. Contrast Increase 36. Q Input
37. l Input
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1. Display
The LCD screen provides information on the current function. Information can include status indicators, frequency and

amplitude settings, and error messages. Softkeys labels are located on the right—hand side of the display. For more detail
on the front panel display, see “Front Panel Display” on page 17.

2. Softkeys
Softkeys activate the displayed function to the left of each key.

3. Knob

Use the knob to increase or decrease a numeric value, change a highlighted digit or character, or step through lists or
select itemsin arow.

4. Amplitude

Pressing this hardkey makes amplitude the active function. You can change the output amplitude or use the menus to
configure amplitude attributes such as power search, user flatness, and leveling mode.

5. Frequency

Pressing this hardkey makes frequency the active function. You can change the output frequency or use the menus to
configure frequency attributes such as frequency multiplier, offset, and reference.

6. Save

CAUTION  The Save hardkey does not save table configurations, such aslist sweep, multitone, or ARB.

Pressing this hardkey displays amenu of choices that enable you to save datain the instrument state register. The
instrument state register is a section of memory divided into 10 sequences (humbered O through 9), each containing 100
registers (numbered 00 through 99). It is used to store and recall frequency, amplitude, and modulation settings.

The Save hardkey provides a quick alternative to reconfiguring the signal generator through the front panel or SCPI
commands when switching between different signal configurations. Once an instrument state has been saved, al of the
frequency, amplitude, and modulation settings can be recalled with the Recall hardkey. For more information on saving
and recalling instrument states, refer to “Using the Instrument State Registers” on page 61.

7. Recall

Thiskey restores an instrument state saved in amemory register. To recall an instrument state, press Recall and enter the
desired sequence number and register number. To save a state, use the Save hardkey. For more information on saving
and recalling instrument states, refer to “Using the Instrument State Registers” on page 61.
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8. Trigger

Thiskey initiates an immediate trigger event for afunction such asalist, step, or ramp sweep (Option 007 only). Before
this hardkey can be used to initiate a trigger event, the trigger mode must be set to Trigger Key. For example: press the
Sweep/List hardkey, then one of the following sequences of softkeys:

e More(1of 2) > Sweep Trigger > Trigger Key
e More(1of 2) >Point Trigger > Trigger Key

9. MENUS

These keys open softkey menus for configuring various functions. For descriptions, see the Keysight PSG Signal
Generators Key Reference.

Table 1-2 Hardkeysin Front Panel MENUS Group

E8257D and E8663D PSG E8267D PSG Vector
Analog
AM Mode FM/®M
Sweepl/List Mux Utility
FM/®M AM 1/Q
Utility Sweep/List Pulse
Pulse M ode Setup LF Out
LF Out Aux Fctn

NOTE Some menus are optional. Refer to “Options” on page 7 for more information.

10. Help

Pressing this hardkey causes a short description of any hardkey or softkey to be displayed and, in most cases, alisting of
related remote—operation SCPlI commands. There are two help modes available on the signal generator: single and
continuous. The single mode is the factory preset condition. Toggle between single and continuous mode by pressing
Utility > Instrument Info/Help Mode > Help M ode Single Cont.

* Insingle mode, help text is provided for the next key you press without activating the key’s function. Any key
pressed afterward exits the help mode and its function is activated.

« Incontinuous mode, help text is provided for each subsequent key press until you press the Help hardkey again or
change to single mode. In addition, each key is active, meaning that the key function is executed (except for the
Preset key).

11. EXT 1INPUT

This female BNC input connector (functional only with Options UNT, UNU, or UNW or on the E8663D) accepts a
+1 Vp signal for AM, FM, and ®M. For these modulations, 1 Vp produces the indicated deviation or depth. When

ac—coupled inputs are selected for AM, FM, or @M and the peak input voltage differs from 1V, by more than 3 percent,

the HI/LO display annunciators light. The input impedance is selectable as either 50 or 600 ohms; the damage levels are
5Vimsand 10 V.. On signal generators with Option 1EM, this connector islocated on the rear panel.
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12. EXT 2 INPUT

This female BNC input connector (functional only with Options UNT, UNU, or UNW or on the E8663D) accepts a

+1 Vp signa for AM, FM, and ®M. With AM, FM, or ®M, +1 Vp produces the indicated deviation or depth. When
ac—coupled inputs are selected for AM, FM, or @M and the peak input voltage differs from 1V, by more than 3 percent,
the HI/LO annunciators light on the display. The input impedance is selectable as either 50 or 600 ohms and damage
levelsare 5 Vg and 10 V|, On signal generators with Option 1EM, this connector islocated on the rear panel.

13.LF OUTPUT

This female BNC output connector (functional only with Option UNT or on the E8663D) outputs modulation signals
generated by thelow frequency (LF) source function generator. This output is capable of driving 3V, (nominal) into a 50

ohm load. On signal generators with Option 1EM, this connector is located on the rear panel.

14. Mod On/Off

This hardkey (E8267D and E8257D with Options UNT, UNU, or UNW) enables or disables all active modulation
formats (AM, FM, ®M, Pulse, or 1/Q) applied to the output carrier signal available through the RF OUTPUT connector.
This hardkey does not set up or activate an AM, FM, ®M, Pulse, or I/Q format; each modulation format must still be set
up and activated (for example, AM > AM On) or nothing is applied to the output carrier signal when the M od On/Off
hardkey isenabled. TheMOD ON/OFF annunciator indicates whether active modulation formats have been enabled or
disabled with the M od On/Off hardkey.

15. ALC INPUT

Thisfemale BNC input connector is used for negative external detector leveling. This connector accepts an input of —0.2
mV to —0.5 V. The nominal input impedance is 120 kohms and the damage level is+15 V. On signa generators with
Option 1EM, this connector islocated on the rear panel.

16. RF On/Off

Pressing this hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. Although you
can set up and enable various frequency, power, and modulation states, the RF and microwave output signal is not
present at the RF OUTPUT connector until RF On/Off is set to On. The RF On/Off annunciator is alwaysvisiblein the
display to indicate whether the RF is turned on or off.

17. Numeric Keypad

The numeric keypad consists of the 0 through 9 hardkeys, a decimal point hardkey, and a backspace hardkey ( ).

The backspace hardkey enables you to backspace or alternate between a positive and a negative value. When specifying
anegative numeric value, the negative sign must be entered prior to entering the numeric value.

18. RF OUTPUT

This connector outputs RF and microwave signas. The nominal output impedance is 50 ohms. The reverse—power
damage levelsare 0 Vdc, 0.5 watts nominal. On signal generators with Option 1EM, this connector islocated on the rear
panel. The connector type varies according to frequency option.

Keysight PSG Signal Generators User’s Guide 13



Signal Generator Overview
Front Panel

19. SYNC OUT

This female BNC output connector (functional only with Options UNU or UNW or on the E8663D) outputs a
synchronizing TTL—compatible pulse signal that isnominally 50 nswide during internal and triggered pul se modulation.
The nominal source impedance is 50 ohms. On signal generators with Option 1EM, this connector is located on the rear
panel.

20.VIDEO OUT

Thisfemale BNC output connector (functional only with Options UNU or UNW or on the E8663D) outputsa TTL—evel
compatible pulse signal that follows the output envelope in al pulse modes. The nominal source impedance is 50 ohms.
On signal generators with Option 1EM, this connector is located on the rear panel.

21. Incr Set

This hardkey enables you to set the increment value of the current active function. The increment value of the current
active function appears in the active entry area of the display. Use the numeric keypad, arrow hardkeys, or the knob to
adjust the increment value.

22. GATE/ PULSE/ TRIGGER INPUT

Thisfemale BNC input connector (functional only with Options UNU or UNW or on the E8663D) accepts an externally
supplied pulse signal for use as a pulse or trigger input. With pulse modulation, +1 V ison and O V is off (trigger

threshold of 0.5 V with ahysteresis of 10 percent; so 0.6 V would be on and 0.4 V would be off). The damage levelsare
15V s and 10 V,,. The nominal input impedance is 50 ohms. On signal generators with Option 1EM, this connector is

located on the rear panel.

23. Arrow Keys

These up and down arrow hardkeys are used to increase or decrease a numeric value, step through displayed lists, or to
select itemsin arow of adisplayed list. Individual digits or characters may be highlighted using the left and right arrow
hardkeys. Once an individual digit or character is highlighted, its value can be changed using the up and down arrow
hardkeys.

24. Hold

Pressing this hardkey blanks the softkey label area and text areas on the display. Softkeys, arrow hardkeys, the knob, the
numeric keypad, and the I ncr Set hardkey have no effect once this hardkey is pressed.

25. Return

Pressing this hardkey displays the previous softkey menu. It enables you to step back through the menus until you reach
the first menu you selected.

26. Contrast Decrease
Pressing this hardkey causes the display background to darken.
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27. Contrast Increase

Pressing this hardkey causes the display background to lighten.

28. Local

Pressing this hardkey deactivates remote operation and returns the signal generator to front—panel control.

29. Preset
Pressing this hardkey sets the signal generator to a known state (factory or user—defined).

30. Line Power LED

This green LED indicates when the signal generator power switch is set to the on position.

31. LINE

In the on position, this switch activates full power to the signal generator; in standby, it deactivates all signal generator
functions. In standby, the signal generator remains connected to the line power and power is supplied to some internal
circuits.

32. Sandby LED
Thisyellow LED indicates when the signal generator power switch is set to the standby condition.

33. SYMBOL SYNC

This female BNC input connector is CMOS-compatible and accepts an externally supplied symbol sync signal for use
with the internal baseband generator (Option 601/602). The expected input isa3.3 V CMOS hit clock signa (whichis
also TTL compatible). SYMBOL SYNC might occur once per symbol or be a single one-bhit—wide pulse that is used to
synchronize the first bit of the first symbol. The maximum clock rate is 50 MHz. The damage levelsare > +5.5V and <
—0.5V. The nominal input impedance is not definable. SYMBOL SYNC can be used in two modes:

¢ When used as a symbol sync in conjunction with a data clock, the signal must be high during the first data bit of the
symbol. The signal must be valid during the falling edge of the data clock signal and may be a single pulse or
continuous.

«  Whenthe SYMBOL SYNC itself isused as the (symbol) clock, the CMOS falling edge is used to clock the DATA
signal.

On signal generators with Option 1EM, this connector is located on the rear panel.

34. DATA CLOCK

This female BNC input connector is CMOS compatible and accepts an externally supplied data—clock input signal to
synchronize serial datafor use with the internal baseband generator (Option 601/602). The expected inputisa 3.3V
CMOS hit clock signal (which isalso TTL compatible) where the rising edge is aligned with the beginning data bit. The
falling edgeis used to clock the DATA and SYMBOL SY NC signals. The maximum clock rate is 50 MHz. The damage
levelsare> +5.5 V and < —0.5V. The nominal input impedance is not definable. On signal generators with Option 1EM,
this connector islocated on the rear panel.
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35. DATA

Thisfemale BNC input connector (Options 601/602 only) is CMOS compatible and accepts an externally supplied serial
data input for digital modulation applications. The expected input isa3.3V CMOS signal (whichisaso TTL
compatible) whereaCMOS high = adata 1 and a CMOS low = a data 0. The maximum input data rate is 50 Mb/s. The
data must be valid on the falling edges of the data clock (normal mode) or the on the falling edges of the symbol sync
(symbol mode). The damage levels are > +5.5 and < —0.5V. The nominal input impedance is not definable. On signal
generators with Option 1EM, this connector islocated on the rear panel.

36. Q Input

Thisfemale BNC input connector (E8267D only) accepts the quadrature—phase (Q) component of an externally
supplied, analog, 1/Q modulation. The in—phase (I) component is supplied through the | INPUT. The signal level is

= Q= 0.5 Vs for acalibrated output level. The nominal input impedanceis 50 or 600 ohms. The damage level is 1
Vms and 10 V. To activate signal's applied to the | and Q input connectors, pressM ux > 1/Q Source 1 or 1/Q Source

2 and then select either Ext 50 Ohm or Ext 600 Ohm. On signal generators with Option 1EM, these connectors are
located on the rear panel.

37.1 Input

Thisfemale BNC input connector (E8267D only) accepts the in—phase (1) component of an externally supplied, analog,
1/Q modulation. The quadrature—phase (Q) component is supplied through the Q INPUT. The signal level is m =
0.5 Vs for acalibrated output level. The nominal input impedance is 50 or 600 ohms. The damage level is1 Vg and
10V pea- To activate signals applied to the | and Q input connectors, pressMux > 1/Q Source 1 or 1/Q Source 2 and

then select either Ext 50 Ohm or Ext 600 Ohm. On signal generators with Option 1EM, these connectors are located on
the rear panel.
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Figure 1-2 shows the various regions of the PSG display. This section describes each region.

Figure1-2 Front Panel Display Diagram
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1. Active Entry Area

The current active function is shown in this area. For example, if frequency isthe active function, the current frequency
setting will be displayed here. If the current active function has an increment value associated with it, that valueis also

displayed.

2. Frequency Area

The current frequency setting is shown in this portion of the display. Indicators are also displayed in this area when the
frequency offset or multiplier is used, the frequency reference modeis turned on, or a source module is enabled.

3. Annunciators

The display annunciators show the status of some of the signal generator functions and indicate any error conditions. An
annunciator position may be used by more than one function. This does not create a problem, because only one function
that shares an annunciator position can be active at atime.

oM This annunciator (Option UNT only) appears when phase modulation is on. If frequency
modulation is on, the FM annunciator replaces ®M.

ALC OFF This annunciator appears when the ALC circuit is disabled. A second annunciator, UNLEVEL,
appears in the same position if the ALC is enabled and cannot maintain the output level.

AM This annunciator (Option UNT only) appears when amplitude modulation is on.

ARMED This annunciator appears when a sweep has been initiated and the signal generator iswaiting for
the sweep trigger event.

ATTEN HOLD This annunciator (E8267D, E8257D, or EB663D with Option 1E1 only) appears when the
attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

DIG BUS This annunciator (Options 003/004 only) appears when the digital busis active, and the internal
oven reference oscillator is not cold (OVEN COLD appearsin this same location).

ENVLP This annunciator appears if aburst condition exists, such as when marker 2 is set to enable RF
blanking in the Dual ARB format.

ERR This annunciator appears when an error message isin the error queue. This annunciator does not
turn off until you either view all the error messages or cleared the error queue. To access error
messages, press Utility > Error Info.

EXT This annunciator appears when external leveling is on.

EXT1 LO/HI This annunciator (Options UNT, UNU, or UNW only or on the E8663D) appears as either EXT1
LOor EXT1 HI, when the ac-coupled signal to the EXT 1 INPUT is<0.97 Vor > 1.03V,,.

EXT2 LO/HI This annunciator (Options UNT, UNU, or UNW only or on the E8663D) is displayed as either
EXT2 LO Or EXT2 HI. Thisannunciator appears when the ac—coupled signal to the EXT 2
INPUT is<0.97 Vyor >1.03V,,

EXT REF This annunciator appears when an external frequency reference is applied.

FM This annunciator (Option UNT only) appears when frequency modulation is turned on. If phase
modulation is turned on, the ®M annunciator will replace FM.

I/Q This annunciator (E8267D only) appears when 1/Q modulation is turned on.

L This annunciator appears when the signal generator isin listener mode and is receiving
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information or commands over the RS-232, GPIB, or VXI-11 LAN interface.

This annunciator (E8267D and E8257D with Options UNT, UNU, or UNW only or on the
E8663D) indicates whether active modul ation formats have been enabled or disabled. Pressing the
Mod On/Off hardkey enables or disables al active modulation formats (AM, FM, ®M, Pulse, or
1/Q) that are applied to the output carrier signal available through the RF OUTPUT connector.
The Mod On/Off hardkey does not set up or activate an AM, FM, ®M, Pulse, or I/Q format; each
individual modulation format must still be set up and activated (for example, AM > AM On) or
nothing will be applied to the output carrier signal when the Mod On/Off hardkey is enabled.

This annunciator (Option UNR/UNX only) appears when the temperature of the internal oven
reference oscillator has dropped below an acceptable level. When this annunciator is on,
frequency accuracy is degraded. This condition should occur for several minutes after the signal
generator isfirst connected to line power.

This annunciator (Options UNU or UNW only or on the EB663D) appears when pul se modulation
ison.

This annunciator appears when the signal generator is remotely controlled over the GPIB,
RS-232, or VX1-11/Sockets LAN interface (TELNET operation does not activate the R
annunciator). When the R annunciator is on, the front panel keys are disabled, except for the
Local key and the line power switch. For information on remote operation, refer to the Keysight
PSG Sgnal Generators Programming Guide.

This annunciator indicates when the RF or microwave signal is present (RF ON) or not present
(RF OFF) at the RF OUTPUT. Either condition of this annunciator is always visible in the
display.

This annunciator appears when the signal generator has generated a service request (SRQ) over
the RS-232, GPIB, or VXI-11 LAN interface.

This annunciator appears when the signal generator isin list, step, or ramp sweep mode (ramp
sweep is available with Option 007 only). List mode is when the signal generator can jump from
point to point in alist (hop list); thelist istraversed in ascending or descending order. Thelist can
be afrequency list, a power level list, or both. Step mode is when a start, stop, and step value
(frequency or power level) are defined and the signal generator produces signals that start at the
start value and increment by the step value until it reaches the stop value. Ramp sweep mode
(Option 007 only) iswhen a start and stop value (frequency or power level) are defined and the
signal generator produces signalsthat start at the start value and produce a continuous output until
it reaches the stop value.

This annunciator appears when the signal generator isin talker mode and is transmitting
information over the GPIB, RS-232, or VXI-11 LAN interface.

This annunciator appears when the signal generator is unable to maintain the correct output level.
The UNLEVEL annunciator is not necessarily an indication of instrument failure. Unleveled
conditions can occur during normal operation. A second annunciator, ALC OFF, will appear inthe
same position when the AL C circuit is disabled.

This annunciator appears when any of the phase locked loops are unable to maintain phase lock.
You can determine which loop is unlocked by examining the error messages.

4. Digital Modulation Annunciators

All digital modulation annunciators (E8267D with Option 601/602 only) appear in this location. These annunciators
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appear only when the modulation is active, and only one digital modulation can be active at any given time.
ARB Dual Arbitrary Waveform Generator M-TONE Multitone Waveform Generator
CUSTOM Custom Real Time I/Q Baseband T-TONE Two-Tone Waveform Generator

DIGMOD Custom Arb Waveform Generator

5. Amplitude Area

The current output power level setting is shown in this portion of the display. Indicators are also displayed in thisarea
when amplitude offset is used, amplitude reference mode is turned on, external leveling mode is enabled, a source
module is enabled, and when user flatness is enabled.

6. Error Message Area

Abbreviated error messages are reported in this space. When multiple error messages occur, only the most recent
message remains displayed. Reported error messages with details can be viewed by pressing Utility > Error Info.

7. Text Area

Thistext area of the display:

« showssignal generator status information, such as the modulation status, sweep lists, and file catalogs

e displaysthetables

. ]STablesyou to perform functions such as managing information, entering information, and displaying or deleting
iles

8. Softkey Label Area

The labelsin this area define the function of the softkeys located immediately to the right of the label. The softkey label
may change depending upon the function selected.
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This section describes each item on the PSG rear panel. Four consecutive drawings show the standard and Option 1EM
rear panels for the E8267D, E8257D, and the E8663D. (Option 1EM moves all front panel connectors to the real panel.)

Figure1-3 Standard E8267D Rear Panel
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1. EVENT 1 11. WIDEBAND Q INPUTS

2. EVENT 2 12. COH CARRIER (Serial Prefixes
>=US4646/MY4646)

3. PATTERN TRIG IN 13. 1 GHz REF OUT (Serial Prefixes
>=US4646/MY4646)

4, BURST GATE IN 14. Q-bar OUT

5. AUXILIARY I/0 15. AC Power Receptacle

6. DIGITAL BUS 16. GPIB

7.Q OUT 17.10 MHz EFC

8.10UT 18. ALC HOLD (Serial Prefixes
>=US4722/MY4722)

9. WIDEBAND | INPUTS 19. AUXILIARY INTERFACE

10. I-bar OUT 20. 10 MHz IN

21.
22.

23.

24.
25.
26.
27.
28.

29.

30.

LAN
10 MHz OUT

STOP SWEEP IN/OUT

BASEBAND GEN CLK IN
Z-AXIS BLANK/MKRS
SWEEP OUT

TRIGGER OUT
TRIGGER IN

SOURCE SETTLED
SOURCE MODULE

INTERFACE
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Figure1-4 E8267D Option 1EM Rear Panel
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1. EVENT 1 16. GPIB 31. RF OUT

2. EVENT 2 17.10 MHz EFC 32. EXT 1

3. PATTERN TRIG IN 18. ALC HOLD (Serial Prefixes 33. EXT 2
>=US4722/MY4722)

4. BURST GATE IN 19. AUXILIARY INTERFACE 34. PULSE SYNC OUT

5. AUXILIARY 1I/0 20.10 MHz IN 35. PULSE VIDEO OUT

6. DIGITAL BUS 21. LAN 36. PULSE/TRIG GATE INPUT

7.Q OUT 22.10 MHz OUT 37. ALC INPUT

8.10UT 23. STOP SWEEP IN/OUT 38. DATA CLOCK

9. WIDEBAND | INPUTS 24. BASEBAND GEN CLK IN 39.1IN

10. I-bar OUT 25. Z-AXIS BLANK/MKRS 40. SYMBOL SYNC
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11. WIDEBAND Q INPUTS

12. COH CARRIER (Serial
Prefixes >=US4646/MY4646)

13. 1 GHz REF OUT (Serial
Prefixes >=US4646/MY4646)

14. Q-bar OUT
15. AC Power Receptacle

26. SWEEP OUT
27. TRIGGER OUT

28. TRIGGER IN

29. SOURCE SETTLED
30. SOURCE MODULE INTERFACE

Figure1-5 Sandard E8257D and E8663D Rear Panel
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42. DATA
41.QIN

43. LF OUT
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5. AUXILIARY 1/0 19. AUXILIARY INTERFACE

12. COH CARRIER (Serial 20. 10 MHz IN
Prefixes >=US4646/MY4646)
13. 1 GHz REF OUT (Serial 21. LAN

Prefixes >=US4646/MY4646)
15. AC Power Receptacle
16. GPIB

22.10 MHz OUT
23. STOP SWEEP IN/OUT

17.10 MHz EFC 25. Z-AXIS BLANK/MKRS
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26. SWEEP OUT
27. TRIGGER OUT

28. TRIGGER IN

29. SOURCE SETTLED

30. SOURCE MODULE
INTERFACE

44. Flash Drive (Serial Prefixes
>=US4829/SG4829/MY4829
(E8267D) and
>=US4928/SG4928/MY4928
(E8257D))
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Figure1-6 E8257D and E8663D Option 1EM Rear Panel
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SERIAL | ARE:
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13. 1 GHz REF OUT (Serial 22.10 MHz OUT 32.EXT 1
Prefixes >=US4646/MY4646)
15. AC Power Receptacle 23. STOP SWEEP IN/OUT 33.EXT 2
16. GPIB 25. Z-AXIS BLANK/MKRS 34. PULSE SYNC OUT
17.10 MHz EFC 26. SWEEP OUT 35. PULSE VIDEO OUT
19. AUXILIARY INTERFACE 27. TRIGGER OUT 36. PULSE/TRIG GATE INPUT
20. 10 MHz IN 28. TRIGGER IN 37. ALC INPUT
21. LAN 29. SOURCE SETTLED 43. LF OUT
31. RF OUT 44, Flash Drive (Serial Prefixes

>=US4829/SG4829/MY4829
(E8267D) and
>=US4928/5G4928/MY4928
(E8257D))
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1. EVENT 1

Thisfemale BNC connector is used with an internal baseband generator (Option 601/602). On signal generators without
Option 601/602, this female BNC connector is non—functional .

In real-time mode, the EVENT 1 connector outputs a pattern or frame synchronization pulse for triggering or gating
external equipment. It may be set to start at the beginning of a pattern, frame, or timeslot and is adjustable to within £
one timeslot with one bit resolution.

In arbitrary waveform mode, the EVENT 1 connector outputs atiming signal generated by Marker 1. A marker (3.3V
CMOS high for both positive and negative polarity) is output on the EVENT 1 connector whenever aMarker 1 isturned
on in the waveform.

The reverse damage levels for this connector are > +8 V and < —4 V. The nominal output impedance is not defined.

2. EVENT 2

Thisfemale BNC connector is used with an internal baseband generator (Option 601/602). On signal generators without
Option 601/602, this female BNC connector is non—functional.

In realtime mode, the EVENT 2 connector outputs a data enable signal for gating external equipment. Thisis applicable
when external datais clocked into internally generated timeslots. Data is enabled when the signal islow.

In arbitrary waveform mode, the EVENT 2 connector outputs atiming signal generated by Marker 2. A marker (3.3V
CMOS high for both positive and negative polarity) is output on the EVENT 2 connector whenever aMarker 2 isturned
on in the waveform.

The reverse damage levels for this connector are > +8 V and < —4 V. The nominal output impedance is not defined.

3.PATTERN TRIG IN

Thisfemale BNC connector is used with an internal baseband generator (Option 601/602). On signal generators without
Option 601/602, this female BNC connector is non—functional. This connector accepts asignal that triggers an internal
pattern or frame generator to start a single—pattern output. Minimum pulse width is 100 ns. Damage levelsare > +5.5V
and <-0.5V. The nominal input impedance is not defined.

4. BURST GATE IN

Thisfemale BNC connector is used with an internal baseband generator (Option 601/602). On signal generators without
Option 601/602, this connector is non—functional. This connector accepts a 3—volt CMOS input signal for gating burst
power. Burst gating is used when you are externally supplying data and clock information.

The input signal must be synchronized with the external datainput that will be output during the burst. The burst power
envelope and modulated data are internally delayed and re-synchronized. The input signal must be CMOS high for
normal burst RF power or CW RF output power and CMOS low for RF off. Damage levelsare>+55V and <-0.5 V.
The nominal input impedance is not defined.

5. AUXILIARY 1/O0

This female 37—pin connector is active only on instruments with an internal baseband generator (Option 601/602); on
signal generators without Option 601/602, this connector is non—functional. This connector provides access to the inputs
and outputs described in the following figure.
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Figure1-7 Auxiliary I/0 Connector (Female 37—Pin)

EVENT 3: Used with an internal baseband generator. In arbitrary waveform mode,

this pin outputs a timing signal generated by Marker 3. A marker (3.3 V CMOS

high for both positive and negative polarity) is output on this pin when a Marker 3 is
View looking into turned on in the waveform. Reverse damage levels: > +8 V and < -4 V.

rear panel connector

EVENT 4: Used with an internal baseband generator. In arbitrary
waveform mode, this pin outputs a timing signal generated by
Marker 4. A marker (3.3V CMOS high for both positive and
negative polarity) is output on this pin when a Marker 4 is turned
on in the waveform. Reverse damage levels: > +8 V and < -4 V.

O

2\
o a9 . .
GND — 370 F—EVENT 3 PATT TRIG IN 2: Accepts a signal that triggers an
O |—EVENT 4 / internal pattern or frame generator to start single
GND—| O Il T TRIGIN2 pattern output. Minimum pulse width: 100 ns.
GND —| © ° ALTPWR IN Damage levels: > +5.5 V and < -0.5 V.
| I PARALLEL DATA T
PARALLELDATA2*—| © ° = LLEL ! ALT PWR IN: Used with an internal baseband
PARALLEL DATA3* —| © O |—GND generator. This pin accepts a CMOS signal for
. O |—GND synchronization of external data and alternate power
PARALLELDATA4"—| © o |l—aenD signal timing. Damage levels are > +8 V and <-4 V.
PARALLEL DATAS*—| © o
PARALLEL DATAB*—| © o GND
PARALLELDATA7*— | © GND
GND o O ||— PARALLEL DATA8*
O || PARALLEL DATACLK*
GND—| © o |- ___————DATA OUT: Used with an internal baseband generator.
GND—| © DATAOUT This pin outputs data (CMOS) from the internal data
oD —| o O ||~ DATACLK OUT generator or the externally supplied signal at data input.
O |F—SYMSYNC OUT
GND—| ©
opeNn—| o © |[TOPEN DATA CLK OUT: Used with an internal baseband
oren—| o O |—GND generator. This pin relays a CMOS bit clock signal for
o |—GND synchronizing serial data.
—.0
OPEN | oPEN
SYM SYNC OUT: Used with an internal baseband

generator. This pin outputs the CMOS symbol clock for

*Future capability symbol synchronization, one data clock period wide.

of;

6. DIGITAL BUS

Thisisaproprietary bus used for Keysight Baseband Studio products, which require an E8267D with Options 003/004
and 601/602. This connector is not operational for general—purpose customer use. Signals are present only when a
Baseband Studio option isinstalled (for details, refer to http://mww.keysight.convfind/basebandstudio). The DIG BUS
annunciator appears on the display when the Digital Busis active (and the internal oven reference oscillator is not
cold—OVEN COLD appearsin this same location).
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7.Q OUT

This female BNC connector (E8267D only) is used with an internal baseband generator (Option 601/602) to output the
anal og, quadrature—phase component of 1/Q modulation. On signal generators without Option 601/602, thisfemale BNC
connector is used to output the quadrature—phase component of an external 1/Q modulation that has been fed into the

Q input connector. The nominal output impedance of the Q OUT connector is 50 ohms, dc—coupled.

8.1 0UT

This female BNC connector (E8267D only) is used with an internal baseband generator (Option 601/602) to output the
anal og, in—phase component of 1/Q modulation. On signal generators without Option 601/602, thisfemale BNC
connector is used to output the in—phase component of an external |/Q modulation that has been fed into the | input
connector. The nominal output impedance of the | OUT connector is 50 ohms, dc—coupl ed.

9. WIDEBAND | INPUTS

These female SMA connectors: | IN (+) and I-bar IN (-) (Option 016 only) are used with differential wideband external
1/Q inputs. They accept wideband AM and allow direct high—bandwidth analog inputs to the I/Q modulator in the
3.2-44 GHz range (frequency limit is dependant on the option). Thisinput is not calibrated. The recommended input
power level is—1 dBm with a+/— 1 VDC input voltage. The nominal impedance for this connector is 50 ohms.

The signal generator uses lowside mixing in the 20-28.5 GHz frequency range (Options 532 and 544), which reverses
the phase relationship for | and Q signals. For internally generated 1/Q signals the signal generator’s firmware
compensates for this. However, for wideband external 1/Q inputs (Option 016) there is no compensation and the | and Q
inputs at the rear panel must be reversed to maintain the correct phase relationships in this frequency band. Refer to the
Data Sheet and to the A37 Upconverter description in the Keysight PSG Sgnal Generators Service Guide for more
information.

For instruments with Option 015 (discontinued), single-ended wideband 1/Q, thereisasingle BNC | input. The
recommended power level at thisinput connector is 0 dBM.

10. |-bar OUT

This female BNC connector (E8267D only) is used with an internal baseband generator (Option 601/602) to output the
complement of the anal og, in—phase component of 1/Q modulation. On signal generators without Option 601/602, this
female BNC connector is used to output the complement of the in—phase component of an external 1/Q modulation that
has been fed into the | input connector.

I-bar OUT is used in conjunction with | OUT to provide a balanced baseband stimulus. Balanced signals are signals
present in two separate conductors that are symmetrical relative to ground and are opposite in polarity (180 degrees out
of phase). The nominal output impedance of the I-bar OUT connector is 50 ohms, dc—coupled.

11. WIDEBAND Q INPUTS

These female SMA connectors: Q IN (+) and Q-bar IN (-) (Option 016 only) are used with differential wideband
external 1/Q inputs. They accept wideband AM and allow direct high—bandwidth analog inputs to the 1/Q modulator in
the 3.2-44 GHz range (frequency limit is dependant on the option). Thisinput is not calibrated. The recommended input
power level is—1 dBm with a+/— 1 VDC input voltage. The nomina impedance for this connector is 50 ohms.

The signal generator uses lowside mixing in the 20-28.5 GHz frequency range (Options 532 and 544), which reverses
the phase relationship for | and Q signals. For internally generated 1/Q signals the signal generator’s firmware
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compensates for this. However, for wideband external 1/Q inputs (Option 016) there is no compensation and the | and Q
inputs at the rear panel must be reversed to maintain the correct phase relationships in this frequency band. Refer to the
Data Sheet and to the A37 Upconverter description in the Keysight PSG Sgnal Generators Service Guide for more
information.

For instruments with Option 015 (discontinued), single-ended wideband 1/Q, thereisasingle BNC Q input. The
recommended power level at thisinput connector is 0 dBM.

12. COH CARRIER (Serial Prefixes >=US4646/M Y 4646)

Thisfemale SMA connector (Option UNT only) outputs an RF signal that is phase coherent with the signal generator
carrier. The coherent carrier connector outputs RF that is not modulated with AM, pulse, or 1/Q modulation, but is
modulated with FM or ®M (when FM or ®M are on).

The output power is nominally 0 dBm. The output frequency range is from 249.99900001 MHz to 3.2 GHz; this output
isnot useful for output frequencies > 3.2 GHz. If the RF output frequency is below 249.99900001 MHz, the coherent
carrier output signal will have the following frequency:

Frequency of coherent carrier = (1E9 — Frequency of RF output) in Hz.

Damage levels are 20 VVdc and 13 dBm reverse RF power. The nominal output impedance of this connector is 50 ohms.

13. 1 GHz REF OUT (Serial Prefixes >=US4646/M Y 4646)

Thisfemale SMA connector (Option UNX only) provides a 1 GHz output that is 100 times the frequency of the internal
or external 10 MHz reference. The nominal output level is7 dBM. The nominal output impedance is 50 ohms. When not
in use, this connector must be terminated with a 50 ohm load.

14. Q-bar OUT

Thisfemale BNC connector (E8267D only) can be used with an internal baseband generator (Option 601/602) to output
the complement of the analog, quadrature—phase component of 1/Q modulation. On signal generators without Option
601/602, this female BNC connector can be used to output the complement of the quadrature—phase component of an
external 1/Q modulation that has been fed into the Q input connector.

Q-bar OUT isused in conjunction with Q OUT to provide a balanced baseband stimulus. Balanced signals are signals
present in two separate conductors that are symmetrical relative to ground and are opposite in polarity (180 degrees out
of phase). The nomina output impedance of the Q—bar OUT connector is 50 ohms, dc—coupled.

15. AC Power Receptacle

The ac line voltage is connected here. The power cord receptacle accepts a three—pronged power cable that is shipped
with the signal generator.

CAUTION  Always use the three-prong AC power cord supplied with this product. Failure to ensure adequate earth
grounding by not using this cord can cause product damage.

Thisinstrument has auto-ranging line voltage input; be sure the supply voltage is within the specified
range and voltage fluctuations do not to exceed 10 percent of the nominal supply voltage:

E8257D: 100/120 VAC 50/60/400 Hz, 220/240, VAC 50/60 Hz, < 250 W typical, 450 W maximum
E8267D: 100/120 VAC 50/60/400 Hz; or 220/240 VAC 50/60 Hz, (automatically selected); < 400 W

28 Keysight PSG Signal Generators User’s Guide



Signal Generator Overview
Rear Panel

typical, 650 W maximum

E8663D: 100/120 VVAC 50/60/400 Hz; or 220/240 VAC 50/60 Hz, (automatically selected); < 250 W
typical, 450 W maximum

16. GPIB
This GPIB interface allows listen and talk capability with compatible |EEE 488.2 devices.

17.10MHz EFC

Thisfemale BNC input connector (Options UNR/UNX only) accepts an external dc voltage, ranging from-5V to+5V,
for electronic frequency control (EFC) of the internal 10 MHz reference oscillator. This voltage inversely tunes the
oscillator about its center frequency (approximately —0.0025 ppm/V). The nominal input impedance is greater than
1 Mohms. When not in use, this connector should be shorted using the supplied shorting cap to assure a stable operating

frequency.

18. ALC HOLD (Serial Prefixes >=USA722/M Y 4722)

Thisfemale BNC connector (E8267D only) isaTTL—compatible input that controls AL C action with bursted I/Q signals
from an arbitrary waveform generator (AWG). A high signal alowsthe ALC to track the RF signal and maintain
constant RF output level asthe I/Q inputsvary. A low input signal allowsthe ALC to be held for abrief time (lessthan 1
second) and not track the RF signal. When driving the external 1/Q inputs from an external arbitrary waveform generator
supplying a bursted waveform, the ALC Hold line should be driven from a marker output from the AWG that is high
when the bursted signal is at the proper level and low when the bursted signal is hot at the proper level Damage levelsare
>55Vand<-05V.
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19. AUXILIARY INTERFACE

This 9—in D—subminiature female connector is an RS-232 serial port that can be used for serial communication and
M aster—Slave source synchronization.

Table 1-3 Auxiliary Interface Connector

Pin Number Signal Description Signal Name
1 No Connection (default operation)/
Retrace (Master—Slave operation)
2 Receive Data RECV
3 Transmit Data XMIT
4 +5V (Default operation)/
Sweep Stop (Master—Slave operation)
5 Ground, OV
6 No Connection
7 Reguest to Send RTS
8 Clear to Send CTS
9 No Connection

Figure1-8

S5e 40 30 20 1o View looking into
O¢ 8o 7o 6o rear panel connector

20.10MHzIN

This female BNC connector accepts an external timebase reference input signal level of > -3 dBm. The reference must
bel, 2, 25,5, or 10 MHz, within +1 ppm. The signal generator detects when avalid reference signal is present at this
connector and automatically switches from internal to external reference operation.

For Option UNR/UNX or instruments with serial prefixes > US4805/MY 4805, this BNC connector accepts asignal with
anominal input level of 515 dBm. The external frequency reference must be 10 MHz, within £1 ppm.

The nominal input impedance is 50 ohms with a damage level of > 10 dBm.

21. LAN

ThisLAN interface allows ethernet local area network communication through a 10Base-T LAN cable. The yellow
LED on the interface illuminates when data transmission (transfer/receive) is present. The green LED illuminates when
thereisadelay in data transmission or no data transmission is present.
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22. 10MHz OUT

This female BNC connector outputs a nominal signal level of > +4 dBm and has an output impedance of 50 ohms. The
accuracy is determined by the timebase used.

23. STOP SWEEP IN/OUT

This female BNC connector (Option 007 only) provides an open—collector, TTL—compatible input/output signal that is
used during ramp sweep operation. It provides low—level (nominaly 0 V) output during sweep retrace and band—cross
intervals. It provides high-evel (nominaly +5 V) output during the forward portion of the sweep. Sweep stops when
this input/output connector is grounded externally. When operating as an input, the nominal impedance for this
connector is less than 10 ohms. When operating as an output, the nominal impedance is approximately 4.2 kohms.

24. BASEBAND GEN CLK IN

Thisfemale BNC connector accepts a sine or square wave PECL clock input with a frequency range of 200 MHz to
400 MHz, resulting in sample rates of 50 M Sa/sto 100 M Sa/s. The recommended input level is approximately 1

V peak—to—peak for a square wave and 1 dBm to 6 dBm for asine wave. This allows baseband generators from multiple
signal sources to run off the same clock.

25. Z-AXISBLANK/MKRS

Thisfemale BNC connector (Option 007 only) suppliesa+5 V (nominal) level during retrace and band—switch intervals
of astep, list, or ramp sweep. During ramp sweep, this female BNC connector suppliesa-5V (nominal) level when the
RF frequency is at a marker frequency and intensity marker modeis on. Thissignal is derived from an operational
amplifier output so the load impedance should be greater than or equal to 5 kohms. This connection is most commonly
used to interface with an Keysight 8757D Scalar Network Analyzer.

26. SWEEP OUT

Thisfemale BNC connector outputs a voltage proportional to the RF power or frequency sweep ranging from 0V at the
start of sweep and goesto +10 V (nominal) at the end of sweep, regardiess of sweep width.

The nominal output impedanceisless than 1 ohm and can drive a2 kohm load.

When connected to an Keysight Technologies 8757D network analyzer, it generates a sel ectable number of equally
spaced 1 ms, 10 V pulses (nominal) across aramp (analog) sweep. The number of pulses can be set from 101 to 1601 by
remote control through the 8757D.

27. TRIGGER OUT

Thisfemale BNC connector, in step/list sweep mode, outputsa TTL signal that is high at the start of adwell sequence or
when waiting for a point trigger in manual sweep mode. The signal islow when the dwell is over or when a point trigger
isreceived. In ramp sweep mode, the output provides 1601 equally spaced 1 s pulses (nominal) across aramp sweep.
When using LF Out, the output provides a 2 us pulse at the start of an LF sweep. The nominal impedance for this
connector islessthan 10 ohms.

28. TRIGGER IN

This female BNC connector accepts a 3.3V CMOS signal, which is used for point—to—point triggering in manual sweep
mode, or in alow frequency (LF output) or analog (AM, FM, and ®M) external sweep trigger setup. Triggering can
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occur on either the positive or negative edge of the signa start. The damage level is< -4V or > +10 V. The nominal
input impedance for this connector is approximately 4.2 kohms.

29. SOURCE SETTLED

This female BNC connector provides a 3—volt CMOS output trigger, indicating when the signal generator has settled to
anew frequency or power level. A high indicates that the source has not settled. A low indicates that the source has
settled. The nominal output impedance for this connector is less than 10 ohms.

30. SOURCE MODULE INTERFACE

Thisinterface is used to connect to compatible Keysight Technologies 83550 Series mm-—wave source modules.

Figure 1-9 Interface Signals of the Source M odule Connector

MOD €1 +EV RESERVED  MOD ANLG GND
ANGL GND
MOD D2 MOD CO | +8V +18V [ RESERVED /° CLAMP CNTL  RET (SHELL)

\_\‘_\‘

MCD D3 MOD DO RESERVED (EXT LVL RET % L MOD RF OFF 0.5V/GHz  MOD SENSE

RESERVED

MOD D1 DIG GND  EXT LWL (COAX) —15v

The codes indicated on the illustration above trand ate as follows.

Mod DO Source module dataline zero. Signals MOD DO through MOD D3 are the mm source module data
bus lines (bi-directional).

MOD D1 Dataline one.

MOD D2 Dataline two.

MOD D3 Datalinethree.

MOD C1 Source module control line zero. Signals MOD CO and MOD C1 are the control lines for the
read/write to and from the mm source module.

MOD C1 Control line one.

CLAMP CNTL Source module clamp control (not used).

MOD SENSE Source module sense. A 1 mA current isinjected on this line by the mm source module to indicate
its presence. Thissignal always equals OV.

L MOD RF OFF Low = RF off. Source module RF is turned off.

EXT LVL RET Source module external leveling return.

EXT LVL Source module external leveling input, from the mm source module.
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0.5V/GHz Internal 0.5 V/GHz to the mm source module.
-15v Power Supply. Range is—14.25 to —15.90V.
+15V Power Supply. Rangeis +14.25 to +16.40V.
+8V Power Supply. Rangeis+7.75 to +8.25V.
+5V Power Supply. Rangeis +4.75 to +5.45V.
DIG GND Digital ground.

MOD ANLG GND  Source module analog ground.
ANLG GND RET  Analog ground return.

31. RF OUT

This connector outputs RF and microwave signals. The nominal output impedance is 50 ohms. The reverse power
damage levels are 0 Vdc, 0.5 watts nominal. On signal generators without Option 1EM, this connector is located on the
front panel. The connector type varies according to frequency option.

32.EXT1

This female BNC input connector (functional only with Options UNT, UNU, or UNW) acceptsa+1 V; signal for AM,
FM, and @M. For these modulations, £1 V, produces the indicated deviation or depth. When ac—coupled inputs are
selected for AM, FM, or @M and the peak input voltage differs from 1V, by more than 3 percent, the HI/LO display
annunciators light. The input impedance is selectable as either 50 or 600 ohms; the damage levelsare 5 Vg and 10 V..
On signal generators without Option 1EM, this connector is located on the front panel.

33.EXT 2

This female BNC input connector (functional only with Options UNT, UNU, or UNW) acceptsa+1 V|, signal for AM,
FM, and ®M. With AM, FM, or ®M, +1 Vp produces the indicated deviation or depth. When ac—coupled inputs are
selected for AM, FM, or @M and the peak input voltage differs from 1V, by more than 3 percent, the HI/LO

annunciators light on the display. The input impedance is selectable as either 50 or 600 ohms and damage levels are
5Vimsand 10 V.. On signal generators without Option 1EM, this connector is located on the front panel.
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34. PULSE SYNC OUT

This female BNC output connector (functional only with Options UNU or UNW) outputs a synchronizing
TTL—compatible pulse signal that is nominally 50 ns wide during internal and triggered pulse modulation. The nominal
source impedance is 50 ohms. On signal generators without Option 1EM, this connector is located on the front panel.

35. PULSE VIDEO OUT

Thisfemale BNC output connector (functional only with Options UNU or UNW) outputsa TTL—-evel compatible pulse
signal that follows the output envelope in al pulse modes. The nominal source impedance is 50 ohms. On signal
generators without Option 1EM, this connector is located on the front rear panel.

36. PULSE/TRIG GATE INPUT

This female BNC input connector (functional only with Options UNU or UNW) accepts an externally supplied pulse
signal for use asa pulse or trigger input. With pulse modulation, +1 V ison and 0 V is off (trigger threshold of 0.5 V with
ahysteresis of 10 percent; so 0.6 V would be on and 0.4 V would be off). The damagelevelsare+5 V,,sand 10 V.. The
nominal input impedance is 50 ohms. On signal generators without Option 1EM, this connector islocated on the front
panel.

37.ALC INPUT

Thisfemale BNC input connector is used for negative external detector leveling. This connector accepts an input of —0.2
mV to —0.5V. The nominal input impedance is 120 kohms and the damage level is+15 V. On signal generators without
Option 1EM, this connector islocated on the front panel.

38. DATA CLOCK

This female BNC input connector (E8267D only) is CMOS compatible and accepts an externally supplied data clock
input signal to synchronize serial datafor use with the internal baseband generator (Option 601/602). The expected input
isa3.3V CMOS hit clock signal (which isalso TTL compatible) where the rising edge is aligned with the beginning
data bit. The falling edge is used to clock the DATA and SYMBOL SYNC signals. The maximum clock rateis 50 MHz.
The damage levelsare > +5.5 V and < —0.5V. The nominal input impedanceis not defined. On signal generators without
Option 1EM, this connector located on the front panel.

39.1'IN

Thisfemale BNC input connector (E8267D only) accepts the in—phase (1) component an externally supplied, analog, I/Q
modulation. The quadrature—phase (Q) component is supplied through the Q IN connector. The signal level is /12 +Q
0.5V s for acalibrated output level. The nominal input impedance is 50 or 600 ohms. The damage level is1 Vs and
10V pegk- To activate signals applied to the | and Q input connectors, pressMux > 1/Q Source 1 or 1/Q Source 2 and

then select either Ext 50 Ohm or Ext 600 Ohm. On signal generators without Option 1EM, this connector islocated on
the front panel.

40. SYMBOL SYNC

This female BNC input connector (E8267D only) is CMOS—compatible and accepts an externally supplied symbol
synchronization signal for use with the internal baseband generator (Option 601/602). The expected input isa3.3V
CMOS bit clock signal (whichisaso TTL compeatible). SYMBOL SYNC might occur once per symbol or be asingle
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one-hit—wide pulse that is used to synchronize the first bit of the first symbol. The maximum clock rateis 50 MHz. The
damage levelsare > +5.5 V and < —0.5V. The nominal input impedance is not defined. SYMBOL SYNC can be used in
two modes:

e When used as a symbol synchronization in conjunction with a data clock, the signal must be high during the first
data bit of the symbol. The signal must be valid during the falling edge of the data clock signal and may be asingle
pulse or continuous.

*«  Whenthe SYMBOL SYNC itself isused asthe (symbol) clock, the CMOS falling edge is used to clock the DATA
signal.
On signal generators without Option 1EM, this connector is located on the front panel.

41.QIN

This female BNC input connector (E8267D only) accepts the quadrature—phase (Q) component an externally supplied,
analog, 1/Q modulation. The in—phase (1) component is supplied through the | IN connector. The signal level is 2 +Q

= 0.5V, ysfor acalibrated output level. The nominal input impedanceis 50 or 600 ohms. The damagelevel is1V s and
10V peg- To activate signal's applied to the | and Q input connectors, pressMux > 1/Q Source 1 or 1/Q Source 2 and
then select either Ext 50 Ohm or Ext 600 Ohm. On signal generators without Option 1EM, this connector islocated on
the front panel.

42. DATA

Thisfemale BNC input connector (Option 601/602 only) is CMOS compatible and accepts an externally supplied serial
data input for digital modulation applications. The expected input isa3.3V CMOS signal (whichisaso TTL
compatible) whereaCMOS high = adata1 and aCMOS low = a data 0. The maximum input data rate is 50 Mb/s. The
data must be valid on the falling edges of the data clock (normal mode) or on the falling edges of the symbol
synchronization (symbol mode). The damage levels are > +5.5 and < —0.5V. The nominal input impedance is not
defined. On signal generators without Option 1EM, this connector is located on the front panel.

43.LF OUT

Thisfemale BNC output connector (functiona only with Option UNT) outputs modulation signals generated by the low
frequency (LF) source function generator. This output is capable of driving 3V, (nominal) into a50-ohm load. On signal

generators without Option 1EM, this connector is located on the front panel.
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44. Flash Drive (Serial Prefixes >=US4829/SG4829/M Y 4829 (E8267D) and
>=U$S4928/SG4928/M Y 4928 (E8257D))

The removable compact flash driveis not hot swappable— always turn the power off to theinstrument when removing or
inserting the memory. Use only Keysight provided or certified compact flash cards.

This flash drive (Options 008 and 009 only) outputs data to a removable flash card. The 8 GB memory capacity easily
stores user datafiles; including flatness calibrations, 1Q calibration, instrument states, waveforms (including header and
marker data), modulation definitions, and sweep lists. Refer to Table 2-5, “Flash Drive Memory (Options 008 and
009),” on page 67.
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2 Basic Operation

In the following sections, this chapter describes operations common to all Keysight PSG signal generators:
e “Using Table Editors” on page 38

e “Using the User-Defined RF Output Power Limit (Option 1EU, or 521 only)” on page 40
e “Configuring a Continuous Wave RF Output” on page 42

* “Configuring a Swept RF Output” on page 45

« “Using Ramp Sweep (Option 007)” on page 49

» “Extending the Frequency Range” on page 58

e “Turning On a Modulation Format” on page 58

*  “Applying a Modulation Format to the RF Output” on page 59

e “Using Data Storage Functions” on page 59

* “Using the Instrument State Registers” on page 61

e “Using Security Functions” on page 63

* “Enabling Options” on page 71

e “Using the Web Server” on page 72

KEYSIGHT

TECHNOLOGIES
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Using Table Editors

Table editors simplify configuration tasks, such as creating alist sweep. This section providesinformation to familiarize
you with basic table editor functionality using the List Mode Values table editor as an example.

Press Preset > Sweep/List > Configure List Sweep.
The signal generator displaysthe List Mode Values table editor, as shown below.

Figure2-1
Active Function Area Cursor
\
FREQUENCY AMPLITU .
Edit It
20.000 000 000 000 s+ ‘ -135.00 den s
’7 @ Insert Row
Delete Rou
List Mode Ualues
Frequency Duell
] 1 ms Goto RoW
2 ms
m=
e Insert Item
3 ms
6 ms
7 .00000000
8 £90.00000000 e Delste Item
9 575.00000000 s
L1/ 10 £87.50000000 ms Hare
7 (1 of 2)
Table Name Table Items Table Softkeys
Active Function Area displaysthe active table item while its value is edited
Cursor an inverse video identifier used to highlight specific table items for
selection and editing
Table Softkeys select table items, preset table values, and modify table structures
Table Items values arranged in numbered rows and titled columns (The columns are

also known as data fields. For example, the column below the Frequency
title is known as the Frequency data field).
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Table Editor Softkeys
The following table editor softkeys are used to load, navigate, modify, and store table item values.

Edit Item

Insert Row
Delete Row
Goto Row

Insert Item
Delete ltem

Page Up and
Page Down

More (1 of 2)
Load/Sore

displays the selected item in the active function area of the display where the item’s value can be
modified

inserts an identical row of table items above the currently selected row
deletes the currently selected row

opens amenu of softkeys (Enter, Goto Top Row, Goto Middle Row, Goto Bottom Row, Page
Up, and Page Down) used to quickly navigate through the table items

inserts an identical item in anew row below the currently selected item
deletes the currently selected item

displays table items that occupy rows outside the limits of the ten—row table display area
accesses L oad/Store and its associated softkeys

opens amenu of softkeys (Load From Selected File, Sore To File, Delete File, Goto Row,
Page Up, and Page Down) used to load table items from afile in the memory catalog, or to store
the current table items as a file in the memory catalog

Moaodifying Table Itemsin the Data Fields

1. If not aready displayed, open the List Mode Values table editor (Figure 2-1 on page 38):
Press Preset > Sweep/List > Configure List Sweep

2. Usethearrow keys or the knob to move the table cursor over the desired item.
In Figure 2-1, the first item in the Frequency datafield is selected.

3. PressEdit Item.

The selected item is displayed in the active function area of the display.

Use the knob, arrow keys, or the numeric keypad to modify the value.

5. PressEnter.

The modified item is now displayed in the table.
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Using the User-Defined RF Output Power Limit (Option 1EU, or 521 only)

Selecting a User-Defined RF Output Power Limit

To protect external components and instruments against damage the PSG has a user-defined RF output limit (see
Figure 2-2). Thefactory default value of the RF output limit is set to 25 dBm and the RF adjusting limit value softkey is
not available (see Figure 2-2). Presetting the instrument, resets the value to 25 dBm and disables any user-defined RF
adjusting limit values (i.e. the user-defined RF output limit values are not persistent).

If apersistent RF output limit is required, a user-defined setup is recommended. Use the “ Save User Preset” softkey
under the Utility > Power On/Preset softkey menu or use the save instrument state register softkeys (Refer to “Using
the Instrument State Registers” on page 61).

NOTE Ininterna leveling mode, when the set amplitude is within +1 dBm of the RF output limit's value, the RF
output limit is printed in bold text in the Frequency and Amplitude status information display. When the user
attempts to set an amplitude that exceeds the RF Output Power Limit, the amplitude will be restricted and the
following error message is displayed: “value clipped to maximum user defined RF Output
Limit”.

Ininternal leveling mode, if the RF output limit is exceeded, awarning message is displayed that reads
“UNLEVEL". When this message is displayed, the RF output is maximized out at the specified RF output limit
and the connected devices are protected.

The RF output limit can be used with an external AL C detector connected to the PSG. When the instrument is
in external leveling mode, no indications or warnings are displayed, but the power isrestricted if it exceedsthe
+1 dBm limits.
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Figure 2-2 User-Defined RF Output Limit Softkey Menu
Amplitude> More>

¢
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SCPI Commands:
To enable changing the RF output limit:

SCPI Command: [:SOURce] : POWer : LIMit [ :MAX] : ADJust <ON|OFF|1|0>
SCPI Command: [: SOURce] : POWer :LIMit [:MAX] : ADJust?

To change the RF output limit:

SCPI Command: [:SOURce] : POWer : LIMit [ :MAX] <ampl>

SCPI Command: [:SOURce] : POWer : LIMit [ :MAX]?

The following example enables the RF Output power limit and changes the value to 20 dBm.
1. To changethe RF output limit value:

Press Amplitude > More> More > RF Output Limit Lock Adjust to Adjust.
2. To change the RF output limit value:

Press RF Output Limit > 20 dBm

By default, the RPG and increment/decrement controls are disabled to avoid accidental changing of the RF output
limit. Press the | eft/right cursor hardkeys to select a digit and enable the RPG or use the keypad to enter the dBm.
The minimum settable value is 15 dBm. The maximum settable value is the unleveled power of the instrument. For
settings accuracy, refer to the Data Sheet.

3. To prevent accidently changing the RF Output Limit level:
Press RF Output Limit Lock Adjust to Lock.
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Configuring the RF Output

This section provides information on how to create continuous wave and swept RF (page 45) outputs. It also has
information on using a mm—\Wave source module to extend the signal generator’s frequency range (page 58).

Configuring a Continuous Wave RF Output

These procedures demonstrate how to set the following parameters:

setting the RF output frequency (page 42)

setting the frequency reference and frequency offset (page 43)
setting the low pass filter (Options 1EH and 521) (page 44)
setting the RF output amplitude (page 44)

setting the amplitude reference and amplitude offset (page 44)
setting the optimize signal to noiseratio (page 45)

Setting the RF Output Frequency
Set the RF output frequency to 700 MHz, and increment or decrement the output frequency in 1 MHz steps.
1. Returnthesignal generator to the factory—defined state: Press Preset.

NOTE You can change the preset condition of the signal generator to a user—defined state. For these examples,
however, use the factory—defined preset state (set the Preset Normal User softkey in the Utility menu to
Normal).

2. Observe the FREQUENCY area of the display (in the upper left—hand corner).
The value displayed is the maximum specified frequency of the signal generator.
3. Press RF On/Off.

The RF On/Off hardkey must be pressed before the RF signal is available at the
RF OUTPUT connector. The display annunciator changes from RF OFF to RF ON. The maximum specified
frequency should be output at the RF OUTPUT connector (at the signal generator’s minimum power level).

4. PressFrequency > 700> MHz.

The 700 MHz RF frequency should be displayed in the FREQUENCY area of the display and aso in the active entry
area.

5. PressFrequency > Incr Set > 1> MHz
This changes the frequency increment valueto 1 MHz.
6. Presstheup arrow key.

Each press of the up arrow key increases the frequency by the increment value last set with the Incr Set hardkey.
The increment value is displayed in the active entry area.
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7. Thedown arrow decreases the frequency by the increment value set in the previous step. Practice stepping the

8.

frequency up and downin 1 MHz increments.

You can also adjust the RF output frequency using the knob. Aslong as frequency is the active function (the
frequency is displayed in the active entry ared), the knob will increase and decrease the RF output frequency.

Use the knob to adjust the frequency back to 700 MHz.

Setting the Frequency Reference and Frequency Offset

The following procedure sets the RF output frequency as a reference frequency to which all other frequency settings are
relative. When the frequency referenceis set, the display will read 0. 00 Hz (the frequency output of the signal
generator’s hardware minus the reference frequency). Although the display changes, the actual frequency output is

700 MHz (from step 8 above). Any subsequent frequency changes are shown as increments or decrementsto the 0 Hz
reference.

The Frequency Reference Set function is not an active function. Onceit is set, any change to the frequency setting
appears as a frequency reading on the signal generator’s front panel display. For example,

1
2.

Preset the signal generator: Press Preset.

Set the frequency reference to 700 MHz:
Press: Frequency > 700 > MHz > More (1 of 3) > Freq Ref Set.

This activates the frequency reference mode, sets the output frequency (700 MHz) as the reference value, and
togglesthe Freg Ref softkey On. The FREQUENCY areadisplays 0.000 Hz. Thisreading isthe frequency output of
the signal generator’s hardware (700 MHz) minus the reference value (700 MHz). The signal generator’strue output
frequency is 700 MHz. If the Freq Ref softkey istoggled to Off, the front panel will indicate the actual frequency:
700 MHz. The REF indicator appears on the front panel display and the Freq Ref Off On softkey togglesto On.

Turn on the RF output: Press RF On/Off.

The display annunciator changes from RF OFF to RF ON. The RF frequency at the RF OUTPUT connector is
700 MHz.

Set the frequency increment value to 1 MHz: Press Frequency > Incr Set > 1> MHz.
Increment the output frequency by 1 MHz: Press the up arrow key.

The FREQUENCY area display changes to show 1.000 000 000 MHz, which is the frequency output by the hardware
(700 MHz + 1 MHz) minus the reference frequency (700 MHz). The frequency at the RF OUTPUT changes to
701 MHz.

Enter a1 MHz offset: PressMore (1 of 3) > Freq Offset >1>MHz.

The FREQUENCY areadisplays2.000 000 00 MHz, whichisthe frequency output by the hardware (701 MHz)
minus the reference frequency (700 MHz) plus the offset (1 MHZ). The OFFS indicator activates. The frequency at
the RF OUTPUT connector is still 701 MHz.
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Setting the Low Pass Filter (Options 1EH and 521)

CAUTION  Option 1EH can degrade power below 2 GHz. Use Option 1EH when improved harmonics are desired
but a degradation of power below 2 GHz is acceptable. Refer to the Data Sheet for details.

Options 1EH and 521 improves the harmonic distortion performance for carrier frequencies ranging from 10 MHz to 2
GHz. Refer to the Data Sheet for specifications on these options.

1. PressPreset.
Default Off
2. PressFrequency >More> More.
3. PressLow PassFilter below 2 GHz to On.

Setting the RF Output Amplitude
1. Preset the signal generator: Press Preset.

The AMPLITUDE area of the display shows the minimum power level of the signal generator. Thisis the normal
preset RF output amplitude.

2. Turnon the RF output: Press RF On/Off.
The display annunciator changesto RF ON. At the RF OUTPUT connector, the RF signal is output at the minimum
power level.

3. Change the amplitude to —20 dBm: Press Amplitude > -20 > dBm.

The new output power displaysin the AMPLITUDE area of the display and in the active entry area. Until you pressa
different front panel function key, amplitude remains the active function. You can also change the amplitude using
the up and down arrow keys or the knob.

Setting the Amplitude Reference and Amplitude Offset

The following procedure sets the RF output power as an amplitude reference to which al other amplitude parameters are
relative. The amplitude initially shown on the display is 0 dB (the power output by the hardware minus the reference
power). Although the display changes, the output power does not change. Any subsequent power changes are shown as
incremental or decremental to O dB.

Press Preset.
Set the amplitude to —20 dBm: Press Amplitude > —-20 > dBm.

Activate the amplitude reference mode and set the current output power (—20 dBm) as the reference value: Press
More (1 of 2) > Ampl Ref Set.

The AMPLITUDE areadisplays 0.00 dB, which isthe power output by the hardware (—20 dBm) minus the
reference value (—20 dBm). The REF indicator activates and the Ampl Ref Off On softkey toggles On.

4. Turn the RF output on: Press RF On/Off.
The display annunciator changesto RF ON. The power at the RF OUTPUT connector is—20 dBm.

Change the amplitude increment value to 10 dB: PressIncr Set > 10 > dB.
Use the up arrow key to increase the output power by 10 dB.

The AMPLITUDE areadisplays 10.00 dB, which isthe power output by the hardware (—20 dBm plus 10 dBm)
minus the reference power (—20 dBm). The power at the RF OUTPUT connector changesto —10 dBm.
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7. Enter a10 dB offset: Press Ampl Offset > 10 > dB.

The AMPLITUDE areadisplays 20.00 dB, which isthe power output by the hardware (-10 dBm) minus the
reference power (—20 dBm) plus the offset (10 dB). The OFFS indicator activates. The power at the RF OUTPUT
connector is still —10 dBm.

Setting the Optimize Signal to Noise Ratio

Enabling this softkey On optimizes the attenuator and AL C setting to provide optimal signal—to—noise performance; it
does not change the RF output power.

NOTE Thismodeis mutualy exclusive with attenuator hold (Atten Hold), and any modulation type. A settings
conflict error will be generated if attentuator hold or any modulation is activated when optimize
signal-to—noiseis active (On).

1. PressPreset.
Default Off
Press Amplitude > More > More > Optimize SN Off On.
Press Optimize S/N to On.

Configuring a Swept RF Output

A PSG signal generator has up to three sweep types: step sweep, list sweep, and ramp sweep. Ramp sweep is available
with Option 007.

The signal generator indicates the sweep advancein aprogress bar on the front panel display. If the sweep timeis greater
than one second, the progress bar sweep advances according to the frequency span of each segment. For each segment in
the span, the progress bar displays the full segment and then the sweep is taken. With sweep times less than one second,
the progress bar is drawn, the sweep taken, and the progress bar is then blanked.

NOTE List sweep data cannot be saved within an instrument state, but can be saved to the memory catalog. For
instructions on saving list sweep data, see “Storing Files to the Memory Catalog” on page 60.

During swept RF output, the FREQUENCY and AMPLITUDE areas of the signal generator’s display are
deactivated, depending on what is being swept.

Step sweep (see page 46) and ramp sweep (see page 47) provide alinear progression through the start—to-stop
frequency and/or amplitude values, while list sweep enables you to create alist of arbitrary frequency, amplitude, and
dwell time values and sweep the RF output based on that list.

The list sweep example uses the points created in the step sweep example as the basis for anew list sweep.

Ramp sweep (see page 49) is faster than step or list sweep, and is designed to work with an 8757D Scalar Network
Analyzer.

The signal generator provides a softkey, Sweep Retrace Off On, that lets you configure single sweep behavior. When
sweep retrace is on, the signal generator will retrace the sweep to the first point of the sweep. If the sweep retrace is off,
the sweep will stop and remain on the last point in the sweep.

Activating Scalar Pulsein Sweep Configurations
If your sweep setup uses a scalar network analyzer and an AC detector, the PSG must modul ate the swept signal with a
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27 kHz sguare wave, also referred to as a scalar pulse. This pulse modulation is necessary for the AC detector to
properly detect the swept signal. If the PSG is controlled by an 8757D through a GPIB connection, the scalar pulse
automatically turns on when AC detection is selected on the 8757D. When using any other scalar analyzer, you can
manually turn on the scalar pulse using either one of the following key—press sequences:

Press Sweep > Configure Ramp/Step Sweep > More > Scalar Pulse Off On to On
or
Press Pulse > Pulse Source > Scalar > Pulse Off On to On

Using Step Sweep
Step sweep provides alinear progression through the start—to—stop frequency and/or amplitude values. You can toggle
the direction of the sweep, up or down. When the Sweep Direction Down Up softkey is set to Up, values are swept from

the start amplitude/frequency to the stop amplitude/frequency. When set to Down, values are swept from the stop
amplitude/frequency to the start amplitude/frequency.

When a step sweep is activated, the signal generator sweeps the RF output based on the values entered for RF output
start and stop frequencies and amplitudes, a number of equally spaced points (steps) to dwell upon, and the amount of
dwell time at each point; dwell time isthe time that the signal is settled and you can make a measurement before the
sweep moves to the next step. The total time at any step isthe sum of the switching speed (from the datasheet) plus the
dwell time at that step. The frequency, amplitude, or frequency and amplitude of the RF output will sweep from the start
amplitude/frequency to the stop amplitude/frequency, dwelling at equally spaced intervals defined by the # Points
softkey value.

To Configure a Single Step Sweep
In this procedure, you create a step sweep with nine, equally spaced points, and the following parameters:

« frequency range from 500 MHz to 600 MHz
¢ amplitude from —20 dBmto O dBm
e dwell time 500 msat each point

Press Preset.

1
2. Press Sweep/List.
This opens amenu of sweep softkeys.

3. Press Sweep Repeat Single Cont.
This toggles the sweep repeat from continuous to single.

Press Configure Step Sweep.

Press Freq Start > 500 > MHz.
This changes the start frequency of the step sweep to 500 MHz.

6. PressFreq Stop > 600 > MHz.
This changes the stop frequency of the step sweep to 600 MHz.

7. PressAmpl Sart >-20>dBm.
This changes the amplitude level for the start of the step sweep.

8. PressAmpl Stop >0>dBm.
This changes the amplitude level for the end of the step sweep.

9. Press# Points> 9> Enter.
This sets the number of sweep pointsto nine.
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10. Press Step Dwell > 500 > msec.
This sets the dwell time at each point to 500 milliseconds.

11. Press Return > Sweep > Freq & Ampl.

This sets the step sweep to sweep both frequency and amplitude data. Selecting this softkey returns you to the
previous menu and turns on the sweep function.

12. Press RF On/Off.
The display annunciator changes from RF OFF to RF ON.

13. Press Single Sweep.

A single sweep of the frequencies and amplitudes configured in the step sweep is executed and available at the RF
OUTPUT connector. On the display, the SWEEP annunciator appears for the duration of the sweep and a progress bar
shows the progression of the sweep. The Single Sweep softkey can also be used to abort a sweep in progress. To see
the frequencies sweep again, press Single Sweep to trigger the sweep.

To Configure a Continuous Sep Sweep

Press Sweep Repeat Single Cont.

This toggles the sweep from single to continuous. A continuous repetition of the frequencies and amplitudes configured
in the step sweep are now available at the RF OUTPUT connector. The SWEEP annunciator appears on the display,
indicating that the signal generator is sweeping and progression of the sweep is shown by a progress bar.

Using List Sweep

List sweep enables you to create alist of arbitrary frequency, amplitude, and dwell time values and sweep the RF output
based on the entriesin the List Mode Values table.

Unlike a step sweep that contains linear ascending/descending frequency and amplitude values, spaced at equal intervals
throughout the sweep, list sweep frequencies and amplitudes can be entered at unequal intervals, nonlinear
ascending/descending, or random order.

For convenience, the List Mode Values table can be copied from a previously configured step sweep. Each step sweep
point’s associated frequency, amplitude and dwell time values are entered into arow in the List Mode Valuestable, asthe
following exampleillustrates.

To Configurea Single List Sweep Using Step Sweep Data

In this procedure, you will leverage the step sweep points and change the sweep information by editing several pointsin
the List Mode Values table. For information on using tables, see “Using Table Editors” on page 38.

1. Press Sweep Repeat Single Cont.

This toggles the sweep repeat from continuous to single. The SWEEP annunciator is turned off. The sweep will not
occur until it istriggered.

2. Press Sweep TypelList Step.
This toggles the sweep type from step to list.
3. PressConfigure List Sweep.

This opens another menu displaying softkeys that you will use to create the sweep points. The display shows the
current list data. (When no list has been previoudly created, the default list contains one point set to the signal
generator’s maximum frequency, minimum amplitude, and a dwell time of 2 ms.)
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4.

PressMore (1 of 2) > Load List From Step Sweep > Confirm Load From Step Data.
The points you defined in the step sweep are automatically loaded into the list.

To Edit List Sweep Points

1

10.
11

12.

Press Return > Sweep > Off.

Turning the sweep off allows you to edit the list sweep points without generating errors. If sweep remains on during
editing, errors occur whenever one or two point parameters (frequency, power, and dwell) are undefined.

Press Configure List Sweep.

This returns you to the sweep list table.

Use the arrow keysto highlight the dwell timein row 1.
Press Edit Item.

The dwell time for point 1 becomes the active function.
Press 100 > msec.

This enters 100 ms as the new dwell time value for row 1. Note that the next item in the table (in this case, the
frequency value for point 2) becomes highlighted after you press the terminator softkey.

Using the arrow keys, highlight the frequency value in row 4.
Press Edit Item > 545> MHz.

This changes the frequency value in row 4 to 545 MHz.
Highlight any column in the point 7 row and press Insert Row.

This adds anew point between points 7 and 8. A copy of the point 7 row is placed between points 7 and 8, creating a
new point 8, and renumbering the successive points.

Highlight the frequency item for point 8, then pressinsert Item.

Pressing I nsert Item shifts frequency values down one row, beginning at point 8. Note that the original frequency
valuesfor both points 8 and 9 shift down one row, creating an entry for point 10 that contains only afrequency value
(the power and dwell time items do not shift down).

The frequency for point 8 is still active.

Press 590 > MHz.

PressInsert Item >-2.5>dBm.

Thisinserts anew power value at point 8 and shifts down the original power values for points 8 and 9 by one row.
Highlight the dwell time for point 9, then press Insert Item.

A duplicate of the highlighted dwell timeisinserted for point 9, shifting the existing value down to complete the
entry for point 10.

To Configurea Single List Sweep

1. PressReturn > Sweep > Freq & Ampl
This turns the sweep on again. No errors should occur if all parameters for every point have been defined in the
previous editing process.

2. Press Single Sweep.
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The signal generator will single sweep the pointsin your list. The SWEEP annunciator activates during the sweep.
3. PressMore (1 of 2) > Sweep Trigger > Trigger Key.
This sets the sweep trigger to occur when you pressthe Trigger hardkey.
4. PressMore (2 of 2) > Single Sweep.
This arms the sweep. The ARMED annunciator is activated.
5. PresstheTrigger hardkey.
The signal generator will single sweep the pointsin your list and the SWEEP annunciator will be activated during the
sweep.
To Configurea Continuous List Sweep
Press Sweep Repeat Single Cont.
This toggles the sweep from single to continuous. A continuous repetition of the frequencies and amplitudes configured
in the list sweep are now available at the RF OUTPUT connector. The SWEEP annunciator appears on the display,
indicating that the signal generator is sweeping and progression of the sweep is shown by a progress bar.
Using Ramp Sweep (Option 007)

Ramp sweep provides alinear progression through the start-to—stop frequency and/or amplitude values. Ramp sweep is
much faster than step or list sweep, and is designed to work with an 8757D Scalar Network Analyzer. This section
describes the ramp sweep capabilities available in signal generators with Option 007. You will learn how to use basic
ramp sweep, and how to configure aramp sweep for a master/slave setup (see page 55).

Refer to the Keysight Signal Generators Programming Guide for an example program that uses pass-thru commandsin
aramp sweep system (pass-thru commands enable you to temporarily interrupt ramp sweep system interaction so that
you can send operating instructions to the PSG).

Using Basic Ramp Sweep Functions

This procedure demonstrates the following tasks (each task builds on the previous task):

e “Configuring a Frequency Sweep” on page 49

e “Using Markers” on page 51

e “Adjusting Sweep Time” on page 53

e “Using Alternate Sweep” on page 54

e “Configuring an Amplitude Sweep” on page 55

Configuring a Frequency Sweep
1. Set up the equipment as shown in Figure 2-3.

NOTE The PSG signa generator is not compatible with the GPIB system interface of an 8757A, 8757C, or 8757E.
For these older scalar network analyzers, do not connect the GPIB cablein Figure 2-3. These scalar network
analyzers provide only a subset of 8757D functionality. See the Data Sheet for details. Use the 8757A/C/E
documentation instead of this procedure.
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Figure 2-3Equipment Setup
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Turn on both the 8757D and the PSG.
3. Onthe8757D, press System > More > Sweep M ode and verify that the SY SINTF softkey is set to ON.

This ensures that the system interface mode is activated on the 8757D. The system interface mode enables the
instruments to work as a system.

4. PressUtility > GPIB/RS-232 L AN to view the PSG’'s GPIB address under the GPIB Address softkey. If you want
to changeit, press GPIB Address and change the value.

5. Onthe8757D, press LOCAL > SWEEPER and check the GPIB address. If it does not match that of the PSG,
change the value.

6. Preset either instrument.

Presetting one of the instruments should automatically preset the other as well. If both instruments do not preset,
check the GPIB connection, GPIB addresses, and ensure the 8757D is set to system interface mode (SYSINTF set to
ON).

The PSG automatically activates a2 GHz to maximum frequency ramp sweep with a constant amplitude of 0 dBm.

Notice that the RF ON, SWEEP, and PULSE annunciators appear on the PSG display. The PULSE annunciator appears
because the 8757D is operating in AC mode.

The PSG also switches its remote language setting to 8757D System, allowing the PSG to talk to the 8757D during
ramp sweep operations. You can confirm this by pressing Utility > GPIB/RS-232 L AN and observing the selection
under the Remote L anguage softkey.

NOTE During swept RF output, the FREQUENCY and/or AMPLITUDE areas of the signal generator’s display are
deactivated, depending on what is being swept. In this case, since frequency isbeing swept, nothing appearsin
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the FREQUENCY area of the display.

7. PressFrequency > Freq CW.
The current continuous wave frequency setting now controls the RF output and ramp sweep is turned off.
8. PressFreq Sart.

The ramp sweep settings once again control the RF output and the CW mode is turned off. Pressing any one of the
softkeys Freq Sart, Freq Stop, Freq Center, or Freq Span activates aramp sweep with the current settings.

NOTE Inafrequency ramp sweep, the start frequency must be lower than the stop frequency.

9. Adjust the settingsfor Freq Center and Freq Span so that the frequency response of the device under test (DUT) is
clearly seen on the 8757D display.

Notice how adjusting these settings also changes the settings for the Freq Sart and Freq Stop softkeys. You may
need to rescale the response on the 8757D for a more accurate evaluation of the amplitude. Figure 2-4 on page 51
shows an example of a bandpass filter response.

Figure 2-4Bandpass Filter Response on 8757D
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Using Markers

1. PressMarkers.
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This opens atable editor and associated marker control softkeys. You can use up to 10 different markers, labeled O
through 9.

PressMarker Freq and select afrequency value within the range of your sweep.

In the table editor, notice how the state for marker O automatically turns on. The marker also appears on the 8757D
display.

Use the arrow keysto move the cursor in the table editor to marker 1 and select a frequency value within the range
of your sweep, but different from marker 0.

Notice that marker 1 is activated and is the currently selected marker, indicated by the marker arrow pointing down.
Asyou switch between markers, using the arrow keys, you will notice that the selected marker’s arrow points down,
while al others point up.

Notice also that the frequency and amplitude data for the currently selected marker is displayed on the 8757D.
Move the cursor back to marker 0 and press Delta Ref Set > Marker Delta Off On to On.

In the table editor, notice that the frequency values for each marker are now relative to marker 0. Ref appearsin the
far right column (also labeled Ref) to indicate which marker is the reference. Refer to Figure 2-5.

Figure 2-5Marker Table Editor
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Move the cursor back to marker 1 and press Marker Freq. Turn the front panel knob while observing marker 1 on
the 8757D.

On the 8757D, notice that the displayed amplitude and frequency values for marker 1 are relative to marker 0 asthe
marker moves along the trace. Refer to Figure 2-6.
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Figure 2-6Delta Markerson 8757D
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6. PressTurn Off Markers.

All active markers turn off. Refer to the Keysight PSG Signal Generators Key Reference for information on other
marker softkey functions.

Adjusting Sweep Time
1. Press Sweep/List.

This opens amenu of sweep control softkeys and displays a status screen summarizing all the current sweep
settings.

2. Press Configure Ramp/Step Sweep.

Since ramp is the current sweep type, softkeysin this menu specifically control ramp sweep settings. When step is
the selected sweep type, the softkeys control step sweep settings. Notice that the Freq Start and Freq Stop softkeys
appear in this menu in addition to the Frequency hardkey menu.

3. Press Sweep Timeto Manual > 5 > sec.

In auto mode, the sweep time automatically sets to the fastest allowable value. In manual mode, you can select any
sweep time slower than the fastest allowable. The fastest allowable sweep time is dependent on the number of trace
points and channels being used on the 8757D and the frequency span.

4. Press Sweep Timeto Auto.
The sweep time returns to its fastest allowable setting.
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NOTE When using an 8757D network analyzer in manual sweep mode, you must activate the signal generator’s

Manual Mode before using the Manual Freq softkey to control the sweep. Press Sweep/List > More (2 of 3)
> Manual Mode On.

Using Alter nate Sweep

1

Press the Save hardkey.

This opens the table editor and softkey menu for saving instrument states. Notice that the Select Reg softkey is
active. (For more information on saving instrument states refer to “Using the Instrument State Registers” on
page 61.)

Turn the front panel knob until you find an available register and press SAVE. Remember this saved register
number. If no registers are available, you can write over an in—use register, by pressing Re-SAVE.

NOTE Whenyou are using the PSG in a system with an 8757D network analyzer, you are limited to using registers 1

through 9 in sequence O for saving and recalling states.

3.

4.

Press Sweep/List > Configure Ramp/Step Sweep and enter new start and stop frequency values for the ramp
sweep.

Press Alter nate Sweep Register and turn the front panel knob to select the register number of the previously saved
sweep state.

Press Alternate Sweep Off On to On.

The signal generator alternates between the original saved sweep and the current sweep. You may need to adjust
8757D settings to effectively view both sweeps, such as setting channel 2 to measure sensor A. Refer to Figure 2-7.
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Figure 2-7Alter nating Sweeps on 8757D
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Configuring an Amplitude Sweep

1

Press Return > Sweep > Off.

This turns off both the current sweep and the alternate sweep from the previous task. The current CW settings now
control the RF output.

Press Configure Ramp/Step Sweep.

Using the Ampl Sart and Ampl Stop softkeys, set an amplitude range to be swept.

Press Return > Sweep > Ampl.

The new amplitude ramp sweep settings control the RF output and the CW mode is turned off.

Configuring a Ramp Sweep for a Master/Slave Setup

This procedure shows you how to configure two PSGs and an 8757D to work in a master/slave setup. The master/slave
control setup must use two instruments from the same signal generator family such astwo PSG's, or two 83640B’s, or
two 83751B’s.

NOTE The master/save setup applies to ramp sweep only, not step sweep or list sweep. To use this setup, you must

have two sources from the same signal generator family. For example, you cannot us a PSG with an 83640B or
aPSG with an 83751B.
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1. Set up the equipment as shown in Figure 2-8. Use a 9—+in, D—subminiature, male RS-232 cable with the pin
configuration shown in Figure 2-9 to connect the auxiliary interfaces of the two PSGs. You can also order the cable
(part number 8120-8806) from Keysight Technologies.

By connecting the master PSG’s 10 MHz reference standard to the slave PSG’s 10 MHz reference input, the master’s
timebase supplies the frequency reference for both PSGs.

2. Set up the slave PSG's frequency and power settings.

By setting up the slave first, you avoid synchronization problems.
3. Set up the master PSG’s frequency, power, and sweep time settings.

The two PSGs can have different frequency and power settings for ramp sweep.
4. Setthe slave PSG’s sweep time to match that of the master.

Sweep times must be the same for both PSGs.

5. Set the dave PSG to continuous triggering.

The slave must be set to continuous triggering, but the master can be set to any triggering mode.

6. Onthe slave PSG, press Sweep/List > Sweep Type > Ramp Sweep Control > Slave.

This sets the PSG to operate in slave mode.

7. Onthe master PSG, press Sweep/List > Sweep Type > Ramp Sweep Control > Master. This sets the PSG to
operate in master mode.
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Extending the Frequency Range

You can extend the signal generator frequency range using an Keysight 83550 series millimeter—wave source module or
other manufacturer’s mm—source module. For information on using the signal generator with a millimeter—wave source
module, refer to “Using Keysight Millimeter-Wave Source Modules” on page 267.

Modulating a Signal

This section describes how to turn on a modulation format, and how to apply it to the RF output.

Turning On a Modulation Format

A modulation format can be turned on prior to or after setting the signal parameters.

1. Accessthefirst menu within the modulation format.
This menu displays a softkey that associates the format’s name with off and on. For example, AM > AM Off On.
For some formats, the off/on key may appear in additional menus other than the first one.

2. Pressthe modulation format off/on key until On highlights.
Figure 2-10 shows the portion of the AM modulation format’s first menu that displays the state of the modulation
format, as well as the active modulation format annunciator.

The modulation format generates, but the carrier signal is not modulated until you apply it to the RF output (see
page 59).

Depending on the modulation format, the signal generator may require afew seconds to build the signal. Within the
digital formats (E8267D PSG with Option 601/602 only), you may see aBaseBand Reconfiguring status bar
appear on the display. Once the signal is generated, an annunciator showing the name of the format appears on the
display, indicating that the modulation format is active. For digital formats (E8267D PSG with Option 601/602 only),
the I/Q annunciator appears in addition to the name of the modulation format.

Figure 2-10Example of AM Modulation Format Off and On
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Applying a Modulation Format to the RF Output

The carrier signal is modulated when the M od On/Off key is set to On, and an individual modulation format is active.

When the M od On/Off key is set to Off, theMOD OFF annunciator appears on the display.When the key is set to On, the
MOD ON annunciator showsin the display, whether or not there is an active modulation format. The annunciators simply
indicate whether the carrier signal will be modulated when a modulation format is turned on.

To Turn RF Output Modulation On
Press the M od On/Off key until theMOD ON annunciator appears in the display.
The carrier signal should be modulated with all active modulation formats. Thisis the factory default.

To Turn RF Output Modulation Off
Pressthe Mod On/Off key until theMOD OFF annunciator appears in the display.
The carrier signal is no longer modulated or capable of being modulated when a modulation format is active.

Figure2-11Carrier Signal Modulation Satus
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Using Data Stor age Functions

This section explains how to use the two forms of signal generator data storage: the memory catalog and the instrument
state register.

Using the Memory Catalog

The Memory Catalog isthe signal generator’s interface for viewing, storing, and saving files; it can be accessed through
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the signal generator’s front panel or aremote controller. (For information on performing these tasks remotely, see the
Keysight Sgnal Generators Programming Guide.)

Table2-1 Memory Catalog File Types and Associated Data

Binary binary data

State instrument state data (controlling instrument operating parameters, such as
frequency, amplitude, and mode)

LIST sweep data from the List Mode Values table including frequency, amplitude, and
dwell time
User Flatness user flatness calibration correction pair data (user—defined frequency and

corresponding amplitude correction values)

FIR Finite Impulse Response (FIR) filter coefficients

ARB Catalog Types (E8267D PSG with Option 601/602 only) user created files—

Waveform Catalog Types: WFM 1 (waveform file),

NVARB Catalog Types:

NVWFM (non-volatile, ARB waveform file),

NVMKR (non-volatile, ARB waveform marker file),

Seq (ARB sequencefile),

MTONE (ARB multitonefile),

DMOD (ARB digital modulation file), MDMOD (ARB multicarrier digital
modulation file)

Modulation Catalog Types (E8267D PSG with Option 601/602 only) associated data for 1/Q and FSK
(frequency shift keying) modulation files

Shape burst shape of a pulse

Bit Bit

Soring Filesto the Memory Catalog

To store afile to the memory catalog, first create afile. For this example, use the default list sweep table.

1
2.

Press Preset.

Press Sweep/List > Configure List Sweep > More (1 of 2) > Load/Sore.
This opensthe “Catalog of List Files'.

Press Storeto File.

This displays amenu of alphabetical softkeys for naming thefile. Store to: isdisplayed in the active function
area.

Enter the file name LIST1 using the alphabetical softkeys and the numeric keypad (for the numbers 0 to 9).
Press Enter.

Thefile should be displayed in the* Catalog of List Files’, showing the file name, file type, file size, and the date
and time the file was modified.
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Viewing Stored Filesin the Memory Catalog
1. PressUtility > Memory Catalog > Catalog Type.

All filesin the memory catalog are listed in alphabetical order, regardless of which catalog type you select. File
information appears on the display and includes the file name, file type, file size, and the date and time the file was
modified.

2. PressList.
The “Catalog of List Files’ is displayed.
3. PressCatalog Type > Sate.
The “Catalog of State Files’ is displayed.
4. PressCatalog Type > All.
The “Catalog of All Files’ isdisplayed. For acomplete list of file types, refer to Table 2-1 on page 60.

Using the Instrument State Registers

The instrument state register is a section of memory divided into 10 sequences (numbered O through 9) with each
sequence consisting of 100 registers (numbered 00 through 99). Instrument state sequences and registers are used to
store and recall instrument settings and provide a quick way to reconfigure the signal generator when switching between
different instrument and signal configurations.

The signal generator with either Option 005 (internal hard drive — 4 GB), or Options 008, and 009 (flash drive — 8 GB)
installed, utilizes the memory for storing instrument state files and other user data. If these options are not installed, the
signal generator has 20 MB available for data and instrument state storage. Instrument state files can vary in length
depending on the signal generator’s configuration.

File data, such as modulation formats, arb setups, and table entries, are not stored with the save function. Only setups
such as frequency, attenuation, power and other user—defined settings that do not survive a power cycle or instrument
reset can be saved to a sequence and register. Any datafile, such as an arb format file, associated with the instrument
state will only be referenced by its file name. Once an instrument state has been saved, recalling that state will setup the
generator with the saved settings and |oad the associated file data.

For more information on storing file data such as modulation formats, arb setups, and table entries refer to “Storing
Files to the Memory Catalog” on page 60. Refer to the Keysight Signal Generators Programming Guide and the
Keysight PSG Sgnal Generators Key Reference for more information on the save and recall function.

NOTE A referenceto afileis saved along with theinstrument state. However, no datais saved with the save function.
You must store file data, using store commands, in a different memory location.

Saving an Instrument Sate
1. Preset the signal generator, then turn on amplitude modulation (the 2M annunciator will turn on):

a PressFrequency > 800> MHz.
b. Press Amplitude>0>dBm.
c. PressAM > AM Off On.

2. Press Save> Select Seq.

The sequence number becomes the active function. The signal generator displays the last sequence used. Using the
arrow keys, set the sequenceto 1.
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3. Press Select Reg.

The register number in sequence 1 becomes the active function. The signal generator displays either the last register
used accompanied by thetext: (in use), or (if no registers are in use) register 00 accompanied by the text:
(available). Usethe arrow keysto select register O1.

4. Press Save Seq[1] Reg[01].
This saves thisinstrument state in sequence 1, register 01 of the instrument state register.
5. Press Add Comment to Seq[1] Reg[01].
This enables you to add a descriptive comment to sequence 1 register 01.
Using the alphanumeric softkeys or the knob, enter acomment and press Enter.
Press Edit Comment In Seq[1] Reg[01].
If you wish, you can now change the descriptive comment for sequence 1 register 01.
After making changes to an instrument state, you can save it back to a specific register by highlighting that register and
pressing Re-SAVE Seq[n] Reg[nn].
Recalling an Instrument Sate
Using this procedure, you will learn how to recall instrument settings saved to an instrument state register.
1. PressPreset.
2. Pressthe Recall hardkey.
Notice that the Select Seq softkey shows sequence 1. (Thisisthe last sequence that you used.)
3. PressRECALL Reg.

The register to be recalled in sequence 1 becomes the active function. Press the up arrow key once to select register
1. Your stored instrument state settings should have been recalled.

Deleting Registers and Sequences
These procedures describe how to delete registers and sequences saved to an instrument state register.

Deleting a Specific Register within a Sequence
1. PressPreset.

2. Pressthe Recall or Save hardkey.
Notice that the Select Seq softkey shows the last sequence that you used.
3. Press Select Seq and enter the sequence number containing the register you want to delete.
4. Press Select Reg and enter the register number you want to delete.
Notice that the Delete Seq[n] Reg[nn] should be |oaded with the sequence and register you want to delete.
5. PressDelete Seg[n] Reg[nn].
This deletes the chosen register.

Deleting All Registerswithin a Sequence
1. PressPreset.
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2. Pressthe Recall or Save hardkey.
Notice that the Select Seq softkey shows the last sequence that you used.
Press Select Seq and enter the sequence number containing the registers you want to delete.
Press Delete all Regsin Seq[n].
This deletes all registersin the selected sequence.

Deleting All Sequences

CAUTION  Besure you want to delete the contents of all registers and all sequencesin the instrument state register.

Press Preset.

Pressthe Recall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.
3. PressDelete All Sequences.

This deletes all of the sequences saved in the instrument state register.

8757 Network Analyzer Save and Recall Functions

The 8757 network analyzer family can save and recall signal generator instrument states although communication
between the instrumentsis limited.

A clear register command from the 8757 will cause the signal generator to replace aregister’s contents with default
values. Default values can be cleared from the signal generator by using the Delete All softkey menu or by using the
corresponding SCPI (Standard Commands for Programmable | nstruments) command.

The signal generator does not communicate directly with the 8757 network analyzer. If the 8757 saves an instrument
state to asignal generator register and the user deletes that register, the 8757 will not recognize the deletion. An attempt,
by the 8757, to recall adeleted state will cause the PSG to generate the error message: +700 “ State Save Recall Error...".

Using Security Functions

This section describes how to use the PSG’s security functions to protect and remove classified proprietary information
stored or displayed in the instrument. All security functions described in this section also have an equivalent SCPI
command for remote operation. (Refer to the “ System Commands® chapter of the Keysight PSG Sgnal Generators SCPI
Command Reference for more information.)

Under standing PSG Memory Types

The PSG comprises several memory types, each used for storing a specific type of data. Before removing sensitive data,
it isimportant to understand how each memory typeis used in the PSG. The following tables describe each memory type
used in the base instrument, baseband generator (Option 601, 602), hard disk (Option 005) or removable compact flash
drive (Options 008 and 009).
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Table 2-2 BaseInstrument Memory

o &
28| O
Memory = e |3 g
Type a 8 € £ | Purpose/Contents Data Input Method Location in Instrument and Remarks
and Size 258
B2 |5
£E (g8
£2 |8z
Main Yes No firmware operating memory | operating system (not | CPU board, not battery backed.
Memory user)
(SDRAM)
64 MB
Main Yes |Yes |factory firmware upgrades and | CPU board (same chip as firmware memory, but managed
Memory calibration/configuration data | user—saved data separately)
(Flash) user file system, which User datais not stored in this memory if hard disk
20MB includes instrument status (Option 005) or the removable compact flash drive (Option
backup, flatness calibration, 008 or 009) isinstalled.
1Q calibration, instrument ' X :
states, waveforms (including Because th!s 32 MB memory chip oo_ntal ns 20 MB of user
header and marker deta), data (q&cn ped here) and 12 MB of firmware memory, a
modulation definitions, and seiect!ve chip eraseis performt_ac_i. User data areas are
aweep lists selectively and completely sanitized when you perform the
Erase and Sanitize function.
Firmware No Yes main firmware image factory installed or CPU board (same chip as main flash memory, but managed
Memory firmware upgrade separately)
(Flash) . . .
During normal operation, this memory cannot be
12MB overwritten except for LAN configuration. It isonly
overwritten during the firmware installation or upgrade
Yes Yes LAN configuration front panel entry or process.
remotely
Because this 32 MB memory chip contains 20 MB of user
data and 12 MB of firmware memory (described here), a
selective chip erase is performed. User data areas are
selectively and completely sanitized when you perform the
Erase and Sanitize function.
Battery Yes Yes user—editable data (table firmware operations CPU board
,\Bﬂfri:g:y editors) The battery can be removed to sanitize the memory, but
(SRAM) last instrument state, last must be reinstalled for the instrument to operate. The battery
instrument state backup, and islocated on the CPU board.
512 kB persistent instrument state
and instrument status
Bootrom No Yes CPU bootup program and factory programmed CPU board
Memory firmware |oader/updater - } )
(Flash) Duri ng normal operati on, this memory canlnot be
overwritten or erased. Thisread—only datais programmed at
128 kB the factory.
Calibration No Yes factory factory or service only | motherboard
Backup calibration/configuration data
Memory backup
(Flash)
no user data
512 KB
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o &

25| O

c
Memory = § B -g
Type a 8 -% 2 | Purpose/Contents Data Input Method Location in Instrument and Remarks
and Size 2 fol

88 |«c

SE|sk

22 |8z
Boards No Yes | factory calibration and factory or serviceonly | al RF boards, baseband generator, and motherboard
Memory information files, code
(Flash) images, and self-test limits
512 Bytes no user data
Micro— Yes No CPU data and instruction memory ismanaged by | CPU board, not battery backed.
processor cache CPU, not user
Cache
(SRAM)
3kB

Table 2-3 Baseband Gener

ator Memory (Options 601 and 602)

o &
28| O
=1
Memory 3|8 —g
Type o2 % = | Purpose/Contents Data Input Method Remarks
. 0 O o)
and Size =2 folfed
8% |c
ZE| sk
£2 |8z
Waveform Yes No waveforms (including header and | normal user operation | User datais completely sanitized when you perform the
Memory marker data) and PRAM Erase and Sanitize function. Not battery backed.
(SDRAM)
40-320 MB
BBG No Yes |firmware image for baseband firmware upgrade
Firmware generator
Memory
(Flash)
32MB
Coprocessor | Yes No operating memory of baseband | During normal This memory is used during normal baseband generator
Memory coprocessor CPU operation, someuser | operation. It is not directly accessible by the user. Not
(SRAM) information, suchas | battery backed.
payload data, can
32mB remain in the memory.
Buffer No No support buffer memory for ARB | normal user operation | This memory is used during normal baseband generator
Memory and real—time applications operation. It is not directly accessible by the user. Not
(SRAM) battery backed.
5x 512 kB
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Table 2-4 Hard Disk Memory (Option 005)2

o &
28| ©
£ g 3B
M emory Type ae % L Pur pose/Contents Data Input Method Remarks
and Size 00 | & 3
= o
8¢ |
SE |k
22 |8z
Media Storage | Yes Yes user files, including flatness user—saved data The magnetic residue requires several rewrite cycles or
(Built-in Hard calibrations, 1Q calibration, drive removal and destruction.
Disk instrument states, waveforms - . . .
156) I(incILLJJding header \;w marker The hard disk is an option and is therefore not installed
6 GB or 10 GB data), modulation definitions, and in some instruments. If it isinstalled, these files are
(4 GB usablein smeeb lists ' stored on the hard disk instead of in flash memory.
both cases)
) User datais completely sanitized when you perform the
Erase and Sanitize function.
Buffer Memory | No No buffer (cache) memory normal operation
(DRAM) through hard disk
512 kB

4 nstruments with serial prefix < US4829/SG4829/MY 4829.

66

Keysight PSG Signal Generators User’s Guide



Basic Operation
Using Security Functions

CAUTION  Theremovable compact flash driveis not hot swappable — always turn the power off to the instrument
when removing or inserting the memory. Use only Keysight provided or certified compact flash cards.

Table 2-5 Flash Drive Memory (Options 0082 and 009b)

o &

28| ©

£ g 3B
Memqry Type ae % L Pur pose/Contents Data Input Method Remarks
and Size 00 | & 3

= o

g% |

ZE |k

22 |8z
Memory Yes Yes user files, including flatness user—saved data The flash driveis an option and is therefore not
Storage calibrations, |Q calibration, installed in some instruments. If it isinstalled, these
(removable instrument states, waveforms files are stored on the flash drive instead of in flash
compact flash (including header and marker memory.
drive data), modulation definitions, and . -

) Méaép lists User datais completely sanitized when you perform the

8 GB (usable Erase and Sanitize function.
8187374080
bytes)

8 nstruments with serial prefix 3 US4928/SG4928/MY 4928.
BInstruments with serial prefix 3 US4829/SG4828/M Y 4829.
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Removing Sensitive Data from PSG Memory

When moving the PSG from a secure devel opment environment, you can remove any classified proprietary information
stored in theinstrument. This section describes several security functions you can use to remove sensitive data from your
instrument.

Erase All

This function removes all user files, user flatness calibrations, user I/Q calibrations, and resets all table editors with
origina factory values, ensuring that user dataand configurations are not accessible or viewable. The instrument appears
asif itisinitsorigina factory state, however, the memory is not sanitized. This action is relatively quick, taking less
than one minute.

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase All > Confirm Erase.

NOTE Thisfunction is different than pressing Utility > Memory Catalog > More (1 of 2) > Delete All Files, which
deletes all user files, but does not reset the table editors.

Erase and Overwrite All

This function performs the same actions as Erase All and then clears and overwrites the various memory typesin
accordance with Department of Defense (DoD) standards, as described below.

SRAM All addressable locations are overwritten with random characters.

CPU Flash All addressable locations are overwritten with random characters and then the flash blocks are erased. This accomplishes the same
purpose of achip erase, however, only the areas that are no longer in use are erased and the factory calibration files are left intact.
System files are restored after erase.

DRAM/SDRAM  Follow the Department of Defence (DoD) manual’s requirements. The instrument must be powered off to purge the memory contents.
The instrument must remain powered off in a secure location for 3 minutes.

Hard Disk All addressable |ocations are overwritten with a single character. (Thisisinsufficient for top secret data, according to DoD standards.
For top secret data, the hard drive must be removed and destroyed.)

Flash Drive All addressable locations are overwritten with asingle character. (Thisisinsufficient for top secret data, according to DoD standards.
For top secret data, consult with your local security officer for approved procedures.)

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase and Overwrite All >
Confirm Overwrite.

Erase and Sanitize All

This function performs the same actions as Erase and Overwrite All and then adds more overwriting actions. After
executing this function, you must manually perform some additional steps for the sanitization to comply with
Department of Defense (DoD) standards. These actions and steps are described bel ow.

SRAM All addressable locations are overwritten with random characters.

CPU Flash All addressable |ocations are overwritten with random characters and then the flash blocks are erased. This accomplishes the same
purpose of achip erase, however, only the areas that are no longer in use are erased and the factory calibration files are left intact.
System files are restored after erase.

DRAM/SDRAM  Follow the Department of Defence (DoD) manual’s requirements. The instrument must be powered off to purge the memory contents.
The instrument must remain powered off in a secure location for 3 minutes.
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Hard Disk All addressable |ocations are overwritten with a single character and then arandom character. (Thisisinsufficient for top secret data,
according to DoD standards. For top secret data, the hard drive must be removed and destroyed.)

Flash Drive All addressable |ocations are overwritten with a single character and then arandom character. (Thisisinsufficient for top secret data,
according to DoD standards. For top secret data, consult with your local security officer for approved procedures.)

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase and Sanitize All >
Confirm Sanitize.

Removing Persistent Sate | nformation Not Removed During Erase

Persistent State

The persistent state settings contain instrument setup information that can be toggled within predefined limits such as
display intensity, contrast and the GPIB address. In vector models, the user 1Q Cal is also saved in this area.

The following key presses or SCPI commands can be used to clear the 1Q cd file and to set the operating states that are
not affected by asignal generator power—on, preset, or *RST command to their factory default:

Instrument Setup
e Onthefront panel, press: Utility > Power On/Preset > Restore System Defaults > Confirm Restore Sys Defaults

e Orsend thecommand: : SYSTem: PRESet : PERSistent

LAN Setup
The LAN setup (hostname, | P address, subnet mask, and default gateway) information is not defaulted with a signal generator
power—on or *RST command. Thisinformation can only be changed or cleared by entering new data.

User |1Q Cal File (Vector Models Only)
When a user—defined |Q calibration has been performed, the cal file datais removed by setting the cal file to default, asfollows:
1. Onthefront panel, press: I/Q > 1/Q Calibration > Revert to Default Cal Settings
2. Send these commands:
* :CAL:IQ:DEF
* :CAL:WBIQ:DEF

Using the Secure Mode

The secure mode automatically applies the selected Security L evel action the next time the instrument’s power is
cycled.

Setting the Secure M ode L evel
1. PressUtility > Memory Catalog > More (1 of 2) > Security > Security Level.

2. Choose from the following selections:

None — equivalent to afactory preset, no user information is lost
Erase — equivalent to Erase All

Overwrite— equivalent to Erase and Overwrite All

Sanitize — equivalent to Erase and Sanitize All
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Activating the Secure Mode

CAUTION  Once you activate secure mode (by pressing Confirm), you cannot deactivate or decrease the security
level; the erasure actions for that security level execute at the next power cycle. Once you activate secure
mode, you can only increase the security level until you cycle power. For example, you can change Erase
to Overwrite, but not the reverse.

After the power cycle, the security level selection remains the same, but the secure mode is not activated.

Press Utility > Memory Catalog > More (1 of 2) > Security > Enter Secure Mode > Confirm.
The Enter Secure M ode softkey changesto Secure Mode Activated.

If Your Instrument is Not Functioning

If the instrument is not functioning and you are unable to use the security functions, you may physically remove the
processor board, hard disk or flash drive if installed, from the instrument. Once these assemblies are removed, proceed
asfollows:

For removal and replacement procedures, refer to the Keysight PSG Signal Generators Service Guide.

Processor Board
Either

« Discard the processor board and send the instrument to arepair facility. A new processor board will be installed and
the instrument will be repaired and calibrated. If the instrument is still under warranty, you will not be charged for
the new processor board.

or

e If you have another working instrument, install the processor board into that instrument and erase the memory. Then
reinstall the processor board back into the non—working instrument and send it to arepair facility for repair and
calibration. If you discover that the processor board does not function in the working instrument, discard the
processor board and note that it caused the instrument failure on the repair order. If theinstrument is still under
warranty, you will not be charged for the new processor board.

Hard Disk
Either

¢ Discard the hard disk and send the instrument to arepair facility. Indicate on the repair order that the hard disk was
removed and must be replaced. A new hard disk will beinstalled and the instrument will be repaired and calibrated.
If theinstrument is still under warranty, you will not be charged for the new hard disk.

or
e Keep the hard disk and send the instrument to arepair facility. When the instrument is returned, reinstall the hard
disk.
Flash Drive (Option 008 and 009 only)
Either

¢ Discard the flash memory card. Indicate on the repair order that the flash memory was removed and request a new
memory card. If the instrument is still under warranty, you will not be charged for the new memory card.
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or

¢ Keep the flash memory card and send the instrument to arepair facility. When the instrument is returned, reinstall
the flash memory card.

Using the Secure Display

This function prevents unauthorized personnel from reading the instrument display and tampering with the current
configuration through the front panel. The display is blanked, except for the message *** SECURE DISPLAY
ACTIVATED #***, and the front panel keys are disabled. Once this function is activated, the power must be cycled to
re—enable the display and front panel keys.

To apply thisfunction, press Utility > Display > More (1 of 2) > Activate Secure Display > Confirm Secure Display

Figure 2-12PSG Screen with Secure Display Activated

(]
(]
(]
*** SECURE DISPLAY ACTIVATED *** :[:]
(]
(]

Enabling Options

You can retrofit your signal generator after purchase to add new capabilities. Some new optional features are
implemented in hardware that you must install. Some options are implemented in software, but require the presence of
optional hardware in the instrument. This example shows you how to enable software options.

Enabling a Software Option

A license key (provided on the license key certificate) is required to enable each software option.

1. Accessthe Software Options menu:
Utility > Instrument Adjustments > Instrument Options > Software Options.
Thefollowing is an example of the signal generator display, which lists any enabled software options, and any
software options that can be enabled:
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FREQUENCY ‘HHPLITUDE Modifu

20,000 000 000000 &= -13500 mn | L=Eid

Softuare Option Selection Host ID = el77Ffff
Option License Key Description

007 FELEZEFAL/214 . FAMF SLEEF

015 00000000000A -+ WIDEBANMD IO

1ER + HIGH OUTPUT FOLER
L0 < RADAR SIMULATION PERSCOWALITY
L21 + MOISE FOWER RATIO PERSOMALITY

Proceed Hith
Reconf iouration

2. Verify that the host ID shown on the display matches the host ID on the license key certificate. The host ID isa
unique number for every instrument. If the host ID on the license key certificate does not match your instrument, the
license key cannot enable the software option.

3. Verify that any required hardware is installed. Because some software options are linked to specific hardware
options, before the software option can be enabled, the appropriate hardware option must be installed. For example,
Option 420 (radar simulation modulation format) requires that Option 601/602 (internal baseband generator) be
installed. If the software option that you intend to install islisted in agrey font, the required hardware may not be
installed (look for an X in the “ Selected” column of the appropriate hardware option in the Hardware Options
menu).

4. Enable the software option:
a.  Highlight the desired option.
b. PressModify License Key, and enter the 12—character license key (from the license key certificate).

c. Verify that you want to reconfigure the signal generator with the new option:
Proceed With Reconfiguration > Confirm Change

The instrument enables the option and reboots.

Using the Web Server

You can communicate with the signal generator using the Web Server. This service uses TCP/IP (Transmission Control
Protocol/Internet Protocol) to communicate with the signal generator over the internet.

The Web Server uses a client/server model where the client isthe web browser on your PC or workstation and the server
isthe signal generator. When you enable the Web Server, you can access aweb page that resides on the signal generator.

The Web—Enabled PSG web page, shown in Figure 2-13, provides general information on your signal generator and a
means to control the instrument by using aremote front panel interface or using SCPI (Standard Communication for
Programmable Instruments) commands. The web page also has links to Keysight's products, support, manuals, and
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website.

NOTE The Web Server service is compatible with the latest version of the Microsoft© Internet Explorer web
browser.

The Signal Generator Web Control menu button on the Web—Enabled PSG web page will access a second web page.
This web page, shown in Figure 2-14, provides avirtual instrument interface that can be used to control the signal
generator. You can use the mouse to click on the signal generator’sfront panel hardkeys, softkeys and number pad. There
isalso atext box that can be used to send SCPI commands to the instrument.

Activating the Web Server

Perform the following steps to access the Web Server.

1. Turnon the Web Server by pressing Utility > GPIB/RS-232 LAN > L AN Services Setup > Web Server On.
Press the Proceed With Reconfiguration softkey.

Press the Confirm Change (Instrument will Reboot) softkey. The signal generator will reboot.

Launch your PC or workstation web browser.

Enter the | P address of the signal generator in the web browser address field. For example, http://101.101.101.101.
Replace 101.101.101.101 with your signal generator’s | P address. Press the Enter key on the computer’s keyboard.

g~ w0 DN

NOTE ThelP (Internet Protocol) address can change depending on your LAN configuration.
Usethe LAN Config Manual DHCP softkey to select aManual or DHCP (dynamic host communication
protocol) LAN configuration. Refer to Keysight PSG Signal Generators Key Reference for more information.

IMicrosoft is a registered trademark of Microsoft Corp.
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6. Pressthe Enter key on the computer’s keyboard. The web browser will display the signal generator’s homepage as
shown below in Figure 2-13. Thisweb page displays information about the signal generator and provides access to
Keysight's website.

Figure 2-13Signal Generator Web Page

Zj Welcome to Agilent Technologies Web-Enabled Site - Microsoft Internet Explorer e =] 3]

File Edt View Favorites Tools Help ‘

GBack + = - @ @ & | Qocarch GuFovorites Pieda B | - S -

e o 101 101101101 et b | @

Welcome to your

Web-Enabled P5G

Infermation about this Web-Enabled PSG:

Serial Numbel Ug44100080

Agilent EB267D (US44100080)
112184
TCPIPO:GALLP3:INSTR

o e 0160t
00:30:D3:05:58:38
romees E

Use the navigation bar on the |eft to access your signal generatar and related information

@ Agilent Technologies, Inc, 2002

-

&) Dane [ [ [ |4 mntemet v
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7. Click the Signal Generator Web Control menu button on the left of the page. A new web page will be displayed as
shown below in Figure 2-14.

Figure 2-14Web Page Front Panel
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File Edit View Favorites Tools  Help
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This web page remotely accesses all signal generator functions and operations. Use the mouse pointer to click on the
signal generator’s hardkeys and softkeys. The results of each mouse click selection will be displayed on the web page.
For example, click on the Frequency hardkey then use the front panel key pad to enter afrequency. You can also use the
up and down arrow keys to increase or decrease the frequency.

You can use the SCPI Command text box at the bottom of the front panel display to send commands to the signal
generator. Enter avalid SCPI command, then click the SEND button. The results of the command will be displayed on a
separate web page titled, “ SCPI Command Processed”. You can continue using this web page to enter SCPI commands
or you can return to the front panel web page.

NOTE It may be necessary to use the web browser Refresh function if the web page does not update with new
settings.
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3 Basic Digital Operation

This chapter providesinformation on the functions and features available for the E8267D PSG vector signal generator
with Option 601 or 602.

e “Custom Modulation” on page 77

«  “Arbitrary (ARB) Waveform File Headers” on page 78
e “Using the Dual ARB Waveform Player” on page 89
e “Using Waveform Markers” on page 94

* “Triggering Waveforms” on page 109

e “Using Waveform Clipping” on page 115

* “Using Waveform Scaling” on page 123

e “Setting the Baseband Frequency Offset” on page 126
See also:

e “Custom Arb Waveform Generator” on page 157

e “Multitone Waveform Generator” on page 217

e “Two-Tone Waveform Generator” on page 227

Custom Modulation

For creating custom modulation, the signal generator offers two modes of operation: the Arb Waveform Generator mode
and the Real Time I/Q Baseband mode. The Arb Waveform Generator mode has built—in modulation formats such as
NADC or GSM and pre-defined modulation types such as BPSK and 16QAM that can be used to create asignal. The
Real Time 1/Q Baseband mode can be used to create custom data formats using built—in PN sequences or custom-user
files along with various modulation types and different built—in filters such as Gaussian or Nyquist.

Both modes of operation are used to build complex, digitally modulated signals that simulate communication standards
with the flexibility to modify existing digital formats, define or create digitally modulated signals, and add signal
impairments.

KEYSIGHT

TECHNOLOGIES
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Custom Arb Waveform Gener ator

The signal generator’s Arb Waveform Generator mode is designed for out—of—channel test applications. This mode can
be used to generate data formats that simulate random communication traffic and can be used as a stimulus for
component testing. Other capabilities of the Arb Waveform Generator mode include:

configuring single or multicarrier signals. Up to 100 carriers can be configured.
creating waveform files using the signal generator’s front panel interface.

The waveform files, when created as random data, can be used as a stimulus for component testing where device
performance such as adjacent channel power (ACP) can be measured. The AUTOGEN_WAVEFORM filethat is
automatically created when you turn the Arb Waveform Generator on can be renamed and stored in the signal
generator’s non—volatile memory. Thisfile can later be loaded into volatile memory and played using the Dual ARB
waveform player.

For more information, refer to the sections “Using the Dual ARB Waveform Player” on page 89 and “Modes of
Operation” on page 8.

Custom Real Timel/Q Baseband

The real-time mode simulates single—channel communication using user—defined modul ation types along with custom
FIR filters, and symbol rates. Data can be downloaded from an external sourceinto PRAM memory or supplied as rea
time data using an external input. The Real Time 1/Q Baseband mode can al so generate pre—defined data formats such as
PNO9 or FIX4. A continuous data stream generated in this mode can be used for receiver bit error analysis. This modeis
limited to asingle carrier. The Real Time 1/Q Baseband mode:

has more data and modul ation types available than the Arb Waveform Generator mode.
supports custom 1/Q constellation formats.

has the capability to generate continuous PN sequences for bit error rate testing (BERT).
needs no waveform build time when signal parameters are changed.

For more information, refer to the custom arb section “Overview” on page 157, the custom real time section
“Overview” on page 179 and the section on “Digital Modulation” on page 9.

Arbitrary (ARB) Waveform File Headers

An ARB waveform file header enables you to save instrument setup information (key format settings) along with a
waveform. When you retrieve a stored waveform, the header information is applied so that when the waveform starts
playing, the dual ARB player is set up the same way each time.

Headers can also store a user—specified 32—character description of the waveform or sequence file.

A default header is automatically created whenever awaveform is generated, a waveform sequence is created, or a
waveform file is downloaded to the PSG (for details on downloading files, see the Keysight Sgnal Generators
Programming Guide).

The following signal generator settings are saved in afile header:
¢ ARB sample clock rate
¢ Runtime scaling (only in the dual ARB player)

Marker settings and routing functions (page 94)

— Polarity
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— RFblanking
e High crest mode (only in the dual ARB player)
e Modulator attenuation
e Modulator filter

* 1/Q output filter (used when routing signals to the rear panel 1/Q outputs)
e Other instrument optimization settings (for files generated by the PSG) that cannot be set by the user.

Creating a File Header for a Modulation Format Waveform

Basic Digital Operation

Arbitrary (ARB) Waveform File Headers

When you turn on a modulation format, the PSG generates a temporary waveform file (AUTOGEN_WAV EFORM),

with adefault file header. The default header has no signal generator settings saved to it.

This procedure, which isthe same for all ARB formats, demonstrates how to create a file header for a Custom digital

modulation format.
1. Preset the signal generator.
2. Turn on the Custom modulation format:

Press M ode > Custom > ARB Waveform Generator > Digital M odulation Off On to On
A default file header is created, and the temporary waveform file (AUTOGEN_WAV EFORM) plays. Figure 3-1

shows the PSG’s display.

Figure 3-1Custom Digital Modulation First—L evel Softkey Menu
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First-Level Softkey
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(Some ARB formats

At this point, adefault file header has been created, with default (unspecified) settings that do not reflect the current
signal generator settings for the active modulation. To save the settings for the active modulation, you must modify
the default settings before you save the header information with the waveform file (see “Modifying Header

Information in a Modulation Format” on page 80).

NOTE Each time an ARB modulation format is turned on, a new temporary waveform file

(AUTOGEN_WAVEFORM) and file header are generated, overwriting the previous temporary file and file
header. Because all ARB formats use the same file name, this happens even if the previous
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AUTOGEN_WAVEFORM file was created by a different ARB modulation format.

Modifying Header Information in a M odulation Format

This procedure builds on the previous procedure, explaining the different areas of afile header, and showing how to
access, modify, and save changes to the information.

In amodulation format, you can access afile header only while the modulation format is active (on). This procedure uses
the Custom digital modulation format. All ARB modulation formats and the dual ARB player access the file header the
same way, except that in some modulation formats, you may have to go to page two of the first-evel softkey menu.

1. From thefirstevel softkey menu (shown in Figure 3-1 on page 79), open the Header Utilities menu:
Press ARB Setup > Header Utilities

Figure 3-2 shows the default header for the Custom digital modulation waveform. The Saved Header
Settings column, showsthat the signal generator settings for the active format are Unspeci fied, which means
that no settings have been saved to the file header.

NOTE

when you select and play the waveform in the future.

If asetting isunspecified in the file header, the signal generator’s current value for that setting does not change

The Current Inst. Settings column showsthe current signal generator settings for the active modulation.
These settings become the saved header settings when they are saved to the file header (as demonstrated in Step 2).

Figure 3-2Custom Digital M odulation Default Header Display
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[————— Default Header Settings

Settings column to the file header:
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settings; the Saved Header Settings column liststhe settings saved in the file header.

Thefile header contains the following signal generator settings:

32—Character
Description:

Sample Rate:

Runtime Scaling:

Marker 1...4 Polarity:

ALC Hold Routing:
RF Blank Routing:

1/Q Mod Filter:
1/Q Output Filter:

Mod Attenuation:

A description entered for the header, such as athe waveform’s function (saved/edited with the Edit Description key,
see Figure 3-2 on page 80).

The ARB sample clock rate.

The Runtime scaling value. Runtime scaling is applied in real-time while the waveform is playing. This setting can
be changed only for filesin the dual ARB player.

The marker polarity, positive or negative (described on page 109).

Which marker, if any, implements the PSG's ALC hold function (described on page 96).

Which marker, if any, implements the PSG's RF blanking function (described on page 107).

The I/Q modulator filter setting. The modulator filter affects the 1/Q signal modulated onto the RF carrier.

The1/Q output filter setting. The I/Q output filter is used for 1/Q signals routed to the rear panel | and Q outputs.

The 1/Q modulator attenuation setting.
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10.

Return to the ARB Setup menu: Press Return.

In the ARB Setup menu (shown in Figure 3-3), you can change the current instrument settings. Figure 3-3 also
shows the softkey paths used in steps four through nine.

Set the ARB sample clock to 5 MHz: Press ARB Sample Clock >5> MHz.

Set the modulator attenuation to 15 dB:
PressMore (1 of 2) > Modulator Atten n.nn dB Manual Auto to Manual > 15 > dB.

Set the 1/Q modulation filter to a through:
Press1/Q Mod Filter Manual Auto to Manual > Through.

Set marker one to blank the RF output at the set marker point(s):
PressMore (2 of 2) > Marker Utilities> Marker Routing > Pulse/RF Blank > Marker 1.

For information on setting markers, see “Using Waveform Markers” on page 94.

Set the polarity of Marker 1 negative:
Press Return > Marker Polarity > Marker 1 Polarity Neg Posto Neg.

Return to the Header Utilities menu: Press Return > Return > Header Utilities.

Noticethat the Current Inst. Settings column now reflects the changes made to the current signal generator
setup in steps 4 through 8, but that the saved header values have not changed (as shown in Figure 3-4 on page 84).

Save the current settings to the file header: Press Save Setup To Header softkey.

The settings from the Current Inst. Settings column now appear inthe Saved Header Settings
column. The file header has been modified and the current instrument settings saved. Thisis shown in Figure 3-5
on page 84.

While a modulation format is active (is on), the waveform file (AUTOGEN_WAVEFORM) plays and you can modify
the header information within the active modulation format. Once you turn the modulation format off, the header
information is available only through the dual ARB player.

NOTE If you turn the modulation format off and then on, you overwrite the previous AUTOGEN_WAVEFORM file

and itsfile header. To avoid this, rename the file before you turn the modulation format back on (see page 94).

Storing awaveform file (see page 93) stores the saved header information with the waveform.
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Figure 3-4 Differing Values between Header and Current Setting Columns
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Storing Header Information for a Dual ARB Player Waveform Sequence

When you create a waveform sequence (described on page 91), the PSG automatically creates a default file header,
which takes priority over the headers for the waveform segments that compose the waveform sequence. During a
waveform sequence playback, the waveform segment headers are ignored (except to verify that al required options are
installed). When you store the waveform sequence, its file header is stored with it.

M odifying and Viewing Header Information in the Dual ARB Player

Once amodulation format is turned off, the waveform file is available only to the dual ARB player. Thisis also true for
downloaded waveform files. Because of this, future edits to awaveform’s header information must be performed using
the dual ARB player.

To modify header information in the dual ARB player, the waveform file must be playing in the dual ARB player
(although you can view the header information in the dual ARB player without playing the file)

You can reapply saved header settings by reselecting the waveform file for playback. When you do this, the values from
the Saved Header Settings column are applied to the PSG

Modifying Header I nformation

All of the same header characteristics shown in Modifying Header Information in a Modulation Format arevalid in
the dual ARB player. This task guides you through selecting awaveform file and accessing the header for the selected
file, then refers you back to the aforementioned procedure to perform the modifications.

1. Select awaveform:
a PressMode> Dual ARB > Select Waveform.
b. Using the arrow keys, highlight the desired waveform file.
c. Pressthe Select Wavefor m softkey.
Play the waveform: Press ARB Off On to On.
Access the header: Press ARB Setup > Header Utilities.
Refer to “Modifying Header Information in a Modulation Format” to edit the header information:

»  For adefault header, read the information in step one on page 80, then perform the remaining stepsin the
procedure.

* To modify an existing file header, start with step three on page 82.
The rest of this section focuses on the additiona file header operations found in the dual ARB player.
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Viewing Header Information with the Dual ARB Player Off

One of the differences between a modulation format and the dual ARB player is that even when the dual ARB player is
off, you can view afile header. You cannot, however, modify the displayed file header unless the dual ARB player ison,
and the displayed header is selected for playback. With the dual ARB player off, perform the following steps.
1. Select awaveform:

a PressMode> Dual ARB > Select Waveform.

b. Highlight the desired waveform file.

c. Pressthe Select Wavefor m softkey.

2. Accessthefile header: Press ARB Setup > Header Utilities.

The header information is now visible in the PSG display. As shown in Figure 3-6, the header editing softkeys are
grayed—out, meaning they are inactive.

Figure 3-6Viewing Header I nfor mation

FREQLEMCY AMPLITUCE N
44.000 000 000 000 &= | -130.00 den y
Header editing softkeys
ARE HIHD — grayed-out
EHULP| 1/0 o gray u
File Header Information: WFM1:DOC_EH
Header Field Saved Header Settings  Current Inst. Settings View
[[] Description DOC_EH Differenth
Header
Sarl‘l:!]_.e Fate _ 5.0000 MHz 2.0000000 MHz
ﬁunﬁlrrelsgailng_t 32-02_2 :5-00 “ File header information and
arker olarity eoat ive g ¢
Marker 2 Polarity Positive Fos curr_ent Slgnal generator
Marker 3 Polarity Positive Meg Pace U settings
Marker L Polarity Positive Mea @oe UP “Wh h |
ALC Hold Routing  Monme Marker 2 Note: When the dual ARB
| | Alt Amel. Routing  MNone None player is off, the current
Page Doqn instrument settings column
does not update; the values
[ FF Blank Routing  Marker 1 Marker 1 \ displayed may not be valid.
High Crest. Mode Off Off Page 1
Mod Attenuation 15.000 dB 2.52 dB
I/0 Mod Filter Through LO.000 HHz
I/0 Dutput Filter  Auto L0.000 MHz
— Page 2

86 Keysight PSG Signal Generators User’s Guide



Viewing Header Information for a Different Waveform File

Basic Digital Operation
Arbitrary (ARB) Waveform File Headers

While awaveform is playing in the dual ARB player, you can view the header information of a different waveform file,
but you can modify the header information only for the waveform that is currently playing. When you select another

waveform file, the header editing softkeys are grayed—out (see Figure 3-6). This task guides you through the available
viewing choices.

1. View thewaveformfilelist: PressMode > Dual ARB > ARB Setup > Header Utilities> View Different Header.
Asshown in Figure 3-7, thereis an alphabetical list of waveform filesin the table.

Figure 3-7Waveform File List for Viewing a Different Header
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View all waveform segments in non—volatile memory:

Current waveform file type

Seq

HFH1

a. Pressthe Catalog Type softkey. As shown in Figure 3-7, you have a choice of three waveform file types that

can be displayed in the table accessed in step one.

NVWFM displays all waveform segments stored in non—volatile memory
Seq displays all waveform sequence files
WFM1 displays all waveform segments stored in volatile memory

b. Pressthe NVWFM softkey. The table displays the waveform files in non—volatile memory.

3. View awaveform file's header information: Highlight afile and pressthe View Header softkey.

The header information for the selected waveform file appearsin the PSG display. If thereisawaveform playing, its
header information is replaced by this information, but the waveform settings used by the signal generator do not
change. To return to the header information for the playing waveform, either press View Different Header, select

the current playing waveform file, and press View Header, or
press Return > Header Utilities.
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Playing a Waveform File that Contains a Header

After awaveform file (AUTOGEN_WAVEFORM) is generated in amodulation format and the format is turned off, the
file becomes accessible to and can only be played back by the dual ARB player. Thisistrue for downloaded waveform

files (downloading files is described in the Keysight Signal Gener
selected for playback, the saved header information is used by the

ators Programming Guide). When the waveformiis
signal generator. Some of these settings appear as part

of the labels of the softkeys used to set the parameters, and also appear on the dual ARB summary display (see

Figure 3-8).

NOTE Thesignal generator used to play back a stored waveform file must have the same options as are required to

generate thefile.

For details on applying file header settings and playing back awaveform, see “Playing a Waveform” on page 92.

To properly set up the instrument:

1. Select the waveform.
2. Modify the signal generator settings as desired.
3. Turnonthedua ARB.

Figure 3-8 File Header Settings
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Using the Dual ARB Waveform Player

The dual arbitrary (ARB) waveform player is used to create, edit, and play waveform files. There are two types of waveform
files: segments and sequences. A segment isawaveform file that is created using one of the signal generator’s pre—defined ARB
formats. A sequence can be described as several segments strung together to create one waveform file. Waveform files can also
be created remotely using another signal generator or using computer programs and downloaded to the PSG for playback by the
Dual ARB waveform player. For information on downloading waveforms, refer to the Keysight Sgnal Generators Programming
Guide.

A waveform fileis automatically generated whenever an ARB modulation format is turned on. This automatically generated file
isnamed AUTOGEN_WAVEFORM. Because this default file nameis shared among all ARB formats, it must be renamed if you
want to save the information. If the file is not renamed, it will be overwritten when another ARB format is turned on.

The Dual ARB waveform player provides markers (page 94), triggering (page 109), and clipping (page 115) capabilities.

Before you can work with any waveform file, it must reside in volatile memory. The signal generator has two types of memory,
WFM1 (volatile waveform memory) and NVWFM (non—volatile waveform memory). A newly generated waveform file
(AUTOGEN_ WAVEFORM), created when the Arb Waveform Generator is turned on, initially residesin WFM 1. If you want to save
thisfile, renameit and store it in NVWFM. Load a stored waveform file from NVWFM into volatile memory (WFM 1) where it
can be edited or played by the ARB waveform player. Refer to Custom Modulation for more information.

Accessing the Dual ARB Player

Press Mode > Dual ARB.
Thisfirst-evel softkey menu is shown in the following figure. Most procedures start from this menu.
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Creating Waveform Segments

There are two ways to provide waveform segments for use by the waveform sequencer. You can either download a
waveform via the remote interface, or generate a waveform using one of the ARB modulation formats. For information
on downloading waveforms via the remote interface, see the Keysight Sgnal Generators Programming Guide.

A waveform sequence is made up of segments but can also contain other sequences. Any number of segments, up to
32768, can be used to create a sequence. Thislimit count is determined by the number of segmentsin the waveform
sequence. Segments and sequences can be repeated within a waveform sequence and the total of all segments and
repeated segments cannot exceed the limit count. The following diagram shows a waveform sequence made up of two
sequences and three segments. In this example the segment count is eleven.

Figure 3-9 Waveform Sequence Diagram

Sequence B
Fepeated 4x

Sedqment @

Sequence E\_|: Seqment T
Seqment M
The following procedure describes how to create two waveform segments, then name and store them in ARB memory.

After you name and store the two waveform segmentsin ARB memory, you can use them to build awaveform sequence,
as described on page 91.

Sequence A

Wave form
Sequence

1. Generatethefirst waveform:

a PressPreset > Mode > Two Tone > Alignment Left Cent Right to Right.

b. Press Two Tone Off On to On, then to Off.
You turn off the Two Tone mode after generation because a waveform cannot be renamed as a segment while it
isinuse.

This generates a two tone waveform with the tone on the right placed at the carrier frequency. During waveform
generation, the T-TONE and I/Q annunciators activate. The waveform is stored in volatile memory, with the default
file name AUTOGEN WAVEFORM.

NOTE Because there can be only one AUTOGEN WAVEFORM Waveform in memory at any given time, you must
rename thisfile to clear the way for a second waveform.
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2. Create the first waveform segment:

Press Mode > Dual ARB > Waveform Segments > Load Storeto Store.

Highlight the default segment AUTOGEN WAVEFORM.

Press Rename Segment > Editing Keys > Clear Text.

Enter afile name (for example, TTONE), and press Enter > Sore Segment To NVWFM Memory.
This renames the waveform segment, and stores a copy in non volatile memory.

oapow

3. Generate the second waveform:

a. Press Mode > Multitone > Initialize Table > Number Of Tones> 9 > Enter > Done.
b. Press Multitone Off On to On, then Off.
Remember that a waveform cannot be renamed as a segment whileitisin use.

This generates a multitone waveform with nine tones. During waveform generation, the M-TONE and I/Q
annunciators activate. The waveform is stored in volatile memory with the default file name AUTOGEN WAVEFORM.

4. Create the second waveform segment:
Repeat Step 2, giving this segment a descriptive name (for example, MTONE).

Building and Soring a Waveform Sequence

This example shows how to build and edit a waveform sequence using the two waveform segments created on page 90.
To use a segment in a sequence, the segment must reside in volatile memory; for information on loading waveform
segments from non volatile to volatile memory, see page 93.

1. Select the waveform segments:

Define a sequence as one repetition of the two-tone waveform segment followed by one repetition of the nine-tone
multitone waveform segment.

a PressMode > Dual ARB > Waveform Sequences > Build New Waveform Segquence > Insert Waveform.
b. Highlight the awaveform segment (for example, TTONE) and press | nsert Selected Waveform.
c. Highlight a second waveform segment (for example, MTONE) and press I nsert Selected Waveform.
d. PressDonelnserting
2. Optional: Enable markers as desired for the segmentsin the new segquence: see page 104.
3. Name and store the waveform sequence to the Catalog of Seqg Files inthe memory cataog:
a PressNameand Store.
b. Enter afile name (for example, TTONE+MTONE).
C. PressEnter.
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Playing a Waveform

This procedure applies to playing either a waveform segment or a waveform sequence.
This example plays the waveform segquence created in the previous procedure.

1. Select awaveform sequence:
a. PressMode > Dual ARB > Select Waveform.

b. Highlight awaveform sequence (for this example, TTONE+MTONE) from the Sequence column of the Select
Waveform catalog, and press Select Waveform.

The display shows the currently selected waveform
(for example, Selected Waveform: SEQ:TTONE+MTONE).

2. Generate the waveform:
Press ARB Off On to On.

This plays the sel ected waveform sequence.
During the waveform sequence generation, the ARB and I/Q annunciators activate.

Editing a Waveform Sequence

This example shows how to edit waveform segments within awaveform sequence, and then save the edited sequence
under a new name. Within the editing display, you can change the number of times each segment plays (the repetitions),
delete segments, add segments, toggle markers (described on page 104), and save changes.

NOTE If you do not store changes to the waveform segquence prior to exiting the waveform sequence editing display,
the changes are removed.

Press Waveform Sequences > Edit Selected Waveform Sequence, and highlight the first entry.
Press Edit Repetitions> 100 > Enter. The second segment is automatically selected.

Press Edit Repetitions > 200 > Enter.

Save the edited file as a new waveform sequence:

A WD PR

a PressName And Store.
b. PressEditing Keys> Clear Text, then enter a new file name (for example, TTONE100+MTONE200).
c. PressEnter.

You have now changed the number of repetitions for each waveform segment entry from 1 to 100 and 200, respectively.
The seguence has been stored under anew nameto the Catalog of Seq Files inthesigna generator’s memory
catalog.

For information on playing a waveform sequence, refer to page 92.
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Adding Real-Time Noise to a Dual ARB Waveform (E8267D with Option 403)

The signal generator with option 403 can apply AWGN (additive white gaussian noise) to acarrier in real time whilethe
modulating waveform fileis being played by the Dual ARB waveform player. The AWGN can be configured using front
panel softkeys. The Carrier to Noise Ratio softkey allows you to specify the amount of noise power relative to carrier
power that is applied to the signal. The Carrier Bandwidth softkey sets the bandwidth over which the noiseis
integrated and the Noise Bandwidth Factor softkey allows you to select aflat noise bandwidth. The Output M ux
softkey enables diagnostic control of additive noise, so that only the noise, only the carrier, or the sum of both the noise
and the carrier are output from the internal baseband generator. With the AL C off, this feature enables direct
measurement of the carrier or the noise contributions independently from the total power. The system still behaves asif
both the noise and the carrier are present on the output when it comes to determining the Auto Modulation Attenuation
and the RMS level for RMS Power Search.

These softkeys are described in the Keysight PSG Signal Generators Key Reference.

The following procedure sets up a carrier and modulates it using the pre—defined SINE_TEST_WFM waveform file.
AWGN isthen applied to the carrier.

Configuring AWGN
Preset the signal generator. Press the Preset hardkey.

Pressthe Freguency hardkey and enter 15 GHz.

Press the Amplitude hardkey and enter —10 dBm.

Press RF On Off to On.

Press Mode > Dual ARB > Select Waveform and select the SINE_TEST_WFM waveform.
Press Select Waveform.

Press ARB Off On to On.

Press ARB Setup > ARB Sample Clock enter 50 MHz.

Press Real-time Noise Setup > Carrier to Noise Ratio and enter 30 dB.

10. Press Carrier Bandwidth and enter 40 MHz.

11. Press Real-time Noise Off On to On.

© o N o g~ w NP

This procedure applies AWGN to the 15 GHz carrier. The displayed power level of the signal generator, —10 dBm, will
include the noise power which is set as a carrier to noise ratio (C/N) of 30 dB. Noise power, for the purpose of C/N, is
applied across acarrier bandwidth of 40 MHz. The default noise bandwidth factor is 1, which provides aflat noise signal
bandwidth of aleast 0.8 times the 50 MHz sample rate.

Storing and L oading Waveform Segments

Waveform segments can reside in volatile memory as WFM 1 files, or they can be stored to non—volatile memory as
NVWFM files, or both. To play or edit awaveformfile, it must reside in volatile memory. Becausefiles stored in volatile
memory do not survive apower cycle, itisagood practice to store important files to non—volatile memory and load them
to volatile memory whenever you want to use them.

Soring Waveform Segmentsto Non—-volatile Memory
1. PressMode > Dual ARB > Waveform Segments.

2. If necessary, press Load Storeto Store.
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3. PressSoreAll ToNVWFM Memory.

Copies of all WFM1 waveform segment files have been stored in non—volatile memory as NVWFM files. To storefiles
individually, highlight the file and press Sore Segment To NVWFM Memory.

L oading Waveform Segments from Non—volatile Memory
1. Clear out the volatile memory and delete all WFM 1 files: Power cycle the instrument.

2. PressMode > Dual ARB > Waveform Segments.
3. If necessary, press L oad Storeto Load.
4. PressLoad All From NVWFM Memory.

Copies of all NVWFM waveform segment files have been |oaded into volatile memory as WFM 1 files.
To load filesindividually, highlight the file and press L oad Segment From NVWFM Memory.

Renaming a Waveform Segment

1. PressMode > Dual ARB > Waveform Segments.

2. Highlight the desired file and press Rename Segment > Editing Keys > Clear Text.
3. Enter the desired file name and then press Enter.

Using Waveform Markers

The signal generator provides four waveform markers to mark specific points on a waveform segment. When the signal
generator encounters an enabled marker, an auxiliary output signal is routed to the rear panel event connector (described
in Rear Panel) that corresponds to the marker number. You can use this auxiliary output signal to synchronize another
instrument with the waveform, or as atrigger signal to start a measurement at a given point on awaveform.

You can also configure markersto initiate ALC hold, or RF Blanking (which includes ALC hold).

Creating awaveform segment (page 90) also creates a marker file that places amarker point on the first sample point of
the segment for markers one and two. When awaveform file is downloaded that does not have a marker file associated

with it, the signal generator creates a marker file without any marker points. Factory—supplied segments have a marker

point on the first sample for all four markers.

The following procedures demonstrate how to use markers while working in the dual ARB player, but the processisthe
same when working in any ARB format.

These procedures al so discuss two types of points: a marker point and a sample point. A marker point isapoint at which
agiven marker is set on awaveform; you can set one or more marker points for each marker. A sample point is one of
the many points that compose a waveform.
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There are three basic steps to using waveform markers:

“1. Clearing Marker Points from a Waveform Segment” on page 101
“2. Setting Marker Points in a Waveform Segment” on page 102

“3. Controlling Markers in a Waveform Sequence (Dual ARB Only)” on page 104
This section also provides the following information:

e “Waveform Marker Concepts” on page 95

¢ “Accessing Marker Utilities” on page 99

¢ “Viewing Waveform Segment Markers” on page 100

e “Viewing a Marker Pulse” on page 106

e “Using the RF Blanking Marker Function” on page 107

e “Setting Marker Polarity” on page 109

Waveform Marker Concepts
The signal generator’s ARB formats provide four waveform markers to mark specific points on a waveform segment.

You can set each marker’s polarity and marker points (on a single sample point or over arange of sample points). Each
marker can also perform ALC hold or RF Blanking and ALC hold.

— J—L Positive ? EVENT N
Marker
File > O | Marker N
Bit N — RF Blank Off On
Set Marker Marker : Marker N
— ) Negative / Blank
On Off Polarit » anks RF
y O— when Marker
: is Low
When the signal generator encounters an enabled marker (described on 1 RF Blank Only: includes ALC Hold
page 104), an auxiliary output signal is generated and routed to the rear g Marker N
panel event connector that corresponds to the marker number (N). /5_ Holds ALC
The EVENT 3 and 4 connectors are pins on the AUXILIARY 1/O connector when Marker
(connector locations are shown in Figure 1-3 on page 21). Is Low

Marker N
ALC Hold Off On
Marker File Generation

Generating awaveform segment (see page 90) automatically creates amarker file that places amarker point on thefirst
sample point of the segment for markers one and two.

Downloading a waveform file (as described in the Keysight Signal Generators Programming Guide) that does not have
amarker file associated with it creates a marker file that does not place any marker points.

Marker Point Edit Requirements

Before you can modify awaveform segment’s marker points, the segment must reside in volatile memory (see “Loading
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Waveform Segments from Non-volatile Memory” on page 94).

In the dual ARB player, you can modify a waveform segment’s marker points without playing the waveform, or while
playing the waveform in an ARB modulation format.

In an ARB modulation format, you must play the waveform before you can modify a segment’s marker points.

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator, or cycle the PSG
power. To ensure that awaveform uses the correct settings when it is played, set the marker polarities or routing (RF
Blanking and ALC Hoald), and save the information to the file header (page 78). Thisis especially important when the
segment plays as part of a sequence because the previously played segment could have different marker and routing
settings.

ALC Hold Marker Function (For Instrumentswith serial prefixes >=USA722/M Y 4722)

While you can set a marker function (described as Marker Routing on the softkey |abel) either before or after you set
marker points (page 102), setting a marker function before setting marker points may cause power spikes or |oss of
power at the RF output.

Usethe ALC hold function by itself when you have awaveform signal that incorporates idle periods, or when the
increased dynamic range encountered with RF blanking (page 107) is not desired.

The ALC hold marker function holds the ALC circuitry at the average (RMS) value of the sampled points set by the
marker(s). For both positive and negative marker polarity, the ALC samples the RF output signal (the carrier plus any
modulating signal) when the marker signal goes high:

Positive: The signal is sampled during the on marker points.
Negative The signal is sampled during the off marker points.

The marker signal has aminimum of atwo sample point delay in its response relative to the waveform signal response.
To compensate for the marker signal delay, offset marker points from the waveform sample at which you want the ALC

sampling to begin.

NOTE Becauseit can affect the waveform’s output amplitude, do not use the ALC hold for longer than 100 ms. For
longer timeintervals, refer to “Setting Power Search Mode” on page 279.

> Markers set early in time
to account for marker response

RF OUTPUT ‘ : >

-‘F. .

<<
Marker n >3 H
- . . <= .
Positive Polarity .
E“- 100 ms :E
. Max ALC hold time '
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CAUTION  Incorrect ALC sampling can create a sudden unleveled condition that may create a spike in the RF output,
potentially damaging aDUT or connected instrument. To prevent this condition, ensure that you set
markersto let the ALC sample over an amplitude that accounts for the higher power levels encountered

within the signal.
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Example of Correct Use

Waveform: 1022 points
Marker range: 95-97
Marker polarity: Positive

This example shows a marker set to sample the waveform'’s area of
highest amplitude. Note that the marker is set well before the
waveform’s area of lowest amplitude. This takesinto account the
response difference between the marker and the waveform signal.

The AL C sampl es the waveform when the marker signal goes
high, and uses the average of the sampled waveform to set the
ALC circuitry.

Here the AL C samples during the on marker points (positive
polarity).

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Positive

This example shows a marker set to sample the low part of the

same waveform, which sets the ALC modulator circuitry for Marker T Mar[;r_
that level; thisusually resultsin an unleveled condition for the
signal generator when it encounters the high amplitude of the

pulse. Pulse Unleveled
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Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Negative

This figure shows that a negative polarity marker goes low during
the marker on points; the marker signal goes high during the off
points. The ALC samples the waveform during the off marker
points.

< Marker On

Sample range begins on first point of signal

Sampling both on and off time sets the modulator circuitry

incorrectly for higher signal levels. Note the increased amplitude -
at the beginning of the pulse.

Marker Marker
< Marker On s =< Oon *~

Negative range set between signal and
off time

Accessing Marker Utilities

Use the following procedure to display the marker parameters. This procedure uses the Dual ARB player, but you can
access the marker utilities through the ARB Setup softkey in all ARB formats.

1. Select the ARB waveform player:
press Mode > Dual ARB
2. Press ARB Setup > Marker Utilities.
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ARE Sample Clock
100,0000000 MHz

Select
M ARE Reference
Haveform Ewt.
Haveform,)
Seaments
Haveform,
Sequences UE?E?E?EE' Marker Polaritud
ARE Setup > Marker ; .
Utilitiesh P Marker Routings When using an ARB format other than
Trigger Dual ARB, you must turn on the format
H L
(Cont indous ) Ut TR (et narkers.>/to enable the Set Markers softkey.

More
(1 of 21

NOTE Most of the procedures in this section begin at the Marker Utilities softkey menu.

Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the markers set for a segment (this example
uses the factory—supplied segment, SINE_TEST WFM).

1. Inthe Marker Utilities menu (page 99), press Set Markers.

2. Highlight the desired waveform segment.
In an ARB format, thereis only onefile (AUTOGEN WAVEFORM) and it is already highlighted.

3. PressDisplay Markers> Zoom in Max. The maximum zoom in range is 28 points.
Experiment with the Zoom functions to see how they display the markers.

The display can show amaximum of 460 points; displayed waveforms with a sample point range greater than 460 points
may not show the marker locations.
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FREQUENCY

44.000 000 000 000 &tz

Marker Polaritu

Marker Routingh

AMPLITUDE

-130.00 den

#

Y

Set Marker

Catalog of UFM1 Files

Points

200

RAMP_TEST_WFM

Select a segment — |

The Set Marker display -

EN: 3L

Set Marker On
First Point

Set. Marker On)l
Range Of Points

Set. Marker Off)
Range Of Points

Set Marker Off
All Points

Display Markersy

Marker

The display below shows the | and Q components of the waveform, and
the marker points set in a factory—supplied segment.

'

FREQUENCY

44.000 000 000 000 s

AMPLITUDE
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W

Arb laveforn Marker:
UFIT1 -STHE_TEST_UF)

Marker
points on /

A= CU I LN I o N |

firstsample ) Sample Point

28

point

Firgt>
Sample Poin%

Zoom In
Zoom Out
Zoom In FMax

Zoom Out Max

I

1. Clearing Marker Pointsfrom a Waveform Segment

First sample

s~ point shown on

display

These softkeys
change the range
of waveform
sample points
shown on the
marker display.

Each press of the
softkey changes
the sample range
by approximately
a factor of two

When you set marker points they do not replace points that already exist, but are set in addition to existing points.
Because markers are cumulative, before you set points, view the segment (page 100) and remove any unwanted points.

With all markers cleared, the level of the event output signal isOV.

Clearing All Marker Points
1. Inthe Marker Utilities menu (page 99), press Set Markers.

2. Highlight the desired waveform segment.

In an ARB format, thereis only one file (AUTOGEN WAVEFORM) and it is already highlighted.

3. Highlight the desired marker number:
PressMarker 1234.
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4. For the selected marker number, remove all marker pointsin the selected segment:
Press Set Marker Off All Points.

5. Repeat from Step 3 for any remaining marker points that you want to remove.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set across points 10-20. This makes it easy to
see the affected marker points. The same process applies whether the existing points are set over arange (page 102) or
asindividual points (page 103).

1. Inthe Marker Utilities menu (page 99), select the desired marker (for this example, Marker 1).

2. Set thefirst sample point that you want off (for this example, 13):
Press Set Marker Off Range Of Points> First Mkr Point > 13 > Enter.

3. Set thelast marker point in the range that you want off to a value less than or equal to the number of pointsin the
waveform, and greater than or equal to the value set in Step 2 (for this example, 17):
PressLast Mkr Point > 17 > Enter > Apply To Waveform > Return.

This turns off all marker points for the active marker within the range set in Steps 2 and 3, as shown in the
following figure.

Arb laveform Markers
UFITL :RAMP_TEST_UFTI

F WM O

1 Sample Point 28

Viewing markers is described on page 100

Clearing a Single Marker Point

Use the steps described in Clearing a Range of Marker Points, but set both the first and last marker point to the value
of the point you want to clear. For example, if you want to clear amarker on point 5, set both the first and last value to 5.

2. Setting Marker Pointsin a Waveform Segment

To set marker points on a segment, the segment must reside in volatile memory (page 94).

When you set marker points, they do not replace points that already exist, but are set in addition to existing points.
Because markers are cumulative, before you set marker points within a segment, view the segment (page 100) and
remove any unwanted points (page 101).

Placing a Marker Acrossa Range of Points
1. IntheMarker Utilitiesmenu (page 99), press Set Markers.

2. Highlight the desired waveform segment.
In an ARB format, thereis only onefile (AUTOGEN WAVEFORM) and it is already highlighted.

3. Highlight the desired marker number:

102 Keysight PSG Signal Generators User’s Guide



Basic Digital Operation
Using Waveform Markers

PressMarker 1234
4. Set thefirst sample point in the range (in this example, 10):
Press Set Marker On Range Of Points> First Mkr Point > 10 > Enter.

5. Set the last marker point in the range to avalue less than or equal to the number of pointsin the waveform, and
greater than or equal to the first marker point (in this example, 20):

PressLast Mkr Point > 20 > Enter.
6. Press Apply To Waveform > Return.

This sets arange of waveform marker points. The marker signal starts on sample point 10, and ends on sample point 20,
as shown in the following figure.

Arb laveform Markers
UFITL :RAMP_TEST_UFTI

F WM O

1 Sample Point 28

Viewing markers is described on page 100

Placing a Marker on a Single Point
On the First Point
1. IntheMarker Utilities menu (page 99), press Set Markers.

2. Highlight the desired waveform segment.
Inan ARB format, thereis only one file (AUTOGEN WAVEFORM) and it is already highlighted.

3. Highlight the desired marker number:

PressMarker 1234
4. Press Set Marker On First Point.

This sets a marker on the first point in the segment for the marker number selected in Step 3.
On Any Point

Use the steps described in Placing a Marker Across a Range of Points, but set both the first and last marker point to
the value of the point you want to set. For example, if you want to set amarker on point 5, set both thefirst and last value
to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped points) between each
marker. You must set the spacing before you apply the marker settings; you cannot apply skipped points to a previously
set range of points.

1. Remove any existing marker points (page 101).
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Inthe Marker Utilities menu (page 99), press Set Markers.

Highlight the desired waveform segment.
In ARB formats there is only one file (AUTOGEN_WAVEFORM) and it is already highlighted.

4. Highlight the desired marker number: PressMarker 1234

5. Set the first sample point in the range (in this example, 5):
Press Set Marker On Range Of Points> First Mkr Point > 5> Enter.

6. Set thelast marker point in the range to a value less than the number of pointsin the waveform, and
greater than or equal to the first marker point (in this example, 25):
PressLast Mkr Point > 25 > Enter.

7. Enter the number of sample points that you want skipped (in this example, 1):
Press# Skipped Points> 1> Enter.

8. Press Apply To Waveform > Return.

This causes the marker to occur on every other point (one sample point is skipped) within the marker point range, as
shown below.

Arb laveform Markers
UFITL :RAMP_TEST_UFTI

F WM O

1 Sample Point 28

Viewing markers is described on page 100

One application of the skipped point feature is the creation of a clock signal as the auxiliary output.

3. Controlling Markersin a Waveform Sequence (Dual ARB Only)

In awaveform segment, an enabled marker point generates an auxiliary output signal that is routed to the rear panel
event connector (described in Rear Panel) corresponding to that marker number. For awaveform sequence, you enable
or disable markers on a segment—by—segment basis; this enables you to output markers for some segmentsin a
sequence, but not for others. Unless you change the marker settings or cycle the power, the setting remains the same for
the next loaded sequence.

As You Create a Waveform Sequence

After you select the waveform segments to create a waveform sequence, and before you name and save the sequence,
you can enable or disable each segment’s markers independently. Enabling a marker that has no marker points
(page 102) has no effect on the auxiliary outputs.

1. Select the waveform segments (Step 1 on page 91).
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2. Toggle the markers as desired:
a. Highlight the first waveform segment.
b. PressEnable/Disable Markers.

c. Asdesired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.
Toggling amarker that has no marker points (page 102) has no effect on the auxiliary outputs.

An entry in the Mkr column (see figure below) indicates that the marker is enabled for that segment; no entry in
the column means that all markers are disabled for that segment

d. Inturn, highlight each of the remaining segments and repeat Step c.
3. PressReturn.
4. Name and store the waveform sequence (Step 3 on page 91).

The following figure shows a sequence built reusing the same factory—supplied waveform segment; afactory—supplied
segment has a marker point on the first sample for all four markers. In this example, Marker 1 is enabled for the first
segment, Marker 2 is enable for the second segment, and markers 3 and 4 are enabled for the third segment.

Togole Marker 3
SINE_TEST_MFM| (UHSTORED) UNTITLED s Marker Col
(1/2) 5 t 5 e| (1/1) Uaveforn  Repst/fikr equence Marker Column
ALITOGEN_PRAM_1 2KKL2KKM WFHL:SINE_TEST_MFH 1h Togale Marker 4 :
RAMP_TEST_MFH A WFHL:SINE_TEST MFHM 1]z This entry shows that
STHE_TEST_UFN ARz LFML:SINE TEST LEM el )| markers 3and 4 are enabled
EDHPLEE for this segment.

For each segment, only the markers enabled for that segment produce arear panel auxiliary output signal. In this
example, the Marker 1 auxiliary signal appears only for the first segment, because it is disabled for the remaining
segments. The Marker 2 auxiliary signal appears only for the second segment, and the marker 3 and 4 auxiliary signals
appear only for the third segment.

In an Existing Waveform Sequence

If you have not already done so, create and store a waveform sequence that contains at |east three segments (page 91).
Ensure that the segment or segments are available in volatile memory (page 94).

1. PressMode > Dual ARB > Waveform Sequences, and highlight the desired waveform sequence.
2. PressEdit Selected Waveform Sequence, and highlight the first waveform segment.

3. PressEnable/Disable Markers> Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.
Toggling amarker that has no marker points (page 102) has no effect on the auxiliary outputs.

An entry in the Mkr column indicates that the marker is enabled for that segment; no entry in the column means that
al markers are disabled for that segment

Highlight the next waveform segment and toggle the desired markers (in this example, markers 1 and 4).
Repeat Step 4 asdesired (for this example, select the third segment and toggle marker 3).
Press Return > Name And Store > Enter.

The markers are enabled or disabled per your selections, and the changes have been saved to the selected sequence file.
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Viewing a Marker Pulse

When awaveform plays (page 92), you can detect a set and enabled marker’s pulse at the rear panel event connector
that corresponds to that marker number. This example demonstrates how to view a marker pulse generated by a
waveform segment that has at |east one marker point set (page 102). The processis the same for awaveform sequence.

This example uses the factory—supplied segment, SINE_TEST WFM inthe Dual ARB Player. Factory—supplied segments
have a marker point on the first sample point for al four markers, as shown.

Arb laveform Markers
UFITL :STHE_TEST_UFTI

Marker points on
first sample point of
waveform segment

oW hJ:>Y‘5 —
=

Sample Point

28

Viewing markers is described on page 100

1. PressMode > Dual ARB > Select Waveform, and highlight the desired segment (in this example,
SINE TEST WFM).
Press ARB Off On to On.
Connect an oscilloscope input to the EVENT 1 connector, and trigger on the Event 1 signal.
When a marker is present, the oscilloscope displays a marker pulse, as shown in the following example.
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RF Output

Marker pulse on the Event 1 signal.

Using the RF Blanking Marker Function

While you can set amarker function (described as Marker Routing on the softkey |abel) either before or after setting
the marker points (page 102), setting a marker function before you set marker points may change the RF outpuit.

RF Blanking includes AL C hold (described on page 96, note Caution regarding unleveled power). The signal generator
blanks the RF output when the marker signal goes low.

1. Using the factory—supplied segment SINE_TEST WFM, Set Marker 1 across points 1-180 (page 102).
2. FromtheMarker Utilities menu (page 99), assign RF Blanking to Marker 1:
PressMarker Routing > Pulse/RF Blank > Marker 1.
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Marker Polarity = Positive
RF Signal When marker polarity is positive (the
f i

default setting), the RF output is blanked
during the off maker points.
i |

| | | [ 1
oA 1f
(L [

II| || || |
A
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Marker Polarity = Negative

When marker polarity is negative, the
RF output is blanked during the on
maker points

ov

|- Segment—— |

108 Keysight PSG Signal Generators User’s Guide



Basic Digital Operation
Triggering Waveforms

Setting Marker Polarity

Setting a negative marker polarity inverts the marker signal.
1. IntheMarker Utilitiesmenu (page 99), press Marker Polarity.
2. Select the marker polarity as desired for each marker number.

. . |[1Erker 1 Polarit
Marker Polarity > Neg el Default Marker Polarity = Positive
Marker Routingl Marker ZNESl%

Set each marker polarity independently.

Set Markersh Marker SNESlariti

Harter b Polarit See Also: “Saving Marker Polarity and Routing Settings” on
Neg Rl page 96.

As shown on page 107:
Positive Polarity: On marker points are high (=3.3V).
Negative Polarity: ~ On marker points are low (0V).

Triggering Wavefor ms

Triggering is available in both ARB and real-time formats. ARB triggering controls the playback of awaveform file;
real-time custom triggering controls the transmission of a data pattern. The examples and discussionsin this section use
the Dual ARB Player, but the functionality and method of access (described on page 111) are similar in al (ARB and
real-time) formats.

Triggers control data transmission by telling the PSG when to transmit the modulating signal. Depending on the trigger
settings, the data transmission may occur once, continuously, or the PSG may start and stop the transmission repeatedly
(Gated mode).

A trigger signal comprises both positive and negative signal transitions (states), which are also called high and low
periods; you can configure the PSG to trigger on either state. It is common to have multiple triggers, also referred to as
trigger occurrences or trigger events, occur when the signal generator requires only a single trigger. In this situation, the
PSG recognizes the first trigger event and ignores the rest.

When you select atrigger mode, you may lose the signal (carrier plus modulation) from the RF output until you trigger
the modulating signal. Thisis because the PSG setsthe | and Q signalsto zero volts prior to the first trigger event, which
suppresses the carrier. If you create a data pattern with theinitial | and Q voltages set to values other than zero, this does
not occur. After the first trigger event, thesignal’sfinal | and Q levels determine whether you see the carrier signal or not
(zero = no carrier, other values = visible carrier). At the end of most data patterns, thefinal | and Q points are set to a
value other than zero.

There are four parts to configuring a waveform trigger:

Source determines how the PSG receives the trigger that initiates waveform play.

Mode determines the waveform’s overall behavior when it plays.

Response determines the specifics of how the waveform responds to a trigger.

Polarity determines the state of the trigger to which the waveform responds (used only with an external trigger
source); you can set either negative, or positive.
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Source

(Patt Trio In 1)

Triager Keu4+@——The Trigger hardkey

Bus f&——A command sent through the rear panel GPIB, LAN, or Auxiliary (RS-232) interface

An external trigger signal applied to either the PATTERN TRIG IN connector, or the PATT TRIG IN 2

Ext 1 ) ) o
* pin on the AUXILIARY 1/O connector (connector locations are shown in Figure 1-3 on page 21).
Ext Source, The following parameters affect an external trigger signal:

« The source (Input connector) of the external trigger signal (see page 111)
Ext Polarity

Fos « The polarity of the external trigger (described on page 111)
Ext Delay » Any desired delay between when the PSG receives an external trigger and when the
I On

Mode and Response

The arbitrary waveform player provides four trigger modes; each mode has one or more possible responses:

Single plays the waveform once. Arb formats have the following retriggering options:

— Off ignores triggers received during play; atrigger received after playback completes restarts the playback.
— On causes atrigger received during play to repeat the waveform after the current play compl etes.
— Immediate causes atrigger received during play to immediately restart the waveform.

Gated causes the waveform to wait for the first active trigger signal state to begin transmission, then repeatedly start
and stop in response to an externally applied gating signal (example on page 112). You select the active state with
the Gate Active L ow High softkey (see page 111).

In an ARB format, the waveform plays during the inactive state, and stops during the active state.
In real—time Custom, behavior depends on whether the signal incorporates framed or unframed data.

Because the PSG provides only unframed data, to transmit aframed data signal you must create an external file that
incorporates the framing and download it to the PSG (see the Keysight Sgnal Generators Programming Guide).

— Unframed data transmits during active states, and stops during inactive states. The signal stops at the last
transmitted symbol and restarts at the next symbol.

— Framed data starts transmitting at the beginning of aframe during active states, and stops at the end of aframe
when the end occurs during inactive states. If the end of the frame extends into the next active state, the signal
transmits continuously.
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¢ Segment Advance (Dua ARB only) causes a segment in a sequence to require atrigger to play. The trigger source
controls how play moves from segment to segment (example on page 114). A trigger received during the last
segment loops play to the first segment in the sequence. You have two choices as to how the segments play:

— Single causes a segment in a sequence to play once, then to stop and wait for atrigger before advancing to the
next segment, which playsto completion. Triggers received during play cause the current segment to finish, then
play advances to the next segment, which plays to completion.

— Continuous causes a segment in a sequence to play continuously until the waveform receives another trigger.
Triggersreceived during play cause the current segment to finish, then play advancesto the next segment, which

plays continuously.

« Continuous repeats the waveform until you turn the signal off or select another waveform, trigger mode, or
response. Continuous has the following options:

— Free Run immediately triggers and plays the waveform; triggers received during play are ignored.
— Trigger & Run plays the waveform when atrigger is received; subsequent triggers are ignored.
— Reset & Run (not available in real—time Custom) plays the waveform when atrigger is received; subsequent

triggers restart the waveform.

Accessing Trigger Utilities

The following figures show the menus for the trigger parameters. These figures show the Dual ARB player, but you can
access the trigger utilities through the Trigger softkey in all ARB formats, and the Pattern Trigger softkey in the Real

Time 1/Q Baseband (Custom) format.

Select
Haveform

Trigger
(Continuous? =

Continuous

Haueform, single
Haveform,

Sequences” Gated
ARE SetupM Seament. Advance

> Triogger Setupk

.

Trigger Source
(Ext)

Cont inuous Mode|
(Free Fun)

Retrigger Mode,)
on

Seo Advance Mode,|
(Continuous?

Gate Aochive
Lov  IEHE

\i

Trigger Ked

Bus

Ext

Ext Source,
(Patt Trig In 1)

Ext Polarity
IE=l Fos

Ext [elad
I On

Ext Delay Time
1.00000000 meec

« Todisplay the trigger modes, press Mode > Dual ARB > Trigger.

PATTERN TRIG IN connector

Patt Trio In 1

Fatt Trio In 2

PAT TRIG IN 2 pin on
the AUXILARY 1/O connector

Active only when
Ext is selected.

* Todisplay the response selections available for agiven trigger mode, press Trigger Setup, then select the desired
trigger mode. To seethe selectionsfor Single modein an ARB format, select Retrigger M ode; in real—time Custom,
selecting Single mode causes the data pattern to play once when triggered.

* Todisplay the trigger source options, press Trigger Setup > Trigger Source.

Setting the Polarity of an External Trigger

Gated Mode

The selections available with the gate active parameter refer to the low and high states of an external trigger signal. For
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example, when you select High, the active state occurs during the high of the trigger signal.

ARB Formats When the active state occurs, the PSG stops the waveform file playback at the last played sample
point, and restarts the playback at the next sample point when the inactive state occurs.

Real-Time Custom  When the active state occurs, the PSG transmits the data pattern. When the inactive state occurs,
the transmission stops at the last transmitted symbol, and restarts at the next symbol when the
active state occurs.

Continuous, Single, or Segment Advance M odes

The Ext Polarity Neg Pos softkey selections refer to the low (negative) and high (positive) states of an external trigger.
With Neg selected (the default), the PSG responds during the low state of the trigger signal.
Using Gated Triggering

Gated triggering enables you to define the on (playback) and off states of a modulating waveform. This example usesthe
factory supplied segment, SINE_TEST WFM.

1. Connect the output of afunction generator to the signal generator’s rear panel PATTERN TRIG IN, as shown in the
following figure.

Function Generator
N

pooooooos O
ooooooos o

&--.
AN

R PATTERN R
Signal Generator TRIG IN Oscilloscope
— S e NG
g EEEE o] — oooo ofee——)
ooog O
5o oo (OLLPPwN
ooo g © ® ©® ©
Doo 000 O ocooooooo ?
=—=— ——|ooonoooo O 8 S 8
=] OOOQ S Qoo 0 oo Q@ ®© @ o

RF OUTPUT § Channel 1
H
i
&

Channel 2

(O

This connection is applicableto all external triggering methods. The optional oscilloscope connection enablesyou to
see the effect that the trigger signal has on the RF output.

2. Preset the signa generator.
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3. Configurethe carrier signal output:

*  Set the desired frequency.
e Set the desired amplitude.
e Turn on the RF output.

4. Select awaveform for playback (sequence or segment):
a Preset the signal generator.
b. PressMode> Dual ARB > Select Waveform.
c. Highlight awaveform file (for this example, SINE_TEST WFM).
d. Press Select Waveform.
5. Select the waveform trigger method:
a  PressTrigger > Gated.

b. PressTrigger > Trigger Setup and note that for the Gate Active Low High softkey, the default selectionis
High, which isthe selection used in this example.

6. Select the trigger source and rear panel input:

a Forthe Trigger Source softkey, the default selection is Ext, which is the selection used in this example (gated
triggering requires an external trigger).

b. PressTrigger Source and note that for the Ext Sour ce softkey, the default selectionis Patt Trig In 1, whichis
the selection used in this example.

7. Generate the waveform:
Press ARB Off On to On.
On the function generator, configurea TTL signal for the external gating trigger.
(Optional) Monitor the current waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external triggering signal. You
will see the waveform modulating the output during the gate inactive periods (low).

The following figure shows an example display.
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Modulating Waveform RF Output

N
S W \M\*ﬁ&/’ gl

]

Externally Applied Gating Signal
Gate Active = High

NOTE Inthe real-time Custom mode, the behavior isreversed: when the gating signal is high, you see the modul ated
waveform.

Using Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within awaveform sequence. The following
example uses awaveform sequence that has two segments.

If you have not created and stored a waveform sequence, complete the steps in the sections, “Creating Waveform
Segments” on page 90, and “Building and Storing a Waveform Sequence” on page 91.

1. Preset the signa generator.
2. Configure the RF output:

e Set thedesired frequency.
e Set the desired amplitude.
e Turn on the RF output.

3. Select awaveform sequence for playback:
a PressMode> Dual ARB > Select Waveform.
b. Highlight awaveform sequencefile.
C. PressSelect Waveform.
4. Select the waveform trigger method and trigger source:
a. PressTrigger > Segment Advance.

b. PressTrigger > Trigger Setup and note that the Seg Advance M ode softkey displays the default selection
(Continuous), which is the selection used in this example.

c. PressTrigger Source> Trigger Key.
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5. Generate the waveform sequence:
Press Return > Return > ARB Off On to On.

6. Trigger the first waveform segment to begin playing repeatedly:
Pressthe Trigger hardkey.

7. (Optional) Monitor the current waveform:

Connect the output of the signal generator to theinput of an oscilloscope, and configure the oscilloscope so that you
can see the output of the signal generator.

8. Trigger the second segment:
Pressthe Trigger hardkey.

The second segment in the sequence now plays. Pressing the Trigger hardkey causes the current playback to finish
and the next segment to start; when the last segment plays, pressing the Trigger hardkey causes the first segment in
the waveform sequence to start when the current segment finishes.

Using Waveform Clipping

Waveforms with high power peaks can cause intermodulation distortion, which generates spectral regrowth (acondition
that interferes with signalsin adjacent frequency bands). The clipping function enables you to reduce high power peaks
by clipping the | and Q data to a selected percentage of its highest peak.

The clipping feature is available only with the Dual ARB mode.

How Power Peaks Develop

To understand how clipping reduces high power pesks, it isimportant to know how the peaks develop asthe signal is
constructed.

1/Q waveforms can be the summation of multiple channels (see Figure 3-10). Whenever most or all of the individual
channel waveforms simultaneously contain abit in the same state (high or low), an unusually high power peak (negative
or positive) occurs in the summed waveform. This does not happen frequently because the high and low states of the bits
on these channel waveforms are random, which causes a cancelling effect.
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Figure 3-10Multiple Channel Summing
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i

Summed Ior Q Waveform

The |l and Q waveforms combine in the 1/Q modulator to create an RF waveform. The magnitude of the RF envelopeis

determined by the equation 112+Q2, where the squaring of | and Q always resultsin a positive value.

Asshownin Figure 3-11, simultaneous positive and negative peaksin the | and Q waveforms do not cancel each other,
but combine to create an even greater peak.
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Figure 3-11Combining the | and Q Waveforms
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How Peaks Cause Spectral Regrowth

Because of the relative infrequency of high power peaks, awaveform will have a high peak—to—average power ratio (see
Figure 3-12). Because atransmitter’s power amplifier gain is set to provide a specific average power, high peaks can
cause the power amplifier to move toward saturation. This causes intermodulation distortion, which generates spectral
regrowth.
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Figure 3-12Peak—to-Aver age Power

———————————————— Peak Power

Average Power

Spectral regrowth is arange of frequencies that develops on each side of the carrier (similar to sidebands) and extends
into the adjacent frequency bands (see Figure 3-13). Consequently, spectral regrowth interferes with communicationin
the adjacent bands. Clipping can provide a solution to this problem.

Figure 3-13Spectral Regrowth Interfering with Adjacent Band

Spectral
Regrowth

RF Signal Adjacent Band

How Clipping Reduces Peak—to-Aver age Power

You can reduce peak—to—average power, and consequently spectral regrowth, by clipping the waveform to a selected
percentage of its peak power. The PSG vector signal generator provides two different methods of clipping: circular and
rectangular.

During circular clipping, clipping isapplied to the combined | and Q waveform (]I +jQ)). Noticein Figure 3-14 that the
clipping level is constant for all phases of the vector representation and appears as a circle. During rectangular clipping,
clipping is applied to the | and Q waveforms separately (|I], |Q|). Notice in Figure 3-15 on page 120 that the clipping
level isdifferent for | and Q; therefore, it appears as a rectangle in the vector representation. With either method, the
objectiveisto clip the waveform to alevel that effectively reduces spectral regrowth, but does not compromise the
integrity of the signal. Figure 3-16 on page 121 uses two complementary cumulative distribution plots to show the

118 Keysight PSG Signal Generators User’s Guide



Basic Digital Operation
Using Waveform Clipping

reduction in peak—to—average power that occurs after applying circular clipping to a waveform.

The lower you set the clipping value, the lower the peak power that is passed (or the more the signal is clipped). Often,
the peaks can be clipped successfully without substantially interfering with the rest of the waveform. Data that might be
lost in the clipping processis salvaged because of the error correction inherent in the coded systems. If you clip too
much of the waveform, however, lost datais irrecoverable. You may have to try several clipping settingsto find a
percentage that works well.

Figure 3-14Circular Clipping
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Figure 3-15Rectangular Clipping
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Figure 3-16Reduction of Peak—to—Aver age Power

Complementary Cumulative Distribution

CCDF with Clipping = 100% (No Clipping)

1007
10%
1%
0.1%

0.01%

L-~~mDmoXT

~12dB

0.001%
0 15 PEAK/AVUG dB

CCDF with Clipping = 80%

100%

10%

Reduction of
Peak - to - Average
Power Ratio

1%
0.1%

0.01%

b o Lo Ll o [ = = = e e = g

0.001%
0 15 PEAK/AVUG dB

=]
=
=

Configuring Circular Clipping

This procedure shows you how to configure circular clipping. The circular setting clips the composite I/Q data (I and Q
data are clipped equally). For more information about circular clipping, refer to “How Clipping Reduces
Peak-to-Average Power” on page 118.

1. PressPreset > Mode > Custom > Arb Waveform Generator > Digital Modulation Off On to On. This generates
acustom arbitrary waveform for use in this procedure. You can also use a previously stored or downloaded
waveform.
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10.

Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFORM is highlighted on the display.
AUTOGEN_WAVEFORM is the default name assigned to the waveform you generated in the previous step.

Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.
Press ARB Off On to On. The Dual Arb player must be turned on to display the CCDF plot in the following steps.

Press ARB Setup > Waveform Utilities > Waveform Statistics and ensure that AUTOGEN WAVEFORM iS
highlighted on the display.

Press CCDF Plot and observe the position of the waveform’s curve, which is the darkest line.
Press Return > Return > Clipping.
Ensure that the Clipping Type |l +j Q| |I|,|Q| softkey is set to [ +] Q|, which is circular clipping.

Press Clip |I+jQ| To >80 > % > Apply to Waveform. The | and Q data are both clipped by 80%. Once clipping is
applied to the waveform it cannot be undone. Repeated use of the clipping function has a cumulative effect on the
waveform.

Press Waveform Satistics > CCDF Plot and observe the waveform’s curve. Notice the reduction in
peak—to—average power, relative to the previous plot, after applying clipping.

Configuring Rectangular Clipping

This procedure shows you how to configure rectangular clipping. The rectangular setting clipsthe | and Q data
independently. For more information about rectangular clipping, refer to “How Clipping Reduces Peak-to-Average
Power” on page 118.

1

10.

11

Press Preset > Mode > Custom > Arb Waveform Generator > Digital M odulation Off On to On. This generates
acustom arbitrary waveform for use in this procedure. You can also use a previously stored or downloaded
waveform.

Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFORM is highlighted on the display.
AUTOGEN_WAVEFORM isthe default name assigned to the waveform you generated in the previous step.

Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.
Press ARB Off On to On. The Dual Arb player must be turned on to display the CCDF plot in the following steps.

Press ARB Setup > Waveform Utilities > Waveform Statistics and ensure that AUTOGEN WAVEFORM iS
highlighted on the display.

Press CCDF Plot and observe the position of the waveform’s curve, which is the darkest line.
Press Return > Return > Clipping.

Ensure that the Clipping Type ||+ Q| |1],|Q| softkey is set to |I|,|Q|. This activates the Clip |I| To and Clip |Q| To
softkeys that enable you to configure rectangular (independent) | and Q data clipping.

PressClip |I| To>80> %.

PressClip |Q| To > 40> % > Apply to Waveform. The | and Q data are individually clipped by 80% and 40%,
respectively. Once clipping is applied to the waveform it cannot be undone. Repeated use of the clipping function
has a cumulative effect on the waveform.

Press Waveform Satistics > CCDF Plot and observe the waveform’s curve. Notice the reduction in
peak—to—average power, relative to the previous plot, after applying clipping.
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Using Waveform Scaling

Waveform scaling is used to eliminate DAC over—range errors. The PSG provides two methods of waveform scaling.
You can perform runtime scaling, which enables you to make real—time scaling adjustments of a currently playing
waveform, or you can permanently scale a non—playing waveform file residing in volatile memory. This section
describes how DAC over—range errors occur and how you can use waveform scaling to eliminate these errors effectively.

The scaling feature is available only with the Dual ARB mode.

How DAC Over—Range Errors Occur

The PSG utilizes an interpolator filter in the conversion of the digital | and Q baseband waveformsinto analog
waveforms. The clock rate of the interpolator is four times that of the baseband clock. The interpolator therefore
calculates sample points between the incoming baseband samples to equal the faster clock rate and smooth out the
waveform, giving it a more curve-like appearance (see Figure 3-17).

Figure 3-17Waveform I nter polation
INTERPOLATED SAMPLES

i S

N/

BASEBAND SAMPLES

The interpolation filtersin the DAC's have overshoot. If a baseband waveform has a fast—rising edge, the interpolator
filter’s overshoot or frequency response becomes a component of the interpol ated baseband waveform. This response
causesarippleor ringing effect at the peak of the rising edge. If thisripple exceeds (or overshoots) the upper limit of the
DAC'srange, the interpolator calculates erroneous sample points and is unable to replicate the true form of theripple
(see Figure 3-18). Asaresult, the PSG reports a DAC over—range error.
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Figure 3-18Waveform Over shoot
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How Scaling Eliminates DAC Over—Range Errors

Scaling reduces or shrinks a baseband waveform’'s amplitude while maintaining its basic shape and characteristics, such
as peak—to—average power ratio. If the fast—rising baseband waveform is scaled enough to allow an adequate margin for
the overshoot, the interpolator filter is then able to calcul ate sample points that include the ripple effect, thereby
eliminating the over—range error

(see Figure 3-19).

Figure 3-19Waveform Scaling
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Although scaling maintains the basic shape of the waveform, too much scaling can compromise itsintegrity because the
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bit resolution can be so low that the waveform becomes corrupted with quantization noise. Maximum accuracy and
optimum dynamic range are achieved by scaling the waveform just enough to remove the DAC over—range error.
Optimum scaling varies with waveform content.

Scaling a Currently Playing Waveform (Runtime Scaling)

This procedure enables you to make real-time scaling adjustments to a currently playing waveform. Thistype of scaling
does not affect the waveform file and is well suited for eliminating DAC over—range errors.

1

Press Preset > Mode > Custom > Arb Waveform Generator > Digital M odulation Off On to On. This generates
acustom arbitrary waveform for use in this procedure. You can also use a previously stored or downloaded
waveform.

Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFORM is highlighted on the display.
AUTOGEN_WAVEFORM isthe default name assigned to the waveform you generated in the previous step.

Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.
Press ARB Off On to On. This plays the selected waveform.

Press ARB Setup > More (1 of 2) > Waveform Runtime Scaling and adjust the front panel knob or use the number
keysto enter anew value. The new scaling valueis instantly applied to the playing waveform. Runtime scaling
adjustments are not cumulative, as the values are always relative to origina amplitude of the waveform file.

Scaling a Waveform Filein Volatile Memory

This procedure enables you to permanently scale awaveform file. You can then store the scaled waveform segment to
non—volatile memory for future use. Scaling is cumulative and non—eversible.

1

Press Preset > Mode > Custom > Arb Waveform Generator > Digital M odulation Off On to On. This generates
acustom arbitrary waveform for use in this procedure. You can also use a previously stored or downloaded
waveform.

Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFORM is highlighted on the display.
AUTOGEN_WAVEFORM isthe default name assigned to the waveform you generated in the previous step.

Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.
Press ARB Setup > Waveform Utilities and ensure that AUTOGEN_WAVEFORM is highlighted on the display.

Press Scale Waveform Data > Scaling > 70 > % > Apply to Wavefor m. The waveform is now reduced to 70
percent of its original amplitude. Once thistype of scaling is applied to the waveform it cannot be undone. Repeated
scaling applications have a cumulative effect on the waveform.
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Setting the Baseband Frequency Offset

The baseband frequency offset specifies avalue to shift the baseband frequency up to +20 MHz within the BBG 80 MHz
signal bandwidth, depending on the signal generator’s baseband generator option.

When the Baseband Frequency Offset is non—zero, the hardware rotator accumul ates phase—shift of the baseband signal.
This phase is automatically reset when the baseband frequency offset isreturned to O Hz.

Common uses for the offset feature include:

« offsetting the carrier from any L O feedthrough (carrier signal spur at the carrier frequency)
e sum the baseband signal with external | and Q inputsto create a multicarrier signal
e usethesignal generator's1/Q signal asan IF

NOTE Changing the baseband frequency offset may cause aDAC over range condition that generates error 628,
Baseband Generator DAC over range. Thesignal generator incorporates an automatic scaling feature
to minimize this occurrence. For more information, see “How Scaling Eliminates DAC Over-Range Errors”
on page 124.

The baseband frequency offset value is one of the file header parameters, which means you can store this value with the
waveform. When you select awaveform with a stored frequency offset value, the signal generator changes the current
value to match the stored file header value. If there is no stored baseband offset frequency value for the current
waveform, the signal generator uses the last set frequency offset value.

You can also use the Save function to store this value as part of the signal generator setup. When you Recall a setup
stored with the Save function, the baseband frequency offset value becomes the current instrument setting value,
disregarding the stored file header value.

Use the following steps to offset the carrier from LO/carrier feedthrough. This example uses the factory supplied
waveform, SINE_TEST WFM availablein the Dual ARB Player. To view the output for this example, connect the RF
OUTPUT of the signal generator to the input of a spectrum analyzer.

1. Select and play the waveform.

a PressMode> Dual ARB > Select Waveform.
b. Inthe main display highlight the waveform: SINE_TEST WFM.
c. Press Select Waveform.

Generate the waveform: Press ARB Off On to On.
Configure the carrier signal:

a.  Setthecarrier signal to 1 GHz.
b. Set the amplitudeto 0 dBm.
c. Turnonthe RF OUTPUT.

4. Press ARB Setup > More (2 of 3) > Baseband Frequency Offset > 20 MHz.
The modulated RF signal is now offset from the carrier frequency by 20 MHz.
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4 Optimizing Performance

In the following sections, this chapter describes procedures that improve the performance of the Keysight PSG signal
generator.

“Using the ALC” on page 127

“Using External Leveling” on page 128

“Creating and Applying User Flatness Correction” on page 132

“Using the Option 521 Detector Calibration (Option 521)” on page 144

“Adjusting Reference Oscillator Bandwidth (Option UNR/UNX/UNY)” on page 145
“Optimizing Phase Noise and Harmonics Below 3.2 GHz (Option UNX/UNY)” on page 145
“Wideband 1Q/FM Mode <3.2 GHz (Option 018)” on page 147

Usingthe ALC

Selecting AL C Bandwidth

CAUTION Internal leveling works from —15 dBm to maximum powe.

For internal leveling, the signal generator uses automatic leveling control (ALC) circuitry prior to the RF output. ALC
bandwidth has five selections: automatic, 100 Hz, 1 kHz, 10 kHz, and 100 kHz. In automatic mode (the preset selection),
the signal generator automatically selects the ALC bandwidth depending on the configuration and settings (see

Figure 4-1).

KEYSIGHT

TECHNOLOGIES
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Figure4-1 Decision Treefor Automatic AL C Bandwidth Selection
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To Select an AL C Bandwidth

Press Amplitude> ALC BW > 100Hz, 1 kHz, 10 kHz, or 100 kHz.
This overrides the signal generator’s automatic AL C bandwidth selection with your specific selection.

For waveforms with varying amplitudes, high crest factors, or both, the recommended AL C loop bandwidth is 100 Hz.
Limiting the loop bandwidth of the ALC circuit will prevent the ALC from sampling the fast rising edges of pulsed
waveforms with high crest factors found in formats such as 802.11b, CDMA, and OFDM. A limited, or narrow
bandwidth will result in alonger ALC sample time and a more accurate representation of the signal’s level.

NOTE Do not usethe 10 kHz AL C bandwidth for any 1/Q modulated signal, asthe ALC integration time istoo short.
For CW signals, you can use higher ALC bandwidths.

Using External Leveling

CAUTION  Externa leveling works from —15 dBm to maximum power.

The PSG signal generator can be externally leveled by connecting an external sensor at the point where leveled RF
output power isdesired. This sensor detects changesin RF output power and returns a compensating voltage to the
signal generator’'s ALC input. The ALC circuitry raises or lowers (levels) the RF output power based on the voltage
received from the external sensor, ensuring constant power at the point of detection.

There are two types of external leveling available on the PSG. You can use external leveling with a detector and
coupler/power splitter setup, or a millimeter—wave source module.

To Level with Detectorsand Couplers/Splitters

Figure 4-2 illustrates atypical external leveling setup. The power level feedback to the ALC circuitry istaken from the
external negative detector, rather than the internal signal generator detector. This feedback voltage controlsthe ALC
system, leveling the RF output power at the point of detection.

To use detectors and couplerg/splitters for external leveling at an RF output frequency of
10 GHz and an amplitude of 0 dBm, follow the instructionsin this section.
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Required Equipment
* Keysight 8474E negative detector

¢ Keysight 87301D directional coupler
e cablesand adapters, as required

Connect the Equipment
Set up the equipment as shown in Figure 4-2.

Figure4-2 External Detector Leveling with a Directional Coupler
SIGNAL GENERATOR

NEGATIVE
DETECTOR

ALC INF’UT) )1

RF OUTPUT | Leveled Output i

DIRECTIONAL
COUPLER

Configurethe Signal Generator
1. PressPreset.

Press Frequency > 10> GHz.

Press Amplitude > 0 > dBm.

Press RF On/Off.

Press L eveling M ode > Ext Detector.

This deactivates the internal ALC detector and switches the ALC input path to the front panel ALC INPUT
connector. The EXT indicator is activated in the AMPL.ITUDE area of the display.

o~ DN

NOTE For signal generators with Option 1E1, notice that the ATTN HOLD (attenuator hold) annunciator is displayed.
During external leveling, the signal generator automatically uncouples the attenuator from the AL C system for
all external leveling points. While in this mode, the RF output amplitude adjustment is limited to —20 to +25
dBm, the adjustment range of the AL C circuitry. For more information, see “External Leveling with Option
1E1 Signal Generators” on page 131.

6. Observe the coupling factor printed on the directional coupler at the detector port. Typically, thisvalueis—10 to
—20 dB.

Enter the positive dB value of this coupling factor into the signal generator.

7. PressMore (1 of 2) > Ext Detector Coupling Factor > 16 (or the positive representation of the value listed at the
detector port of the directional coupler) > dB.

Leveled output power is now available at the output of the directional coupler.
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NOTE Whileoperating in external leveling mode, the signal generator’s displayed RF output amplitude is affected by
the coupling factor value, resulting in a calculated approximation of the actual RF output amplitude. To
determine the actual RF output amplitude at the point of detection, measure the voltage at the external detector
output and refer to Figure 4-3 or measure the power directly with a power meter.

Determining the L eveled Output Power

Figure 4-3 shows the input power versus output voltage characteristics for typical Keysight Technologies diode
detectors. Using this chart, you can determine the leveled power at the diode detector input by measuring the external
detector output voltage. You must then add the coupling factor to determine the leveled output power. The range of
power adjustment is approximately —20 to +25 dBm.
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Figure4-3 Typical Diode Detector Response at 25° C
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External Leveling with Option 1E1 Signal Generators

Signal generators with Option 1E1 contain a step attenuator prior to the RF output connector. During external leveling,
the signal generator automatically holds the present attenuator setting (to avoid power transients that may occur during
attenuator switching) as the RF amplitude is changed. A balance must be maintained between the amount of attenuation
and the optimum AL C level to achieve the required RF output amplitude. For optimum accuracy and minimum noise,
the ALC level should be greater than —10 dBm.
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For example, leveling the CW output of a 30 dB gain amplifier to alevel of —10 dBm requires the output of the signal
generator to be approximately —40 dBm when leveled. Thisis beyond the amplitude limits of the ALC modulator aone,
resulting in an unleveled RF output. Inserting 45 dB of attenuation resultsin an ALC level of +5 dBm, well within the
range of the ALC modulator.

NOTE Inthe example above, 55 dB is the preferred attenuation choice, resulting in an ALC level of +15 dBm. This
provides adequate dynamic range for AM or other functions that vary the RF output amplitude.

To achieve the optimum ALC level at the signal generator RF output of —40 dBm for an unmodulated carrier, follow
these steps:

1. PressAmplitude > Set Atten > 45 > dB.
2. PressSet ALC Level >5>dBm.

This sets the attenuator to 45 dB and the ALC level to +5 dBm, resulting in an RF output amplitude of 40 dBm, as
shown in the AMPLITUDE area of the display.

To obtain flatness—corrected power, refer to “Creating and Applying User Flatness Correction” on page 132.

To Level with a mm—-Wave Source Module

Millimeter—wave source module leveling is similar to externa detector leveling. The power level feedback signal to the
ALC circuitry istaken from the millimeter—wave source module, rather than the internal signal generator detector. This
feedback signal levels the RF output power at the mm—wave source module output through the signal generator’s rear
panel SOURCE MODULE interface connector.

For instructions and setups, see Chapter 12, “ Peripheral Devices,” on page 235.

Creating and Applying User Flatness Correction

User flatness correction allows the digital adjustment of RF output amplitude for up to 1601 frequency pointsin any
frequency or sweep mode. Using an Keysight E4416A/17A or E4418B/19B power meter (controlled by the signal
generator through GPIB) to calibrate the measurement system, atable of power level correctionsis created for
frequencies where power level variations or losses occur. These frequencies may be defined in sequential linear steps or
arbitrarily spaced.

To alow different correction arrays for different test setups or different frequency ranges, you may save individual user
flatness correction tables to the signal generator’s memory catalog and recall them on demand.

Use the steps in the next sections to create and apply user flatness correction to the signal generator’s RF outpuit.

Afterward, use the stepsin Recalling and Applying a User Flatness Correction Array to recall a user flatnessfile
from the memory catalog and apply it to the signal generator’s RF output.
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Creating a User Flatness Correction Array

In this example, you create a user flatness correction array. The flatness correction array contains ten frequency
correction pairs (amplitude correction values for specified frequencies), from 1 to 10 GHz in 1 GHz intervals.

An Keysight E4416A/17A/18B/19B power meter (controlled by the signa generator via GPIB) and E4413A power
sensor are used to measure the RF output amplitude at the specified correction frequencies and transfer the results to the
signal generator. The signal generator reads the power level data from the power meter, calculates the correction val ues,
and stores the correction pairsin a user flatness correction array.

If you do not have the required Keysight power meter, or if your power meter does not have a GPIB interface, you can
enter correction values manually.

Required Equipment

e Keysight E4416A/17A or Keysight N1913A/14A power meter
e Keysight E4413A E Series CW power sensor

e GPIB interface cable

« adaptersand cables, as required

NOTE If the setup has an external leveling configuration, the equipment setup in Figure 4-4 assumes that the steps
necessary to correctly level the RF output have been followed. If you have questions about external leveling,
refer to “Using External Leveling” on page 128.

Configurethe Power Meter

1. Select SCPI asthe remote language for the power meter.

2. Zeroand calibrate the power sensor to the power meter.

3. Enter the appropriate power sensor calibration factors into the power meter as appropriate.
4. Enablethe power meter’s cal factor array.

NOTE For operating information on a particular power meter/sensor, refer to its operating guide.

Connect the Equipment
Connect the equipment as shown in Figure 4-4.

NOTE During the process of creating the user flatness correction array, the power meter is slaved to the signal
generator via GPIB. No other controllers are allowed on the GPIB interface.
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Figure4-4 User Flatness Correction Equipment Setup
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Configurethe Signal Generator
1. PressPreset.

2. Configure the signal generator to interface with the power meter.

a. PressAmplitude>More (1 of 2) > User Flatness> More (1 of 2) > Power Meter > E4416A, E4417A,
E4418B, or E4419B.

b. PressMeter Address > enter the power meter’s GPIB address > Enter.
For E4417A and E4419B models, press M eter Channel A B to select the power meter’s active channel.

Press Meter Timeout to adjust the length of time before the instrument generates a timeout error if
unsuccessfully attempting to communicate with the power meter.

3. PressMore (2 of 2) > Configure Cal Array > More (1 of 2) > Preset List > Confirm Preset.
This opens the User Flatness table editor and presets the cal array frequency/correction list.
4. PressConfigure Step Array.
This opens amenu for entering the user flatness step array data.
PressFreqg Sart > 1> GHz.
Press Freq Stop > 10> GHz.
Press# of Points> 10 > Enter.
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Steps 4, 5, and 6 enter the desired flatness—corrected frequencies into the step array.
8. PressReturn >Load Cal Array From Step Array > Confirm Load From Sep Data.

This populates the user flatness correction array with the frequency settings defined in the step array.
9. PressAmplitude> More (1 of 2) > Ampl Offset.

Enter anominal (average) value for the gain or loss of any cables or other devices connected between the signal
generator’s RF output and the power sensor. Refer to figure Figure 4-4. Gain is entered as a positive number while
lossis entered as a negative number.

10. Press RF On/Off.
This activates the RF output and the RF ON annunciator is displayed on the signal generator.

Perform the User Flatness Correction

NOTE If you are not using an Keysight E4416A/17A/18B/19B power meter, or if your power meter does not have a
GPIB interface, you can perform the user flatness correction manually. For instructions, see “Performing the
User Flatness Correction Manually” on page 135.

1. PressMore (1 of 2) > User Flatness> Do Cal.

Pressing the Do Cal softkey causes the signal generator to perform the user flatness correction routine. A progress
bar is shown on the front panel display as the routine runs. The routine generates a table of correction points with
each correction point consisting of a frequency and amplitude correction value for that frequency. The correction
value at each point is the difference between the power level, as measured by the power meter, and the output power
of the signal generator.

NOTE A power meter timeout may occur at low power levels. If a power meter timeout error message appears,
increase the timeout value by pressing Amplitude > More (1 of 2) > User Flatness> More (1 of 2) > Meter
Timeout.

2. PressDone.
Pressing the Done softkey loads the amplitude correction values into the user flatness correction array.
If desired, press Configure Cal Array.

This opens the user flatness correction array, where you can view the stored amplitude correction values. The user
flatness correction array title displaysUser Flatness: (UNSTORED) indicating that the current user flatness
correction array data has not been saved to the memory catalog.

Performing the User Flatness Correction Manually

If you are not using an Keysight E4416A/17A/18B/19B power meter, or if your power meter does not have a GPIB
interface, complete the stepsin this section and then continue with the user flatness correction tutorial.
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o

8.

PressMore (1 of 2) > User Flatness > Configure Cal Array.

This opens the User Flatness table editor and places the cursor over the frequency value
(1 GHz) for row 1. The RF output changes to the frequency value of the table row containing the cursor and 1. 000
000 000 00 isdisplayed inthe AMPLITUDE area of the display.

Observe and record the measured value from the power meter.

Subtract the measured value from 0 dBm.

Move the table cursor over the correction valuein row 1.

Press Edit Item > enter the difference value from step 3> dB.

The signal generator adjusts the RF output amplitude based on the correction val ue entered.
Repeat steps 2 through 5 until the power meter reads 0 dBm.

Use the down arrow key to place the cursor over the frequency value
for the next row. The RF output changes to the frequency value of the table row containing the cursor, as shown in
the AMPL.ITUDE area of the display.

Repeat steps 2 through 7 for every entry in the User Flatness table.

Savethe User Flatness Correction Data to the Memory Catalog

This process allows you to save the user flatness correction data as in the signal generator’s memory catalog. With
severa user flatness correction files saved to the memory catalog, any file can be recalled, loaded into the correction
array, and applied to the RF output to satisfy specific RF output flatness requirements.

1
2.
3.
4.

Press L oad/Store.

Press Storeto File.

Enter the file name FLATCAL1 using the alphanumeric softkeys, numeric keypad, or the knob.
Press Enter.

The user flatness correction array file FLATCAL1 is now stored in the memory catalog as a UFLT file.

Applying a User Flatness Correction Array
Press Return > Return > Flatness Off On to On.

This applies the user flatness correction array to the RF output. The UF indicator is activated in the AMPLITUDE section
of the signal generator’s display and the frequency correction data contained in the correction array is applied to the RF
output amplitude.

Recalling and Applying a User Flatness Correction Array

Before performing the steps in this section, complete “Creating a User Flatness Correction Array” on page 133.

1. PressPreset.

2. Press Amplitude> More (1 of 2) > User Flatness > Configure Cal Array > More (1 of 2) > Preset List >
Confirm Preset.
PressMore (2 of 2) > Load/Sore.

4. Ensurethat thefile FLATCALL is highlighted.
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5. PressLoad From Selected File> Confirm Load From File.

This populates the user flatness correction array with the data contained in the file FLATCAL1. The user flatness
correction array title displaysUser Flatness: FLATCALL.

6. PressReturn > Flatness Off On to On.
This applies the user flatness correction data contained in FLATCATL1 .

Returning the Signal Generator to GPIB Listener Mode

During the user flatness correction process, the power meter is slaved to the signal generator via GPIB, and no other
controllers are allowed on the GPIB interface. The signal generator operatesin GPIB talker mode, as a device controller
for the power meter. In this operating mode, it cannot receive SCPlI commands via GPIB.

If the signal generator isto be interfaced to aremote controller after performing the user flatness correction, its GPIB
controller mode must be changed from GPIB talker to GPIB listener.

If an RF carrier has been previously configured, you must save the present instrument state before returning the signal
generator to GPIB listener mode.

1. Saveyour instrument state to the instrument state register.
For instructions, see “Saving an Instrument State” on page 61.
2. PressAmplitude> More (1 of 2) > User Flatness > GPIB Listener Mode.

This presets the signal generator and returnsit to GPIB listener mode. The signal generator can now receive remote
commands executed by a remote controller connected to the GPIB interface.

3. Recall your instrument state from the instrument state register.

For instructions, see “Saving an Instrument State” on page 61.
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Creating a User Flatness Correction Array with a mm-Wave Source Module

CAUTION  Option 521 signal generators can damage MM source modules. Consult the MM source modul€e's
operating manual for input damage levels.

In this example, a user flatness correction array is created to provide flatness—corrected power at the output of an
Keysight 83554A millimeter—wave source module driven by an E8257D.

The flatness correction array contains 28 frequency correction pairs (amplitude correction values for specified
frequencies), from 26.5 to 40 GHz in 500 MHz intervals. Thiswill result in 28 evenly spaced flatness corrected
frequencies between 26.5 GHz and 40 GHz at the output of the 83554A millimeter—wave source module.

An Keysight E4416A/17A/18B/19B power meter (controlled by the signal generator via GPIB) and R8486A power
sensor are used to measure the RF output amplitude of the millimeter—wave source module at the specified correction
frequencies and transfer the results to the signal generator. The signal generator reads the power level datafrom the
power meter, calculates the correction values, and stores the correction pairsin the user flatness correction array.

If you do not have the required Keysight power meter, or if your power meter does not have a GPIB interface, you can
enter correction values manually.

NOTE User Flatness correction is only applicable for Keysight 83550 series mm—wave source modules and does not
function with other mm—wave modules such as OML modules.

Required Equipment

*  Keysight 83554A millimeter—wave source module

e Keysight E4416A/17A/18B/19B power meter

e Keysight R8486A power sensor

« Keysight 8349B microwave amplifier (required for signal generators without Options 1EA, 1EU, or 521)
e GPIB interface cable

e adaptersand cables as required

NOTE The equipment setupsin Figure 4-5 and Figure 4-6 assume that the steps necessary to correctly level the RF
output have been followed. If you have questions about leveling with a millimeter—wave source module, refer
to “To Level with a mm-Wave Source Module” on page 132.

Configurethe Power Meter
1. Select SCPI asthe remote language for the power meter.

2. Zeroand calibrate the power sensor to the power meter.
3. Enter the appropriate power sensor calibration factors into the power meter as appropriate.
4. Enablethe power meter’s cal factor array.

NOTE For operating information on your particular power meter/sensor, refer to their operating guides.
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Connect the Equipment

CAUTION  To prevent damage to the signal generator, turn off the line power to the signal generator before
connecting the source module interface cable to the rear panel SOURCE MODULE interface connector.

Option 521 signal generators can damage MM source modules. Consult the MM source module’s
operating manual for input damage levels.

1. Turn off the line power to the signal generator.

2. Connect the equipment. For standard signal generators, use the setup in Figure 4-5. For signal generators with
Options 1EA, 1EU, or 521, use Figure 4-6.

NOTE During the process of creating the user flatness correction array, the power meter is slaved to the signal
generator via GPIB. No other controllers are allowed on the GPIB interface.
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Figure4-5 User Flatness with mm-Wave Source Module for a Signal Generator without Options 1EA, 1EU, or 521
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Figure4-6 User Flatness with mm—-Wave Source Module for Signal Generatorswith Options 1EA, 1EU, or 521
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CAUTION  Option 521 signal generators can damage MM source modules. Consult the MM source modul€e’'s
operating manual for input damage levels.
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NOTE To ensure adeguate RF amplitude at the mm—wave source module RF input when using Options 1EA, 1EU, or
521 signal generators, maximum amplitude loss through the adapters and cables connected between the signal
generator’s RF output and the mm—wave source module’s RF input should be less than 1.5 dB.

Configurethe Signal Generator
1. Turnonthesigna generator’s line power. At power—up, the signal generator automatically does the following:

senses the mm—wave source module

switches the signal generator’s leveling mode to external/source module

sets the mm—wave source module frequency and amplitude to the source modul€’s preset values
displays the RF output frequency and amplitude available at the mm—wave source modul e output

The MMMOD indicator in the FREQUENCY area and the MM indicator in the AMPLITUDE area of the signal generator’'s
display indicate that the mm-wave source moduleis active

NOTE For specific frequency/amplitude ranges, see the mm—wave source module specifications.

2. Configure the signal generator to interface with the power meter.

a. PressAmplitude> More (1 of 2) > User Flatness> More (1 of 2) > Power Meter > E4416A, E4417A,
E4418B, or E4419B.
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10.

b. PressMeter Address > enter the power meter’s GPIB address > Enter.
For E4417A and E4419B models, press M eter Channel A B to select the power meter’s active channel.

Press Meter Timeout to adjust the length of time before the instrument generates a timeout error if
unsuccessfully attempting to communicate with the power meter.

PressMore (2 of 2) > Configure Cal Array >More (1 of 2) > Preset List > Confirm Preset.

This opens the User Flatness table editor and resets the cal array frequency/correction list.

Press Configure Step Array.

This opens amenu for entering the user flatness step array data.

Press Freq Start > 26.5 > GHz.

Press Freq Stop > 40> GHz.

Press# of Points> 28 > Enter.

This enters the desired flatness—corrected frequencies (26.5 GHz to 40 GHz in 500 MHz intervals) into the step
array.

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.

This populates the user flatness correction array with the frequency settings defined in the step array.
Press Amplitude > 0 > dBm.

Press RF On/Off.

This activates the RF output and the RF ON annunciator is displayed on the signal generator.

Perform the User Flatness Correction

NOTE If you are not using an Keysight E4416A/17A/18B/19B power meter, or if your power meter does not have a

GPIB interface, you can perform the user flatness correction manually. For instructions, see Performing the
User Flatness Correction Manually below.

PressMore (1 of 2) > User Flatness> Do Cal.

This creates the user flatness amplitude correction value table entries. The signal generator begins the user flatness
correction routine and a progress bar is shown on the display.

When prompted, press Done.
This loads the amplitude correction valuesinto the user flatness correction array.
If desired, press Configure Cal Array.

This opens the user flatness correction array, where you can view the list of defined frequencies and their calculated
amplitude correction values. The user flatness correction array title displaysUser Flatness: (UNSTORED)
indicating that the current user flatness correction array data has not been saved to the memory catal og.

Performing the User Flatness Correction Manually

If you are not using an Keysight E4416A/17A/18B/19B power meter, or if your power meter does not have a GPIB
interface, complete the stepsin this section and then continue with the user flatness correction tutorial.

1

PressMore (1 of 2) > User Flatness> Configure Cal Array.

142
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This opens the User Flatness table editor and places the cursor over the frequency value (26.5 GHz) for row 1. The
RF output changes to the frequency value of the table row containing the cursor and 26 .500 000 000 00 is
displayed in the AMPL.ITUDE area of the display.

Observe and record the measured value from the power meter.
Subtract the measured value from 0 dBm.
Move the table cursor over the correction valuein row 1.

g > w0 N

Press Edit Item > enter the difference value from step 3> dB.
The signal generator adjusts the RF output amplitude based on the correction val ue entered.

o

Repeat steps 2 through 5 until the power meter reads 0 dBm.

Use the down arrow key to place the cursor over the frequency value for the next row. The RF output changesto the
frequency value highlighted by the cursor, as shown in the AMPLITUDE area of the display.

8. Repeat steps 2 through 7 for each entry in the User Flatness table.

Savethe User Flatness Correction Data to the Memory Catalog

This process allows you to save the user flatness correction data as afile in the signal generator’s memory catalog. With
several user flatness correction files saved to the memory catal og, specific files can be recalled, loaded into the
correction array, and applied to the RF output to satisfy various RF output flatness requirements.

1. PressLoad/Sore.

2. PressSoretoFile.

3. Enter thefile name FLATCAL2 using the alphanumeric softkeys and the numeric keypad.

4. PressEnter.

The user flatness correction array file FLATCALZ2 is now stored in the memory catalog as a UFLT file.

Applying the User Flatness Correction Array
1. PressReturn > Return > Flatness Off On.

This applies the user flatness correction array to the RF output. The UF indicator is activated in the AMPLITUDE
section of the signal generator’s display and the frequency correction data contained in the correction array is
applied to the RF output amplitude of the mm—wave source module.

Recalling and Applying a User Flatness Correction Array

Before performing the stepsin this section, complete the section “Creating a User Flatness Correction Array with a
mm-Wave Source Module” on page 138.

1. PressPreset.

2. PressAmplitude>More (1 of 2) > User Flatness> Configure Cal Array >More (1 of 2) > Preset List >
Confirm Preset.

PressMore (2 of 2) > Load/Sore.
Ensure that the file FLATCAL?2 is highlighted.
5. PressLoad From Selected File> Confirm Load From File.
This populates the user flatness correction array with the data contained in the file FLATCAL2. The user flatness
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correction array title displays User Flatness: FLATCAL2.
6. PressReturn > Flatness Off On.
This activates flatness correction using the data contained in the file FLATCAT.2.

Using the Option 521 Detector Calibration (Option 521)

CAUTION  Using the Option 521 Detector Calibration softkey changes the factory calibration. Avoid using this
feature unless following a service center’s recommendations.

This calibration should be done whenever the instrument temperature changes beyond specified
parameters or and when greater amplitude flatnessis required around the 500 MHz frequency transition.
Refer to the Data Sheet.

NOTE If the Option 521 Detector Calibration isinadvertently used, the PSG has the ahility to recall the factory
amplitude flatness calibration. Refer to “Restoring the Factory Flatness Calibration”.

The purpose of this calibration isto improve the 500 MHz frequency transition to compensate for changesin
temperature. The 500 MHz frequency transition can degrade as the temperature changes. By using the detector
calibration, when the instrument temperature change occurs, the PSG’s flatness performance can be optimized. Refer to
the Data Sheet.

Running the Option 521 Detector Calibration

Following the following steps to run the Detector calibration:
e PressAmplitude> More > More> Option 521 Detector Calibration > Execute

Restoring the Factory Flatness Calibration

The instrument’s original factory calibration settings can be restored by the following steps:
e PressUtility > Power On/Preset > Restore System Defaults
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Adjusting Reference Oscillator Bandwidth (Option UNR/UNX/UNY)

The reference oscillator bandwidth (sometimes referred to as loop bandwidth) in signal generators with Option
UNR/UNX/UNY (improved close-in phase noise <1 kHz) is adjustable in fixed steps for either an internal or external
10 MHz frequency reference. The reference oscillator bandwidth can be set to 25, 55, 125, 300, or 650 Hz; models
without Option UNR/UNX/UNY have afixed reference oscillator bandwidth.

At frequency offsets below approximately 1 kHz, the stability and phase noise are determined by the internal or external
frequency reference. At frequency offsets above 1 kHz, stability and phase noise are determined by the synthesizer
hardware.

To optimize the overall phase noise performance of the signal generator for your particular application, make this
adjustment depending on your confidence in the stability and phase noise of the external or internal reference versusthe
synthesizer hardware for various frequency offsets from the carrier.

To Select the Reference Oscillator Bandwidth

When using the internal bandwidth reference:
1. PressUtility > Instrument Adjustments > Reference Oscillator Adjustment > Internal Ref Bandwidth.

2. Select the desired bandwidth.

When using an external bandwidth reference:
1. PressUtility > Instrument Adjustments > Reference Oscillator Adjustment > External Ref Bandwidth.

2. Select the desired bandwidth.

To Restore Factory Default Settings:

Internal Bandwidth: 125 Hz
External Bandwidth: 25 Hz (Option UNR), 650 Hz (Option UNX/UNY)

Press Utility > Instrument Adjustments > Reference Oscillator Adjustment > Restore Factory Defaults.

Optimizing Phase Noise and Har monics Below 3.2 GHz (Option UNX/UNY)

Included with the Ultra-Low Phase Noise (Option UNX/UNY), isthe ability to improve both phase noise and harmonic
performance below 3.2 GHz. Refer to the PSG’'s Data Sheet.

This section contains the following topics:
e “Optimizing Phase Noise Below 250 MHz (serial prefix > xx4928 and higher)” on page 146
e “Optimizing Harmonics Below 2 GHz” on page 147
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Optimizing Phase Noise Below 250 MHz (serial prefix > xx4928 and higher)

This feature is available on instruments with Option UNX or Option UNY, and serial number prefix
> xx4928 and higher.

CAUTION  Maximum available power below 3.2 GHz is lower when the Optimizing Phase Noise Below 250 MHz
softkey is been pressed. Refer to the PSG’s Data Sheet.

The PSG’s low band phase noise can be improved below 250 MHz by using the Low Phase Noise Below 250 MHz
softkey. Refer to the PSG’'s Data Sheet. See also “Optimizing Harmonics Below 2 GHz” on page 147.

Figure4-7 Low Band Phase Noise Below 250 MHz
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For SCPI commands, refer to the SCPI Command Reference.

146 Keysight PSG Signal Generators User’s Guide



Optimizing Performance
Wideband 1Q/FM Mode <3.2 GHz (Option 018)

Optimizing Harmonics Below 2 GHz

CAUTION  Maximum available power below 3.2 GHz, islower when the Low Pass Filter Below 2 GHz softkey is
been pressed. Refer to the PSG's Data Sheet.

The PSG’s harmonic performance can be improved below 3.2 GHz by using the Low Pass Filter Below 2 GHz softkey.
Refer to the PSG’s Data Sheet. See also “Optimizing Phase Noise Below 250 MHz (serial prefix > xx4928 and
higher)” on page 146.

Figure4-8 Low Band Phase Noise Below 2 GHz
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For SCPI commands, refer to the SCPI Command Reference.

Wideband IQ/FM M ode <3.2 GHz (Option 018)

Wideband 1Q/FM mode (Option 018) provides the following features for frequencies <3.2 GHz:
¢ Wideband I/Q bandwidth

« Improved IQ frequency response (with an internal BBG)

¢ Wider FM and Phase-modulation deviation

External differential inputs, on the rear panel (Wide | and Wide Q) are provided for direct access to the microwave I/Q
modulator.

To enable the wideband 1/Q inputs refer to Figure 4-9.
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Figure4-9 Wideband IQ/FM Softkey Menu

Frequency > More > More > RF Path

'

FREOUENCY OFFS_REF MULT [AMPLITUDE N
-239.990 000000000 &=z | -8.00 den
L 10D This softkey selects the
OH downconverted RF path
8l ERR] below 3.2 GHz. When this
| — path is active, the low band
B lllldg %ﬂéﬁ" frequencies are generated
Frequency Status Information Amplitude Status Information elou 3. Z by a downconverter. This
Offset.: 200. 000000000GHz enables very wide I/Q and
Referance: 1.00000000MHz FM performance.
Multiplier: -10.000 =
/ ‘\\ Attenuator: .00 dB (Auto)
\RF Path: Wide IO/FM <= 3.2 GHz ) ALC Level: —3.00 dBem
N Leveling Mode:  Internal
ALC Bandwidth: Auto CALC Ond
08:.0

This message is displayed when the Wideband IQ/FM softkey has been pressed.
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b Analog Modulation

In the following sections, this chapter describes the standard continuous waveform and optional analog modulation
capability in the Keysight E8257D PSG Analog, E8663D, Analog, and E8267D PSG Vector signal generators.

* “Analog Modulation Waveforms” on page 149

«  “Configuring AM (Option UNT)” on page 150

e “Configuring FM (Option UNT)” on page 150

« “Configuring FM (Option UNT)” on page 151

e “Configuring Pulse Modulation (Option UNU/UNW)” on page 152
« “Configuring the LF Output (Option UNT)” on page 154

Analog M odulation Waveforms

Available standard internal waveforms include:

Sine sine wave with adjustable amplitude and frequency

Dua—-Sine dual—sine waves with individually adjustable frequencies and a percent—of— peak—amplitude
setting for the second tone (available from function generator only)

Swept—Sine swept—sine wave with adjustable start and stop frequencies, sweep rate, and sweep trigger settings
(available from function generator only)

Triangle triangle wave with adjustable amplitude and frequency

Ramp ramp with adjustable amplitude and frequency

Square square wave with adjustable amplitude and frequency

Noise noise with adjustable amplitude generated as a peak—to—peak value (RM S value is approximately
80% of the displayed value)

With Option UNT, the signal generator can modulate the RF carrier with amplitude, frequency, or phase modulation.
Option UNT also provides low—frequency output capability.

With Option UNU, the signal generator can modul ate the RF carrier with standard pulse modulation (150 ns minimum
pulse width).

With Option UNW, the signal generator can modulate the RF carrier with narrow pulse modulation.

KEYSIGHT
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Configuring AM (Option UNT)

In this example, you will learn how to generate an amplitude-modul ated RF carrier.

To Set the Carrier Frequency
1. PressPreset.
2. PressFrequency > 1340 > kHz.

To Set the RF Output Amplitude
Press Amplitude> 0> dBm.

To Set the AM Depth and Rate
1. Pressthe AM hardkey.

2. PressAM Depth>90>%.

3. PressAM Rate> 10> kHz.

The signal generator is now configured to output a 0 dBm, amplitude-modulated carrier at 1340 kHz with the AM depth
set to 90% and the AM rate set to 10 kHz. The shape of the waveform is a sine wave. Notice that sine is the default
selection for the AM Wavefor m softkey, which can be viewed by pressing (More 1 of 2).

To Turn on Amplitude Modulation

Follow these remaining steps to output the amplitude—modul ated signal.
1. Pressthe AM Off On softkey to On.
2. Pressthefront panel RF On Off key.

The aM and RF ON annunciators are now displayed. Thisindicates that you have enabled amplitude modulation and the
signal is now being transmitted from the RF OUTPUT connector.

Configuring FM (Option UNT)

In this example, you will learn how to create afrequency—modul ated RF carrier. For aE8267D with Option 018, see also
“Wideband 1Q/FM Mode <3.2 GHz (Option 018)” on page 147.

To Set the RF Output Frequency
1. PressPreset.

2. PressFrequency >1>GHz.

To Set the RF Output Amplitude
Press Amplitude> 0> dBm.
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To Set the FM Deviation and Rate
1. Pressthe FM/®M hardkey.
2. PressFM Dev >75>kHz.
3. PressFM Rate> 10> kHz.

The signal generator is now configured to output a 0 dBm, frequency—modulated carrier at 1 GHz with a 75 kHz
deviation and a 10 kHz rate. The shape of the waveform is a sine wave. (Notice that sineis the default for the
FM Waveform softkey. PressMore (1 of 2) to see the softkey.)

To Activate FM
1. PressFM Off Onto On.
2. Press RF On/Off.

The FM and RF ON annunciators are now displayed. Thisindicates that you have enabled frequency modulation and the
signal is now being transmitted from the RF OUTPUT connector.

DC Offset and External FM

Applying aDC offset to an external FM signal will shift the frequency of the FM signal above or below the carrier
frequency, depending on the polarity of the DC level. The amount frequency shift is directly related to the amplitude of
the DC level. A DC offset of +1.0 volt or greater will shift the external FM frequency by an amount equal to the
maximum deviation setting. For example, if the signal generator CW fregquency is 1 GHz and the maximum deviation
setting is set to 100 kHz, an external DC—coupled signal with a+1.0 volt DC level used as the modulating source will
center the FM signal at 1 GHz + 100 kHz. Keeping the same setup and settings and changing the DC level to +0.5 volts
will center the FM signal at 1 GHz + 50 kHz.

Configuring ®M (Option UNT)
In this example, you will learn how to create a phase-modulated RF carrier. For a E8267D with Option 018, see aso
“Wideband 1Q/FM Mode <3.2 GHz (Option 018)” on page 147.

To Set the RF Output Frequency
1. PressPreset.
2. PressFrequency > 3> GHz.

To Set the RF Output Amplitude
Press Amplitude> 0 > dBm.

To Set the ®M Deviation and Rate
1. Pressthe FM/®M hardkey.

2. Pressthe FM ©®M softkey.

3. Press®M Dev > .25 > pi rad.

4. Press®M Rate> 10> kHz.
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The signal generator is now configured to output a 0 dBm, phase-modulated carrier at 3 GHz with a0.25 p radian
deviation and 10 kHz rate. The shape of the waveform isa sine wave. (Notice that sineis the default for the
®M Waveform softkey. PressMore (1 of 2) to see the softkey.)

To Activate ®M
1. Press®M Off On.
2. Press RF On/Off.

The ®M and RF ON annunciators are now displayed. This indicates that you have enabled phase modulation and the
signal is now being transmitted from the RF OUTPUT connector.

Configuring Pulse M odulation (Option UNU/UNW)

In this example, you will learn how to create a gated, pulse-modulated RF carrier with an external trigger.

To Set the RF Output Frequency
1. PressPreset.
2. PressFrequency >2>GHz.

To Set the RF Output Amplitude
Press Amplitude > 0 > dBm.

To Set the Pulse Period, Width, and Triggering
1. PressPulse> Pulse Period > 100 > usec.

2. PressPulse > Pulse Width > 24 > usec.

3. PressPulse > Pulse Source > Int Gated.
4

Connect aTTL signal to the Trigger In connector on the rear panel of the signal generator. To configure the trigger
signal polarity, Press Utility > I nstrument Adjustments > Signal Polarity Setup > Trigger In Polarity.

The signal generator is now configured to output a 0 dBm, pulse-modulated carrier at 2 GHz with a 100-microsecond
pulse period and 24-microsecond pulse width. The pulse source is set to internal gated. (Notice that Internal Free Runis
the default for the Pulse Sour ce softkey.)

To Activate Pulse Modulation

Follow these remaining steps to output the pulse-modulated signal.
1. PressPulse Off Onto On.
2. Press RF On/Off.

The Pulse and RF ON annunciators are now displayed. This indicates that you have enabled pulse modulation and the
signal is now being transmitted from the RF OUTPUT connector. The TTL trigger signal state will control pulse
modulation output.
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Triggering Simultaneous Pulses from Two PSGs Using an Internal or an External Pulse
Source

Two PSG pulse generators can be triggered simultaneously using the PSG internal pulse generator or using an external
pulse source. The pulse from PSG1 istriggered internally or by the external pulse generator and the pulse from PSG2 is
triggered using the SYNC OUT signa from PSG1. Each PSG can be set to different pul se widths, pulse repetition

intervals (PRI), and RF output frequencies. Refer to “Configuring FM (Option UNT)” on page 150 and to
“Configuring Pulse Modulation (Option UNU/UNW)” on page 152.

1. Ensurethetwo PSGs should have the same "Analog Mod Gen" PC board part numbersinstalled (i.e. E8251-60306)
and board software code version (i.e. A0100).

You can view thisinformation by selecting the Utility hardkey, then selecting the Instrument Info/Help Mode and
the Installed Board Info softkeys on each PSG.

Set PSGL1 to its RF output frequency (f1) and PSG2 to its frequency (f2).
Connect the two PSGs as shown in Figure 5-1 on page 154. For connection details, refer to Table 5-1.

CAUTION  The cables should be as short as possible.

Table5-1 PSG Connectivity for Simultaneous Pulse Configuration

From (PSG1)% To (PSG2):
10 MHz OUT 10 MHz IN
SYNC OUT GATE/PULSE/TRIGGER INPUT

4 f an external pulse source is being used as the pulse trigger, connect
the pulse source’s pulse output connector to the PSG1
GATE/PULSE/TRIGGER INPUT.

Keysight PSG Signal Generators User’s Guide 153



Analog Modulation
Configuring the LF Output (Option UNT)

Figure5-1 Setup Diagram for Triggering Simultaneous Pulses Using Two PSGs

| Only When Using an | Pulsed
| External Pulse Source ! S] PSG1 RF Signals
| | .
1 Pulse or Function Generator | | qp MHz QUT g OOODO
1 | (rear) >
1 Pulse I GATE/PULSE/ f1
i Output I TRICCER INPUT| |y
I [
' Set: Pulse Width I

- O
! Pulse PRI I 8 PSG2 o
I Voltage 1.5 Vp- I O
f R L MEIN 8 O OOOOO

(rean 00 OfgFgurruT™ 2
GATE /PULSE/ 500

TRIGGER INPUT

4. If you areusing:

* Anexternal pulse source as the pulse trigger:
Set the trigger mode to Internal Trigger for both PSGs by selecting the Pulse hardkey, and then selecting the Pulse
Source and Internal Triggered on PSG 1 and PSG2.

¢ PSG1astheinternal pulse source:

a  Set PSG1 trigger modes to Free Run by selecting the Pulse hardkey, then selecting the Pulse Source and Int
Free-Run softkeys.

b. Set PSG 2 trigger to the Internal Trigger mode by selecting the Pulse hardkey, then selecting the Pulse Source
and Internal Triggered softkeys.

3. You can adjust the relative timing of the PSG pulses using the Pulse Delay softkey on each PSG

Configuring the LF Output (Option UNT)

With Option UNT, the signal generator has alow frequency (LF) output (described on page 13). The LF output’s source
can be switched between Internal 1 Monitor, Internal 2 Monitor, Function Generator 1, or Function Generator 2.

Using Internal 1 Monitor or Internal 2 Monitor asthe LF output source, the LF output provides areplica of the signal
from theinternal source that is being used to modulate the RF output. The specific modulation parameters for this signal
are configured through the AM, FM, or FM menus.

Using Function Generator 1 or Function Generator 2 as the LF output source, the function generator section of the
internal modulation source drives the LF output directly. Frequency and waveform are configured from the LF output
menu, not through the AM, FM, or FM menus. You can select the waveform shape from the following choices:

Sine sine wave with adjustable amplitude and frequency

Dual—Sine dua—sine waves with individually adjustable frequencies and a percent—of— peak—amplitude
setting for the second tone (available from function generator 1 only)
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Swept—Sine a swept—sine wave with adjustable start and stop frequencies, sweep rate, and sweep trigger
settings (available from function generator 1 only)

Triangle triangle wave with adjustable amplitude and frequency

Ramp ramp with adjustable amplitude and frequency

Square sguare wave with adjustable amplitude and frequency

Noise noise with adjustable amplitude generated as a peak—to—peak value (RM S value is approximately
80% of the displayed value)

DC direct current with adjustable amplitude

NOTE TheLF Out Off On softkey controls the operating state of the LF output. However, when the LF output
source selection is I nternal Monitor, you have three ways of controlling the output. You can use the
modulation source (AM, FM, or FM) on/off key, the LF output on/off key, or the Mod On/Off softkey.

The RF On/Off hardkey does not apply to the LF OUTPUT connector.

To Configurethe LF Output with an Internal M odulation Source

In this example, the internal FM modulation is the LF output source.

NOTE Interna modulation (Internal Monitor) isthe default LF output source.

Configuring the Internal Modulation asthe LF Output Source
Press Preset.

Pressthe FM/®M hardkey.
PressFM Dev > 75> kHz.
PressFM Rate> 10> kHz.
5. PressFM Off On.

You have set up the FM signal with arate of 10 kHz and 75 kHz of deviation. The FM annunciator is activated indicating
that you have enabled frequency modulation.

A w DR

Configuring the Low Frequency Output
1. Pressthe LF Out hardkey.

2. PressLF Out Amplitude> 3> Vp.

3. PressLF Out Off On.

You have configured the LF output signal for a 3 volt sine wave (default wave form) output which is frequency
modulated using the Internal 1 Monitor source selection (default source).

To Configurethe LF Output with a Function Generator Source

In this example, the function generator is the LF output source.
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Configuring the Function Generator asthe LF Output Source
1. PressPreset.

2. Pressthe LF Out hardkey.
3. PressLF Out Source> Function Generator 1.

Configuring the Waveform
1. PressLF Out Waveform > Swept-Sine.

2. PressLF Out Sart Freq > 100> Hz.
3. PressLF Out Sop Freg>1>kHz.
4. PressReturn > Return.

This returns you to the top LF Output menu.

Configuring the Low Frequency Output
1. PressLF Out Amplitude>3>Vp.

This sets the LF output amplitude to 3 Vp.
2. PressLF Out Off On.

The LF output is now transmitting a signal using Function Generator 1 that is providing a
3 Vp swept—sine waveform. The waveform is sweeping from 100 Hz to 1 kHz.
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O  Custom Arb Waveform Generator

In the following sections, this chapter describes the custom arbitrary waveform generator mode, which is available only
in E8267D PSG vector signal generators with Option 601 or 602:

*  “Overview” on page 157

«  “Working with Predefined Setups (Modes)” on page 157
*  “Working with Filters” on page 160

e “Working with Symbol Rates” on page 167

*  “Working with Modulation Types” on page 169

e “Configuring Hardware” on page 176

See dso: Chapter 3, “Basic Digital Operation,” on page 77

Overview

Custom Arb Waveform Generator mode can produce a single modulated carrier or multiple modulated carriers. Each
modulated carrier waveform must be calculated and generated before it can be output; this signal generation occurs on
the internal baseband generator (Option 601 or 602). Once a waveform has been created, it can be stored and recalled
which enables repeatable playback of test signals.

To begin using the Custom Arb Waveform Generator mode, select whether to create a single modulated carrier or a
multiple modulated carrier waveform:

« If youwant to create a single modulated carrier waveform, start by selecting a Digital Modulation Setup from a set
of predefined modes (setups). Once a predefined mode is selected, you can modify the Modulation Type, the Filter
being used, the Symbol Rate, and the type of Triggering; the Data Pattern is random by default. This modified setup
can then be stored and reused.

e If youwant to create a multiple modulated carrier waveform, start by selecting a Multicarrier Setup from a set of
predefined modes (setups). Once a predefined modeis selected, you can modify the number of carriersto be created,
the frequency spacing between each carrier, whether the phase offset between each carrier is to be fixed or random,
and the type of Triggering; the Data Pattern is random by default, the Filter is set to 40 MHz by default, and the
Symbol Rate is automatically specified by the selected Modulation Type being used.

Working with Predefined Setups (M odes)

When you select a predefined mode, default values for components of the setup (including the filter, symbol rate, and
modulation type) are automatically specified.

KEYSIGHT
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Selecting a Custom ARB Setup or a Custom Digital Modulation Sate

1
2.
3.

Preset the signal generator: press Preset.
Press Mode > Custom > Arb Waveform Generator > Setup Select.
Select either:

« one of the predefined modulation setups: NADC, PDC, PHS, GSM, DECT, EDGE, APCO 25 w/C4FM,
APCO 25 w/CQPSK, CDPD, PWT, or TETRA

This selects a predefined setup where filtering, symbol rate, and modulation type are defined by the predefined
modulation setup (mode) that you selected and returns you to the top—evel custom modulation menu; it does not
include bursting or channel coding.

or
e Custom Digital Mod Sate

This selects a custom setup stored in the Catalog of DMOD Files. (For information on creating a custom
digital modulation setup, refer to “Working with User-Defined Setups (Modes)-Custom Arb Only” on
page 158).

Working with User—Defined Setups (M odes)—Custom Arb Only

Modifying a Single-Carrier NADC Setup

In this procedure, you learn how to start with asingle—carrier NADC digital modulation and modify it to a custom
waveform with customized modulation type, symbol rate, and filtering.

1. PressPreset.
2. PressMode > Custom > ARB Waveform Generator > Setup Select > NADC.
3. PressDigital Mod Define > Modulation Type > PSK > QPSK and OQPSK > QPSK.
4. Press Symbol Rate > 56 > ksps.
5. PressFilter > Select > Nyquist.
6. PressReturn > Return > Digital Modulation Off On.
This generates a waveform with the custom single—carrier NADC digital modulation state. The display changesto
Dig Mod Setup: NADC (Modified).Duringwaveform generation, the DIGMOD and I/Q annunciators appear
and the custom single—carrier digital modulation state is stored in volatile memory.
Set the RF output frequency to 835 MHz.
Set the output amplitude to 0 dBm.
Press RF On/Off.
The user—defined NADC signal is now available at the RF OUTPUT connector.
10. Press Return > Return.
This returns to the top-evel Digital Modulation menu, where Digital M odulation Off On isthefirst softkey.
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11. Press Digital Mod Define > Store Custom Dig Mod Sate > Store To File.

If thereis dready afile name fromthe Catalog of DMOD Files occupying the active entry area, press: Edit
Keys> Clear Text

12. Enter afile name (for example, NADCQPSK) using the alpha keys and the numeric keypad.
13. PressEnter.

The user—defined single—carrier digital modulation state should now be stored in non—volatile memory. The RF
output amplitude, frequency, and operating state settings are not stored as part of a user—defined digital modulation
statefile.

Customizing a Multicarrier Setup

In this procedure, you learn how to customize a predefined multicarrier digital modulation setup by creating a custom
3—carrier EDGE digital modulation state.

Press Preset.
Press M ode > Custom > Arb Waveform Generator > Multicarrier Off On.
Press Multicarrier Define> Initialize Table> Carrier Setup > EDGE > Done.

Highlight the Freq Offset value(500.000 kHz) for the carrier in row 2, and
press Edit Item > —625 > kHz.

A WD PR

5. Highlight the Power value (0.00 dB) for the carrier in row 2, and press Edit Item >—-10 > dB.

You have a custom 2—carrier EDGE waveform with a carrier at afrequency offset of —625 kHz and a power level of
—10.00 dBm.

6. PressReturn > Digital Modulation Off On.

This generates a waveform with the custom multicarrier EDGE state. The display changesto Dig Mod Setup:
Multicarrier (Modified).Duringwaveform generation, the DIGMOD and I/Q annunciators appear and the
new custom multicarrier EDGE state is stored in volatile memory.

Set the RF output frequency to 890.01 MHz.
Set the output amplitudeto —10 dBm.
Press RF On/Off.

The custom multicarrier EDGE waveform is available at the RF OUTPUT connector; it does not include bursting or
channel coding.

10. Press Mode > Custom > Arb Waveform Generator, where Digital M odulation Off On isthe first softkey.
11. PressMulticarrier Off On > Multicarrier Define>More (1 of 2) > Load/ Store > Store To File.

If thereis adready afile name fromthe Catalog of MDMOD Files occupying the active entry area, press Edit
Keys> Clear Text.
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12. Enter afile name (for example, EDGEM1) using the alpha keys and the numeric keypad, and press Enter.
The user—defined multicarrier digital modulation state is now stored in non—volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings (such as RF On/Off) are not stored as part of
a user—defined digital modulation state file. For more information, refer to “Using Data Storage Functions”
on page 59.

Recalling a User—Defined Custom Digital Modulation State

In this procedure, you learn how to select (recall) a previously stored custom digital modulation state from the Memory
Catalog (the Catalog of DMOD Files).

1. PressPreset.

2. PressMode > Custom > ARB Waveform Generator > Setup Select.

3. PressMore(1 of 2) > Custom Digital Mod Sate.

4. Press Select Fileto select a custom modulation state from the Catalog of DMOD Files.

The user—defined custom digital modulation state should now be recalled from non—volatile memory. Because the
RF output amplitude, frequency, and operating state settings are not stored as part of a user—defined digital

modul ation state file, they must still be set or recalled separately. For more information, refer to “Using Data
Storage Functions” on page 59.

Working with Filters
This section provides information on using predefined (page 161) and user—defined (page 162) FIR filters.

NOTE The proceduresin this section apply only to filters created in either the Custom Arb Waveform Generator or
Custom Real Time |/Q Baseband mode; they do not work with downloaded files, such as those created in
Matlab.

The Filter menu selections enable you to apply afilter to the generated signal, define afinite impulse response (FIR)
filter, change a Root Nyquist or Nyquist filter alpha, change a Gaussian filter BbT, or restore all filter parametersto their
default state. In Custom Real Time 1/Q mode, you can also optimize a FIR filter for Error Vector Magnitude (EVM) or
Adjacent Channel Power (ACP)

Predefined Filters (Filter > Select)

¢ Root Nyquist is aroot—aised cosine pre-modulation FIR filter. Use a Root Nyquist filter when you want to place
half of the filtering in the transmitter and the other half in the receiver. The ideal root—raised cosine filter frequency
response has unity gain at low frequencies, the square root of raised cosine function in the middle, and total
attenuation at high frequencies. The width of the middle frequenciesis defined by the roll off factor or Filter Alpha
(O <Filter Alpha< 1).

¢ Nyquist isaraised cosine pre-modulation FIR filter. You can use a Nyquist filter to reduce the bandwidth required
by asignal without losing information. Theideal raised cosine filter frequency response comprises unity gain at low
frequencies, araised cosine function in the middle, and total attenuation at high frequencies. The width of the middle
frequencies is defined by theroll off factor or Filter Alpha (0 < Filter Alpha< 1).

e Gaussian isaGaussian pre-modulation FIR filter.
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e User FIR enablesyou to select from a Catalog of FIR filters; use this selection if the other predefined FIR filters do
not meet your needs. For more information, see Define User FIR, below.

« Rectangleisarectangular pre-modulation FIR filter.

¢ APCO 25 C4FM isan APCO 25-specified C4FM filter; thisis a Nyquist filter with an alpha of 0.200 that is
combined with a shaping filter.

Filter Parameters

* DefineUser FIR isavailable for when the predefined FIR filters do not meet your needs. You can define FIR
coefficients and set the oversample ratio (number of filter coefficients per symbol) to be applied to a custom FIR
filter.

¢ Filter Alpha enablesyou to adjust the filter alphafor a Nyquist or root Nyquist filter. If a Gaussian filter is used,
you will see Filter BbT; this softkey is grayed out when any other filter is selected.

¢ (Custom Realtime I/Q Baseband Only) Optimize FIR for EVM ACP enables you to optimize a Nyquist or root
Nyquist filter for minimized error vector magnitude (EVM) or for minimized adjacent channel power (ACP); the
softkey is grayed out when any other filter is selected.

« Restore Default Filtersreplaces the current FIR filter with the default FIR filter for the selected format.

Using a Predefined FIR Filter

Selecting a Predefined FIR Filter

1. Preset theinstrument: Press Preset.

2. PressMode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Select
or
Mode > Custom > Real Time 1/Q Baseband > Filter > Select >

3. Select the desired filter. If thefilter you want isnot in the first list, pressMore (1 of 2).

Adjusting the Filter Alpha of a Predefined Root Nyquist or Nyquist Filter

1. Preset theinstrument: Press Preset.

2. PressMode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Filter Alpha
or
Mode > Custom > Real Time 1/Q Baseband > Filter > Filter Alpha

3. Enter anew Filter Alphavalue and press Enter.

Adjusting the Bandwidth-Bit—Time (BbT) Product of a Predefined Gaussian Filter

1. PressMode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Select > Gaussian
or
Mode > Custom > Real Time 1/Q Baseband > Filter > Select > Gaussian

2. PressFilter BbT.

3. Enter anew Bandwidth-Bit—Time (BbT) product filter parameter and press Enter.

Optimizing a Nyquist or Root Nyquist FIR Filter for EVM or ACP (Custom Realtime 1/Q Baseband only)

1. Preset theinstrument: Press Preset.

2. PressMode > Custom > Real Time|/Q Baseband > Filter > Optimize FIR For EVM or ACP.
The FIR filter is now optimized for minimum error vector magnitude (EVM) or for minimum adjacent channel
power (ACP). Thisfeature applies only to Nyquist and root Nyquist filters; the softkey is grayed out when any other
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filter is selected.

Restoring Default FIR Filter Parameters
1. Preset theinstrument: Press Preset.

2. PressMode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Restore Default Filter.
This replaces the current FIR filter with the default filter for the selected modulation format.

Using a User—Defined FIR Filter

FIR filters can be created and modified by defining the FIR coefficients or by defining the oversample ratio (number of
filter coefficients per symbol) to be applied to your own custom FIR filter.

To Modify Predefined FIR Coefficientsfor a Gaussian Filter Using the FIR Values Editor

You can definefrom 1 to 32 FIR coefficients, where the maximum combination of symbols and oversampleratio is 1024
coefficients. While the FIR Values editor allows a maximum filter length of 1024 coefficients, the PSG hardware is
limited to 64 symbols for real—time and 512 symbols for arbitrary waveform generation (the number of symbols equals
the number of coefficients divided by the oversample ratio).

If you enter more than 64 symbols for real-time or 512 symbols for arbitrary waveform generation, the PSG cannot use
thefilter; it will decimate the filter (throw away coefficients) until the required condition is met and then use thefilter,
but fine resolution may be lost from the impulse response.

FIR filters stored in signal generator memory can easily be modified using the FIR Values editor. In this example, you
will load the FIR Values editor with coefficient values from adefault FIR filter (or, if one has been defined, a
user—defined FIR file that has been stored in the Memory Catalog), modify the coefficient values, and store the new file
to the Memory Catalog.

1. PressPreset.

2. PressMode> Custom > Arb Waveform Generator > Digital Mod Define > Filter
or Mode > Custom > Real Time |/Q Baseband > Filter

Press Define User FIR > More (1 of 2) > Load Default FIR > Gaussian.
PressFilter BbT > 0.300 > Enter.

PressFilter Symbols> 8 > Enter.

Press Gener ate.

o 0 &~ w

NOTE Theactua oversampleratio during modulation is automatically selected by the instrument. A value between 4
and 16 is chosen dependent on the symbol rate, the number of bits per symbol of the modulation type, and the
number of symbols.

162 Keysight PSG Signal Generators User’s Guide



Custom Arb Waveform Generator

Working with Filters

7. PressDisplay Impulse Response. A graph displays the impul se response of the current FIR coefficients.

Impulse Responsa .
Oversample Ratio: 4

1.2

TE~AC

Coefficient 31

Press Return.
Highlight coefficient 15.
10. Press0 > Enter.
11. Press Display Impulse Response.

Inpulse Response i
Oversample Ratio: U

1.9

TEAs

Coefficient 31

The graphic display can provide a useful troubleshooting tool (in this case, it indicates that a coefficient valueis set
incorrectly, resulting in an improper Gaussian response).

12. Press Return.

13. Highlight coefficient 15.

14. Press 1> Enter.

15. PressLoad/Sore> Sore To File.

16. Namethe file NEWFIR2, and press Enter.

The contents of the current FIR VValues editor are stored to afilein the Memory Catalog and the Catalog of FIR Files

is updated to show the new file.

Keysight PSG Signal Generators User’s Guide

163



Custom Arb Waveform Generator
Working with Filters

To Create a User—Defined FIR Filter with the FIR Values Editor

In this procedure, you use the FIR Values editor to create and store an 8-symbol, windowed, sinc function filter with
an oversampleratio of 4. The Oversample Ratio (OSR) is the number of filter coefficients per symbol.

You can define from 1 to 32 FIR coefficients, where the maximum combination of symbols and oversampleratio is 1024
coefficients.

The FIR Values editor allows a maximum filter length of 1024 coefficients, but the PSG hardwareis limited to 512
symbolsfor arbitrary waveform generation, and 64 symbols for real—time waveform generation. The number of symbols
equals the number of coefficients divided by the oversample ratio. If you enter more than the maximum number of
symbols, the PSG cannot use the filter; it decimates the filter (throws away coefficients) until the required condition is
met and then uses thefilter, but fine resolution may be lost from the impulse response.

1. PressPreset.
2. PressMode > Custom > Arb Waveform Generator > Digital Mod Define > Filter
or

Mode > Custom > Real Time 1/Q Baseband > Filter

3. PressDefineUser FIR > More (1 of 2).

4. PressDelete All Rows > Confirm Delete Of All Rows> More (2 of 2).
This brings up the FIR Values editor and clears the table of existing values.

FREQUEMCY

44.000 000 000 000 &+

AMPLITUOE

130 00 dBn Edit Item
’7 ﬂ Insert Rod

Oelete Ron

FIR Values Oversample Ratio: L
Coeff. Ualue

M 0 e Gota Rou

Mirrar Table

Oversample Rat iE

More
(1 of 23

Press Edit Item. The value field for coefficient 0 should be highlighted.

Use the numeric keypad to type the first value (—0.000076) from the following table and press Enter. Asyou press
the numeric keys, the numbers are displayed in the active entry area. (If you make amistake, you can correct it using
the backspace key.) Continue entering the coefficient values from the table until all 16 values have been entered.
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Coefficient Value Coefficient Value Coefficient Value
0 —0.000076 6 0.043940 12 0.123414
1 -0.001747 7 0.025852 13 0.442748
2 -0.005144 8 -0.035667 14 0.767329
3 —0.004424 9 —-0.116753 15 0.972149
4 0.007745 10 -0.157348
5 0.029610 1 -0.088484

7. PressMirror Table.

In awindowed sinc function filter, the second half of the coefficients are identical to the first half, but in reverse
order. The signal generator provides amirror table function that automatically duplicates the existing coefficient

valuesin the reverse order; coefficients 16 through 31 are automatically generated and the first of these coefficients
(number 16) highlights, as shown in the following figure.

FREQUENCY

44.000 000 000 000 &=

AMPLITLOE

-130.00 n

HHD Insert Rouw

Edit Item

Delete Row
FIR Ualues C(UHSTORED) Oversample Ratio: L
Coeff. Ualue
] 10 -0.1573L8 Goto RoWy

11 -0.088458L
12 0. 123414

13 0.L427Lg Mirror Table
14 0.767329
15 u] 1.3

16 1L Oversample Ratio

17 0.767329 L
18 0.uL2748
19 0. 123414

More
(1 of 23

8. For this example, the desired OSR is 4, which is the default, so no action is necessary.

The Oversample Ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range from 1

through 32; the maximum combination of symbolsand oversampling ratio allowed by the FIR Values editor is 1024.
Remember, however, that the instrument hardware is limited to 64 symbols for real—time waveform generation, and
512 symbols for arbitrary waveform generation. The number of symbols equals the number of coefficients divided

by the oversampleratio.
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9. PressMore (1 of 2) > Display FFT (fast Fourier transform).

A graph displays the fast Fourier transform of the current set of FIR coefficients. The signal generator has the
capability of graphically displaying the filter in both time and frequency dimensions.

FFT

[--1-1

=100

Sumbol Rate

(-]

10. Press Return > Display | mpulse Response.
A graph shows the impul se response of the current set of FIR coefficients.

Impulse Responsa i
Oversample Ratio: U

LR - TR —

1] Coefficient 31

11. PressReturn > Load/Store> Store To File.
The Catalog of FIR Files appears along with the amount of memory available.
12. If thereis aready afile name occupying the active entry area, press: Edit Keys> Clear Text
13. Using the a phabetic menu and the numeric keypad, enter NEWFIR1 as the file name.
14. Press Enter.

The NEWFIRL1 fileisthefirst file namelisted. (If you have previously stored other FIR files, additional file names
arelisted below NEWFIR1.) Thefiletypeis FIR and the size of the file is 260 bytes. The amount of memory used is
also displayed. The number of files that can be saved depends on the size of the files and the amount of memory
used.
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FREQUENC'Y

44.000 000 000 000 s+

AMPLTTUOE Load From

—130 00 dBm Selected File
’7 ﬂ Store Toyl
on File

Oelete File

Catalog of FIR Files 260 butes used BLL3Z2112EL butes free
File Hame Tupe Size Hodified
] 1 3 ] 07 /01 1b:36 Goto RowM
Page Up
Page Doun

Working with Symbol Rates

The Symbol Rate menu enables you to set the rate at which 1/Q symbols are fed to the I/Q modulator. The default
transmission symbol rate can also be restored in this menu.

* Symbol Rate (displayed as Sym Rate) isthe number of symbols per second that are transmitted using the
modulation (displayed asMod Type) along with the filter and filter alpha (displayed as Filter). Symbol rate
directly influences the occupied signal bandwidth.

Symbol Rate is the Bit Rate divided by the number of bits that can be transmitted with each symbol; thisis also
known as the Baud Rate.

* Bit Rateisthe frequency of the system bit stream. The internal baseband generator (Option 602) automatically
streams the selected Data Pattern at the appropriate rate to accommaodate the symbol rate setting (Bit Rate =
Symbols/s x Number of Bits/Symbol).

¢ Occupied Signal Bandwidth = Symbol Rate x (1 + Filter Alpha); therefore, the occupied signal bandwidth is
dependent on thefilter alpha of the Nyquist or Root Nyquist filter being used. (To change thefilter alpha, refer to the
procedure, “Adjusting the Filter Alpha of a Predefined Root Nyquist or Nyquist Filter” on page 161.)

To Set a Symbol Rate
1. PressPreset.

2. PressMode> Custom > ARB Waveform Generator > Digital Mod Define > Symbol Rate
or
Mode > Custom > Real Time 1/Q Baseband > Symbol Rate

3. Enter anew symbol rate and press M sps, ksps, or sps.
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To Restore the Default Symbol Rate (Custom Real Time [/Q Only)
¢ PressMode> Custom > Real Timel/Q Baseband > Symbol Rate > Restore Default Symbol Rate.
This replaces the current symbol rate with the default symbol rate for the sel ected modulation format.

Bits Custom Real Time Only
Modulation Type Per Bit Rate= Internal Symbol Rate External Symbol Rate
yp Symbol Symbols/s x Number of (Minimum Maximum) (Minimum Maximum)
Bits/Symbol
PSK QPSK and OQPSK 2 90 bps— 100 Mbps 45 sps— 50 Msps 45 sps— 25 Msps
(quadrature phase shift keying and
Phase offset quadrature phase shift keying)
Shift Includes: QPSK, 1S95 QPSK,
Keying Gray Coded QPSK, OQPSK,
1S95 OQPSK
BPSK 1 45 bps— 50 Mbps 45 sps— 50 Msps 45 sps— 50 Msps
(binary phase shift keying)
/4 DQPSK 2 90 bps— 100 Mbps 45 sps— 50 Msps 45 sps— 25 Msps
8PSK 3 135 bps— 150 Mbps 45 sps— 50 Msps 45 sps— 16.67 Msps
(eight phase state shift keying)
16PSK 4 180 sps— 200 Mbps 45 sps— 50 Msps 45 sps— 12.5 Msps
(sixteen phase state shift keying)
D8PSK 3 135 bps— 150 Mbps 45 sps— 50 Msps 45 sps— 16.67 Msps
(eight phase state shift keying)
MSK MSK 1 45 bps— 50 Mbps 45 sps— 50 Msps 45 sps— 50 Msps
Minimum (GSM —Global System for
Shift Mobile Communications)
Keying
FSK 2-Lvl FSK 1 45 bps— 50 Mbps 45 sps— 50 Msps 45 sps— 50 Msps
;rfﬁuency 4-Lvl FSK 2 90 bps— 100 Mbps 45 sps— 50 Msps 45 sps— 25 Msps
i
Keying
8-Lvl FSK 3 135 bps— 150 Mbps 45 sps— 50 Msps 45 sps— 16.67 Msps
16-Lvl FSK 4 180 bps— 200 Mbps 45 sps— 50 Msps 45 sps— 12.5 Msps
C4FM 2 90 bps— 100 Mbps 45 sps— 50 Msps 45 sps— 25 Msps
QAM 4QAM 2 90 bps— 100 Mbps 45 sps— 50 Msps 45 sps— 25 Msps
Quadrature | 160AM 4 180 bps— 200 Mbps 45 sps— 50 Msps 45 sps— 12.5 Msps
Amplitude
Modulation | o>0am 5 225 bps— 250 Mbps 45 sps— 50 Msps 45 5ps— 10 Msps
64QAM 6 270 bps — 300 Mbps 45 sps— 50 Msps 45 sps— 8.33 Msps
128QAM 7 315 bps — 350 Mbps 45 sps— 50 Msps 45 sps— 7.14 Msps
Thereisno preset value for this
modulation, it must be user defined.
256QAM 8 360 bps — 400 Mbps 45 sps— 50 Msps 45 sps— 6.25 Msps
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Working with Modulation Types

The Modulation Type menu enables you to specify the type of modulation applied to the carrier signal when the Mod
On Off hardkey is on.

When the Custom Off On softkey ison:

e For Custom Arb, the BBG (baseband generator) creates a sampled version of the 1/Q waveform based on a random
data pattern and the modulation type that has been selected.

¢ For Custom Real Time 1/Q, the real—time custom I/Q symbol builder creates I/Q symbols based on the data pattern
and modulation type that has been selected (see “Working with Data Patterns” on page 180 for information on
selecting a data pattern).

In Custom Real Time I/Q, you can aso:
¢ Create user—defined modulation type (see page 169) that can be used immediately or saved to the Memory Catalog.
¢ Restore al modulation parameters to their default state.

To Select a Predefined M odulation Type
1. PressPreset.

2. PressMode > Custom > ARB Waveform Generator > Digital Mod Define > Modulation Type > Select
or
Mode > Custom > Real Time 1/Q Baseband > Modulation Type > Select

3. Select one of the available modulation types.

NOTE If you select QPSK and OQPSK, you must make a specific selection from the menu that displays.

To Use a User—Defined M odulation Type (Real Time1/Q Only)

Creating a 128QAM 1/Q Modulation Type User Filewith thel/Q Values Editor

In 1/Q modulation schemes, symbols appear in default positionsin the 1/Q plane. Using the I/Q values editor, you can
define your own symbol map by changing the position of one or more symbols. Use the following procedure to create
and store a 128-symbol QAM modulation.

NOTE Although this procedure provides a quick way to implement a 128QAM modulation format, it does not take
full advantage of the I/Q modulator’s dynamic range. Thisis because you begin with a256QAM constellation,
and delete unwanted points. The remaining points that make up the 128QAM constellation are closer together
than if you had mapped each point specifically. Additionally, this approach does not enable you to define the
bit pattern associated with each symbol point, asyou could if the 128QAM constellation had been defined one
point at atime.

Press Preset.

2. PressMode > Custom > Real Time |/Q Baseband > Modulation Type > Define User 1/Q >
More (1 of 2) > Load Default 1/Q Map > QAM > 256QAM.

This loads a default 256QAM 1/Q modulation into the I/Q Values editor.
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3. PressMore (2 of 2) > Display |/Q Map.

+

=

=W =)= T i —

I/Q State Map
I/0 States: 256

T++++++++ T
+++++++F A+
++++++++ A+
+++++++F A+
+++++++F A+
++++++++ A+
+++++++F A+
++++++++++++++++
++++++++ A+
++++++++ A+
+++++++F A+
+++++++F A+
++++++++ A+
+++++++F A+
++++++++ A+

THH+++++++H+ 4T

-1 I Ualue +1

In the next steps, you will delete specific portions of this1/Q constellation and change it into a 128QAM with 128

1/Q states.

4. PressReturn > Goto Row > 0011 0000 > Enter; thisis row 48.

170

Keysight PSG Signal Generators User’s Guide



Custom Arb Waveform Generator
Working with Modulation Types

5. Pressthe Delete Row softkey 16 times.
Repeat this pattern of steps using the following table:

Goto Row... Press the Delete Row softkey...
0110 0000 (96) 16 times
1001 0000 (144) 16 times
1100 0000 (192) 16 times
0001 0000 (16) 4 times
0001 0100 (20) 4times
0001 1000 (24) 8times
0011 0000 (48) 4times
0011 0100 (52) 4 times
0011 1000 (56) 4times
0101 1000 (88) 8times
0111 0000 (112) 4times
0111 0100 (116) 4 times
0111 1000 (120) 8times

6. PressDisplay I/Q Map to view the new constellation that has been created.

The I/Q State Map in this example has 128 symbols. I'm State l1ap

I/0 States: 128

7. PressReturn. When the contents of an I/Q Values table have not been +1 1
stored, I/Q Values (UNSTORED) appearson thedisplay. 0 R
+++++++ 4+
8. PressMore(1of 2) > Load/Sore> Sore ToFile. U R M
. . , . a ++++ S+
If thereisalready afile name fromthe Catalog of IQ Files occupying 1 ottt bt
the active entry area, press the following keys: u R M
. e +4+++++
Editing Keys> Clear Text FHEF R R
+++++++ 4+
9. Enter afile name (for example, 128QaM) using the alpha keys and the L
numeric keypad. -11

10. PressEnter. -1 I Ualue +1

The user—defined 1/Q State Map should now be stored in the Catalog of IQ Files.

Creating a QPSK 1/Q Modulation Type User Filewith the 1/Q Values Editor

In 1/Q modulation schemes, symbols appear in default positionsin the 1/Q plane. Usingthe I/Q Values editor, you can
define your own symbol map by changing the position of one or more symbols. Use the following procedure to create
and store a4—symbol unbalanced QPSK modulation.

1. PressPreset.
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2. PressMode > Custom > Real Time |/Q Baseband > Modulation Type > Define User 1/Q > More (1 of 2) >
Delete All Rows > Confirm Delete All Rows.

Thisloads adefault 4QAM 1/Q modulation and clearsthe I/Q Values editor.
3. Enter thel and Q values listed in the following table:

Symbol Data | Value Q Value
0 0000 0.500000 1.000000
1 0001 —0.500000 1.000000
2 0010 0.500000 —1.000000
3 0011 —0.500000 —1.000000

a Press0.5> Enter.
b. Press1> Enter.
c. Enter theremaining | and Q vaues.

Asthe | value updates, the highlight moves to the first Q entry (and provides a default value of 0) and an empty row
of data appears below thefirst row. Asthe Q value updates, the highlight movesto the next | value. Asyou pressthe
numeric keys, the numbers display in the active entry area. If you make a mistake, use the backspace key and retype.

Also notethat 0.000000 appears asthefirst entry inthelist of Distinct Values, andthat 0.500000 and
1.000000 arelisted as the distinct values.

4. PressMore (2 of 2) > Display 1/Q Map.
An I/Q State Map is displayed from the current valuesinthe I/Q Values table.

The I/Q State Map in this example has four symbols. The 1/Q State Map uses the following four unique values: 0.5,
1.0, -0.5, and —1.0 to create the four symbols. It is not the number of values that defines how many symbols a map
has, but how those values are combined.

5. PressReturn.

When the contents of an I/Q Values table have not been stored, I/Q Values (UNSTORED) appearson the
display.
6. PressMore (1 of 2) > Load/Store> Store To File.

If thereis aready afile namefromthe Catalog of IQ Files occupying the active entry area, pressthe
following keys: Editing Keys> Clear Text

Enter afile name (for example, NEW4QaM) using the alpha keys and the numeric keypad.

Press Enter. The user—defined 1/Q State Map should now be stored inthe Catalog of IQ Files and canbe
recalled even after the signal generator has been turned off.
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Modifying a Predefined 1/Q Modulation Type (1/Q Symbols) & Simulating Magnitude Errors & PhaseErrors

Use the following procedure to manipulate symbol locations which simulate magnitude and phase errors. In this
example, you edit a4QAM constellation to move one symbol closer to the origin.

1
2.

Press Preset.

Press M ode > Custom > Real Time 1/Q Baseband > Modulation Type > Define User 1/Q > More (1 of 2) >
L oad Default 1/Q Map > QAM > 4QAM.

This loads a default 4QAM 1/Q modulation into the I/Q Values editor.
PressMore (2 of 2).

Inthe I1/Q Values editor, navigateto Data 00000000 and press Edit Item.
Press .235702 > Enter, then .235702 > Enter.

When you press Enter thefirst time, the | value updates and the highlight moves to the first Q entry. The second
time, the Q value updates and the highlight moves to the following | entry.

Press Display 1/Q Map. Note that one symbol has moved, as shown.

FREQUENCY

44.000 000 000 000 &tz

AMPLITUDE

130.00 den
&

1/0 State Map
I/0 States: L

+1 [+
0 /
g +
1
u
e
_1 + +
-1 I Ualue +1

Creating an FSK Modulation Type User Filewith the Frequency Values Editor
Use this procedure to set the frequency deviation for data 00, 01, 10, and 11 to configure a user—defined FSK

modulation.
1. PressPreset.
2. PressMode > Custom > Real Time |/Q Baseband > Modulation Type > Define User FSK > More (1 of 2) >

Delete All Rows > Confirm Delete All Rows.

This accesses the Frequency Values editor and clears the previous values.
Press 600 > Hz.

Press 1.8 > kHz.

Press—600 > Hz.
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6. Press-1.8>kHz.

Each time you enter avalue, the Data column increments to the next binary number, up to atotal of 16 data values
(from 0000 to 1111). An unstored file of frequency deviation valuesis created for the custom 4-{evel FSK file.

7. PressLoad/Sore> SoreTo File.

If thereis dready afile name fromthe Catalog of FSK Files occupying the active entry area, pressthe
following keys:

Edit Keys> Clear Text

Enter afile name (for example, NEWFSK) using the alpha keys and the numeric keypad.
Press Enter.

The user—defined FSK modulation should now be stored inthe Catalog of FSK Files.

Modifying a Predefined FSK Modulation Type User File with the Frequency Values Editor

Using the Frequency Values editor, you can define, modify, and store user—defined frequency shift keying
modulation. The Frequency Values editor is available for custom Real-Time |/Q Baseband mode, but is not
available for waveforms generated in custom Arb Waveform Generator mode. Use this example to learn how to add
errors to a default FSK modulation.

1. PressPreset.

2. PressMode > Custom > Real Time |/Q Baseband > Modulation Type > Define User FSK > More (1 of 2) >
L oad Default FSK.

3. PressFreq Dev >1.8>kHz.
Press4-L vl FSK.

This sets the frequency deviation and opens the Frequency Values editor with the 4-level FSK default values
displayed. The frequency value for data 0000 is highlighted.

Press—1.81 > kHz.
Press—590 > Hz.
Press 1.805 > kHz.
Press 610 > Hz.

Asyou modify the frequency deviation values, the cursor moves to the next data row. An unstored file of frequency
deviation values is created for your custom 4-evel FSK file.

9. PressLoad/Sore> SoreToFile.

If there is already afile name fromthe Catalog of FSK Files occupying the active entry area, pressthe
following keys:

© N o u

Edit Keys> Clear Text
10. Enter afile name (for example, NEWFSK) using the alpha keys and the numeric keypad.
11. PressEnter.
The user—defined FSK modulation should now be stored inthe Catalog of FSK Files.
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Differential Wideband 1Q (Option 016)

The signal generator with Option 016 can use an external 1/Q modulation source such as atwo channel arbitrary
waveform generator to generate up to 2 GHz modulation bandwidth at RF. To enable the wideband 1/Q inputs:

1. Pressthefront panel I/Q hardkey.

2. Press|/Q Off.

3. Press|/Q Path Wide (Ext Rear Inputs).
4. Press|/Q On.

Connect the external 1/Q modulation source to the signal generator’s rear panel, differential WIDEBAND 1/Q INPUTS.
Thevoltagelevel at theinputsis+/—1 Vdc. Wideband 1Q isavailable for RF above 3.2 GHz. Refer to the Data Sheet for
more information.

Itispossibleto usethe signal generator’sinternal arbitrary waveform generator (ARB) as a baseband source while using
the wideband inputs at RF. Theinternal ARB | and Q signals are available at the | and Q OUT and the I-bar and Q-bar
OUT rear panel connectors. Use the following stepsto set up the internal ARB as a baseband source and enable the
wideband inputs.

Set up theinternal baseband generator with the desired signal.
Press the Mux hardkey.

Press1/Q Out.

PressBBG1

Press the front panel 1/Q hardkey.

Press1/Q Off.

Press 1/Q Path Wide (Ext Rear Inputs).

Press1/Q On.

O N o ok~ 0D

Single-Ended Wideband 1Q (Option 015 — Discontinued)

The signal generator with Option 015 can use an external 1/Q modulation source such as atwo channel arbitrary
waveform generator to generate up to 2 GHz modulation bandwidth at RF. To enable the wideband 1/Q inputs:

1. Pressthefront panel I/Q hardkey.

2. Press|/Q Off.

3. Press|/Q Path Wide (Ext Rear Inputs).
4. Press|/Q On.

Connect the external 1/Q modulation source to the signal generator’s rear panel WIDEBAND | INPUT and
WIDEBAND Q INPUT. Thevoltage level at theinputsis +/—1 Vdc. Wideband |Q is available for RF above 3.2 GHz.
Refer to the Data Sheet for more information.

Itispossibleto usethe signal generator’sinternal arbitrary waveform generator (ARB) as a baseband source while using
the wideband inputs at RF. Theinternal ARB | and Q signals are available at the | and Q OUT and the I-bar and Q-bar
OUT rear panel connectors. Use the following steps to setup the internal ARB as a baseband source and enable the
wideband inputs.

1. Set uptheinternal baseband generator with the desired signal.
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Press the M ux hardkey.

Press1/Q Out.

PressBBG1

Press the front panel 1/Q hardkey.
Press1/Q Off.

Press1/Q Path Wide (Ext Rear Inputs).
Press1/Q On.

© N o oA~ WD

Configuring Hardware

To Set a Delayed, Positive Polarity, External Single Trigger

Using this procedure, you learn how to utilize an external function generator to apply a delayed single-trigger to a
custom multicarrier waveform.

1. Connect an Keysight 33120A function generator or equivalent to the signal generator PATT TRIGGER IN port, as

shown in Figure 6-1.
PATTERN
i TRIG IN FUNCTION

Figure6-1

== > GENERATOR
o = geEg
o] @ gﬁﬁng o \—L‘@
Q =] EEE B8 o O ooooonds ©

Doooooong
SIGNAL GENERATOR \ OUTPUT j

On the signal generator, press Preset.

pk719b

Press Mode > Custom > Arb Waveform Generator.
Press Multicarrier Off On until On is highlighted.
Press Trigger > Single.

Press Trigger > Trigger Setup >Trigger Source > Ext.
Press Ext Polarity Neg Pos until Posis highlighted.
Press Ext Delay Off On until On is highlighted.

Press Ext Delay Time > 100 > msec.

© o N o g~ w D

The Custom Arb Waveform Generator has been configured to play asingle multicarrier waveform 100 milliseconds
after it detectsachangein TTL state from low to high at the PATT TRIG IN rear panel connector.

10. Set the function generator waveform to a 0.1 Hz square wave at an output level of 0 to 5V.
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11. Onthe signal generator, press Mode > Custom > Arb Waveform Generator > Digital M odulation Off On until
Onis highlighted.

This generates a waveform with the custom multicarrier state and the display changesto Dig Mod Setup:
Multicarrier.

During waveform generation, the DIGMOD and I/Q annunciators activate and the new custom multicarrier stateis
stored in volatile ARB memory. The waveform should be modulating the RF carrier.

12. Press RF On/Off.

The externally single-triggered custom multicarrier waveform should be available at the signal generator’s RF
OUTPUT connector 100 ms after receiving achangein TTL state from low to high at the PATT TRIG IN.
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/  Custom Real Time I/Q Baseband

In the following sections, this chapter describes the custom real—time I/Q baseband mode, which is available only in
E8267D PSG vector signal generators with Option 601 or 602:

e “Overview” on page 179

«  “Working with Predefined Setups (Modes)” on page 179
*  “Working with Data Patterns” on page 180

e “Working with Burst Shapes” on page 185

» “Configuring Hardware” on page 189

e “Working with Phase Polarity” on page 191

*  “Working with Differential Data Encoding” on page 191
See also: Chapter 3, “Basic Digital Operation,” on page 77

Overview

Custom Real Time I/Q Baseband mode can produce a single carrier, but it can be modulated with real time data that
alows real time control over all of the parameters that affect the signal. The single carrier signal that is produced can be
modified by applying various data petterns, filters, symbol rates, modulation types, and burst shapes.

To begin using the Custom Real Time I/Q Baseband mode, start by selecting from a set of predefined modes (setups) or
specify a setup by selecting a Data Pattern, Filter, Symbol Rate, Modulation Type, Burst Shape, Configure Hardware,
Phase Polarity, and whether Differential Data Encode is off or on.

Working with Predefined Setups (M odes)

When you select a predefined mode, default values for components of the setup (including the filter, symbol rate, and
modulation type) are automatically specified.

Selecting a Predefined Real Time M odulation Setup

The following steps select a predefined mode where filtering, symbol rate, and modulation type are defined by the
APCO 25 w/C4FM digital modulation standard, and return to the top—evel custom modulation menu.

1. PressPreset.
2. PressMode> Custom > Real Time I/Q Baseband.

KEYSIGHT

TECHNOLOGIES
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3. PressMore (1 of 3) > More (2 of 3) > Predefined Mode > APCO 25 w/C4FM.
4. PressMore (3 of 3).

Deselecting a Predefined Real Time Modulation Setup

To deselect any predefined mode that has been previously selected, and return to the top-evel custom modulation menu:
1. PressPreset.

2. PressMode > Custom > Real Time |/Q Baseband.

3. PressMore(1of 3)>More (2 of 3) > Predefined Mode > None.

4. PressMore (3 of 3).

Working with Data Patterns

This section provides information on the following:

¢ “Using a Predefined Data Pattern” on page 181

e “Using a User-Defined Data Pattern” on page 181

e “Using an Externally Supplied Data Pattern” on page 185

The Data menu enables you to select from predefined and user defined data patterns. Data Patterns are used for
transmitting continuous streams of unframed data. When the Custom Off On softkey is on, the real—time custom 1/Q
symbol builder creates I/Q symbols based on the data pattern and modulation type that has been selected. Refer to
“Working with Modulation Types” on page 169 for information on selecting a modulation type.

The following data patterns are available:

¢ PN sequence alows you to access amenu (PN9, PN11, PN15, PN20, PN23) for internal data generation of
pseudorandom sequences (pseudorandom noise sequences); a pseudorandom noise sequence is a periodic binary
sequence approximating, in some sense, a Bernoulli “coin tossing” process with equiprobabl e outcomes.

¢ FIX4 0000 alowsyou to define a4—bit repeating sequence data pattern and make it the active function. The selected
4-hit pattern will be repeated as necessary to provide a continuous stream of data.

e Other Patterns allows you to access amenu of choices(41's& 40's,81's& 80's,16 1's& 160's,321's& 320's,
or 64 1's & 64 0's) from which you can select a data pattern. Each pattern contains an equal number of ones and
zeroes. The selected pattern will be repeated as necessary to provide a continuous stream of data.

e User File allows you to access a menu of choices from which you can create afile and store it to the Catalog of Bit
Files, select from a Catalog of Bit Filesand useit, or select from a Catalog of Bit Files, edit the file, and resave the
file.

« Ext alows data patterns to be fed into the 1/Q symbol builder, through the DATA port, in real—time.
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Using a Predefined Data Pattern

Selecting a Predefined PN Sequence Data Pattern
1. PressPreset.

2. PressMode > Custom > Real Time|/Q Baseband > Data > PN Sequence.
3. Pressoneof thefollowing: PN9, PN11, PN15, PN20, PN23.

Selecting a Predefined Fixed 4-bit Data Pattern
1. PressPreset.

2. PressMode> Custom > Real Time |/Q Baseband > Data > FI X4.
3. Press1010 > Enter > Return.

Selecting a Predefined Data Pattern Containing an Equal Number of 1s& 0Os
1. PressPreset.

2. PressMode > Custom > Real Time |/Q Baseband > Data > Other Patterns.

3. Pressone of thefollowing:

41s& 40's5,81's& 80's,161's& 160's,321's& 320's,0r641's& 640's.

Using a User—Defined Data Pattern

User Files (user—defined data pattern files) can be created and modified using the signal generator’'sBit File Editor
or they can be created on aremote computer and moved to the signal generator for direct use; these remotely created data
pattern files can also be modified with the Bit File Editor. For information on creating user—defined datafileson a
remote computer, see the Keysight Signal Generators Programming Guide.

These procedures demonstrate how to usetheBit File Editor to create, edit, and store user—defined data pattern
files for use within the custom real-time 1/Q baseband generator modulation. For this example, auser fileis defined
within a custom digital communication.

Creating a Data Pattern User File with the Bit File Editor

This procedure uses the Bit File Editor to create a Data Pattern User File and stores the resulting file in the Memory
Catalog (described on page 59).

1. PressPreset.
2. PressMode > Custom > Real Time |/Q Baseband > Data > User File> CreateFile.
This opensthe Bit File Editor, which contains three columns, as shown in the following figure.
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NOTE When you create anew file, the default name is UNTITLED, or UNTITLEDL, and so forth. This prevents
overwriting previousfiles.

3. Using the numeric keypad (not the softkeys), enter the 32 bit values shown.

Bit datais entered into the Bit File Editor in 1-bit format. The current hexadecimal value of the binary datais shown
inthe Hex Data column and the cursor position (in hexadecimal) is shown in the Position indicator.
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PressMore (1 of 2) > Rename > Editing Keys > Clear Text.

Enter afile name (for example, USER1) using the a pha keys and the numeric keypad.

Press Enter.

The user file should be renamed and stored to the Memory Catalog with the name USER1.

Selecting a Data Pattern User File from the Catalog of Bit Files

In this procedure, you learn how to select a data pattern user file from the Catal og of Bit Files. If you have not created
and stored a user—defined datafile, complete the stepsin the previous section, “Creating a Data Pattern User File with
the Bit File Editor” on page 181.

1

2
3.
4

Press Preset.

Press Mode > Custom > Real Time 1/Q Baseband > Data > User File.
Highlight the file to be selected (for example, USER1) .

Press Edit File.

TheBit File Editor should open the selected file (for example, USER1L).

Modifying an Existing Data Pattern User File

In this example, you learn how to modify an existing data pattern user file by navigating to a particular bit position and
changing its value. Next, you will learn how to invert the bit values of an existing data pattern user file.

If you have not already created, stored, and recalled a data pattern user file, complete the steps in the previous sections,
“Creating a Data Pattern User File with the Bit File Editor” on page 181 and “Selecting a Data Pattern User File
from the Catalog of Bit Files” on page 183.
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Navigating the Bit Values of an Existing Data Pattern User File
1. PressGoto>4>C >Enter.

This moves the cursor to bit position 4C, of the table, as shown in the following figure.

Cursor moves to new position

Position indicator changes
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Inverting the Bit Values of an Existing Data Pattern User File
1. Onthekeypad, press 1011.

Thisinverts the bit values that are positioned 4C through 4F. Notice that hex data in this row has now changed to

76DB6DBS6, as shown in the following figure.

Bits 4C through 4F inverted

Hex Data changed

/
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To Apply Bit Errorsto an Existing Data Pattern User File

This example demonstrates how to apply bit errorsto an existing data pattern user file. If you have not created and stored
adata pattern user file, first complete the stepsin the previous section, “Creating a Data Pattern User File with the Bit
File Editor” on page 181.

1. PressApply Bit Errors.
2. PressBit Errors>5> Enter.
3. PressApply Bit Errors.
Notice both Bit Errors softkeys change value as they are linked.

Using an Externally Supplied Data Pattern

In this procedure, an external real time data pattern is supplied through DATA, DATA CLOCK, and SYMBOL SYNC
connectors.

Press Preset.

Press M ode > Custom > Real Time I/Q Baseband > Data > Ext.
Connect the real-time data to the DATA input.

Connect the data clock trigger signal to DATA CLOCK input.
Connect the symbol sync trigger to the SYMBOL SYNC input.

grLODNDE

Working with Burst Shapes

e “Configuring the Burst Rise and Fall Parameters” on page 186
e “Using User-Defined Burst Shape Curves” on page 186

The Burst Shape menu enables you to modify the rise and fall time, rise and fall delay, and the burst shape (either sine or
user file defined). In addition, you can define the shape of the burst and preview the burst shape through a Rise Shape
Editor, or restore all of the burst shape parameters back to their original default state.

Risetime the period of time, specified in bits, where the burst increases from a minimum of —70 dB (0) to
full power (1).

Fal time the period of time, specified in bits, where the burst decreases from full power (1) to a minimum
of =70 dB (0).

Rise delay the period of time, specified in bits, that the start of the burst rise is delayed. Rise delay can be

either negative or positive. Entering adelay other than zero shifts the full power point earlier or
later than the beginning of the first useful symbol.

Fall delay the period of time, specified in hits, that the start of the burst fall is delayed. Fall delay can be
either negative or positive. Entering adelay other than zero shifts the full power point earlier or
later than the end of the last useful symbol.

User—defined

burst shape up to 256 user—entered values, which define the shape of the curve in the specified rise or fall
time. The values can vary between 0 (no power) and 1 (full power) and are scaled linearly. Once
specified, the values are resampled as necessary to create the cubic spline that passes through all
of the sample points.

The default burst shape of each format isimplemented according to the standards of the format selected. You can,
however, modify the following aspects of the burst shape:
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Burst shape maximum rise and fall time values are affected by the following factors:

¢ thesymbol rate
« the modulation type

When therise and fall delays equal 0, the burst shape attempts to synchronize the maximum burst shape power to the
beginning of thefirst valid symbol and the ending of the last valid symbol.

If you find that the error vector magnitude (EVM) or adjacent channel power (ACP) increases when you turn bursting
on, you can adjust the burst shape to assist with troubleshooting.

Configuring the Burst Rise and Fall Parameters

Press Preset.

Press Mode > Custom > Real Time 1/Q Baseband > Burst Shape.
PressRise Time > 5 > bits.

Press Rise Delay > 1 > bits.

PressFall Time> 5> bits.

Press Fall Delay > 1 > bits.

This configures the burst shape for the custom real—time I/Q baseband digital modulation format. For instructions on
creating and applying user—defined burst shape curves, see “To Create and Store User-Defined Burst Shape Curves”
on page 187.

© g & W NP

Using User—Defined Burst Shape Curves

You can adjust the shape of the rise time curve and the fall time curveusing theRise Shape and Fall Shape editors.
Each editor enables you to enter up to 256 values, equidistant in time, to define the shape of the curve. The values are
then resampled to create the cubic spline that passes through all of the sample points.

TheRise Shape and Fall Shape editors are available for custom real—time 1/Q baseband generator waveforms.
They are not available for waveforms generated by the dual arbitrary waveform generator.
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You can also design burst shape files externally and download the data to the signal generator. For more information, see
the Keysight Signal Generators Programming Guide.

To Create and Store User—Defined Bur st Shape Curves

Using this procedure, you learn how to enter rise shape sample values and mirror them asfall shape valuesto create a
symmetrical burst curve.

1

2
3.
4

Press Preset.

Press Mode > Custom > Real Time |/Q Baseband > Burst Shape.

Press Define User Burst Shape> More (1 of 2) > Delete All Rows > Confirm Delete Of All Rows.
Enter values similar to the sample valuesin the following table:

Rise Shape Editor

Sample Value Sample Value

0 0.000000 5 0.900000
1 0.400000 6 0.950000
2 0.600000 7 0.980000
3 0.750000 8 0.990000
4 0.830000 9 1.000000

Press .4 > Enter.

Press .6 > Enter.

a0 T o

Highlight the value (1. 000000) for sample 1.

Enter the remaining values for samples 3 through 9 from the table above.

PressMore (2 of 2) > Edit Fall Shape> Load Mirror Image of Rise Shape >
Confirm Load Mirror Image of Rise Shape.

This changes the fall shape values to amirror image of the rise shape values.
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5. PressMore (1 of 2) > Display Burst Shape.

This displays agraphical representation of the waveform’srise and fall characteristics.

Figure7-2
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NOTE To return the burst shape to the default conditions, press Return > Return > Confirm Exit From Table

Without Saving > Restore Default Burst Shape.

6. PressReturn > Load/Sore> SoreTo File.
If thereis dready afile name fromthe Catalog of SHAPE Files occupying the active entry area, pressthe
following keys: Editing Keys> Clear Text

7. Enter afile name (for example, NEWBURST) using the alpha keys and the numeric keypad.

188 Keysight PSG Signal Generators User’s Guide



8.

Custom Real Time I/Q Baseband
Configuring Hardware

Press Enter.

The contents of the current Rise Shape and Fall Shape editorsare stored tothe Catalog of SHAPE Files.
This burst shape can now be used to customize a modulation or as a basis for a new burst shape design.

To Select and Recall a User—Defined Burst Shape Curve from the Memory Catalog

Once a user—defined burst shapefileis stored in the Memory Catalog, it can be recalled for use with real—time I/Q
baseband generated digital modulation.

This example requires a user—defined burst shape file stored in memory. If you have not created and stored a
user—defined burst shape file, complete the steps in the previous sections.

1

2
3.
4

Press Preset.

Press Mode > Custom > Real Time |/Q Baseband > Burst Shape > Burst Shape Type > User File.
Highlight the desired burst shape file (for example, NEWBURST).

Press Select File.

The selected burst shape file is now applied to the current real-time 1/Q baseband digital modulation state.
Press Return > Custom Off On.

This generates the custom modul ation with user—defined burst shape created in the previous steps. During waveform
generation, the CUSTOM and I/Q annunciators activate. The waveform is now modulating the RF carrier.

Press RF On/Off.

The current real—time 1/Q baseband digital modulation format with user—defined burst shape should be available at
the signal generator’s RF OUTPUT connector.

Configuring Hardware

“To Set the BBG Reference” on page 189

“To Set the External DATA CLOCK to Receive Input as Either Normal or Symbol” on page 190
“To Set the BBG DATA CLOCK to External or Internal” on page 190

“To Adjust the I/Q Scaling” on page 190

To Set the BBG Reference

Setting for an External or Internal Reference

1

Press Mode > Custom > Real Time |/Q Baseband > More (1 of 3) > Configure Hardware.
Configure Hardware displays a menu where you can set the BBG Reference to External or Internal.
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2. PressBBG Ref Ext Int to select either external or internal as the bit—clock reference for the data generator.
If external is selected, apply the reference frequency to the rear—panel BASEBAND GEN REF IN connector.

Setting the External Frequency
The BBG reference external frequency is used only when the BBG Ref Ext I nt softkey has been set to Ext (external).
1. PressMode> Custom > Real Time|/Q Baseband > More (1 of 3) > Configure Hardware.

Configure Hardware displays a menu where you can set the external BBG reference frequency.

Press Ext BBG Ref Freq.

Use the numeric keypad to a desired frequency, then pressMHz, kHz, or Hz.

To Set the External DATA CLOCK to Receive Input as Either Normal or Symboal
1. PressMode> Custom > Real Time|/Q Baseband > More (1 of 3) > Configure Hardware.

Configure Hardware allows you to access a menu from which you can set the external DATA CLOCK to receive
input as either Normal or Symbol.

2. PressExt Data Clock to select either Normal or Symbol; this setting has no effect in internal clock mode.
e When set to Normal, the DATA CLOCK input connector requires a bit clock.

e When set to Symbol, a one-shot or continuous symbol sync signal must be provided to the SYMBOL SYNC
input connector.

To Set the BBG DATA CLOCK to External or Internal
1. PressMode > Custom > Real Time 1/Q Baseband > More (1 of 3) > Configure Hardware.

Configure Hardware allows you to access a menu from which you can set the BBG DATA CLOCK to receive input
from External or Internal.

2. PressBBG Data Clock Ext Int to select either external or internal.
e When set to Ext (external), the DATA CLOCK connector is used to supply the BBG Data Clock.
e When set to Int (internal), the internal data clock is used.

To Adjust thel/Q Scaling

Adjusting the 1/Q Scaling (amplitude of the 1/Q outputs) multipliesthe | and Q data by the 1/Q scaling factor that is
selected and can be used to improve the Adjacent Channel Power (ACP). Lower scaling values equate to better ACP.
This setting has no effect with MSK or FSK modulation.

1. PressMode> Custom > Real Time|/Q Baseband > More (1 of 3) > Configure Hardware.
Configure Hardware allows you to access a menu from which you can adjust the 1/Q Scaling.
2. Press1/Q Scaling, enter adesired 1/Q scaling level, and press %.
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Working with Phase Polarity

To Set Phase Polarity to Normal or Inverted
1. PressMode > Custom > Real Time|/Q Baseband > More (1 of 3) > Phase Polarity Normal Invert.

Phase Polarity Normal Invert enables you to either leave the selection as Normal (so that the phase relationship
between the | and Q signalsis not altered by the phase polarity function), or set to Invert and invert the internal Q
signal, reversing the rotation direction of the phase modulation vector.

When you choose Invert, the in—phase component lags the quadrature—phase component by 90° in the resulting
modulation. Inverted phase polarity isrequired by some radio standards and it is useful for lower sideband mixing
applications. The inverted selection also appliesto the |, I-bar, Q, and Q-bar output signals.

Working with Differential Data Encoding

The Differential Data Encode Off On menu enables you to toggle the operational state of the signal generator’s
differential data encoding.

¢ When set to Off, data bits are not encoded prior to modulation.

¢ When set to On, data bits are encoded prior to modulation. Differential encoding uses an exclusive-OR function to
generate amodulated bit. Modulated bitswill have avalue of 1 if adatabit is different from the previous bit or they
will have avalue of 0 if adata bit is the same as the previous bit.

This section provides information about the following:
¢ Understanding Differential Encoding
e “Using Differential Encoding” on page 195

Under standing Differential Encoding

Differential encoding is a digital—encoding technique whereby abinary value is denoted by asignal change rather than a
particular signal state. Using differential encoding, binary datain any user—defined 1/Q or FSK modulation can be
encoded during the modulation process via symbol table offsets defined in the Differential State Map.

For example, consider the signal generator’s default 4QAM 1/Q modulation. With a user—defined modulation based on
the default 4QAM template, the I/Q Values editor contains data that represent four symbols (00, 01, 10, and 11)
mapped into the I/Q plane using two distinct values, 1.000000 and —1.000000. These four symbols can be differentially
encoded during the modul ation process by assigning symbol table offset values associated with each data value. Figure
7-3 on page 192 shows the 4QAM modulationinthe I/Q Values editor.
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Figure7-3
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NOTE Thenumber of bits per symbol can be expressed using the following formula. Because the equationisaceiling
function, if the value of x contains afraction, x is rounded up to the next whole number.

x= Logzor)

Where x = bits per symbol, and y = the number of differential states.

The following illustration shows a 4QAM modulation 1/Q State Map.
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Differential Data Encoding

In real-time 1/Q baseband digital modulation waveforms, data (1's and 0's) are encoded, modulated onto a carrier
frequency and subsequently transmitted to areceiver. In contrast to differential encoding, differential data encoding
modifies the data stream prior to I/Q mapping. Where differential encoding encodes the raw data by using symbol table
offset values to manipulate I/Q mapping at the point of modulation, differential data encoding uses the transition from
one bit value to another to encode the raw data.
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Differential data encoding modifies the raw digitized data by creating a secondary, encoded data stream that is defined
by changesin the digital state, from 1 to O or from 0to 1, of the raw data stream. This differentially encoded data stream

isthen modulated and transmitted.

In differential data encoding, achangein araw data bit's digital state, from 1to O or from O to 1, producesal in the
encoded data stream. No change in digital state from one bit to the next, in other words a bit with avalue of 1 followed
by another bit with avalue of 1 or abit with avalue of 0 followed by the same, produces a0 in the encoded data. For
instance, differentially encoding the data stream containing 01010011001010 renders 1111010101111.

Differential data encoding can be described by the following equation:
transmittedbit(i)= databit(i —1) @ databit(i)
For a bit—by—bit illustration of the encoding process, see the following illustration:

0101001100101

raw (unencoded) data I I I I | I I I I

\ \ }

change =
nochange= =-------- -

\ \ \
1111010101111

differentially encoded data ...l I I I I I I

How Differential Encoding Works

Differential encoding employs offsets in the symbol table to encode user—defined modulation schemes. The
Differential State Map editor isused to introduce symbol table offset values, which in turn cause transitions
through the 1/Q State Map based on their associated data value. Whenever a data value is modulated, the offset value
stored in the Differential State Map is used to encode the data by transitioning through the 1/Q State Map in a direction
and distance defined by the symbol table offset value.

Entering avalue of +1 causes a 1-state forward transition through the I/Q State Map. As an example, consider the
following data/symbol table offset values. These symbol table offsets result in one of the transitions shown.
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NOTE Thefollowing I/Q State Map illustrations show all possible state transitions using a particular symbol table

offset value. The actua state-to—state transition depends on the state in which the modulation starts.

Example 1 Example 2
transition 1 state forward transition 1 state backward
Example Data Offset
Value I/0 State Map I,r’u State Map
I/0 States: L I/0 States: L
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d d
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I/0 State Map I/Q0 State Map
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194 Keysight PSG Signal Generators User’s Guide




Custom Real Time I/Q Baseband
Working with Differential Data Encoding

I/0 State Map
. Les: L
J 1st Symbol 5th Symbol
+1 Y 3rd Symbol Y
u Data = 0011100001
T 2nd Symbol 4th Symbol
a ( 4th
]_ Data Value Symbol Table Offset
u 00 +1
01 -1
e 10 +2
11 +0
-1 1® ®;
-1 I Ualue +1

When applied to the user—defined default 4QAM 1/Q map, starting from the 1st symbol (data 00), the differential
encoding transitions for the data stream (in 2—bit symbols) 0011100001 appear in the previousillustration.

Asyou can see, the 1st and 4th symbols, having the same data value (00), produce the same state transition (forward 1
state). In differential encoding, symbol values do not define location; they define the direction and distance of a
transition through the 1/Q State Map.

For instructions on configuring differential encoding, see “Understanding Differential Encoding” on page 191.

Using Differential Encoding

Differential encoding is a digital—encoding technique that denotes a binary value by asigna change rather than a
particular signal state. It is available for Custom Real Time I/Q Baseband mode. It is not available for waveforms
generated by Arb Waveform Generator mode.

The signal generator'sDifferential State Map editor enablesyou to modify the differential state map associated
with user—defined 1/Q and user—defined FSK modulations. In this procedure, you create a user—defined 1/Q modulation
and then configure, activate, and apply differential encoding to the user—defined modulation. For more information, see
“Understanding Differential Encoding” on page 191.

This section includes information on following:

¢ Configuring User-Defined I/Q Modulation

¢ “Accessing the Differential State Map Editor” on page 196
e “Editing the Differential State Map” on page 197

Configuring User—Defined 1/Q Modulation
1. PressPreset.

2. PressMode > Custom > Real Time |/Q Baseband > Modulation Type > Define User 1/Q > More (1 of 2) >
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L oad Default 1/Q Map > QAM > 4QAM.

This loads a default 4QAM 1/Q modulation and displaysit in the I/Q Values editor. The default 4QAM 1/Q modulation
contains data that represent 4 symbols (00, 01, 10, and 11) mapped into the I/Q plane using 2 distinct values (1.000000
and —1.000000). These 4 symbols will be traversed during the modulation process by the symbol table offset values
associated with each symbol of data.

FREQUENCY

44.000 000 000 000 &tz

AMPLITUDE

130 00 dBn Load/Storen
’7 ﬂ Lomd Default )
o 170 Hap

Oelete ALl Rows

I1/0 Values

Data I Value 0 Value DiFFErengial
00D0000D 1.000000 ENcoding

00000001 -1.000000 1.000000 an

00000010 —1.000000 —1.000000

0opoo011 1.000000 —1.000000 DiF%gpéé%Tg?D
00000100 Encoding
Offset 0

on

Mare

(2 of 23

Accessing the Differential State Map Editor
e PressConfigure Differential Encoding.
ThisopenstheDifferential State Map editor. At this point, you see the data for the 1st symbol (00000000) and

the cursor prepared to accept an offset value. You are now prepared to create a custom differential encoding for the
user—defined default 4QAM 1/Q modulation.
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Data Symbol Table Offset Values Entry Area

FHEDUEN4EY4 0 /{0 0 000 00 / ﬂﬂPLfTéD[ElU 0 . Edit Item
’7 @ Inzert Rouw

Delete Row
Differeptial State Hap
ata Sumbol Table Offsey

00000000 | ——— | Goto RouM

Oelete ALl Rows

Editing the Differential Sate Map

1

Press 1> Enter.

This encodes the first symbol by adding a symbol table offset of 1. The symbol rotates forward through the state
map by 1 value when a data value of 0 is modul ated.

Press +/—>1 > Enter.

This encodes the second symbol by adding a symbol table offset of —1. The symbol rotates backward through the
state map by 1 value when a data value of 1 is modulated.

NOTE At thispoint, the modulation has one bit per symbol. For the first two data val ues (00000000 and 00000001)

only the last bits (the 0 and the 1, respectively) are significant.

Press 2 > Enter.

This encodes the third symbol by adding a symbol table offset of 2. The symbol rotates forward through the state
map by 2 values when a data value of 10 is modulated.

Press0 > Enter.

This encodes the fourth symbol by adding a symbol table offset of 0. The symbol does not rotate through the state
map when a data value of 11 is modul ated.

NOTE At thispoint, the modulation has two bits per symbol. For the data values 00000000, 00000001, 00000010,

00000011, the symbol values are 00, 01, 10, and 11 respectively.
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5. PressReturn > Differential Encoding Off On.
This applies the custom differential encoding to a user—defined modulation.

NOTE Noticethat (UNSTORED) appearsnextto Differential State Map onthesigna generator’s display.
Differential state maps are associated with the user—defined modulation for which they were created.

To save a custom differential state map, you must store the user—defined modulation for which it was
designed. Otherwise the symbol table offset data is purged when you press the Confirm Exit From Table
Without Saving softkey when exiting from the 1/Q or FSK editor.
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Option 409 includes real time multiple-satellite and single-satellite global positioning system (GPS) signal generation
capabilities. Thisfeature is available only in E8267D PSG Vector Signal Generators with Option 602. The following
topics are covered in this chapter:

* “Real Time MSGPS” on page 199 (multiple satellite GPS)
* “Real Time GPS” on page 206 (single satellite GPS)

NOTE TheKeysight Scenario Generator for GPS software (Option 422) provides the ahility to create custom scenario
filesfor real-time playback using Option 409.

The softwareis available as afree download, allowing you to investigate the features of the scenario generator,
create and save scenario files, or download them to your E8267D signal generator. The signal generator must
have licenses for Option 422 and 409 in order to use the scenario files created by the software.

For more information, go to: www.keysight.com/find/gps.

Real Time M SGPS

In Real Time MSGPS mode, selectable scenario files define simulated multiple-satellite conditions. The E8267D
generates asignal (C/A code only) simulating multiple satellite transmissions from the information in the selected
scenario file. MSGPS signal generation capabilities include:

* selectable MSGPS scenario files that include the following information:

— simulated location (city, latitude, longitude, el evation)
— simulated date and time

— scenario duration

— satellite IDs present (in view) in the scenario

» pause and resume function for the currently playing scenario

« restart function that sets the currently playing scenario to the beginning
(without turning off the RF output)

» adjustable number of satellitesin view to include in the generated signal
« selectableinternal or external chip clock reference source

KEYSIGHT

TECHNOLOGIES
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« adjustable chip clock reference (10.23 Mcps + 10%)
« selectable 1/Q phase (normal or inverted)
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Signal Generation Block Diagram

GPS Modulation (Option 409)
Real Time MSGPS

Figure 8-1 shows how the signal is generated within the PSG for afour satellite MSGPS simulation. The PSG produces
asimulated signal for each satellite and then sums them together to produce the MSGPS signal. Use the Number of

Satellites softkey to specify the number of satellitesin the M SGPS simulation.

Figure8-1 MSGPS Signal Generation Diagram
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When you install option 409, a GPS directory is created in the PSG non-volatile memory and two M SGPS scenario files
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areloaded into the GPS directory. Additional scenario files are available for Option 409.
(Goto http://www.Keysight.com/find/gps.)

After downloading a scenario fileto your PC, you can download the scenario file to the PSG using FTP over alocal area
network (LAN) or using SCPlI commands over a genera purpose interface bus (GPIB) interface.

Downloading Scenario Files Using the PSG Web Interface

The following procedure describes how to download scenario files to a PSG using the PSG Web interface and LAN
connection:

1. Open your web browser and type in the | P address of your PSG. The PSG’s Wel come webpage is displayed.
2. Click Signal Generator FTP Access on the left hand side. An explorer file window will be opened.

3. If aview to your desktop is not already visible on the explorer file window, open one by selecting View/Explorer
Bar/Folders from the drop down menu. Thiswill provide aview of both your desktop and the PSG’s file system.

4. Locate the .GPS scenario file previously downloaded on your PC.
Drag and drop the .GPS file into the USER/GPS directory on the PSG.

NOTE Refer to the Programming Guide for more information on downloading files.

Downloading Scenario FilesUsing FTP (LAN)

The following procedure describes how to download scenario filesto a PSG using FTP on a PC connected to your PSG
through a LAN:

1. OnthePC click Sart > Programs > Accessories > Command Prompt.

At the command prompt enter: ftp <IP address> Of <hostname>

At the user name prompt, press Enter.

At the password prompt, press Enter. You are now in the signal generator’s user directory.
Type cd GPS.

Typebin.

Typeput <scenario files.

Type quit or bye to end your FTP session.

© o N o gk~ 0w D

Type exit to end the command prompt session.

Downloading Scenario Files Using SCPI Commands (GPIB)

The following procedure describes how to download scenario filesto a PSG using a SCPI command on a PC connected
to your PSG through a GPIB interface:

1. Open your web browser and type in the | P address of your PSG. The PSG’s Wel come webpage is displayed.

2. Click Signal Generator Web Control. Below the graphical representation of the PSG front panel isafield for
entering SCPI commands.
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3. Enter the following command in the SCPI command field:
:MEMory :DATA "<GPS:file name>", <data block>
where file name isthe name of the destination file in PSG memory and GPS : specifies the destination directory.
Refer to the Programming Guide for adescription of the <data blocks> parameter.

NOTE Refer to the Programming Guide for more information on downloading files.

RF Power Level Considerations

When you set up your GPS test signal, pay specia attention to the RF power level delivered to the GPS receiver.
Because typical GPS sensitivities are between -155 dBm and -159 dBm, delivering a GPS signal to your device with a
power level greater than -150 dBm or less than -160 dBm may produce invalid test results.

If you use a physical connection to apply the GPS signal to your antenna, keep in mind that most GPS antennas are
active (aDC voltage is delivered to the antenna from the receiver). A DC block is therefore required between the signal
generator and the antenna. For direct connection, Keysight recommends setting the signal generator RF output power to
between -70 and -80 dBm and using an 80 dB attenuator and a DC blocking device between the signal generator output
and the antenna input of the receiver under test.

If you use aradiated connection, place your receiver in a caibrated test fixture designed with alink budget that will
deliver a-150 dBm to -160 dBm power level at the receiver antenna.

Using NMEA datato monitor signal power

One method to monitor the receiver’s perceived signal level isto monitor the National Marine Electronics Association
(NMEA) data stream from the receiver. Most GPS receivers have the capability to output data viaa serial RS232
connectionin NMEA format. An NMEA message called GPGSV reportsthe signal strength of the satellites that the GPS
receiver istracking. The GPGSV message reports a carrier-to-noise (CNO) value for each observed satellite. Asyou
monitor this message, increase or decrease the power to the receiver until the receiver’s perceived CNO values are
between 35 and 40. Table 8-1 on page 204 shows how to obtain the CNO value from the GPGSV message.

Thefollowing exampleisaset of three GPGSV messages. The receiver produces amaximum of three GPGSV messages
every second. The fields are comma-separated; two adjacent commas signify afield for which avalueis not assigned.

$GPGSV,3,1,12,21,71,000,,27,68,000,34,08,62,000,33,29,52,000,,* 71
$GPGSV,3,2,12,24,39,000,,10,36,000,,26,35,000,,25,32,000,35* 71
$GPGSV,3,3,12,19,29,000,,03,20,000,33,16,19,000,34,18,19,000,* 71
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Table 8-1 describes each field for the first of the three GPGSV messages in the example:
$GPGSV,3,1,12,21,71,000,,27,68,000,34,08,62,000,33,29,52,000,,* 71

Table8-1 GPGSV Fields

GPGSV Field

Description

Number of GPGSV messagesin this set

Number of this GPGSV in the set (1 of 3)

12,

Total number of satellitesin view

21,71,000,,

Satellite 21, elevation 71, azimuth 0, CNO unknown

27,68,000,34

Satellite 27, elevation 68, azimuth 0, CNO 34

08,62,000,33,

Satellite 8, elevation 62, azimuth 0, CNO 33

29,52,000,,

Satellite 29, elevation 52, azimuth 0, CNO unknown

*71

Checksum

If no CNO valueisreported for a particular satellite (satellites 21 and 29 in the table) the receiver is currently not

tracking that satellite.

For more information, refer to the following document, available at http://www.nmea.org/pub/0183/.

NMEA 0183, Standard For Interfacing Marine Electronic Devices
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Generating a Real Time M SGPS Signal

This procedure uses the internal reference clock with the factory preset settings (the C/A chip rateis 1.023 Mcpswith a
clock reference of 10.23 Mcps).

Set the carrier frequency and amplitude
1. Pressthe Preset hardkey.

2. Pressthe Frequency hardkey. Using the numeric keypad, set the signal generator RF output carrier frequency to
1.57542 GHz.

3. Pressthe Amplitude hardkey. Using the numeric keypad, set the signal generator RF output amplitude to —135
daBm.

4. Press RF On/Off to toggle the RF output on.

Select and play a multi-satellite scenario

1. PressMode>More (1 of 2) > GPS> Real Time M SGPS.

2. Press Scenario.

3. Usethe navigation softkeys or the up and down arrow hardkeys to highlight the santarosa scenario file.

4. Press Select Scenario. A summary of the scenario is displayed including the simulated location, the date and time,
and the satellites in view.

5. PressNumber of Satellitesand enter 5 to use only the first five satellitesin view in the generated signal.

6. PressReal-time M SGPS Off On to On to play the selected scenario.

7. PressPause. The scenario file stops playing.

8. Press Resume. The scenario file continues playing from the point at which it was paused.

9. PressRestart. The scenario file plays from the beginning without turning off the RF.

NOTE Selecting anew scenario, toggling Real-time M SGPS off and on, or pressing Restart sets the active scenario to
the beginning. If Resumeis active, the scenario immediately starts playing; if Pauseisactive, select Resumeto
start playing the scenario.

Figure 8-2 on page 206 shows the signal generator display with the santar osa M SGPS scenario selected.

The scenario information within the box (Scenario State, Signal Play Duration, Satellitesin View) isdynamic. The
scenario information outside of the box (Location, Start Date, and so on) is static.
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Figure8-2 Real Time M SGPS Scenario

FREQUENCY AMPLITUCE Feal-time MSGPS
IIEA On
1.575420 00000 ez | -135.00 aen
Eﬂﬂ Pause
|Nunber of Satellites: 5
Restart
RT NMSGEPS Location: Santa Fosa Filename: SAMTARDSA
Uff Start Date: 21-Mau-2007 GPS Ref (fO): 1.023000McPps
Start Time: 01:00:00 GPS Ref Clk: Int Scenar ioM
Altitude tmi: 100 I0 Phase: Inwert
Latitude: 38.4811651 Humber of
Longitude: -122.709619 gatellites
H]
Scenario State:
Signal Play Ouration: 00:00:00 of 00:30:00
Satellites in Wiew:
More
03/06/2007 11:14 (1 of 2)

Configuring the Exter nal Reference Clock

1. Connect the external reference clock source to the rear panel connector BASEBAND GEN REF IN.

Set the chip rate of the external clock to the desired value.

PressMode> More (1 of 2) > GPS> Real Time MSGPS > More (1 of 2) > GPS Ref Clk Ext Int to Ext.
Press GPS Ref (f0).

Use the numeric keypad to set the GPS reference clock to the same chip rate as the external clock.

o~ DN

NOTE The chip rate of the external source must match the chip rate of the reference clock set using the GPS Ref (f0)
softkey.

Real Time GPS

This real-time personality simulates GPS satellite transmissions for single channel receiver testing. Basic GPS signal
building capabilitiesinclude:

« P code generation at 10.23 Mcps with the standard GPS 10.23 Mcps reference’
e CI/A code generation at 1.023 Mcps with the standard GPS 10.23 Mcps reference

e navigation data output at 50 bps using PN9, PN15, afixed 4-bit pattern, a user-defined file, or default data (TLM
mode) for encoding with the C/A code or the C/A + P code

« three selectable ranging codes: C/A, P, or C/A+P

1p code signal's are spectrally correct but do not contain valid data.
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satellite ID range of 1 to 32 with an additional range of 33 to 37 for other uses
sel ectable data modes: Raw, Encoded, and TLM

simulated doppler shift with a 250 kHz range

selectable internal or external chip clock reference source

The signal generator’s pre-defined GPS signal setup includes a C/A ranging code, a satellite ID of 1, zero doppler shift,
a10.23 Mcps reference clock, and the Raw data mode enabled, using PN9 data.

The satellite ID numbers match the pseudorandom numbers used to generate the C/A and P codes and dictate the amount
of chip delay in compliance with the GPS standards.

The following advanced features are also available:

P code power adjustment (—40 to 0 dB)

adjustable chip clock reference (1 kepsto 12.5 Mcps)
selectable 1/Q phase

selectable filters and the ability to create user-defined filters

Real Time GPS Introduction

Signal Generation Block Diagram

Figure 8-3 shows how the GPS signal is generated within the PSG. Notice that the C/A code modul ates the L-band
signal using the | axis of the I/Q modulator, and the P code modul ates the L-band signal using the Q axis. Select the data
provided by the data generator using the Data softkey or by choosing the TLM data mode.
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Figure 8-3 GPS Signal Generation Diagram
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Data Modes and Subframe Structures
You can select one of the three following data modes for use with the C/A or C/A+P ranging code:

¢ Raw - The Raw data mode enables the continuous transmission of 300 bits of data per subframe without
incorporating parity bits. Use this mode for BER and low-level demodulation testing.

e Enc- The encoded (Enc) data mode enables the continuous transmission of 10 words per subframe, with each word

containing 24 bits of raw data and 6 trailing parity bits (computed from the selected data by the PSG).

1.023 Mcps

v

gps_blk

¢ TLM - Thetelemetry (TLM) mode enables the continuous transmission of aformatted TLM word, a handover word
(HOW), and default navigation data as outlined in the Global Positioning System Sandard Positioning Service
Sgnal Specification, 2nd Edition, June 2, 1995. Use this mode for receiver testing.
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Figure 8-4 shows the subframe structures for each data mode.

Figure8-4 Subframe Sructures
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The TLM word is 30-bits long, with an 8-bit preamble, 16 reserve bits (bits 9 to 24, all set to zero), and 6 parity bits (bits
2510 30).

The HOW word is 30-bits long, with the first 17 bits used for an incrementing time-of-week (TOW), bits 23 and 24 used
for parity computation, and bits 25 to 30 used for parity bits.

During a GPS signal transmission, a pulse signal is generated every 6 seconds at the
EVENT 1 rear panel connector. This pulse coincides with the beginning of each subframe starting with the second
subframe and is synchronized to the RF output to compensate for any internal signal delay.

Chip Clock Reference

The GPS reference clock (chip clock) is adjustable using the GPS Ref (f0) softkey. The factory-set value is 10.23 Mcps
(the GPS standard). You can use theinternal chip clock or an external source to provide the reference. To use an external
reference, connect the external source to the DATA CLOCK input connector.

NOTE If you use an external source to provide the chip clock reference, the frequency of the external source must
match the PSG’s reference clock frequency. Press the GPS Ref (f0) softkey then use the numeric keypad to
enter the reference clock frequency.

The P and C/A code chip rates are determined by the reference clock frequency whether you are using the internal or an
external chip clock reference. The P code chip rate matches the reference clock frequency and the C/A code chip rateis
one-tenth of the reference clock frequency. Refer to Figure 8-3 on page 208 for ablock diagram showing how the GPS
signal is generated within the PSG.

Rear Panel Signal Synchronization

Figure 8-5 illustrates the timing relationships of the GPS signals available at the signal generator rear panel. The AUX
1/0 connector outputs the SYMBOL SYNC OUT, DATA CLOCK OUT, and DATA OUT signals (refer to, “5.
AUXILIARY 1/0” on page 25 for more information). EVENT 1 and EVENT 2 are BNC connectors. If the signal
generator is configured with Option 1EM, EVENT 1 and EVENT 2 connectors are changed from BNC to SMB
connectors. See “Rear Panel” on page 21.
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Figure8-5 GPS Signals
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User Files

You can create datafiles internally in the PSG or create them externally and download them to the PSG. In either case,
the size of user datafilesislimited by the amount of available PSG memory. If you devel op datafiles externally, you can
define signal structures that are not available internally in the PSG. For example, if you require a fully-coded signal
consisting of frames structured according to GPS standards (1 frame consisting of 5 subframes and 25 pages), you can
develop thissignal externally and download it to the PSG. User files can be in either binary or bit format. Save user files
to the bin directory.

Select adata mode for your data file as you would for other data types (see “Data Modes and Subframe Structures”
on page 208). If files are created externally and incorporate parity bits, use the Raw data mode to transmit the datain its
original form. If your file does not contain parity bits and you want to incorporate parity bitsin the transmitted signal,
select the encoded (Enc) data mode. The PSG will compute parity bits for the last 6-bits of each word.

NOTE If you select the encoded mode for a user file that incorporates parity bits, the parity bits will be recomputed
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and their values changed.

Setting Up the Real Time GPS Signal

If the signal generator isin the factory-defined preset mode, (Utility > Power On/Preset > Preset Normal User to
Normal) abasic GPS signal is automatically set up when you press the Preset key. Perform step 2 and steps 6 through 8
to generate asigna at the RF OUTPUT connector. To set up asignal using additional features of the GPS personality,
complete this procedure starting with step 1.

1. PressPreset.

2. PressMode>More(1of 2) > GPS> Real Time GPS.
Press Satellite ID > 8 > Enter.

Press Doppler Shift >2.5>kHz.

Press Data Mode Enc TLM to Enc.

Press Data > PN Sequence > PN15.

Press Real-time GPS Off On to On.

Press the Freguency hardkey. Using the numeric keypad, set the signal generator RF output frequency to 1.57542
GHz (L1 carrier frequency).

© N o ok~ w

9. Pressthe Amplitude hardkey. Using the numeric keypad, set the signal generator RF output amplitude to —120
dBm.

10. Turn the RF output on by pressing the RF On/Off hardkey on the signal generator front panel.

The real-time GPS signal is now available at the signal generator RF OUTPUT connector. Figure 8-6 on page 213
shows what the signal generator display should like after all steps have been completed. Notice the GPS, 1/Q, and RF
ON annunciators are on and the parameter settings for the signal are displayed in the status area of the signal generator
display.

This procedure sets up a GPS signal that incorporates a subframe structure using 10 words, each with 24 raw data bits
and 6 parity bits computed from the data source. The signal generator created this subframe structure when you selected
Enc as the data mode and a PN15 sequence as the data type. The PN 15 sequence was encoded with the C/A code at

50 bps. Using factory preset settings, the C/A chip rateis 1.023 Mcps with a clock reference of 10.23 Mcps. A 2.5 kHz
doppler shift simulates the relative motion of the satellite with respect to the receiver. For more information on the GPS
option, refer to “Real Time GPS” on page 206.
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Figure8-6 Real Time GPS Setup with Internal Clock
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Configuring the Exter nal Reference Clock

1. Accesstherea-time GPS personality (Mode > More(1 of 2) > GPS > Real Time GPS).
2. PressMore (1 of 2) > GPS Ref Clk Ext Int to Ext.

3. Press GPSRef (f0) > 11.03 > keps.

4. Connect the external reference clock source to the DATA CLOCK INPUT connector.

The maximum clock rate for thisinput connector is 50 MHz with a voltage range of
-05t05.5V.

5. Set the external reference clock source to the chip rate value entered in Step 3.

The maximum datarate for this input connector is 50 Mb/s with a voltage range of
-05t055V.

NOTE The chip rate of the external source must match the chip rate value set using the GPS Ref (f0) softkey.

Figure 8-7 on page 214 shows what the signal generator display should look like after all the steps have been
completed. The CA Chip Rate, P Chip Rate, GPS Ref (£0),andGPS Ref Clk fieldsin the status areaof the
display show the new parameters you set in this procedure. Notice the settings Satellite ID, Doppler Shift,
Data, and Data Mode, have not changed from the previous procedure, “Setting Up the Real Time GPS Signal” on
page 212.
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Figure8-7 Real Time GPS Setup with External Clock
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This procedure used an external source as the reference clock signal. The reference frequency was changed from the
GPS standard of 10.23 Mcpsto 11.03 keps. This change in the reference signa frequency automatically changed the P
and C/A code chip rates. Since the P code chip rate matches the reference frequency, its chip rate is now 11.03 kcps; the
C/A coderate is one-tenth of the reference frequency and so is now 1.103 keps. For more information on the GPS
option, refer to “Real Time GPS” on page 206.

Testing Receiver Sensitivity
Refer to Figure 8-8.
1. Connect the cables between the receiver and the PSG as shown in Figure 8-8.
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Figure 8-8 Setup for a Recelver Sensitivity Test
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Set the GPS datamode to TLM.

Set the power level on the PSG.

Set the L-band frequency on the PSG.

Set up the UE (user equipment) to receive the signal from the PSG.
Turn on the GPS personality and the RF output on the PSG.

o 0~ W N
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9  Multitone Waveform Generator

In the following sections, this chapter describes the multitone mode, which is available only in E8267D PSG Vector
Signal Generators with Option 601 or 602:

e “Overview” on page 217
e “Creating, Viewing, and Optimizing Multitone Waveforms” on page 218

See dso: Chapter 3, “Basic Digital Operation,” on page 77

Overview

The multitone mode builds a waveform that has up to 64 CW signals, or tones. Using the Multitone Setup table
editor, you can define, modify, and store waveforms for playback. Multitone waveforms are generated by theinternal 1/Q
baseband generator.

The multitone waveform generator is typically used for testing the intermodulation distortion characteristics of
multi—channel devices, such as mixers or amplifiers. Intermodulation distortion (IMD) occurs when non-inear devices
with multiple input frequencies cause unwanted outputs at other frequencies or interfere with adjacent channels. The
multitone waveform generator supplies a waveform with a user—specified number of tones whose IMD products can be
measured using a spectrum analyzer and used as a reference when measuring the IMD generated by a device-under—test.

Multitone waveforms are created using the internal 1/Q baseband generator and stored in ARB memory for playback.
Although the multitone mode generates a high—quality waveform, a small amount of IMD, carrier feedthrough, and
feedthrough—elated IMD occurs. Carrier feedthrough may be observed when an even number of tones are generated,
since there are no tones at the center carrier frequency to mask the feedthrough. To minimize carrier feedthrough for an
even—numbered multitone signal, it is necessary to manually adjust the | and Q offsets while observing the center carrier
frequency with a spectrum analyzer.

For measurements that require more than 64 tones or the absence of IMD and carrier feedthrough, you can create up to
1024 distortion—free multitone signals using Keysight Technologies Signal Studio software Option 408.

NOTE For moreinformation about multitone waveform characteristics and the PSG vector signal generator multitone
format, download Application Note 1410 from our website by going to http://mww.keysight.com and searching
for “AN 1410” in Test & Measurement.
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Creating, Viewing, and Optimizing Multitone Waveforms

This section describes how to set up, generate, and optimize a multitone waveform while viewing it with a spectrum
analyzer. Although you can view a generated multitone signal using any spectrum analyzer that has sufficient frequency
range, an Keysight Technologies PSA high—performance spectrum analyzer was used for this demonstration. Before
generating your signal, connect the spectrum analyzer to the signal generator as shown in Figure 9-1.

Figure9-1 Spectrum Analyzer Setup
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To Create a Custom Multitone Waveform

UsingtheMultitone Setup table editor, you can define, modify and store user—defined multitone waveforms.
Multitone waveforms are generated by the dual arbitrary waveform generator.

1. Preset the signal generator.

Set the signal generator RF output frequency to 20 GHz.

Set the signal generator RF output amplitude to 0 dBm.

Press Mode > Multitone > I nitialize Table > Number of Tones> 9 > Enter.
Press Freg Spacing> 1> MHz.

Press I nitialize Phase Fixed Random to Random.

Press Done.

Press M ultitone Off On to On.

9. Turn on the RF output.

© N o gk~ w DN

The multitone signal should be available at the signal generator RF OUTPUT connector.

Figure 9-2 showswhat the signal generator display should look like after all steps have been completed. Notice that the
M-TONE, I/Q, RF ON, and MOD ON annunciators are displayed and the parameter settings for the signal are shownin
the status area of the signal generator display. The multitone waveform is stored in volatile ARB memory.
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The waveform has nine tones spaced 1 MHz apart with random initial phase values. The center toneis placed at the
carrier frequency, while the other eight tones are spaced in 1 MHz increments from the center tone. If you create an even
number of tones, the carrier frequency will be centered between the two middle tones.

Figure9-2
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To View a Multitone Waveform

This procedure describes how to configure the spectrum analyzer to view a multitone waveform and its IMD products.
Actual key presseswill vary, depending on the model of spectrum analyzer you are using.

1. Preset the spectrum analyzer.

Set the carrier frequency to 20 GHz.

Set the frequency span to 20 MHz.

Set the amplitude for a 10 dB scale with a4 dBm reference.

Adjust the resol ution bandwidth to sufficiently reduce the noise floor to expose the IMD products. A 9.1 kHz setting
was used in our example.

6. Turn on the peak detector.
7. Set the attenuation to 14 dB, so you' re not overdriving the input mixer on the spectrum analyzer.

g~ DN

You should now see awaveform with nine tones and a 20 GHz center carrier frequency that is similar to the one shown
in Figure 9-3. You will aso see IMD products at 1 MHz intervals above and below the highest and lowest tones.
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Figure 9-3
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To Edit the Multitone Setup Table

This procedure builds upon the previous procedure.

Press Initialize Table > Number of Tones> 10 > Enter.

Press Done.

Highlight the value (On) in the State column for the tone in row 2.
Press Toggle Sate.

Highlight the value (0 dB) in the Power column for the tone in row 4.
Press Edit Item >-10 > dB.

Highlight the value (0) in the Phase column for the tone in row 4.
Press Edit Item > 123 > deg.

© N o gk~ 0w DR
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9. Press Apply Multitone.

NOTE Whenever achange is made to a setting while the multitone generator is operating (M ultitone Off On set to
On), you must apply the change by pressing the Apply Multitone softkey before the updated waveform will be
generated. When you apply a change, the baseband generator creates a multitone waveform using the new
settings and replaces the existing waveform in ARB memory.

You have now changed the number of tones to 10, disabled tone 2, and changed the power and phase of tone 4.
Figure 9-4 shows what the multitone setup table display on the signal generator should look like after all steps have
been completed. The spectrum analyzer should display awaveform similar to the one shown in Figure 9-5 on

page 222. Notice that even—numbered multitone waveforms have a small amount of carrier feedthrough at the center
carrier frequency.

Figure9-4
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Figure9-5
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ToMinimize Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power between the tones
and their intermodulation distortion products. Carrier feedthrough can only be observed with even—numbered multitone
waveforms.

This procedure builds upon the previous procedure.

1

w

© ®© N o 0 &

On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about
100 to 200 ms. Thiswill allow you to dynamically view the carrier feedthrough spike as you make adjustments.

On the signal generator, press 1/Q > 1/Q Adjustments > 1/Q Adjustments Off On to On.

Press| Offset and turn the rotary knob while observing the carrier feedthrough with the spectrum analyzer.
Changing the | offset in the proper direction will reduce the feedthrough level. Adjust the level aslow as possible.

Press Q Offset and turn the rotary knob to further reduce the carrier feedthrough level.
Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.
On the spectrum analyzer, return the resolution bandwidth to its previous setting.

Turn on waveform averaging.

Create amarker and place it on the peak of one of the end tones.

Create a delta marker and place it on the peak of the adjacent intermodulation product, which should be spaced
10 MHz from the marked tone.
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10. Measure the power difference between the tone and its distortion product.

You should now see adisplay that is similar to the one shown in Figure 9-6. Your optimized multitone signal can now
be used to measure the IMD products generated by a device-under—test.

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to periodically readjust your
| and Q offsets to keep the signal optimized.

Figure9-6
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To Determine Peak to Average Characteristics

This procedure describes how to set the phases of the tones in a multitone waveform and determine the peak to average
characteristics by plotting the complementary cumulative distribution function (CCDF).

Press Mode > Multitone > I nitialize Table > Number of Tones > 64 > Enter.

Press Freq Spacing > 20 > kHz.

Press I nitialize Phase Fixed Random to Fixed.

Press Done.

Press Apply Multitone.

PressMore (1 of 2) > ARB Setup > Waveform Utilities > Waveform Statistics > Plot CCDF.

You should now see adisplay that is similar to the one shown in Figure 9-7. The CCDF plot displays the peak to
average characteristics of the waveform with all phases set to zero.

© 0~ w NP
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Figure 9-7CCDF Plot with Fixed Phase Set
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Press M ode Setup > I nitialize Table.
Press I nitialize Phase Fixed Random to Random.
Press Random Seed Fixed Random to Random.
10. Press Done.
11. Press Apply Multitone.
12. PressMore (1 of 2) > Waveform Satistics > Plot CCDF.

You should now see adisplay that is similar to the one shown in Figure 9-8. The CCDF plot displays the peak to
average characteristics of the waveform with randomly generated phases and a random seed.

The random phase setup simulates the typically random nature of multitone waveforms. Notice that randomly
distributed phasesresult in amuch lower peak to average ratio than fixed phases. An increase in the number of tones
with random phases will decrease the probability of a maximum peak power occurrence.
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Figure 9-8CCDF Plot with Random Phase Set
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10 Two-Tone Waveform Generator

In the following sections, this chapter describes the two-tone mode, which is available only in E8267D PSG vector
signal generators with Option 601 or 602:

*  “Overview” on page 227
e “Creating, Viewing, and Modifying Two-Tone Waveforms” on page 227
See dso: “Arbitrary (ARB) Waveform File Headers” on page 78

Overview

The two-tone mode builds awaveform that has two equal—powered CW signals, or tones. The default waveform hastwo
tones that are symmetrically spaced from the center carrier frequency, and have user—defined amplitude, carrier
frequency, and frequency separation settings. The user can also align the tones |eft or right, relative to the carrier
frequency.

The two—tone waveform generator is designed for testing the intermodul ation distortion characteristics of non-inear
devices, such as mixers or amplifiers. Intermodulation distortion (IMD) occurs when norHinear devices with multiple
input frequencies interfere with adjacent channels or cause unwanted outputs at other frequencies. The two-tone
waveform generator supplies a signal whose IMD products can be measured using a spectrum analyzer and used as a
reference when measuring the IMD generated by a device-under—test.

Two-tone waveforms are created using the internal 1/Q baseband generator and stored in ARB memory for playback.
Although the two-tone mode generates a high—quality waveform, asmall amount of IMD occurs. In addition to IMD, a
small amount of carrier feedthrough and feedthrough—related IMD may be present when the spacing between thetonesis
centered on the carrier frequency. To minimize carrier feedthrough for atwo—tone signal, you must manually adjust the |
and Q offsets while observing the center carrier frequency with a spectrum analyzer. For measurements that require the
absence of IMD and carrier feedthrough, you can create distortion—free multitone signals using Keysight Technologies
Signal Studio software Option 408.

NOTE For more information about two-tone waveform characteristics and the E8257D/67D PSG Vector Signal
Generator two—tone format, download Application Note 1410 from our website by going to
http: //mmw.keysight.com and searching for “AN 1410" in Test & Measurement.

Creating, Viewing, and M odifying Two—Tone Wavefor ms

This section describes how to set up, generate, and modify atwo-tone waveform while viewing it with a spectrum
analyzer. Although you can view a generated two-tone signal using any spectrum analyzer that has sufficient frequency
range, an Keysight Technologies PSA Series High—Performance Spectrum Analyzer was used for this demonstration.
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Before generating your signal, connect the spectrum analyzer to the signal generator as shown in Figure 10-1.

Figure 10-1Spectrum Analyzer Setup
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To Create a Two-Tone Waveform

This procedure describes how to create and a basic, center—aligned, two-tone waveform.
Preset the signal generator.

Set the signal generator RF output frequency to 20 GHz.

Set the signal generator RF output amplitude to 0 dBm.

Press Mode > Two Tone > Freg Separation > 10 > MHz.

Press Two Tone Off On to On.

Turn on the RF output.

o 0~ w DR

The two-tone signal is now available at the signal generator RF OUTPUT connector. Figure 10-2 on page 229 shows
what the signal generator display should look like after all steps have been completed. Notice that the T-TONE, I/Q, RF
ON, and MOD ON annunciators are displayed and the parameter settings for the signal are shown in the status area of the
signal generator display.
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Figure 10-2
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To View a Two-Tone Waveform

This procedure describes how to configure the spectrum analyzer to view atwo-tone waveform and its IMD products.
Actual key presseswill vary, depending on the model of spectrum analyzer you are using.

1

o~ D

6.
7.

Preset the spectrum analyzer.

Set the carrier frequency to 20 GHz.

Set the frequency span to 60 MHz.

Set the amplitude for a 10 dB scale with a4 dBm reference.

Adjust the resol ution bandwidth to sufficiently reduce the noise floor to expose the IMD products. A 9.1 kHz setting
was used in our example.

Turn on the peak detector.
Set the attenuation to 14 dB, so you're not overdriving the input mixer on the spectrum analyzer.

You should now see a two-tone waveform with a 20 GHz center carrier frequency that is similar to the one shown in
Figure 10-3. You will also see IMD products at 10 MHz intervals above and below the generated tones, and a carrier
feedthrough spike at the center frequency with carrier feedthrough distortion products at 10 MHz intervals above and
below the center carrier frequency.
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Figure10-3
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ToMinimize Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power between the tones
and their intermodul ation distortion products. Carrier feedthrough only occurs with center—aligned two-tone waveforms.

This procedure builds upon the previous procedure.

1

w

© o N o g &

On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about
100 to 200 ms. Thiswill alow you to dynamically view the carrier feedthrough spike as you make adjustments.

On the signa generator, press 1/Q > 1/Q Adjustments > 1/Q Adjustments Off On to On.

Press| Offset and turn the rotary knob while observing the carrier feedthrough with the spectrum analyzer.
Changing the | offset in the proper direction will reduce the feedthrough level. Adjust the level aslow as possible.

Press Q Offset and turn the rotary knob to further reduce the carrier feedthrough level.
Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.
On the spectrum analyzer, return the resolution bandwidth to its previous setting.

Turn on waveform averaging.

Create amarker and place it on the peak of one of the two tones.

Create a delta marker and place it on the peak of the adjacent intermodulation product, which should be spaced
10 MHz from the marked tone.

230

Keysight PSG Signal Generators User’s Guide



Two-Tone Waveform Generator
Creating, Viewing, and Modifying Two-Tone Waveforms

10. Measure the power difference between the tone and its distortion product.

You should now see adisplay that is similar to the one shown in Figure 10-4. Your optimized two—-tone signal can now
be used to measure the IMD products generated by a device-under—test.

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to periodically readjust your
| and Q offsets to keep your signal optimized.

Figure10-4 )
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To Change the Alignment of a Two-Tone Waveform

This procedure describes how to align a two—-tone waveform left or right, relative to the center carrier frequency.
Because the frequency of one of the tones is the same as the carrier frequency, this alignment eliminates carrier
feedthrough. However, image frequency interference caused by |eft or right alignment may cause minor distortion of the
two—tone signal. This procedure builds upon the previous procedure.

1. Onthesignal generator, press Mode Setup > Alignment L eft Cent Right to Left.
2. Press Apply Settingsto regenerate the waveform.

NOTE Whenever achange is made to a setting while the two—tone generator is operating (Two Tone Off On set to
On), you must apply the change by pressing the Apply Settings softkey before the updated waveform will be
generated. When you apply a change, the baseband generator creates a two—tone waveform using the new
settings and replaces the existing waveform in ARB memory.

3. On the spectrum analyzer, temporarily turn off waveform averaging to refresh your view more quickly. You should
now see aleft—aligned two—tone waveform that is similar to the one shown in Figure 10-5.
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Figure10-5
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11T  AWGN Waveform Generator

In the following sections, this chapter contains examples for using the AWGN waveform generator, which is available
only in E8267D vector PSGs with Options 601 or 602 and Option 403:

e “Arb Waveform Generator AWGN” on page 233
e “Real Time I/Q Baseband AWGN” on page 234

For adding real-time AWGN to waveforms using the Dual ARB player, see “Adding Real-Time Noise to a Dual ARB
Waveform (E8267D with Option 403)” on page 93

Configuring the AWGN Generator

The AWGN (additive white Gaussian noise) generator is available for the Arb Waveform Generator mode and the Real
Time I/Q Baseband mode. The AWGN generator can be configured with user—defined noise bandwidth, noise waveform
length, and noise seed parameters.

¢ Bandwidth — the noise bandwidth can be set from 50 kHz to 15 MHz.

*  Waveform Length — the waveform length is the length in samples of the noise waveform. Longer waveform lengths
provide more statistically correct noise waveforms.

* Noise Seed — the noise seed selection can be either random or fixed. The noise seed determines whether the noise
waveform datais repeatable (using the fixed selection) or random (using the random selection).

When the AWGN generator is active, an annunciator, labeled AWGN, is displayed on the front panel of the signal
generator.

Arb Waveform Generator AWGN

Press Preset.

PressMode> More (1 of 2) > AWGN > Arb Waveform Generator AWGN
Press Bandwidth > 1.25> MHz.

Press Waveform Length > 131072.

5. Press Noise Seed Fixed Random until Random is highlighted.

This configures arandomly seeded AWGN waveform with a bandwidth of 1.25 MHz and awaveform length of
131072 bits.

EE A
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Configuring the AWGN Generator

Configuring the RF Output
1. Set the RF output frequency to 500 MHz.

2. Set the output amplitude to —10 dBm.
3. Press RF On/Off.

Generating the Waveform
Press AWGN Off On until On is highlighted.

This generates an AWGN waveform with the parameters defined in the previous procedure. During waveform
generation, the AWGN and I/Q annunciators activate and the AWGN waveform is stored in volatile ARB memory. The
waveform is now modulating the RF carrier.

Real Timel/Q Baseband AWGN

1. PressPreset.

2. PressMode> More (1 of 2) > AWGN > Real Time/Q Baseband AWGN
3. PressBandwidth > 10> MHz.

Configuring the RF Output
1. Set the RF output frequency to 500 MHz.

2. Set the output amplitude to —10 dBm.
3. Press RF On/Off.

Generating the Waveform
Press AWGN Off On until On is highlighted.

This generates an AWGN waveform with the parameters defined in the previous procedure. During waveform
generation, the AWGN and I/Q annunciators activate. The waveform is now modulating the RF carrier.
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12 Peripheral Devices

This chapter providesinformation on peripheral devices used with PSG signal generators. The N5102A Baseband Studio
digital signal interface module and extended frequency source module operation and features are described in the
following sections:

N5102A Digital Signal Interface Module

* “Clock Timing” on page 235

*  “Connecting the Clock Source and the Device Under Test” on page 247
» “Data Types” on page 248

» “Operating the N5102A Module in Output Mode” on page 250

* “Operating the N5102A Module in Input Mode” on page 259
Millimeter-Wave Source Modules

e “Using Keysight Millimeter-Wave Source Modules” on page 267

e “Using Other Source Modules” on page 271

N5102A Digital Signal Interface Module

Clock Timing

This section describes how clocking for the digital datais provided. Clock timing information and diagrams are supplied
for the different port configurations (serial, parallel, or parallel interleaved data transmission) and phase and skew
settings. All settings for the interface module are available on the signal generator user interface (Ul).

Clock and Sample Rates

A sampleisagroup of bits where the size of the sampleis set using the Word Size softkey. The clock isthe signal that
tellswhen the bits of a sample are valid (in a non-transition state). The clock and sample rates are displayed in the
first-level and data setup softkey menus. The clock rate and sample rate are usually the same. They will differ when
serial mode is selected, or when there are multiple clocks per sample.

KEYSIGHT

TECHNOLOGIES
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Figure 12-1Data Setup Menu for a Parallel Port Configuration
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See the PSG User’s Guide for information

Clock and sample rates

The N5102A module clock rateis set using the Clock Rate softkey and has arange of 1 kHz to
400 MHz. The sample rate is automatically calculated and has arange of 1 kHz to 100 MHz. These ranges can be
smaller depending on logic type, data parameters, and clock configuration.

Maximum Clock Rates

The N5102A module maximum clock rate depends on the logic and signal type. Table 12-1 and
Table 12-2 show the warranted rates and the maximum clock rates for the various logic and signal types. Notice that
LVDSin the output mode using an IF signal isthe only logic type where the warranted and maximum rates are the same.

Table 12-1Warranted Parallel Output Level Clock Rates and Maximum Clock Rates

Warranted Level Clock Rates Maximum Clock Rates (typical)
Logic Type
1Q Signal Type IF Signal Type? 1Q Signal Type IF Signal Type
LVTTL and CMOS 100 MHz 100 MHz 150 MHz 150 MHz
LVDS 200 MHz 400 MHz 400 MHz 400 MHz
@The IF signal type is not available for a serial port configuration.
Table 12-2Warranted Parallel Input Level Clock Ratesand Maximum Clock Rates
Logic Type Warranted Level Clock Rates Maximum Clock Rates (typical)

LVTTL and CMOS

100 MHz

100 MHz
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Table 12-2Warranted Parallel Input Level Clock Ratesand Maximum Clock Rates

Logic Type Warranted Level Clock Rates Maximum Clock Rates (typical)

LVDS 100 MHz 400 MHz

The levels will degrade above the warranted level clock rates, but they may still be usable.

Serial Port Configuration Clock Rates

For a seria port configuration, the lower clock rate limit is determined by the word size (word size and sample size are
synonymous), while the maximum clock rate limit remains constant at 150 MHz for LVTTL and CMOS | ogic types, and
400 MHz for an LVDS logic type.

Thereverseistrue for the samplerate. The lower sample (word) rate value of 1 kHz remains while the upper limit of the
sampl e rate varies with the word size. For example, afive-bit sasmplefor an LVTTL or CMOS logic typeyields the
following values in serial mode:

¢ Clock rate of 5 kHz through 150 MHz
e Samplerate of 1 kHz through 30 MHz

Refer to Table 12-3 and Table 12-4, for the serial clock rates.
Table 12-30utput Serial Clock Rates

Logic Type Minimum Rate Maximum Rate
LVDS 1 x (word size) kHz 400 MHz
LVTTL and CMOS 1 x (word size) kHz 150 MHz

Table 12-4Input Serial Clock Rates

Logic Type Data Type Minimum Rate Maximum Rate
LVDS Samples 1 x (word size) kHz 400
Pre-FIR Samples | 1x (word size) kHz the smaller of: 50% x (word size) MHz
or
400 MHz
LVTTL and CMOS N/A 1 x (word size) kHz 150 MHz

aThe maximum sample rate depends on the selected filter when the datarate is Pre-FIR Samples. Refer to “Input Mode” on
page 249 for more information.

Parallel and Parallel Interleaved Port Configuration Clock Rates
Parallel and parallel interleaved port configurations have other limiting factors for the clock and sample rates:
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e logictype
¢ Clocks per sample selection
* 1QorIFdigita signal type

Clocks per sample (clocks/sample) istheratio of the clock to samplerate. For an 1Q signal type, the samplerateis
reduced by the clocks per sample value when the value is greater than one. For an |F signal or an input signal, clocks per
sampleisaways set to one. Refer to Table 12-5 for the Output mode parallel and parallel interleaved port configuration
clock rates.

Table 12-50utput Parallel and Parallel Interleaved Clock Rates

Logic Type Signal Type Minimum Rate Maximum Rate
LVDS 1Q 1 x (clocks/sample) kHz the smaller of: 100 x (clocks /sample) MHz
EJ12)0 MHz
IF 4 kHz 400 MHz
Other 1Q 1 x (clocks/sample) kHz the smaller of: 100 x (clocks /sample) MHz
ggo MHz
IF 4kHz 150 MHz

For Input mode, the maximum clock rate is limited by the following factors:

e samplesize

e datatype

* selected filter for Pre-FIR Samples

Refer to Table 12-6 for the Input mode parallel and parallel interleaved port configuration clock rates.

Table 12-6Input Parallel and Parallel Interleaved Clock Rates

Logic Type Data Type Minimum Rate Maximum Rate
N/A Samples 1kHz 100 MHz
Pre-FIR Samples 1kHz 502 MHz

@The maximum sampl e rate depends on the selected filter when the datarate is Pre-FIR Samples. Refer to “Input Mode” on
page 249 for more information.
Clock Source
The clock signal for the N5102A module is provided in one of three ways through the following selections:
« Interna: generated internally in the interface module (requires an external reference)
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« External: generated externally through the Ext Clock In connector
« Device: generated externally through the Device Interface connector

The clock source is selected using the N5102A module Ul on the signal generator, as shown in
Figure 12-2.

Figure 12-2Clock Source Selection
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When you select a clock source, you must let the N5102A module know the frequency of the clock signal using the
Clock Rate softkey. In the internal clock source mode, use this softkey to set the internal clock rate. For device and
external clock sources, this softkey must reflect the frequency of the applied clock signal.

When the clock sourceis Internal, afrequency reference must be applied to the Freq Ref connector. The frequency of
this applied signal needs to be specified using the Reference Frequency softkey, unless the current setting matches that
of the applied signal.

The selected clock source provides the interface module output clock signal at the Clock Out and the Device Interface
connectors.

Common Frequency Reference

The clocking flexibility of the digital signal interface module allows the setting of arbitrary clock rates for the device
under test. In general, the clock rate inside the PSG will be different from the interface module clock rate, so the
interface module performs arate conversion. An important aspect of this conversion isto have accurate clock rate
information to avoid losing data. The module relies on relative clock accuracy, instead of absolute accuracy, that must be
ensured by using a single frequency reference for all clock ratesinvolved in the test setup. This can be implemented in
various ways (see the five drawingsin Figure 12-3 on page 240), but whatever way it isimplemented, the clock inside
the signal generator must have the same base frequency reference as the clock used by the device under test.

PSG Freguency Reference Connections
When afrequency reference is connected to the PSG, it is applied to one of two rear-panel connectors:

e 10MHzIN
« BASEBAND GEN REF IN
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The BASEBAND GEN REF IN connector will accept afrequency reference in the range of 1 to 100 MHz. If the
external or device under test clock source cannot provide or accept a frequency reference, that clock signal can be
applied to this connector and used as the frequency reference.

Whenever an external clock signal or frequency reference is connected to the BASEBAND GEN REF IN connector, its
frequency needs to be entered into the current signal generator modulation format. For information on the BASEBAND
GEN REF IN connector refer to “24. BASEBAND GEN CLK IN” on page 31. For information on the associated
softkeys and fields for entering the frequency of the applied clock signal or frequency reference, refer to the Keysight

PSG Sgnal Generators Key Reference.

Figure 12-3Frequency Reference Setup Diagramsfor the N5102A Module Clock Signal
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NOTE: Use only one of the two signhal generator frequency reference inputs.
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Externally Supplied Clock

Data
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NOTE: Use only one of the two signal generator frequency reference inputs.

Clock Timing for Parallel Data

Some components require multiple clocks during a single sample period. (A sample period consists of an | and Q
sample). For parallel data transmissions, you can select one, two, or four clocks per sample. For clocks per sample
greater than one, the | and Q samples are held constant to accommodate the additional clock periods. This reduces the
samplerate relative to the clock rate by afactor equal to the clocks per sample selection. For example, when four is
selected, the sample rate is reduced by afactor of four (sample rate to clock rate ratio). Figure 12-4 demonstrates the
clock timing for each clocks per sample selection. For input mode, the clocks per sample setting is always one.
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Figure 12-4Clock Sample Timing for Parallel Port Configuration
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2 Clocks Per Sample
Sample rate decreases by a factor of two

1 Sample Period

Peripheral Devices
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Clock Timing for Parallel Interleaved Data

The N5102A module provides the capability to interleave the digital | and Q samples. There are two choices for
interleaving:

¢ 1Q, wherethel sampleistransmitted first
¢ Ql, wherethe Q sampleistransmitted first

When parallel interleaved is selected, all samples are transmitted on the | data lines. This effectively transmits the same
number of samples during a sample period on half the number of datalines as compared to non-interleaved samples. (A
sample period consists of an | and Q sample.) Clocks per sampleis still avalid parameter for parallel interleaved
transmissions and creates a reduction in the sample rate relative to the clock rate. The clocks per sample selection isthe
ratio of the reduction. Figure 12-5 shows each of the clocks per sample selections, for aparallel 1Q interleaved port
configuration, using aword sized of four bits and the clock timing relative to the | and Q samples. For aparalel QI
interleaved port configuration, just reverse the | and Q sample positions. For input mode, the clocks per sample setting is
alwaysone.

Figure 12-5Clock Timing for a Parallel | Q Interleaved Port Configuration

1 Clock Per Sample

The | sample is transmitted on one clock transition and the Q sample is transmitted on the
other transition; the sample and clock rates are the same.
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2 Clocks Per Sample

The | sample is transmitted for one clock period and the Q sample is transmitted during the second
clock period; the sample rate decreases by a factor of two.
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4 Clocks Per Sample

The | sample is transmitted for the first two clock periods and the Q sample is transmitted during the second two
clock periods; the sample rate is decreased by a factor of four.
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Clock Timing for Serial Data

Figure 12-6 shows the clock timing for a serial port configuration. Notice that the serial transmission includes frame
pulses that mark the beginning of each sample while the clock delineates the beginning of each bit. For seria
transmission, the clock and the bit rates are the same, but the sample rate varies depending on the number of bits per
word that are entered using the Word Size softkey. The number of bits per word is the same as the number of bits per
sample.

Figure 12-6Clock Timing for a Serial Port Configuration
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Clock Timing for Phase and Skew Adjustments

The N5102A module provides phase and skew adjustments for the clock relative to the data and can be used to align the
clock with the valid portion of the data. The phase has a 90 degree resolution (0, 90, 180, and 270 degree selections) for
clock ratesfrom 10 to 200 MHz and a 180 degree resolution (0 and 180 degree selections) for clock rates below 10 MHz
and greater than 200 MHz.

The skew is displayed in nanoseconds with a maximum range of +5 ns using a maximum of +127 discrete steps. Both
the skew range and the number of discrete steps are variable with a dependency on the clock rate. The skew range
decreases asthe clock rateisincreased and increases as the clock rate is decreased. The maximum skew range is reached
at aclock rate of approximately 99 MHz and is maintained down to a clock rate of 25 MHz. For clock rates below

25 MHz, the skew adjustment is unavailable.

A discrete step is calculated using the following formula:

1
256 x Clock Rate
The number of discrete steps required to reach the maximum skew range decreases at lower frequencies. For example, at

aclock rate of 50 MHz, 127 steps would exceed the maximum skew range of +5 ns, so the actual number of discrete
steps would be less than 127.

Figure 12-7 isan example of a phase and skew adjustment and shows the original clock and its phase position relative
to the data after each adjustment. Notice that the skew adjustment adds to the phase setting.
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Figure 12-7Clock Phase and Skew Adjustments
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Connecting the Clock Source and the Device Under Test

Asshown in Figure 12-3 on page 240, there are numerous ways to provide a common frequency reference to the
system components (PSG, N5102A module, and the device under test). Figure 12-8 shows an example setup where the
signal generator supplies the common frequency reference and the N5102A module provides the clock to the device.

See the N5102A Digital Signal Interface Module Installation Guide for detailed information on device interface
connections.

CAUTION  The Device Interface connector on the interface module communicates using high speed digital data. Use
ESD precautions to eliminate potential damage when making connections.

NOTE You must disconnect the digital bus cable and the digital module while downloading firmware to the signal
generator.
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Figure 12-8Example Setup using the PSG 10 MHz Frequency Reference

Signal generator 10 MHz Out

Common Freq Ref cable

Freq Ref connector
Device under test
Break-out board

Device interface connection User furnished ribbon cable(s) connect
between the device and break-out board.
The clock to the device is in the ribbon
cable.

1. Refer to the five setup diagramsin Figure 12-3 on page 240 and connect the frequency reference cable according
to the clock source.

2. If anexterna clock sourceis used, connect the external clock signal to the Ext Clock In connector on the interface
module.

3. Select the break-out board that has the output connector suited for the application. See the N5102A Digital Sgnal
Interface Module Installation Guide for information on breakout boards.

NOTE If the Device Interface mating connector is used with the device under test, refer to
Figure 12-8 for the device interface connection and connect the device to the N5102A module. Then proceed
to “Operating the N5102A Module in Output Mode” on page 250 or “Operating the N5102A Module in
Input Mode” on page 259.

4. Refer to Figure 12-8. Connect the breakout board to the N5102A module's Device Interface connector.

5. Connect the device to the break-out board. See the N5102A Digital Sgnal Interface Module Installation Guide for
information on breakout board connectivity.

Data Types

The following block diagram indicates where in the PSG signal generation process the datais injected for input mode or
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tapped for output mode.
Output
Mode
Pre-FIR
Samples Samples
A A
=
Data FIR 1,Q RF
o > > 1/Q
Generator A Filteri ng A DACs Modulator >
Pre-FIR Samples
Samples

Mbde

Output Mode

When using an ARB format, the data type is always Samples and no filtering is applied to the data samples.The samples
are sent to the digital module at the ARB sample clock rate.

For real-time formats, choosing Samples as the data type will send filtered samples to the digital module at arate
between 50 MHz and 100 MHz. Selecting Pre-FIR Samples, sends unfiltered samples to the digital module at arate
equal to the sample rate of the current format.

Input Mode

When the data type is Samples, the data samples coming through the digital module are injected at a point that bypasses
the filtering process.

If Pre-FIR Samplesis selected, the data samples are injected before the filtering process. The maximum rate will be
determined by the selected filter. Refer to Table 12-7.
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Table 12-7Maximum Sample Rate for Selected Filter

Filter Maximum Rate

Gaussian
Nyquist

Root Nyquist
Rectangle
Edge 50 MHz
UN3/4 GSM Gaussian
1S-95

1S95 W/EQ

1S-95 Mod 25 MHz
1S-95 Mod w/EQ

APCO 25 C4FM 12.5 MHz

The Filter softkey accesses amenu that enables you set the desired filtering parameters.

Operating the N5102A Modulein Output Mode

This section shows how to set the parameters for the N5102A Option 003 modulein output mode using the front panel
keys. Each procedure contains afigure that shows the softkey menu structure for the interface module function being
performed.

Setting up the Signal Generator Baseband Data

The digita signal interface module receives data from a baseband source and outputs adigital 1Q or digital IF signal
relative to the selected logic type. Because the PSG provides the baseband data, the first procedure in operating the
interface module is configuring the PSG using one of the real-time or ARB modulation formats, or playing back a stored
file using the Dual ARB player. For information on setting up real-time or ARB waveforms, or to learn about using the
Dual ARB player, refer to the appropriate chapter in this guide.

1. Preset the signa generator.
2. Select the modulation format (TDMA, Custom, and so forth) and set the desired parameters.
3. Turn-on the modulation format.

Accessing the N5102A Module User Interface
Press Aux Fctn > N5102A Interface.

This accessesthe Ul (first-level softkey menu shown in Figure 12-9) that is used to configure the digital signal interface
module. Notice the graphic in the PSG display showing a setup where the N5102A moduleis generating its own internal
clock signal. This graphic changes to reflect the current clock source selection.
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Choosing the Logic Type and Port Configuration

Figure 12-10L ogic and Port Configuration Softkey Menus
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CAUTION  Changing the logic type can increase or decrease the signal voltage level going to the device under test.
To avoid damaging the device and/or the N5102A module, ensure that both are capable of handling the
voltage change.

2. Select the logic type required for the device being tested.

A caution message is displayed whenever achange is made to the logic types, and a softkey selection appears
requesting confirmation.

3. Refer to Figure 12-10. Press the Port Configuration softkey.
In this menu, select either a serial, parallel, or paralel interleaved data transmission.

NOTE Within the data and clock setup softkey menus, only softkeysthat are relative to the current configuration are
active. Softkeysthat are grayed out are not available for the current setup. Refer to the help text to determine
which parameter is causing the softkey to be unavailable. To get help information, pressthe Help hardkey,
then press the unavailable softkey.

4. Select the port configuration for the device.

Selecting the Output Direction
Press Data Setup > Direction Input Output to Output and press Return.

NOTE If Option 003 isthe only option installed, the direction softkey will be unavailable and the mode will aways
be output. With both Option 003 (output mode) and Option 004 (input mode) installed, the default directionis
output.

Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have self-explanatory names are generally not
mentioned. For example, the Word Size softkey. For more information on all of the softkeys, refer to Keysight PSG
Sgnal Generators Key Reference.

1. Referto Figure 12-11. Pressthe Data Setup softkey.
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This softkey menu accesses the various parameters that govern the data received by the device under test. The status
area of the display shows the number of datalines used for both | and Q along with the clock position relative to the
data. When the port configuration is parallel or parallel interleaved, the number of datalinesindicated is equivalent
to the word (sample) size. When the port configuration is serial, the display will show that only one | and one Q data
line is being used along with the frame marker that delineates the beginning of a sample. Figure 12-12 showsthe

data setup menu structure.
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Figure 12-12Data Setup Softkey Menu with Parallel Port Configuration
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2. If area-time modulation format is being used, press the Data Type softkey. (This softkey isinactive when an ARB

modulation format is turned on.)

In this menu, select whether the real-time baseband data from the signal generator is either filtered (Samples) or

unfiltered (Pre-FIR Samples). The selection depends on the test needs. The Samples selection provides FIR filtered
baseband samples based on the communication standard of the active modulation format. Thisis the preset selection
and the one most commonly used. However if the device being tested already incorporates FIR filters, the Pre-FIR
Samples selection should be used to avoid double filtering.

Select the data type that is appropriate for the test.
Press the Numeric Format softkey.

From this menu, select how the binary values are represented. Selecting 2's complement allows both positive and
negative data values. Use the Offset Binary selection when components cannot process negative values.

Select the numeric format required for the test.
Pressthe More (1 of 2) softkey.
From this softkey menu, select the bit order, swap | and Q, select the polarity of the transmitted data, and access
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menus that provide data negation, scaling, gain, offset, and |Q rotation adjustments.

7. Pressthe Data Negation softkey.

Negation differs from changing the | and Q polarity. Applied to a sample, negation changes the affected sample by
expressing it in the two's complement form, multiplying it by negative one, and converting the sample back to the
selected numeric format. This can be done for | samples, Q samples, or both.

The choice to use negation is dependent on the device being tested and how it needs to receive the data.
8. Pressthe Gain, Offset & Scaling softkey.

Use the softkeysin this menu for the following functions:

* reduce sample valuesfor both | and Q using the Scaling softkey

* increase or decrease the sample values independently for | and Q using the | Gain and Q Gain softkeys
« compensate for or add a DC offset using the | Offset and Q Offset softkeys
« rotate the data on the 1Q plane using the Rotation softkey

9. Make any required scaling, gain, offset, or rotation adjustments to properly test the device.

10. Press Return > Return to return to the first-level softkey menu.

Configuring the Clock Signal

1. Referto Figure 12-13. Pressthe Clock Setup softkey.

Figure 12-13Clock Setup Menu L ocation
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From this softkey menu, set all of the clock parameters that synchronize the clocks between the N5102A module and
the PSG. You can aso change the clock signal phase so the clock occurs during the valid portion of the data.
Figure 12-14 showsthe clock setup menu.

Figure 12-14Clock Setup Softkey Menu for a Parallel Port Configuration
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The top graphic on the display shows the current clock source that provides the output clock signal at the Clock Out
and Device Interface connectors. The graphic changes to reflect the clock source selection discussed later in this
procedure. The bottom graphic shows the clock position relative to the data. The displayed clock signal will change
to reflect the following:

« clocks per sample selection
e clock phase choice

» clock skew adjustment

» clock polarity selection

If the device or external clock does not match the frequency, one of the following error messages will appear on the
PSG:

805 Digital module output FIFO overflow error; There are more
samples being produced than can be consumed at the current
clock rate. Verify that the digital module clock is set up
properly.
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Thiserror is reported when the output FIFO is overflowing in the
digital module. This error can be generated if an external clock
or itsreference is not set up properly, or if theinternal VCO is
unlocked.

806 Digital module output FIFO underflow error; There are not
enough samples being produced for the current clock rate.
Verify that the digital module clock is set up properly.

Thiserror is reported when the output FIFO is underflowing in the digital module. This error
can be generated if an external clock or itsreferenceis not set up properly, or if the internal
VCO is unlocked.

2. If the port configuration is parallel or parallel interleaved, using an 1Q signal type, pressthe
Clocks Per Sample softkey.

Notice that multiple clocks per sample can be selected. Some DACs require the ability to clock multiple times for
each sample; having a clocks per sample value greater than one reduces the sample rate by afactor equal to the
selected number of clocks per sample. The samplerate is viewed on the first-level and Data Setup softkey menus.

3. Select the clocks per sample value to fit the test.
Pressthe Clock Sour ce softkey.

From this menu, select the clock signal source. With each selection, the clock routing display in the signal generator
clock setup menu will change to reflect the current clock source. Thiswill be indicated by a change in the graphic.

5. Select the clock source.
If External or Deviceis Selected
Pressthe Clock Rate softkey and enter the clock rate of the externally applied clock signal.

NOTE The clock phase and clock skew may need to be adjusted each time the clock rate setting is changed. Refer to
“Clock Timing for Phase and Skew Adjustments” on page 246.

For the External selection, the signal is supplied by an external clock source and applied to the Ext Clock In
connector. For the Device selection, the clock signal is supplied through the Device Interface connector, generally
by the device under test.

If Internal is Selected

Using an external frequency reference, the N5102A module generatesits own internal clock signal. The reference
frequency signal must be applied to the Freq Ref connector on the digital module.

a. Pressthe Reference Frequency softkey and enter the frequency of the externally applied frequency reference.
b. Pressthe Clock Rate softkey and enter the appropriate clock rate.

Table 12-8 provides a quick view of the settings and connections associated with each clock source selection.
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Table 12-8Clock Source Settings and Connectors

Clock Source Softkeys N5102A M odule Connection
Reference Clock Rate? Freq Ref Ext Clock In Device Interface
Frequency

External . .

Device . .

Internal® * * *

3For the Internal selection, this sets the internal clock rate. For the External and Device selections, thistells
the interface modul e the rate of the applied clock signal.

bThere should be no clock signal applied to the Ext Clock In connector.

6.

Press the Clock Phase softkey.

From the menu that appears, you can adjust the phase of the clock relative to the datain 90 degree increments. The
selections provide a coarse adjustment for positioning the clock on the valid portion of the data. Selecting 180
degreesis the same as selecting a negative clock polarity.

The 90 degree and 270 degree selections are not available when the clock rate is set below 10 MHz or above
200 MHz. If 90 degrees or 270 degreesiis selected when the clock rateis set below 10 MHz or above 200 MHz, the
phase will change to O degrees or 180 degrees, respectively.

NOTE The clock phase and clock skew may need to be adjusted any time the clock rate setting is changed. Refer to

“Clock Timing for Phase and Skew Adjustments” on page 246.

10.
11.

12.
13.

Enter the required phase adjustment.
Press the Retur n softkey to return to the clock setup menu.
Pressthe Clock Skew softkey.

This provides afine adjustment for the clock relative to its current phase position. The skew is a phase adjustment
using increments of time. This enables greater skew adjustment capability at higher clock rates. For clock rates
below 25 MHz, this softkey isinactive.

The skew has discrete values with arange that is dependent on the clock rate. Refer to “Clock Timing for Phase
and Skew Adjustments” on page 246 for more information on skew settings.

Enter the skew adjustment that best positions the clock with the valid portion of the data.
Pressthe Clock Polarity Neg Pos softkey to Neg.

This shiftsthe clock signal 180 degrees, so that the data starts during the negative clock transition. This hasthe same
affect as selecting the 180 degree phase adjustment.

Make the clock polarity selection that is required for the device being tested.
Pressthe Return hardkey to return to the first-level softkey menu.

The clock source selection is also reflected in the first-level softkey menu graphic. For example, if the device isthe
new clock source, the graphic will show that the frequency reference is now connected to the DUT and the DUT has
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an input clock line going to the N5102A module.

Generating Digital Data
Press the N5102A Off On softkey to On.

Digital datais now being transferred through the N5102A module to the device. The green status light should be
blinking. This indicates that the data lines are active. If the status light is solidly illuminated (not blinking), al the data
lines are inactive. The status light comes on and stays on (blinking or solid) after the first time the N5102A module is
turned on (N5102A Off On to On). The status light will stay on until the module is disconnected from its power supply.

The interface module can only be turned on while amodulation format is active. If the modulation format is turned off
while the module is on, the module will turn off and an error will be reported.

NOTE If changes are made to the baseband data parameters, it isrecommended that you first disable the digital output
(N5102A Off On softkey to Off) to avoid exposing your device and the N5102A module to the signal
variations that may occur during the parameter changes.

Operating the N5102A Modulein Input Mode

This section shows how to set the parameters for the N5102A Option 004 module using the signal generator Ul in the
input direction. Each procedure contains afigure that shows the softkey menu structure for the interface modul e function
being performed.

Refer to “Connecting the Clock Source and the Device Under Test” on page 247 and configure the test setup.

Accessing the N5102A Module User Interface
All parameters for the N5102A module are set with softkeys on the PSG signal generator.
Press Aux Fctn > N5102A Interface.

This accesses the Ul (first-level softkey menu shown in Figure 12-15) that is used to configure the digital signal
interface module. Notice the graphic, in the PSG display, showing a setup where the N5102A module is generating its
own internal clock signal. This graphic changes to reflect the current clock source selection.
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Figure 12-15First-L evel Softkey Menu
Internal clock going to the DUT
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Selecting the Input Direction
If both Option 003 (output mode) and Option 004 (input mode) are installed, you must select the input direction.
Press Data Setup > Direction Input Output to Input and press Return.

NOTE If only Option 004 isinstalled, the direction softkey will be unavailable and the mode will always be input.

260 Keysight PSG Signal Generators User’s Guide



Choosing the Logic Type and Port Configuration

Figure 12-16L ogic and Port Configuration Softkey Menus
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1. Referto Figure 12-16. Pressthe L ogic Type softkey.

From this menu, choose alogic type.
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CAUTION  Changing the logic type can increase or decrease the signal voltage level. To avoid damaging the device
and/or the N5102A module, ensure that both are capable of handling the voltage change.

2. Select the logic type required for the device being tested.

A caution message is displayed whenever achangeis made to thelogic types, and a softkey selection appears asking

for confirmation.

3. Refer to Figure 12-16. Pressthe Port Configuration softkey.

In this menu, select either a serial, parallel, or parallel interleaved data transmission.

NOTE Within the data and clock setup softkey menus, only softkeysthat are relative to the current configuration are
active. Softkeys that are grayed out are not available for the current setup. Refer to the help text to determine
which parameter is causing the softkey to be unavailable. To get help information, press the Help hardkey,

then press the unavailable softkey.

4. Select the port configuration for the device being tested.

Configuring the Clock Signal

1. Pressthe Clock Setup softkey, as shown in Figure 12-17.
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Figure 12-17Clock Setup Menu L ocation
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From this softkey menu, set all of the clock parameters that synchronize the data between the N5102A module and
the device. From this menu, the clock signal phase can be changed so the clock occurs during the valid portion of the
data. Figure 12-18 shows the clock setup menu.

If the device or external clock does not match the frequency, one of the following error messages will appear on the

PSG:
803

804

Digital module input FIFO overflow error; There are more
samples being produced than can be consumed at the current
clock rate. Verify that the digital module clock is set up
properly.

This error is reported when the digital module clock setup is not
synchronized with the rate the samples are entering the digital
module. Verify that the input clock rate matches the specified
clock rate under the clock setup menu.

Digital module input FIFO underflow error; There are not enough
samples being produced for the current clock rate. Verify that
the digital module clock is set up properly.

Thiserror is reported when the digital module clock setup is not
synchronized with the rate the samples are entering the digital
module. Verify that the input clock rate matches the specified
clock rate under the clock setup menu.
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Figure 12-18Clock Setup Softkey Menu for a Parallel Port Configuration
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The top graphic on the display shows the current clock source that provides the output clock signal at the Clock Out
and Device Interface connectors. The graphic changes to reflect the clock source selection discussed later in this

procedure. The bottom graphic shows the clock edges relative to the data. The displayed clock signa will change to
reflect the following:

e clock phase choice
» clock skew adjustment
« clock polarity selection
2. Pressthe Clock Source softkey.

From this menu, select the clock signal source. With each selection, the clock routing display in the signal generator
clock setup menu will change to reflect the current clock source. Thiswill be indicated by a change in the graphic.

3. Select the clock source.
If External or Deviceis Selected
Pressthe Clock Rate softkey and enter the clock rate of the externally applied clock signal.

NOTE The clock phase and clock skew may need to be adjusted any time the clock rate setting is changed. Refer to
“Clock Timing for Phase and Skew Adjustments” on page 246.

For the External selection, the signal is supplied by an external clock source and applied to the Ext Clock In
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connector. For the Device selection, the clock signal is supplied through the Device Interface connector, generally
by the device being tested.

If Internal is Selected

Using an external frequency reference, the N5102A module generatesits own internal clock signal. The reference
frequency signal must be applied to the Freq Ref connector on the digital module.

a Pressthe Reference Frequency softkey and enter the frequency of the externally applied frequency reference.
b. Pressthe Clock Rate softkey and enter the appropriate clock rate.

Table 12-9 provides aquick view of the settings and connections associated with each clock source selection.

Table 12-9Clock Source Settings and Connectors

Clock Source Softkeys N5102A M odule Connection
Reference Clock Rate? Freq Ref Ext Clock In Device Interface
Frequency

External . .

Device . .

Internal® * * *

3For the Internal selection, this sets the internal clock rate. For the External and Device selections, thistells
the interface modul e the rate of the applied clock signal.

bThere should be no clock signal applied to the Ext Clock In connector when Internal is being used.

4.

Press the Clock Phase softkey.

From the menu that appears, the phase of the clock relative to the data can be changed in 90 degree increments. The
selections provide a coarse adjustment for positioning the clock on the valid portion of the data. Selecting 180
degreesis the same as selecting a negative clock polarity.

The 90 degree and 270 degree selections are not available when the clock rate is set below 10 MHz or above
200 MHz. If 90 degrees or 270 degrees is selected when the clock rateis set below 10 MHz or above 200 MHz, the
phase will change to O degrees or 180 degrees, respectively.

NOTE The clock phase and clock skew may need to be adjusted any time the clock rate setting is changed. Refer to

“Clock Timing for Phase and Skew Adjustments” on page 246.

Enter the required phase adjustment.
Press the Retur n softkey to return to the clock setup menu.
Pressthe Clock Skew softkey.

This provides afine adjustment for the clock relative to its current phase position. The skew is a phase adjustment
using increments of time. This enables greater skew adjustment capability at higher clock rates. For clock rates
below 25 MHz, this softkey isinactive.
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The skew has discrete values with arange that is dependent on the clock rate. Refer to “Clock Timing for Phase
and Skew Adjustments” on page 246 for more information on skew settings.

Enter the skew adjustment that best positions the clock with the valid portion of the data.
Pressthe Clock Polarity Neg Pos softkey to Neg.

This shiftsthe clock signal 180 degrees, so that the data starts during the negative clock transition. This hasthe same
affect as selecting the 180 degree phase adjustment.

Make the clock polarity selection that is required for the device being tested.
Press the Return hardkey to return to the first-level softkey menu.

The clock source selection is also reflected in the first-level softkey menu graphic. For example, if the deviceisthe
new clock source, you will see that the frequency reference is now connected to the DUT and the DUT has an input
clock line going to the N5102A module.

Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have self-explanatory names (for example, the
Word Size softkey) are generally not mentioned. For more information on all of the softkeys, refer to the Keysight PSG
Sgnal Generators Key Reference.

1. Referto Figure 12-19. Pressthe Data Setup softkey.
Figure 12-19Data Setup Menu L ocation
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This softkey menu accesses the various parameters that govern the data received by the PSG. The status area of the
display shows the number of data lines used for both | and Q along with the clock position relative to the data.
Figure 12-20 shows the data setup menu structure.
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Figure 12-20Data Setup Softkey Menu with Parallel Port Configuration
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2. Pressthe Data Type softkey.

In this menu, select the data type to be either filtered (Samples) or unfiltered (Pre-FIR Samples). The selection is
dependent on the test needs and the device under test. However if the device being tested already incorporates FIR
filters, the Pre-FIR Samples selection should be used to avoid double filtering. Refer to “Data Types” on

page 248, for more information.

3. Select the datatype that is appropriate for the test needs.
4. Pressthe Numeric Format softkey.

From this menu, select how the binary values are represented. Selecting 2's complement allows both positive and
negative data values. Use the Offset Binary selection when components cannot process negative values.

5. Select the numeric format required for the test.
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6. PresstheMore (1 of 2) softkey.

From this softkey menu, select the bit order, swap | and Q, the polarity of the data, and access menus that provides
data negation, scaling, and filtering parameters.

7. Pressthe Data Negation softkey.

Negation differs from changing the | and Q polarity. Applied to a sample, negation changes the affected sample by
expressing it in the two's complement form, multiplying it by negative one, and converting the sample back to the
selected numeric format. This can be done for | samples, Q samples, or both.

The choice to use negation is dependent on the device being tested.

8. Toaccess|/Q scaling and filter parameters, press Return > N5102A Off On to On. Thiswill invoke the real time
Custom format in the PSG baseband generator. Thisis needed to set the filter parameters when Pre-FIR Samplesis
selected as the data type.

9. Pressthe Baseband Setup softkey.
Use this softkey menu to adjust the 1/Q scaling and access filter parameters. If the selected datatype is Samples, the
Filter softkey is grayed out (inactive).

Digital Data

If the N5102A digital moduleis not on, press Return > Return > N5102A Off On to On.

Digital datais now being transferred through the N5102A module to the PSG The green status light should be blinking.
Thisindicates that the data lines are active. If the status light is solidly illuminated (not blinking), all the datalines are
inactive. The status light comes on and stays on (blinking or solid) after the first time the N5102A moduleis turned on
(N5102A Off On softkey to On). The status light will stay on until the module is disconnected from its power supply.

NOTE If changes are made to the baseband data parameters, it isrecommended that you first disable the digital output
(N5102A Off On softkey to Off) to avoid exposing the device and the N5102A module to the signal variations
that may occur during the parameter changes.

Millimeter-Wave Sour ce M odules

You can extend the signal generator’s RF frequency using an Keysight 8355x series millimeter-wave source module or
any other external source module. The output frequency range depends on the frequency range of the mm-wave source
module. This section contains the following procedures:

¢ Using Keysight Millimeter-Wave Source Modules
e Using Other Source Modules

Using Keysight Millimeter-Wave Sour ce M odules

The Keysight 8355x series millimeter-wave source module connects to the signal generator’s rear panel SOURCE
MODULE INTERFACE connector and allows for direct communication between the instruments as well as providing
for automatic leveling control of the source module. If you want to use an 8355x series source module without the
automatic leveling or multiplier selection features, then refer to the section “Using Other Source Modules” on

page 271.

Thefollowing isalist of equipment required for extending the frequency range of the signal generator:
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« Keysight 8355x series millimeter-wave source module
¢ Keysight 8349B microwave amplifier (required only for the E8257D PSG without Options 1EA, 1EU, or 521)
* RF output cables and adapters as required

NOTE Maximum insertion loss for cables and adapters connected to the E8267D PSG or E8257D PSG with
Options 1EA, 1EU, or 521, should be less than 1.5 dB. Thiswill ensure maximum power from the external
source module.

Setting Up the External Source Module

CAUTION  To prevent damage to the signal generator, turn off the line power to the signal generator before
connecting the source module interface cable to the rear panel SOURCE MODULE INTERFACE
connector.

1. Turn off the signa generator’s line power.
2. Connect the equipment as shown.
« E8257D PSG without Options 1EA, 1EU, or 521
e EB8257D PSG with Options 1EA, 1EU, 521, or E8267D PSG uses the setup in Figure 12-22.
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Figure 12-21E8257D PSG without Option 1EA, 1EU, or 521
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Figure 12-22Setup for E8267D PSG and E8257D PSG with Option 1EA, 1EU, or 521
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Configuring the Signal Generator
1. Turnonthe signa generator’s line power.

NOTE Refer to the mm-wave source module specifications for the specific frequency and amplitude ranges.

2. PressFrequency > (3 of 3) > Source Module, toggle the Keysight 8355x Sour ce M odule Off On softkey to On.
The signal generator will:

«  recognize the Keysight mm-wave source module,
« switch the leveling mode to external/source module (power is leveled at the mm-wave source modul e output),
¢ set the mm-wave source module frequency and amplitude to the source modul€’s preset values, and

» display the RF output frequency and amplitude values available at the mm-wave source modul e output when
enabled
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When the 8355x series mm-wave source is enable via the front panel Keysight 8355x Source Module Off On
softkey, the MMOD indicator inthe FREQUENCY areaand the MM indicator in the AMPLITUDE areawill appear
on the signal generator’s display.

3. IftheRF OFF annunciator isdisplayed, press RF On/Off.
Leveled power should be available at the output of the millimeter-wave source module.
To obtain flatness-corrected power, refer to “Creating and Applying User Flatness Correction” on page 132.

Using Other Source M odules

Use the following procedure to extend the frequency range of the PSG with any external source module, or to use the
Keysight 8355x series millimeter-wave source modul€' swithout automatic leveling. Thefollowing isalist of equipment
required for extending the frequency range of the signal generator:

e external millimeter-wave source module

« Keysight 8349B or other microwave amplifier (required only for the E8257D PSG without Option 1EA, 1EU, or
521)

* RF output cables and adapters as required

Setting Up the External Source Module
1. Turn off the signal generator’s line power.

2. Connect the equipment as shown.
« E8257D PSG without Option 1EA, 1EU, or 521
» EB8257D PSG with Option 1EA or E8267D PSG uses the setup in Figure 12-24.
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Figure 12-23E8257D PSG without Option 1EA, 1EU, or 521
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Figure 12-24Setup for E8267D PSG and E8257D PSG with Option 1EA, 1EU, or 521
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Configuring the Signal Generator

The following procedure configures a PSG for use with any external source module that has a WR (waveguide
rectangular) frequency range of 90-140 GHz. You can modify the frequency range to match your source module.

1. Turnonthesignal generator’sline power.

NOTE Automatic leveling at the source module output is not available with the OEM Source Module selection.

Press Frequency > (3 of 3) > Source Module. Toggle the K eysight 8355x Sour ce M odule Off On softkey to Off.
Toggle the OEM Sour ce Off On softkey to On.
Press OEM Source M odule Config > Sandard WR Freq Bands > WR8 90-140GHz.

The selections in the Standard WR Freg Bands menu are pre-defined frequency ranges and multipliers for the most
common external source module frequency ranges. They are provided for setup convenience. If your source module
has a frequency range not listed in the list of pre-defined setups, use the Min Band Freg, Max Band Freq, and
Freq Multiplier softkeysto manualy set the range and PSG frequency display multiplier. For more information on
these manual settings, refer to the E8257D/67D PSG Sgnal Generators Key Reference.

5. If theRF OFF annunciator isdisplayed, press RF On/Off.

To obtain flatness-corrected power, refer to “Creating and Applying User Flatness Correction” on page 132.
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13 Troubleshooting

This chapter provides basic troubleshooting information for Keysight PSG signal generators. If you do not find a
solution here, refer to the Keysight PSG Sgnal Generators Service Guide.

NOTE If thesignal generator displays an error, aways read the error message text by pressing Utility > Error Info.

e  “RF Output Power Problems” on page 275

e “No Modulation at the RF Output” on page 281

* “Sweep Problems” on page 282

» “Data Storage Problems” on page 283

e “Cannot Turn Off Help Mode” on page 284

» “Signal Generator Locks Up” on page 284

e “Error Messages” on page 285

» “Contacting Keysight Sales and Service Offices” on page 287

» “Returning a Signal Generator to Keysight Technologies” on page 287

RF Output Power Problems
Check the RF ON/OFF annunciator on the display. If it readsRF OFF, press RF On/Off to toggle the RF output on.

No RF Output Power when Playing a Waveform File (E8267D only)

Preset the signal generator, then replay the waveform file.

If aheader fileisnot specified for awaveform, the signal generator uses adefault header file with unspecified settings. If
you play awaveform file that has unspecified signal generator settings; (settings not saved to the file header, see

page 92), the signal generator will use the header file settings from the previously played file. If the previous header file
had a marker routed to RF blanking, the RF output power will be blanked. Preset the signal generator to return the RF
blanking marker function to its default state (Off)). Refer to the Key Reference, Marker section, for more information.

NOTE If thedefault marker file is used, ensure that the Pulse/RF Blank softkey is set to None. Markers may have
been set to Pulse/RF Blank by a previous file header.

KEYSIGHT

TECHNOLOGIES
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RF Output Power too L ow

NOTE OnE8267D’s,an -222 Data out of range (“output power”) error can be caused by:

e Anincorrect waveform RM S voltage when using the signal generator with the ALC off.

e Themarker signal is not routed correctly to the ALC hold and the pul se modulator for complex wireless
signals.

For these instrument setups, if the signal is unleveled, the instrument does not have sufficient power available.

Look for an OFFS or REF indicator in the AMPLITUDE area of the display.

OFFS tells you that an amplitude offset has been set. An amplitude offset changes the value shown in the
AMPLITUDE areaof the display but does not affect the output power. The amplitude displayed is equal to the current
power output by the signal generator hardware plus the value for the offset.

To eliminate the offset, press the following keys:
Amplitude> More (1 of 2) > Ampl Offset > 0> dB.

REF tells you that the amplitude reference mode is activated. When this modeis on, the displayed amplitude valueis
not the output power level. It isthe current power output by the signal generator hardware minus the reference value
set by the Ampl Ref Set softkey.

To exit the reference mode, follow these steps:

a PressAmplitude> More (1 of 2).

b. Press Ampl Ref Off On until Off is highlighted.
You can then reset the output power to the desired level.

If you are using the signal generator with an external mixer, see “Signal Loss While Working with a Mixer” on
page 276.

If you are using the signal generator with a spectrum analyzer, see “Signal Loss While Working with a Spectrum
Analyzer” on page 278.

The Power Supply has Shut Down

If the power supply is not working, it requires repair or replacement. There is no user—replaceable power supply fuse.
Refer to the Keysight PSG Signal Generators Service Guide for instructions.

Signal Loss While Working with a Mixer

If you experience signal loss at the signal generator’s RF output during low—amplitude coupled operation with a mixer,
you can solve the problem by adding attenuation and increasing the RF output amplitude of the signal generator.

Figure 13-1 shows a hypothetical configuration in which the signal generator provides alow amplitude signal to a
mixer.

276
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Figure 13-1Effects of Reverse Power on ALC
SIGNAL GENERATOR
OUTPUT CONTROL
ALC LEVEL RE OUTPUT MIXER
=-8dBm =_8dBm
_— RN
RF LEVEL
CONTROL > j j Lo
DETECTOR DETECTOR LO FEEDTHRU LO LEVEL
MEASURES MEASURES =-5dBm =+10dBm
-8dBm -5dBm
ALC LEVEL REVERSE
POWER IF

Theinternally leveled signal generator RF output (and ALC level) is—8 dBm. The mixer is driven with an LO of
+10 dBm and has an LO-to—RF isolation of 15 dB. The resulting L O feedthrough of -5 dBm enters the signa
generator’s RF output connector and arrives at the internal detector.

Depending on frequency, it is possible for most of this LO feedthrough energy to enter the detector. Since the detector
responds to its total input power regardless of frequency, this excess energy causes the AL C to reduce the RF output of
the signal generator. In this example, the reverse power across the detector is actually greater than the ALC level, which
may result in loss of signal at the RF output.

Figure 13-2 shows a similar configuration with the addition of a 10 dB attenuator connected between the RF output of

the signal generator and theinput of the mixer. The signal generator’s ALC level isincreased to +2 dBm and transmitted
through a 10 dB attenuator to achieve the required -8 dBm amplitude at the mixer input.
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Figure 13-2Rever se Power Solution
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Compared to the original configuration, the ALC level is 10 dB higher while the attenuator reduces the L O feedthrough
(and the RF output of the signal generator) by 10 dB. Using the attenuated configuration, the detector is exposed to a
+2 dBm desired signal versus the—15 dBm undesired L O feedthrough. This 17 dB difference between desired and
undesired energy resultsin amaximum 0.1 dB shift in the signal generator’s RF output level.

Signal Loss While Working with a Spectrum Analyzer

The effects of reverse power can cause problems with the signal generator’s RF output when the signal generator is used
with a spectrum analyzer that does not have presel ection capability.

Some spectrum analyzers have as much as +5 dBm L O feedthrough at their RF input port at some frequencies. If the
frequency difference between the LO feedthrough and the RF carrier is less than the ALC bandwidth, the LO’s reverse
power can cause amplitude modulation of the signal generator’s RF output. The rate of the undesired AM equals the
difference in frequency between the spectrum analyzer’s L O feedthrough and the RF carrier of the signal generator.

Reverse power problems can be solved by using one of two unleveled operating modes: AL C off or power search.

Setting ALC Off Mode

AL C off mode deactivates the automatic leveling circuitry prior to the signal generator’s RF output. In thismode, a
power meter isrequired to measure the output of the signal generator and assist in achieving the required output power at
the point of detection.

Use the following steps to set the signal generator to the ALC off mode:

Preset the signal generator: press Preset.

Set the desired frequency: press Frequency and enter the desired frequency.

Set the desired amplitude: press Amplitude and enter the desired amplitude.

Turn the RF on: set RF On/Off to On

Turn the signal generator’s automatic leveling control (ALC) off: press Amplitude > AL C Off On to Off.
Monitor the RF output amplitude as measured by the power meter.

Press Amplitude and adjust the signal generator’s RF output amplitude until the desired power is measured by the

oukrwNE
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power meter.

Poor Pulse Performance

For pulse widths <1 microsecond, you may need to do a power search to optimize the pulse performance of the
instrument. Refer to “Setting Power Search Mode” on page 279.

Setting Power Search Mode

Power search mode executes a power search routine that temporarily closesthe ALC, calibrates the power of the current
RF output, and then opensthe ALC circuitry. See the Keysight PSG Signal Generators Key Reference for more
information on the Power Search function.

CAUTION  Therearetwo “RF During Power Search” settings available for the power search, Minimum and Normal.
The Minimum softkey setsthe internal attenuator to its maximum setting during power search to protect
the power sensitive circuits. When the power search has completed the attenuator is returned to the last
attenuator setting before the power search was executed. The Normal softkey executes the power search
without this added attenuator protection.

A successful power search is dependent on avalid power search reference and the instrument’s ability to
level at a set power level without modulation.

There are three power search modes: manual, automatic, and span.

Manual When Power Search is set to Manual, pressing Do Power Search executes the power search
calibration routine for the current RF frequency and amplitude. In this mode, if thereis a change
in RF frequency or amplitude, you will need to press Do Power Search again.

Auto When Power Search is set to Auto, the calibration routine is executed whenever the frequency or
amplitude of the RF output is changed.

Span When Power Search is set to Span, pressing Do Power Search executes the power search
calibration routine over a selected range of frequencies at one time. The power search corrections
are then stored and used whenever the signal generator is tuned within the selected range of
frequencies. Span power search settings are only valid for asingle power level.

Use the following steps to set the signal generator to manual fixed power search mode:

Press Preset.

Press Frequency and enter the desired frequency.

Press Amplitude and enter the desired amplitude.

Press Amplitude > AL C Off On to Off.

Press Power Search (Manual, Fixed) > Minimum. (The Minimum softkey setstheinternal attenuator to its
maximum setting during power search to protect the power sensitive circuits. Refer to the Key Help.)

Press RF On/Off to On.

Press Do Power Search.

This executes the manual fixed power search routine, which is the default mode.

grwbdpE
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Setting the Power Search Reference (E8267D only)

NOTE A successful power search is dependent on avalid power search reference.

Additionally, on the E8267D, there are up to four Power Search Reference modes: ARB RMS, Fixed, Manual RMS or
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Manual, and Modulated. These four reference modes select the reference voltage used while the RF signal isbeing I/Q
modulated. (Power search reference modes are not used for analog modulation: FM, PM, or pulse modulation.)

CAUTION If the power search reference has the incorrect RM S voltage, the output power will be incorrect. Refer to
Figure 13-3, "Calculating the Output Power Error for a Single Waveform Sample Point" and
Figure 13-4, “Calculating the RMS Voltage of the Waveform.”

Figure 13-3Calculating the Output Power Error for a Single Wavefor m Sample Point

The Output Power Error = 20 x |og10((V1)/(V2))

Where:
V1 is the actual waveform RMS voltage
V2 is the entered RMS voltage

Note: If the RMS voltage value entered is lower than the actual RMS voltage, the output power will be higher than desired.
If the RMS voltage value entered is higher than the actual RMS voltage, the output power will be lower than desired.

Figure 13-4Calculating the RM S Voltage of the Waveform

i
RMS value for the waveform = 1
2 2
itoa ) * N
n=1

Because the RMS calculation, that is done by the signal generator, is

slow and may not be appropriate for your application, it is recommended

that the user calculate and enter in their measured RMS value for the N =# of Samples
waveform file.

SCPI Commands:

[ :SOURce] :RADio:ARB:HEADER : RMS <"fi1e7name">,<va1>|UNSPecified
[:SOURce] :RADio:ARB:HEADER:RMS? <"file name">

For a programming example of determining the RMS voltage of a waveform, refer to the Programming Guide and to the
Documentation CD that came with this instrument.

ARB RMS During ARB RMS, the Power Search Referenceisset to ARB RMS, the I/Q modulation is
disabled, and the 1/Q modulator is biased with aDC level that is equivalent to the RM S voltage of
the modulating signal. This selection istypically used with internally generated baseband 1/Q
modul ations. When the search is complete, the DC biasis removed and the I/Q signal isreapplied
to the I/Q modulator.

The RM Svoltage value can be found in the waveform header (Refer to Chapter 3, “Basic Digital
Operation.”) The RM S voltage value can be set by the user or calculated by the signal generator.

NOTE The ARB RMS softkey is only available when the internal Arb is enabled.

Fixed During Fixed, the Power Search Referenceis set fixed RMS reference level and is used to bias
the 1/Q modulator.
Manua RMS During the Manual RMSS, the user selectsaDC biaslevel (0to 1.414 Vrms) as a Power Search
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Reference to be applied to the I/Q modulator during the power search.

Modulated During the Modul ated power search, the Power Sear ch Referenceis set to Modulated, the actual
modulating signal is used to provide the AC bias on the I/Q modulator. Modulated can be used
with either internally generated or externally supplied 1/Q modulation.

CAUTION Dueto thetime varying nature of the I/Q data, amodul ated reference search can take longer to settle and
be less accurate than the other reference bias types. The modulated search reference bias type is not
recommended for use with low symbol rate modulated formats.

The modulated power search reference cannot be used with a bursted signal.

No M odulation at the RF Output

Check theMOD ON/OFF annunciator on the display. If it reeadsMOD OFF, press Mod On/Off to toggle the modulation
on.

Although you can set up and enable various modulations, the RF carrier is modulated only when you have also set
Mod On/Off to On.

On the E8267D, for digital modulation, make sure that 1/Q Off On is set to On.
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Sweep Problems

Sweep Appearsto be Salled

The current status of the sweep isindicated as a shaded rectangle in the progress bar. You can observe the progress bar to
determineif the sweep is progressing. If the sweep appears to have stalled, check the following:

[d Have you turned on the sweep by pressing any of the following key sequences?
Sweep/List > Sweep > Freq
Sweep/List > Sweep > Ampl
Sweep/List > Sweep > Freg & Ampl

1 Isthe sweep in continuous mode? If the sweep isin single mode, be sure that you have pressed the Single Sweep
softkey at least once since completion of the prior sweep. Try setting the mode to continuous to determine if the
missing single sweep is blocking the sweep.

[ Isthe signa generator receiving the appropriate sweep trigger? Try setting the
Sweep Trigger softkey to Free Run to determine if a missing sweep trigger is blocking the sweep.

[ Isthesignal generator receiving the appropriate point trigger? Try setting the Point Trigger softkey to Free Run to
determineif amissing point trigger is blocking the sweep.

[ Isthe dwell time appropriate? Try setting the dwell time to one second to determine if the dwell time was set to a
value which was too slow or too fast for you to see.

[d Do you have at least two pointsin your step sweep or list sweep?

Cannot Turn Off Sweep Mode

Press Sweep/List > Sweep > Off.
In the sweep mode menu you can choose to set the sweep to various sweep types or to turn sweep off.

Incorrect List Sweep Dwell Time

If the signal generator does not dwell for the correct period of time at each sweep list point, follow these steps:
1. Press Sweep/List > Configure List Sweep.

This displays the sweep list values.

Check the sweep list dwell values for accuracy.

Edit the dwell values if they are incorrect.

NOTE Theeffectivedwell timeat the RF OUTPUT connector isthe sum of the value set for the dwell plus processing
time, switching time, and settling time. This additional time added to the dwell is generally afew milliseconds.
The TTL/CMOS output available at the TRIG OUT connector, however, is asserted high only during the
actual dwell time.

If thelist dwell values are correct, continue to the next step.
4. Observeif the Dwell TypeList Sep softkey is set to Step.
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When Step is selected, the signal generator will sweep the list points using the dwell time set for step sweep rather
than the sweep list dwell values.

To view the step sweep dwell time, follow these steps:
a PressConfigure Step Sweep.
b. Observethe value set for the Sep Dwell softkey.

List Sweep Information isMissing from a Recalled Register

List sweep information is not stored as part of the instrument state in an instrument state register. Only the current list
sweep is available to the signal generator. List sweep data can be stored in the instrument catalog. For instructions, see
“Storing Files to the Memory Catalog” on page 60.

Data Storage Problems

Registers With Previously Sored Instrument Sates are Empty

The savelrecall registers are backed—up by a battery when line power to the signal generator is not connected. The
battery may need to be replaced.

To verify that the battery has failed:

1. Turn off line power to the signal generator.
Unplug the signal generator from line power.
Plug in the signal generator.

Turn on the signal generator.

g > w0 N

Observe the display for error messages.
If either error message —311 or —700 is stored in the error message queue, the signal generator’s battery has failed.
6. Refer tothe Keysight PSG Signal Generators Service Guide for battery replacement instructions.

Saved Instrument Sate, but Register is Empty or Contains Wrong State

If you select aregister number greater than 99, the signal generator automatically selects register 99 to save the
instrument state.

If the register number you intended to use is empty or contains the wrong instrument state, recall register 99:
Press Recall > 99 > Enter.
The lost instrument state may be saved there.
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Cannot Turn Off Help Mode
1. PressUtility > Instrument Info/Help M ode

2. PressHelp Mode Single Cont until Singleis highlighted.
The signal generator has two help modes; single and continuous.

When you press Help in single mode (the factory preset condition), help text is provided for the next key you press.
Pressing another key will exit the help mode and activate the key’s function.

When you press Help in continuous mode, help text is provided for the next key you press and that key’sfunctionisaso
activated (except for Preset). You will stay in help mode until you press Help again or change to single mode.

Signal Generator LocksUp
If the signal generator islocked up, check the following:

* Make sure that the signa generator is not in remote mode (in remote mode, the R annunciator appears on the
display). To exit remote mode and unlock the front panel keypad, press L ocal.

e Make sure that the signal generator isnot in local lockout condition. Local lockout prevents front panel operation.
For more information on local lockout, refer to the Keysight Sgnal Generators Programming Guide.

e Check for aprogress bar on the signal generator display, which indicates that an operation isin progress.
e PressPreset.

e Cycle power on the signal generator.

Fail-Safe Recovery Sequence

Use the fail—safe recovery sequence only if the previous suggestions do not resolve the problem.

CAUTION  This process does reset the signal generator, but it also destroys the following types of data:

el user files (instrument state and data files)
¢ DCFM/DC®M cdlibration data
e persistent states

NOTE Do not attempt to perform any other front panel or remote operations during the fail—safe sequence.

To run the fail-safe sequence, follow these steps:
1. Hold down the Preset key while cycling power.
2. Continue to hold down the Preset key until the following message is displayed:

WARNING You areentering the diagnostics menu which can cause unpredictable instrument behavior. Are
you sure you want to continue?

CAUTION  Carefully read the entire message! It may list additional risks with this procedure.

3. Releasethe Preset key.
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4. To continue with the sequence, press Continue (to abort with no lost files, press Abort).
5. When the sequence concludes, do the following:
a  Cycle power.

Cycling power restores al previoudly installed options. Because calibration files are restored from EEPROM,
you should see several error messages.

b. Performthe DCFM/DC®M calibration.
Refer to the DCFM/DC®M Cal softkey description in the Keysight PSG Signal Generators Key Reference.

c. Keysight Technologiesisinterested in the circumstances that made it necessary for you to initiate this
procedure. Please contact us at the telephone number listed at http: //mmw.keysight.comvfind/assist. We would
like to help you eliminate any repeat occurrences.

Error Messages

If an error condition occursin the signal generator, it isreported to both the front panel display error queue and the SCPI
(remote interface) error queue. These two queues are viewed and managed separately; for information on the SCPI error
queue, refer to the Keysight Signal Generators Programming Guide.

NOTE When thereis an unviewed message in the front panel error queue, the ERR annunciator appears on the signal
generator’s display.

Characteristic Front Panel Display Error Queue

Capacity (#errors) 30

Circular (rotating).

Overflow Handling Drops oldest error as new error comesin.

Viewing Entries Press: Utility > Error Info > View Next (or Previous) Error Page
Clearing the Queue Press: Utility > Error Info> Clear Error Queue(s)
Unresolved Errors? Re-reported after queueis cleared.

When the queue is empty (every error in the queue has been read, or the queue is cleared), the following message appears
No Errors in the queue:
0 No Error Message (s) in Queue

®Errors that must be resolved. For example, unlock.

Error Message File

A completelist of error messages is provided in the file errormessages.pdf, on the CDROM supplied with your
instrument.

In the error message list, an explanation is generally included with each error to further clarify its meaning. The error
messages are listed numerically. In cases where there are multiple listings for the same error number, the messages arein
alphabetical order.
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Error Message For mat

When accessing error messages through the front panel display error queue, the error numbers, messages and
descriptions are displayed on an enumerated (“1 of N”) basis.

Error messages appear in the lower— eft corner of the display as they occur.

Error Description

Error Number Error Message (May be truncated on the display)
A A

r NS A\

=222 Data out of range; wvalue clipped to lower limit.

Indicates that the user has entered a deviation, depth or internal
source frequency that is beyond the specified limits. y
\

'

Explanation provided in the Error Message List
(This is not displayed on the instrument)

Error Message Types
Events do not generate more than one type of error. For example, an event that generates a query error will not generate
a device-specific, execution, or command error.

Query Errors(—499 to —400) indicate that the instrument’s output queue control has detected a problem with the
message exchange protocol described in IEEE 488.2, Chapter 6. Errorsin this class set the query error bit (bit 2) in the
event status register (IEEE 488.2, section 11.5.1). These errors correspond to message exchange protocol errors
described in |EEE 488.2, 6.5. In this case:

e Either an attempt is being made to read data from the output queue when no output is either present or pending, or
e datain the output queue has been lost.

Device Specific Errors (—399 to —300, 201 to 703, and 800 to 810) indicate that a device operation did not properly
complete, possibly due to an abnormal hardware or firmware condition. These codes are also used for self—test response
errors. Errorsin this class set the device—specific error bit (bit 3) in the event status register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates that the instrument
detected an error within the GPIB system, within the instrument’s firmware or hardware, during the transfer of block
data, or during calibration.

Execution Errors (—299 to —200) indicate that an error has been detected by the instrument’s execution control block.
Errorsin this class set the execution error bit (bit 4) in the event status register (IEEE 488.2, section 11.5.1). In this case:

¢ Either a<PROGRAM DATA> element following a header was evaluated by the device as outside of itslegal input
range or is otherwise inconsistent with the device's capabilities, or

« avalid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression evaluation operations are completed. Rounding a numeric
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data element, for example, is not reported as an execution error.

Command Errors (—199 to —100) indicate that the instrument’s parser detected an |EEE 488.2 syntax error. Errorsin
this class set the command error bit (bit 5) in the event status register (IEEE 488.2, section 11.5.1). In this case:

« Either an IEEE 488.2 syntax error has been detected by the parser (a control-to—device message was received that is
in violation of the |EEE 488.2 standard. Possible violations include a data element that violates device listening
formats or whose type is unacceptable to the device.), or

¢ anunrecognized header was received. These include incorrect device—specific headers and incorrect or
unimplemented |EEE 488.2 common commands.

Contacting Keysight Sales and Service Offices

Assistance with test and measurement needs, and information on finding alocal Keysight office are available on the
Internet at:
http: //www.keysi ght.convfind/assist

You can also purchase E8257D/67D or E8663D PSG accessories or documentation items on the Internet at:
http: //mww.keysi ght.convfind/psg

If you do not have access to the Internet, contact your field engineer.

NOTE Inany correspondence or telephone conversation, refer to the signal generator by its model number and full
serial number. With this information, the Keysight representative can determine whether your unit is still
within its warranty period.

Returning a Signal Generator to Keysight Technologies

To return your signal generator to Keysight Technologies for servicing, follow these steps:
1. Gather as much information as possible regarding the signal generator’s problem.

2. Cadll the phone number listed on the Internet (http://mww.keysi ght.convfind/assist) that is specific to your geographic
location. If you do not have access to the Internet, contact your field engineer.

After sharing information regarding the signal generator and its condition, you will receive information regarding
where to ship your signal generator for repair.

3. Shipthesigna generator in the original factory packaging materials, if available, or use similar packaging to
properly protect the signal generator.
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Symbols
®M 18,151

Numerics
003, option 5
004, option 5
005, option 5
007, option 3, 6, 8, 49
008, option 3,6
009, option 5
015, option 5
016, option 5
1 GHz REF OUT connector 28
10 MHz EFC connector 29
10 MHz IN connector 30
10 MHz OUT connector 31
128QAM 1/Q modulation, creating 169
1410, application note 217, 227
1E7, option 3,6
1EA, option 3,6
1ED, option 3,6
1EH, option 3, 6, 44
1EM, option 3,6
1EU, option 3,6
1SM, option 3,6
2's complement description 254, 266
27 kHz pulse 45
403,0ption 93
403/403, option
description 5
521, option 3,6
601/602, option
custom arb mode 77, 157,179
description 5,9
multitone mode 217
symbol rates 167
two-tone mode 227
628, error 126
802.11b 128
8757 network analyzers 53
8757D Scalar Network Analyzer 45, 49-57

A

AC power receptacle 28
ACP 77,161,186
active entry area (display) 18
adding & editing (instrument state) 62
adjustments, display 14, 15
ALC
annunciator 18
bandwidth selection 127
limitations, amplitude 129
off mode, setting 278

Index

with attenuator option 131
ALC hold

description 96

saving setting 96
ALC HOLD connector 29
ALC INPUT connector 13, 34
alpha adjustment (filter) 161
alternate ramp sweep 54
AM 18,150
amplifier, microwave 268, 271
amplitude

display area 20

hardkey 11

LF output 155

modulation. See AM

ramp sweep 55, 44
analog modulation 8, 149-156
analog PSG

optional features 3, 6
annunciators 18
application notes

1410 217,227

obtaining 1
ARB

AWGN 233

file catalogs 59

triggers 109

waveform clipping 115-122, 78-88, 123-125

See also custom arb waveform generator

See also dual arbitrary waveform generator
arb 77
ARMED annunciator 18
arrow hardkeys 14
ATTEN HOLD annunciator 18
attenuator, external leveling 131
AUTOGEN_WAVEFORM file 89
automatic leveling control. See ALC
AUXILIARY 1/0 connector 25
AUXILIARY INTERFACE connector 30
AWGN

ARB 233

dual ARB player 93

real-time 233

B
bandwidth

ALC, selecting 127

reference oscillator, adjusting 145
baseband

clipping 115-122

frequency offset

softkey location 126
scaling 123-125
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Index

BASEBAND GEN CLK IN connector 31
baseband generator 77
AWGN 233
custom arb mode 9, 157,9, 179
dual arb mode 9, 77
multitone mode 9, 217
settings 189, 190
two-tone mode 9, 227
basic operation
digital 77
standard 37
BbT, adjusting 161
binary files 59
bit files 59
bits per symbol, equation 192
block diagrams
GPS signal generation 207, 209
MSGPS signal generation 2071
BURST GATE IN connector 25
burst shapes 185-189
bursted signals 128

C

carrier bandwidth 93
carrier feedthrough, minimizing 222, 230
carrier signal, modulating 59
carrier to noise ratio 93
CCDF curve 121-122,223
CDMA 128
ceiling function, bits per symbol 192
certificate, license key 71
circular clipping 121
clipping
CCDF curve 121-122
circular 118,121, 115-121
procedure 121, 122
rectangular 118, 122
clock adjustment
phase and skew 246
clock rate limits, logic type output 236
clock source
setting 257, 263
clock timing
parallel data 241, 244, 246
serial data 246
clocking, frequency reference 239
clocking, frequency reference diagrams 240
Clocks Per Sample
parallel data 241, 244
COH CARRIER connector 28
comments, adding & editing (instrument state) 62
common frequency reference diagrams 240
component test 77

concepts
differential data encoding 191
FIR filters 160

waveform clipping 115-121, 95, 123-125

confidential data 63
connections

common frequency reference 240
connectors

external triggering 112,113

front panel 10

rear panel 21
continuous

list sweep 49

step sweep 47

triggering 111
continuous wave

configuring 42

description 8
contrast adjustments 14, 15
correction array (user flatness)

configuration 134

load from step array 135

viewing 135

See also user flatness correction
couplers/splitters, using 128
custom arb 78

custom arb waveform generator 9, 157-177

custom mode 77

custom real-time I/Q baseband 9, 179-198

CW mode
configuring 42
description 8

D

DAC over range error 126
DAC over-range errors 123-125
data
clock 190
encoding, differential 191-198
fields, editing 39, 59, 110
input methods 63
patterns
triggering 109
using 180
removal 68
sensitive 63, 68
problems 283
security 63
See also instrument state register
See also memory catalog
unframed 110
DATA CLOCK connector 15, 34
DATA connector 16, 35
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data filtering, pre or post fir 254, 266
data sheets 1
data types 248
DC detector 45
DC offset 151
declassification 63
default FIR filter, restoring 162
default navigation data, GPS 208
delay, external trigger signal 111
Delete Item softkey 39
Delete Row softkey 39
description, adding & editing (instrument state) 62
detector
diode response 130
using 128
device clock source selection 257, 263
DHCP 72
diagram
data types 248
diagrams
clock timing, parallel data 241, 244, 246, 240
differential data encoding 191-198
DIG BUS annunciator 18
Digital Bus connector 26
digital modulation
annunciators 19
custom 157-177,179-198
formats 9
multicarrier 157,159, 176, 217-225
two tone 227-232
digital signal interface 235
digital signal interface module 235
diode detector response 130
discrete steps, skew range 246
display
blanking 71
contrast decrease 14, 15
descriptions 17
overview 17
secure /1
DMOD files 59
documentation options 7
documentation, list of xiii
downloading firmware 7
dual arb 77
dual ARB player 9, 89-94
Dual ARB real-time noise 93
dual arbitrary waveform generator 9, 89-94
dwell time 46

E

E8257D
optional features 3

Index

E8267D
optional features 5
standard features 4
E8663D
optional features 6
Edit Item softkey 39
Erase All 68, 69, 71
erase and overwrite 68
erase and sanitize 68
erasing memory 63, 68, 69, 71
ERR annunciator 18, 285
error messages
DAC over range 126, 123-125
display 20
message format 286
overview 285
queue 285
types 286
EVENT connectors 25
EVM 161,186
EXT
annunciators 18
EXT 1 connector 33
EXT 1 INPUT connectors 12
EXT 2 connector 33
EXT 2 INPUT connector 13
extend frequency 58
extend frequency range 58
external
data clock, setting 190, 130
simultaneous triggering pulse source 153
external clock source selection 257, 263
external FM 151
external I/Q modulation 175
external source module 267
external trigger
connection 112
gated, setting 112
single, setting 176,113

F

fail-safe recovery sequence 284
failures. See troubleshooting
fall delay, burst shape 186
fall time, burst shape 186
FAQ 1
features, signal generator 1
feedthrough, carrier, minimizing 230
file headers (ARB waveform) 78-88
file store
files 61

catalogs 59

using 60
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Index

waveform segments 90-94, 91-93

See also instrument state register

See also memory catalog
filtered & unfiltered samples 254, 266
filters

interpolation 123-124

using 160-167
FIR 59,160
firmware

options 7

upgrades

obtaining 7
using GPIB 7

Flash Drive Input Connector 36
flatness correction. See user flatness correction
FM 18, 150
formula, skew discrete steps 246
framed data 110
free run trigger response 111
frequency

display area 18

hardkey 11

modulation. See FM

offset 43, 126

ramp sweep 49, 1,43

RF output, setting 42
frequency extension 58
frequency output limits, clock rates & logic levels 236
frequency range 58
frequency reference

common 239

hookup diagrams 240
front panel

description 10-17, 71
FSK

files 59

modulation 169, 173, 174

G

GATE/PULSE/TRIGGER connector 14
gated 152
gated triggering 110, 112
Gaussian filter, selecting 161
Goto Row softkey 39
GPIB 29,137
GPS
chip clock reference 210, 213
data modes 208
handover word 208
overview 206
satellite ID range 206, 214, 207, 210, 208
TLM word 208
user files 211

H

handover word, GPS 208

hardkeys 10-15

hardware, configuring 176, 189
harmonics, below 2 GHz, option UNX 147
Help hardkey 12

help mode troubleshooting 284

Hold hardkey 14

I IN connector 34
I Input connector 16
I OUT connector 27
I/0 connector, auxiliary 25
I/Q
4QAM state map 192
annunciator 18
files 59
input connectors 16
modulation 173, 195
scaling, adjusting 190
I/Q waveform
clipping 115-122
scaling 123-125
I-bar OUT connector 27
IMD. See intermodulation distortion
Incr Set hardkey 14
information
additional PSG 1
protecting sensitive 63
Insert Item softkey 39
Insert Row softkey 39
installing firmware 7
instrument state register
comments, adding and editing 62
troubleshooting 283
using 61
See also memory catalog
instrument states 54
int gated 152
interface connectors
AUXILIARY INTERFACE 30
GPIB 29
LAN 30
RS-232 30
interface, remote 137
intermodulation distortion
how to minimize 117
testing non-linear devices 217, 227
internal
simultaneous triggering pulse source 153
internal clock source selection 257, 263
interpolation filter 123-124
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1Q
clock rates 237
modulation 175
|Q modulation 175

K

key, license 71
keypad, numeric 13
keys

disabling 71

front panel 10-15
Keysight PSG web page 1
knob, front panel 11

L

L (listener mode) annunciator 18
lan configuration 72
LAN connector 30
LEDs 15
leveling
ALC 278
external 128-132
internal 127
mm-wave source module, using 267
LF OUT connector 35
LF output 154-156
LF OUTPUT connector 13
license key 71
limits, clock & sample rates, logic outputs 236
line power LED 15
line switch 15
list
error messages 285
files 59
mode values table editor 38
sweep 47, 282
listener mode annunciator 18
Load/Store softkey 39
Local hardkey 15
logic type
output levels 236
selecting 251
low frequency output. See LF output
Low pass filter
improved harmonic distortion performance 44

M

magnitude error simulation 173
manual freq softkey 53
manual sweep 53
markers
output 31
ramp sweep 51

Index

waveform 94-109
master/slave setup 55
MDMOD files 59
media storage 64, 67
memory 89
base instrument 64
catalog b9, 283
See also instrument state register
erasing 63, 68
flash drive 67
hard disk 64
overwriting 68
persistence 63
sanitizing 68, 69, 63
types 63
waveform 64, 63
menus
marker 99, 109
trigger 111
MENUS hardkeys 12
microwave amplifier 268, 271
Millimeter 267
millimeter-wave source module 267
mixer, signal loss while using 276
mm-source 58
mm-wave source module
extending frequency range with 267
leveling with 132
user flatness correction array, creating 138-144
mod on/off 19
Mod On/Off hardkey 13
models, signal generator 1
modes of operation 8
modes, triggering 110
modulation
amplitude. See AM 8, 149-156, 149, 18-20, 58
digital 9
file catalogs 59
multicarrier 157,159, 176
phase. See ®M 157,179, 8,152, 153
types 169
user-defined 158, 195
See also digital modulation
modulation, pulse 5
module user interface location 250, 259
MSGPS
chip rate 206
external reference clock 206
generating a signal 205
RF power level 203
scenario files 199, 201, 205, 201
MSK modulation 169
MTONE files 59
multicarrier waveform 157, 159, 176
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Index

multitone 77
multitone mode 9
multitone waveform generator 217-225

N

N5102A 235
baseband data 250
clock rates 235, 255, 261
description 238
235,241,239, 247
data parameters, setting 252, 265, 248, 267
frequency reference connector 239
generating data 259
input direction 260, 249, 259, 244
logic type, port configuration 261, 2571
output direction 252, 249, 250
phase and skew clock timing 246
serial clock timing 246
user interface 250, 259
N5102A digital signal interface module 235
negation description 255, 267
noise 93, 233
noise bandwidth factor 93
non-linear devices, testing 217, 227
non-volatile memory 89
numeric format selection 254, 266
numeric keypad 13
NVMKR files 59
nvwfm 89
NVWFM files 59
Nyquist filters 1671

0

OFDM 128
offset 43, 44,151
offset binary use 254, 266
on/off switch 15
operation
basics 37
digital basics 77
modes of 8
Optimize Signal-to-Noise ratio
softkey 45
Option 422 199
options
0035,3,6,8,49,3,6,5,27,175,5,27,175
1E13,6,3,6,3,6,3,6,44,3,6,3,6,3,6
40393
description 5
206, 199
5213,6
601/602
basic digital operation 77

custom arb mode 157,179

description 5,9

multitone mode 217

two-tone mode 227

using symbol rates 167
additional information 7
enabling 71

UKB 3, 6,4,6,145,4,6,8,149-152,154, 4,8,149,152, 4,7,

8,149,152, 4,6
Options, UNX 145
oscillator, reference, adjusting BW 145
output levels, logic types 236
output power, troubleshooting 276
output. See LF output and RF output
OVEN COLD annunciator 19
over-range errors 123-125
overview, GPS 206
overwriting memory 68

P

Page Down softkey 39
Page Up softkey 39
parallel
clock rates 237
data clock timing 241
interleaved data clock timing 244
sample rates 237
PATTERN TRIG IN connector 25
peak to average power
CCDF curve 121,223
high ratios 117
multitone characteristics 223
reducing 118
performance, optimizing 127-148
peripheral devices 235
digital signal interface module 235
millimeter wave source module 235
phase
error simulation 173
modulation. See ®M
polarity 191
phase clock timing 246
phase noise, below 250 MHz, option UNX 146
player, dual ARB 89-94
polarity
marker setting, saving 78, 109
trigger, external 111
port configuration, selecting 251
power
meter 133,278
output, troubleshooting 276
peaks 115-121
receptacle, AC 28
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search mode 279, 276, 15
PRAM 77
predefined filters 160
predefined modulation setups 157,179
pre-fir samples selection 254, 266
Preset hardkey 15
private data 63
problems. See troubleshooting
product information 1
proprietary data 63
protecting data 63
PSG
additional information 1
firmware 7
modes of operation 8
options 7
web page 1
PSK modulation 169
pulse 128
annunciator 19
modulation 152
pulse modulation b5, 8, 45
simultaneous triggering 153
pulse performance, improving 279
pulse source 45, 152
PULSE SYNC OUT connector 34
PULSE VIDEO OUT connector 34
pulse width 279
pulse, marker, viewing 106
PULSE/TRIG GATE INPUT connector 34

Q

@ IN connector 35

@ Input connector 16

@ OUT connector 27

Q@AM modulation 169, 192

@-bar OUT connector 28

QPSK I/Q modulation, creating 171
queue, error 285

R

R (remote) annunciator 19
ramp sweep 49-57

real time 77

real-time AWGN 233
real-time I/Q 179-198
real-time mode 9, 78
real-time noise 93
real-time triggers 109
rear panel description 21
Recall hardkey 11

recall state 54

recall states 61

Index

receiver test 77
recovery sequence, fail-safe 284
rectangular clipping 122
reference
amplitude, setting 44
frequency, setting 43
GPS chip clock 210
MSGPS chip clock 206
oscillator bandwidth, adjusting 145
registers 61, 62
remote operation 137
remote operation annunciator 19
reset & run trigger response 111
response, triggering mode 110
restricted data 63
Return hardkey 14
returning a signal generator 287
RF blanking 275
marker function 107
settings, saving 96
RF On/Off hardkey 13
RF OUT connector 33
RF output
annunciator 19
configuring 42, 13
leveling, external 128-132, 40
mm-wave source module, using 267
sweeping 45
troubleshooting 275
user flatness correction 132-144
rise delay, burst shape 186
rise time, burst shape 186
root Nyquist filters 161
routing, marker
ALC hold 96
RF blanking 107
saving settings 96, 78
RS-232 connector 30
runtime scaling 125

S

S (service request) annunciator 19
sample

rates 235, 237

type selection 254, 266
samples

baseband 123-124

interpolated 123-124
sanitizing memory 68
satellite ID range, GPS 206
save and recall 54
save and recall states 61
save files
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Save hardkey 11
scalar network analyzer 45, 49-57
scalar pulse 45
scaling
concepts 123-125
procedure 125
runtime 125
waveform data 125
scenario files
MSGPS 199, 201
downloading 202
playing 205
SCPI 72
secure display 71
secure mode 69
security functions 63, 69
security level 69
segment advance triggering 111, 114
sensitive data 63
sensitivity testing, GPS 214
Seq files 59
sequences
building and storing 91
deleting 62
editing 92
instrument state register 61
marker control 104
playing 92
triggering 109
serial
clock and sample rates 237, 246
service request annunciator 19
service, Keysight sales and service offices 287
setting
user-defined, RF output limits 40
shape files 59
signal generator
features 1, 7
models 1, 8
options 7, 1
signal loss, troubleshooting 275
Signal Studio software 217, 227
Signal to noise ratio
setting 45
single step sweep 46
single trigger mode 110
single trigger, setting 176
skew
clock timing 246
range 246
SMI connector 32
softkeys 11, 20, 39
software
available for PSG 1

options 7
source module 267
source module interface 32
SOURCE SETTLED connector 32
source, external trigger 111
spectral regrowth 117
spectrum analyzer, troubleshooting signal loss 278
square pulse 45
standby LED 15
state files 59
state registers b4
step array (user flatness) 133
See also user flatness correction
step attenuator, external leveling 131
step sweep 46-47
STOP SWEEP IN/OUT connector 31
storage, troubleshooting 283
subframe indicator, GPS 210
sweep
27 kHz pulse 45
8757D Scalar Network Analyzer 45
annunciator 19
DC detector 45
list47
mode 8
ramp 49-57
RF output 45
scalar network analyzer 45, 46
trigger 49, 282
SWEEP OUT connector 31
sweep progress bar 45
switch, power 15
symbol rates 167
SYMBOL SYNC connector 15, 34
SYNC OUT connector 14

T

T (talker mode) annunciator 19
table editor, using 38-39
talker mode annunciator 19
TCP/IP 72
technical support 1
text display area 20
TLM word, GPS 208
trigger

hardkey 12

inputs

PATTERN TRIG IN 25

setting 49
trigger & run 111
trigger in 152
TRIGGER IN connector 31
TRIGGER OUT connector 31
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trigger polarity 152 web server /72
triggers 109-115, 176 website 1
troubleshooting 275-287 wfm1 89
two tone 9, 77,227-232 WEMT1 files 59
WIDEBAND I INPUT connectors 27
U wideband IQ 175
UK, option 3,6 WIDEBAND Q INPUT connectors 27
unfiltered & filtered samples 254, 266
unframed data 110 z
UNLEVEL annunciator 19 Z-AXIS BLANK/MKRS connector 31

UNLOCK annunciator 19
UNR/UNX, option 4, 6, 145
UNT, option 4, 6, 8, 149-152, 154
UNU, option 4, 8, 149, 152
UNW, option 4, 7, 8, 149, 152
UNX, option 145
UNY, option 4, 6
upgrading firmware 7
user files
GPS usage 211
user flatness 59, 132-144
user interface location, module 250, 259
user-defined
burst shape curves 186
data patterns 181
files 59, 162, 164
modulation type
custom arb 158
real-time 1/Q 169, 195

v

vector PSG
optional features 5
standard features 4
VIDEO OUT connector 14
volatile memory 89

w

warranted logic output clock rates 236
waveform memory 64, 67
waveforms
analog modulation 149
ARB file headers 78-88
CCDF curve 121-122
clipping 115-122,157-177,179-198
DAC over-range errors 123-125
file catalogs 59
interpolation 123-124
markers 94, 157,159, 176, 217-225
player, dual ARB 89-94
samples 123-124,123-125,90-94,91-93, 104, 121-122
triggering 109, 227-232
utilities 121-122
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