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FlexRay Automated Testing—At a Glance

Agilent's FlexRay Physical Layer Conformance Test Application software 
for Agilent InfiniiVision 3000 X- Series, 4000 X- Series, 6000 Series, and 
7000 Series oscilloscopes gives you a fast and easy way to verify and 
debug the physical layer characteristics of your FlexRay designs. This 
FlexRay test software lets you automatically execute FlexRay conformance 
tests, and displays the results in a flexible report format. In addition to 
the measurement data, the report provides margin analysis that shows 
how closely your device passed or failed each test.

The Physical Layer Conformance Test Application guides you through the 
process of selecting and configuring tests, making oscilloscope connections, 
running tests, and evaluating the test results. This application:

• Lets you select individual or multiple tests to run.

• Shows you how to make oscilloscope connections to the device under 
test based on selected connection type.

• Automatically checks for proper oscilloscope configuration.

• Automatically sets up the oscilloscope for each test.

• Provides detailed information for each test that has been run and lets 
you specify the thresholds at which marginal or critical warnings 
appear.

• Creates a printable HTML report of the tests that have been run.

For more information, see:

• Chapter 1, “Prerequisites,” starting on page 7

• "Required Equipment and Software" on page 8

• "Installing Agilent IO Libraries Suite" on page 9

• "Installing the Software" on page 13

• "Licensing the FlexRay Test Application" on page 13

• Chapter 2, “Using the Physical Layer Conformance Test Application,” 
starting on page 15

• "Starting the FlexRay Physical Layer Conformance Test Application" 
on page 16

• "Creating or Opening a Test Project" on page 19

• "Setting Up the Test Environment" on page 20

• "Selecting Tests" on page 23

• "Configuring Tests" on page 26

• "Connecting the Oscilloscope to the DUT" on page 28

• "Differential Input Signal Requirements and Troubleshooting Tips" on 
page 29

• "Running Tests" on page 31
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• "Viewing Results" on page 40

• "Viewing/Exporting/Printing the Report" on page 44

• "Saving Test Projects" on page 47

• "Controlling the Application via a Remote PC" on page 49

• Chapter 3, “About the Tests,” starting on page 53

• "Eye Diagram Measurement Tests" on page 54

• "Signal Integrity Voting Procedure Tests" on page 64

• "TSS Width Measurement Test" on page 70

• "Mean Corrected Cycle Time Test" on page 71

• "Amplitude Measurement Tests" on page 72

• "Transition Time Measurement Tests" on page 75

For a printable version of this help file, see: "FlexRay Automated 
Testing Online Help".

See Also • The electrical and timing parameters are specified by FlexRay 
Communications System Electrical Physical Layer Specification, 
Version 2.1, Revision E.
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Before running the automated tests, you need to acquire the required 
equipment and software, and you should calibrate the oscilloscope. After 
the oscilloscope has been calibrated, you are ready to start the FlexRay 
Physical Layer Conformance Test Application and perform measurements.
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1 Prerequisites
 

Required Equipment and Software

In order to run the automated tests, you need the following equipment 
and software:

• One of the following InfiniiVision 4- channel oscilloscopes:

• 4000 X- Series oscilloscope with:

• FLEX license (order DSOX4FLEX).

• MASK license (order DSOX4MASK).

• 3000 X- Series oscilloscope with:

• FLEX license (order DSOX3FLEX).

• MASK license (order DSOX3MASK).

• SGM license (order DSOX3SGM).

• 6000 Series or 7000 Series oscilloscope with:

• Software version 6.00 or greater.

• Option FLX (N5432C) license, or Option FRS (N5432A) with 
N5432U upgrade license.

• Differential active probe. Agilent recommended probes include:

• N2792A 200 MHz differential active probe.

• N2793A 800 MHz differential active probe.

• 113xA InfiniiMax differential active probe.

• FlexRay Physical Layer Conformance Test Application software.

• Agilent I/O libraries version 15.0 or greater.

• FlexRay device under test.

Controller PC Requirements

To ensure adequate performance, the FlexRay Physical Layer Conformance 
Test Application requires a controller PC with these characteristics:

• Processor: Intel Pentium 4 Processor 3 Ghz or better.

• RAM: 2 GB or better.

• Operating System: Windows XP 32- bit.
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Installing Agilent IO Libraries Suite

The controller PC must have installed Agilent I/O libraries version 15.0 or 
greater.

The Agilent IO Libraries Suite software can be downloaded from the 
Agilent web site at: "www.agilent.com/find/iolib"

• “Adding Your Oscilloscope Using Agilent Connection Expert" on page 9

Adding Your Oscilloscope Using Agilent Connection Expert

This procedure only needs to be performed once for each oscilloscope used 
to perform FlexRay conformance measurements.

1 On the PC that will run the FlexRay Test Application, choose Start > All 
Programs > Agilent IO Libraries Suite > Agilent Connection Expert from the 
Windows Start menu. Or, click on the Agilent IO Control icon in the 
taskbar, and choose Agilent Connection Expert from the popup menu.

2 In the Agilent Connection Expert application, instruments connected to 
the controller's USB and GPIB interfaces should automatically appear. 
(You can click Refresh All to update the list of instruments on these 
interfaces.)

NOTE The menus and dialogs shown here may differ slightly depending on the version of the 
Agilent IO Libraries Suite.

http://www.agilent.com/find/iolib
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1 Prerequisites
 

You must manually add instruments on LAN interfaces:

a Right- click on the LAN interface, choose Add Instrument from the 
popup menu, and click OK in the resulting dialog (because the 
desired interface is already selected).

b If the oscilloscope is on the same subnet, select it and click OK.
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Otherwise, click Add Address (or if you have a version of the IO 
Libraries that doesn't have Auto Find, select the LAN interface and 
click OK).

c In the next dialog, select either Hostname or IP address, and enter the 
oscilloscope's hostname or IP address.

d Click Test Connection.
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1 Prerequisites
 

e If the instrument is successfully opened, click OK to close the dialog. 
If the instrument is not opened successfully, go back and verify the 
LAN connections and the oscilloscope setup.

3 In the Agilent Connection Expert application, choose File > Exit from the 
menu to exit the application.
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Installing the FlexRay Physical Layer Conformance Test Application 
software

You must install the FlexRay Physical Layer Conformance Test Application 
on a controller PC that is connected to the InfiniiVision 3000 X- Series, 
4000 X- Series, 6000 Series, or 7000 Series oscilloscope via LAN or USB.

• “Installing the Software" on page 13

• “Licensing the FlexRay Test Application" on page 13

Installing the Software

Install the FlexRay Test Application software from one of the following 
download web pages:

• "http://www.agilent.com/find/flexray3000" (for 3000 X- Series 
oscilloscopes)

• "http://www.agilent.com/find/flexray4000" (for 4000 X- Series 
oscilloscopes)

• "http://www.agilent.com/find/flexray" (for 6000 Series and 7000 Series 
oscilloscopes)

To install the software:

1 If you have an InfiniiVision 6000 Series or 7000 Series oscilloscope, 
make sure you have version 6.00 or higher of the oscilloscope firmware 
by choosing [Utility] > Service > About Oscilloscope from the front panel.

2 Download the FlexRay Physical Layer Conformance Test Application 
install package from the Agilent web site to your controller PC.

3 Run the install package executable file and follow its instructions.

Be sure to accept the installation of the .NET Framework software; it is 
required in order to run the FlexRay Physical Layer Conformance Test 
Application.

Licensing the FlexRay Test Application

The FlexRay Physical Layer Conformance Test Application software comes 
standard with:

• DSOX3FLEX on 3000 X- Series oscilloscopes.

• DSOX4FLEX on 4000 X- Series oscilloscopes.

• Option FLX (N5432C) on 6000 Series and 7000 Series oscilloscopes, 
which automatically licenses Option FRC. Option FRC in the 
oscilloscope is the only requirement.

http://www.agilent.com/find/flexray3000
http://www.agilent.com/find/flexray4000
http://www.agilent.com/find/flexray
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1 Prerequisites
 

Previous Option FRS (N5432A) customers can order the N5432U 
upgrade to get Option FRC.

Option FRC is an oscilloscope- locked license — this enables any FlexRay 
Physical Layer Conformance Test Application to connect to and use a 
licensed oscilloscope. This type of license permits multiple users to 
share an oscilloscope using a single license.

To install option
licenses

On 3000 X- Series and 4000 X- Series oscilloscopes:

1 Follow the instructions on the Entitlement Certificate you received with 
your FlexRay option purchase.

2 Your license file will be delivered via e- mail.

License files are loaded from a USB storage device using the 
oscilloscope's File Explorer.

On 6000 Series and 7000 Series oscilloscopes:

1 Follow the instructions on the Entitlement Certificate you received with 
your FlexRay option purchase.

You will need the unique identifier for the oscilloscope. You can find 
the Instrument ID by choosing [Utility] > Options > Licenses > Show license 
information from the front panel.

2 Your license will be delivered via e- mail.

The e- mail will contain an alphanumeric code. Enter this code directly 
into your instrument using the oscilloscope's interface (see the 
oscilloscope documentation for instructions on how to install feature 
licenses).
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2 Using the Physical Layer Conformance Test Application
 

Starting the FlexRay Physical Layer Conformance Test Application

1 Start the FlexRay test application:

• On the controller PC's desktop, double- click the FlexRay Test App icon.

• Or, from the controller PC's Windows Start menu, choose All Programs 
> Agilent Scope Applications > FlexRay Test App > FlexRay Test App.

2 In the Connect to Instrument dialog, enter the SICL address of your 
oscilloscope or select it from the list of available instruments.

Oscilloscopes are added to the list of available instruments using the IO 
Libraries Suite's Agilent Connection Expert (see "Adding Your 
Oscilloscope Using Agilent Connection Expert" on page 9).

Click Connect.

3 In the "successful connection" information dialog, click OK.

After a successful connection, the FlexRay Physical Layer Conformance 
Test Application window appears.
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The task flow pane, and the tabs in the main pane, show the steps you 
take when running the automated tests:

See Also • "To view/minimize the task flow pane" on page 18

• "To view/hide the toolbar" on page 18

Next • "Creating or Opening a Test Project" on page 19

Set Up Lets you identify the test environment, including information about the 
device and differential signal being tested.

Select Tests Lets you select the tests you want to run. The tests are organized 
hierarchically so you can select all tests in a group. After tests are run, 
status indicators show which tests have passed, failed, or not been run, 
and there are indicators for the test groups.

Configure Lets you configure test parameters (like oscilloscope channel).

Connect Shows you how to connect the oscilloscope to the device under test for 
the tests that are to be run.

Run Tests Starts the automated tests.

Results Contains more detailed information about the tests that have been run. 
You can change the thresholds at which marginal or critical warnings 
appear.

Html Report Shows a test report that can be printed.
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2 Using the Physical Layer Conformance Test Application
 

To view/minimize the task flow pane

• To toggle between a minimized and restored task flow pane, choose 
View > Task Flow from the menu.

• To minimize the task flow pane, click the minimize button in the pane.

• To restore a minimized task flow pane, click the Task Flow button in the 
pane.

To view/hide the toolbar

• To toggle between a hidden and visible toolbar, choose View > Toolbar 
from the menu.
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Creating or Opening a Test Project

To create a new test project:

1 Choose File > New Project... from the menu.

A new, empty project, with all the default settings is created.

To open an existing test project:

1 Choose File > Open Project... from the menu.

2 In the Open dialog, browse to a test project directory and select the 
desired ".proj" file.

3 Click Open.

See Also • "To set load preferences" on page 19

Next • "Setting Up the Test Environment" on page 20

To set load preferences

1 From the FlexRay test application's menu, choose View > Preferences....

2 In the Preferences dialog, select the Save/Load tab.

3 In the Save/Load tab, you can choose to restore saved test selections 
when loading a project.

4 Click Apply to save the changes and click OK to close the Preferences 
dialog.
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2 Using the Physical Layer Conformance Test Application
 

Setting Up the Test Environment

1 Click the Set Up tab, or click Set Up in the Task Flow pane.

2 Select the Test Plane, that is, the location of the signal under test:

• Receiver Input — The location of the signals under test are at or near 
the receiver input.

• Transmitter Output — The location of the signals under test are at or 
near the transmitter output.

Test limits differ depending on the test plane location.

3 Select the Input/Output Device-under-test, that is the bus network of the 
device under test:

• Bus Driver (BD) — The BD is a mandatory FlexRay component. It 
represents the physical interface between the Communication 
Controller (CC) and the wiring harness. Mainly it converts the data 
stream and supports the node with a power mode controlling.
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• Active Star (AS) — An AS is an active element which passes bus signals 
from one input port to several output ports automatically. A passive 
net is plugged to each port usually. An AS refreshes the bus signal 
slopes and levels; an AS does not refresh the bit- timing. An AS may 
be implemented in a monolithic way or a non- monolithic way. 
Optionally, an AS may have a Communication Controller (CC) and a 
host included.

4 Select the Transmitter Signal Source (if testing at a transmitter output test 
plane):

• Signal Generator Clock gated by T-ENABLE — Select this, for example, when 
an output device's (bus driver or active star) inputs are driven with 
an external source, such as an Agilent 81150A arbitrary waveform 
generator.

• FlexRay Communication Controller generated traffic — Select this when the 
transmitter signal is generated by a FlexRay communication 
controller, in other words, when testing "live" FlexRay traffic.

5 Select the Transmitter Type (if testing at a transmitter output test plane):

• Standard Voltage

• Increased Voltage

6 Select the Baud Rate (bps), that is, the bus speed of the device under test:

• 10 Mb/s — This is the only available selection when using an external 
signal source as the input to a transmitter device (bus driver or 
active star).

• 5 Mb/s

• 2.5 Mb/s

7 Select the Expanded/Debug SI Voting Options:

• On — You can test SI Voting parameters individually by selecting from 
the expanded test parameter selections in the Select Tests tab. This 
is useful if you want to look at an individual test parameter in more 
detail, perhaps using multiple runs.

• Off — SI Voting parameters are all tested together.

8 Enter a Static Frame ID to test.

Note that it is typically only necessary to test one frame ID from each 
transmitting node. The physical layer characteristics of all frames 
generated from an individual transmitting node/ECU should all have 
similar electrical/parametric characteristics because the signals 
produced by that node were all generated by the same FlexRay 
Communication Controller, the same Bus Driver device, and the same 
transmission line network.
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2 Using the Physical Layer Conformance Test Application
 

If testing at a receiver test plane (for example, at Node A), and you 
wish to test received signals from all other nodes in your synchronous 
FlexRay system, begin by testing one specific frame ID that is generated 
by Node B. After the first test run has completed, select the Setup tab 
and enter a different frame ID that is generated by Node C, and run a 
second test/trial. After the second test run/trial is completed, enter a 
third frame ID that is generated by Node D, etc. The final test report 
will include statistics for all frame IDs tested. But, note that you should 
not test any frame IDs generated by Node A because signals generated 
by Node A while testing at the receiver input of Node A would actually 
test transmitted signals — not received signals.

If testing at a transmitter test plane, and you wish to test all nodes in 
your synchronous FlexRay system, begin by testing one specific frame 
ID generated by Node A while probing at the output of Node A. After 
the first test run has completed, move your differential active probe to 
Node B, select a specific frame ID generated by Node B, and then run a 
second test/trial. Continue testing one frame ID from each node while 
probing at the output of that specific node.

9 Enter any comments in the Reports area. These comments are included 
in the test report.

Next • "Selecting Tests" on page 23
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Selecting Tests

1 Click the Select Tests tab, or click Select Tests in the Task Flow pane.

2 Check the tests you want to run.
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2 Using the Physical Layer Conformance Test Application
 

Some things to note:

• Checking a parent node/group will check all available 
sub- groups/tests.

• Unchecking a parent node/group will uncheck all sub- groups/tests.

• A parent node is checked if all subgroups are checked.

• A parent node is unchecked if ANY subgroup is unchecked.

When Tests Have
Already Been Run

The marks have the following meanings:
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See Also • Chapter 3, “About the Tests,” starting on page 53 (for more information 
on specific tests)

Next • "Configuring Tests" on page 26

The test passed.

The test failed.

The test has not been run, or no tests in the group have been run.

The test is currently running.

Some tests in the group have run and passed.

Some tests in the group have run and failed.

Some tests in the group have passed and some have failed; not all of the tests have 
been run.

Some tests in the group have passed and some have failed; all of the tests have run.

All tests in the group have run and passed.

All tests in the group have run and failed.
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Configuring Tests

1 Click the Configure tab, or click Configure in the Task Flow pane.

2 Select the bulleted item for the settings you want to configure; then, 
select or enter your settings.

A description of the selected configuration item appears in the lower, 
right part of the application window.

Note that you can also enter values in some of the drop- down selection 
fields. Entered values are checked for validity.

These are the items you can configure:

TIP A quick way to reset all configuration options and delete all test results is to create a new 
project (see page 19). The new project will have default configuration options.

Scope Input Channel Select the oscilloscope channel used to capture the FlexRay signal.

Number of 
Waveforms

Select the number of waveforms to test for the eye-diagram mask test.

FlexRay Bus Select to test either FlexRay bus "A" or "B".
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Next • "Connecting the Oscilloscope to the DUT" on page 28

Vertical Scaling Mode Select "auto" mode to allow the software to optimally scale the V/div 
and trigger level for all tests.
However, if the amplitude of the highest amplitude frame is more than 
30% higher than the amplitude of the lowest amplitude frame, the 
software may not be able to optimally scale and trigger on each selected 
frame ID. In this case, you should select the "manual" mode.

Vertical Scaling 
(V/div)

When in the "manual" vertical scaling mode, select or enter the initial 
V/div to a setting that will scale the highest amplitude frame to be 
approximately 75% of screen height.

Trigger Level (V) When in the "manual" vertical scaling mode, select or enter the initial 
trigger level (in Volts) to a setting that is approximately 25% above the 
base level (V-base) of the lowest amplitude frame.
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2 Using the Physical Layer Conformance Test Application
 

Connecting the Oscilloscope to the DUT

1 Click the Connect tab, or click the Connect box in the Task Flow pane.

2 Follow the displayed instructions for connecting the oscilloscope to the 
device under test.

3 Note that it is important that the "+" input of your differential probe be 
connected to BP (Bus Plus), and the "- " input of differential probe be 
connected to BM (Bus Minus). If the polarity of your differential probe 
is connected correctly, the first pulse of each frame (TSS event) will be 
a negative going pulse. If the first pulse of each frame is a positive 
going pulse, then you probably have the polarity of your differential 
probe connections reversed. You may want to manually or visually 
check the polarity of your probe connections before running an 
automated test.

4 When connections to the device under test have been made, check the I 
have completed these instructions box.

See Also • "Differential Input Signal Requirements and Troubleshooting Tips" on 
page 29

Next • "Running Tests" on page 31
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Differential Input Signal Requirements and Troubleshooting Tips

• If the differential input signal under test (uBus) is < 500 mVp- p or > 
8 Vp- p, none of the selected tests will run, and the software will 
report, "Volts peak to peak too low/high, failed to find trigger!".

• The FlexRay App does NOT test to see if the polarities of differential 
probe's connections are correct.

If you select to run any tests with the probe connected incorrectly, the 
oscilloscope will not be able to trigger on the specified Frame ID, and 
the software will report "frame not found" for most tests.

Before running any tests, ensure that your probe is connected correctly 
by following the instructions in "Connecting the Oscilloscope to the 
DUT" on page 28.

• If the differential input signal is less than 800 mVp- p, the Eye- diagram 
Mask tests will not execute, but will report "Signal level limitation for 
Eye Diagram Test Group… expected measured Vpp to be >0.8 Vpp".

• If the highest amplitude frame is more than approximately 30% higher 
than the lowest amplitude frame, you must select the "Manual" vertical 
scaling mode in the Configure tab. Refer to the instructions in 
"Configuring Tests" on page 26 to manually select the appropriate V/div 
setting and trigger level.

• If the differential input signal Vmax < 300 mV, or if Vmin > - 300 mV, 
the Transition Time Tests (Rise Time and Fall Time) when testing at a 
receiver input test plane will not run because the measurement 
threshold levels for these measurements are +/-  300 mV.

• If you specify a static frame ID (see "Setting Up the Test Environment" 
on page 20) that does not exist in your synchronous FlexRay system, 
the oscilloscope will be unable to trigger on the specified frame ID, 
most selected tests will not run, and the software will report "frame not 
found".

• If you specify a dynamic frame ID in the static frame ID entry box (see 
"Setting Up the Test Environment" on page 20), some tests such as 
Transition Time tests and Isolated "1" and Isolated "0" tests, will not 
run unless the specified dynamic frame ID occurs during all 64 cycles. 
If the dynamic frame ID does not occur in all 64 cycles, the software 
will report, "frame not found". All other tests will run as long as the 
specified dynamic frame ID occurs at least once per 64 cycles.

• If you specify an incorrect baud rate (see "Setting Up the Test 
Environment" on page 20), the Eye- diagram test (all frames) will run, 
but will provide erroneous measurement results. In addition, all other 
tests will NOT run and the software will report "frame not found".
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• If the differential signal- to- noise ratio (relative to peak- to- peak signal 
and peak- to- peak noise) does not exceed 3.0, the selected tests may 
run, but the measurement results may be incorrect due to erroneous 
signal crossings through measurement threshold levels and trigger 
levels.
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Running Tests

The Run Tests tab's settings let you run the selected tests once or multiple 
times. When you run tests multiple times, there are options for selecting 
which trials are stored and how long tests are run.

To run the selected tests once:

1 Start the test run.

There are several ways to run selected tests:

• Click Run Tests in the Task Flow pane.

• Click  in the toolbar.

• Select a branch in the Select Tests tab; then, click  in the toolbar.

• Select the Run Tests tab, make sure the Once "run until" option is 
selected, and click the big Run button.

NOTE You should allow the oscilloscope to warm-up at least 30 minutes before running any 
measurement tests.

TIP It is a good idea to calibrate the oscilloscope at least once a year or when the Calibration 
ΔTemp is greater than ±5 °C. The Calibration ΔTemp is found using the oscilloscope's front 
panel, by pressing the [Utility] key followed by the Service and User Cal Status softkeys.
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For more information on additional run options, see:

• "To select the "store mode"" on page 34

• "To run multiple times" on page 34

• "To send email on pauses or stops" on page 35

• "To pause or stop on events" on page 36

• "To specify the event" on page 37

2 If there are existing test results, you are asked if you would like to keep 
them or re- test (delete) them.

If you would like to keep the existing test results to compare against 
new results, select Append New "Trial" Results.

Select Replace the Existing Results if you would like to delete the existing 
test results.
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3 While the tests are running, status dialogs appear to inform you about 
the test progress.

4 When the tests are complete, click OK.

See Also • "Differential Input Signal Requirements and Troubleshooting Tips" on 
page 29

• "To set the display preferences" on page 37

• "To set the run preferences" on page 39

Next • "Viewing Results" on page 40
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To select the "store mode"

When running tests multiple times, you can select which trials are stored.

1 Select the Run Tests tab.

2 In the Store Mode area, select:

• Best — stores the results of the best N trials.

• Event — stores the results of N trials in which the event is detected. 
The event is determined in the Event area. See "To specify the event" 
on page 37.

• Last — stores the results of the last N trials.

• Worst — stores the results of the worst N trials.

Up to 25 trials can be stored.

If you change the Store Mode when test results exist, the existing results 
will be deleted.

The Store Mode selection affects the trial display options in the Report tab 
of the Preference dialog. See "To set trial display preferences" on page 42.

To run multiple times

The "run until" option lets you specify whether tests are run once or 
multiple times.

1 Select the Run Tests tab.

2 In the Run Until area, select:

• Forever — runs the tests repeatedly until you click the Cancel button.
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• N Times — runs the tests N times. When this option is selected, you 
can specify the number of runs and whether pauses occur between 
each run.

• Once — runs the tests only once. This is the default setting.

When multiple runs are selected, you can use the trial display options in 
the Report tab of the Preference dialog to specify how many trials are 
displayed in the test report. See "To set trial display preferences" on 
page 42.

To send email on pauses or stops

You can configure the test application to send email whenever a run 
pauses or ends.

1 Select the Run Tests tab.

2 In the Run Until area, check Send email.

3 Click Configure.

4 In the Configure Email dialog, enter your To and From email addresses 
and the hostname of the SMTP Server.

5 Click OK.
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Pauses can occur between runs when running a specific number of times 
(see "To run multiple times" on page 34) or when pausing on an event (see 
"To pause or stop on events" on page 36).

To pause or stop on events

You can set up test runs to pause or stop on events which are checked at 
the end of each test..

1 Select the Run Tests tab.

2 In the Run Until area, check On event.

3 In the drop- down selection field that appears, select either:

• Pause — causes the run to pause when the event is detected.

• Stop — cause the run to stop when the event is detected.

4 In the Event area, specify the type of event. See "To specify the event" 
on page 37.

Pauses or stops can be set up to automatically send email (see "To send 
email on pauses or stops" on page 35).
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To specify the event

In the Store Mode area when you have selected Event (see "To select the 
"store mode"" on page 34) or in the Run Until area when you have selected 
to pause or stop on an event (see "To pause or stop on events" on 
page 36), the Event area appears so that you can specify the event.

1 In the Event area, select the type of event:

• Fail — causes the event to fire when a prerequisite test or selected 
test fails..

• Margin < N — causes the event to fire when a test generates a 
margin < specified. When this option is selected, enter the minimum 
required margin percentage.

• Pass — causes the event to fire when a test passes (excluding 
prerequisite tests).

A tilde "~" character in the event selection drop- down shows that the 
event is unavailable. If you select an event type that is not available, a 
dialog tells you why.

To set the display preferences

Information, warning, and error conditions can occur while running tests. 
The display preferences let you choose whether message dialogs are 
shown. And, there are other display preferences that affect what happens 
as tests are run.

1 From the FlexRay test application's menu, choose View > Preferences....

2 In the Preferences dialog, select the Display tab.
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3 In the Display tab, you can choose to show the following types of 
message dialogs:

• Information dialogs.

• Warning dialogs.

• Error dialogs.

4 Also, you can choose to:

• Invert scope display — (white background) when the application 
captures the screen shots.

• Keep application on top — Always keep the application's main dialog on 
the top of other windows. Note that the mid- run dialogs are always 
displayed on the top.

• Log events — Use this option only when directed to by Agilent Support 
(Note that this option degrades the runtime performance).

• Show tooltips — By enabling this option, the tooltips appear as you 
move the pointer over various controls in the application.

5 Click Apply to save the changes and click OK to close the Preferences 
dialog.

NOTE Messages that require you to make a choice, such as "OK/Cancel" and "Yes/No" are 
always enabled.
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To set the run preferences

Information, warning, and error conditions can occur while running tests. 
The display preferences let you choose whether message dialogs are 
shown. And, there are other display preferences that affect what happens 
as tests are run.

1 From the FlexRay Physical Layer Conformance Test Application's menu, 
choose View > Preferences....

2 In the Preferences dialog, select the Run tab.

3 In the Run tab, choose if/when you would like beeps to occur during 
test runs:

• Beep when user prompted —  causes the controller PC to beep when 
there is a prompt for user input.

• Beep only during run — specifies that beeps only occur during runs.

4 Select the Test Abort Action.

You can choose to continue the run or stop the run.

5 Click Apply to save the changes and click OK to close the Preferences 
dialog.
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Viewing Results

1 Click  in the toolbar, or click the Results tab.

The Results tab contains three resizable panes for test results 
information. If you select one of the tests in the top pane, details and 
reference images (if any) are shown in the lower panes.

See Also • "To show reference images" on page 41

• "To change margin thresholds" on page 41

• "To set trial display preferences" on page 42

Next • "Viewing/Exporting/Printing the Report" on page 44

TIP A quick way to reset all configuration options and delete all test results is to create a new 
project (see page 19). The new project will have default configuration options.
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To show reference images

1 In the Results tab, click on an image in the Reference Images pane.

This opens the reference image dialog.

In the reference image dialog, you can:

• Click the  zoom in or  zoom out buttons to resize the dialog.

2 Click the  close button to close the # Mask Failures dialog.

To change margin thresholds

1 From the FlexRay Physical Layer Conformance Test Application's menu, 
choose View > Preferences....

Or, when viewing the Results tab, click  in the toolbar.
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2 In the Preferences dialog, select the Report tab.

3 In the Margin Reporting area, you can:

• Enable or disable margin highlighting.

• You can change the percent of margin at which to give warnings or 
critical failures.

4 Click OK to close the Preferences dialog.

To set trial display preferences

1 From the FlexRay Physical Layer Conformance Test Application's menu, 
choose View > Preferences....

Or, when viewing the Results tab, click  in the toolbar.

2 In the Preferences dialog, select the Report tab.
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3 In the Trial display area, you can:

• Select the maximum number of trials, up to 25, whose details are 
displayed at one time.

• Order trial details chronologically or by "best", "worst", or "last" trial 
first.

• Specify whether screens captured during the run are displayed in the 
Results tab.

Note that the "worst", "best", or "last" trials depends on the "store mode" 
setting in the Run Tests tab. See "To select the "store mode"" on 
page 34.

4 Click Apply to save the changes and click OK to close the Preferences 
dialog.

NOTE These settings only affect the viewing of results and not their capture. Therefore, a change 
can be made to either before or after running the tests.
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Viewing/Exporting/Printing the Report

• To view the HTML test report, click the Html Report tab.

See Also • "To export the report" on page 44

• "To print the report" on page 46

Next • "Saving Test Projects" on page 47

To export the report

1 From the FlexRay test application's menu, choose File > Export Results > 
from the menu.

There are two options for exporting the HTML test report: CSV or 
HTML.

To export results
in CSV

(comma-separate
d values) format

Select the CSV option to export the results as a comma- separated list of 
values.
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The data format is shown in the first line of the exported *.csv file.

To export the
report in HTML

format

There are two options for exporting HTML format test reports:
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• Single-File — To save a single- file report, use the "save as" type "Web 
Archive, single file (.mht)".

• Multi-File — If your report is large and you would like to use links 
within the report, select the HTML > Multi-File option. Selecting the 
multi- file option exports the results as a set of separate image and 
HTML files. It creates a folder with the specified name that may be 
copied to any computer.

To view the exported report, open the HTML file stored in the folder.

To print the report

• To preview the HTML test report printout, click  or choose File > Print 
Preview... from the menu.

• To print the HTML test report, click  or choose File > Print... from the 
menu.

NOTE Single-file reports will not contain hyperlinks in the summary table (due to a .mht format 
limitation). If you want these hyperlinks, use the multi-file format.
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Saving Test Projects

To save test settings and results to the current project directory:

1 Choose File > Save Project from the menu.

To save test settings and results to a new project directory:

1 Choose File > Save Project As... from the menu.

2 In the Save Project As... dialog, enter the device name and location.

Project files will be saved in a directory whose name is the device 
name.

3 Click OK.

See Also • "To set AutoRecovery preferences" on page 47

To set AutoRecovery preferences

1 From the FlexRay test application's menu, choose View > Preferences....

2 In the Preferences dialog, select the Save/Load tab.
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3 In the AutoRecovery area, you can choose:

• To auto- save results after each trial or permutation even if the entire 
multi- trial is not completed. This option enables full recovery.

• To auto- save results only upon the completion of the entire 
multi- trial.

4 Click Apply to save the changes and click OK to close the Preferences 
dialog.
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Controlling the Application via a Remote PC

The FlexRay test application's Preference dialog has a Remote tab for 
enabling the remote interface and setting remote options.

The remote interface lets you control test applications from a remote PC. 
It comes with ready to run executables, but it also lets you create custom 
programs using a .NET 2.0 programming language or the National 
Instruments' LabVIEW 8.5 graphical programming environment.

With the remote interface, you can:

• Launch and close applications.

• Configure options.

• Run tests.

• Obtain results.

• Control when and where dialogs are displayed.

• Save and load projects.

For more information on the remote interface, see the "N5452A Remote 
Interface for Infiniium Compliance Applications" on the Agilent web site.

See Also • "To identify the remote interface version" on page 49

• "To enable the remote interface" on page 50

• "To enable remote interface hints" on page 50

To identify the remote interface version

1 From the FlexRay test application's menu, choose Help > About....

2 In the About dialog, the remote interface version is listed above other 
version information.

http://www.home.agilent.com/agilent/redirector.jspx?action=ref&cname=PRODUCT&ckey=1439856&cc=US&lc=eng
http://www.home.agilent.com/agilent/redirector.jspx?action=ref&cname=PRODUCT&ckey=1439856&cc=US&lc=eng
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To enable the remote interface

1 From the FlexRay test application's menu, choose View > Preferences....

2 In the Preferences dialog, select the Remote tab.

3 Check the Enable remote interface option if you need to access the 
application remotely.

If you are performing the tests with the application's user interface and 
want to ensure no remote users accidentally interfere with you, disable 
the remote interface by un- checking this option.

4 Click Apply to save the changes and click OK to close the Preferences 
dialog.

To enable remote interface hints

1 From the FlexRay test application's menu, choose View > Preferences....

2 In the Preferences dialog, select the Remote tab.
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3 In the remote options area, check Show remote interface hints.

When this option is checked:

• You can select the remote programming language described in the 
tips.

• Tooltips related to the remote interface commands appear when you 
click the toolbar.

• Various controls in the tabs will have a context menu item added as 
"Remote interface hint…".

• The Select Tests and Configure tabs will display a remote hint in their 
description panes at the bottom of the screen, when an item is 
selected.

4 Click Apply to save the changes and click OK to close the Preferences 
dialog.
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Eye Diagram Measurement Tests

• "Eye Diagram Measurement (all frames)" on page 54

• "Eye Diagram Measurement (specified frame only)" on page 63

Eye Diagram Measurement (all frames)

• "Eye- diagram Measurement at the Transmitter Output Test Plane" on 
page 54

• "Eye- diagram Measurement at the Receiver Input Test Plane" on page 60

Eye-diagram Measurement at the Transmitter Output Test Plane

References:

Figure 1 Standard TP1 Mask (Figure 7-3 from FlexRay EPL Specification)
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Figure 2 TP1 mask for functional class "Bus driver increased voltage amplitude 
transmitter" (Figure 7-4 from FlexRay EPL Specification)
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Figure 3 Standard TP11 Mask (Figure 7-5 from FlexRay EPL Specification)
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Figure 4 TP11 mask for functional class "Active star increased voltage amplitude 
transmitter" (Figure 7-6 from FlexRay EPL Specification)
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Overview:

Eye- diagram mask testing at the transmitter output test plane (TP1 or 
TP11) is primarily intended to test the output characteristics of 
standard- voltage or increased- voltage Bus Driver (BD) or Active Star (AS) 
devices.

According to the FlexRay EPL Specification document, the differential 
output characteristics of these devices should be tested using a 
pulse/pattern generator as a source that drives the single- ended input 
(TxD) of the device under test. The generator should be setup to output a 
continuous 1- 0- 1- 0… serial pattern at 10 Mbs (5 MHz square wave) with a 
near- perfect 100 ns bit time and gated by TxEn- low. The device under test 
(bus driver or active star) should be terminated with a 40Ω resistor in 
parallel with a 100 pF capacitor across BP (bus plus output) and BM (bus 
minus output). The oscilloscope's differential probe should be connected to 
BP and BM as close as possible to the output of the device under test.

One of four different specified mask templates is automatically applied to 
the transmitter eye- diagram test based on the following user- selections in 
the Setup menu:

Figure 5 TP1 FlexRay Mask
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Note that these masks are defined in section 7.2 of the 
FlexRay_EPL- Specification_V2.1_Rev_E document.

The transmitter eye- diagram mask tests are based on the oscilloscope 
using its pulse- wide triggering mode to trigger on alternate rising and 
falling edges of the output differential signal. This test runs for a default 
10,000 captured bits, but the number of captured bits may be modified in 
the Configuration menu.

Note that 5 Mbs and 2.5 Mbs transmitter output eye- diagram masks do 
not exist for testing the output characteristics of bus drivers and active 
stars at these baud rates. Even if these devices will be used in 5 Mbs or 
2.5 Mbs FlexRay systems, they should be tested to the 10 Mbs standard.

Although the transmitter eye- diagram mask test is intended for testing 
output devices using a signal/pattern generator as the device input source, 
this test can also be used to test actual 10 Mbs FlexRay output traffic 
generated by a FlexRay Communication Controller within "closed" ECU 
systems. In this case, you would select "FlexRay Communication Controller 
generated traffic" as the "Transmitter Signal Source" in the Setup menu. 
However, it is critical that the network under test be carefully controlled 
and the test results should be carefully interpreted. And you need to be 
aware that this test is not in accordance with the recommended test 
procedure outlined in the FlexRay EPL Specification document. When 
performing this measurement with random FlexRay Communication 

Standard TP1 Mask 
applied if:

Test Plane: Transmitter Output
Output Device-under-test: Bus Driver (BD)
Transmitter Signal Source: Signal Generator gated by T-ENABLE
Transmitter Type: Standard Voltage

TP1 mask for 
functional class "Bus 
driver increased 
voltage amplitude 
transmitter" applied 
if:

Test Plane: Transmitter Output
Output Device-under-test: Bus Driver (BD)
Transmitter Signal Source: Signal Generator gated by T-ENABLE
Transmitter Type: Increased Voltage

Standard TP11 Mask 
applied if:

Test Plane: Transmitter Output
Output Device-under-test: Active Star (AS)
Transmitter Signal Source: Signal Generator gated by T-ENABLE
Transmitter Type: Standard Voltage

TP11 mask for 
functional class 
"Active star increased 
voltage amplitude 
transmitter" applied 
if:

Test Plane: Transmitter Output
Output Device-under-test: Active Star (AS)
Transmitter Signal Source: Signal Generator gated by T-ENABLE
Transmitter Type: Increased Voltage
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Controller generated frames, test results are for information purposes only 
and should NOT be considered a physical layer conformance or compliance 
test.

If you use this transmitter eye- diagram mask test to test the output 
characteristics of a particular node within a synchronous system (FlexRay 
Communication Controller generated traffic), such as a single ECU along a 
second "buddy" node, first of all make sure that the length of the 
transmission line network is minimized and is tightly controlled. Secondly, 
be aware that the results of a transmitter eye- diagram mask test on this 
type of 2- node system will actually consist of both transmitted and 
received signals (signals generated from the "buddy" node). If the test 
passes when testing signals generated by both nodes, then you can be 
confident that the output characteristics of the particular transmitting 
node that is under test meets required output device specifications. But if 
the test fails, then this could be due to testing the "received" signals from 
the "buddy" node. There is no way to isolate TP1 and TP11 eye- diagram 
testing on particular frame IDs as there is with TP4 eye- diagram mask 
testing (receiver input testing).

You should be cautioned against testing an actual in- car multi- node 
system consisting of a long and complex transmission line network (or a 
simulated in- car network) using an eye- diagram test at a transmitter 
output test plane.

Eye-diagram Measurement at the Receiver Input Test Plane

References:

Figure 6 Eye-diagram for 10 Mbit/s (Figure 2-15 from FlexRay EPL Application Notes)
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Figure 7 Eye-diagram for 5 Mbit/s (Figure 2-16 from FlexRay EPL Application Notes)

Figure 8 Eye-diagram for 2.5 Mbit/s (Figure 2-17 from FlexRay EPL Application Notes)
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Overview:

The receiver input eye- diagram mask test is the most common type of 
eye- diagram mask test used to evaluate the overall quality of received 
FlexRay signals in your synchronous multi- node FlexRay system. One of 
three different specified TP4 mask templates is automatically applied to 
the receiver eye- diagram test based on the specific baud rate of your 
system, which is specified in the Setup menu.

Note that these masks are defined in section 2.20 of the 
FlexRay_EPL- Application Notes_V2.1_Rev_E document.

The Agilent InfiniiVision Series oscilloscope utilizes a unique repetitive 
hardware clock recovery technique to capture and overlay each bit of 
every byte based on triggering on Byte Start Sequence (BSS) events. This 
is the same reference signal that FlexRay receivers use to re- synchronize 
and recover clocks for sampling received data. This test runs for a default 
10,000 captured bits, but the number of captured bits may be modified in 
the Configuration menu.

If you select to perform a test on "all frames" in the Select Tests menu, 
then the oscilloscope will capture and compare bits from all frames in the 
system. But if you select to perform a test on "specified frames only" in 
the Select Tests menu, then the oscilloscope will capture and compare bits 
from just the frame ID that was entered in the Setup menu.

Figure 9 TP4 FlexRay Mask
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Eye Diagram Measurement (specified frame only)

The eye diagram measurement for the specified frame only (when testing 
at a receiver input test plane) is the same as the test for all frames, except 
that it only looks at the fame ID entered on the application's Set Up page.
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Signal Integrity Voting Procedure Tests

• "Isolated One" on page 64

• "Isolated Zero" on page 66

Isolated One

References:
Table 1 Signal voting – parameter list (Table 2-19 from FlexRay EPL Application Notes)

IN uBusTPx Filtered differential voltage

dBitShort Shortest detectable duration of one bit

dBitLong Longest detectable duration of one bit

dEdgeMax Duration of the slowest edge

OUT Sq Voted signal quality

PARAMETER dBitLengthVariationMax Allowed maximal length variation 7 ns

dBitMin Required minimum duration of the shortest bit 
at TP4_BDi:
• 70.95 ns @ 10 Mbit/s (*)
• 134.40 ns @ 5.0 Mbit/s (**)
• 261.30 ns @ 2.5 Mbit/s (***)

uData0Top Required level (top): -330 mV

uData1Top Required level (top): 330 mV

dIdleDetectionMin Minimal timeout to detect Idle: 50 ns

(*) (100 ns – 36.6 ns) + 7.55 ns for the path from TP5 to TP4_BDi according to figure 6-4 and table 
6-6 in the FlexRay EPL Specification (@ 10 Mbit/s for one single bit)
(**) (200 ns – 73.2 ns) + 7.60 ns for the path from TP5 to TP4_BDi according to figure 6-4 in the 
FlexRay EPL Specification (@ 5 Mbit/s for one single bit)
(***) (400 ns – 146.4 ns) + 7.70 ns for the path from TP5 to TP4_BDi according to figure 6-4 in the 
FlexRay EPL Specification (@ 2.5 Mbit/s for one single bit)
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Overview:

Table 2 Signal voting procedure – calculation method (Table 2-19 from FlexRay EPL 
Application Notes)

BEHAVIOR IF dBitLengthVariation <= 
dBitLengthVariationMax
AND uBusTPx >= uData1Top
AND dBitShort >= dBitMin
AND dEdgeMax <= 
dIdleDetectionMin
THEN Sq = "pass"
ELSE Sq = "fail"

IF dBitLengthVariation <= 
dBitLengthVariationMax
AND uBusTPx <= uData0Top
AND dBitShort >= dBitMin
AND dEdgeMax <= 
dIdleDetectionMin
THEN Sq = "pass"
ELSE Sq = "fail"

The result is coded in the value Sq:
• pass — the differential signal meets the minimal signal shape requirements (level and delay)
• fail — the differential signal does not meet the minimal signal shape requirements (level or 

delay)

Figure 10 Capturing and low-pass filtering an isolated "one"
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The purpose of this test is to verify that the DUT signal meets the minimal 
shape requirement.

The Signal Integrity Voting is a procedure given by the BD properties and 
its robustness against disturbances. The procedure detects whether a 
FlexRay topology is a operable or not in principle. This is a mathematical 
calculation procedure based on a variety of measurements performed on a 
low- pass filtered isolated "1" pulse.

Condition to Pass the test:

• The differential voltage level has to be high enough.

• The shortest detectable duration of one bit has to be long enough.

• The asymmetry of the measured bit has to be less than the limit.

• The edge speed of the measured bit has to be fast enough.

• Idle detection during the frame has to be avoided.

Isolated Zero

References:

Figure 11 Isolated "one" result details

Table 3 Signal voting – parameter list (Table 2-19 from FlexRay EPL Application Notes)

IN uBusTPx Filtered differential voltage

dBitShort Shortest detectable duration of one bit

dBitLong Longest detectable duration of one bit

dEdgeMax Duration of the slowest edge

OUT Sq Voted signal quality
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PARAMETER dBitLengthVariationMax Allowed maximal length variation 7 ns

dBitMin Required minimum duration of the shortest bit 
at TP4_BDi:
• 70.95 ns @ 10 Mbit/s (*)
• 134.40 ns @ 5.0 Mbit/s (**)
• 261.30 ns @ 2.5 Mbit/s (***)

uData0Top Required level (top): -330 mV

uData1Top Required level (top): 330 mV

dIdleDetectionMin Minimal timeout to detect Idle: 50 ns

(*) (100 ns – 36.6 ns) + 7.55 ns for the path from TP5 to TP4_BDi according to figure 6-4 and table 
6-6 in the FlexRay EPL Specification (@ 10 Mbit/s for one single bit)
(**) (200 ns – 73.2 ns) + 7.60 ns for the path from TP5 to TP4_BDi according to figure 6-4 in the 
FlexRay EPL Specification (@ 5 Mbit/s for one single bit)
(***) (400 ns – 146.4 ns) + 7.70 ns for the path from TP5 to TP4_BDi according to figure 6-4 in the 
FlexRay EPL Specification (@ 2.5 Mbit/s for one single bit)

Table 4 Signal voting procedure – calculation method (Table 2-19 from FlexRay EPL 
Application Notes)

BEHAVIOR IF dBitLengthVariation <= 
dBitLengthVariationMax
AND uBusTPx >= uData1Top
AND dBitShort >= dBitMin
AND dEdgeMax <= 
dIdleDetectionMin
THEN Sq = "pass"
ELSE Sq = "fail"

IF dBitLengthVariation <= 
dBitLengthVariationMax
AND uBusTPx <= uData0Top
AND dBitShort >= dBitMin
AND dEdgeMax <= 
dIdleDetectionMin
THEN Sq = "pass"
ELSE Sq = "fail"

The result is coded in the value Sq:
• pass — the differential signal meets the minimal signal shape requirements (level and delay)
• fail — the differential signal does not meet the minimal signal shape requirements (level or 

delay)

Table 3 Signal voting – parameter list (Table 2-19 from FlexRay EPL Application Notes) 
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Overview:

Figure 12 Capturing and low-pass filtering an isolated "zero"

Figure 13 Isolated "zero" result details
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The purpose of this test is to verify that the DUT signal meets the minimal 
shape requirement.

The Signal Integrity Voting is a procedure given by the BD properties and 
its robustness against disturbances. The procedure detects whether a 
FlexRay topology is a operable or not in principle. This is a mathematical 
calculation procedure based on a variety of measurements performed on a 
low- pass filtered isolated "0" pulse.

Condition to Pass the test:

• The differential voltage level has to be high enough.

• The shortest detectable duration of one bit has to be long enough.

• The asymmetry of the measured but has to be less than the limit.

• The edge speed of the measured bit has to be fast enough.

• Idle detection during the frame has to be avoided.
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TSS Width Measurement Test

The TSS- width (gdTSSTransmitter) test measures the width of the 
Transmission Start Sequence (TSS) low pulse of the specified frame at a 
receiver or transmitter test plane. Approximately 100 measurements are 
performed to provide statistical results, which are included in the screen 
image within the test report. However, just the "mean" measured results 
are compared against the specified test limits of:

• 10 Mbs: 1gdBit (90 ns) ≤ gdTSSTransmitter ≤ 15gdBit (1.51 µs).

• 5 Mbs: 1gdBit (180 ns) ≤ gdTSSTransmitter ≤ 8gdBit (1.62 µs).

• 2.5 Mbs: 1gdBit (360 ns) ≤ gdTSSTransmitter ≤ 5gdBit (2.04 µs).

These test limits are based on absolute maximum and minimum possible 
TSS widths, and also include oscilloscope measurement resolution margin 
of +/-  10 ns (10 Mbs), +/-  20 ns (5 Mbs), or +/-  40 ns (2.5 Mbs).

Figure 14 Measuring "–width" of TSS pulse.
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Mean Corrected Cycle Time Test

The Mean Corrected Cycle Time measures and computes the mean cycle 
time of the synchronous FlexRay system under test utilizing the 
oscilloscope's Segmented Memory acquisition mode to capture 1001 
consecutive cycles of the specified frame ID. The test application then 
computes the average cycle time by dividing the segmented time- tag of the 
1001st captured frame by 1000. Measured results are provided for 
"information only", and are NOT compared against any specified test limits.

Figure 15 Cycle time test using Segmented Memory acquisition.
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Amplitude Measurement Tests

The purpose of the amplitude measurement tests is to verify that the 
Amplitude (Data1, Data0, and Idle level) of the device under test (DUT) is 
within the conformance limits specified in FlexRay EPL Specification, 
Figure 2.1.1 and Figure 2.1.2.

• "Data 1 Amplitude Measurement" on page 72

• "Data 0 Amplitude Measurement" on page 73

• "Idle Level Measurement" on page 74

Data 1 Amplitude Measurement

The Data1 Amplitude (uBusRx- Data and uBDTx- active) test measures the 
maximal steady- state level (Vtop) of the differential Data1 (active high) 
signal of the specified frame at a receiver input (uBusRx- Data) or 
transmitter output (uBDTx- active) test plane. Approximately 100 
measurements are performed to provide statistical results, which are 
included in the screen image within the test report. However, just the 
"mean" measured results are compared against the specified test limits of:

Figure 16 Measuring Data1 and Data0
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• Data1 received @ receiver input test plane: 400 mV ≤ uBusRx- Data ≤ 
3.0 V.

• Data 1 transmitted @ transmitter output test plane: 600 mV ≤ 
uBDTx- active ≤ 2.0 V.

Data 0 Amplitude Measurement

The Data0 Amplitude (- uBusRx- Data and - uBDTx- active) test measures 
the minimal steady- state level (Vbase) of the differential Data0 (active low) 
signal of the specified frame at a receiver input (- uBusRx- Data) or 
transmitter output (- uBDTx- active) test plane. Approximately 100 
measurements are performed to provide statistical results, which are 
included in the screen image within the test report. However, just the 
"mean" measured results are compared against the specified test limits of:

• Data0 received @ receiver input test plane: - 3.0 V ≤ - uBusRx- Data ≤ 
- 400 mV.

• Data0 transmitted @ transmitter output test plane: - 2.0 V ≤ 
- uBDTx- active ≤ - 600 mV.

Figure 17 Measuring Data1 and Data0
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Idle Level Measurement

The Idle Level (uRx- Idle and uBDTx- Idle) test measures the average DC 
voltage level of the idle level signal just prior to the TSS event of the 
specified frame at a receiver input (uRx- Idle) or transmitter output 
(uBDTx- Idle) test plane. Approximately 100 measurements are performed 
to provide statistical results, which are included in the screen image 
within the test report. These statistics can be used to determine the level 
of noise on the idle level signal including Vmax, Vmin, and Standard 
Deviation (RMS noise). However, just the "mean" of average DC measured 
results are compared against the specified test limits of:

• Average DC level of idle signal @ receiver input test plane: - 30 mV ≤ 
uRx- Idle ≤ +30 mV.

• Average DC level of idle signal @ transmitter output test plane: -  30 mV 
≤ uBDTx- Idle ≤ +30 mV.

Figure 18 Measuring Idle Level
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Transition Time Measurement Tests

• "Rise Time – Data0 to Data1" on page 75

• "Fall Time – Data1 to Data0" on page 76

Rise Time – Data0 to Data1

The Rise Time – Data0 to Data1 (dBusRx01 and dBusTx01) test measures 
the rising edge transition time of signals within the specified frame at a 
receiver input test plane (dBusRx01) based on - 300 mV to +300 mV 
measurement threshold levels, or measures the rising edge transition time 
of signals within the specified frame at a transmitter test plane 
(dBusTx01) based on 20% to 80% measurement threshold levels. 
Approximately 100 measurements are performed to provide statistical 
results, which are included in the screen image within the test report. 
However, just the "mean" measured results are compared against the 
specified test limits of:

• Rise time of received signals @ receiver input test plane: dBusRx01 ≤ 
22.50 ns.

Figure 19 Rise time measurement on Data0 to Data1 Transition
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• Rise time of transmitted signals @ transmitter output test plane: 6.0 ns 
≤ dBusTx01 ≤ 18.75 ns.

Fall Time – Data1 to Data0

The Fall Time – Data1 to Data0 (dBusRx10 and dBusTx10) test measures 
the falling edge transition time of signals within the specified frame at a 
receiver input test plane (dBusRx10) based on +300 mV to - 300 mV 
measurement threshold levels, or measures the falling edge transition time 
of signals within the specified frame at a transmitter test plane 
(dBusTx10) based on 80% to 20% measurement threshold levels. 
Approximately 100 measurements are performed to provide statistical 
results, which are included in the screen image within the test report. 
However, just the "mean" measured results are compared against the 
specified test limits of:

• Fall time of received signals @ receiver input test plane: dBusRx10 ≤ 
22.50 ns.

• Fall time of transmitted signals @ transmitter output test plane: 6.0 ns 
≤ dBusTx10 ≤ 18.75 ns.

Figure 20 Fall time measurement on Data1 to Data0 transition
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10 Mb/s baud rate, 21
2.5 Mb/s baud rate, 21
3000 X-Series oscilloscope, 8
4000 X-Series oscilloscope, 8
5 Mb/s baud rate, 21
6000 Series oscilloscope, 8
7000 Series oscilloscope, 8

A

Active Star (AS) transmitter device under 
test, 21

Agilent Connection Expert, 9
Agilent I/O libraries, 8
amplitude measurement tests, 72
AutoRecovery preferences, 47

B

baud rate, 21, 29
beep only during run, 39
beep when user prompted, 39
best trials, store mode, 34
Bus Driver (BD) transmitter device under 

test, 20

C

comma-separated value (CSV) format, export 
results, 44

comments on report, 22
configuring tests, 26
connecting oscilloscope to DUT, 28
controller PC requirements, 8
creating test project, 19
critical at percent of margin, 41
CSV (comma-separated value) format, export 

results, 44

D

Data0 amplitude measurement test, 73
Data1 amplitude measurement test, 72
differential input signal requirements, 29
differential signal-to-noise ration, 30
display preferences, 37
DUT, connecting to oscilloscope, 28
dynamic frame ID, 29

E

email on pause or stop, 35
enable margin reporting, 41
enable remote interface, 50
Entitlement Certificate, 14
environment (test), setting up, 20
equipment required, 8
error dialogs, 38
event log, 38
event specification, 37
event trials, store mode, 34
events, pause or stop on, 36
expanded test options, 21
exporting the report, 44
eye diagram measurement (all frames), 54
eye diagram measurement (specified frame 

only), 63
eye diagram measurement tests, 54

F

fail event, 37
fall time - Data1 to Data0 test, 76
FlexRay bus configuration, 26
FlexRay communication controller generated 

traffic, 21
FlexRay Communication System Electrical 

Physical Layer Specification, 4
FlexRay physical layer conformance testing, 3
forever, run until setting, 34
frame ID, dynamic, 29
frame ID, static, 21, 29

H

hints, remote interface, 50
HTML format, export results, 45
HTML test report, 

viewing/exporting/printing, 44

I

I/O libraries, 8
idle level measurement test, 74
increased voltage transmitter type, 21
information dialogs, 38
input signal requirements, 29
input/output device under test, 20
installation, 13
invert scope display, 38
isolated one test, 64

isolated zero test, 66

K

keep application on top, 38

L

LAN interface, 10
last trials, store mode, 34
load preferences, 19
log events, 38

M

margin < N event, 37
margin thresholds, changing, 41
mask test input signal requirements, 29
mean corrected cycle time test, 71
multi-file HTML, export results, 46
multiple runs, 34

N

N times, run until setting, 35
N5452A remote interface, 49
notices, 2
number of waveforms configuration, 26

O

once, run until setting, 35
opening test project, 19
oscilloscope input channel configuration, 26
oscilloscope required, 8
oscilloscope, connecting to DUT, 28

P

pass event, 37
pause on event, 36
pause, email on, 35
PC requirements, 8
preferences, display, 37
preferences, remote, 50
preferences, report, 41, 42
preferences, run, 39
preferences, save/load, 19, 47
preview print, 46
printing HTML test report, 46
project, creating or opening, 19
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project, saving, 47

R

receiver test plane location, 20
reference images, showing, 41
remote control, 49
remote interface hints, 50
remote interface version, 49
remote interface, enable, 50
remote preferences, 50
report (HTML), viewing/exporting/printing, 44
report preferences, 41, 42
report, exporting, 44
report, printing, 46
report, user comments, 22
required equipment and software, 8
requirements, controller PC, 8
requirements, input signal, 29
results, viewing test, 40
rise time - Data0 to Data1 test, 75
run multiple times, 34
run preferences, 39
run until, 34
running tests, 31

S

save/load preferences, 19, 47
saving test project, 47
scope input channel configuration, 26
selecting tests, 23
set up test environment, 20
show tooltips, 38
showing reference images, 41
signal generator clock gated by T-ENABLE, 21
signal integrity voting procedure tests, 64
signal-to-noise ration, 30
single-file HTML, export results, 46
software installation, 13
software required, 8
standard voltage transmitter type, 21
starting FlexRay Physical Layer Conformance 

Test Application, 16
static frame ID, 21, 29
stop on event, 36
stop, email on, 35
store mode, 34

T

task flow pane, viewing/minimizing, 18
test environment, setting up, 20
test plane, 20
test project, creating or opening, 19
test project, saving, 47
test report (HTML), 

viewing/exporting/printing, 44
tests, about the, 53
tests, configuring, 26
tests, running, 31

tests, selecting, 23
tests, viewing results, 40
threshold voltage levels for transition time 

tests, 29
toolbar, viewing/hiding, 18
tooltips, show, 38
trademarks, 2
transition time measurement tests, 75
transmitter signal source, 21
transmitter test plane location, 20
transmitter type, 21
trial display preferences, 42
trials, best/worst/last, 34, 42
trigger level configuration, 27
troubleshooting tips, 29
TSS width measurement test, 70

U

unavailable tests, 23
user comments on report, 22

V

version, remote interface, 49
vertical scaling configuration, 27
vertical scaling mode configuration, 27
viewing HTML test report, 44
viewing test results, 40

W

warn at percent of margin, 41
warning dialogs, 38
worst trials, store mode, 34

Z

zoom in/out in reference images, 41
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