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Report Generator 

Report Generator 

The Report Generator enables you to generate and print reports directly from the 
oscilloscope. It enhances the DPOPWR application capabilities by simplifying 
the process of creating and maintaining reports.  

The Report Generator automates the process of compiling the test results and 
generating the reports. It allows you to set up the template layout using the 
factory default templates or custom templates. The Report Generator allows you 
to save files in the custom file formats such as .rgt, .rpl, or .rpt. The generated 
reports can also be saved as .rtf files. The Report Generator is integrated with the 
DPOPWR application. 

Using Report Generator 

Analyze> Power Device Analysis> Report  

You can generate and print reports directly from the oscilloscope.  

 

 
Figure 1: Generate Report Screen 

Perform the following steps to generate a report:  

1. Create a new or edit an existing test template. 

2. Define a new or edit an existing report layout. 

3. Generate, print, or view a report. 

Click here to go back to the DPOPWR Printed Help Document. 
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Report Generator 
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About Template Editor 

About Template Editor 

The Report Generator allows you to create templates apart from providing you 
with factory default templates. Use the Template Editor to create and edit 
templates in the .rgt format (report generator template). A template stores the 
fields and their positions. You can save the templates and reuse them in any 
number of reports or report layouts. You can cut, copy, and paste across 
templates. Once the report is generated, the application fills in the fields of the 
template using the acquired data from the oscilloscope.  

The Template Editor has a palette list that displays the following groups of fields: 
the DPOPWR Fields, Oscilloscope Fields, and Native Fields as shown in  
Figure 2. The template editor provides you with the option to create custom 
groups; these groups once created, appear in the palette list. The fields are listed 
according to the group selected. You can use these fields to design and create a 
template. 

You can place the fields in the template, and then move and size them 
appropriately. Multiple fields can be selected and placed in the template. You can 
select more than one field and make the following changes: cut, copy, paste, 
align, delete, size, edit font, and change caption of the fields. 

Once a template is defined and saved, either click Done to close the template 
editor, or use the Layout icon to directly go to the report layout editor. 

 
Figure 2: Template Editor Window 
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About Template Editor 

 

Table 1: Template Editor Default Settings 

Parameter Selection Default setting 

Page Size Change Template 
Size 

8.5x11inches 

Palette List None 
Displays application fields by default. If there are 
no application fields, the oscilloscope fields are 
displayed. 

Static Text Static Text Inserts My Static Text. 

Fields None The default size of the field dragged into the 
template is 200 X 300 pixels. 

Template Editor Window 

The Template Editor window contains a menu bar, a toolbar, a client area, a 
palette list, and a status bar. When you select the New Template button in your 
application, the client area in the Template Editor Window is empty. When you 
select the Edit Template button in your application, the client area displays the 
selected template. 

See the following topics for more information about each of these interface 
elements: 

View> Palette Toolbar 

The Palette List is a floating toolbar that has a list of Native Fields, DPOPWR 
fields, and oscilloscope fields grouped logically. You can drag and drop fields 
from the palette list into the template. The palette toolbar is displayed by default; 
you can show or hide the toolbar by selecting View> Palette Toolbar. 
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About Template Editor 

 
Figure 3: Palette List 

The Palette list groups the fields into the following categories:  

 

 

 

 

Native fields—Static Text, Rectangle, Line, Logo, Table, Date and Time.  

<Application> fields—Fields related to the application. The <Application> 
is replaced with the application from which you opened Report Generator. 
The <Application> field is displayed as DPOPWR fields because you 
opened Report Generator from DPOPWR. 

Oscilloscope fields—Groups of fields related to the data acquired from the 
oscilloscope.  

Custom groups—Custom groups that you created. 

Native Fields  

You can enhance the report using the following parameters from the Native 
fields—Static Text, Rectangle, Line, Logo, Table, Date, and Time. 

You can drag any fields from the Native field and drop it in the active template.  
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About Template Editor 

Static Text 

From the Native fields, drag and drop the static text.  

 
Figure 4: Edit Text 

1. In the Edit Text dialog box,  

Click .   

 In the Virtual Keyboard, select the text and select Enter.  

2. Click OK. 

Rectangle 

From the Native Fields, drag and drop the Rectangle into the Active Template. 

 

   

The black squares that appear at the corners of the rectangle allow you to 
increase the size. 

Line 

From the Native Fields, drag and drop the Line into the Active Template. 

 

The black squares that appear at the corners of the line allow you to increase the 
size. 
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About Template Editor 

Logo 

1. From the Native Fields, drag and drop the Logo into the Active Template. 

 
Figure 5: Edit Image 

2. In the Edit Image dialog box,  

Select .   

 

 

In the Virtual Keyboard, enter the path and filename and select Enter.  
Or 

Select Browse to navigate to the location where the image is available.  

3. Click OK. 

Table 

1. From the Native Fields, drag and drop the Table into the Active Template. 

 
Figure 6: Edit Table dialog 

2. In the Edit Table dialog box, you can select the number of rows and columns. 

Select  next to Number of Rows and Number of Columns to edit the 
number.  

 

 In the Virtual Keypad, enter the number and select Enter.  

3. Click OK. 
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About Template Editor 

Date and Time  

From the Native fields, drag and drop the Date and Time.  

Oscilloscope Fields 

These fields are grouped into ten different groups: 

1. Fields 

 

 

 

 

 

 

 

 

 

 

 

Waveform Group: The Waveform group has the entire active live 
channels and independent channels (only CH1 to CH4) waveforms in 
both jpeg and bmp. These waveforms are generated to smoothen out 
the stair-step effect seen on the display. 

Vertical Group: The Vertical group has all vertical related fields, 
including the vertical scale, position, and the offset. 

Horizontal Group: The Horizontal group has all horizontal related 
fields, including the horizontal divisions, scale, record length, position, 
and the sample rate. 

Math Group: The Math group has all the math related fields, including 
the math definition for a specified math channel, magnitude, spectral 
gate, spectral phase, spectral window, and the spectral frequencies of 
the math channel. 

Trigger Group: The Trigger group has all trigger related fields, 
including the trigger type, mode, level, and various fields related to 
different trigger types. 

Measurement Group: The Measurement group has all the 
measurements, including the eight automated measurements and the 
immediate measurements. 

Acquisition Group: The Acquisition group has all acquisition related 
fields, including the acquisition mode, acquisition state, repetitive 
mode, and the fast acquisition mode. 

Cursor Group: The Cursor group has all the cursor related fields 
including the cursor mode, source, state, type of the cursor, H Bars, and 
the V Bars. 

Zoom Group: The Zoom group has all zoom related fields, including 
the zoom horizontal position, and the horizontal scale. 

Histogram Group: The Histogram group has all histogram fields, 
including the co-ordinates of histogram box mode, size, and the source. 

Screen snapshot: The Screen Snapshot group has two variations: one 
in color and the other in black-and-white. For these screenshots, the 
attributes are graticule, ink-saver, and jpeg. 
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About Template Editor 

Template Editor | File menu 

Table 2 lists the File menu descriptions. 

Table 2: File menu descriptions  

Menu selection Description 
New Creates a new template. 
Open Opens a template file. 
Close Closes the active template. 
Save Saves changes to the file. 
Save As Saves the template to a different file name using the Save as 

dialog box. 
Print Prints all or part of the contents of the active template. 
Print preview Displays a sample view of the active template, as it would be 

printed. 
List of recent templates Opens a recently opened template. 
Exit Closes the Template Editor. 

Template Editor | Edit menu  

The available Edit menu selections depend on whether a template is active. In 
other words, the client area is empty or has a template open. 

Table 3 lists the Edit menu descriptions. 

Table 3: Edit menu description 

Menu selection Description 
Cut Cuts the selected fields. 
Copy Copies the selected fields. 
Paste Pastes the clipboard content. 
Delete Deletes the selected fields. 
Select All Selects all the fields. 
Edit Custom Group Edits the custom group. 
Change Template Size Changes the template size. 
Find Finds the data matching the search criteria. 
Replace Replaces the data matching the search criteria 

with the specified data. 
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About Template Editor 

Template Editor | View menu  

A check mark ( ) appears next to the selected menu item. 
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About Template Editor 

Table 4 lists the View menu descriptions. 

Table 4:View menu descriptions 

Menu selection Description 
Toolbar Displays/Hides the selected toolbars such as 

Standard, Align Size, Layout, and Action. 
Status Bar Displays/Hides the Status bar. 
Palette Bar Displays/Hides the Palette Bar. 
Grid Lines Displays/Hides the Grid Lines in the client area. 

Template Editor | Object menu 

The available object menu selections depend on whether a parameter in the client 
area is selected. 

Table 5 lists the Object menu descriptions. 

Table 5: Object menu descriptions 

Menu selection Description 
Bring To Front Brings the selected fields to front. 
Send To Back Sends the selected fields to back. 
Hide Text/Show Text Shows or hides the caption of the selected 

parameter. 
Position Caption on Top/to 
the Left 

Positions the caption of the selected parameter to 
left or on top. 

Edit Caption Allows you to edit the caption of the selected 
parameter. 

Change Font Allows you to change the font of the selected 
parameter or the caption using the Change Font 
dialog box. 

Align Fields Aligns fields to top, bottom, left, or right. 
Make Same Size Resizes the selected objects to the same size by 

height, width, or both.  
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About Template Editor 

Template Editor | Window menu 

Table 6 lists the Window menu descriptions. 

Table 6: Window menu description 

Menu selection Description 
New Window Opens a new window duplicating the current active 

window.  
Cascade Arranges the open templates in the client area from 

the upper left side to lower right side so that they 
overlap one another. 

Tile Arranges the open templates horizontally and 
vertically in the application client area without 
overlapping.  

Arrange Icons Arranges the icons of any templates you have 
minimized to the bottom-left of the window. 

List of open templates. Allows you to jump to another open template. 

Template Editor | Help menu 

The available Edit menu selections depend on whether a template is active or not. 
In other words, the client area is empty or has a template open.  

Table 7 lists the Help menu descriptions. 

Table 7: Help menu descriptions 

Menu selection Description 
Help Topics Displays the online help. 
About Template Editor Displays version and copyright information. 
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About Template Editor 

Standard Toolbar View> Toolbar> Standard 

Enable the Standard Toolbar by selecting it in the View> Toolbar menu. 

 

Align/Size View> Toolbar> Align/Size 

Enable the Align/Size Toolbar by selecting it in the View> Toolbar menu.  

 

Layout Toolbar View> Toolbar> Layout  

Enable the Layout Toolbar by selecting it in the View> Toolbar menu.  
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About Template Editor 

Action toolbar  

View> Toolbar> Action 

Enable the Action Toolbar by selecting it in the View> Toolbar menu.  

 

The Layout button also prompts to save documents. 

Status bar  

The Status bar displays the status of the application and tool tips for selected 
options. 

Template Editor | Edit menu 

The available Edit menu selections depend on whether a template is active. In 
other words, the client area is empty or has a template open. 

Using Template Editor 

To create a template: 

1. From the Palette List, drag and drop the fields that you want in the 
report. 

2. If you drag and drop a group from the Palette List, all the fields within 
the group are placed in the active template. 

3. Organize the fields as you want them to appear in the report.  

4. After you have finished creating the template, select File> Save. 

To edit an existing template: 

1. Organize the fields as you want them to appear in the report.  

2. From the Palette List, drag and drop the fields that you want in the 
report. 
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About Template Editor 

3. If you drag and drop a group from the Palette List, all the fields within 
the group are placed in the active template. 

4. Organize the fields as you want them to appear in the report.  

5. After you have finished editing the template, select File> Save. 

 

 

You can create custom group, edit custom group, and change 
template size.  

You can also edit caption, change font, align fields, and make 
selected fields same size. 

For more information on application interface of the Template Editor, refer to 
Template Editor Window. 

Creating Custom Groups: Edit> Create Custom Group 

You can create custom groups using any fields from the Palette List. 

1. Select Edit> Create Custom Group. 

 
Figure 7: Create Custom group 

2. In the Create Custom Group dialog box, enter the group name. You can enter 
the group name using the Virtual Keyboard.  

3. Click Next. The Select Fields dialog box displays all the fields of the Palette 
List. 
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Figure 8: Select fields 

4. Using Add >>, Add All, << Remove, or Remove All, select the fields you 
want to include in the new group. 

5. Click Finish.  

Editing Custom Groups: Edit> Edit Custom Group 

You can edit custom groups. 

1. Select Edit> Edit Custom Group. 

 
Figure 9: Edit Custom group 

2. In the Edit Custom Group dialog box, select a group to edit. 

3. Click Next. 
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About Template Editor 

 
Figure 10: Select Fields 

4. In the Select Fields dialog box, select the fields you want to add or remove 
from the group using Add >>, Add All, << Remove, or Remove All. 

5. Click Finish.  

Delete Custom Groups: Edit> Edit Custom Group 

You can delete custom groups. 

1. Select Edit> Edit Custom Group. 

 
Figure 11: Edit Custom Group 

2. In the Edit Custom Group dialog box, select a group to delete. 

3. Click Delete. A message box appears asking you to confirm your choice.  

4. Select Yes to delete. 
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Change Template Size: Edit> Change Template Size 

You can change the size and page setup for a template. 

1. Select Edit> Change Template Size. 

 
Figure 12: Change Template Size 

2. In the Change Template dialog box, 

 

 

Select the Template Size as 1/4 page, 1/2 page, or Full page.  

If the printer is not available, select the Page Size as Default (8.5" x 
11"); otherwise, select Configure Page.  

 
Figure 13: Page Setup 

18                                               Report Generator Reference Manual 



About Template Editor 

 

 

In the Page Setup dialog box, select the paper size, source, orientation, 
and margins. 

Click OK to return to Change Template Size dialog box. 

3. Click OK. 

Note: Do not reduce the template size beyond the content filled in the template. 
You may lose information. 

Select All: Edit> Select All 

To cut, copy, or delete the fields from the active template, you need to select the 
fields. You can also select the fields from the active template by clicking CTRL+ 
selecting the fields. 

Find: Edit> Find 

You can search for text in the active template. 

1. Select Edit> Find. 

 
Figure 14: Find  

2. In the Find dialog box, enter the search string using the Virtual Keyboard. 

3. Select Find Next until you find the required search string. 
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Replace: Edit> Replace 

You can search and replace the text in the active template. 

 
Figure 15: Find 

1. Select Edit> Replace. 

2. In the Replace dialog box, enter the search string using the Virtual Keyboard 
in the Find what field. 

3. In the Replace with field, using the Virtual Keyboard, enter the replacement 
string. 

4. Select Find Next until you find the required search string. 

5. Select Replace to replace one instance of the string.  
or 
Select Replace All to replace all instances of the string. 

6. Click Cancel after you have replaced the strings. 

Bring To Front: Object> Bring To Front 

You can bring the selected fields to the front.  

Send To Back Object> Send To Back 

You can send the selected fields to the back. 

Show/Hide Text: Object> Show/Hide Text 

You can show or hide the captions for the selected fields. 

Position Caption: Object> Position Caption to the 
Left, or on Top 

You can position the caption of the selected fields on either the left or on the top. 

Editing Caption: Object> Edit Caption 

You can edit the caption of the selected parameter or object. 

1. Select Object> Edit Caption. 
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Figure 16: Edit Caption 

2. In the Edit Caption dialog box, select  to enter the caption using the 
Virtual Keyboard. 

3. Click OK.  

Change Font Object> Change Font 

You can change the font for the selected field in the template. 

1. Select the fields or fields in the active template. 

2. Select Object> Change Font, or right click the field to display the options. 

 
Figure 17: Change Font 

3. In the Font dialog box, choose the font size, color and style, and effects. 

4. Click OK.  
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Align Fields: Object> Align Fields 

You can align the fields to top, bottom, left, or right. 

1. Select the fields in the active template. 

2. Select Object> Align Fields> Top, Bottom, Left, or Right to align the fields 
accordingly. 

Make Same Size Object> Make Same Size 

You can set the selected fields to same height, width, or both. 

1. Select the fields in the active template. 

2. Select Object> Make Same Size> Height, Width, or Both to make the 
selected fields the same size.  
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Report Layout Editor 

The Report Layout Editor helps you define the report layout for generating 
reports. The report layout, once created can be reused for generating multiple 
reports. 

You can select the number of test templates per page and position the templates 
in the report. The report can have multiple pages with different template sizes. 
Each template is a sub report with a unique test title. This unique test title helps 
you select the required template when generating a report. You can define 
headers and footers for the report layout.  

To display the Report Layout Editor, select Define Report Layout> New Layout. 

  

Figure 18: Report Layout Window 

The Report Layout Editor window has two panes: 

 

 

List of Templates: Displays a list of templates, template sizes, template 
folders, and buttons that allow you to clear or place a template in a 
report layout tile and to create new templates. 

Report Layout: Displays the selected report layout and the header, 
footer definition. 
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Report Layout Editor Default Settings  

Table 8 lists the Report Layout Editor Default Settings. 

Table 8: Report Layout Editor Default 
Settings 

Parameter Selection Default setting 
Report Layout Layout  Four tests per page 
Page Size   Page Setup 8.5 X 11inches 
Layout Editor None One page 
Go to  Edit  Displays the current page number in 

the page layout 
Font  None  Arial>  Regular 9 
Default Margin Size  None  Margin size on all sides of the paper 

is 0.8 inches 

Report Layout Editor Window  

The Report Layout Editor window contains a menu bar, a tool bar, a list of 
templates pane, and a report layout pane. 

 
Figure 19: Report Layout Window 

List of Templates pane 

The List of Templates pane displays the path of the template, templates in the 
folder, file names, and template sizes. You can select the template from this list 
and place it in the Report Layout pane. 
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Report Layout Editor 

 
Figure 20: List of Templates 

In the List of Templates pane, you can do the following:  

 

 

 

 

Select a different path where you have saved the customized templates by 
using the Virtual Keyboard or clicking the Directory button that displays a 
Browse for Folder window. 

Create a new template by selecting New. The Template Editor Window is 
displayed, where you can create a new template. 

Drag and drop the Template File into the report layout pane's tile or select 
the template file and click Place on Tile >>. 

Clear the selected tile in the report layout pane by clicking << Clear Tile. 
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Report Layout pane 

Depending on the number of tests selected per page, the Report Layout pane 
appears as shown by the following figure. 

 

 
Figure 21: Report Layout Pane 

 In the Report Layout pane, you can do the following:  

 Specify a title for each test 

 Define or modify the header and footer 

 Navigate between pages of the report layout 
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Report Layout Editor | File menu 

Table 9 lists the File menu descriptions. 

Table 9: File menu descriptions 

Menu selection Description 
New Creates a new layout. 
Open Opens a report layout file. 
Save Saves changes to the file. 
Save As Saves the report layout to a different file name using the 

Save as dialog box. 
Page Setup Prints all or part of the contents of the active template. 
Configure Page Configures the paper size, source, orientation, and margins 

using the Page Setup dialog box.  
Default (8.5" X 11") Configures the page setup to default—8.5" X 11". 
Layout Preview Displays a sample view of the active report layout as it would 

be printed. 
List of recent report 
layouts 

Opens a previously (recent) opened report layouts.  

Exit Closes the Report Layout Editor. 

Report Layout Editor | Edit menu 

Table 10 lists the Edit menu description. 

Table 10: Edit menu description 

Menu selection Description 
Go To Goes to the page entered in the Go To Page dialog box. 

Report Layout Editor | View menu 

A check mark ( ) appears next to the selected menu item. 

Table 11 lists the View menu descriptions. 

Table 11: View menu descriptions 

Menu selection Description 
Toolbar Displays or Hides the selected toolbars such as Standard, 

Page, Layout, and Action. 
Status Bar Displays or Hides the Status bar. 
Refresh Template List Refreshes the Template list in the List of Templates pane. 
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Report Layout Editor | Layout menu 

A check mark ( ) appears next to the selected menu item. 

Table 12 lists the Layout menu description. 

Table 12: Layout menu descriptions 

Menu selection Description 
One Test Per Page Changes the report layout to fit one test per page. 
Two Tests Per Page Changes the report layout to fit two tests per page. 
Four Tests Per Page Changes the report layout to fit four tests per page. 

Report Layout Editor | Page menu 

Table 13 lists the Page menu descriptions.  

Table 13: Page menu descriptions  

Menu selection Description 
Insert Blank 
          Before Current Page Inserts a blank page before the current page. 
          After Current Page Inserts a blank page after the current page. 
Insert Copy 
        Before Current Page Inserts a copy of the current page before the current 

page. 
        After Current Page Inserts a copy of the current page after the current page. 
Delete Deletes the current page. 

Report Layout Editor | Help menu  

Table 14 lists the Help menu descriptions. 

Table 14: Help menu descriptions 

Menu selection Description 
Help Topics Displays the online help. 
About Template Editor Displays version and copyright information. 
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Report Layout Editor | Standard toolbar 

View> Toolbars> Standard 

Enable the Standard Toolbar by selecting it in the View> Toolbars menu. 

 

Report Layout Editor | Layout toolbar 

View> Toolbars> Layout 

Enable the Layout Toolbar by selecting it in the View> Toolbars menu. 

 

Report Layout Editor | Page toolbar 

View> Toolbars> Page 

Enable the Page Toolbar by selecting it in the View> Toolbars menu. 
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Report Layout Editor 

Report Layout Editor | Action toolbar 

View> Toolbars> Action 
Enable the Action Toolbar by selecting it in the View> Toolbars menu. 

 

Using Report Layout Editor  

To define a report layout, perform the following steps: 

1. Set the report layout. 

 

 

 

 

 

 

 

Select Layout> One Test Per Page/Two Tests Per Page/Three Tests Per 
Page. The Report Layout pane displays tiles depending on the selected 
number of tests per page. 

2. Add the templates. 

The List of Templates pane displays the templates in the default 
directory —
C:\TekApplications\DPOPWR\ReportGenerator\Templates. 

From the List of Templates pane, drag and drop the templates into the 
tiles in the Report Layout pane. You can use the Place on Tile and 
Clear Tile buttons to move the templates to the tiles and to clear the 
tiles. 

If you want to define a new template, select New in the List of 
Templates pane. 

To browse for a different folder other than the default templates, select 
Directory to display Browse for Folder dialog box. Navigate to the 
folder where you have the templates stored and select OK. 

3. Define Header and Footer. 

4. Save the report layout. 

Select File> Save to display the Save dialog box. Enter the report 
layout name and select Save. 

The report layout is saved in the .rpl format. 
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To edit an existing report layout, perform the following steps: 

1. Change the report layout. 

 

 

 

 

 

 

 

 

 

 

 

 

Select Layout> One Test Per Page/Two Tests Per Page/Three Tests Per 
Page. The Report Layout pane displays tiles depending on the selected 
number of tests per page. 

The application displays an alert message—All the Test(s) information 
in the current page will be lost. Do you want to continue? 

Select Yes to continue or No to stop. 

2. Add or Remove the templates. 

In the Report Layout pane, select the tile to which you want to add or 
remove the template. 

To remove a template from the Report Layout, complete the following 
steps: 

In the List of Templates pane, select Clear Tile. 

The application displays an alert message—The test is already filled 
with data. Do you want to remove it? 

Select Yes to continue or No to stop. 

3. To add a template to the Report Layout, complete the following steps: 

The List of Templates pane displays the templates in the default 
directory —
C:\TekApplications\DPOPWR\ReportGenerator\Templates. 

From the List of Templates pane, drag and drop the templates into the 
tiles in the Report Layout pane. Select the Place on Tile button to move 
the template to the selected tile. 

If you want to define a new template, select New in the List of 
Templates pane. 

To browse for a different folder other than the default templates, select 
Directory to display the Browse for Folder dialog box. Navigate to the 
folder where you have the templates stored and select OK. 
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4. Modify Header and Footer. 

5. Save the report layout. 

 

 

Select File> Save to display the Save dialog box. Enter the report 
layout name and select Save. 

The report layout is saved in the .rpl format. 

Note: Each report can only have up to five pages. 

 

Configure Page  

File> Page Setup> Configure Page 

You can configure the paper size, source, orientation, and margins. 

 
Figure 22: Page Setup 

After you configure the page setup, select OK. 
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Go To Page  

Edit> Go To 

You can go to different pages in the report layout using the Go To Page dialog 
box. 

 
Figure 23: Go To Page 

1. In the Enter Page Number field, enter the page number or select  to 
display the Virtual keyboard. 

2. Select Go To. The Report Layout pane displays the relevant page. 

Change Report Layout 

You can change the report layout to fit one, two, or four tests per page. 

Layout> One Test Per Page/Two Tests Per Page/Four Tests Per Page 

 

 

Header/Footer Definition 

To modify Header Definition, do the following: 

 
Figure 24: Header/Footer Definition 
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1. In the Report Layout pane, click Header - Click to Modify. 

2. In the Header/Footer Definition dialog box, select the header position - 
Header Left, Header Center, or Header Right. 

3. Enter the Header definition in the text box.  

Select  to display the Virtual Keyboard. In the Virtual Keyboard, select 
the text and select Enter.  
or 
To insert the special text, select the Insert Special Text button to display a 
sub menu. Select Date, File Name, Author, Page X of Y, Page X, or Logo. 

4. Select Set Font to change the font style, size, effects, color, and script for 
each field separately, and then select OK. 

5. In the Header/Footer Definition dialog box, select OK. 

To modify Footer Definition, do the following: 

1. In the Report Layout pane, click Footer - Click to Modify. 

 
Figure 25: Header/Footer Definition 

2. In the Header/Footer Definition dialog box, select the footer position - Footer 
Left, Footer Center, or Footer Right. 

3. Enter the Footer definition in the text box.  
 
Select  to display the Virtual Keyboard. In the Virtual Keyboard, select 
the text and select Enter.  
or 
To insert the special text, select the Insert Special Text button to display a 
sub menu. Select Date, File Name, Author, Page X of Y, Page X, or Logo. 

4. Select Set Font to change the font style, size, effects, color, and script for 
each field separately, and then select OK. 

5. In the Header/Footer Definition dialog box, select OK. 
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Insert Pages 

1. Select Page> Insert Blank> Before Current Page/After Current Page to insert 
a new page before the current page or after the current page. 

2. Select Page> Insert Copy> Before Current Page/After Current Page to insert 
copy of the current page before the current page or after the current page. 

Note: When you insert a copy of a page before or after the current page, the 
layout of the current page is the same layout as the new page. 
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Report Viewer 

The Report Viewer allows you to view the generated report. 

Under the Generate Report tab, select Load Report or Generate Report to display 
the Report Viewer and browse for the report that you want to view or generate. 

Report Viewer Window 

The Report Viewer window contains a menu bar, a toolbar, an align/size bar, and 
a client area. 

Report Viewer | File menu 

Table 15 lists the File menu descriptions. 

Table 15:File menu descriptions 

Menu selection Description 
Open Opens a template file. 
Save Saves changes to the file. 
Save As Saves the template under a different file name using the 

Save as dialog box. 
Print Prints all or part of the contents of the active template. 
Print Preview Displays a sample view of the active template, as it would 

be printed. 
Print Setup Prompts you to set up the Printer. 
Export to RTF Exports the report in .rtf (rich text format). 
List of recent 
templates 

Opens a previously (recent) opened template.  

Exit Closes the Report Viewer. 
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Report Viewer | Edit menu 

The available edit menu selections depend on whether a field is selected. 

Table 16 lists the Edit menu descriptions. 

Table 16: Edit menu descriptions 

Menu selection Description 
Cut Cuts the selected fields and places them on the clipboard. 
Copy Copies the selected fields to the clipboard. 
Paste Pastes the clipboard content. 
Delete Deletes the selected fields. 
Select All Selects all the fields. 
Add Text Field Adds a text field to the report. 
Find Finds the data matching the search criteria entered. 
Replace Replaces the data matching the search criteria with the specified 

data. 
Go To Goes to the page number specified in the Go To Page dialog box. 

Report Viewer | View menu 

A check mark ( ) appears next to the selected menu item. 

Report Viewer | Object menu 

The available object menu selections depend on whether a field in the client area 
is selected. 

Table 17 lists the Object menu descriptions. 

Table 17: Object menu descriptions 

Menu selection Description 
Bring To Front Brings the selected field to front. 
Send To Back Sends the selected field to back. 
Hide Text/Show Text Shows or hides the caption of the selected field. 
Position Caption on Top/to 
the Left 

Positions the caption of the selected field to left or on top. 

Edit Text Allows you to edit the text in the selected field. 
Change Font Allows you to change the font of the selected field or the 

caption using the Change Font dialog box. 
Align Fields Aligns fields to the top, bottom, left, or right. 
Make Same Size Resizes the selected fields to the same size by height, width, 

or both.  
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Report Viewer | Help menu 

Table 18 lists the Help menu description. 

Table 18: Help menu descriptions 

Menu selection Description 
Help Topics Displays the online help. 
About Report Viewer Displays version and copyright information. 

Report Viewer | Standard Toolbar 

View> Toolbar 

Enable the Standard Toolbar by selecting it in the View> Toolbar menu. 

 

 

Report Viewer | Align or Size bar 

View> Align/Size bar 

Enable the Align/Size Toolbar by selecting it in the View> Align/Size bar menu. 

 

40                                                                                                                        Report Generator Reference Manual  



Report Viewer 

Report Viewer | Status bar 

The Status bar displays the status of the application and tool tips for selected 
options. 

Report Viewer | Separators 

View> Separators 

Shows or hides the template separators. 

Using Report Viewer 

 

 

To view a report: 

1. Select File> Open. The Open dialog box displays all the reports in the 
default directory—
C:\TekApplications\DPOPWR\ReportGenerator\Reports. 

2. Select the report that you want to view and select Open. 

3. The Report Viewer displays the selected report. 

 

To edit text: 

1. Select Edit> Add Text Field. The Edit Text dialog box appears. 

2. In the Text field, enter the text or click  to display the Virtual 
keyboard. In the Virtual Keyboard, enter the text and select Enter.  

3. In the Edit Text dialog box, select OK. 

 

 To find text: 

1. Select Edit> Find. The Find dialog box appears. 

2. In the Find what field, enter the text or click  to display the Virtual 
keyboard. In the Virtual Keyboard, enter the text and select Enter.  

3. In the Find dialog box, select Find Next until you find that text for which 
you are searching. 
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 To replace text: 

1. Select Edit> Replace. The Replace dialog box appears. 

2. In the Find what field, enter the text or click  to display the Virtual 
keyboard. In the Virtual Keyboard, enter the text and select Enter.  

3. In the Replace with field, enter the text or click  to display the Virtual 
keyboard. In the Virtual Keyboard, enter the text and select Enter.  

4. In the Replace dialog box, 

 

 

 

 

Select Find Next to find the text for which you are searching. 

Select Replace to replace one instance of the text that you want to 
replace. 

Select Replace All to replace all instances of the text that you want 
to replace. 

Select Cancel to cancel the operation and close the dialog box. 

You can select some objects and bring to front or send to back. You can 
show/hide text, position caption to the left, or on top. You can edit text, or 
change font. You can align selected fields or make the selected fields to same 
size. You can export a report as an .rtf. 

Export to RTF  

File> Export to RTF 

You can export a report as an .rtf (rich text format) file. 

Find  

Edit> Find 

You can search for text in the report. 

Select Edit> Find. 

 
Figure 26: Find 

In Find dialog box, enter the search string using the Virtual Keyboard. 

Select Find Next until you find the required search string. 
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Replace  

Edit> Replace 

You can search and replace the text in the report. 

 
Figure 27: Find 

1. Select Edit to replace. 

2. In Replace dialog box, enter the search string using the Virtual Keyboard in 
the Find what field. 

3. In Replace with field, using the Virtual Keyboard enter the replacement 
string. 

4. Select Find Next until you find the required search string. 

5. Select Replace to replace one instance of the string.  
or 
Select Replace All to replace all instances of the string. 

6. Click Cancel after you have replaced the strings. 

Bring To Front  

Object> Bring To Front 

You can bring the selected fields to the front. 

Send To Back 

Object> Send To Back  

You can send the selected fields to the back. 

Show/Hide Text 

Object> Show/Hide Text 

You can show or hide the captions for the selected fields. 

Position Caption 

Object> Position Caption to the Left, or on Top. 

You can position the caption of the selected fields on either the left or on the top. 
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Edit Caption  

Object> Edit Caption  

You can edit the caption of the selected parameter or object. 

 
Figure 28: Edit Caption 

1. Select Object> Edit Caption. 

2. In Edit Caption dialog box, select  to enter the caption using the Virtual 
Keyboard. 

3. Click OK. 

Change Font  

Object> Change Font 

You can change font for the selected field in the report. 

1. Select the fields or fields in the report. 

2. Select Object> Change Font or right-click on the field to display the options. 

 
Figure 29: Change Font 
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3. In the Font dialog box, choose the font size, color, style, and effects. 

4. Click OK. 

Make Same Size 

Object> Make Same Size 

You can make the selected fields the same height, width, or both. 

1. Select the fields in the report. 

2. Select Object> Make Same Size> Height, Width, or Both to make the 
selected fields to the same size. 

Align Fields 

Object> Align Fields 

1. Select the fields in the report. 

2. Select Object> Align Fields> Top, Bottom, Left, or Right to align the fields 
accordingly. 
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Using Report Generator 

Create or edit a test template 

Report> Define Report Layout 

You can create a new test template or edit an existing template. 

 
Figure 30: Define Report Layout 

To create a new test template: 

Under the Define Test Template tab, select New Test Template. 

1. The Template Editor window appears with an empty client area. 

2. Create the template using the Palette list. 

3. After you have completed creating a new test template, select Done. 

See Template Editor for more information about Template Editor. 

To edit an existing test template: 

1. Under the Define Test Template tab, select Browse. 

2. The open window displays the existing factory default templates and 
customized templates in 
C:\TekApplications\DPOPWR\ReportGenerator\Templates. 
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Figure 31: Open Window 

3. Select the template that you want to use and select Open. 

4. In the Define Test Template tab, select Edit Template. 

5. The Template Editor window appears with client area displaying the selected 
template. 

6. Edit the template using the Palette list. 

7. After you have completed editing an existing test template, select Done. 

See Template Editor for more information about Template Editor. 

Define or edit a report layout 

Report> Define Report Layout 

You can create a new layout or edit an existing report layout. 

To create a new layout: 

1. The Report Layout Editor window appears with an empty report layout area. 

2. Create the report by defining the report layout and dragging and dropping 
the templates to the report layout area. 

3. After you have completed creating a new layout, select Done. 

See Report Layout Editor for more information about Report Layout Editor. 
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To edit an existing report layout: 

 
Figure 32: Open window 

1. Under the Define Report Layout tab, select Browse. 

2. The Open window displays the existing factory default report layout and 
customized report layouts in 
C:\TekApplications\DPOPWR\ReportGenerator\Layouts. 

3. Select the report layout that you want to use and select Open. 

4. In the Define Report Layout tab, select Edit Layout. 

5. The Report Layout Editor window appears with report layout area displaying 
the customized report layout and selected template files. 

6. Edit the report layout using the List of Templates and defining the Report 
Layout. 

After you have completed editing an existing report layout, select Done. 

See Report Layout Editor for more information about Report Layout Editor. 
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Generate, print, or view a report 

Report> Generate Report 

You can generate, print, or view a report. 

 
Figure 33: Generate Report 

To generate a report 

Under the Generate Report tab, select Browse. 

 
Figure 34: Open window 

1. The Open window displays the existing reports in 
C:\TekApplications\DPOPWR\ReportGenerator\Reports. 

2. Select the report that you want to generate and select Open. 

3. Under the Generate Report tab, select Generate Report. 

4. In the Assign Data to Report dialog box, select a test template in this report 
to assign the current data from your measurement application. 
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5. Select Assign. The Report Viewer displays the report with current data from 
the application. You can choose to export to the report in an rtf format. 

To print a report: 

Under the Generate Report tab, select Browse. 

 
Figure 35: Open window 

1. The Open window displays the existing reports in 
C:\TekApplications\DPOPWR\ReportGenerator\Reports. 

2. Select the report that you want to print and select Open. The Report Viewer 
displays the selected report with current data from the application. 

3. If the page settings do not match the page settings for the Report, a Page Size 
Mismatch message box displays a message—The current page settings do 
not match the page settings for the Report. Do you want to continue? 

 Click Yes to continue. 

 Click No to stop printing the report. 

If the printer is available, the report is printed. 
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Table 19 lists the View menu descriptions. 

Table 19: View menu descriptions 

Menu selection Description 
Toolbar Displays/Hides the Standard toolbar. 
Align/Size Bar Displays/Hides the Align/Size toolbar. 
Status Bar Displays/Hides the Status bar. 
Separators Displays/Hides the separators. 
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