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About TDSET3

The TDSET3 Ethernet Compliance Test Software tests the Ethernet 's physical
layer for — 1000BASE-T, 100BASE-TX, and 10BASE-T in compliance with
IEEE 802.3-2000 and ANSI X3.263-1995 standards.

Click here to go back to TDSET3 Printed Help Document.

About Report Generator

The Report Generator enables you to generate and print reports directly from the
oscilloscope. It enhances the TDSET3 application capabilities by simplifying the
process of creating and maintaining reports.

The Report Generator automates the process of compiling the test results and
generating the reports. It allows you to set up the template layout using the
factory default templates or custom templates. The Report Generator allows you
to save files in the custom file formats such as .rgt, .rpl, or .rpt. The generated
reports can also be saved as a .rtf file. The Report Generator is integrated with
the TDSET3 application.

There are several tools to convert RTF to PDF. For converting the .RPT to PDF,
there are several tools such as RoboPDFTM, GhostWriterTM and many others.

You can generate and print reports directly from the oscilloscope.

File Tests Resuls Utiities Help TDSET3 B x|
Report Generator

Define Test Template Define Report Layout Generate Report

e e T T

Generate Report Frint Report Load Report i

Peasdy @/

Perform the following steps to generate a report:

B Create a new or edit an existing test template.

®  Define a new or edit an existing report layout.

Report Generator Printed Help Document for TDSET3 1-1



Report Generator

®  Generate, print, or view a report.

Note: The report image settings are as per the existing export settings of the
oscilloscope. It is recommended that you use Graticule(s) only for Image view
setting in export setup.

Shortcut Keys for Report Generator

Table 1-1: Shortcut Keys

Action / common keys Shortcut keys
Open Ctri+O

Save Ctrl+S

Template editor

New Ctrl+N
Find Ctrl+F
Replace Ctrl+H
Print Ctrl+P
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Delete Del
Select all Ctrl+A
Bring to front Ctrl+Plus
Send to Back Ctrl+Minus
Edit Text Alt+Enter

Report layout
New Ctrlr+N
GoTo Ctri+G
Refresh Template List F5
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Table 1-1: Shortcut Keys (cont)

Action / common keys Shortcut keys
Report viewer

Find Ctrl+F

Select Al Ctrl+A

Del Del

GoTo Ctri+G

Bring to front Ctrl+Plus
Send to Back Ctrl+Minus
Edit Text Alt+Enter

Report Generator Printed Help Document for TDSET3
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About Template Editor

The Report Generator allows you to create templates apart from providing you
with factory default templates. Use the Template Editor to create and edit
templates in the .rgt format (report generator template). A template stores the
fields and their positions. You can save the templates and reuse them in any
number of reports or report layouts. You can cut, copy, and paste across
templates. Once the report is generated, the application fills in the fields of the
template using the acquired data from the oscilloscope.

The Template Editor has a palette list that displays the following groups of fields:
the TDSET3 Fields, Oscilloscope Fields, and Native Fields. The template editor
provides you with the option to create custom groups; these groups once created,
appear in the palette list. The fields are listed according to the selected group.
You can use these fields to design and create a template.

You can place the fields in the template, and then move and size them
appropriately. Multiple fields can be selected and placed in the template. You can
select more than one field and make the following changes: cut, copy, paste,
align, delete, size, edit font, and change caption of the fields.

Once a template is defined and saved, either click Done to close the template
editor, or use the Layout icon to directly go to the report layout editor.

Table 2-1: Template Editor Default Settings

Parameter Selection Default setting
Page Size Change Template Size 8.5x11inches
Displays application fields by default. If there

Palette List None are no application fields, the oscilloscope
fields are displayed.
Static Text Static Text Inserts My Static Text.

The default size of the field dragged into the

Fields None template is 200 x 300 pixels.

Report Generator Printed Help Document for TDSET3 2-1



About Template Editor

Template Editor Window

Palette List

The Template Editor window comprises a menu bar, a toolbar, a client area, a
palette list, and a status bar. When you select the New Template button in your
application, the client area in the Template Editor Window is empty. When you
select the Edit Template button in your application, the client area displays the
selected template.

Bt Template Editor - [Tmpit1] [_[O] x
File Edit “iew Object ‘Window Help -8 x

DDWE|3{'%E@|%“E%ﬁ}|&@”’iaaﬂ |JLay0ut |iDune|

D‘l’

21 Mative Fields TDSETA Fields

9.1.8 100BASE-TX Wavsform Cvershoot

1000BASE-T

T00BASE-TH

10BASE-T

<Positt = < 1 kS
Positive Overshoot Image Megative Owershoot Image DUT Config

Puositive Owershoot Negative Owvershoot |<Walue>
Waveform Owvershoot Test Results

-
4] | »

Feady MLk ”

View> Palette Toolbar

The Palette List is a floating toolbar that has a list of Native Fields, TDSET3
fields, and oscilloscope fields grouped logically. You can drag and drop fields
from the palette list into the template. The palette toolbar is displayed by default;
you can show or hide the toolbar by selecting View > Palette Toolbar.

[<|D

Mative Figlds TDSET3 Fields

El 1000BASE-T

Carfigure

Templates

Peak Vol

Droop

Jditter

T00BASE-TX

10BASE-T
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Application Fields

The Palette list fields are grouped into the following categories:
Native fields — Static Text, Rectangle, Line, Logo, Table, Date and Time.

<Application> fields — fields related to the application. The <Application> is
replaced with the application from which you opened Report Generator. As you
have opened Report Generator from TDSET3, the <Application> fields are
displayed as TDSET3 fields.

Oscilloscope fields — Groups of fields related to the data acquired from the
oscilloscope.

Custom groups — custom groups created.

The following table lists the options and sub menus for 1000BASE-T. You can
drag and drop any of these fields.

Table 2-2: 1000BASE-T Application Fields

Options Sub menus

Configuration Parameters

Source — Data

Source — Master Clock
Source — Slave Clock

Source - TX_TCLK

Source — Return Loss Probe 1
Source - Return Loss Probe 2
Source — Data (TM2)

Source — Data (TM3)

Meas Type

Record Length

Disturbing Signal

Filter

Clock Edge

# Averages

Output

TX_TCLK

Hi Resolution

Jig Match - Amplitude

Jig Match - Frequency

Jig Match - DUT Amp
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Table 2-2: 1000BASE-T Application Fields (cont)

Options Sub menus
Jig Match - Probe Point Amp
Jig Match - Attenuation
Output Waveform Return Loss
Output Waveform OdB Marker
Return Loss - Pair ID
Return Loss - Load
Return Loss - # Averages
Return Loss — Smooth
LP Filter
Hysteresis
Point A, Point B, Test Result
Templates Point C, Point F,
Point H
Image
Summary
Peak Volt Point A Test Result
Point A Peak
Point A Image
Point B % Diff A& B
% Diff A & B, Test Result
Test Result
Point A Peak
Point B Peak
Point B Image
Point C Test Result
Point A Peak
Point B Peak
Point C Peak
% Diff C
Point C Image
Point D Test Result
Point A Peak
Point B Peak
Point D Peak
% Diff D
Point D Image
Droop Point G Test Result
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Table 2-2: 1000BASE-T Application Fields (cont)

Options

Sub menus

Point F Peak

Point G Peak

Limit

Point G Image

Point J

Test Result

Point H Peak

Point J Peak

Limit

Point J Image

Jitter Master

Filtered with
TX_TCLK

Result

Master Pk-Pk Jitter

Master Jtx_Out

Master Pk-Pk Jitter + Master Jtx_Out

Clock Edges

Trend Plot: Master Filtered Pk-Pk Jitter

Trend Plot: Master Jtx_Out

TX_TCLK

Filtered without Result

TX_TCLK
Data (TM2) Pk-Pk Jitter
Trend Plot; Data (TM2) Jitter
CLK Edges

Unfiltered with Histogram Method

Result, Master Pk-Pk Jitter, Median, Mean, Image

TIE Method

Result, Master Pk-Pk Jitter, Clk Edges, Trend Plot
— Master Unfiltered Pk-Pk Jitter

Unfiltered without
TX_TCLK

Histogram Method

Result, Data (TM2) Pk-Pk Jitter, Data (TM2) Jitter
Image, Remarks

TIE Method

Result, Data (TM2) Pk-Pk Jitter, Trend Plot; Data
(TM2) Jitter, CLK Edges

Report Generator Printed Help Document for TDSET3
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Table 2-2: 1000BASE-T Application Fields (cont)

Options Sub menus
Slave
Filtered with Result
TX_TCLK

Master Pk-Pk Jitter

Slave Pk-Pk Jitter

Slave Jtx_Out

Slave Pk-Pk Jitter + Slave Jix_Out

0.4 ns + Master Filtered Pk-Pk Jitter
Clk Edges

Trend Plot: Master Filtered Pk-Pk Jitter
Trend Plot: Slave Filtered Pk-Pk Jitter
Trend Plot: Slave Jtx_Out

Filtered without Result
TX_TCLK

Data (TM2) Pk-Pk Jitter

Data (TM3) Pk-Pk Jitter

Data (TM2) Pk-Pk Jitter - Data (TM3) Pk-Pk Jitter
Trend Plot: Data (TM2) Jitter

Trend Plot: Data (TM3) Jitter

Clk Edges

Unfiltered with Histogram Method

TX_TCLK Result, Slave Pk-Pk Jitter, Median, Mean, Image
TIE Method

Result, Slave Pk-Pk Jitter, Clk Edges, Trend Plot -
Slave Unfiltered Pk-Pk Jitter

Histogram Method
- - Result, Data (TM2) Pk-Pk Jitter, Data (TM3) Pk-Pk
?Qf”}eéfiw'tho“t Jitter, Data (TM2) Pk-Pk Jiter - Data (TM3) Pk-Pk

Jitter, Data (TM2) Jitter Image, Data (TM3) Jitter
Image, Remarks

TIE Method
Result, Data (TM2) Pk-Pk Jitter, Data (TM3) Pk-Pk
Jitter, Data (TM2) Pk-Pk Jitter - Data (TM3) Pk-Pk

Jitter, Trend Plot; Data (TM2) Jitter, Trend Plot:;
Data (TM3) Jitter, Clk Edges

Distortion Test Result, Peak Distortion, RMS, SNR, Other
Details, Peak Distortion Image

Return Loss Return Loss (1MHz - 100MHz), Image, Result

CM Voltage Image, Result, Value

2-6 Report Generator Printed Help Document for TDSET3



About Template Editor

The following table lists the options and submenus for 100BASE-TX. You can
drag and drop any of these fields.

Table 2-3: 100BASE-TX Application Fields

Options

Sub menus

Configuration Parameters

Signal Source

Source - Return Loss Probe 1

Source - Return Loss Probe 2

Acquisition Mode

# Averages

Mask Scale

Output Waveform Return Loss

Output Waveform 0dB Marker

Return Loss - Load

Return Loss - # Averages

Return Loss - Smooth

Differential Output Voltage

Output Voltage (+Vout)

Output Voltage (-Vout)

Differential Output Voltage Result

Output Voltage (+Vout) Image

Output Voltage (-Vout) Image

Output Voltage (+Vout) Result

Output Voltage (-Vout) Result

Signal Amplitude Symmetry

Amplitude Symmetry

Amplitude Symmetry Result

Amplitude Symmetry (+Vout) Image

Amplitude Symmetry (-Vout) Image

Rise and Fall Times

Rise Time (+ve)

Fall Time (+ve)

Rise Time (-ve)

Fall Time (-ve)

Rise Time Result

Fall Time Result

Rise Time (-ve) Image

Rise Time (+ve) Image

(
Rise Time (+ve) Result
Rise Time (-ve) Result

Report Generator Printed Help Document for TDSET3
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Table 2-3: 100BASE-TX Application Fields (cont)

Options Sub menus

Fall Time (+ve) Result

Fall Time (-ve) Result

Fall Time (+ve) Image

Fall Time (-ve) Image

Rise and Fall Time Symmetry Rise/Fall Symmetry Result
Rise/Fall Symmetry (+ve)
Rise/Fall Symmetry (-ve)
Rise/Fall Symmetry (+ve) Result
Rise/Fall Symmetry (-ve) Result
(
(

Rise/Fall Symmetry (+ve) Image
Rise/Fall Symmetry (-ve) Image
Waveform Overshoot Overshoot (+ve)

Overshoot (-ve)

Waveform Overshoot Result
Positive Overshoot Image
Negative Overshoot Image
Overshoot (+ve) Result
Overshoot (-ve) Result

AOI Template AOI Template Test Result
AQOI Template Image
Duty Cycle Distortion Distortion (Duty Cycle)

Distortion (Duty Cycle) Image

Distortion (Duty Cycle) Result

Test Result Summary

Jitter Transmitter Jitter (+ve) Image

Transmitter Jitter (-ve) Image

Transmitter Jitter (+ve)

Transmitter Jitter (-ve)

Transmitter Jitter (+ve) Result

Transmitter Jitter (-ve) Result

Transmitter Return Loss Return Loss (1MHz - 100MHz), Image, Result
Receiver Return Loss Return Loss (1MHz - 100MHz), Image, Result
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The following table lists the options and submenus for 1I0BASE-T. You can drag
and drop any of these fields.

Table 2-4: 10BASE-T Application Fields

Options Sub menus

Configuration Parameters

Signal Source

Source - Return Loss Probe 1

Source - Return Loss Probe 2
Acquisition Mode

# Averages

Harmonic — Output

Harmonic — # Averages

Harmonic — Time Scale

Output Waveform Return Loss
Output Waveform 0dB Marker
Return Loss — Load

Return Loss — # Averages

Return Loss — Smooth

Templates
100 ohm w/o TPM
Load 1 w/o TPM
Link Pulse Load 2 w/o TPM Head Image, Tail Image, Result, Test Result

100 ohm with TPM Summary
Load 1 with TPM
Load 2 with TPM
Internal Normal

Internal Inverted
MAU Image, Mask Scale, Result, Test Result Summary

External Normal

External Inverted
100 ohm w/o TPM
Load 1 w/o TPM
Load 2 w/o TPM Head Image, Tail Image, Result, Test Result
100 ohm with TPM Summary

Load 1 with TPM
Load 2 with TPM

TP_IDL
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Native Fields

2-10

Table 2-4: 10BASE-T Application Fields (cont)

Options Sub menus
Parametric
With Cable
Normal
8BT Jitter Image, MAU Type, Spec Range, Value, Result
Jtter 8.5BT Jitter
Without Cable
Normal
8BT Jitter Image, MAU Type, Spec Range, Value, Result
8.5BT Jitter
Peak Diff Voltage Image
Min Pos Peak Diff Voltage
Peak Diff Volt Max Pos Peak Diff Voltage
Min Neg Peak Diff Voltage
Max Neg Peak Diff Voltage
Result
Harmonic of all ones Image
Fundamental
Harmonic Harmonic 2 - 25
Harmonic of all ones Result
Spec Range
Transmitter Return Loss (5MHz), Return Loss (10MHz), Image,
Return Loss Result
Receiver Return Loss (5MHz), Return Loss (10MHz), Image,
Return Loss Result
CM Voltage Image, Result, Value

You can enhance the report using the following parameters from the Native fields
— Static Text, Rectangle, Line, Logo, Table, Date, and Time.

You can drag any fields from the Native field and drop it in the active template.
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Static Text

1. From the Native fields, drag and drop the static text.

Edit Text

Palette String : | Static: Text

2. In the Edit Text dialog box,

" Click .

®  Inthe Virtual Keyboard, select the text and select Enter.
3. Click OK.

Rectangle
From the Native Fields, drag and drop the Rectangle into the Active Template.
&
SN
The black squares that appear at the corners of the rectangle allow you to
increase the size.

Line

From the Native Fields, drag and drop the Line into the Active Template.

— =

The black squares that appear at the corners of the line allow you to increase the
size.
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2-12

Logo

1. From the Native Fields, drag and drop the Logo into the Active Template.

Edit Image

Falette String : | Logo |

2. In the Edit Image dialog box,

= Select .

®  Inthe Virtual Keyboard, enter the path and filename and select Enter.
Or

®  Select Browse to navigate to the location where the image is available.
3. Click OK.
Table
1. From the Native Fields, drag and drop the Table into the Active Template.

Edit Table

Mumber of Fows : .

HummﬂdEmmmm:ElIEH

2. Inthe Edit Table dialog box, you can select the number of rows and
columns.

®  Select next to Number of Rows and Number of Columns to edit the
number.

®  Inthe Virtual Keyboard, enter the number and select Enter.
3. Click OK.
Date and Time

From the Native fields, drag and drop the Date and Time.
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Oscilloscope Fields

These fields are grouped into ten different groups:

Waveform Group: The Waveform group has all the active live channels and
independent channels (only CH1 to CH4) waveforms in both jpeg and bmp.
These waveforms are generated to smoothen out the stair-step effect seen on the
display.

Vertical Group: The Vertical group has all vertical related fields such as the
vertical scale, position, offset, and others.

Horizontal Group: The Horizontal group has all horizontal related fields such as
the horizontal divisions, scale, record length, position, sample rate, and others.

Math Group: The Math group has all the math related fields such as the math
definition for a specified math channel, magnitude, spectral gate, spectral phase,
spectral window, spectral frequencies of the math channel, and others.

Trigger Group: The Trigger group has all trigger related fields such as the
trigger type, mode, level, and various fields related to different trigger types.

Measurement Group: The Measurement group has all the measurements such
as the eight automated measurements and the immediate measurements.

Acquisition Group: The Acquisition group has all acquisition related fields such
as the acquisition mode, acquisition state, repetitive mode, fast acquisition mode,
and others.

Cursor Group: The Cursor group has all the cursor related fields such as the
cursor mode, source, state and type of the cursor, H Bars, V Bars, and others.

Zoom Group: The Zoom group has all zoom related fields such as the zoom
horizontal position, horizontal scale, and others.

Histogram Group: The Histogram group has all histogram fields such as the co-
ordinates of histogram box. mode, size, source, and others.

Screen snapshot: The Screen Snapshot group has two variations: one in color
and the other in black-and-white. For these images, the attributes are graticule,
ink-saver, and jpeg.
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Menus

2-14

Table 2-5: Template Editor | File menu

Menu selection Description

New Creates a new template.

Open Opens a template file.

Close Closes the active template.

Save Saves changes to the file.

Save As Saves the template to a different file name using the Save as dialog
box.

Print Prints all or part of the contents of the active template.

Print Preview Displays a sample view of the active template as it would be printed.

List of recent Opens a previously (recent) opened template.

templates

Exit Closes the Template Editor.

Table 2-6: Template Editor | Edit menu

Menu selection

Description

Cut Cuts the selected fields.

Copy Copies the selected fields.

Paste Pastes the clipboard content.

Delete Deletes the selected fields.

Select All Selects all the fields.

Create Custom Group Creates a custom group.

Edit Custom Group Edits the custom group.

Change Template Size | Changes the template size.

Find Finds the data matching the search criteria.

Replace Replaces the data matching the search criteria with the specified

data.

Table 2-7: Template Editor | View menu

Menu selection

Description

Toolbar Displays/Hides the toolbars selected such as Standard, Align Size,
Layout, and Action.

Status Bar Displays/Hides the Status bar.

Palette Bar Displays/Hides the Palette bar.

Grid Lines Displays/Hides the Grid Lines in the client area.
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Table 2-8: Template Editor | Object menu

Menu selection

Description

Bring To Front Brings the selected fields to front.

Send To Back Sends the selected fields to back.

Hide Text / Show Text Shows or hides the caption of the selected parameter.

Position Caption on Positions the caption of the selected parameter to left or on top.

Top/to the Left

Edit Caption Allows you to edit the caption of the selected parameter.

Change Font Allows you to change the font of the selected parameter or the
caption using the Change Font dialog box.

Align Fields Aligns fields to top, bottom, left, or right.

Make Same Size

Resizes the selected objects to the same size by height, width, or
both.

Table 2-9: Template Editor | Window menu

Menu selection

Description

New Window Opens a new window duplicating the current active window.

Cascade Arranges the open templates in the client area from the upper, left
side to lower right side so that they overlap one another.

Tile Arranges the open templates horizontally and vertically in the

application client area without overlapping.

Arrange Icons

Arranges the icons of any templates you have minimized to the
bottom-left of the window.

List of open templates.

Allows you to jump to another open template.

Table 2-10: Template Editor | Help menu

Menu selection

Description

Help Topics

Displays the online help.

About Template Editor

Displays version and copyright information.
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Toolbars

The Template Editor has the following toolbars. You can choose to display or
hide these toolbars using View > Toolbars.

Standard View > Toolbar > Standard
toolbar

Enable the Standard Toolbar by selecting it in the View > Toolbar menu.

EH| BB oS %ES Y

l Prints the active template.
Displays a sample view of the active ternplate as it would be printed.
Changes the text of the selected field.

Changes the text of the selected field either to the top or to the left.

Show or Hide the caption text of the selected field.
L 3

Sends the selected object behind.

Brings the selected object front.
Y

Deletes the selected pararneter or field in the template.

Inserts the clipboard contents.

Copies the selected parameter or field to the clipboard,

Cuts the selected parameter or field and puts in the clipboard.

L
Saves the active template.

Opens a template file,

Creates a new template file,

Align/Size View > Toolbar > Align/Size
toolbar

Enable the Align/Size Toolbar by selecting it in the View > Toolbar menu.

o+ +0] og
o+ —+0| &+

IED]BEI

Resizes the selected field to have the same height as the dominant field.

4
oo
Resmes the selected field to have the same size as the dominant field.
Resizes the selected field to have the same width as the dominant field,

Aligns the bottorn edge of the selected fields with the dominant field,

L J

Aligns the top edge of the selected fields with the dominant field.

Aligns the right edge of the selected fields with the dorinant field.

Aligns the left edge of the selected fields with the daminant field.
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Layout View > Toolbar > Layout
toolbar
Enable the Layout Toolbar by selecting it in the View > Toolbar menu.

OB H

1 Changes current template size to four tests per page.
Changes current ternplate size to two tests per page.

Changes current ternplate size to one test per page.

Action View > Toolbar > Action
toolbar
Enable the Action Toolbar by selecting it in the View > Toolbar menu.

e Layout | gx Done

1 Prompts to save documents and quits the application,
Closes the application and opens Report Layout Editor,

The Layout button also prompts to save documents.

Status bar

The Status bar displays the application status and tool tips for selected options.

Using Template Editor

To create a new template:
1. From the Palette List, drag and drop the fields that you want in the report.

2. Ifyou drag and drop a group from the Palette List, all the fields within the
group are placed in the active template.

3. Organize the fields as you want them to appear in the report.

4. After you have finished creating the template, select File > Save.
To edit an existing template:

1. Organize the fields as you want them to appear in the report.

2. From the Palette List, drag and drop the fields that you want in the report.

Report Generator Printed Help Document for TDSET3 2-17



About Template Editor

3. Ifyou drag and drop a group from the Palette List, all the fields within the
group are placed in the active template.

4. Organize the fields as you want them to appear in the report.
After you have finished editing the template, select File > Save.
®  You can create custom group, edit custom group, and change template size.

®  You can also edit caption, change font, align fields, and make selected fields
same size.

Creating Custom Edit > Create Custom Group
Groups
You can create custom groups using any fields from the Palette List.
1. Select Edit > Create Custom Group.

Create Custom Group - Step 1 of 2

Enter Group Mame :

2. In the Create Custom Group dialog box, enter the group name. You can
enter the group name using the Virtual Keyboard.

3. Click Next. The Select Fields dialog box displays the fields of Palette List.

5elect Fields - S5tep 2 of 2

; [=- Jitter
- 1000BASE-T
B T00BASE-TX kPl Jitter with Cable T
=l 10BASE-T k-Pk Jitter without Cabl

- Corfigure Add Al k-Fk Jitter without Cabl

& Templates
-- Peak Diff Vol
[=1-Witter
L PhPh itter with Ce
o PP Jitter with C2
i PhePle Jitter without

Lo Pl-Ple itter withfiﬂ
»

4. Using Add>>, Add All, <<Remove, or Remove All, you can select the fields
you want to include in the new group. Then, click Finish.
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Editing Edit > Edit Custom Group
Custom Groups
You can edit custom groups.
1. Select Edit > Edit Custom Group.

Edit Custom Group - S5tep 1 of 2 E3

. group to Edit
| 1D0BASE-T A

g SE-T .Jitter
Pt. & Template

2. In Edit Custom Group dialog box, select a group to edit.

3. Click Next.

Select Fields - Step 2 of 2

Mative Fields

- 1000BASE-T
B 100BASE-TX
- 10BASE-T

Add All
Peak Diff Walt
t << Remave
(= Jitter _
i Pk-Pk Jitter with Cz
PPk Jitter with e Remove Al

PPl Jitter without
o PhAPl Jitter without
3

PPl Jitter with Cable
kP Jitter with Cable T
kPl Jitter without Cabl
kPl Jitter without Cabl

4. In Select Fields dialog box, select the fields you want to add or remove from
the group using Add>>, Add All, <<Remove, or Remove All.

5. Click Finish.
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Deleting Edit > Edit Custom Group
Custom Groups
You can delete custom groups.

1. Select Edit > Edit Custom Group.

Edit Custom Group - Step 1 of 2

Select group to Edit

100BASE-T AL
STOBASE-T Jitker
Pt. & Template

2. In Edit Custom Group dialog box, select a group to delete.

3. Click Delete. A message box appears asking you to confirm your choice.

4. Select Yes to delete.

Change Template Size Edit > Change Template Size
You can change the size and page setup for a template.

1. Select Edit> Change Template Size.

Change Template Size
Templa
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2. Inthe Change Template dialog box,
3. Select the Template Size as 1/4 page, 1/2 page, or Full page.

4. If the printer is not available, select the Page Size as Default (8.5" x 11");
otherwise, select Configure Page.

Page Setup

®¥ Landscape Top: m Eottom: m

5. In Page Setup dialog box, select the paper size, source, orientation, and
margins.

6. Click OK to return to Change Template Size dialog box.
7. Click OK.

Note: Do not reduce the template size beyond the content filled in the template.
You may lose information.

Select All Edit > Select All
To cut, copy, or delete the fields from the active template, you need to select the

fields. You can also select the fields from the active template by clicking
CTRL+ selecting the fields.
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Find Edit > Find
You can search for text in the active template.

1. Select Edit > Find.

Find

Cancel

2. In Find dialog box, enter the search string using the Virtual Keyboard.

3. Select Find Next until you find the required search string.

Replace Edit > Replace
You can search and replace the text in the active template.

1. Select Edit > Replace.
Find

Cancel

2. InReplace dialog box, enter the search string using the Virtual Keyboard in
the Find what field.

3. In Replace with field, using the Virtual Keyboard, enter the replacement
string.

4. Select Find Next until you find the required search string.

5. Select Replace to replace one instance of the string.
or
Select Replace All to replace all instances of the string.

6. Click Cancel after you have replaced the strings.
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Bring To Front

Send To Back

Show/Hide Text

Position Caption

Editing Caption

Change Font

Object > Bring To Front

You can bring the selected fields to the front.

Object > Send To Back

You can send the selected fields to the back.

Object > Show/Hide Text

You can show or hide the captions for the selected fields.

Object > Position Caption to the Left, or on Top

You can position the caption of the selected fields on either the left or on the top.

Object > Edit Caption
You can edit the caption of the selected parameter or object.

1. Select Object > Edit Caption.

E dit Caption

Palette Sting : [AOQ] Template Image

Captian :

2. In Edit Caption dialog box, select to enter the caption using the Virtual
Keyboard.

3. Click OK.

Object > Change Font
You can change font for the selected field in the template.
1. Select the fields or fields in the active template.

2. Select Object > Change Font or right-click the field to display the options.
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Font style:

R eqular

B Tempus Sans ITC
Terrminal
H Thickhead
Times Mew Faman
T Typewriter

Sample

- oLt
W Undeiline AaBbYyZz

Coalar:

3. Inthe Font dialog box, choose the font size, color and style, and effects.

4. Click OK.

Align Fields Object > Align Fields
You can align the fields to top, bottom, left, or right.
1. Select the fields in the active template.
2. Select Object > Align Fields > Top, Bottom, Left, or Right to align the fields
accordingly.
Make Same Size Object > Make Same Size
You can set the selected fields to same height, width, or both.
1. Select the fields in the active template.

2. Select Object > Make Same Size > Height, Width, or Both to make the
selected fields the same size.
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Report Layout Editor

About Report Layout Editor

The Report Layout Editor helps you define the report layout for generating
reports. The report layout, once created can be reused for generating multiple
reports.

You can select the number of test templates per page and position the templates
in the report. The report can have multiple pages with different template sizes.
Each template is a subreport with a unique test title. This unique test title helps
you select the required template when generating a report. You can define
headers and footers for the report layout.

To display the Report Layout Editor, select Define Report Layout > New

Report Layout.
10007 _rpl - Report Layout HEE
Eile Edit iew Lawout Page Help
% % % % | R Template | [ Preview | & Done
Feport Layout
Header - Click to Modif
1 3

List of Templates

C:ATekApplications', Tdeet2 \Re

Template File | Template Size « - 1

1000 Peak Volt.. 172 Page Test Title: Test Title:

1000 Peak Yol . 1/2 Page ITempIate Pt E ITempIate PLE E

1000 Template ... 1/4 Page

1000 Template ... 1/4 Page Template File:
IE:\TekﬂppIications\

Template File:
IC:\T ekapplications'.

1000 Template ... 144 Page
1000 Template ... 1/4 Page
1000 Template ... 1/4 Page
1000 Template ... 144 Page

2 4
4]

Test Title: Test Title:

ITempIate FtC E ITempIate FtD E

Template File:
IE:\T ekApplications’.

Place ot Tile »»
<< Clear Tile

Template File:
|1 000 Template Pt F.r

Footer - Click bo Modify

The Report Layout Editor window has two panes:

List of Templates: Displays a list of templates, template sizes, template folders,
and buttons that allow you to clear or place a template in a report layout tile and
to create new templates.

Report Layout: Displays the selected report layout and the header, footer
definition.
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Table 3-1: Report Layout Editor Default Settings

Parameter Selection Default setting

Report Layout Layout Four tests per page

Page Size Page Setup 8.5 x 11inches

Layout Editor None One page

Go to Edit Displays the current page number in the page layout
Font None Arial > Regular 9

Default Margin Size None Margin size on all sides of the paper is 0.8 inches

Report Layout Editor Window

The Report Layout Editor window comprises a menu bar, a tool bar, a list of
templates pane, and a report layout pane.

1000T.rpl - Report Layout HEER
File Edit “iew Layout Page Help
- | B Template | [\ Preview | &5 Done
Report Layout
Header - Click ta Modify
1 3

Template File | Template Size - T
1000 Peak Valt.. 172 Page Test Tile: Test Title:

1000 Peak Volt.. 1/2 Page [Tempiate P& E [Template Pt B E
1000 Template ... 1/4 Page
1000 Template .. 1/4 Page Template File: Template File:
::ggg EEE:::: ::::i E:g: IE:\TekAppIications\ IC:\TekAppIications\
1000 Template ... 1/4 Page
1000 Template ... 1/4 Page

z 4
Test Title: Test Title:
ITempIate PtC E ITempIate PtD E

Template File: Template File;

Flace on Tile »» |1 000 Template Pt F.r IC:\TekAppIications\
<< Clear Tile

Footer - Click to Modify
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List of Templates pane The List of Templates pane displays the path of the template, templates in the
folder, file names, and template sizes. You can select the template from this list
and place it in the Report Layout pane.

Ligt of Templates

CATekdpplications Tdset “Re

Template File | Template Size
10 Baze T.rgt 1/4 Page
10 Link Pulze T... 1/4 Page
10TP_IDL Te.. 1/4Page
100 A0 Templ... 1/2 Page
100 Differential ... 1/2 Page
100 Rize and F...  1/2 Page
100 Rize and fa... 1/2 Page

100 Signal Amp... 1/2 Page
100w aveform ... 1/2 F'au:lEi

al

Place an Tile »>

¢4 Clear Tile

In the List of Templates pane, you can do the following:

B Select a different path where you have saved the customized templates by
using the Virtual Keyboard or clicking the Directory button that displays a
Browse for Folder window.

B (Create a new template by selecting New. The Template Editor Window is
displayed, where you can create a new template.

®  Drag and drop the Template File into the report layout pane's tile or select
the template file and click Place on Tile >>.

®  Clear the selected tile in the report layout pane by clicking << Clear Tile.

Report Generator Printed Help Document for TDSET3 3-3



Report Layout Editor

Report Layout pane Depending on the number of tests selected per page, the Report Layout pane
appears as shown by the following figure:

Menus

Feport Lapout
Header - Click to kodif

1 3
Test Title: Test Title:

[FTH E [FD

Template File: Template File:

]

|1nnu Template PtH. |1nun Template Pt D.

2 4

Test Title: Test Title:

[FrF E [Fr.d

Template File: Template File:

]

|1nnu Template PtF 1 |1nun Template Pt C.

Footer - Click to Modify

In the Report Layout pane, you can do the following:

" Specify a title for each test.

®  Define or modify the header and footer.

®  Navigate between pages of the report layout.

Table 3-2: Report Layout Editor | File menu

Menu selection

Description

New Creates a new report layout.

Open Opens a report layout file.

Save Saves changes to the file.

Save As Saves the report layout to a different file name using the Save as
dialog box.

Page Setup Prints all or part of the contents of the active template.

Configure Page Configures the paper size, source, orientation, and margins

using the Page Setup dialog box.

Default (8.5” x 11")

Configures the page setup to default — 8.5" x 11"

Layout Preview

Displays a sample view of the active report layout as it would be
printed.

List of recent report layouts

Opens a previously (recent) opened report layouts.

Exit

Closes the Report Layout Editor.
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Table 3-3: Report Layout Editor | Edit menu

Menu selection

Description

GoTo

Goes to the page entered in the Go To Page dialog box.

Table 3-4: Report Layout Editor | View menu

Menu selection

Description

Toolbar Displays or Hides the selected toolbars such as Standard, Page,
Layout, and Action.

Status Bar Displays or Hides the Status bar.

Refresh Template List Refreshes the Template list in the List of Templates pane.

Table 3-5: Report Layout Editor | Layout menu

Menu selection

Description

One Test Per Page

Changes the report layout to fit one test per page.

Two Tests Per Page

Changes the report layout to fit two tests per page.

Four Tests Per Page

Changes the report layout to fit four tests per page.

Table 3-6: Report Layout Editor | Page menu

Menu selection

Description

Insert Blank

Before Current Page

Inserts a blank page before the current page.

After Current Page

Inserts a blank page after the current page.

Insert Copy

Before Current Page

Inserts a copy of the current page before the current page.

After Current Page

Inserts a copy of the current page after the current page.

Delete

Deletes the current page.

Table 3-7: Report Layout Editor | Help menu

Menu selection Description

Help Topics Displays the online help.

About Report Layout Displays version and copyright information.
Editor

Report Generator Printed Help Document for TDSET3 3-5



Report Layout Editor

Toolbars

The Report Layout Editor has the following toolbars. You can choose to display
or hide these toolbars using View > Toolbars.

Standard View > Toolbars > Standard
toolbar

Enable the Standard Toolbar by selecting it in the View > Toolbars menu.
0=

}

Saves the report layout file,
Qpens a report layout file,

Creates a report layvout file,

Layout View > Toolbars > Layout
toolbar

Enable the Layout Toolbar by selecting it in the View > Toolbars menu.

[m=heE

!

Changes the report layout to fit four tests per page.
Changes the report layout to fit two tests per page.

Changes the report lavout to fit one test per page.

Page View > Toolbars > Page
toolbar

Enable the Page Toolbar by selecting it in the View > Toolbars menu.
HEEB|K

|

Deletes the current page.

Inserts a copy of the current page after the current page.

Inserts a copy of the current page before the current page.

Inserts new page after the current page.
L

Inserts new page before the current page.
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Action View > Toolbars > Action
toolbar
Enable the Action Toolbar by selecting it in the View > Toolbars menu.

Templatel [ Preview | g Done

l Prompts to save the report layout and guits the Report Layout Editor,
Displays a sample view of the active report layout as it would be printed.

Closes the Report Layout Editor and opens the Template Editar,

Using Report Layout Editor

To define a report layout, perform the following steps:
1. Set the report layout.

®  Select Layout > One Test Per Page / Two Tests Per Page / Three
Tests Per Page. The Report Layout pane displays tiles depending on
the selected number of tests per page.

2. Add the templates.

®  The List of Templates pane displays the templates in the default
directory —C:\TekApplications\TDSET3\ReportGenerator\Templates.

®  From the List of Templates pane, drag and drop the templates into the
tiles in the Report Layout pane. You can use the Place on Tile and
Clear Tile buttons to move the templates to the tiles and to clear the
tiles.

®  Ifyou want to define a new template, select New in the List of
Templates pane.

®  To browse for a different folder other than the default templates, select
Directory to display Browse for Folder dialog box. Navigate to the
folder where you have the templates stored and select OK.

3. Define Header and Footer.
4. Save the report layout.

®  Select File > Save to display the Save dialog box. Enter the report
layout name and select Save.

®  The report layout is saved in the .rpl format.
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To edit an existing report layout, perform the following steps:
1. Change the report layout.

®  Select Layout > One Test Per Page / Two Tests Per Page / Three Tests
Per Page. The Report Layout pane displays tiles depending on the
selected number of tests per page.

®  The application displays an alert message — All the Test(s)
information in the current page will be lost. Do you want to continue?

B Select Yes to continue or No to stop.
2. Add or Remove the templates.

®  In the Report Layout pane, select the tile to which you want to add or
remove the template.

®  To remove a template from the Report Layout, complete the following
steps:

®  Inthe List of Templates pane, select Clear Tile.

®  The application displays an alert message — The test is already
filled with data. Do you want to remove it?

B Select Yes to continue or No to stop.
3. To add a template to the Report Layout, complete the following steps:

®  The List of Templates pane displays the templates in the default
directory —C:\TekApplications\TDSET3\ReportGenerator\Templates.

"  From the List of Templates pane, drag and drop the templates into the
tiles in the Report Layout pane. Select the Place on Tile button to move
the template to the selected tile.

®  Ifyou want to define a new template, select New in the List of
Templates pane.

B To browse for a different folder other than the default templates, select
Directory to display the Browse for Folder dialog box. Navigate to the
folder where you have the templates stored and select OK.

4. Modify Header and Footer.
5. Save the report layout.

" Select File> Save to display the Save dialog box. Enter the report
layout name and select Save.
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The report layout is saved in the .rpl format.

Note: Each report can only have up to five pages.

Configure page File > Page Setup > Configure Page

You can configure the paper size, source, orientation, and margins.

Page Setup

Source: Upper tray el

o Partrait

® Lar

After you have configured the page setup, select OK.

Go To Page Edit> Go To

You can go to different pages in the report layout using the Go To Page dialog
box.

Go To Page E

Enter Page Murber;

1. Inthe Enter Page Number field, enter the page number or select to
display the Virtual keyboard.
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2. Select Go To. The Report Layout pane displays the relevant page.

Change Report Layout Layout > One Test Per Page / Two Tests Per Page / Four Tests Per Page

You can change the report layout to fit one, two or four tests per page.
[m]=h=

!

Zhanges the report layout to fit four tests per page.
Changes the report lavout to fit two tests per page.

Changes the report lavout to fit one test per page.

Header/Footer Definition To modify Header Definition, do the following:

1. In the Report Layout pane, click Header - Click to Modify.

Header/ Footer Definition

H

Header Center
Header Right
Footer Left
Faater Center
Footer Right

2. Inthe Header/Footer Definition dialog box, select the header position -
Header Left, Header Center, or Header Right.

3. Enter the Header definition in the text box.
Select to display the Virtual Keyboard. In the Virtual Keyboard, select
the text and select Enter.
or

To insert the special text, select the Insert Special Text button to display a

submenu. Select Date, File Name, Author, Page X of Y, Page X, or Logo.

4. Select Set Font to change the font style, size, effects, color, and script for
each field separately, then select OK.

5. In the Header/Footer Definition dialog box, select OK.
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To modify Footer Definition, do the following:

1. In the Report Layout pane, click Footer - Click to Modify.

Header/ Footer Definition

Header Right

Footer Left
Faater Center
Footer Right

2. Inthe Header/Footer Definition dialog box, select the footer position -
Footer Left, Footer Center, or Footer Right.

3. Enter the Footer definition in the text box.

Select to display the Virtual Keyboard. In the Virtual Keyboard, select
the text and select Enter.

or

To insert the special text, select the Insert Special Text button to display a
submenu. Select Date, File Name, Author, Page X of Y, Page X, or Logo.

4. Select Set Font to change the font style, size, effects, color, and script for
each field separately, then select OK.

5. In the Header/Footer Definition dialog box, select OK.

Insert Pages Sclect Page > Insert Blank > Before Current Page / After Current Page to
insert a new page before the current page or after the current page.

Select Page > Insert Copy > Before Current Page / After Current Page to
insert copy of the current page before the current page or after the current page.

Note: When you insert a copy of a page before or after the current page, the
layout of the current page is the same layout as the new page.
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Report Viewer

About Report Viewer

Report Viewer Window

The Report Viewer allows you to view the generated report.

Under the Generate Report tab, select Load Report or Generate Report to
display the Report Viewer and browse for the report that you want to view or
generate.

The Report Viewer window comprises a menu bar, a toolbar, an align/size bar,
and a client area.

g Droop_Point) rpt - Report Viewer
File Edit “iew Object Help

Sl RS RREAYS A|RS]FEE %= @

40.6.1.2.2: 1000 Base-T Maximum Qutput Droop Point J B
: | |
Spec Range: Magnitude of Point J Peak Value > 73.1%, of Point H Peak Value.
Limit: 73.1%, of Point H Peak Value
Foint H Peak Point J Peak Limit Test Results
1.06Y 1.0% F74.26mY Fassed
[« | ;I_I
Ready Page3of& |  [MUM Z
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Menus
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Table 4-1: Report Viewer | File menu

Menu selection Description

Open Opens a template file.

Save Saves changes to the file.

Save As Saves the template under a different file name using the Save as
dialog box.

Print Prints all or part of the contents of the active template.

Print Preview

Displays a sample view of the active template as it would be
printed.

Print Setup Prompts you to set up the printer.

Export to RTF Exports the report in .rtf (rich text format).

List of recent templates Opens a previously (recent) opened template.
Exit Closes the Report Viewer.

Table 4-2: Report Viewer | Edit menu

Menu selection

Description

Cut

Cuts the selected fields and places it on the clipboard.

Copy Copies the selected fields to the clipboard.

Paste Pastes the clipboard content.

Delete Deletes the selected fields.

Select All Selects all the fields.

Add Text Field Adds a text field to the report.

Find Finds the data matching the search criteria entered.

Replace Replaces the data matching the search criteria with the specified data.
Go To Goes to the page number specified in the Go To Page dialog box.

Table 4-3: Report Viewer | View menu

Menu selection

Description

Toolbar Displays/Hides the Standard toolbar.
Align/Size Bar Displays/Hides the Align/Size toolbar.
Status Bar Displays/Hides the Status bar.
Separators Displays/Hides the separators.
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Table 4-4: Report Viewer | Object menu

Menu selection

Description

Bring To Front Brings the selected field to front.

Send To Back Sends the selected field to back.

Hide Text / Show Text Shows or hides the caption of the selected field.

Position Caption on Positions the caption of the selected field to left or on top.
Top/to the Left

Edit Text Allows you to edit the text in the selected field.

Change Font

Allows you to change the font of the selected field or the caption
using the Change Font dialog box.

Align Fields

Aligns fields to the top, bottom, left, or right.

Make Same Size

Resizes the selected fields to the same size by height, width, or
both.

Table 4-5: Report Viewer | Help menu

Menu selection Description

Help Topics Displays the online help.

About Report Viewer Displays version and copyright information.
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Toolbars

The Report Viewer has the following toolbars. You can choose display or hide
these toolbars using View > Toolbars.

Standard View > Toolbars > Standard
toolbar

Enable the Standard Toolbar by selecting it in the View > Toolbars menu.

DSH|$ 2@ | EHS%

=7

l trints the active template.
Displays a sample view of the active template as it would be printed.
Changes the text of the selected field.
Changes the text of the selected field either to the top or to the left.

Show ar Hide the caption text of the selected field.

L 4

Sends the selected object behind.

L 4
Brings the selected object front.

L J
Celetes the selected parameter or field in the template.

Inserts the clipboard contents.

Copies the selected parameter or field to the clipboard.

Cuts the selected parameter or field and puts in the clipboard.

L 2
Saves the active termnplate.

COpens a template file.

L J
Creates a new template file,

Align or Size bar View > Align/Size bar

Enable the Align/Size Toolbar by selecting it in the View > Align/Size bar
menu.

S TR
1 Resizes the selected field to have the same size as the dominant field.

o | =
| \ Resizes the selected field to have the same height as the dominant field.

Resizes the selected field to have the same width as the dominant field.

Aligns the bottorn edge of the selected fields with the dominant field.

L J

Aligns the top edge of the selected fields with the dominant field.

Aligns the right edge of the selected fields with the dorminant field.

Aligns the left edge of the selected fields with the dorinant field.
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Status bar The Status bar displays the application status and tool tips for selected options.

Separators View > Separators

Using Report Viewer

Shows or hides the template separators.

To view a report

1. Select File > Open. The Open dialog box displays all the reports in the
default directory —
C:\TekApplications\TDSET3\ReportGenerator\Reports.

2. Select the report that you want to view and select Open.

3. The Report Viewer displays the selected report.

To edit text

1. Select Edit > Add Text Field. The Edit Text dialog box appears.

2. Inthe Text field, enter the text or click El to display the Virtual keyboard.
In the Virtual Keyboard, enter the text and select Enter.

3. Inthe Edit Text dialog box, select OK.

To find text

1. Select Edit > Find. The Find dialog box appears.

2. Inthe Find what field, enter the text or click El to display the Virtual
keyboard. In the Virtual Keyboard, enter the text and select Enter.

3. Inthe Find dialog box, select Find Next until you find that text that you are
searching for.

To replace text

1. Select Edit > Replace. The Replace dialog box appears.

2. Inthe Find what field, enter the text or click El to display the Virtual
keyboard. In the Virtual Keyboard, enter the text and select Enter.
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Export to RTF

Find

3. Inthe Replace with field, enter the text or click IE5] to display the Virtual
keyboard. In the Virtual Keyboard, enter the text and select Enter.

4. In the Replace dialog box,
®  Select Find Next to find the text that you are searching for.

" Select Replace to replace one instance of the text that you want to
replace.

®  Select Replace All to replace all instances of the text that you want to
replace.

®  Select Cancel to cancel the operation and close the dialog box.

You can select some objects and bring to front or send to back. You can
show/hide text, position caption to the left, or on top. You can edit text, or
change font. You can align selected fields or make the selected fields to same
size. You can export a report as an rtf.

File > Export to RTF

You can export a report as an .rtf (rich text format) file.

Note: Report Generator exports the report to a rtf file in a compressed format
ensuring the file size to be small. If you edit the RTF file using Microsoft Word
the file size may increase.

Edit > Find
You can search for text in the report.

1. Select Edit > Find.

Find

Cancel

2. In Find dialog box, enter the search string using the Virtual Keyboard.

3. Select Find Next until you find the required search string.
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Replace Edit > Replace
You can search and replace the text in the report.

1. Select Edit > Replace.

Find

Cancel

2. In Replace dialog box, enter the search string using the Virtual Keyboard in
the Find what field.

3. In Replace with field, using the Virtual Keyboard enter the replacement
string.

4. Select Find Next until you find the required search string.

5. Select Replace to replace one instance of the string.
or
Select Replace All to replace all instances of the string.

6. Click Cancel after you have replaced the strings.
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Bring To Front

Send To Back

Show/Hide Text

Position Caption

Editing Caption

Change Font

4-8

Object > Bring To Front

You can bring the selected fields to the front.

Object > Send To Back

You can send the selected fields to the back.

Object > Show/Hide Text

You can show or hide the captions for the selected fields.

Object > Position Caption to the Left, or on Top

You can position the caption of the selected fields on either the left or on the top.

Object > Edit Caption
You can edit the caption of the selected parameter or object.

1. Select Object > Edit Caption.

E dit Caption

Palette Sting : [AOQ] Template Image

Captian :

2. In Edit Caption dialog box, select to enter the caption using the Virtual
Keyboard.

3. Click OK.

Object > Change Font
You can change font for the selected field in the template.
1. Select the fields or fields in the active template.

2. Select Object > Change Font or right click the field to display the options.
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Font style:
Tek R eqular
T TekCondensed

B Tempus Sans ITC

Terrminal
H Thickhead

Times Mew Faman
T Typewriter

Elfigeit—————————————| pSEmlE

Wl Strikeout
W Undeiline AaBbYyZz

Coalar:

3. Inthe Font dialog box, choose the font size, color and style, and effects.

4. Click OK.

Align Fields Object > Align Fields
You can align the fields to top, bottom, left, or right.
1. Select the fields in the active template.

2. Select Object > Align Fields > Top, Bottom, Left, or Right to align the fields
accordingly.

Make Same Size Object > Make Same Size
You can set the selected fields to same height, width, or both.

1. Select the fields in the active template.

2. Select Object > Make Same Size > Height, Width, or Both to make the
selected fields the same size.
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Create or edit a test template

Utilities > Report Generator > Define Test Template
You can create a new test template or edit an existing template.

File Tests Resuts Utiiies Help TDSET3 B x|
Report Generator

Generate Feport

Edit Template

Ready @

To create a new test template:

1. Under the Define Test Template tab, select New Test Template.

2. The Template Editor window appears with an empty client area.

3. Create the template using the Palette list.

4. After you have completed creating a new test template, select Done.
To edit an existing test template:

1. Under the Define Test Template tab, select Browse.

Laak ir: Ia Templates j gl

10Baze T.rgt 100 Rize and fall time .rgt

10 Link Pulze Template Test Resultz.gt 100 Signal Amplitude S pmmetry, rgt
10 TP_IDL Template Test Reszult.rgt 100w aveform Overshoot. gt

100 401 Template.rgt 'IUDD Droop Pt Gurgt

100 Differential Sighal dmplitude.rgt 1000 Droop Pt.J gt

100 Rige and Fall Spmmetry.rgt 1000 Peak. Wollt Pt B.rgt

l
File name: || Open I
Files of type: I Template [*.rat) j Cancel |

[~ Open az read-anly

2
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2. The open window displays the existing factory default templates and
customized templates in
C:\TekApplications\TDSET3\ReportGenerator\Templates.

3. Select the template that you want to use and select Open.
4. Inthe Define Test Template tab, select Edit Template.

5. The Template Editor window appears with client area displaying the
selected template.

6. Edit the template using the Palette list.

7.  After you have completed editing an existing test template, select Done.

Define or edit a report layout

Utilities > Report Generator > Define Report Layout

You can create a new report layout or edit an existing report layout.

File Tests Resuls Utlities Help TDSET3 B x|
Report Generator

Diefine Test Template | Def L | Generate Report

Edit Report Layout

|

|Ready [ I

Edit Layout

To create a new report layout:
1. Under the Define Report Layout tab, select New Report Layout.

2. The Report Layout Editor window appears with an empty report layout
area.

3. Create the report by defining the report layout and dragging and dropping
the templates to the report layout area.

4. After you have completed creating a new report layout, select Done.
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To edit an existing report layout:

1. Under the Define Report Layout tab, select Browse.

Laok in: Iﬁ Layouts j gl

i b
1000-T [rizw).rpl
ADET000-T [rew).rpl

File name: 1007 new].rpl Open |
Files of ype: IF!epcurt Lapaut [*.rpl) | Cangel |

[~ Open as read-only

4

2. The Open window displays the existing factory default report layout and
customized report layouts in
C:\TekApplications\TDSET3\ReportGenerator\Layouts.

3. Select the report layout that you want to use and select Open.
4. In the Define Report Layout tab, select Edit Layout.

5. The Report Layout Editor window appears with report layout area
displaying the customized report layout and selected template files.

6. Edit the report layout using the List of Templates and defining the Report
Layout.

7.  After you have completed editing an existing report layout, select Done.
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Generate, print or view a report

Utilities > Report Generator > Generate Report
You can generate, print, or view a report.

File Tests Results Utiities Help TDSET3 BH x|
Report Generator

Define Test Template Define Repart Layout Generate Report

Flaaoi—

nort Prirk Report Load Report

Peady 0

To generate a report

1. Under the Generate Report tab, select Browse.

Lock ir: |E Reparts j ﬁl

1000T. ipt
100Tx.rpt
10T.rpt

File name: || Open I
Files of tupe: ITempIate[".rgt], Lapout(*.rpll, Repart{*.pt] j Cancel |

[~ Open as iead-only

Z

2. The Open window displays the existing reports in
C:\TekApplications\TDSET3\ReportGenerator\Reports.

3. Select the report that you want to generate and select Open.

4. Under the Generate Report tab, select Generate Report.
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template in
AT YaLr m

1000T Jitker b azter Filte
1000T Jitker b aszter Unfi
1000T Jitter M aster Llnfij

5. Inthe Assign Data to Report dialog box, select a test template in this report
to assign the current data from your measurement application.

6. Select Assign. The Report Viewer displays the report with current data from
the application. You can choose to export to the report in an rtf format.

To print a report

1. Under the Generate Report tab, select Browse.

Loak i Ia Reparts j ﬁl

1000T.rpt
1007, rpt
10T .rpt

File mame: || Open

Filez of twpe: ITempIate[*.rgt], Lapout[*.rpl], Repart]* rpt] j Cancel

[~ Open as jead-only

2. The Open window displays the existing reports in
C:\TekApplications\TDSET3\ReportGenerator\Reports.

3. Select the report that you want to print and select Open. The Report Viewer
displays the selected report with current data from the application.
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5-6

If the page settings do not match the page settings for the Report, a Page
Size Mismatch message box displays a message — The current page

settings do not match the page settings for the Report. Do you want to
continue?

®  (Click Yes to continue.
| ]

Click No to stop printing the report.

If the printer is available, the report is printed.
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Appendix A: Error Messages

Code

Error message

Description

Possible solution

Report Generator Interface Error Codes

741 Some installation files are missing or The Application FDB File path Uninstall the application and try
corrupted, try reinstalling the retrieved from registry is corrupted or | reinstalling.
application. The application will now invalid file path.
exit.

742 Some installation files are missingor | Application Id retrieved from registry Uninstall the application and try
corrupted, try reinstalling the is invalid. (<0) reinstalling.
application. The application will now
exit.

743 Some installation files are missing or | Application version is invalid. Uninstall the application and try
corrupted, try reinstalling the reinstalling.
application. The application will now
exit.

744 Some installation files are missing or Unable to spawn Report Viewer. Report Viewer executable file is
corrupted, try reinstalling the missing, or there might be resource
application. The application will now crunch if there are many applications
exit. running currently.

Try closing some of the other
applications. If this does not work,
then uninstall and reinstall the
application.

745 Internal initialization error. The The Memory Map File or The application was not closed
application will exit now. synchronization events for completely last time. A module

communication with RGScope are RGScope might be still running in the
already open. The application was background. Try closing it.

previously not shut down completely.

Try closing RGScope.

746 Some installation files are missing or Unable to spawn Oscilloscope RGScope file is missing, or there
corrupted, try reinstalling the Interface. might be resource crunch if there are
application. The application will exit many applications running currently.
now. Try closing some of the other

applications. If this does not work,
then uninstall and reinstall the
application.

747 Some installation files are missing or The application FDB File read failed. Uninstall the application and try

corrupted, try reinstalling the
application. The application will exit
now.
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Code Error message Description Possible solution

748 Some installation files are missing or The application FDB File read failed. Uninstall the application and try
corrupted, try reinstalling the The file may be read only. reinstalling.
application. The application will exit
now.

749 Some installation files are missing or The application name passed by the Uninstall the application and try
corrupted, try reinstalling the invoking application is not found in reinstalling.
application. The application will exit the registry.
now.

750 Some installation files are missing or Not able to spawn the Report Layout The Report Layout Editor executable
corrupted, try reinstalling the Editor. file is missing, or there might be
application. The application will exit resource crunch if there are many
now. applications running currently.

Try closing some of the other
applications. If this does not work,
then uninstall and reinstall the
application.

751 Some installation files are missing or Not able to spawn the Template The Template Editor executable file

corrupted, try reinstalling the
application. The application will exit
now.

Editor.

is missing, or there might be
resource crunch if there are many
applications running currently.

Try closing some of the other
applications. If this does not work,
then uninstall and reinstall the
application.

Report Layout Editor Error Codes

721 Some installation files are missing or
corrupted, try reinstalling the
application.

The application name passed by
invoking the application is not found
in the registry.

Try uninstalling and reinstalling the
application.

722 The Selected file is not a valid layout
for this application.

The layout belongs to some other
application.

The layout file being opened belongs
to an older application, may have
been uninstalled. It is not possible to
open a file belonging to another
application.

723 Layout file is not valid for the current
version of the Application.

The layout was created for some
other version of the application.

The opened layout file belongs to a
different version of the same
application, may have been
uninstalled. It is not possible to open
a file belonging to another version.

Template Editor Error Codes

761 Error in Initialization of Application.

The Dlls and application executables
are not properly installed.

Try uninstalling and reinstalling the
application.

762 Invalid Application Name.

Registry entries are not appropriate.

Try uninstalling and reinstalling the
application.

A-2
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Code Error message

Description

Possible solution

763 The Selected file is not a valid
template for this application.

The template belongs to some other
application.

The opened template file belongs to
a different version of the same
application, may have been
uninstalled. It is not possible to open
a file belonging to another version.

764 Template file is not valid for the
current version of the Application.

The template was created for the
some other version of the
application.

The opened template file belongs to
a different version of the same
application, may have been
uninstalled. It is not possible to open
a file belonging to another version.

765 A Group with the specified name
already exists.

User tried to create a custom group
with the same name as an existing

group.

Try using a different name than the
existing groups.

Oscilloscope Interface Error Codes

781 MFC initialization failed.

The MFC Dlls are not properly
installed.

Reinstall the application.

782 Error in creating or setting system
resource.

The system resources required for
communication are already open.

Close all application related
executables and try again.

783 RGScope already running.

RGScope.exe is already running on
the system.

Close RGScope and restart the
application.

784 Memory exception occurred +
<context specific message>

lllegal memory access.

Close the application and restart.

785 An Exception Occurred.

An unknown exception occurred in
the application.

Close the application and restart.

786 File Exception Occurred + <context Exception occurred while accessing Close the application and restart.
specific message> a file.
787 Error in acquiring window resources The application was not able to Close the application and restart.

+ <context specific message>

acquire windows resources such as
GDI objects.

788 Failed to connect to the
oscilloscope.

The application was not able to
connect to the oscilloscope. Make
sure the TekScope.exe is running.

If this does not solve the problem
reinstall the application.

789 Error querying registry.

The required registry key does not
exist or an error occurred while
getting it's value.

Close the application and restart. If
this does not solve the problem
reinstall the application.

790 Error in reading FDB file.

The FDB file does not exist or it may
be read-only.

Make sure the FDB file is present
and not read-only. If this does not
solve the problem reinstall the
application.

791 Invalid Frame received. Oscilloscope interface received an Close the application and restart.
invalid message from RG interface.
792 Error in allocating memory. Error in getting memory from the Quit one or more applications

system.

running on the system and restart
RGApp.
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Code Error message

Description

Possible solution

793 <context specific message>

Error in creating the jpeg file.

Ensure that the “temp” folder exists
and there is space on the hard disk.

Message boxes and dialogs in the user interface

701 Error initializing Report Generator. System resources cannot be If this does not work, then uninstall
allocated. Try closing some of the and reinstall the application.
other applications.

702 No valid file name was provided. This happens when no file name is Select a valid file.

selected in application for generating
areport.

703 <Path of the file selected>.
The template file name is invalid.

The reading of the template file fails.
This will happen if the application
fails to read the rgt file.

Select another valid template file.

704 <filename> is not a valid Report An invalid report layout was Select another valid layout file.
Layout. provided.
This happens if the application fails
to read the layout file.
705 <filename> is not a valid Report The layout is not valid for the Select another valid layout file for the

Layout file for the application.

application. This means that the file
was read properly but the application
and version for the rpl file does not
match the application.

application.

706 Invalid report file specified.

A file other than the Report
Generator file(s) is selected with the
extension (rpt rgt rpl) used by Report
Generator files.

Select another valid file.

707 Invalid file format. Other file types such as text are Select another valid file.
selected.
708 <filename> is not a valid report file The application name and version for | Select another valid report file for
for <AppName> the report file do not match that of that application.

application.

709 Unable to read the report file.

An exception occurs for a rpt file.

This happens if the application
cannot read the report .rpt file.

Select another valid report file for
that application.
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