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About TDSET3

TDSET3

Ethernet Compliance Test Software

Copyright @ 2008, Tektrani:, Inc. Al rights
resenred. TEKTROMLS and TEK ara
registered trademarks of Tektronix Inc. Tekironix

Figure 1-1: TDSET3 Splash Screen

The TDSET3 Ethernet Compliance Test Software tests the Ethernet 's physical
layer for — 1000BASE-T, 100BASE-TX, and 10BASE-T in compliance with
IEEE 802.3-2000 and ANSI X3.263-1995 standards. This version allows you to
test each speed for various fields such as:

1000BASE-T
Template

Peak Voltage

Droop

Jitter Master Filtered
Jitter Master Unfiltered
Jitter Slave Filtered
Jitter Slave Unfiltered
Distortion

Return Loss

Common mode Voltage

100BASE-TX

Template

Differential Output VVoltage
Signal Amplitude Symmetry
Rise Time

Fall Time

Rise / Fall Time Symmetry
Waveform Overshoot

Jitter
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Using Online Help

1-2

Duty Cycle Distortion
Return Loss

10BASE-T

Template MAU Ext
Template MAU Ext Inv
Template MAU Int
Template MAU Int Inv
Template Link Pulse
Template TP_IDL
Differential Voltage
Harmonic

Jitter with cable

Jitter without cable
Return Loss

Common mode Voltage

TDSET3 has a Report Generator tool that helps you create and print custom
reports.

TDSET3 also supports Remote GPIB commands.

Note: Use the Select All button to test all the parameters of the selected speed.

The TDSET3 online help serves as a reference for using the TDSET3 Ethernet
Compliance Test Software.

Contents: The Contents tab displays books and pages that represent the
categories of information in the online Help system.

Index: The Index tab displays a multi-level list of keywords and keyword
phrases. These terms are associated with topics in the Help system and direct you
to specific topics.

Search: The Search tab enables you to search for keywords in the Help system
and to locate topics containing those words. When the search is completed, a list
of topics is displayed so that you can select a specific topic to view.

Back and Forward: The Back and Forward buttons allow you to browse through
topics.

To print a topic: Select the Print button from the Help Topics menu bar.
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Printing from the Online Help

While using the online help, you can print topics and information from the
HTML Help viewer.

To print a single topic:

1. Find the topic in the Contents pane. Click Print.

2. Click Print the selected topic and click OK.

To print all topics in a selected TOC book:

1. Find the TOC book in the Contents pane. Click Print.

2. Click Print the selected heading and all subtopics and click OK.

Note: If topics include expanding or drop-down hotspots, click the hotspots to
display the information before you print.

Hotspot is a clickable text that displays additional information below the link.
Click on the hotspot text to show or hide the hotspot content.

Some online help topics have color in the examples of the displayed application.
If you want to print this type of topic on a monochrome printer, some

information may not print because of certain colors. Instead, you should print the
topic from the PDF (portable document format) file that corresponds to the online
help. You can find the file in the Documents directory on the Optional
Applications Software on Windows-Based Oscilloscopes CD-ROM.

Conventions

Online help uses the following conventions:

" When steps require a sequence of selections using the application interface,
the ">" delimiter marks each transition between a menu and an option. For
example, File > Minimize

= DUT refers to the device transmitting the signal to be tested
®  Two or more adjacent hyperlinks are separated with "|"

®  Hotspot is a clickable text that displays additional information below the
link. Click on the hotspot link to show or hide the hotspot content
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The application uses this convention:

®  Three dots "..." next to any menu item means that the dialog box that pops
up requires user input

Feedback

Tektronix values your feedback on our products. To help us serve you better,
please send us your suggestions, ideas, or comments on the application.

Direct your feedback via email to techsupport@tektronix.com or FAX at
(503) 627-5695 and include the following information. Please be as specific as
possible.

General information:
®  Instrument model number and hardware options, if any
®  Probes used

®  Your name, company, mailing address, phone number, FAX number,
email id

®  Please indicate if you would like to be contacted by Tektronix about your
suggestion or comments

Application specific information:
= Software version number

= Description of the problem such that technical support can duplicate the
problem

" The instrument setup file of the oscilloscope and the application is also
required to identify the problem

"  If possible, save the waveform on which you are performing the
measurement as a .wfm file

Note: To know the software version number, click Help > About in the
application.
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Information through the Web site

You can find information about this and other applications at the Tektronix Inc.
Web site, www.tektronix.com. Check this site for firmware updates and other
information about our application. You can download a free trial version of the
TDSET3 application that allows you a five-time trial.
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Getting Started

Compatibility

For information on oscilloscope compatibility, refer to the Optional Applications
Software on Windows-Based Oscilloscopes Installation Manual, Tektronix part
number 071-1888-00. The manual is also available as a PDF file.

Recommended Accessories

Differential Probes
= P6247 — 1.0 GHz Differential Probe
= P6248 — 1.5 GHz Differential Probe

®  P6330 — 3.5 GHz Differential Probe

Note: The P6247, P6248, and P6330 probes require the TPA-BNC adapter for
interface to DPO7000 series oscilloscopes.

= P7330 — 3.5 GHz Differential Probe (cannot be used with DPO7054,
DPO7104, and DPO7254 oscilloscopes)

= P7350 — 5.0 GHz Differential Probe (cannot be used with DPO7054,
DPO7104, and DPO7254 oscilloscopes)

Note: 10Base-T test without TPM and RL tests require P6247 and P6248 probes.
Two probes are required for Return Loss tests.

Active Probes

" P6243, and P6245 1 GHz or above depending on the oscilloscope (for
1000BASE-T lJitter tests)

®  TAP1500 (two probes needed for Slave Jitter Test and one probe for Master
Jitter Test)
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Note: P6243 or P6245 (two numbers of each are needed for Slave Jitter Test,
and one for Master Jitter Test). These require TPA-BNC adapter to DPO7000
series oscilloscopes.

Arbitrary Waveform Generator

" AWG410 — 200 MS/s, 16-Bit Arbitrary Waveform Generator
" AWG420 — 200 MS/s, 16-Bit Arbitrary Waveform Generator
" AWG430 — 200 MS/s, 16-Bit Arbitrary Waveform Generator
" AWG510 — 1 GS/s, 10-Bit Arbitrary Waveform Generator

" AWG520 — 1 GS/s, 10-Bit Arbitrary Waveform Generator

" AWG610 — 2.6 GS/s, 8-Bit Arbitrary Waveform Generator

" AWG710 — 4.0 GS/s, 8-Bit Arbitrary Waveform Generator

" AWG2021 — 250 MS/s, 12-Bit Arbitrary Waveform Generator (for
Disturbing Signal Generator)

= AWGT710B - 4.2 GS/s, 8-Bit Arbitrary Waveform Generator

Note: In the case of AWG 400 series, the 1000Base-T return loss test values after
98.5 MHz are extrapolated. Use AWG710 waveform files for AWG710B.

Probe Positioner

®  PPM100 Flexible Arm Probe Positioner
Differential Input Voltage of Differential Probes
" P6247 —+8.5V (+10)

" P6248 —+ 8.5V (+10)

" P6330—t2V

" P7330—+2V

" P7350 —+25V
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Requirements and Restrictions

Do not change the oscilloscope settings when the test is running. If you change
the settings when the test is running, the application may give abnormal test
results.

Prerequisites

TekVisa must be installed in the oscilloscope

A TDS7000/CSA7000/TDS6000 series oscilloscope with Firmware version
2.2.0 or later

A TDS7000B/CSA7000B oscilloscope with Firmware version 3.0.0 or later
A TDS5000B series oscilloscope with Firmware version 2.0.0 or later

A TDS6000B series ocilloscope with Firmware version 4.0.1 or later

A TDS6000C series oscilloscope with Firmware version 5.0.0 or later

A DPO7000 series oscilloscope with Firmware version 1.0.0 or later

For better and reliable results

Prior to running any test, calibrate the probes, and oscilloscope for Signal
Path Compensation®

Cable length between the DUT and the test fixture should not be more than
two inches

Use 500 waveforms for averaging 1000BASE-T

Use 64 waveforms for averaging, and 200000 samples for mask testing
10BASE-T or 100BASE-TX wherever applicable

Use 48 waveforms for averaging 10BASE-T harmonics

If the signal is not connected and the noise level is below 50 mV, the
application detects and gives a message as invalid signal

! To calibrate an oscilloscope, select Utilities > Instrument Calibration in the
oscilloscope menu bar and select the Calibrate button

Note: If you do not install the latest version (Version 2.2.0 or above) of TDS7000
or CSA7000 Firmware, the application will not test the mask related parameters.
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Remember

®  TDS5032B and TDS5052B are two-channel oscilloscopes. The drop-down
list for any Data, Ref, or Math sources displays only two channels

®  For 1000BASE-T Template test, the TDS5000B series oscilloscope displays
the horizontal scale as 4 ns

®  The two-channel oscilloscopes do not support the 1000BASE-T Jitter Slave
Filtered test

®  The TDS6000B and TDS7000B series oscilloscope do not support Flash
Hits

About the Test Fixture

The TF-GBE test fixture, designed by Tektronix and manufactured and
distributed by Crescent Heart Software, facilitates 1000BASE-T, 100BASE-TX
and 10BASE-T Ethernet compliance testing when used with an appropriate
supported oscilloscope and Tektronix TDSET3 Ethernet Compliance Test
Software.

For more information, visit Crescent Heart Software Web site www.c-h-s.com.

Starting the Application

1. From the oscilloscope menu, select File > Run Application > Ethernet
Compliance Test Software or Analyze > Ethernet Compliance Test Software.
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File  Edit  Wertical Horizfacqg  Trig  Display  Cursors  Measure  Masks  Math Utilities  Help
0311

Reference Waveforms 3
Instrument Setup. ..
Recall Default Setup

Run Application

Page Sekup...
Prink Preview
Print. .. Chrlp

Power Measurements 2

Export Setup, .,
Select Far Export 3
Expart...

1 TDSSetup. set

Ilinimize Chrl+1

Shutdown...

Figure 2-1: Run Application

2. The splash screen appears. The oscilloscope display resizes to fit the upper
part of the screen and the lower part of the oscilloscope screen displays the
TDSET3 application.

File Tests Results Ltiities Help TDSET3 B x|

1 Croop Jit tion | Return ge
; Run Test
Template Peak Yolt
Il'l IIII Illl II'I Selest Al Resul |

Feport

[ o | )
Detail |

[1000-T--=Template-- =& |Data--=Chi Avg-—-=64 Output-->Refl Disturber-—=ho |

Figure 2-2: Application Interface
3. The application is automatically set to its default settings.

4. If you access oscilloscope functions, the oscilloscope display appears in full
screen and the TDSETS3 application recedes to the background.

5. To return to the TDSET3 application, select the APP button in the
oscilloscope display.
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Minimizing and Maximizing the Application

The application appears even when you minimize the oscilloscope.

To minimize the application, select File > Minimize. The TDSET3 window
minimizes to the Windows taskbar and upper half screen has the
oscilloscope display and lower half of the screen has the desktop

To maximize the application, select Ethernet Compliance Test Software in
the Windows taskbar

To hide the application, select the Hide button B or select File > Hide

The Report Generator module windows are independent of the TDSET3
application. Select the Minimize button on the right hand corner of the relevant
report generator window to minimize it

Note: If you select Hide button, the TDSET3 window goes to the background and
the oscilloscope display resizes to the whole screen.

Returning to the Application

Exiting the Application

2-6

When you access oscilloscope functions, the oscilloscope fills the display. You
can access oscilloscope functions in the following ways:

Choose the Menu bar or the Toolbar mode on the oscilloscope and access
the menus

Press front-panel buttons

To return to the application, select the APP button on the top right of the
oscilloscope display

To exit the application, do the following:

Select File > Exit or select the Exit button _X|

On exiting the application a message box "'Do you want to restore the
oscilloscope settings to their state before starting this application?"
appears

Select Yes, No, or Cancel. Yes is selected by default
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Note: Using other methods to exit the application results in abnormal
termination of the application.

Application Directories and File Names

The TDSETS3 application uses directories to save and recall setup files and uses
file name extensions to identify the file type. The next table lists the default

directory names.

Table 2-1: Application Default Directories

Directory

Action

C:\TekApplications\TDSET3\Setup

Stores the application settings to
setup files.

C:\TekApplications\TDSET3\ReportGenerator\Templates

Stores the default templates of
report generator.

C:\TekApplications\TDSET3\ReportGenerator\Reports

Stores the Reports for 10BASE-T,
100BASE-TX, and 1000BASE-T.

C:\TekApplications\TDSET3\ReportGenerator\Layouts

Stores the Report Layouts for
10BASE-T, 100BASE-TX, and
1000BASE-T.

C:\TekApplications\TDSET3\AWGWaveforms

Stores the AWG waveforms.

C:\TekApplications\TDSET3\Images

Stores all the images.

Application Software Default Layouts and Templates

Table 2-2: 1000BASE-T Default Layouts and Templates

Test Default template

1000BASE-T (Default layout — 1000T.rpl)

Coversheet Coversheet for 1000BaseT.rgt
Coversheet for 1000BaseT _2.rgt

Template 1000T-TemplateA.rgt
1000T-TemplateB.rgt
1000T-TemplateC.rgt
1000T-TemplateD.rgt
1000T-TemplateF.rgt
1000T-TemplateH.rgt

Peak Volt 1000T-PeakVoltA.rgt

1000T-PeakVoltB.rgt
1000T-PeakVoltC.rgt
1000T-PeakVoltD.rgt
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Table 2-2: 1000BASE-T Default Layouts and Templates

(cont)

Test

Default template

Droop

1000T-DroopG.rgt
1000T-DroopJ.rgt

Jitter

1000 Jitter Master filtered.rgt

1000 Jitter Master Unfiltered[TIE].rgt

1000 Jitter Master Unfiltered[HIS].rgt

1000 Jitter Slave filtered.rgt

1000 Jitter Slave Unfiltered[TIE].rgt

1000 Jitter Slave Unfiltered[HIS].rgt

1000T- Jitter master filtered_NOCLK.rgt
1000T- Jitter master unfiltered[HIS] NOCLK.rgt
1000T- Jitter master unfiltered[TIE]_NOCLK.rgt
1000T- Jitter slave filtered_NOCLK.rgt

1000T- Jitter slave unfiltered[HIS]_NOCLK.rgt
1000T- Jitter slave unfiltered[TIE] NOCLK.rgt

Distortion

1000T-Distortion.rgt

Common mode Voltage

1000T-Common mode Voltage.rgt

Return Loss

1000T-Return Loss.rgt

TDSET3 Printable Help Document



Getting Started

Table 2-3: 100BASE-TX Default Layouts and Templates

Test

Default template

100BASE-TX (Default layout — 100TX.rpl)

Coversheet

Coversheet for 100BaseTX.rgt

Template

100-A0I Template.rgt

Differential Output Voltage

100-Differential Output Voltage.rgt

Signal Amplitude Symmetry

100-Signal Amplitude Symmetry.rgt

Rise Time

100-Rise Time.rgt

Fall Time

100-Fall Time.rgt

Rise/Fall Time Symmetry

100-Rise Fall Time Symmetry.rgt

Waveform Overshoot

100-Waveform Overshoot.rgt

Jitter 100-Transmit Jitter.rgt
Duty Cycle Distortion 100-Duty Cycle Distortion.rgt
Return Loss 100-Tx Return Loss.rgt

100-Rx Return Loss.rgt

Table 2-4: 10BASE-T Default Layouts and Templates

Test

Default template

10BASE-T (Default layout — 10T.rpl)

Coversheet

Coversheet for 10BaseT.rgt

MAU Ext Template

10 MAU ext template.rgt

MAU Ext Inv Template

10 mau ext inv template.rgt

MAU Int Template

10 mau int template.rgt

MAU Int Inv Template

10 mau int inv template.rgt

Link Pulse Template Load
with TPM

10 Link Pulse Load1 with TPM template.rgt
10 Link Pulse Load2 with TPM template.rgt
10 Link Pulse 100 with TPM template.rgt

Link Pulse Template Load
without TPM

10 Link Pulse Loadl without TPM template.rgt
10 Link Pulse Load2 without TPM template.rgt
10 Link Pulse 100 without TPM template.rgt

Link Pulse Timing

10 Link Pulse Timing.rgt

TP_IDL Template Load with
TPM

10 TP_IDL Load1 with TPM template.rgt
10 TP_IDL Load2 with TPM template.rgt
10 TP_IDL 100 with TPM template.rgt

TP_IDL Template Load
without TPM

10 TP_IDL Load1 without TPM template.rgt
10 TP_IDL Load2 without TPM template.rgt
10 TP_IDL 100 without TPM template.rgt
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Table 2-4: 10BASE-T Default Layouts and Templates

(cont)

Test

Default template

Differential Output Voltage

10 differential output voltage.rpt

Harmonic

10 harmonic of all ones.rgt

Jitter with cable Normal output
timing

10 output timing jitter with cable.rgt

Jitter with cable 8.0 output timing

10 8.0 output timing jitter with cable.rgt

Jitter with cable 8.5 output timing

10 8.5 output timing jitter with cable.rgt

Jitter without cable Normal output
timing

10 output timing jitter without cable.rgt

Jitter without cable 8.0 output
timing

10 8.0 output timing jitter without cable.rgt

Jitter without cable 8.5 output
timing

10 8.5 output timing jitter without cable.rgt

Return Loss

10 Tx Return Loss.rgt
10 Rx Return Loss.rgt

Common mode Voltage

10 Common mode Voltage.rgt

Application Software Default Settings

2-10

The TDSETS3 application is automatically set to the default settings. The next
table lists the default settings with which the TDSET3 application starts.

Table 2-5: Default Settings

Parameter Selection Default Setting
Speed 1000-T
Select > 1000-T Template/Volt tab
Template/Volt tab A
Droop tab G
Jit/Distortion tab Master Unfiltered
Return Loss tab Return Loss
CM Voltage tab CM Voltage
Select > 100-TX Parametric tab
Parametric tab Template (Both Polarity)
Return Loss tab Transmitter
Configure > 1000-T Data CH1
Master CLK CH2
Slave CLK CH3
Data (TM2) CH1
Data (TM3) CH2
TX_TCLK CH1
# Averages 64
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Table 2-5: Default Settings (cont)

Parameter Selection Default Setting
Clock Edge Rising
Hi Resolution 64
Output Refl
Disturbing Signal No
Filter Int
TX_TCLK No
LP Filter Yes
Meas Type TIE
Probe:P1 CH1
Probe:P2 CH2
Pair ID A
Load 85, 100, 115 ohm
Smooth 7
Record Length Varies depending on the Memory option
available on the oscilloscope.
Hysteresis 5.00 %
Configure > 100-TX Data CH1
Mask Setup
Samples 50K
Fail Threshold 1
Mask Scale Normal
Acquisition Sample/Average (depends on the
parameter selected)
Average is the default mode
# Waveforms = 16
Pulse Width 16 ns
Probe:P1/ Probe:P3 CH1
Probe:P2 / Probe:P4 CH2
Load 85, 100, 115 ohm
Smooth 7
# Averages 100 for Return Loss and 48 for other
tests
Configure > 10-T Data CH1
Acquisition Sample/Average (depends on the
parameter selected)
Average is the default mode
# Waveforms = 16
Section Both
MAU Type Internal
MAU Scale Normal
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Table 2-5: Default Settings (cont)

Parameter Selection Default Setting
Mask Setup 50K
Samples 1

Fail Threshold

Harmonic Ones

Output Math1

# Averages 48

Time/Scale 10 microseconds
Sequence Normal (NLP)

Probe: P1/ Probe: P3 CH1

Probe: P2 / Probe: P4 CH2

Load 85, 100, 111 ohm
Smooth 7
Report > Report Generator Generate Report tab
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TDSET3 Application Window

The TDSETS3 application is a Windows-based application. The application
window comprises the Menu bar, Selection pane, Speed pane, Client pane,
Execution pane, and Status bar. The Client pane changes between Configuration
pane, Parameter Selection pane, Connection pane, and View Waveform pane
depending on what you have selected in the Selection pane. The Client pane
changes to Result pane automatically after you run the test.

Selection pane Menu bar Client pane Execution pane

t

Fil= Tests Resuls Utities Help TDSET3 B x|
Speed Selech: TMOBASE-]

Droop JibD on | Beturn Loss

Tem VO .
1000-T Template Peak Volt
OO oo

w07
Gl B &

1000-T--=Temp Data->Chl Avg—>64 Output--=Refl Disturber—>Mo

! !

Speed pane Status bar

Figure 3-1: Application Window

TDSET3 Application Interface Controls

The TDSETS3 application interface uses the following controls:

Table 3-1: Application Interface Controls

Controls Description

Menu bar Located at the top of the application and has the TDSET3 menus.

Tab Labeled group of options with similar items.

Pane Enclosed visual frame with a set of related options.

Option button Defines a particular command or task.

Drop-down list box | Lists the items from which you can select one item.

Field Box that you can use to type in text or to enter a value with the keypad or a
multipurpose knob.
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Table 3-1: Application Interface Controls (cont)

Controls Description

Check Boxes Square box that you can use to select or clear preferences.

Scroll bar Vertical or horizontal bar at the side or bottom of a display area used to
move around that area.

Browse Displays a window where you can look through a list of directories and files.

Command button Initiates an immediate action.

Keypad Appears when you select a box and enter a value.

MP/GP knob Displays a line between the knob and the box. You can turn the knob on the
oscilloscope to select a value.

Menu bar
The menu bar of TDSET3 has the following menus.
" File menu
®  Tests menu
®  Results menu
= Utilities menu
=  Help menu
File Menu

The File menu appears as shown by the next figure:

File Tests Results LUkilities Help
Recall Defaulk Setup
Recal Setup. .. Ckrl+R,
Save Setup.., Chrl+5

Preferences. ..

Minimize CEr+M
Hide:

Exit

Figure 3-2: File Menu
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The next table lists the menu selection and description for the File menu:

Table 3-2:

File menu

Menu selection

Description

Recall Default
Setup

Recalls the default settings for the application.

Recall Setup

Recalls the application settings from a setup file.

Save Setup

Saves the application settings to a setup file.

Preferences

Shows/Hides the message boxes displayed while running the test.

Minimize

Minimizes the Application window.

Hide

Hides the Application window.

Exit

Displays the Restore Settings dialog box and closes the Application.

Tests Menu

The Tests menu appears as shown by the next figure:

Eile | Tests Results  Utilities Help
_____ 3 & 1000BASE-T
Configure 100BASE-TH
Conneck 10BASE-T
Wiew Waveform |

Figure 3-3: Tests menu

The next table lists the menu selection and description for the Tests menu:

Table 3-3:

Tests menu

Menu selection

Description

Select

1000BASE-T

Displays the point and test parameter selections for 1000BASE-T in the
Client pane.

100BASE-TX

Displays the parameters for 100BASE-TX in the Client pane.

10BASE-T

Displays the parameters for 10BASE-T in the Client pane.

Configure

Displays the configuration details for the selected speed and test.

Connect

Displays the connection instructions for the selected speed.

View Waveform

Displays the waveform based on the settings.
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Results Menu

The Results menu appears as shown by the next figure:

Filz= Tests | Results  Ukilities  Help

Surmaty
Dretails

Figure 3-4: Results menu

The next table lists the menu selection and description for the Results menu:

Table 3-4: Results menu

Menu selection Description
Summary Displays the results summary of last test conducted.
Details Displays the detailed results of last test conducted.

Utilities Menu

The Utilities menu appears as shown by the next figure:

File Tests Results | Ukiities Help

Report Genetakor
v Enable Remate GPIE
Automate AWS, ..

Figure 3-5: Utilities menu

The next table lists the menu selection and description for the Utilities menu:

Table 3-5: Utilities menu

Menu selection Description
Report Generator Displays the Report Generator window.
Enable Remote GPIB

Enables you to use remote GPIB commands to control the application.

Enables you to automate file transfer and waveform setup on an
Arbitrary Waveform Generator.

Automate AWG

TDSET3 Printable Help Document



Operating Basics

Help Menu
The Help menu appears as shown by the next figure:

Fil=: Tests Results Utiities | Help
Help Topics
About Ethernet Compliance Test Software

Figure 3-6: Help menu

The next table lists the menu selection and description for the Help menu:

Table 3-6: Help menu

Menu selection Description

Help Topics Displays the help file for the TDSET3 application.

About Ethernet Compliance | Displays a dialog box with information about the current TDSET3
Test Software application.

Selection pane

The Selection pane located to the left of the Application window allows you to
navigate through the application.

I Select

Configure

Connect

W it ST

Figure 3-7: Selection pane
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The next table lists the button and the task description:

Table 3-7: Selection pane buttons

Button Description

Select Displays the test selection parameters in the Client pane for the selected
speed.

Configure Displays the configuration parameters in the Client pane for the selected test
parameter.

Connect Displays the connection details in the Client pane for the selected test
parameter.

View Wfm Displays the waveform in the Client pane for the selected test parameter.

Speed pane

The Speed pane located to the left of the application window displays the speed
to be selected.

Speed

1000-T

Figure 3-8: Speed pane

Select 1000-T to test 1000BASE-T, 100-TX to test 100BASE-TX, and 10-T to
test LOBASE-T.

The Client pane displays the parameters of the selected speed.
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Client pane

The Client pane located adjacent to the Speed pane displays the test parameters,
configuration parameters, connections, view waveforms or results. Clicking on
each tab changes the Client pane to display the relevant test parameters.

100.OBASE‘T The following figure shows the Client pane of 1000BASE-T Template:
Client pane

Fle Tests Resuls Utiities Help TDSET3 B x|
Speed Select: 1000BASE-T

Ternpl ol Droop Jit n | Return L tage
Select
1000-T Template Peak Volt
o oo e

100-T¥
= o

1000-T-->Template-- =&

Configure

Data--=Chl  Awvg--=64 Output--=Refl  Disturber--=ko

Figure 3-9: 1000BASE-T Client pane

1OOBASE'TX The following figure shows the Client pane of 100BASE-TX Template:
Client pane

Fle Tests Resuls Utiities Help TDSET3 B x|
Speed Select: T00BASE-TX

Pararmetric Return L
Select
1000-T Tests
Tempiste [ output volt B armp Sy MM Select Al

Polarity

BT L Both ¥ Sumrmary

[100-Tx--=Template

|Data--=Chi  Pol--=Both

Figure 3-10: 100BASE-TX Client pane
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1_OBASE‘T The following figure shows the Client pane of 10BASE-T Template:
Client pane

File Tests Resuls Utiiies Help TDSET3 B x|
Speed Select: 10BASE-T

[ Te e || Parametric Feturn Loss
Select —k ;

1000-T

g Link Pulze SRl

100-T¥

ool JH T =1

10-T-=Template-=Link Pulse- =100 ohm wjio TP

Data--=Chl Acg--=Average Mask Sel--=Both

Figure 3-11: 10BASE-T Client pane

Execution pane

The Execution pane located to the right of the Application window displays the
buttons Run Test and Result.

Figure 3-12: Execution pane
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Clicking on each button performs a particular task. The following table lists the
button and the task description:

Table 3-8: Execution pane

Button Button Name Description
AunTest! | Run Test Runs the selected test or tests.
Res it Result Displays the Result pane that shows the test results.

Displays the location to which the report summary is saved.

Sumenary : o .
Report Summary Click OK to store the result details in a .csv file.

_ Displays the location to which the detailed report is saved.
Detail Report Detail Click OK to store the result details in a .rpt file depending on
the layout selected in Report Configuration pane.

Note: The report details are real time and no history is maintained. Ensure that
you save the report details before you run another test.

Status bar
At the bottom of the application window is the status bar that displays the
selected test and the important configuration parameters.

[1000-T--=Template-- =4 [Data--»Chl  Avg--»64 Oubput--=Refl Disturber-=No |

Figure 3-13: Status bar
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Result pane

After you run a test, the Result pane automatically appears as shown by the
following figure:

File Tests Results Ltiities Help TDSET3 B X |

Port 10

Re: ummary: 1000B&SE-T

Pair 1D

Report File
Clea esylt Details hlanual Fit
Wl Enable P

1000-T--xJitker Master--=Filkered

Data--»Chl Master CLK-->Ch2  Clock Edge-->Rising

Figure 3-14: Result pane for all tests

After you run a Return Loss test, the Result pane automatically appears as shown
by the following figure:

File Tests Resulbs Utilties Help TDSET3 B x|
Report Cun-figu-lal-iun '
Dlevice ils
Part 10
Pair 10

Export  Clear |

| [ Enahble

[1000-T--=Return Loss [Pair ID--2A P1-»Chl P2->Ch2 Avg->100 Smooth--»7

Figure 3-15: Result pane for Return Loss tests

The Result pane comprises Result Summary pane and Report Configuration
pane.
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Result  The Result Summary pane displays the test results as Pass/Fail/Inconclusive.
Summary pane

It Surmrmary: 1000BASE-T
st Paoint B
- Point G
- Paint O
- Point F

ult Details Manual Fit

Figure 3-16: Result Summary pane
Indicates that the test has passed.
E3 Indicates that the test has failed.
3 Indicates that the test is inconclusive.

The next table lists the buttons and the task descriptions:

Table 3-9: Result Summary pane buttons

Button Description

Export Exports the return loss values in a .csv file.

Clear Results Clears the results in the Result Summary pane.

Result Details | Displays the Result Details dialog box that shows the details of test results
categorized as Description, Specification range, Measured Value,
Pass/Fail/Inconclusive, and Remarks.

Manual Fit Displays the Manual Fit dialog box that allows you to adjust the waveform to fit
into the Mask. This button is enabled only when you test 1000BASE-T Template,
100BASE-TX Template or 10BASE-T Template.

Smooth Displays the Smooth dialog box that allows you to smoothen the return loss
waveform. This button is enabled only when you test Return Loss.
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_ ~ Report  yoy can set the report details to identify and automatically generate the report.
Configuration pane yoy can set a default report file.

Report Configuration
Device Oetails
T ]
Fair 10

Repuort File

(W Enahble Preview

Figure 3-17: Report Configuration pane

The next table lists the report configuration fields and descriptions:

Table 3-10: Report Configuration fields

Field Description

Device ID To identify on which DUT the test was conducted by printing the Device ID
on the generated report.

Device description | To identify on which DUT the test was conducted by printing the Device
Description on the generated report.

Pair ID To identify the unique pairs by printing the Device Description on the
generated report. This field is enabled only for 1000BASE-T.

Report File To specify the path and the file in which the generated report will be saved.
A default file name and path displayed for the selected speed.

Enable Preview To automatically preview the report after generation.

Advanced button Displays the Advanced Report Configuration dialog box.

Dialog Boxes

Preferences Use this dialog box to set the user preferences such as, show or hide the
dialog box Overwrite Reference message box, Overwrite Math message box, 10Base-T user
intervention for Template, 10Base-T user intervention for Jitter tests and
1000Base-T user intervention for Distortion test.
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Click File > Preferences to display the Preferences dialog box.

x

Dialog Show/Hide

[ Show Ref

Figure 3-18: Preferences dialog box

The next table lists the preferences and task description:

Table 3-11:

Preferences

Preference

Task Description

Show or Hide the
Overwrite
Reference
message box

In Preference dialog box, select or clear the Show Ref overwrite check
box.

If you select Show Ref overwrite check box, the application displays the
following warning every time you run 1000BASE-T Template, Peak Volt,
Distortion, and Jitter tests. This dialog box also appears for Return Loss
tests. This dialog box appears for 1000BASE-T Droop test only if Disturbing
Signal is selected as Yes.

Do vow want bo ovenante Refl 2

TDSET3 Printable Help Document
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Table 3-11:

Preferences (cont)

Preference

Task Description

Show or Hide the
Overwrite Math
message box

In Preference dialog box, select or clear the Show Math overwrite check
box.

If you select Show Math overwrite check box, the application displays the
following warning box every time you run 10BASE-T Harmonic Test.

Do you want o overwnte Mathl ?

[l Dor

Show or hide

10Base-T user
intervention for
Template tests

In Preference dialog box, select or clear the Show 10Base-T Template
user control check box.

If you select the check box, the application displays the following warning
box every time you run 10BASE-T Template Test.

10Base-T: Template user conktrol

o the settings now.

Toggle Lock Mask to Wfm between On and Off to lock or unlock the mask
to waveform when you zoom in or zoom out.

Toggle Mask Autofit between On and Off to allow the oscilloscope to
automatically fit the waveform to mask.
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Table 3-11:

Preferences (cont)

Preference

Task Description

Show or hide
1000Base-T user
intervention for
Distortion test

In Preference dialog box, select or clear the Show 1000Base-T Distortion
user control check box.

If you select the check box, the application displays the following warning
box every time you run 1000BASE-T Distortion Test.

Ethernet Compliance Test Software

TDSET3 Printable Help Document
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Table 3-11:

Preferences (cont)

Preference

Task Description

Show or hide
10Base-T user
intervention for
Jitter tests

In Preference dialog box, select or clear the Show 10Base-T Jitter user
control check box.

If you select the check box, the application displays the following warning
box every time you run 10BASE-T Jitter with cable Test.

Ethernet Comphiance Test Software

If you select the check box, the application displays the following warning
box every time you run 10BASE-T Jitter without cable Test.

Ethernet Compliance Test Software

b zero level, adjust tigger haold off.
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Table 3-11:

Preferences (cont)

Preference

Task Description

Show or Hide the
message for
alternate
1000Base-T Jitter
test

In Preference dialog box, select or clear the Show 1000Base-T Jitter
message user control check box.

If you select the check box, the application displays the following message
every time you run 1000BASE-T JitterTest (Alternate Method).

ure ment
ible.

Click OK to set the preferences.

Click Cancel to exit the Preference dialog box.

Advanced Report Select Results in the Execution pane, and Advanced in the Report Configuration
Configuration pane of the Result pane. The Advanced Report Configuration dialog box appears
dialog box as shown in the next figure:

Advanced Report Configuration x|

Oeyice 10

Pron

Yoltage _ :

Termperature

settings for image export

Figure 3-19: Advanced Report Configuration dialog box
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The table lists the options that you can configure in the advanced report

configuration dialog box:

Table 3-12: Advanced Report Configuration

Field

Description

Device ID

Prints the Device Id on the generated report to help you identify
on which DUT the test was conducted.

Process

Prints the Process on the generated report to help you identify
the process used for DUT.

Voltage

Prints the Voltage on the generated report to help you identify
the voltage values used while testing the DUT.

Temperature

Prints the Temperature on the generated report to help you
identify the temperature values used while making the DUT.

Last Cal date

Prints the Last Cal date on the generated report to help you
identify the date on which the oscilloscope was last calibrated.

Use oscilloscope settings for
image report

Select this check box to use the oscilloscope settings for
exporting images.

Click OK to configure the report.

Click Cancel to exit the report setup.

Result Details  Select Result Details button in Result pane to display the Result Details dialog

dialog box box.

After you have completed the test and you want to see the result details, click on
the Result Details button in Result pane. The Result Details dialog box appears
as shown by the following figure. The title bar displays the selected speed.

Description

Figure 3-20: Result Details dialog box

3-18
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The results are categorized as listed in the next table:

Table 3-13: Result Details Categorization

Category Description

Description Displays the selected test.

Spec Range Displays the specification range.
Measured Value Measured value of the selected test.
Pass/Fail

Test passed or failed or inconclusive as
or

Remarks Additional information about the test.

Note: Locate Hits, and Flash Hits are enabled only if a template test fails.
The TDS5000B series oscilloscopes do not support Flash Hits.

Select Locate Hits to view and change the mask color and hit color.
Select Flash Hits to flash the hits on the oscilloscope display.
Select Show Seg to display the mask segments.

Select Close to close the dialog box.

Note: If you run all the tests together using Select All, the Locate Hits, Flash
Hits, and Show Seg buttons are disabled.

Locate Hits Select Result Details button in Result pane to display the Result Details dialog
dialog box box. In the Result Details dialog box, select Locate Hits to display the Mask Hit
Locator dialog box as shown by the following figure:

Ehi 160mY &

GCircle Color
Cyan ¥

Figure 3-21: Mask Segments dialog box
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1. Selecting Locate Hits changes the mask color and hit color. Closing the
Locate Hits dialog box will set the Mask color to default.

2. Inthe Circle Color drop-down list, select the color in which you want to see
the mask hits circled.

3. Select Save to save the mask-hit image as a jpg or a bmp file. The default
directory is C:\TekApplications\TDSET3\Images.

4. Select Close to close the dialog box.

Flash Hits Select Result Details button in Result pane to display the Result Details dialog

dialog box box. In the Result Details dialog box, select Flash Hits to flash the hits on the
oscilloscope display. The Flash Hits message box appears as shown by the
following figure:

top flashing.

Figure 3-22: Flash Hits message box

Select Stop in the Flash Hits message box to stop flashing the mask hits.
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Show Segments Select Result Details button in Result pane to display the Result Details dialog
dialog box box. In the Result Details dialog box, select Show Seg to display the mask
segments. The Show Segments dialog box appears as shown by the following

figure:

1000BASE-T Template for A,B,C,D

T

Figure 3-23: Show Segments dialog box

Show Seg is enabled only if you run the template test.
Select Close to close the dialog box.

Manual Fit  Select Result Details button in Result pane to display the Result Details dialog
dialog box box. In the Result Details dialog box, select Manual Fit to display the manual fit

dialog box.

Note: If you select the Select All button, Manual Fit is not enabled.
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If you are running 1000BASE-T Template test, the Manual Fit dialog box
appears as shown by the next figure:

Figure 3-24: 1000BASE-T Manual Fit dialog box

When you test Template in 1000BASE-T, you can manually fit the waveform
into the mask.

If the processed waveform does not lie within the mask, use Manual Fit to
manually fit the waveform into the mask as described below:

1. Click the arrow buttons to adjust the waveform to fit into the Mask.
2. Click OK to perform the mask pass/fail test again.

= Click Cancel to exit the Manual Fit dialog box without performing the
mask pass/fail test

If you are running 100BASE-TX or 10BASE-T Template tests, the Manual Fit
dialog box appears as shown by the next figure:

Manual Fit E

Click an the nntrol bo adjust the waweform to
fit intothe hask. Click OK buttan to perfarm the test,

Horiz Pos J'—' Vert Pos

. 1.1

Figure 3-25: 100BASE-TX/10BASE-T Manual Fit dialog box

When you test Template in 100BASE-TX, and 10BASE-T, you can manually fit
the waveform into the mask.
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If the processed waveform does not lie within the mask, use Manual Fit to
manually fit the waveform into the mask as follows:

1. To adjust the waveform to fit into the Mask, change the horizontal position
and vertical position using the general purpose knobs or Virtual Keyboard.

2. Click OK to perform the mask pass/fail test again.

Jig match If you are running 1000BASE-T Template test, the Jig Match button appears in
dialog box the Connect pane. Click Jig Match to display the Jig Match dialog box.

1000-T > Template > Connect > Jig Match

Note: Jig Match is enabled only if you select Disturbing Signal as Yes.

JigMakch N

Digturber Compenszation

Connect Tektronis A4 B to test fisture TCE || HElp |

Enpectad Yalue | Last Measured ¥alue e
Afnplitude : Measure | Default
Frequency 7 z

wture TC2 | Help

Expected Yalue | Last Measured Yalue

: Measure | Derault
750 [

wture TCE | HEID

Expected Yalue |Last Measured Yalue BB : ’
Probe Point Amp| T | Measwe | Deraut
Attenuation 15 :

fpply Cancel

Figure 3-26: Jig Match dialog box for 1000-T Template/Peak Volt/Droop test
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1000-T > Distortion > Connect > Jig Match

Disturber Compensation

Connect Tektronis WG o test fisture TCS | Halp

_EHpected Walle TLast Measured Yalue

Amplitute B | Measurs [ Defauit.

Frequency 200,55 MHz

Test Fisture Compensation

bure TG2 | Halp

uEHpectedT.falue -]Last Measured Yalue
' 2,22y

j".'1 CEEAT ) Ciafault

Expected Yalue |Last Measured Yalug

Prabe Point &mp| }.48?_ Measurs |Detault
Attenuation 15 I :

Apply Gancal

Figure 3-27: Jig Match dialog box for 1000-T Distortion test

Use Jig Match to effectively remove the disturbing signal and compensate for
non-linearities in the disturber and the test fixture. You can measure the
disturbing signal's Amplitude, and Frequency. You can also set the default
values. The application measures and displays the values in Measured Value
fields. You can validate the disturbing signal by comparing the Measured Value
with the Expected Value.
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To compensate for the Disturbing Signal, do the following:

1. Use TC5 of the test fixture for Disturber Compensation.

2. Make the connections as shown by the following figure:

Tektronix AWG Tektronix Oscilloscope
e
-, ——|
= ==== 8 et me =
= =222 S8l0s82 0
= [ v R s s
" aaaa
) s @ G o @ = = = < J
CH1 CH1/CH2 =5 =i= =
—
: To Oscilloscope
1630
(es] TCS5
- =3 A = =
i :JE)@EI & o %Elﬁ —
J?sﬂE pL7 " 1650 E%lEl% 1700
To Channel 2 o Vo - r EI ;
of AWG 2[s) &gl Eg B8;

1731

1723

Figure 3-28: Connections for Disturber Compensation

Note: Do not connect the Ethernet cable to J700 and the test port of the DUT.

3. Connect a BNC Cable to AWG+ and Channel 1 of Arbitrary Waveform

Generator.

4. Connect a BNC Cable to AWG- and Channel 2 (CH1) of Arbitrary

Waveform Generator.

5. Short the jumpers J621, J630, J620, J623, J721, J723, J680, and J781.

6. Connect the Differential Probe to P19 and configured channel of the

oscilloscope.

7. Inthe Jig Match dialog box, select Measure button in the Disturber

Compensation pane.

TDSET3 Printable Help Document
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8. Compare the Measured Value with the Expected Value.

9. If the Measured Value is not approximately equal to the Expected Value,
modify the amplitude and clock frequency settings of the Arbitrary
Waveform Generator. Then click Measure and compare the values to be
approximately equal.

To compensate for the Test Fixture, do the following:
1. Use TC2 and TC5 of the test fixture for Test Fixture Compensation.

2. Make the connections as shown by the following figure:

Tektronix Oscilloscope

g.. ST
OS5 |
DuT al=0 = 0
gy g,y | [T & R & R 5}

- aaaa
T\(-I = - l: :l
= E
il
. % Test Fixture ( TF-GBE)
= )
TC 2

Toe DUT

= 3
[ 1 A
= 0= | &g
[ ] s -
o E
‘ -
i To Oscilloscope

Figure 3-29: Step 1 Connections of Test Fixture Compensation

3. For Template, Droop, and Peak Voltage tests, set the DUT to generate Test

Mode 1 signal.
For Distortion test, set the DUT to generate Test Mode 4 signal.

4. Connect the Ethernet cable to J490 and the test port of the DUT.
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5. Connect the Differential Probe to P9 and configured channel of the
oscilloscope.
6. Inthe Jig Match dialog box, select Measure button in Step 1 in the Test
Fixture Compensation pane.
7. Make the connections as shown by the following figure:
Tektronix AWG Tektronix Oscilloscape
=== s ce
g; - @ Sgc gt &
M= 22222 SE0/E=2 0
D= === oo oo
0 Test Fixture : aaa
Cl== =1 e Ml_ L, T J
CH1 CH1/CH2 g EE ['g —J | -
| put

To Oscilloscope

o

To Channel 1 EI

of AWG :
1780 E P17

To Channel 2

of AWG B

To DUT

Bl

TC5
—]

700

1]

Figure 3-30: Step 2 Connections of Test Fixture Compensation

8.

10.

11.

12.
13.
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For Template, Droop, and Peak Voltage tests, set the DUT to generate Test
Mode 1 signal.
For Distortion test, set the DUT to generate Test Mode 4 signal.

Connect the Ethernet cable to J700 and test port of the DUT.

Connect a BNC Cable to AWG+ and Channel 1 of Arbitrary Waveform
Generator.

Connect a BNC Cable to AWG- and Channel 2 ( ©H1) of Arbitrary
Waveform Generator.

Switch OFF the Arbitrary Waveform Generator.

Short the jumpers J621, J630, J623, J721, J723, J680, and J781.
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14. Connect the Differential Probe to P18 and configured channel of the
oscilloscope.

15. In the Jig Match dialog box, select Measure button in Step 2 in the Test
Fixture Compensation pane.

Virtual Keyboard  Selecting IE3| adjacent to any number field displays the Virtual Keyboard.
dialog box

=@ Device Description

Figure 3-31: Virtual Keyboard

The field on the top displays what you have selected. After you have selected the
required number, select Enter.

B Selecting Space inserts a space
= Selecting Enter enters the value for the selected field
= Selecting Backspace deletes the value entered

= Selecting Esc exits the Virtual Keyboard
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Virtual Keypad Select the knob or the keypad icon adjacent to any text field to display the

dialog box

ci # of Wims [x]

Virtual Keypad dialog box.

Figure 3-32: Virtual Keypad

Use this dialog box to enter custom values.
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Selecting Set to min automatically displays the minimum value of the
selected field

Selecting Set to max automatically displays the maximum value of the
selected field

Selecting CLR clears the value for the field selected and returns to zero
value

Selecting Enter enters the value for the selected field
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quk Setup The Mask Setup button is available in the Configure pane and is enabled only
dialog box when you run template tests.

If you are configuring 100BASE-TX Template test, click on Mask Setup button
in the Configure pane to display the Mask Setup dialog box.

Mazk Configuration

Fail Thresh ®
| [

| Close
I

Figure 3-33: 100BASE-TX Mask Setup dialog box

In the Samples text box, enter the number of samples to use in the test. Entering
the number of samples stops the test when that number has been reached.

The accepted range of samples is between 5000 and 2,147,400,000. The default
number of samples is 16,000.

In the Fail Thresh text box, enter the minimum number of samples that must fail
for the test to fail.

The accepted range of samples is between 1 and 2,147,483,647. The default fail
threshold is 1.

Note: You can use the Virtual Keyboard or the General Purpose knobs to enter
the values in the Samples and Fail Thresh fields.
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If you are configuring 10BASE-T Template test, click on Mask Setup button in
the Configure pane to display the Mask Setup dialog box.

# of Wims

21
=

Fail Thresh
1

Figure 3-34: 10BASE-T Mask Setup dialog box

In the # of Wfms text box, enter the number of waveforms to use in the test.
Entering the number of waveforms stops the test when that number has been
reached.

The accepted range of samples is between 1 and 2,147,483,647. The default
number of samples is 16.

In the Fail Thresh text box, enter the minimum number of samples that must fail
for the test to fail.

The accepted range of samples is between 1 and 2,147,483,647. The default fail
threshold is 1.

Smooth Select Result Details button in Result pane to display the Result Details dialog
dialog box box. In the Result Details dialog box, select Smooth to smoothen the return loss
waveform. This button is enabled only when you test Return Loss for all speeds.

Smooth [0-10)

(V] Al

Close

Figure 3-35: Smooth dialog box

After you test Return Loss, you can change the smoothness of the waveform. The
accepted range is within 0 to 10. The default is 7.
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Click the arrow buttons to increase or decrease the value and view the
smoothness of the waveform. The waveform is automatically updated as you
change the value.

Click Close to perform the pass/fail test again.

EXxit  Select File > Exit to display the following message box:
dialog box

Ethernet Compliance Test Software

Do you want to restore the ogcillozcope settings to their state prior to gtarting
thiz application?

Figure 3-36: Exit dialog box

You can exit the application by restoring the oscilloscope settings to the previous
state before starting the application or retaining the present oscilloscope settings.

= Select File> Exit

" Select Yes to restore the oscilloscope settings to their original state before
starting the application and exit the application
or
Select No to retain the present oscilloscope settings and exit the application
or
Select Cancel to cancel the operation and return to the application

Note: Clicking X displays the Exit dialog box.
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How To Select Test Parameters

Selecting 1000BASE-T Test Parameters

The following table lists how to select the 1000BASE-T test parameters:

Table 4-1: Select 1000BASE-T Test Parameters

Test Parameter

Selection

1000BASE-T

Click Tests > Select > 1000BASE-T or select 1000-T in the
Speed pane.

Template

In the Template/Volt tab, select a point in the Template group.

Peak Voltage

In the Template/Volt tab, select a point in the Peak Volt group.

Droop

In the Droop tab, select a point.

Jitter Master Filtered

In the Jit/Distortion tab, select Master Filtered.

Jitter Master Unfiltered

In the Jit/Distortion tab, select Master Unfiltered.

Jitter Slave Filtered

In the Jit/Distortion tab, select Slave Filtered.

Jitter Slave Unfiltered

In the Jit/Distortion tab, select Slave Unfiltered.

Distortion

In the Jit/Distortion tab, select Distortion.

Return Loss

In the Return Loss tab, select Return Loss.

CM Voltage

In the CM Voltage tab, select CM Voltage.

Note: The TDS5000B series oscilloscopes do not support Jitter Slave Filtered

test.
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Selecting 100BASE-TX Test Parameters

The following table lists how to select the 100BASE-TX test parameters:

Table 4-2: Select 100BASE-TX Test Parameters

Test Parameter

Selection

100BASE-TX Click Tests > Select > 100BASE-TX or select 100-TX in the Speed
pane.
Template In the Parametric tab, select Template. In the Polarity drop-down list,

select Pos for positive, Neg for negative, or Both.

For Positive polarity, the application tests segments 1, 2, 3, 6, and 7.
For Negative polarity, the application tests segments 4, 5, 8, 9, and 10.
For Both, the application tests all the segments.

Differential Output
Voltage

In the Parametric tab, select Output Volt. In the Polarity drop-down list,
select Pos for positive, Neg for negative, or Both.

Signal Amplitude

In the Parametric tab, select Amp Sym. In the Polarity drop-down list,

Symmetry select Pos for positive, Neg for negative, or Both.

Rise Time In the Parametric tab, select Rise Time. In the Polarity drop-down list,
select Pos for positive, Neg for negative, or Both.

Fall Time In the Parametric tab, select Fall Time. In the Polarity drop-down list,
select Pos for positive, Neg for negative, or Both.

Rise/Fall Time In the Parametric tab, select R/F Sym. In the Polarity drop-down list,

Symmetry select Pos for positive, Neg for negative, or Both.

Waveform Overshoot

In the Parametric tab, select Overshoot. In the Polarity drop-down list,
select Pos for positive, Neg for negative, or Both.

Jitter

In the Parametric tab, select Jitter. In the Polarity drop-down list, select
Pos for positive, Neg for negative, or Both.

Duty Cycle Distortion

In the Parametric tab, select Distortion.
Select Random or 010101 in the Pattern drop-down list.

Return Loss

In the Return Loss tab, select either Transmitter or Receiver.
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Selecting 10BASE-T Test Parameters

The following table lists how to select the 10BASE-T test parameters:

Table 4-3: Select 10BASE-T Test Parameters

Test Parameter Selection

10BASE-T Click Tests > Select > 10BASE-T or select 10-T in the Speed pane.
Template MAU In the Template tab, select MAU and select Normal, Inverted or Both in

the adjacent drop-down list. Select Configure in the Selection pane and
select the MAU Type as External or Internal.

Template Link Pulse

In the Template tab, select Link Pulse. In the adjacent drop-down list,
select the load with or without TPM — Load1 w/o TPM, Load2 w/o TPM,
100 ohm w/o TPM*, Load1 with TPM, Load2 with TPM, or 100 ohm with
TPM*,

Template TP_IDL

In the Template tab, select TP_IDL. In the adjacent drop-down list, select
the load with or without TPM — Load1 w/o TPM, Load2 w/o TPM, 100
ohm w/o TPM*, Load1 with TPM, Load2 with TPM, or 100 ohm with
TPM*,

Differential Voltage

In the Parametric tab, select Diff Volt.
From the Peak drop-down list, select the peak value as Max or MinMax.

Harmonic

In the Parametric tab, select Harmonic.

Jitter with cable

In the Parametric tab, select With Cable in the Jitter group.
Select Normal, 8BT, 8.5BT, or All in the adjacent drop-down list.

Jitter without cable

In the Parametric tab, select w/o Cable in Jitter group.
Select Normal, 8BT, 8.5BT, or All in the adjacent drop-down list.

Return Loss

In the Return Loss tab, select either Transmitter or Receiver.

CM Voltage

In the CM Voltage tab, select CM Voltage.

* The loads 100 ohm with TPM and 100 ohm w/o TPM are optional and not required as per
the 802.3-2002 standards.
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Configuring 1000BASE-T

Use this dialog box to configure 1000BASE-T for Source, # Averages, Output,
Disturbing Signal, and Filter.

Fle Tests Results Utities Help TDSET3 B x|
Configure: 1D00BASE-T

- Source # Averages Output
Salect
(i Refl ¥

Ch1 ¥
Disturhing Signal

Yes

Filter

Yiaw i = sl

|1000-T--=Template-- =4 |Data--=Chl Avg-—-»64 Output-->Refl Disturber--=Mo

Figure 5-1: 1000BASE-T Configure pane
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The following table shows the 1000BASE-T tests parameters you can configure:

Table 5-1: 1000BASE-T Configure parameters

i =
A - i N
ElE |5]5]3 z 5|2
— — i 5 _ = =
Sllx [F|E| 5|8 222|535 |88|a]n A
S| D E E Plwg @z | 2 0 ol = Rl R S |lp | o| ¥
i = —_ | = o E - | T a]% 5 o | w il 8 § = | o
o |l g | 2fF m m = | 5 3w z|l | 2|88 |o]|a e o #
Ela| 2| | B |® 2|22 |8a |2 2 05| A2 |2 El5|2|E|5] 3|5
alz|wn|E|la|lal=|sE|las |z || F|o|z|l&|la|ld|8|e|xz|5]T
Ternplate v v v v v
Paak Walt v v v v v
Croop v v v v’
Jitter Mastar Filterad v v v v v v v
Jitter Master Unfiltered o v v v v v v
Jitter Slave Filtered v | v v | W v v v v
Jitter Slave Unfitberad v | v v W Vs v Vs v v
Dishartion v v v v v v | v v
Febim Loss v AR AN 44
<M Valtage v v
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The following table describes the 1000BASE-T configuration parameters:

Table 5-2:

1000BASE-T Configure parameter description

Configure parameters

Description

Source
— Souice — Source
Data Data [TM2)

Chl W

Data [TH3)

| chiw

| Master CLK

[ chaw

Slave CLK

The Data source and CLK source should be mutually exclusive. The Data source, Master
CLK source and Slave clock source should be mutually exclusive.

Data — Select the channel to which the DUT signal is connected.

Master CLK — Select the channel to which the master clock is connected.
Slave CLK — Select the channel to which the slave clock is connected.
TX_TCLK — Select the channel to which the TX_TCLK is connected.

Data (TM2) — Select the channel to which data in Test Mode 2 is connected.
Data (TM3) — Select the channel to which data in Test Mode 3 is connected.

Note: TX_TCLK drop-down list appears only for Distortion test and if you
have selected TX TCLK as Yes.

Data (TM2) and Data (TM3) drop-down lists appear only for Jitter tests if you have selected
the TX_TCLK as No.

Master CLK and Slave CLK drop-down lists appear only for Jitter tests if you have selected
the TX TCLK as Yes.

# of Averages
- # Averages -

Enter the number of averages between 64 and 10000 depending on the noise present in
the acquired waveform.

Clock Edge
—— Clock Edge ——

Select the clock edge on which the oscilloscope finds the trigger point.

Disturbing Signal
r Disturbing Signal -

Select Yes or No depending on whether the disturbing signal is added to the test mode
signal.

Filter

Select Int or Ext depending on whether the filter is applied internally or externally.

Select Yes or No to perform the Distortion test with TX_TCLK.

I Output —
| [rerw |

Select the reference waveform on which the processed waveform will be stored.
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Table 5-2: 1000BASE-T Configure parameter description (cont)

Configure parameters

Description

Meas Type
- Meas Type

Select the measurement type as either Time Interval Error (TIE) or Histogram.

Hi Resolution
Hi Resolution

Enter the number of averages to be done in the vertical domain.

Return Loss
- SOUrces -

Probe:P1 Prohe:P2
Chl ¥ | Ch2 ¥

Load
00, 11559

- Qutput Waveform
Heturn Loss 0 dB Marker
| Rel1 Y | Reiz Y

r # Averages -  Smooth{0-10]

Probe: P1 and Probe: P2 — Select the channels to which the probes are connected.

Note: Depending on the Pair ID selected, the sources will change from
P1/P3/P5/P7 and P2/P4/P6/P8.

Load — Select the load as 85, 100, 111 ohm or 100 ohm.

Pair ID — Select the Pair ID as A, B, C, or D. Depending on the Pair ID selected the
sources will change from P1/P3/P5/P7 and P2/P4/P6/P8.

Return Loss — Select the reference waveform on which the output waveform will be
stored.

0 dB Marker — Select the reference waveform on which you want the 0 dB Marker to be
indicated.

Note: Return Loss and 0 dB Marker fields appear only if you set Load as
100 ohm.

# Averages — Enter the number of waveforms you want to average.
Smooth — Enter the smoothening factor.

Record Length
Record Length
| 1 Meg¥

Select the record length. This varies depending on the memory option available on the
oscilloscope.

Low Pass Filter
LP Filter

|

Select Yes or No. The Low Pass Filter has a cutoff frequency of 150 MHz and when
applied, eliminates high frequency noise.

Hysteresis
Hysteresis

Enter the hysteresis percent value.

5-4

TDSET3 Printable Help Document



How To Configure Parameters

The following table lists the configuration parameters and default settings:

Table 5-3: 1000BASE-T Configuration Default Settings
Parameter Options Default

Data CH1, CH2, CH3, CH4 CH1

Master CLK CH1, CH2, CH3, CH4 CH2

Slave CLK CH1, CH2, CH3, CH4 CH3

Data (TM2) CH1, CH2, CH3, CH4 CH1

Data (TM3) CH1, CH2, CH3, CH4 CH2

# Averages 64 to 10000 64

Clock Edge Rising, Falling Rising

Disturbing Signal Yes, No No

Filter Int, Ext Int

TX TCLK No, Yes No

TX_TCLK CH1, CH2, CH3, CH4 CH2

Output Refl, Ref2, Ref3, Ref4 Refl

Meas Type Histogram, TIE TIE

Hi Resolution 021to0 75 64
Probe:P1/P3/P5/P7 CH1, CH2, CH3, CH4 CH1
Probe:P2/P4/P6/P8 CH1, CH2, CH3, CH4 CH2

Pair ID AB,CD A

Load 85, 100, 115 or 100 ohm 85, 100, 115 ohm

Note: The TDS5052B oscilloscope displays the graticule only for 100 ohm Load.

Smooth 0-10 7

Record Length Varies depending on the Memory option
available on the oscilloscope.

Low Pass Filter Yes, No Yes

Hysteresis 5.00% to 30.00% 5.00%
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Configuring 100BASE-TX

Use this dialog box to configure 100BASE-TX for Data source, Acquisition,

Rise/Fall Time Test, and Mask Setup.

File Tests Results Utilities Help

TDSET3 BH X

Configure: 100BASE-TX

Source Acquisition
lect | Data Mask Scale _
# of Wims
hl = Mar malF
= - Result |

Report

Connect Summaryl
Yiew wrml BEED |

100-Tx--=Template Data--=Chl Pol--=Both

Toyfigure;

Figure 5-2: 100BASE-TX Configure pane

The following table shows parameters of 100BASE-TX that you can configure:

Table 5-4: 100BASE-TX Configure parameters

Fulse width

Acquisition
Probe:P1
Probe:P2
Probe:P3

Praobe: P4

BWG Series

Load
# Averages
Srnooth

%.| Mask Scale
%.| Mask Setup

Termplate

Differential Dutput Yaltage

arplitude Syrmmetry

Rise Time

Fall Time

ASRYAN

Rise or Fall Time Syrmmetry

NESEVENENEN

W & eform Owershoot

Jitter

S RYENENESENENEN RN =2

<

Dty Cycle Distortion

Return Loss Transmitter ¥ ¥

Return Loss Receiver ¥
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The following table describes the 100BASE-TX configuration parameters:

Table 5-5: 100BASE-TX Configure parameter description

Configure parameters

Description

Source
Source —
Data

1w

Select the channel to which the Device Under Test (DUT) is connected.

Acquisition
Acquisition

# of Wims
Zample BRAverage 16
i

Select Sample or Average depending on the acquisition mode.

The Acquisition is only enabled for some tests. If you select Average, enter the number
of waveforms in # of Wfms field.

If you select Sample, the application assumes the number of waveforms as 1.

You can use the virtual keyboard or the general-purpose knobs to enter the values in
the Sample and Average text boxes.

Rise/Fall Time Test
RiseTFall Time Test

Select Pulse Width as 16 ns or 80 ns.
You can only configure this parameter for Rise/Fall Time Symmetry, Rise Time, and Fall
Time tests.

Select Mask Scale as Normal, 0.95, or 1.05 depending on the Mask scale factor.
You can configure Mask Scale only for Template test.

Mask Setup

You can configure the Samples and Fail Thresh. You can only configure these
parameters for the template tests.
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Table 5-5: 100BASE-TX Configure parameter description (cont)

Configure parameters

Return Loss Probe: P1 and Probe: P2 — Select the channels to which the probes are connected on
Sources the fixture.

Probhe:P1 Prohe:P2

Note: Depending on whether the Transmitter or Receiver is selected,
the source will change from P1/P3 and P2/P4.

AWG Series

— Output Waveform
Return Loss 0 dB Marker

Return Loss — Select the reference waveform on which the output waveform will be
stored.

0 dB Marker — Select the reference waveform on which you want the 0 dB Marker to
be indicated.

Note: Return Loss and 0 dB Marker fields appear only if you set Load

| Rel¥ | Ref2 ¥ 25 100 ohim.

# Averages Smooth{0-10) . .
o = AWG Series — Select the AWG Series to use. If you select the default value-Select—
s - then the application considers all AWGs other than the AWG 4xx series.

Load — Select the load as 85, 100, 111 ohm or 100 ohm.
# Averages — Enter the number of waveforms you want to average.
Smooth — Enter the smoothening factor.

The following table lists the configuration parameters and default settings:

Table 5-6: 100BASE-TX Configuration Default Settings

Parameter Options Default
Data CH1, CH2, CH3, CH4 CH1
Acquisition Sample, Average If you select Sample, the default value is 1.
If you select Average, the default # of Wfms
is 16.
Mask Scale Normal, 0.95, 1.05 Normal
Mask Setup See Mask Setup for information on default
Sample and Fail Thresh.
Pulse Width 16 ns, 80 ns 80 ns
Probe:P1/P3 CH1, CH2, CH3, CH4 CH1
Probe:P2/P4 CH1, CH2, CH3, CH4 CH2
AWG Series Select, AWG 4xx, AWG Select
2021, AWG 5xx, AWG 6xx,
AWG 7xx
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Table 5-6:
(cont)

100BASE-TX Configuration Default Settings

Parameter

Options

Default

Load

85, 100, 115 ohm or 100
ohm

85, 100, 115 ohm

Note: The two-channel oscilloscopes display the graticule only for 100 ohm

Load.

Smooth

| 0-10

| 7

Configuring 10BASE-T

Use this dialog box to configure 10BASE-T for Data source, Acquisition,
Harmonic Ones, and Mask Setup.

File Tests Results LUtlities Help

Confiqure: 10BASET-T

Source Acquisition
Select
- Data # of Wims
-
Ch1 ¥ 16

k Mask Selection
MAU Type MAU Scale
Internal ¥ Wor ma

TDSET3 B x|

Fesult

Summary

Detail

|1D—T——>Template——>MAU——>Both {Mormal+In) |Data-->Ch1 MaL Type--=Int  Mall Scale-- =hormal

Figure 5-3: 10BASE-T Configure pane
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The following table shows parameters of 10BASE-T that you can configure:

Table 5-7: 10BASE-T Configure parameters

Mask Harmnonic
Selection ones
(N3
o u L} il w [
= n L =] Lit] m o 5} =
I S O - O - B - O O - A g%
2lelE |2 S (8|2 e s s |8 |8 |8 60|28 |2
0 0 0 0 [u}
Ele|E (2|2 |58 |2 |2 |E|e |2 || |2 |8 |=|E|%
O L= i = = = i L= * ~ o o o =% k= 4 * w |
Ternplate Link Pulse | " | " | + " "y
Ternplate MaL v vl v | v
Template TP_IDL A I v
Jitter with Cable v v
Jitter without Cable | ¥ v
Cifferential Woltage v
Harmonic v A A
Return Loss v v
Transmitter v oY
Return Loss v v | Y v vy
Receiver
CM Woltage v

The following table describes the 10BASE-T configuration parameters:

Table 5-8: 10BASE-T Configure parameter description

Configure parameters Description
Source Select the channel to which the Device Under Test (DUT) is connected.
— Source
Data
Chl ¥
Acquisition Select Sample or Average depending on the acquisition mode. The Acquisition is only
Acquisition enabled for some tests.
# of Wims If you select Average, enter the number of waveforms in # of Wims field.
18 If you select Sample, the application assumes the number of samples as 1.

You can use the virtual keyboard or the general-purpose knobs to enter the values in
the Sample and Average text boxes.
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Table 5-8: 10BASE-T Configure

parameter description (cont)

Configure parameters

Description

Mask Selection
Mask Selection

MAU Type

MALU Scale

Internal W [ Mormane

Mask Selection
Section

E HHl T

Select MAU Type as Internal or External.

Select MAU Scale as Normal, 0.9, or 1.1 depending on the MAU scale factor.
Select Section as Both, Head or Tail depending on the section of mask to test.
You can configure MAU Type and MAU Scale only for Template MAU tests.
You can configure Section only for Template TP_IDL and Link Pulse tests.

Mask Setup
hask Setup

You can configure the Samples and Fail Thresh. You can only configure these
parameters for the template tests.

Harmonic all of ones

Harmonic Ones
OQutput [ # Averages | TimefScale

Fdath 1%

Select the math waveform on which the processed waveform will be displayed.
Enter the number of math waveforms to be averaged.
Enter the time or scale depending on the packet length being transmitted.

Sequence
Sequence

You can set the sequence to Normal (NLP) or Fast (FLP). You can only configure this
parameter for the Template Link Pulse test.

Test Options
Test Options
¥

Buoth

Select Both to perform Template and Timing tests, Template Only to perform Template
tests, and Timing Only to perform Timing tests. Timing tests are available for normal link
pulse.
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Table 5-8: 10BASE-T Configure parameter description (cont)

Configure parameters

Description

Return Loss
Sources
Probhe:P1 Prohe:P2

AWG Series

— Output Waveform

0 dB Marker
| Rei2¥

Return Loss
| Rl ¥

# Averages Smooth{0-10)

Probe: P1 and Probe: P2 — Select the channels to which the probes are connected on
the fixture.

Note: Depending on whether the Transmitter or Receiver is selected,
the source will change from P1/P3 and P2/P4.

Return Loss — Select the reference waveform on which the output waveform will be
stored.

0 dB Marker — Select the reference waveform on which you want the 0 dB Marker to
be indicated.

Note: Return Loss and 0dB Marker fields appear only if you set Load as
100 ohm.

AWG Series — Select the AWG Series to use. If you select the default value-Select-
then the application considers all AWGs other than the AWG 4xx series.

Load — Select the load as 85, 100, 111 ohm or 100 ohm.
# Averages — Enter the number of waveforms you want to average.
Smooth — Enter the smoothening factor.

The following table lists the configuration parameters and default settings:

Table 5-9: 10BASE-T Configuration Default Settings

Parameter Options Default
Data CH1, CH2, CH3, CH4 CH1
Acquisition Sample, Average If you select Sample, the default value is 1.
If you select Average, the default # of Wfms
is 16.
Section Both, Head, Tail Both
MAU Type Internal, External Internal
MAU Scale Normal, 0.9, 1.1 Normal
Mask Setup See Mask Setup for information on default
Sample and Fail Thresh.
Sequence Normal (NLP), Fast (FLP) Normal (NLP)
Test Options Both, Template Only, Both
Timing Only
Output Math1, Math2, Math3, Mathl
Math4
Time/Scale 10 micro seconds, 1micro 10 micro seconds
seconds
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Table 5-9: 10BASE-T Configuration Default Settings
(cont)
Parameter Options Default
# Averages 48 for other tests and 100 for Return Loss.
Probe:P1/P3 CH1, CH2, CH3, CH4 CH1
Probe:P2/P4 CH1, CH2, CH3, CH4 CH2
AWG Series Select, AWG 4xx, AWG Select
2021, AWG 5xx, AWG 6xx,
AWG 7xx
Load 85, 100, 111 ohm or 100 85, 100, 111 ohm

ohm

Note: The TDS5052B oscilloscope displays the graticule only for 100 ohm Load.

Smooth

| 0-10

| 7

TDSET3 Printable Help Document

5-13






Making Connections

1000BASE-T Connections

Template, Peak Volt, Use TC5 of the test fixture for these tests with disturbing signal and TC2 of the
Droop, and Distortion test fixture for these tests without disturbing signal.

With Disturbing Signal

Make the connections as shown by the following figure:

Tektronix AWG Tektronix Oscilloscope

FEeeme=== o) T
CH1

To Oscilloscope

.

To DUT

Bl

e [ om iE

To Ch 12 -
of AWG = R &l

Figure 6-1: 1000BASE-T Connections with disturbing signal for Template, Peak Volt,
Droop, and Distortion

For Template, Peak Volt, and Droop tests, set the DUT to generate a Test Mode 1
signal. For Distortion test, set the DUT to generate Test Mode 4 signal.

1. Connect the Ethernet cable to J700 and test port of the DUT.
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2. Connect a BNC Cable to AWG+ and Channel 1 of Arbitrary Waveform
Generator.

3. Connect a BNC Cable to AWG- and Channel 2 ( THI) of Arbitrary
Waveform Generator.

Note: The AWG waveforms are available in
C:\TekApplications\TDSET3\AWGWaveforms. You can use relevant waveform
files to generate the disturbing signal. Some of the AWG models do not support
the .set file for automatic settings. Refer to the ReadMe.txt file for instructions to
make those settings manually. In particular, ensure that the AWG clock
frequency is set to 250 MHz. This file is available in the corresponding AWG
waveform file folder. You can automate the AWG to transfer files and settings as
described in Automate AWG.

4. To test Pair A, do the following:
®  Short the jumpers J621, J630, J623, J721, J723, J680, and J781
®  Ensure that the other jJumpers are open

= Connect the Differential Probe to P18 and configured channel of the
oscilloscope

5. To test Pair B, do the following:
= Short the jJumpers J620, J622, J631, J721, J723, J680, and J781
®  Ensure that the other jumpers are open

®  Connect the Differential Probe to P18 and configured channel of the
oscilloscope

6. To test Pair C, do the following:
®  Short the jumpers J620, J623, J720, J730, J723, J680, and J781
®  Ensure that the other jJumpers are open

= Connect the Differential Probe to P18 and configured channel of the
oscilloscope

6-2 TDSET3 Printable Help Document



Making Connections

7. To test Pair D, do the following:
®  Short the jumpers J620, J623, J721, J722, J731, J680, and J781
®  Ensure that the other jumpers are open

®  Connect the Differential Probe to P18 and configured channel of the
oscilloscope

Without Disturbing Signal

Make the connections as shown by the following figure:

Tektronix Oscilloscope

A
s]l==

DUT OB .
yyyw v, vy I Lol Wi &y o]

; 2000

T l: —J

To DUT

= B
] x
%:l: i §EP|n EE P11
= B
i,

Figure 6-2: 1000BASE-T Connections without disturbing signal for Template, Peak
Volt, Droop, and Distortion

1. For Template, Peak Volt, and Droop tests, set the DUT to generate a Test

Mode 1 signal.
For Distortion test, set the DUT to generate a Test Mode 4 signal.
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2. Connect the Ethernet cable to J490 and test port of the DUT.

3. To test Pair A, connect the Differential Probe to P9 and configured channel
of the oscilloscope.

4. To test Pair B, connect the Differential Probe to P10 and configured channel
of the oscilloscope.

5. To test Pair C, connect the Differential Probe to P11 and configured channel
of the oscilloscope.

6. To test Pair D, connect the Differential Probe to P12 and configured channel
of the oscilloscope.

Note: Align the positive (+) probe-tip of the differential probe with the notch
marked on the test fixture.
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Making Connections

Jitter Master Filtered If you have access to TX_TCLK
Step 1

Use TC3 of the test fixture to calculate master clock jitter. Make the connections
as shown by the following figure:

Tektronix Oscilloscope

Link partner =
cooocogn
O-gl—oo
A E o |(HEE
= = lEELE ]
=T
N aaaa
/7 Test ) Iz ——
IJ',_' channel /;'
\Q spunl ;,f
e ; =7 TX_TCLK
e, veww
=33 ouT
I||! wiki ‘n
i+ N_g
B _:.-""
¥ 4
To Link Partner . TC 3 I—I_
A e13 Btz To DUT
e s i =
5 1501 —
C Pis EJ522 : I F—
D PiE EJ‘E:& -

Figure 6-3: 1000BASE-T Step 1 Connections for Jitter Master Filtered
1. Setthe DUT in Normal mode as Master.
2. Connect the Ethernet cable to J501 and test port of the DUT.

3. Connect the Test Channel spool to J580 and Link partner.
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4. Connect the active probe from TX_TCLK of the DUT to the configured
channel of the oscilloscope.

5. To test Pair A, connect the Differential Probe to P13 and configured channel
of the oscilloscope.

6. To test Pair B, connect the Differential Probe to P14 and configured channel
of the oscilloscope.

7. To test Pair C, connect the Differential Probe to P15 and configured channel
of the oscilloscope.

8. To test Pair D, connect the Differential Probe to P16 and configured channel
of the oscilloscope.
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Step 2

Use TC2 of the test fixture to calculate data jitter with respect to master clock.
Make the connections as shown by the following figure:

Tektronix Oscilloscope

i o]
- o :
8..G==
o =0 o
[l ¥ 5 It 5]
s Yo Ro Ne)
DUT | @ e@e F § B B |
L W, e
TX_TCLK
Tl [
A
i

TC 2
To DUT

[ ] A
o P10 = P11
[ ] s s
= E
e

To Oscilloscope

Figure 6-4: 1000BASE-T Step 2 Connections for Jitter Master Filtered
1. Setthe DUT to generate a Test Mode 2 signal.
2. Connect the Ethernet cable to J490 and test port of the DUT.

3. Connect the active probe from TX_TCLK of the DUT to the configured
channel of the oscilloscope.

4. To test Pair A, connect the Differential Probe to P9 and configured channel
of the oscilloscope.
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5. To test Pair B, connect the Differential Probe to P10 and configured channel
of the oscilloscope.

6. To test Pair C, connect the Differential Probe to P11 and configured channel
of the oscilloscope.

7. To test Pair D, connect the Differential Probe to P12 and configured channel
of the oscilloscope.

If you do not have access to TX_ TCLK

Tektronix Oscilloscope

O o nCo00

TC 2
To DUT

E]
[ 1] D
490 EEPW EE P11
[ ] . =
— E
a

To Oscilloscope

Figure 6-5: 1000BASE-T Connections for Jitter Master Filtered
1. Setthe DUT to generate a Test Mode 2 signal.

2. Connect the Ethernet cable to J490 and test port of the DUT.

6-8 TDSET3 Printable Help Document



Making Connections

Jitter Master Unfiltered

Link partner

k.’
= '_-d__' T_ _'—_:"__: .
F Test =\
/i channel 1}

\\\‘\‘m spool j i

-

.._:__________.-_ =

3. Totest Pair A, connect the Differential Probe to P9 and configured channel

of the oscilloscope.

4. To test Pair B, connect the Differential Probe to P10 and configured channel

of the oscilloscope.

5. To test Pair C, connect the Differential Probe to P11 and configured channel

of the oscilloscope.

6. To test Pair D, connect the Differential Probe to P12 and configured channel

of the oscilloscope.

If you have access to TX_TCLK

Use TC3 of the test fixture to calculate master clock jitter. Make the connections

as shown by the following figure:

Tektronix Oscilloscope

To Link Partner “

B

S0 58
CEolfz= o
=TS
= 3000
[I:J =

TE_TCLK
0w vvww
DUt
4

To DUT

TC 3 |
A PHEJ‘FM

a

L
"

c eis B
D -

P16 EJ523

 —
1501
—

s

Figure 6-6: 1000BASE-T Connections for Jitter Master Unfiltered
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Making Connections

6-10

Set the DUT to generate a Test Mode 2 signal.
Connect the Ethernet cable to J501 and test port of the DUT.
Connect the Test Channel spool to J580 and Link partner.

Connect the active probe from TX_TCLK of the DUT to the configured
channel of the oscilloscope.

To test Pair A, connect the Differential Probe to P13 and configured channel
of the oscilloscope.

To test Pair B, connect the Differential Probe to P14 and configured channel
of the oscilloscope.

To test Pair C, connect the Differential Probe to P15 and configured channel
of the oscilloscope.

To test Pair D, connect the Differential Probe to P16 and configured channel
of the oscilloscope.
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If you do not have access to TX_ TCLK

Tektronix Oscilloscope

g..c o
o |==

=[] O
L & bt o R ¥ ]

. oReReo Ne)

DUT [ 1

| - | -

TC 2
To DUT

=
[ ]

F

EE]HU EE!FH
i
a

To Oscilloscope

Figure 6-7: 1000BASE-T Connections for Jitter Master Unfiltered
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Set the DUT to generate a Test Mode 2 signal.
Connect the Ethernet cable to J490 and test port of the DUT.

To test Pair A, connect the Differential Probe to P9 and configured channel
of the oscilloscope.

To test Pair B, connect the Differential Probe to P10 and configured channel
of the oscilloscope.

To test Pair C, connect the Differential Probe to P11 and configured channel
of the oscilloscope.
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Jitter Slave Filtered

6. To test Pair D, connect the Differential Probe to P12 and configured channel
of the oscilloscope.

If you have access to TX_TCLK
Step 1

Use TC3 of the test fixture to calculate master and slave clock jitter. Make the
connections as shown by the following figure:

Tektronix Oscilloscope

Link partner TX_TCLK ———
B e
= OEEE o
==y
" aoaa
PN | '
I!I. TE St \:_.'.I "l D ]:l
I channel )':
5, W
Q*\::‘ spool ;w"{
'-:-_-_._T.... - TX_TCLK
f = e = seww
::M%E: DuUT
. __w
¥ 4
To Test channel TC 3 |—|_
spool A e13 Bt To DUT

Figure 6-8: 1000BASE-T
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e ]
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1580
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1501
—1

Step 1 Connections for Jitter Slave Filtered

1. Setthe DUT in Normal mode as Slave.
2. Connect the Ethernet cable to J501 and test port of the DUT.

3. Connect the Test Channel spool to J580 and Link partner.
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Connect the active probe from TX_TCLK of the DUT to the configured
channel of the oscilloscope.

Connect the active probe from TX_TCLK of the Link Partner to the
configured channel of the oscilloscope.

To test Pair A, connect the Differential Probe to P13 and configured channel
of the oscilloscope.

To test Pair B, connect the Differential Probe to P14 and configured channel
of the oscilloscope.

To test Pair C, connect the Differential Probe to P15 and configured channel
of the oscilloscope.

To test Pair D, connect the Differential Probe to P16 and configured channel
of the oscilloscope.
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Step 2

Use TC2 of the test fixture to calculate data jitter with respect to slave clock.
Make the connections as shown by the following figure:

Tektronix Oscilloscope

g.. oTe S o
==
o =0 (=]
Lol o o
. o We e Ne
L W, e
TE_TCLK

TC 2
To DUT

[ ] A
o P10 = P11
[ ] s s
= E
e

To Oscilloscope

Figure 6-9: 1000BASE-T Step 2 Connections for Jitter Slave Filtered
1. Setthe DUT to generate a Test Mode 3 signal.
2. Connect the Ethernet cable to J490 and test port of the DUT.

3. Connect the active probe from TX_TCLK of the DUT to the configured
channel of the oscilloscope.

4. To test Pair A, connect the Differential Probe to P9 and configured channel
of the oscilloscope.
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Making Connections

5. To test Pair B, connect the Differential Probe to P10 and configured channel

of the oscilloscope.

6. To test Pair C, connect the Differential Probe to P11 and configured channel

of the oscilloscope.

7. To test Pair D, connect the Differential Probe to P12 and configured channel

of the oscilloscope.

If you do not have access to TX_ TCLK

Tektronix Oscilloscope

g.. P
c = =
I=1=e] o]
Qoo
. anao
DUT | @ @00 § B @ & - |
. | —J —J
Eyy v, ve
Data (TM2/TM3)

"4 Test Fixture ( TF-GBE)

TC 2
To DUT

E]
[ 1 a
1490 EBPm EE P11
[ ] - =
— E
Y

To Oscilloscope

Figure 6-10: 1000BASE-T Connections for Jitter Slave Filtered
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Making Connections

Step 1:
1. Setthe DUT to generate test mode 2 signal.
2. Connect the Ethernet cable to J490 and test port of the DUT.

3. Connect the active probe from Data (TM2) to the configured channel of the
oscilloscope.

4. To test Pair A, connect the Differential Probe to P9 and configured channel
of the oscilloscope.

5. To test Pair B, connect the Differential Probe to P10 and configured channel
of the oscilloscope.

6. To test Pair C, connect the Differential Probe to P11 and configured channel
of the oscilloscope.

7. To test Pair D, connect the Differential Probe to P12 and configured channel
of the oscilloscope.

Step 2:
1. Setthe DUT to generate test mode 3 signal.
2. Connect the Ethernet cable to J490 and test port of the DUT.

3. Connect the active probe from Data (TM3) to the configured channel of the
oscilloscope.

4. To test Pair A, connect the Differential Probe to P9 and configured channel
of the oscilloscope.

5. To test Pair B, connect the Differential Probe to P10 and configured channel
of the oscilloscope.

6. To test Pair C, connect the Differential Probe to P11 and configured channel
of the oscilloscope.

7. To test Pair D, connect the Differential Probe to P12 and configured channel
of the oscilloscope.
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If you have access to TX_TCLK

Jitter Slave Unfiltered Use TC3 of the test fixture to calculate slave clock jitter. Make the connections
as shown by the following figure:

Tektronix Oscilloscope

Link partner TX_TCLK =
8S5TEog
= OIEEE o
oS0 o
. aoao
o == [ [
= g o
Test = — I
i channel )':
Q*‘x\& spool .~
= TX_TCLK
' e, v verw
* AR ouT
\ L
-,\ _ :,-.__

4

To Test channel TC 3 |
spool “ . p13 Btz To DUT

A
e |
LIS s |
- 1501
C Pis EJ522 1|1
o =

P16 HJ'E:*J

1580

Figure 6-11: 1000BASE-T Connections for Jitter Slave Unfiltered
1. Setthe DUT in Normal mode as Slave.
2. Connect the Ethernet cable to J501 and test port of the DUT.
3. Connect the Test Channel spool to J580 and Link partner.

4. Connect the active probe from TX_TCLK of the DUT to the configured
channel of the oscilloscope.

5. Connect the active probe from TX_TCLK of the Link Partner to the
configured channel of the oscilloscope.
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6. To test Pair A, connect the Differential Probe to P13 and configured channel
of the oscilloscope.

7. To test Pair B, connect the Differential Probe to P14 and configured channel
of the oscilloscope.

8. To test Pair C, connect the Differential Probe to P15 and configured channel
of the oscilloscope.

9. To test Pair D, connect the Differential Probe to P16 and configured channel
of the oscilloscope.

If you do not have access to TX_ TCLK

Tektronix Oscilloscope

g..g e
0==
o =0 (=]
Lol o o
. e e s
DUT [_, 2e® & B B B 1
wewy L
Data (TM2/TM3)

TC 2
To DUT

E]
| | A
o PID = P11
[ ] s s
= E
Y

To Oscilloscope

Figure 6-12: 1000BASE-T Connections for Jitter Slave Unfiltered (If you do not have
access to TX_ TCLK)
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Making Connections

Step 1:

1. Setthe DUT to generate test mode 2 signal.

2. Connect the Ethernet cable to J490 and test port of the DUT.

3. Connect the active probe from Data (TM2) to the configured channel of the
oscilloscope.

4. To test Pair A, connect the Differential Probe to P9 and configured channel
of the oscilloscope.

5. To test Pair B, connect the Differential Probe to P10 and configured channel
of the oscilloscope.

6. To test Pair C, connect the Differential Probe to P11 and configured channel
of the oscilloscope.

7. To test Pair D, connect the Differential Probe to P12 and configured channel
of the oscilloscope.

Step 2:

1. Setthe DUT to generate test mode 3 signal.

2. Connect the Ethernet cable to J490 and test port of the DUT.

3. Connect the active probe from Data (TM3) to the configured channel of the
oscilloscope.

4. To test Pair A, connect the Differential Probe to P9 and configured channel
of the oscilloscope.

5. To test Pair B, connect the Differential Probe to P10 and configured channel
of the oscilloscope.

6. To test Pair C, connect the Differential Probe to P11 and configured channel
of the oscilloscope.

7. To test Pair D, connect the Differential Probe to P12 and configured channel
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of the oscilloscope.
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Return Loss Use TC1 of the test fixture for calibration.

Make the connections as shown by the following figure:

Tekironix AWG Tektronix Oscilloscope
ektronix - -
BHHEO = 6 [+ g
= o o, = EE
P 5 8 : |z 0
e === = o= OIEE2 ¢
0= Eggga = o0 oo
D= ===
i} (o e e e
AEemmmem= e § B ) marker 1/Sync l ® @E® BEEEE J
CH1L CH1/CH2 iy I
e
“THE-
Rkl - ww put

To Channel 1 o= w B To DUT
UfAWG JZ"I.EB m;E? :
> - 1200
To Channel 2 m"B% B2 |
of AWG Jm'EE m;EE

Figure 6-13: 1000BASE-T Connections for Return Loss
1. Setthe DUT to generate a Test Mode 4 signal.
2. Connect the Ethernet cable to J200 and test port of the DUT.

3. Connect a BNC Cable to AWG+ and Channel 1 of Arbitrary Waveform
Generator.

4. Connect a BNC Cable to AWG- and Channel 2 ( CH1) of Arbitrary
Waveform Generator.
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Making Connections

Note: The AWG waveforms are available in
C:\TekApplications\TDSET3\AWGWaveforms. Some of the AWG models do not
support the .set file for automatic settings. Refer to the ReadMe.txt file for
instructions to make those settings manually. In particular, ensure that the
AWG clock frequency is set to 250 MHz. This file is available in the
corresponding AWG waveform file folder. You can automate the AWG to transfer
files and settings as described in Automate AWG.

5. To test Pair A, connect the Differential Probes to P1 (J240) and P2 (J230),
and configured channels of the oscilloscope.

6. To test Pair B, connect the Differential Probe to P3 (J241) and P4 (J231), and
configured channels of the oscilloscope.

7. To test Pair C, connect the Differential Probe to P5 (J242) and P6 (J232), and
configured channels of the oscilloscope.

8. To test Pair D, connect the Differential Probe to P7 (J243) and P8 (J233), and
configured channels of the oscilloscope.
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Return Loss Use TC1 of the test fixture for calibration. Make the connections as shown by the
Calibration  following figure:

Tektronix Oscilloscope

Tektronix AWG -
| |= == S m0 :
12 2222 SHo ™z o
il= 52522 oETete
U IL aaad
T ems=s=ssg o ¢ J | Marker 1/Sync | El o
CH1 EH1/CH2 - |Au{m =
- _II
v N
/ i =[]
-l ] =11
o, r . i
Test Fixture (TF-GBE) . = : For Calibration ~~™"

= To Oscilloscope

SHORT

OPEN

To Channel 1
of AWG

IRIXIIRI XN

[]

J=1

LOAD

ne"B% o {7
L3 >
na3 HE 0 EE

To Channel 2
of AWG

Figure 6-14: 1000BASE-T Connections for Return Loss Calibration
1. Connect the Ethernet cable to J200 and test port of the DUT.

2. Connect a BNC Cable to AWG+ and Channel 1 of Arbitrary Waveform
Generator.

3. Connect a BNC Cable to AWG- and Channel 2 ( ZH1) of Arbitrary
Waveform Generator.

Note: The AWG waveforms are available in
C:\TekApplications\TDSET3\AWGWaveforms.

4. To test Pair A, connect the Differential Probes to P1 (J240) and P2 (J230),
and configured channels of the oscilloscope.

5. To test Pair B, connect the Differential Probe to P3 (J241) and P4 (J231), and
configured channels of the oscilloscope.
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6. To test Pair C, connect the Differential Probe to P5 (J242) and P6 (J232), and
configured channels of the oscilloscope.

7. To test Pair D, connect the Differential Probe to P7 (J243) and P8 (J233), and
configured channels of the oscilloscope.

8. Connect CATS5 cable to J200 of TC1 and J702 for OPEN calibration.
9. Connect CATS5 cable to J200 of TC1 and J703 for SHORT calibration.
10. Connect CAT5 cable to J200 of TC1 and J704 for LOAD calibration.

CM Voltage Use TC4 of the test fixture for this test. Make the connections as shown by the
following figure:

Tektronix Oscilloscope

B
¢ O |HE= =
g QISEE o
oUoToTo
. O aa
K i
"-'r.l ity DUT
= o g |llllllll L L

=75 Test Fixture ( TF-GBE)

-

= |

(1900 | To Oscilloscope

o [#®] 1440
c [2®] 343
g [9®] ju3p
n (9] 45

— To DUT
JE
TC 4 =

Figure 6-15: 1000BASE-T Connections for CM Voltage
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1. Setthe DUT to generate Test Mode 4 signal.

2. Connect the Ethernet cable to J500 and test port of the DUT.

3. Connect a BNC Cable to J400 and configured channel of the oscilloscope.
4. To test Pair A, short J420 using a jumper.

5. To test Pair B, short J430 using a jumper.

6. To test Pair C, short J431 using a jumper.

7. To test Pair D, short J440 using a jumper.
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100BASE-TX Connections

All Tests except Return  Template, Differential Output Voltage, Amplitude Symmetry, Rise Time, Fall
Loss Time, Rise/Fall Time Symmetry, Waveform Overshoot, Jitter, Duty Cycle

Distortion.
Use TC2 of the test fixture for this test. Make the connections as shown by the

following figure:

Tektronix Oscilloscope

g.. LT
=l
il o=0EEE o
yyyw v, ve I Lol iy =y o]
. aaaa
T z [EZ : E:l
EEE
L = :'"l_l'qﬂ
:‘ PR

TC 2 ]
To DUT 2

E
[ A
=0= | g@
[ ] s A
o E
i -
i To Oscilloscope

Figure 6-16: All 100BASE-TX Connections except Return Loss

1. Setthe DUT to transmit scrambled idles.
2. Connect the Ethernet cable to J490 and test port of the DUT.

3. Connect the Differential Probe to P9 and configured channel of the
oscilloscope.
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Return Loss Use TC1 of the test fixture for this test. Make the connections as shown by the
following figure:

Tektronix Oscilloscope

Tektronix AWG
' ts.-mgo = 8o aTs aa
= —— = Ege'S
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Figure 6-17:
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100BASE-TX Connections for Return Loss

1.
2.

Set the DUT to generate scrambled idles.
Connect the Ethernet cable to J200 and test port of the DUT.

Connect a BNC Cable to AWG+ and Channel 1 of Arbitrary Waveform
Generator.

Connect a BNC Cable to AWG- and Channel 2 ( €H1) of Arbitrary
Waveform Generator.

Note: The AWG waveforms are available in
C:\TekApplications\TDSET3\AWGWaveforms. Some of the AWG models do not
support the .set file for automatic settings. Refer to the ReadMe.txt file for
instructions to make those settings manually. In particular, ensure that the
AWG clock frequency is set to 250 MHz. This file is available in the
corresponding AWG waveform file folder. You can automate the AWG to transfer
files and settings as described in Automate AWG.
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Return Loss

5. To test Transmitter, connect the Differential Probes to P1 (J240) and P2
(J230), and configured channels of the oscilloscope.

6. To test Receiver, connect the Differential Probe to P3 (J241) and P4 (J231),
and configured channels of the oscilloscope.

Use TC1 of the test fixture for this test. Make the connections as shown by the

Calibration  following figure:
Tektronix Oscilloscope
Tektronix AWG - -
Sc:vHO” 8 0 S
[ - 8 o :
Ig -1 E oEHO0lE=E o
gg == o~~~
il Qcéccf Aaaa
sEEs====r) |— o | Marker 1/Sync D 0 ] 3l @ o
CH1 CH1/CH2| I inux n —
mr
5 Lk -
.'J [l
Test Fixture (TF-GBE) | For Calibration ™™
A,
] L
=]
—1 &
]
¥
TC 1 &
— | &
To Channel 1 nao"[2 d G
of AWG 2u’Q3 B2 — |2
Bl g
To Channel 2 2’ Q% BR | — | S
of AWG za"Q3 s @3

Figure 6-18: 100BASE-TX Connections for Return Loss Calibration
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1. Connect the Ethernet cable to J200 and test port of the DUT.

2. Connect a BNC Cable to AWG+ and Channel 1 of Arbitrary Waveform
Generator.

3. Connect a BNC Cable to AWG- and Channel 2 ( CH1) of Arbitrary
Waveform Generator.

Note: The AWG waveforms are available in
C:\TekApplications\TDSET3\AWGWaveforms.

4. To test Transmitter, connect the Differential Probes to P1 (J240) and P2
(J230), and configured channels of the oscilloscope.

5. To test Receiver, connect the Differential Probe to P3 (J241) and P4 (J231),
and configured channels of the oscilloscope.

6. Connect CAT5 cable to J200 of TC1 and J702 for OPEN calibration.
7. Connect CAT5 cable to J200 of TC1 and J703 for SHORT calibration.

8. Connect CATS5 cable to J200 of TC1 and J704 for LOAD calibration.
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10BASE-T Connections

Link Pulse Use TC6 of the test fixture for this test without twisted-pair model and use TC7
of the test fixture for this test with twisted-pair model.

Without Twisted-pair model

Make the connections as shown by the following figure:

Tektronix Oscilloscope

g e
=alfE2 g
==l 1H
a=e=o=k
: aaoa
|‘|_|
DuUT
|---- wlww
- ]
LOAD 1[@&] 761 —
1701
LOAD 2[aw] 1760

LOAD 3[aa] 1550

=
[
=

TC 6

]
- TO DUT
= 3800
[ee] —

S =—=4%m

To Oscilloscope

Figure 6-19: 10BASE-T Connections for Link Pulse without Twisted-pair model
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1. Setthe DUT to generate a link pulse signal.
2. Connect the Ethernet Cable to J800 and test port of the DUT.

3. Connect the differential probe to P20 and configured channel of the
oscilloscope.

4. Using the jumpers, short the LOAD1, LOAD2 or LOAD3 (100 Ohm).
Ensure that the jJumper you have short and the LOAD you have selected in
the application are the same.

Note: LOAD3 (100 ohm) is optional and not required as per the 802.3-2002
standards.

With Twisted-pair model

Make the connections as shown by the following figure:

Tektronix Oscilloscope
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Figure 6-20: 10BASE-T Connections for Link Pulse with Twisted-pair model
1. Setthe DUT to generate a link pulse signal.

2. Connect the Ethernet cable to J990 and the test port of the DUT.
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3. Connect the differential probe to P22 and the configured channel of the

oscilloscope.

Using the jumpers, short the LOAD1, LOAD2 or LOAD3 (100 Ohm).

Ensure that the jJumper you have short and the LOAD you have selected in
the application are the same.

Note: LOAD3 (100 ohm) is optional and not required as per the 802.3-2002

standards.

MAU  Use TC7 of the test fixture for this test. Make the connections as shown by the

following figure:

Tektronix Oscilloscope
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Figure 6-21:

10BASE-T Connections for MAU

1. Setthe DUT to generate a pseudo-random sequence signal.

2. Connect the Ethernet Cable to J990 and test port of the DUT.

3.
partner.
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If you do not have a Link Partner, short J2 using a jumper. If J2 is not present, go
to the next step.

4. Connect the differential probe to P22 and configured channel of the
oscilloscope.

5. Short LOAD3 (100 Ohm) using a jumper.

TP_IDL Use TC6 of the test fixture for this test without Twisted-pair model and use TC7
of the test fixture for this test with Twisted-pair model.

Without Twisted-pair model

Make the connections as shown by the following figure:

Tektronix Oscilloscope

=0 BES 2
a0
L i i
3 G300 Test Fixture
|_ p = B B 5 = J { TF-GBE)
= : 7 = gy

To LINK PARTNER

.

. TO LINK PARTKER
LoAD 1 [@&] 1761

4

=N
—

701

LoAD 2 1760

(e=] —1

—
—1

T,

LOAD 3[ee] jp60

=
(=3
=4

TC 6

B

E
1850
-
2
=]

To Oscilloscope

Figure 6-22: 10BASE-T Connections for TP_IDL without Twisted-pair model
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1. Setthe DUT to generate a pseudo-random sequence signal.
2. Connect the Ethernet cable to J800 and test port of the DUT.

3. If you have a Link Partner, connect the Ethernet cable to J701 and link
partner. If you do not have a link partner, short J1 using a jumper. If J1 is not
present, go to the next step.

4. Connect the Differential Probe to P20 and configured channel of the
oscilloscope.

5. Using the jumpers, short the LOAD1, LOAD2 or LOAD3 (100 Ohm).
Ensure that the jJumper you have short and the LOAD you have selected in
the application are the same.

Note: LOAD3 (100 ohm) is optional and not required as per the 802.3-2002
standards.
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With Twisted-pair model

Make the connections as shown by the following figure:

Tektronix Oscilloscope

R
5 0B B
ola/DIsEE o
[ ol ol ]
Test Fixture 000
To LINK PARTNER { TF-GBE) L J
T = ) &
2 = =
DUT =
=
e !«?,!l
e et
— g ¥ o
E
TO LINK PARTNER 1880
1
— 12 4
— |
TO DUT 19490 >
— ) loaD i [ ]iezn To Oscilloscope
- P22
Eg Loap 2 [@®@]iez0 C——
Fi1 s30 [J2
TC =7 Laab 1 [ee]) -

Figure 6-23: 10BASE-T Connections for TP_IDL with Twisted-pair model
1. Setthe DUT to generate pseudo-random sequence signal.
2. Connect the Ethernet cable to J990 and test port of the DUT.

3. If you have a Link Partner, connect the Ethernet cable to J890 and Link
Partner.

If you do not have a link partner, short J2 using a jumper. If J2 is not present, go
to the next step.

4. Connect the Differential Probe to P22 and configured channel of the
oscilloscope.
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5. Using the jumpers, short the LOAD1, LOAD2 or LOAD3 (100 Ohm).
Ensure that the jJumper you have short and the LOAD you have selected in
the application are the same.

Note: LOAD3 (100 ohm) is optional and not required as per the 802.3-2002
standards.

Jitter with cable Use TC7 of the test fixture for this test. Make the connections as shown by the
following figure:

Tektronix Oscilloscope

g--d 'JP
=
ola/DIsEE o
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: 2 =
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£ ¥ . - 2 2
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—
— 32 4
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TO DUT 1390 i
— v loan i [@e gz To Oscilloscope
i Pid
Eg Laap @ [ew 830
P21 930 EE
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Figure 6-24: 10BASE-T Connections for Jitter with cable
1. Setthe DUT to generate a pseudo-random sequence signal.
2. Connect the Ethernet cable to J990 and test port of the DUT.

3. If you have a Link Partner, connect the Ethernet Cable to J890 and Link
Partner.

If you do not have a link partner, short J2 using a jumper. If J2 is not present, go
to the next step.
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4. Connect the Differential Probe to P22 and configured channel of the
oscilloscope.

5. Short LOAD3 (100 Ohm) using a jumper.

Jitter without cable Use TC6 of the test fixture for this test. Make the connections as shown by the
following figure:

Tektronix Oscilloscope

To LINK PARTNER

DuT
I WEyy Ll L]
" ]
= 1 TO LINK PARTNER
LoaD 1 [@%] 1761 lﬂ?
LOAD 2[ww] }760 _E

LDAD 3[a#] 1560

— TO DUT

TC 6

To Oscilloscope

Figure 6-25: 10BASE-T Connections for Jitter without cable
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1. Setthe DUT to generate a pseudo-random sequence signal.
2. Connect the Ethernet cable to J800 and test port of the DUT.

3. If you have a Link Partner, connect the Ethernet Cable to J701 and Link
Partner.

If you do not have a link partner, short J1 using a jumper. If J1 is not present, go
to the next step.

4. Connect the Differential Probe to P20 and configured channel of the
oscilloscope.

5. Short LOAD3 (100 Ohm) using a jumper.
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Differential Voltage Use TC6 of the test fixture for this test. Make the connections as shown by the
following figure:

Tektronix Oscilloscope

% oleo
=0 5= 3
a0ZEE g
[oda whae ke o]
‘ a0
I-I_I
To LINK PARTNER
DuT
|---- L L
r ]
n r—  TO LINK PARTNER
LoAD 1 [#e] 1761 lﬂ? —
LOAD 2 [aw] 1760 E

LOAD 3[@a] 1pen

=
[]
=1

TC 6

E__ TO DUT

ST =40
g

To Oscilloscope

Figure 6-26: 10BASE-T Connections for Differential Voltage
1. Setthe DUT to generate a pseudo-random sequence signal.

2. Connect the Ethernet cable to J800 and test port of the DUT.
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3. If you have a Link Partner, connect the Ethernet Cable to J701 and Link
Partner.

If you do not have a link partner, short J1 using a jumper. If J1 is not present, go
to the next step.

4. Connect the Differential Probe to P20 and configured channel of the
oscilloscope.

5. Short LOAD3 (100 Ohm) using a jumper.

Harmonic Use TC6 of the test fixture for this test. Make the connections as shown by the
following figure:

Tektronix Oscilloscope

To LINK PARTNER

DUT
J |---- AL L] I
3 ¥
u TO LINK PARTNER
LoaD 1[e®] 3761 lﬂ?
LOAD Z[wa] J760 —
LOAD 3[@®] 60 =
P20
N — TO DUT
g2 T
1 —
IEI Je0n ———
TC 6 FT =] =

To Oscilloscope

Figure 6-27: 10BASE-T Connections for Harmonic
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1. Setthe DUT to generate an all-one or an all-zero sequence signal.
2. Connect the Ethernet cable to J800 and test port of the DUT.

3. If you have a Link Partner, connect the Ethernet Cable to J701 and Link
Partner.

If you do not have a link partner, short J1 using a jumper. If J1 is not present, go
to the next step.

4. Connect the Differential Probe to P20 and configured channel of the
oscilloscope.

5. Short LOAD3 (100 Ohm) using a jumper.
Return Loss Use TC1 of the test fixture for this test. Make the connections as shown by the
following figure:

Tektronix Oscilloscope

Tektronix AWG
=20 L
- = = 2|E5= &
g; - - E} §: Q=52 0
= ==== .
Ble 23322 Y
2 o e NeRe
S Em===== ) | © §)Marker 1/Sync L B §E8® p & & ° I
CH1 CH1/CH2 T [Awxin I
)
— DUT

Test Fixture ( TF-GBE)

TC 1

To DUT

To Channel 1 ne"f= nw BB

of AWG szLPEa p_\fE? —]
- » 1200

To Channel 2 na"BF o’ B2 —

of AWG JM:'EE m‘BE

Figure 6-28: 10BASE-T Connections for Return Loss
1. Setthe DUT to generate a pseudo random sequence.

2. Connect the Ethernet cable to J200 and test port of the DUT.
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3. Connect a BNC Cable to AWG+ and Channel 1 of Arbitrary Waveform
Generator.

4. Connect a BNC Cable to AWG- and Channel 2 ( TH1L) of Arbitrary
Waveform Generator.

Note: The AWG waveforms are available in
C:\TekApplications\TDSET3\AWGWaveforms. Some of the AWG models do not
support the .set file for automatic settings. In particular, ensure that the AWG
clock frequency is set to 250 MHz. Refer to the ReadMe.txt file for instructions
to make those settings manually. This file is available in the corresponding AWG
waveform file folder. You can automate the AWG to transfer files and settings as
described in Automate AWG.

5. To test Transmitter, connect the Differential Probes to P1 (J240) and P2
(J230), and configured channels of the oscilloscope. Then, short the Jumper
J241.

6. To test Receiver, connect the Differential Probe to P3 (J241) and P4 (J231),
and configured channels of the oscilloscope.
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Return Loss Use TC1 of the test fixture for this test. Make the connections as shown by the
Calibration  following figure:

Tektronix Oscilloscope

Tektronix AWG

S::ao = 8 0 £ ..-.o

| [ === 6 bt ;

B ooos @ g osE ¥

%g SE==a oSeTeTe™

] [ aaooa
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CH1 TH1/CH2 = i‘”‘ - =

_I L)
THE
S L 2
Test Fixture (TF-GBE) ||~ —— _ For Calibration ~~™"
:.. 4
e N .
“= To Oscilloscope 1 E
: =]
— &
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¥
TC 1 H =]
— | &
To Channel 1 no"B2 wd 3
of AWG lZﬂrEa Jn!‘EE —1 1 o
,Ba ,Ea 1200 _— é
To Channel 2 O x —1 — 1 3
of AWG na"B3 B2

Figure 6-29: 10BASE-T Connections for Return Loss Calibration
1. Connect the Ethernet cable to J200 and test port of the DUT.

2. Connect a BNC Cable to AWG+ and Channel 1 of Arbitrary Waveform
Generator.

3. Connect a BNC Cable to AWG- and Channel 2 ( CH1) of Arbitrary
Waveform Generator.

Note: The AWG waveforms are available in
C:\TekApplications\TDSET3\AWGWaveforms.

4. To test Transmitter, connect the Differential Probes to P1 (J240) and P2
(J230), and configured channels of the oscilloscope. Then, short the Jumper
J241.
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To test Receiver, connect the Differential Probe to P3 (J241) and P4 (J231),
and configured channels of the oscilloscope.

Connect CATS5 cable to J200 of TC1 and J702 for OPEN calibration.
Connect CATS5 cable to J200 of TC1 and J703 for SHORT calibration.

Connect CATS5 cable to J200 of TC1 and J704 for LOAD calibration.
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CM Voltage Use TC4 of the test fixture for this test. Make the connections as shown by the
following figure:

Tektronix Oscilloscope

¢ a -]
ociQEEE 0
(ol vt s
Oaao
K g
¥ DuUT
o L — [— v ve

27 Test Fixture ( TF-GBE)

] = 4

(2400 | To Oscilloscope

o [@®] 1440
c [@®] 1434
s [®%] 3430
A [®9] 5439

210 To DUT
=E
TC 4 —

-

Figure 6-30: 10BASE-T Connections for CM Voltage
1. Setthe DUT to generate a pseudo-random sequence signal.

2. Connect one end of the Ethernet Cable to J500 of Test Fixture TC4 and the
other end to the test port of the DUT.

3. Connect a BNC Cable between J400 of Test Fixture TC4 and configured
channel of the oscilloscope.

Note: Do not use a TPA-BNC adapter at the oscilloscope.

4. Short J420 of Test Fixture TC4 using a jumper.
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Set up the Signal

1000BASE-T
The DUT needs to be set in different modes for various tests according to the
following table:
Table 7-1: Test and Pattern description
Test Pattern BIT1(9.15) | BIT2(9.14) | BIT3(9.13)
Template, Peak Volt, Droop Testmodel | 0 0 1
Jitter in Master mode Testmode?2 | 0 1 0
Jitter in Slave mode Testmode3 | 0 1 1
Distortion, Return Loss, CM Testmode4 | 1 0 0
Voltage
Normal Operation 0 0 0
Contact your PHY vendor for a program that allows you to modify the bits 13,
14, 15 in the GMII Management Register 9.

100BASE-TX

The following table lists the signal pattern that needs to be generated for each of
the 100BASE-TX tests:

Table 7-2: Test and Pattern description

Test Pattern
Template Scrambled idles
Differential Output Voltage Scrambled idles
Signal Amplitude Symmetry Scrambled idles
Rise Time Scrambled idles
Fall Time Scrambled idles
Rise/Fall Time Symmetry Scrambled idles
Waveform Overshoot Scrambled idles
Jitter Scrambled idles
Duty Cycle Distortion Scrambled idles or 0101 pattern
Return Loss Scrambled idles
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Set up the Signal

10BASE-T

7-2

If you are using a traffic generator to generate the signal, set the traffic generator
to generate the signal pattern as listed in the table.

If you are not using a traffic generator to generate the signal, contact your PHY
vendor for a special program to generate these patterns.

The following table lists the signal pattern that needs to be generated for each of
the 10BASE-T tests:

Table 7-3: Test and Pattern description

Test Pattern

Link Pulse Link Pulse

MAU Pseudo-random sequence
TP_IDL Pseudo-random sequence
Jitter Pseudo-random sequence
Differential Voltage Pseudo-random sequence
Harmonic All 1s or Os

Return Loss Pseudo-random sequence
CM Voltage Pseudo-random sequence

Note: If you are using a Link Partner, ensure that you do not test the Link Pulse
generated by the Link Partner, but test the Link Pulse generated by the DUT.

If you are using a traffic generator to generate the signal, set the traffic generator
to generate the signal pattern as listed in the table.

If you are not using a traffic generator to generate the signal, contact your PHY
vendor for a special program to generate these patterns.
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Template

1. Click Tests > Select > 1000BASE-T from the menu bar.

2. In Template/Volt tab, select a point in the Template group, for example, A.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 8-1: 1000BASE-T Template Configuration Options
Parameter Options To Do
Data CH1, CH2, CH3, Select the channel to which the DUT is connected.
or CH4
# Averages 64 to 10000 Enter the number of waveforms you want to average.
Output Refl, Ref2, Ref3, | Select the reference waveform on which the processed
or Ref4 waveform will be stored.
Disturbing Signal | Yes or No Select the options depending on whether the
Disturbing signal is present or not.
Note: Selecting Disturbing Signal as Yes,
enables the Jig Match in Connect pane.
Filter Int or Ext Select the options depending on whether the filter is

applied or not. If you select Ext, the application
assumes that the filter is applied externally.

5. Select Tests > Connect or Connect in the Selection pane and make

connections.

6. Select View WTfm in the Selection pane, to view and compare the waveform

with the acquired waveform.

7. If the disturbing signal is present and you have configured Disturbing Signal
as Yes, then click Run Test. The application does as described next.
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How To Test 1000BASE-T

=  Displays a message box to confirm the overwrite of the reference
waveform. Select Yes to continue

®  Checks whether the DUT is connected

" Sets the trigger

" Acquires, filters, and removes the disturbing signal
®  Normalizes the data

= Displays the processed waveform on selected output (reference
waveform) over the template mask

8. If the disturbing signal is not present and you have configured Disturbing
Signal as No, and then click Run Test. The application does the following:

=  Displays a message box to confirm the overwrite of the reference
waveform. Select Yes to continue

®  Checks whether the DUT is connected
®  Sets the trigger
®  Acquires, filters, and normalizes the data

®=  Displays the processed waveform on selected output (reference
waveform) over the template mask

If the test fails, the application captures the waveform, circles the hits and saves
the information to the report.

The following figure shows a typical processed waveform for Template Testing
on Points A, B, C, and D:

Figure 8-1: Waveform for 1000BASE-T Template Points A, B, C, and D

8-2 TDSET3 Printable Help Document



How To Test 1000BASE-T

The following figure shows a typical processed waveform for Template Testing
on Points F and H:

il
I=E—

Ref1 10.0ns

Figure 8-2: Waveform for 1000BASE-T Template Points F and H

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 4 ns.

The application also tests for mask and displays the results as pass or fail.

If the acquired waveform does not lie within the mask, click Manual Fit. Click
the arrow buttons to adjust the Ref waveform to fit into the mask. This repeats
the mask pass/fail test and displays the results in the Results Summary pane.

The application automatically displays the results as pass or fail. Select Results

in the Execution pane and then click Result Details button to view the detailed
results.

Peak Volt

1. Click Tests > Select > 1000BASE-T from the menu bar.

2. In Template/Volt tab, select a point in the Peak Volt group, for example, A.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.
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8-4

4. In the Configuration window, select the following options:

Table 8-2: 1000BASE-T Peak Volt Configuration Options
Parameter Options To Do
Data CH1, CH2, CH3, Select the channel to which the DUT is connected.
or CH4
# Averages 64 to 10000 Enter the number of waveforms you want to average.
Output Refl, Ref2, Ref3, | Select the reference waveform on which the processed
or Ref4 waveform will be stored.
Disturbing Signal | Yes or No Select the options depending on whether the
Disturbing signal is present or not.
Filter Int or Ext Select the options depending on whether the filter is
applied or not. If you select Ext, the application
assumes that the filter is applied externally.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

7. |Ifthe
as Ye

disturbing signal is present and you have configured Disturbing Signal
s, and then click Run Test.

The application does the following:

8. |Ifthe

Displays a message box to confirm the overwrite of the reference
waveform. Select Yes to continue

Checks whether the DUT is connected

Acquires, filters, and removes the disturbing signal

Finds the peak value of the point selected after filtering
Compares with the specification range specified by the standard
Displays the processed waveform on the selected output

disturbing signal is not present and you have configured Disturbing

Signal as No, and then click Run Test. The application does the following:

Displays a message box to confirm the overwrite of the reference
waveform. Select Yes to continue

Checks whether the DUT is connected

Acquires and filters the data
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®  Finds the peak value of the point selected after filtering
= Compares with the specification range specified by the standard

®  Displays the processed waveform on the selected output

The following figure displays a typical DUT waveform for Peak Voltage Testing
on Points A, B, C, and D:

Figure 8-3: Waveform for 1000BASE-T Peak Volt Points A, B, C, and D

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 4 ns.

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Droop

1. Click Tests > Select > 1000BASE-T from the menu bar.

2. Inthe Droop tab, select a point, for example, G.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.
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8-6

4. In the Configuration window, select the following options:

Table 8-3: 1000BASE-T Droop Configuration Options

Parameter Options To Do
Data CH1, CH2, CH3, Select the channel to which the DUT is connected.
or CH4
# Averages 64 to 10000 Enter the number of waveforms you want to average.
Output Refl, Ref2, Ref3, | Select the reference waveform on which the processed
or Ref4 waveform will be stored.
Disturbing Signal | Yes or No Select the options depending on whether the
Disturbing signal is present or not.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

7. If the disturbing signal is present and you have configured Disturbing Signal
as Yes, and then click Run Test.

The application does the following:

Displays a message box to confirm the overwrite of the reference
waveform. Select Yes to continue

Checks whether the DUT is connected
Acquires and removes the disturbing signal

Displays the processed waveform on selected output and places vertical
cursors at Point F and Point G

Displays the cursor values — voltage, time, voltage difference and time
difference — at the points F and G

8. If the disturbing signal is not present and you have configured Disturbing
Signal as No, and then click Run Test. The application does the following:

Checks whether the DUT is connected

Displays the acquired waveform and places vertical cursors at Point F
and Point G

Displays the cursor values — voltage, time, voltage difference, and time
difference — at the Point F and Point G
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The following figure shows a typical DUT waveform showing points F and G:

Figure 8-4: Waveform for 1000BASE-T Droop Points F and G

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Jitter Master Filtered

1. Click Tests > Select > 1000BASE-T from the menu bar.

2. Inthe Jit/Distortion tab, select Master Filtered.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 8-4: 1000BASE-T Jitter Master Filtered
Configuration Options

Parameter Options To Do
Data CH1, CH2, CH3, Select the channel to which the DUT is connected.
or CH4
Master CLK CH1, CH2, CH3, Select the channel to which the Master TX_TCLK is
or CH4 connected.
Clock Edge Rising or Falling Select the clock edge on which the oscilloscope finds
the trigger point.
Record Length Varies depending on the Memory option available on
the oscilloscope.
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Table 8-4: 1000BASE-T Jitter Master Filtered
Configuration Options (cont)

Parameter Options To Do
TX_TCLK Yes, No Select Yes if you have access to TX_TCLK. Select No
if you do not have access to TX_TCLK.
Data (TM2) CH1, CH2, CH3, Select the channel to which the Test Mode 2 signal is
or CH4 connected.
Hysteresis 5.00% to 30.00% Enter the hysteresis percent value.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

If you have access to TX_TCLK

7. Click Run Test. The application displays the following dialog box:

Ethernet Compliance Test Software

Set OUT in Marma 0
HPF of cutoff plied ko jitker wavefor ms.

Figure 8-5: 1000BASE-T Jitter Master Filtered Step 1
8. Setthe DUT in Normal mode as Master and connect to the Link Partner.
9. Click OK. The application does the following:
" Checks whether the Master TX_TCLK is connected

= Sets up the signal, where at least 10° edges (minimum of opt. 3M
required) are available

=  Derives the jitter waveform, applies the filter

= Determines the peak-to-peak value of the filtered waveform
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10. The application displays the following dialog box:

Ethernet Compliance Test Software
e

—— TC2 P12 H
= r
r I‘JDH:—-;|H
[ 3 "
i i [ o A=

INil

1
=l

Set OUT in Test mode 2.
Connect Data and Master TH_TCLE tothe ozcillozcope.

Cancel

Figure 8-6: 1000BASE-T Jitter Master Filtered Step 2
11. Set DUT in Test mode 2 and connect Data and Clock to the oscilloscope.

12. Click OK. The application checks whether the Data and Master CLK signal
are connected and then measures jitter (Jtxout) of the data with respect to the
Master CLK.

13. Displays the TIE plot of the jitter waveform as shown by the following
figure:

-------------- Plaster-dr Dr- - - M - o oo

Figure 8-7: Waveform for 1000BASE-T Jitter Master Filtered

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 1250
edges.

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.
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If you do not have access to TX_TCLK (this is only an informative test and
not a compliance test)

7. Click Run Test. A message box appears. Click OK to quit the message box
and continue running the test.

1000Base-T Jitter Test {Alternate

8. Setthe DUT in Test Mode 2 and connect Data (TM2) to the oscilloscope.
9. Click OK. The application does the following:
®  Checks whether Data (TM2) is connected

®  Sets up the signal, where at least 105 edges (minimum of opt. 4M
required) are available

®  Derives the jitter waveform, applies the filter
®  Determines the peak-to-peak value of the filtered waveform
10. Displays the TIE plot of the jitter waveform.

The following figure shows a typical TIE plot of Jitter waveform:

Nl 'ﬂ Ml M’ ‘“W"| M |\'||Miﬂ“ w W “Nr \lu HWWM W

Figure 8-8: 1000BASE-T Jitter Master Filtered (without TX_TCLK)

N
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Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 625
edges. This is an alternate test method for jitter measurement being proposed,
when TX TCLK is not accessible. This is an informal test method.

The application automatically displays the results as inconclusive or fail. Select
Results in the Execution pane and then click Result Details button to view the
detailed results.

Jitter Master Unfiltered

1. Click Tests > Select > 1000BASE-T from the menu bar.

2. Inthe Jit/Distortion tab, select Master Unfiltered.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 8-5: 1000BASE-T Jitter Master Unfiltered
Configuration Options

Parameter Options To Do
Master CLK CH1, CH2, CH3, Select the channel to which the Master TX_TCLK is
or CH4 connected.
Clock Edge Rising or Falling Select the clock edge on which the oscilloscope finds
the trigger point.
Meas Type Histogram or TIE Select the measurement type.
Record Length Varies depending on the Memory option available on

the oscilloscope.

Note: The Record Length is enabled only if
you select Meas Type as TIE.

TX_TCLK Yes, No Select Yes if you have access to TX_TCLK. Select No
if you do not have access to TX_TCLK.
Data (TM2) CH1, CH2, CH3, Select the channel to which the Test Mode 2 signal is
or CH4 connected.
Hysteresis 5.00% to 30.00% Enter the hysteresis percent value.
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5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

If you have access to TX_TCLK

7. Click Run Test. The application does the following for Histogram method:

Checks whether the Master TX_TCLK is connected

Trigger on Master TX_TCLK clock signal at 50% of peak-to-peak
amplitude

Sets up the oscilloscope horizontal and vertical scale based on Master
clock signal

Places a horizontal histogram on the pulse following the trigger pulse at
the trigger level

Reads the peak-to-peak jitter from the histogram
Compares the read out values with the values specified in the standard

Takes approximately one minute to achieve approximately 13 million
waveform acquisition

Displays the Master clock waveform

8. Click Run Test. The application does the following for TIE method:

Checks whether the Master TX_TCLK is connected

Trigger on Master TX_TCLK clock signal at 50% of peak-to-peak
amplitude

Derives the jitter waveform of the Master TX_TCLK with respect to
unjittered reference.

Determines the Pk-Pk value of jitter waveform
Compares the read out values with the values specified in the standard

Displays the TIE plot of the jitter waveform
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The following figure shows a typical TIE plot of Jitter waveform:

Figure 8-9: TIE Waveform for 1000BASE-T Jitter Master Unfiltered

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 1250
edges.

The following figure shows a typical Histogram plot of Jitter waveform:

19469493 4

Figure 8-10: Histogram Waveform for 1000BASE-T Jitter Master Unfiltered

Note: In TDS6000 and DPO7000 series oscilloscopes, approximately 13,000,000
waveform database samples are acquired.

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.
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If you do not have access to TX_TCLK (this is only an informative test and
not a compliance test)

7. Click Run Test. A message box appears. Click OK to quit the message box
and continue running the test.

1000Base-T Jitter Test (Alternate Mek

x|

ImesasLre menk

8. Setthe DUT in Test Mode 2 and connect Data (TM2) to the oscilloscope.

9. Click OK. The application does the following for Histogram method:

1000Base-T Jitter Test (Alternate Mek

Checks whether Data (TM2) is connected
Trigger on Data (TM2) signal at 50% of peak-to-peak amplitude

Sets up the oscilloscope horizontal and vertical scale based on Data
(TM2) signal

Places a horizontal histogram on the pulse following the trigger pulse at
the trigger level

Reads the peak-to-peak jitter from the histogram
Compares the read out values with the values specified in the standard

Takes approximately one minute to achieve approximately 13 million
waveform acquisition

Displays the Data (TM2) waveform.
x|

mmeasLre menk

10. Click OK. The application does the following for TIE method:

8-14

Checks whether Data (TM2) is connected
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®  Trigger on Data (TM2) signal at 50% of peak-to-peak amplitude

®  Derives the jitter waveform of Data (TM2) with respect to unjittered
reference

= Determines the Pk-Pk value of jitter waveform
®  Compares the read out values with the values specified in the standard
®  Displays the TIE plot of the jitter waveform

The following figure shows a typical TIE plot of Jitter waveform:

Figure 8-11: TIE Waveform for 1000BASE-T Jitter Master Unfiltered

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 625
edges. This is an alternate test method for jitter measurement being proposed,
when TX TCLK is not accessible. This is an informal test method.

The following figure shows a typical Histogram plot of Jitter waveform:

Figure 8-12: Histogram Waveform for 1000BASE-T Jitter Master Unfiltered
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Jitter Slave Filtered

8-16

Note: In TDS6000 and DPO7000 series oscilloscopes, approximately 13,000,000
waveform database samples are acquired.

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Note: The two-channel oscilloscopes do not support the Jitter Slave Filtered test.

1. Click Tests > Select > 1000BASE-T from the menu bar.

2. Inthe Jit/Distortion tab, select Slave Filtered.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 8-6: 1000BASE-T Jitter Slave Filtered
Configuration Options

Parameter Options To Do

Data CH1, CH2, CH3, or CH4 | Select the channel to which the DUT is connected.

Master CLK CH1, CH2, CH3, or CH4 | Select the channel to which the Master TX_TCLK
is connected.

Slave CLK CH1, CH2, CH3, or CH4 | Select the channel to which the Slave TX_TCLK is
connected.

Clock Edge Rising or Falling Select the clock edge on which the oscilloscope
finds the trigger point.

Record Length Varies depending on the Memory option available
on the oscilloscope.

TX_TCLK Yes, No Select Yes if you have access to TX_TCLK. Select

No if you do not have access to TX_TCLK.

Data (TM2) CH1, CH2, CH3, or CH4 | Select the channel to which the Test Mode 2 signal
is connected.

Data (TM3) CH1, CH2, CH3, 0r CH4 | Select the channel to which the Test Mode 3 signal
is connected.

Hysteresis 5.00% to 30.00% Enter the hysteresis percent value.
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5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

If you have access to TX_TCLK

7. Click Run Test. The application displays the following dialog box:

Ethernet Compliance Test Software

Device
Parman - 5 ] | Wiidar Tast

TH_TELH

Set OUT in Normal mode of aparatian.

HFF of cutoff-freq 32KHz is applied ta jitter waveforms. Cancel

Figure 8-13: 1000BASE-T Jitter Slave Filtered Step 1

8. Set the DUT in Normal mode as Slave and connect to the Link Partner.
9. Click OK. The application does the following:

®  Checks whether the Master TX_TCLK and Slave TX_TCLK are
connected

= Sets up the signal, where at least 10° (minimum of opt. 3M required)
edges are available

®  Derives the jitter waveform of Master TX_TCLK with respect to
unjittered reference

®  Derives the jitter waveform of Slave TX_TCLK with respect to Master
TX_TCLK

®  Applies the filter, and determines the peak-to-peak value of the filtered
waveforms
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10. The application displays the following dialog box:

Ethernet Compliance Test Software

TCl P12

Device E r - b
Under Test E}E p”H oy .;I_] q
’ — rﬁikﬂ::]—— =

T TH_TCL} p B L

Set OUT in Test mode 3.
Connect Data and Slave TE_TCLE tothe oscilloscope,

[k Cancel

Figure 8-14: 1000BASE-T Jitter Slave Filtered Step 2

11. Set DUT in Test mode 3 and connect Data and Slave TX_TCLK to the
oscilloscope.

12. Click OK. The application checks whether the Data and Slave TX_TCLK are
connected.

13. Then, the application measures jitter (Jtxout) of the data with respect to the
Slave TX_TCLK.

Displays the TIE plot of the Jitter waveform as shown by the next figure:

a-Filtargid Rk=-REk-Jitter- - - - - = - - ~Slava Jrs Sk o - - - - - 2

g

I|‘

B
|
|
|
|
|

2
Hl [ g Ll Nl I T..L

B

Fefz” " S20ps ~ & T00ps 7" """ "7 TR TTTTTITTTTT

Figure 8-15: Waveform for 1000BASE-T Jitter Slave Filtered

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 1250
edges.
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The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

If you do not have access to TX_TCLK (this is only an informative test and
not a compliance test)

7. Click Run Test. A message box appears. Click OK to quit the message box
and continue running the test.

8. Set the DUT to generate the signal in test mode 2.
9. Click OK. The application does the following:
Step 1:

®  Checks whether Data (TM2) is connected

®  Sets up the signal, where at least 105 edges (minimum opt. 4M
required) are available

®  Derives the jitter waveform of Data (TM2) with respect to unjittered
reference

®  Applies the filter, and determines the peak-to-peak value of the filtered
waveforms

Step 2:

1000-T: Jitter, Slave Filtered

Set the DUT in kest mode 3 and connect to the configured channel,
Click. Ok ko continue the best,

" Setthe DUT to generate the signal in test mode 3

®  Checks whether Data (TM3) is connected
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®  Sets up the signal, where at least 105 edges (minimum opt. 4M
required) are available

=  Derives the jitter waveform of Data (TM3) with respect to unjittered
reference

®  Applies the filter, and determines the peak-to-peak value of the filtered
waveforms

Displays the TIE plot of the Jitter waveform as shown by the next figure:

Stopped Sin

At
At

i

l 'I| il . -.' |-
1l

Figure 8-16: Waveform for 1000BASE-T Jitter Slave Filtered

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 625
edges. This is an alternate test method for jitter measurement being proposed,
when TX TCLK is not accessible. This is an informal test method.

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Jitter Slave Unfiltered

1. Click Tests > Select > 1000BASE-T from the menu bar.

2. Inthe Jit/Distortion tab, select Slave Unfiltered.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

8-20 TDSET3 Printable Help Document



How To Test 1000BASE-T

4. In the Configuration window, select the following options:

Table 8-7: 1000BASE-T Jitter Master Unfiltered

Configuration Options

Parameter Options To Do

Master CLK CH1, CH2, CH3, Select the channel to which the Master TX_TCLK is
or CH4 connected.

Slave CLK CH1, CH2, CH3, Select the channel to which the Slave TX_TCLK is
or CH4 connected.

Clock Edge Rising or Falling Select the clock edge on which the oscilloscope finds

the trigger point.
Meas Type Histogram or TIE Select the measurement type.

Record Length

Varies depending on the Memory option available on
the oscilloscope.

Note: The Record Length is enabled only if
you select Meas Type as TIE.

TX_TCLK Yes, No Select Yes if you have access to TX_TCLK. Select No
if you do not have access to TX_TCLK.
Data (TM2) CH1, CH2, CH3, Select the channel to which the Test Mode 2 signal is
or CH4 connected.
Data (TM3) CH1, CH2, CH3, Select the channel to which the Test Mode 3 signal is
or CH4 connected.
Hysteresis 5.00% to 30.00% Enter the hysteresis percent value.

5. Select Tests > Connect or Connect in the Selection pane and make

connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform

with the acquired waveform.

If you have access to TX_TCLK

7. Click Run Test. The application does the following for Histogram method:

®  Checks whether the Master TX_TCLK and Slave TX_TCLK are
connected

®  Triggers on Master TX_TCLK clock signal at 50% of peak-to-peak
amplitude

®  Sets up the oscilloscope horizontal and vertical scale based on Slave
TX_TCLK signal

®  Places a horizontal histogram on the Slave TX_TCLK pulse following
the trigger pulse at 50% of peak-to-peak amplitude
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8-22

Measures the peak-to-peak jitter from the histogram
Compares the read out values with the values specified in the standard

Takes approximately one minute to achieve approximately 13 million
waveform acquisition

Displays the Slave TX_TCLK waveform

8. Click Run Test. The application does the following for TIE method:

Checks whether the Master TX_TCLK and Slave TX_TCLK are
connected

Triggers on Master TX_TCLK clock signal at 50% of peak-to-peak
amplitude

Derives the jitter waveform of the Slave TX_TCLK with respect to
Master TX _TCLK

Determines the Pk-Pk value of jitter waveform
Compares the read out values with the values specified in the standard

Displays the TIE plot of the jitter waveform

TDSET3 Printable Help Document



How To Test 1000BASE-T

The following figure shows a typical TIE plot of Jitter waveform:

!

10005

Figure 8-17: TIE Waveform for 1000BASE-T Jitter Slave Unfiltered

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 1250
edges.

The following figure shows a typical Histogram plot of Jitter waveform:

Figure 8-18: Histogram Waveform for 1000BASE-T Jitter Slave Unfiltered

Note: In TDS6000 and DPO7000 series oscilloscopes, approximately 13,000,000
waveform database samples are acquired

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.
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If you do not have access to TX_TCLK (this is only an informative test and
not a compliance test)

7. Set the DUT to generate the signal in test mode 2.

8. Click Run Test. A message box appears. Click OK to quit the message box
and continue running the test.

The application does the following for Histogram method:
Step 1:
®  Checks whether Data (TM2) is connected
®  Triggers on Data (TM2) at 50% of peak-to-peak amplitude

= Sets up the oscilloscope horizontal and vertical scale based on Data
(TM2)

®  Places a horizontal histogram on the Data (TM2) pulse following the
trigger pulse at 50% of peak-to-peak amplitude

" Measures the peak-to-peak Data (TM2) jitter from the histogram

= Takes approximately one minute to achieve approximately 13 million
waveform acquisition

= Displays the Data (TM2) waveform

1000-T: Jitter, Slave Unfiltered

Set the DUT in kest mode 3 and connect to the configured channel,
Click O to continue the kest,

®  Set the DUT to generate the signal in test mode 3

®  Checks whether Data (TM3) is connected
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Triggers on Data (TM3) at 50% of peak-to-peak amplitude

Derives the jitter waveform of the Data (TM3) with respect to
unjittered reference

Determines the Pk-Pk value of Data (TM3) jitter waveform
Compares the read out values with the values specified in the standard

Displays the TIE plot of the jitter waveform

9. Click Run Test. A message box appears. Click OK to quit the message box
and continue running the test.

10. The application does the following for TIE method:
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Checks whether Data (TM2) and Data (TM3) are connected
Triggers on Data (TM2) at 50% of peak-to-peak amplitude

Derives the jitter waveform of the Data (TM2) with respect to
unjittered reference

Determines the Pk-Pk value of Data (TM2) jitter waveform
Triggers on Data (TM3) at 50% of peak-to-peak amplitude

Derives the jitter waveform of the Data (TM3) with respect to
unjittered reference

Determines the Pk-Pk value of Data (TM3) jitter waveform
Compares the read out values with the values specified in the standard

Displays the TIE plot of the jitter waveform
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The following figure shows a typical TIE plot of Jitter waveform:

1 AGYS
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Figure 8-19: TIE Waveform for 1000BASE-T Jitter Slave Unfiltered

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 625
edges. This is an alternate test method for jitter measurement being proposed,
when TX_TCLK is not accessible. This is an informal test method.

The following figure shows a typical Histogram plot of Jitter waveform:

Stapped

Figure 8-20: Histogram Waveform for 1000BASE-T Jitter Slave Unfiltered

Note: In TDS6000 and DPO7000 series oscilloscopes, approximately 13,000,000
waveform database samples are acquired

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.
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Distortion

Note: The TDS5000 series oscilloscopes are not recommended for 1000BASE-T
Distortion test.

1. Click Tests > Select > 1000BASE-T from the menu bar.

2. Inthe Jit/Distortion tab, select Distortion.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 8-8: 1000BASE-T Distortion Configuration Options

Parameter Options To Do
Data CH1, CH2, CH3, Select the channel to which the DUT is connected.
or CH4
# Averages 64 to 10000 Enter the number of waveforms you want to average.
Output Refl, Ref2, Ref3, | Select the reference waveform on which the processed
or Ref4 waveform will be stored.

Disturbing Signal | Yes or No Select the options depending on whether the

Disturbing signal is present or not.

TX_TCLK CHZ1, CH2, CH3, Select the channel to which the clock source is
or CH4 connected.
Hi Resolution 2t075 Enter the number of averages to be done in the

vertical domain.

Low Pass Filter Yes, No Select Yes or No depending on whether the noise

elimination filter is required.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

7. If the disturbing signal is present and you have configured Disturbing Signal
as Yes, and then click Run Test.

8. The application does the following:
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=  Displays a message box to confirm the overwrite of the reference
waveform. Select Yes to continue

®  Checks whether the DUT is connected

" Sets the trigger

9. The application displays the following dialog box:

Ethernet Compliance Test Software

. Don't show again

Figure 8-21: 1000BASE-T Distortion user control

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 10 ns.

®  Check the polarity of the signal

= If the trigger is not stable, adjust the trigger level for proper stable
trigger. Then click OK to continue

10. The application does the following:
= Acquires, filters, and removes the disturbing signal

" Jf TX_TCLK is set as Yes, the application samples the differential
signal output with the symbol rate of selected TX_ TCLK source at an
arbitrary phase and processes a block of 2047 consecutive samples
If TX_TCLK is set as No, the application samples the differential
signal output with the symbol rate with the estimated clock frequency
at an arbitrary phase and processes a block of 2047 consecutive
samples

®  Displays the error plot on selected output (reference waveform)
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11. If the disturbing signal is not present and you have configured Disturbing
Signal as No, and then click Run Test. The application does the following:

®=  Displays a message box to confirm the overwrite of the reference
waveform. Select Yes to continue

®  Checks whether the DUT is connected
" Sets the trigger
®  Acquires and filters the data

" fTX_TCLK is set as Yes, the application samples the differential
signal output with the symbol rate of selected TX_TCLK source at an
arbitrary phase and processes a block of 2047 consecutive samples

" If TX_TCLK is set as No, the application samples the differential
signal output with the symbol rate with the estimated clock frequency
at an arbitrary phase and processes a block of 2047 consecutive
samples

= Displays the error plot on selected output (reference waveform)

The following figure shows a typical error plot for Distortion:
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Figure 8-22: Waveform for 1000BASE-T Distortion

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.
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Return Loss

1. Click Tests > Select > 1000BASE-T from the menu bar.

2. Inthe Return Loss tab, select Return Loss.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 8-9: 1000BASE-T Return Loss Configuration

Options

Parameter Options To Do

Sources

P1/P3/P5/P7 CH1, CH2, CH3, or CH4 Select the channel to which the DUT is

P2/P4/P6/P8 CH1, CH2, CH3, or CH4 connected.

Output Waveform

Return Loss Refl, Ref2, Ref3, or Ref4 Select the reference waveform on which
the output waveform will be stored.

0 dB Marker Refl, Ref2, Ref3, or Ref4 Select the reference waveform on which
you want the 0 dB Marker to be indicated.
Note: These fields appear only if
you set Load as 100 ohm.

Pair ID A, B,CD Depending on the Pair ID selected the
sources will change from P1/P3/P5/P7 and
P2/P4/P6/P8.

Load 85, 100, 115 ohm or 100 ohm | Select the load as 85, 100, 111 ohm or 100
ohm.

#Averages 100 to 10000 Enter the number of waveforms you want to
average.

Smooth 0to 10 Enter the smoothening factor.

AWG Series Select, AWG 4xx, AWG 2021, | Select the AWG Series to use. If you select

AWG 5xx, AWG 6xx, AWG the default value-Select-then the
XX application considers all AWGs other than

the AWG 4xx series.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.
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6. Calibrate the test setup. If you do not calibrate the test setup before running
the test, an error message Error 412: Calibration Data Not Available appears.

7. Click Run Test. The application does the following:

®  Displays a message box to confirm the overwrite of the reference
waveform. Select Yes to continue

" Sets the trigger
®  Acquires, and computes the return loss

®  Displays the return loss curve on selected output (reference waveform)

If the test fails, the application captures the waveform, circles the hits and saves
the information to the report. The application obtains the hits information only

for the 100 ohm waveform.

The following figure shows a typical waveform for Return Loss:

§ Mar 99 12:30:47

Figure 8-23: Waveform for 1000BASE-T Return Loss

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed

results.
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CM Voltage

8-32

1. Click Tests > Select > 1000BASE-T from the menu bar.

2. Inthe CM Voltage tab, select CM Voltage.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 8-10: 1000BASE-T CM Voltage Configuration

Options

Parameter Options To Do

Data CH1, CH2, CH3, Select the channel to which the DUT is connected.
or CH4

5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

7. Click Run Test. The application does the following:

Checks whether the DUT is connected and a valid signal is acquired
Sets the trigger

Measures the Output VVoltage amplitude for positive and negative
pulses of 96 ns

Compares the values with the Standard

Displays the DUT waveform for Common Mode Voltage testing
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The following figure shows a typical waveform for Common mode Voltage:

Stopped 220 ALl

Figure 8-24: Waveform for 1000BASE-T Common mode Voltage

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.
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Template

1. Click Tests > Select > 100BASE-TX from the menu bar.

2. In the Parametric tab, select Output Volt.

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down

list.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

4. To change the configuration settings, select Tests > Configure from the menu
bar, or click the Configure button in the Selection pane.

5. In the Configuration window, select the following options:

Table 9-1: 100BASE-TX Template Configuration Options

Parameter Options To Do

Data CH1, CH2, CH3, or CH4 | Select the channel to which the DUT is
connected.

Acquisition Sample or Average Select the acquisition mode. If you select
Average, # of Wfms appears. Enter the number
of averages to test in the # of Wfms field.

6. Select Tests > Connect or Connect in the Selection pane and make
connections.

7. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

8. Click Run Test. The application does the following:
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Checks whether the DUT is connected and a valid signal is acquired

Sets up the trigger

Loads the AOI template mask

Carries out the mask pass/fail test
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If the test fails, the application captures the waveform, circles the hits and saves
the information to the report.

The following figure shows a typical DUT waveform for AOI template test:

Figure 9-2: Waveform for 100BASE-TX Template for Negative polarity

The application also tests for mask and displays the results as pass or fail.

If the acquired waveform does not lie within the mask, click Manual Fit. To
adjust the waveform to fit into the Mask, change the horizontal position and
vertical position using the general purpose knobs or the Virtual Keyboard. This
repeats the mask pass/fail test and displays the results in the Results Summary
pane.

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.
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Differential Output Voltage

1. Click Tests > Select > 100BASE-TX from the menu bar.

2. In the Parametric tab, select Output Volt.

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down

list.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

4. To change the configuration settings, select Tests > Configure from the menu
bar, or click the Configure button in the Selection pane.

5. In the Configuration window, select the following options:

Table 9-2:

Configuration Options

100BASE-TX Differential Output Voltage

Parameter

Options

To Do

Data

CH1, CH2, CH3, or CH4

Select the channel to which the DUT is
connected.

Acquisition

Sample or Average

Select the acquisition mode. If you select
Average, # of Wfms appears. Enter the number
of averages to test in the # of Wfms field.

6. Select Tests > Connect or Connect in the Selection pane and make
connections.

7. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

8. Click Run Test. The application does the following:
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The following figure shows a typical waveform of Differential Output VVoltage
test for positive pulse:

Figure 9-3: Waveform for 100BASE-TX Differential Output Voltage for Positive
polarity

The following figure shows a typical waveform of Differential Output Voltage
test for negative pulse:

Figure 9-4: Waveform for 100BASE-TX Differential Output Voltage for Negative
polarity

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.
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Signal Amplitude Symmetry

1. Click Tests > Select > 100BASE-TX from the menu bar.

2. In the Parametric tab, select Amp Sym.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the menu
bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 9-3: 100BASE-TX Amplitude Symmetry Configuration

Options

Parameter Options To Do

Data CH1, CH2, CH3, or CH4 | Select the channel to which the DUT is
connected.

Acquisition Sample or Average Select the acquisition mode. If you select
Average, # of Wfms appears. Enter the number
of averages to test in the # of Wfms field.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

7. Click Run Test. The application does the following:

TDSET3 Printable Help Document

Checks whether the DUT is connected and a valid signal is acquired

Sets up the trigger

Measures the Output VVoltage amplitude for positive and negative

pulses of 96 ns

Calculates the amplitude symmetry

Compares the values with the standard

9-5



How To Test 100BASE-TX

The following figure shows a typical waveform of Signal Amplitude Symmetry
test:

Figure 9-6: Waveform for 100BASE-TX Amplitude Symmetry for Negative polarity

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Rise Time

1. Click Tests > Select > 100BASE-TX from the menu bar.
2. Inthe Parametric tab, select Rise Time.

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down
list.
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Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

4. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

5. In the Configuration window, select the following options:

Table 9-4:

100BASE-TX Rise Time Configuration Options

Parameter

Options

To Do

Data

CH1, CH2, CH3, or CH4

Select the channel to which the DUT is
connected.

Acquisition

Sample or Average

Select the acquisition mode. If you select
Average, # of Wfms appears. Enter the number
of averages to test in the # of Wfms field.

Pulse Width

16ns or 80ns

Set Pulse Width to 16 ns or 80 ns.

6. Select Tests > Connect or Connect in the Selection pane and make

connections.

7. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

8. Click Run Test. The application does the following:

®  Checks whether the DUT is connected and a valid signal is acquired

®  Sets up the trigger

= Measures the rise time of the positive and negative pulses of the
configured pulse width

= Compares the values with the standard
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The following figure shows a typical waveform of Rise Time test:

Figure 9-8: Waveform for 100BASE-TX Rise Time for Negative polarity

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Fall Time

1. Click Tests > Select > 100BASE-TX from the menu bar.
2. Inthe Parametric tab, select Fall Time.

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down
list.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.
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4. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

5. In the Configuration window, select the following options:

Table 9-5:

100BASE-TX Fall Time Configuration Options

Parameter

Options

To Do

Data

CH1, CH2, CH3, or CH4

Select the channel to which the DUT is
connected.

Acquisition

Sample or Average

Select the acquisition mode. If you select
Average, # of Wfms appears. Enter the number
of averages to test in the # of Wfms field.

Pulse Width

16ns or 80ns

Set Pulse Width to 16 ns or 80 ns.

6. Select Tests > Connect or Connect in the Selection pane and make

connections.

7. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

8. Click Run Test. The application does the following:

®  Checks whether the DUT is connected and a valid signal is acquired

®  Sets up the trigger

®  Measures the fall time of the positive and negative pulses of the
configured pulse width

®  Compares the values with the standard
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The following figure shows a typical waveform of Fall Time test:

Figure 9-10: Waveform for 100BASE-TX Fall Time for Negative polarity

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.
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Rise/Fall Time Symmetry

1. Click Tests > Select > 100BASE-TX from the menu bar.

2. In the Parametric tab, select R/F Sym.

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down

list.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

4. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

5. In the Configuration window, select the following options:

Table 9-6: 100BASE-TX Rise/Fall Time Symmetry
Configuration Options

Parameter

Options

To Do

Data

CH1, CH2, CH3, or CH4

Select the channel to which the DUT is
connected.

Acquisition

Sample or Average

Select the acquisition mode. If you select
Average, # of Wfms appears. Enter the number
of averages to test in the # of Wfms field.

Pulse Width

16ns or 80ns

Set Pulse Width to 16 ns or 80 ns.

6. Select Tests > Connect or Connect in the Selection pane and make

connections.

7. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

8. Click Run Test. The application does the following:

®  Checks whether the DUT is connected and a valid signal is acquired

" Sets up the trigger

" Measures the rise and fall time for the configured pulse width

" Calculates the Rise/Fall Time Symmetry

= Compares the values with the standard
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The following figure shows a typical waveform of Rise/Fall Time Symmetry test:

Figure 9-12: Waveform for 100BASE-TX Rise/Fall Time Symmetry for Negative polarity

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Waveform Overshoot

1. Click Tests > Select > 100BASE-TX from the menu bar.
2. Inthe Parametric tab, select Overshoot.

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down
list.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.
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4. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

5. In the Configuration window, select the following options:

Table 9-7: 100BASE-TX Waveform Overshoot Configuration
Options

Parameter Options To Do

Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is

connected.

Acquisition

Sample or Average

Select the acquisition mode. If you select
Average, # of Wfms appears. Enter the number
of averages to test in the # of Wfms field.

6. Select Tests > Connect or Connect in the Selection pane and make
connections.

7. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

8. Click Run Test. The application does the following:

®  Checks whether the DUT is connected and a valid signal is acquired

®  Sets up the trigger

®  Measures the Overshoot for positive and negative pulses of 96 ns

®  Compares the values with the standard
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The following figure shows a typical waveform of Waveform Overshoot test:

Figure 9-14: Waveform for 100BASE-TX Waveform Overshoot for Negative polarity

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Jitter

1. Click Tests > Select > 100BASE-TX from the menu bar.

2. Inthe Parametric tab, select Jitter.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.
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4. In the Configuration window, select the following options:

Table 9-8: 100BASE-TX Jitter Configuration Options

Parameter Options To Do

Data CH1, CH2, CH3, or CH4 | Select the channel to which the DUT is
connected.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

7. Click Run Test. The application does the following:

Checks whether the DUT is connected and a valid signal is acquired

Sets up the trigger

Acquires the signal

Places a horizontal histogram at the crossing

Reads the peak-top-peak jitter from the histogram

Compares the values with the standard

The following figure shows a typical waveform of Jitter test:

Figure 9-15: Waveform for 100BASE-TX Jitter for Positive polarity
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Figure 9-16: Waveform for 100BASE-TX Jitter for Negative polarity

Duty Cycle Distortion

9-16

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

1. Click Tests > Select > 100BASE-TX from the menu bar.
2. Inthe Parametric tab, select Distortion.

3. Select Random or 0101 in the Pattern drop-down list.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

4. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

5. In the Configuration window, select the following options:

Table 9-9: 100BASE-TX Distortion Configuration Options

Parameter Options To Do
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is connected.
Acquisition Sample or Average Select the acquisition mode. If you select Average,

# of Wfms appears. Enter the number of
waveforms to test in the # of Wfms field.

6. Select Tests > Connect or Connect in the Selection pane and make
connections.
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7. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

8. Click Run Test. The application does the following:
®  Checks whether the DUT is connected and a valid signal is acquired
®  Sets up the trigger
®  Calculates the duty cycle distortion
= Compares the values with the standard

The following figure shows a typical waveform of Distortion test:
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Figure 9-17: Waveform for 100BASE-TX Distortion

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Return Loss

1. Click Tests > Select > 100BASE-TX from the menu bar.

2. Inthe Return Loss tab, select Transmitter or Receiver.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.
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9-18

4. In the Configuration window, select the following options:

Table 9-10:

100BASE-TX Return Loss Configuration

Options

Parameter Options To Do

Sources Select the channel to which the DUT is

P1/P3 CH1, CH2, CH3, or CH4 connected.

P2/P4 CH1, CH2, CH3, or CH4 -
Note: Depending on whether the
Transmitter or Receiver is selected,
the sources will change from P1/P3
and P2/P4.

Output Waveform

Return Loss

Refl, Ref2, Ref3, or Ref4

Select the reference waveform on which
the output waveform will be stored.

0 dB Marker Refl, Ref2, Ref3, or Refd Select the reference waveform on which
you want the 0 dB Marker to be indicated.
Note: These fields appear only if
you set Load as 100 ohm.
Pair ID A, B,C,D Depending on the Pair ID selected the
sources will change from P1/P3/P5/P7 and
P2/P4/P6/P8.
Load 85, 100, 115 ohm or 100 ohm | Select the load as 85, 100, 111 ohm or 100
ohm.
AWG Series Select, AWG 4xx, AWG 2021, | Selectthe AWG Series to use. If you select
AWG 5xx, AWG 6xx, AWG the default value-Select-then the
XX application considers all AWGs other than
the AWG 4xx series.
#Averages 100 to 10000 Enter the number of waveforms you want to
average.
Smooth 0to 10 Enter the smoothening factor.

5. Select Tests > Connect or Connect in the Selection pane and make

connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

7. Click Run Test. The application does the following:

=  Displays a message box to confirm the overwrite of the reference

waveform. Select Yes to continue

= Sets up the trigger
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®  Acquires and computes the return loss
= Displays the return loss curve on selected output (reference waveform)

If the test fails, the application captures the waveform, circles the hits and saves
the information to the report. The application obtains the hits information only
for the 100 ohm waveform.

The following figure shows a typical waveform for Return Loss Transmitter:

Figure 9-18: Waveform for 100BASE-TX Return Loss Transmitter

The following figure shows a typical waveform for Return Loss Receiver:

Figure 9-19: Waveform for 100BASE-TX Return Loss Receiver

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.
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MAU

1. Click Tests > Select > 10BASE-T from the menu bar.

2. Inthe Template tab, select MAU. In the adjacent drop-down list, select
Normal, Inverted, or Both.

Notel: The status bar displays the major configuration details. If you do not
want to change the configuration settings, you can skip Step 3.

Note2: If you select Both and if the test fails, then Locate hits and Flash hits
display the MAU Inverted failures.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 10-1:

10BASE-T MAU Configuration Options

Parameter

Options

To Do

Data

CH1, CH2, CH3, or CH4

Select the channel to which the DUT is
connected.

MAU Type

Internal, or External

Select the MAU Type.

MAU Scale

Normal, 0.9, 1.1

Select the MAU scale factor.

Mask Setup

Samples and Fail Thresh

Select the number of samples, and the number
of samples for fail thresh.

Report Setup

Device ID, Device
Description, and Report File

Configure the options to identify the report. You
can also choose to automatically preview a file.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

7. Click Run Test. The application does the following:

®  Checks whether the DUT is connected and a valid signal is acquired

®  Validates the DUT for noise and loads the mask
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®  Sets up the Vertical, Horizontal, and Trigger oscilloscope parameters

The application displays the following dialog box:

10Base-T: Template user contral

hanges ta the settings now.
antinue

Figure 10-1: 10BASE-T Template user control dialog box

" Toggle Lock Mask to Wfm between On and Off to lock or unlock the
mask to waveform when you zoom in or zoom out

" Toggle Mask Autofit between On and Off to allow the oscilloscope to
automatically fit the waveform to mask

®  Click OK to continue

The application then carries out the mask pass/fail test.

Note: The application introduces a gap in the mask where segments 1 and 5
merge.

If the test fails, the application captures the waveform, circles the hits and saves
the information to the report.

The following figure shows a typical DUT waveform for Template testing of
MAU Ext:

Figure 10-2: Waveform for 10BASE-T MAU Ext
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The following figure shows a typical DUT waveform for Template testing of
MAU Ext Inv:

Figure 10-3: Waveform for 10BASE-T MAU Ext Inv

The following figure shows a typical DUT waveform for Template testing of
MAU Int:

Figure 10-4: Waveform for 10BASE-T MAU Int

The following figure shows a typical DUT waveform for Template testing of
MAU Int Inv:

Figure 10-5: Waveform for 10BASE-T MAU Int Inv
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If the acquired waveform does not lie within the mask, click Manual Fit. To
adjust the waveform to fit into the Mask, change the horizontal position and
vertical position using the general-purpose knobs or Virtual Keyboard. This
repeats the mask pass/fail test and displays the results in the Results Summary
pane.

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Link Pulse

1. Click Tests > Select > 10BASE-T from the menu bar.
2. Inthe Template tab, select Link Pulse.

3. Inthe adjacent drop-down list, select the load with or without TPM — Loadl
w/o TPM, Load2 w/o TPM, 100 &2 w/o TPM, Loadl with TPM, Load2 with
TPM, or 100 £2 with TPM.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

4. To change the configuration settings, select Tests > Configure from the menu
bar, or click the Configure button in the Selection pane.
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5. In the Configuration window, select the following options:

Table 10-2:

10BASE-T Link Pulse Configuration Options

Parameter

Options

To Do

Data

CH1, CH2, CH3, or CH4

Select the channel to which the DUT is
connected.

Acquisition

Sample or Average

Select the acquisition mode.

If you select Average, # of Wfms appears.
Enter the number of waveforms to test in
the # of Wfms field.

Section

Both, Head, or Tail

Select the section of mask to test.

Note: If you select Both and if the
test fails, then Locate hits and
Flash hits display the Tail section
failures.

Mask Setup

# of Wfms and Fail Thresh

Select the number of waveforms to be
tested and the number of waveforms that
must fail for the test to fail.

Sequence

Normal (NLP), Fast (FLP)

Select the type of link pulse you want to
test.

Test Options

Both, Template Only, Timing
Only

Select Both to perform Template and
Timing tests, Template Only to perform
Template tests, and Timing Only to perform
Timing tests.

Note: Timing tests are available
only for normal link pulse.

6. Select Tests > Connect or Connect in the Selection pane and make

connections.

7. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

8. Click Run Test. The application does the following:

®  Checks whether the DUT is connected and a valid signal is acquired

®  Sets up the signal

®  Loads the front portion of the mask
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9. The application displays the following dialog box:

10Base-T: Template user control

Click OK to cantifue

W Don't s

Figure 10-6: 10BASE-T Template user control dialog box

®  Toggle Lock Mask to Wfm between On and Off to lock or unlock the
mask to waveform when you zoom in or zoom out

" Toggle Mask Autofit between On and Off to allow the oscilloscope to
automatically fit the waveform to mask

®  Click OK to continue

10. The application then carries out the mask pass/fail test.

Note: If you have selected the Section as Both, the application sets up the signal
and loads the front portion of the mask for the Head. Then, the application sets
up the signal and loads the tail portion of the mask. The application adds the
pass/fail result of both Head and Tail.

If the test fails, the application captures the waveform, circles the hits and saves
the information to the report.
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The following figure shows a typical DUT waveform for Link Pulse Timing test:
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Figure 10-7: Waveform for 10BASE-T Link Pulse Timing

The following figure shows a typical DUT waveform for Template testing of
Link Pulse:

Figure 10-9: Waveform for 10BASE-T Link Pulse Tail
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If the acquired waveform does not lie within the mask, click Manual Fit. To
adjust the waveform to fit into the Mask, change the horizontal position and
vertical position using the general purpose knobs or the Virtual Keyboard. This
repeats the mask pass/fail test and displays the results in the Results Summary
pane.

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Note: Link Pulse Timing test is not available in TDS6604 and TDS6804
oscilloscopes.
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TP_IDL

Click Tests > Select > 10BASE-T from the menu bar.

In the Template tab, select TP_IDL.

In the adjacent drop-down list, select the load with or without TPM — Loadl
w/o TPM, Load2 w/o TPM, 100 &2 w/o TPM, Loadl with TPM, Load2 with

TPM, or 100 L2 with TPM.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

4. To change the configuration settings, select Tests > Configure from the menu
bar, or click the Configure button in the Selection pane. In the Configuration

Table 10-3:

window, select the following options:

10BASE-T TP IDL Configuration Options

Parameter

Options

To Do

Data

CH1, CH2, CH3, or CH4

Select the channel to which the DUT is
connected.

Acquisition

Sample or Average

Select the acquisition mode.

If you select Average, # of Wfms appears.
Enter the number of waveforms to test in
the # of Wfms field.

Section

Both, Head, or Talil

Select the section of mask to test.

Note: If you select Both and if the
test fails, then Locate hits and
Flash hits display the Tail section
failures.

Mask Setup

# of Wfms and Fail Thresh

Select the number of waveforms to be
tested and the number of waveforms that
must fail for the test to fail.
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Select Tests > Connect or Connect in the Selection pane and make

connections.

Select View Wfm in the Selection pane, to view and compare the waveform

with the acquired waveform.
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7. Click Run Test. The application does the following:
®  Checks whether the DUT is connected and a valid signal is acquired
®  Sets up the signal
®  Loads the front portion of the mask

8. The application displays the following dialog box:

10Base-T: Template user control

You can make changes to the settings now.
Click Ok to continue

[ Don't show again

fask dukofit

Figure 10-10: 10BASE-T Template user control dialog box

®  Toggle Lock Mask to Wfm between On and Off to lock or unlock the
mask to waveform when you zoom in or zoom out

" Toggle Mask Autofit between On and Off to allow the oscilloscope to
automatically fit the waveform to mask

®  Click OK to continue

9. The application then carries out the mask pass/fail test.

Note: If you have selected the Section as Both, the application sets up the signal
and loads the front portion of the mask for the Head. Then, the application sets
up the signal and loads the tail portion of the mask. The application adds the
pass/fail result of both Head and Tail.

If the test fails, the application captures the waveform, circles the hits and saves
the information to the report.
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The following figure shows a typical DUT waveform for Template testing of
TP_IDL:

Figure 10-12: Waveform for 10BASE-T TP_IDL Tail

If the acquired waveform does not lie within the mask, click Manual Fit. To
adjust the waveform to fit into the Mask, change the horizontal position and
vertical position using the general purpose knobs or Virtual Keyboard. This
repeats the mask pass/fail test and displays the results in the Results Summary
pane.

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Differential Voltage

1. Click Tests > Select > 10BASE-T from the menu bar.

2. In the Parametric tab, select Diff Volt. From the Peak drop-down list, select
the peak value as Max or Min Max.
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Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the menu
bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 10-4: 10BASE-T Differential Voltage
Configuration Options

Parameter | Options To Do

Data CH1, CH2, CH3, or CH4 | Select the channel to which the DUT is connected.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

7. Click Run Test. The application does the following:
®  Checks whether the DUT is connected and a valid signal is acquired
®  Sets up the Vertical, Horizontal, Trigger oscilloscope parameters
" Measures the maximum and minimum voltages on the waveform

The following figure shows a typical DUT waveform for Differential Voltage:

Figure 10-13: Waveform for 10BASE-T Differential Voltage

10-12

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.
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How To Test 10BASE-T

Note: The application displays the probe offset value in the Result Details dialog
box.

Harmonic

1. Click Tests > Select > 10BASE-T from the menu bar.

2. Inthe Parametric tab, select Harmonic.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 10-5: 10BASE-T Harmonic Configuration Options

Parameter Options To Do

Data CH1, CH2, CH3, or CH4 | Select the channel to which the DUT is connected.

Harmonic Ones

Output Mathl, Math2, Math3, or | Select the math waveform on which the processed
Math4 waveform will be stored.

# of Averages Enter the number of waveforms to be averaged.

Time/Scale 1 or 10 microseconds Enter the time or scale depending on the packet

length being transmitted.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

7. Click Run Test. The application does the following:
®  Checks whether the DUT is connected and a valid signal is acquired

®  Sets up the Vertical, Horizontal, Trigger and Math Spectral
oscilloscope parameters

®  Displays the Math waveform
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How To Test 10BASE-T

The following figure shows a typical DUT waveform for Harmonic:

Figure 10-14: Waveform for 10BASE-T Harmonic

Note: The Harmonic result starts at 2 and ends at 25. If the calculated harmonic
frequency value is not in the range of + 0.5 MHz, then cursor- based readings of
the harmonic value are used.

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Jitter with cable

1. Click Tests > Select > 10BASE-T from the menu bar.

2. In the Parametric tab, select With Cable in the Jitter group. Select Normal,
8BT, 8.5BT, or All in the adjacent drop-down list.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the menu
bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 10-6: 10BASE-T Jitter with cable Configuration

Options

Parameter Options To Do

Data CH1, CH2, CH3, or CH4 | Select the channel to which the DUT is connected.
MAU Type Internal, or External Select the MAU Type as Internal or External.
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How To Test 10BASE-T

Select Tests > Connect or Connect in the Selection pane and make
connections.

Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

Click Run Test. The application checks whether the DUT is connected and a
valid signal is acquired.

If you selected 8BT or 8.5BT or All (Refer Step 2), the following window
appears:

Ethernet Compliance Test Software

Figure 10-15: 10BASE-T Jitter with cable user control

If the signal does not look like the one in the image, you can set up the
oscilloscope. The signal may not match the one in the image if an interpacket
interval is observed on the screen. Adjust these parameters in the oscilloscope:

9.
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Increase the trigger level so that the interpacket interval is not considered.
Trigger level is currently set to 60 mV accounting for the noise of 50 mV

If the signal still does not match the one in the image, adjust the trigger hold
off parameter. This adjustment will help in skipping the interpacket interval
and get the stable trigger every time

The application does the following:
" Sets up the signal
®  Places the horizontal histogram at the zero crossing
®  Reads the peak-to-peak jitter from the histogram
=  Compares the read out values with the standard

®  Acquires the signal for approximately 15 seconds
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If you have selected Output Timing Jitter as Normal, the application displays the
typical DUT waveform for Jitter with cable testing as shown in the following
figure:

Figure 10-16: Waveform for 10BASE-T Jitter with Cable for Normal output timing
jitter

If you have selected Output Timing Jitter as 8 BT, the application displays the
typical DUT waveform for Jitter with cable testing as shown in the following
figure:

173444 Acos

Figure 10-17: Waveform for 10BASE-T Jitter with Cable for
8 BT output timing jitter
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If you have selected Output Timing Jitter as 8.5 BT, the application displays the
typical DUT waveform for Jitter with cable testing as shown in the following
figure:

Figure 10-18: Waveform for 10BASE-T Jitter with Cable for 8.5 BT output timing
jitter

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Jitter without cable

1. Click Tests > Select > 10BASE-T from the menu bar.

2. In the Parametric tab, select w/o Cable in the Jitter group. Select Normal,
8BT, 8.5BT, or All in the adjacent drop-down list.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 10-7: 10BASE-T Jitter without cable
Configuration Options

Parameter Options To Do
Data CH1, CH2, CH3, or CH4 | Select the channel to which the DUT is connected.
MAU Type Internal, or External Select the MAU Type as Internal or External.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.
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How To Test 10BASE-T

Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

Click Run Test. The application checks whether the DUT is connected and a
valid signal is acquired.

If you selected 8BT or 8.5BT or All (Refer Step 2), the following window
appears:

Ethernet Compliance Test Software

. D [u] r'|'t [m1E] agair'u

at zero level, adjust trigger hald off.

Figure 10-19: 10BASE-T Jitter without cable user control

10-18

If the signal does not look like the one in the image, you can set up the
oscilloscope. The signal may not match the one in the image if an interpacket
interval is observed on the screen. Adjust these parameters in the oscilloscope:

9.

Increase the trigger level so that the interpacket interval is not considered.
Trigger level is currently set to 60 mV accounting for the noise of 50 mV

If the signal still does not match the one in the image, adjust the trigger hold
off parameter. This adjustment will help in skipping the interpacket interval
and get the stable trigger every time

The application does the following:
®  Sets up the signal
®  Places the horizontal histogram at the zero crossing
®  Reads the peak-to-peak jitter from the histogram
=  Compares the read out values with the Standard

= Acquires the signal for approximately 15 seconds
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If you have selected Output Timing Jitter as Normal, the application displays the
typical DUT waveform for Jitter with cable testing as shown in the following
figure:

Figure 10-20: Waveform for 10BASE-T Jitter without Cable for Normal output timing
jitter

If you have selected Output Timing Jitter as 8 BT, the application displays the
typical DUT waveform for Jitter with cable testing as shown in the following
figure:

Figure 10-21: Waveform for 10BASE-T Jitter without Cable for 8 BT output timing
jitter
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If you have selected Output Timing Jitter as 8.5 BT, the application displays the
typical DUT waveform for Jitter with cable testing as shown in the following
figure:

Figure 10-22: Waveform for 10BASE-T Jitter without Cable for 8.5 BT output timing
jitter

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and then click Result Details button to view the detailed
results.

Return Loss

1. Click Tests > Select > 10BASE-T from the menu bar.

2. Inthe Return Loss tab, select Transmitter or Receiver.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.

4. In the Configuration window, select the following options:

Table 10-8: 10BASE-T Return Loss Configuration Options

Parameter Options To Do
Sources Select the channel to which the DUT is connected.
P1/P3 CH1, CH2, CH3,
P2/PA or CH4 Note: Depending on whether the Transmitter
CH1, CH2, CH3, | or Receiver is selected, the sources will
or CH4 change from P1/P3 and P2/P4.
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Table 10-8:
(cont)

10BASE-T Return Loss Configuration Options

Parameter

Options

To Do

Output Waveform
Return Loss

Refl, Ref2, Ref3,
or Ref4

Select the reference waveform on which the output
waveform will be stored.

0 dB Marker Select the reference waveform on which you want the
Refl, Ref2, Ref3, | 0 dB Marker to be indicated.
or Ref4 _ _

Note: These fields appear only if you set Load
as 100 ohm.

AWG Series Select, AWG 4xx, | Selectthe AWG Series to use. If you select the default
AWG 2021, AWG | value-Select—then the application considers all AWGS
5xx, AWG 6xx, other than the AWG 4xx series.

AWG 7xx

Load 85, 100, 115 ohm | Select the load as 85, 100, 111 ohm or 100 ohm.
or 100 ohm

#Averages 100 to 10000 Enter the number of waveforms you want to average.

Smooth 0to 10 Enter the smoothening factor.

5. Select Tests > Connect or Connect in the Selection pane and make

connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform

with the acquired waveform.

7. Click Run Test. The application does the following:

= Displays a message box to confirm the overwrite of the reference
waveform. Select Yes to continue

= Sets up the trigger

®  Acquires and computes the return loss

=  Displays the return loss curve on selected output (reference waveform)

If the test fails, the application captures the waveform, circles the hits and saves
the information to the report. The application obtains the hits information only
for the 100 ohm waveform.

TDSET3 Printable Help Document

10-21
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The following figure shows a typical waveform for Return Loss Transmitter:

Figure 10-23: Waveform for 10BASE-T Return Loss Transmitter

The following figure shows a typical waveform for Return Loss Receiver:

Figure 10-24: Waveform for 10BASE-T Return Loss Receiver

The application automatically displays the results as pass or fail. Select Results
in the Execution pane and click Result Details button to view detailed results.

CM Voltage

1. Click Tests > Select > 10BASE-T from the menu bar.

2. Inthe CM Voltage tab, select CM Voltage.

Note: The status bar displays the major configuration details. If you do not want
to change the configuration settings, you can skip Step 3.

3. To change the configuration settings, select Tests > Configure from the
menu bar, or click the Configure button in the Selection pane.
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4. In the Configuration window, select the following options:

Table 10-9: 10BASE-T CM Voltage Configuration Options
Parameter | Options To Do

Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is connected.

5. Select Tests > Connect or Connect in the Selection pane and make
connections.

6. Select View Wfm in the Selection pane, to view and compare the waveform
with the acquired waveform.

7. Click Run Test. The application does the following:
®  Checks whether the DUT is connected and a valid signal is acquired
" Sets the trigger
®  Measures the maximum positive and negative voltage levels
" Compares the values with the Standard
= Displays the DUT waveform for Common mode Voltage testing

The following figure shows a typical waveform for Common mode Voltage:

245 doos

p= Jid
A Width - Chi

Figure 10-25: Waveform for 10BASE-T Common mode Voltage
The application automatically displays the results as pass or fail. Select Results

in the Execution pane and then click Result Details button to view the detailed
results.
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View Waveform for 1000BASE-T

Template, Peak Volt, Droop

File Tests Resulks Utiities Help

Dietail

Connect | i : 5

1000-T--=Template--=4 Data--=Chl Awg--=64 Output--=Refl Disturber--=Yes

Figure 11-1: 1000BASE-T View Waveform for Template, Peak Volt, and Droop with
disturbing signal

Fle Tests Results Uklities Help B x|

.
H—

| Configure

# i

Summaryl

Detail

Connect |

|1000-T-->Template—»a [pata—-=Chl Avg—-»64 Output-=Rsfl Disturber--=No

Figure 11-2: 1000BASE-T View Waveform for Template, Peak Volt, and Droop without
disturbing signal

Ensure the waveform displayed by the application in the circled portion is similar
to the acquired waveform.

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  For Template, Peak Volt, and Droop tests, check if the DUT is set to
transmit Test Mode 1 signal

®  Check the polarity of the signal
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View Waveform for 1000BASE-T

®  Check the correctness of jumper connections in the fixture

®  Check the correctness of the probing point in the fixture

Jitter Master

File Tests: Results Utiities Help TDSET3 B x|

]:
o
o
L

ff-;Cnnfigurel N 5 i ) it |
Connect | ¥ y Summary
Wwwm ; Yo M, on | Deatl |

[1000-T->Jitter Master— Filtered |Data->Chl  Master CLE->Ch2 T TCLE-->Yes |

Figure 11-3: 1000BASE-T View Waveform for Jitter Master Filtered (with TX TCLK
access)

File Tests Results Utlities Help TDSET3 B x|
1 3 our vaveform lo e image below. Then p 1 Test” button, -
Select | : e . e T —
- t 0t 0 I_-Ir:!l_p hutkan. Help
?-;Eunfigure e - .ﬂ
Connect ; f ; \ Summary
%wwm 1 % t Myl i W |\t
|'| 000-T -=Jitter Master-->Filtered |Data[TM2]->Chl T _TCLE-»Ma

Figure 11-4: 1000BASE-T View Waveform for Jitter Master Filtered (without TX_TCLK
access)
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View Waveform for 1000BASE-T

%Cnnfigurel
Connect |
mem

gt

|'IDDEI-T-->.JittelMaster-->Unfi|tered |Master CLE-->Ch2 T¥_TCLK-*Yes Meaz Type->TIE

Figure 11-5: 1000BASE-T View Waveform for Jitter Master Unfiltered (with TX_ TCLK
access)

File Testz Results Utilities Help TDSET3 B x|

%Eunfigurel . o

|1000-T - Jitter Master-» Unfitered |Data[TM2]--Ch1 T¥_TCLK-2Mo Meas Type->TIE

Figure 11-6: 1000BASE-T View Waveform for Jitter Master Filtered (without TX_TCLK
access)

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 10 ns.

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

" Check if the DUT is set to transmit Test Mode 2 signal
®  Check the correctness of test setup

®  Check the correctness of the probing point in the fixture
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Jitter Slave

File Test: Besults Utlites Help

Fvies Wi

. 2

TDSET3

I X |

' Result |

Sumrmary

Detail

[1000-T->Jitter Slave->Filtered

|Data->Ch1 Master CLE->Ch2 Slave CLK-*Ch3 T _TCLK-»Ves

Figure 11-7: 1000BASE-T View Waveform for Jitter Slave Filtered (with TX_ TCLK

access)

File Testz Hesulkz LUtilifies

Select

a

:-Ecunfigure

Connect

lili

e Wt

T

e 7

|;|E|[|

TDSET3

"huttan, ----=

Help

B X |

Summary

Detail

|1000-T-Jitter Slave->Filtered

|Data[Th2)---Chl Data[TM3]->Ch2 T _TCLK->MNo

Figure 11-8: 1000BASE-T View Waveform for Jitter Master Filtered (without TX_TCLK

access)

File Testz Resuls

Select |
Cnnfigurél
: .Ennnect.llll
mem

A i

Utiiies  Help

TDSET3

B x|

|1000-T - Jitter Slave->Unkitered

|MasterELK-->Eh2 Slave CLK-:Ch3 T#_TCLK-»Yes Measz Tupe

S TIE

Figure 11-9: 1000BASE-T View Waveform for Jitter Slave Unfiltered (with TX_TCLK

access)
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View Waveform for 1000BASE-T

File  Testz Hesulk: Utiities: Help TDSET3 Eﬂ

T the image below. Then
Select

o

form does not [ook like the image below, click the "Help" huttan,

%Configure

e - | Result

Connect

li i

Sumrmary

Detail

|| ———
| =

H

iy Wi

|1000-T - Jitter Slave->Unfitered |DataTM2]->Ch1  Data[TM3]-»Ch2 Tx_TCLE->MNo Meas Type->TIE

Figure 11-10: 1000BASE-T View Waveform for Jitter Master Filtered (without TX_ TCLK
access)

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 10 ns.

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is set to transmit the appropriate Test Mode signal
®  Check the correctness of test setup

®  Check the correctness of the probing point in the fixture

Distortion

File Tests Resuls Utiities Help TDSET3 B x|

Select |

| Configure

Result I

m

-~ Feport

Summaryl

Detail

Connect

Wiews Wim

Hid

|1000-T-->Distartion [Data--=Chi Avg--=64 Outpub—->Refl Disturber—=Mo TH_TCLK- Mo |

Figure 11-11: 1000BASE-T View Waveform for Distortion

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 10 ns.

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:
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®  Check if the DUT is set to transmit Test Mode 4 signal
®  Check the polarity of the signal
®  Check the correctness of jumper connections in the fixture

®  Check the correctness of the probing point in the fixture

Return Loss

Ele Testz Besults Utlites Help

ik Zel

i | . e image helow
A

:‘-Cnnfigurel wdd o b Lo |

R 1} ) |

Connest

1000-T-->Fetun Loss Pair ID-->C P5-3Ch1 PB-3Ch2 Awg-3100 Smooth->7

Figure 11-12: 1000BASE-T View Waveform for Return Loss

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is set to transmit Test mode 4 signal
®  Check if the polarity of probe connection is right

®  Check the correctness of the probing point in the Test Fixture

CM Voltage

File Tests Results Utiities Help

Select |

T

Cnnrigurel

+

Connect |

T

1000-T-- =M Volkage Data--=Chi

Figure 11-13: 1000BASE-T View Waveform for CM Voltage
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If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is set to transmit Test mode 4 signal
®  Check if the probe is properly locked to the oscilloscope

®  Check if all the connections are proper
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All 100BASE-TX Tests except Return Loss

File Tests Resuks Utiities Help TDSET3 B x|

O AT YR A AT T

|Data->Chl Pol->Both

N Detail

Figure 12-1: 100BASE-TX View Waveform for all tests except Return Loss

[100-T-> Template

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is set to transmit random sequence
®  Check if the polarity of probe connection is right

®  Check the correctness of the probing point in the Test Fixture

Return Loss

File Tests Results Ubiities Help TDSET3 BH X |

waveform [ooks like the image belo

ok |an

- S

[100-T#-- > Transmitter Return Loss [P1--»Chl P2->ChZ Avg-->100 Smooth--37

Figure 12-2: 100BASE-TX View Waveform for Return Loss Transmitter
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File Tests Results LUtiities Help TDSET3 BH x|

jun Test" butkan, ----=

elp” hutton. [ el

|100-T#--=Receiver Return Loss P3—-#Chl P4-»ChZ Avg—->100 Smooth--37

Figure 12-3: 100BASE-TX View Waveform for Return Loss Receiver

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is set to transmit random sequence
®  Check if the polarity of probe connection is right

" Check the correctness of the probing point in the Test Fixture
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Link Pulse

File Tests Results Utiliies Help

Select

+

Configure
Cannect

Fesult |

Report

Figure 13-1: 10BASE-T View Waveform for Link Pulse

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is transmitting the Link Pulse
®  Check if the probe is properly locked to the oscilloscope
®  Check if the polarity of probe connection is right

®  Check if all the connections are proper

MAU

File Tests Results Utiliies Help

Select

Summary

=)

10- Template--=MAl--=Both {Mormal+Inv) |Data—->Chl MAU Type--=Int MAL Scale--=MNormal

Figure 13-2: 10BASE-T View Waveform for MAU

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

" Check if the DUT is transmitting the Link Pulse
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View Waveform for 10BASE-T

®  Check if the probe is properly locked to the oscilloscope
®  Check if the polarity of probe connection is right

®  Check if all the connections are proper

TP_IDL

File Tests Results Utlities Help

Run Testl
Result |

Report

Summaryl

Select |
Configurel
Connest |

Detail

10-T--=Template--=TP_IDL-->100 ohm w/o TPM |Data-->Chl Acg-—=>Average Mask Section--=Bath

Figure 13-3: 10BASE-T View Waveform for TP_IDL

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is transmitting 10Base-T packets
" Check if the polarity of probe connection is right
®  Check if the probe is properly locked to the oscilloscope

®  Check if all the connections are proper

Jitter with or without cable

TDSET3 BH x|

File Tests Results LUtiities Help

— | wayefo 00 age helo : B p I ' = HunTestl

Cunrigurel
Connest |

Result |

Report

10-T--=Jitker-- =With Cable--=All Data--=Chl  MAaU Type-->Ink

Figure 13-4: 10BASE-T View Waveform for Jitter with cable
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View Waveform for 10BASE-T

File Tests Results Utiities Help

Run Testl
Fesult |

Repart

Summaryl
Dietail |

Data--=Chl MAL Type--=Int

10-T--=Jitker-- =wjio Cable--=all

Figure 13-5: 10BASE-T View Waveform for Jitter with cable

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is transmitting 10Base-T packets
®  Check if the probe is properly locked to the oscilloscope

®  Check if all the connections are proper

Differential Voltage

File Tests Results Utiides Help

ure orm loo e image helow. The un Test" hutton, ----=

Select ) Fun Test |
to huttan.

Configure sl |

Report
Connect Summaryl

Dietail

10-T--=DifF Yolk--=Max Peak Data--=Chl

Figure 13-6: 10BASE-T View Waveform for Differential Voltage

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is transmitting 10Base-T packets
®  Check if the polarity of probe connection is right
" Check if the probe is properly locked to the oscilloscope

®  Check if all the connections are proper
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Harmonic

File Tests Results Utlities Help

Fiun Test

ot

Report

Summary
[ietail

Data--»Chl  Outpuk--=Mathl

Select |
Configurel
Connect |

Figure 13-7: 10BASE-T View Waveform for Harmonic

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is transmitting 10Base-T packets

Check if the polarity of probe connection is right

Check if the probe is properly locked to the oscilloscope

Check if all the connections are proper

Return Loss

File Tests Results LUtiities Help

Selest | o ) - i : Run Testl
Cunfigurel e |

Report
Connest |

Summiary

|
EN

Detail

10-T-=Harmoric ~ |Data-=Chl Output--=Mathi

Figure 13-8: 10BASE-T View Waveform for Return Loss

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is transmitting 10Base-T packets

Check if the polarity of probe connection is right

Check if the probe is properly locked to the oscilloscope

®  Check if all the connections are proper
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CM Voltage

File Tests Results Utlities Help

Select o o - - e Hun_Testl
Configure il |

Fepart

Connect Summaryl
e thi Vyw NS A Detail |
1 Harmanic Data—-=Chl  Output--=Mathl

Figure 13-9: 10BASE-T View Waveform for CM Voltage

If the waveform displayed by the application is not similar to the acquired
waveform in the graticule, do the following:

®  Check if the DUT is transmitting 10Base-T packets
®  Check if the probe is properly locked to the oscilloscope

®  Check if all the connections are proper
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Generate Reports

You can automatically generate reports using the Report Summary or Details
button. You can use Report Configuration pane in the Result pane for
configuring the DUT details and report file name.

Use Report Generator to manually generate the report. For more information, see
the next section About Report Generator.

To manually generate the report, do the following:

1. From the application menu bar, select Utilities > Report Generator to
display Report Generator window.

2. Inthe Generate Report tab, select Browse. The Open dialog box displays all
the reports in the default directory c:\TekApplications\TDSET3\Report
Generator\Reports.

3. Inthe Open dialog box, select the relevant tests, and then select Open.

4. Inthe Generate Report tab, select Generate Report, Print Report, or Load
Report.

5. If you select Generate Report, the Assign Data to Report dialog box appears.

® Inthe Assign Data to Report dialog box, select the test templates to
assign the current data from your measurement application

®  Select Assign. The Report Viewer displays the report with current data
from the application. You can choose to export to rtf format

If you select Print Report, the Report Viewer displays the selected report with
current data from the application.

®  If the page settings do not match the page settings for the report, a Page
Size Mismatch message box displays a message — The current page
settings do not match the page settings for the Report. Do you want
to continue?

®  Click Yes to continue
= Click No to stop printing the report
® If a printer is connected to the oscilloscope, the report is printed

If you select View Report, the Report Viewer displays the selected report with
current data from the application.
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You can also define test templates, and define report layouts.

About Report Generator

14-2

The Report Generator enables you to generate and print reports directly from the
oscilloscope. It enhances the TDSET3 application capabilities by simplifying the
process of creating and maintaining reports.

The Report Generator automates the process of compiling the test results and
generating the reports. It allows you to set up the template layout using the
factory default templates or custom templates. The Report Generator allows you
to save files in the custom file formats such as .rgt, .rpl, or .rpt. The generated
reports can also be saved as an .rtf file. The Report Generator is integrated with
the TDSET3 application.

To generate a report in PDF format, you can use any tool that converts RTF to
PDF. For converting the .RPT to PDF, there are several tools such as
RoboPDFTM, GhostWriterTM and so on.

For more information on Report Generator, click here to view the Report
Generator Printed Help Document.

You can also access the file — ReportGenerator.pdf at C:\Program
Files\TekApplications\TDSET3.
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Automate AWG

Utilities > Automate AWG

This procedure will guide you through the process of connecting and configuring
the AWG and the oscilloscope for automation.

You will need: Tektronix AWG, Tektronix digital oscilloscope, and National
Instruments GPIB-USB-A cable with the included software (N1-488.2 for
Windows) or GPIB-USB-B cable with pre-installed software.

1. Connect the equipment and verify the connection.

2. From the TDSET3 menu, select Utilities > Automate AWG. The following
screen appears:

AWG Automation Setup

- Select - GPIB Setup
Address

Primary

Board Type T

GRFIED ¥

v

B Shiow File ovenarite warnings Halp - Glosa

‘l | Secondary Tast Connaction

Figure 15-1: AWG Automation Setup
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3. Select GPIB to automate the AWG and configure GPIB setup. The following
table describes the AWG Automation configuration parameters:

Table 15-1: AWG Configuration Parameters and

Descriptions

Configuration Parameter

Description

GPIB, Manual Select GPIB to automate file transfer and settings to the AWG.
Board Type Select the Board Type that you are using.

Primary Address Select the Primary GPIB Address.

Secondary Address Select the Secondary GPIB Address.

Show File overwrite warnings

When checked, warns you before transferring files on the AWG
while running a test.

Note: While running a test, the oscilloscope transfers waveform and setup files to
the AWG. Ensure that the AWG does not have files with the same name to avoid

overwriting those files.

4. Click Test Connection and look for a message that the connection is
successful. Test Connection is enabled only for the GPIB mode.

5. RUN the selected test.

If you have selected Manual to set up the AWG and configure GPIB setup, you

must:

" Copy the waveform files from C:\TekApplications\TDSET3\AWG

Waveforms

®  |oad the appropriate waveform onto the proper channel

= Make the AWG settings according to the ReadMe.txt in the
corresponding folder

®  Then RUN the test

Configuration Parameters and Default Settings:

15-2

Table 15-2: AWG Configuration Parameters and Defaults

Parameter Default
Select: GPIB, Manual Manual
Board Type GPIBO
Primary Address 9
Secondary Address 1

Show File overwrite warnings Checked
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Connect the Equipment and Verify the Connections

Before you connect the equipment and verify the connection, ensure that you
have installed NI1-488.2 for Windows. If you are using the GPIB-USB-B cable
verify that the software is pre-installed. Follow these steps to install NI-488.2 for
Windows.

1. Install NI-488.2 for Windows on the oscilloscope.
During installation:

2. Ensure that NI-VISA is NOT installed.

3. Install the Measurement and Automation Explorer.

4. When prompted, enable the GPIB-USB-A/B interface.
5. Restart the oscilloscope.

Connect the Equipment

1. Connect the GPIB-USB-A/B to the USB port on the oscilloscope (the
TDS7000B rear panel is shown here). The oscilloscope operating system will
detect the USB-GPIB controller and install the appropriate driver for it.

2. Connect the other end of the cable GPIB-USB-A/B to the AWG.

) UsB
GPIR Oscilloscope

AWG /

o]
S & @E S
& &

GPIB-LSE -AB
Figure 15-2: Connecting the AWG and the Oscilloscope
Verify the Equipment Connections

3. Open the Measurement and Automation Explorer that was installed with the
NI-488.2 software.
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4. In the Configuration pane, look under Devices and Interfaces for the GPIB

device.

L.\__, Instrumentl - Measurement & Automation Explorer HEE
Fie Edit ‘iew Toolz Help
J Eommunicate with Instrument | % NI Spy E."?L GFIB Analyzer
Configuration 2 | Instrumentd &) Show/Hide
Elg MiFystern I ame | Walue I Descrip
| =B Devices and Interfaces i G Adidrass 5
E1-{E8 GPIBN (GPIB-USE-4] i L
@] Ry Secondary Address Mone
I'ﬂ S aitvare & Identification SOMNY/TER &wG2021.0.CF91.1CT Rv: 250
g Rierate Systems B8 GFIB Interface Mumber 0
1] |
@] Attributes I

Figure 15-3: Verifying the instrument connections

5. Right-click on the GPIB device and click Scan for Instruments.

6. Note the GPIB Instrument Number and the Primary Address for configuring
the instrument connection in the TDSET3 application.

7. Right click on the instrument (InstrumentO in this example) and click
Communicate with Instrument.

8. Inthe NI-488.2 Communicator dialog box, click Query and check that
*IDN? brings up a description of the correct equipment.

9. From the Tekscope menu, select Utilities> GPIB Configuration. In the GPIB
Configuration, ensure that the Talk/Listen is selected and the primary address

matches the GPIB instrument number.

15-4
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E TekV¥I5A Rezource Manager Configuration

10. Search for the TekVISA configuration on one of the following:
®  Desktop
®  Start\Program Files\TekVISA\Tek VISA configuration

= Start\Program Files\TekVISA\OpenChoice Instrument Manager
configuration for application version 3.0.0 and above

If you cannot find TekVISA, rename the visa32.dll in C:\winnt\system32 and
then install the latest TekVISA.

11. Click on the Find/Refresh button to refresh the list of devices connected to
the oscilloscope.

— TekWI54& Rezources

Y154 Dezcriptar | [ezcriptor Aliaz | Local Lock | Local Shared Lock | Hoztt

ASRL1ZINSTR

ASRLZ:IMSTR

GFIBO:09:INSTR

GFIBS:1:IMSTR
Preferences. I
Call Manitor I 4_1

5ea e,
5,8,a s,

— Remote Hosts

Add...

Hoztname |

Rermove

i

Status: Ready

WISA Library: % 2.00e Tektronix

Figure 15-4: TekVISA Resource Manager Configuration
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For application version 3.0.0 and above, click "search criteria” in the Instrument
Manager. To confirm that the AWG is connected over GPIB to the oscilloscope,
select the "Search for GPIB" option and click Done.To update the list of devices
connected to the oscilloscope, click Update.

OpenChoice Instrument Manager

File Edt Help

Instruments I Applications and Utilities

GPRIBO::09::INSTR
[GPIB|GRIBS: 1 INSTR

- 111
[Last Updated: 4/3/2006 .25 Fiv

Instrument List Instrument
Update ldentify. ..

a 0 Start Application or Utility

search Criteria. . Froperties. ..

- Teklrnn;:x

Figure 15-5: TekVISA Resource Manager Configuration (application version 3.0.0 and
above)

12. If the NI-488.2 GPIB settings and TekVISA configuration do not match, the
connection/configuration might not be correct.

Note: If the AWG is not found listed in TekVISA (with the properties as in NI
VISA), make sure that TekVISA detects the GPIB devices. Sometimes it could
detect only those network devices that you see.
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13. Start the application and continue with AWG automation.

Note: While running a test, the oscilloscope transfers waveform and setup files to
the AWG. Ensure that the AWG does not have files with the same name to avoid
overwriting those files.
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Reference to Standards

1000BASE-T

Template Purpose:

To verify that the transmitter output fits the time domains transmit templates.
Reference to Standard:

Subclause 40.6.1.2.3 of IEEE standard 802.3-2002 ab

What Standard says:

According to standard, the Test Mode 1 signal from the DUT needs to be
normalized. This should be compared to the differential output templates shown
in Figure 40-26 of the standard. The normalization factors to be applied to
various points:

For Point A: Normalization with the peak voltage at point A.
For Point B: Normalization with the negative of peak voltage at point A.
For Point C: Normalization with 0.5 times the peak voltage at point A.

For Point D: Normalization with the negative of 0.5 times the peak voltage at
point A.

For Point F and H: The waveform around points F and H are compared to time
domain transmit template 2 after the following normalization factors are applied:

Normalization with the peak voltage at point F.
Normalization with the peak voltage at point H.

According to standard, the waveform can be shifted in time to fit the template.
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Peak Voltage Purpose:
To verify correct transmitter output levels.
Reference to the Standard:
Subclause 40.6.1.2.1 of IEEE standard 802.3-2002 ab
What the Standard says:

According to standard, magnitude of peak differential output voltage measure at
points A and B should be between 670 and 820 mV. Also, these conditions
should be met:

FeakVolicge B — |FeaklVolfag Al < 1%
| ge5|-| 2

|Pe'c:rk Vafmgfﬂ + |Pé'c:rk Vc:'fmgﬁq

{|Peak VoltagC|
2

2% of 0. Stmes
|PeakValtag D

Droop Purpose:

To verify that the transmitter output level does not decay faster than the
maximum specified rate.

Reference to the Standard:
Subclause 40.6.1.2.2 of IEEE standard 802.3-2002 ab

What the Standard says:

According to standard, the Point G and J are exactly 500 ns from Points F and H
respectively. The magnitude of voltage at Point G should be greater than 73.1%
magnitude of voltage at Point F and magnitude of voltage at Point J should be
greater than 73.1% magnitude of voltage at Point H.

Jitter (with TX_TCLK Purpose:
ACCESS)

To verify that the transmitter output level does not reduce faster than the
maximum specified rate.

Reference to the Standard:

Subclause 40.6.1.2.5 of IEEE standard 802.3-2002 ab

What the Standard says:
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Jitter Master Unfiltered — According to the standard, the peak-to-peak value
of jitter waveform on MASTER TX_TCLK relative to unfiltered reference
should be less than 1.4 ns.

Jitter Master Filtered — According to the standard, the peak-to-peak value of
jitter

waveform on MASTER TX_TCLK when filtered by a high pass filter, Hin(D)
with the transfer function below + JTx out of Data related to the corresponding
edge of MASTER TX_TCLK should be less than 0.3 ns.

_ A
f + 5000

Jitter Slave Unfiltered — According to the standard, the peak-to-peak value of
jitter waveform on SLAVE TX_TCLK relative to unfiltered reference should be
less than 1.4 ns.

H jfl':f:' = Jinfz

Jitter Slave Filtered —According to the standard, the peak-to-peak value of
jitter

waveform on SLAVE TX_TCLK when filtered by a high pass filter, Hin(f) \with
the transfer function below + JTx out of data related to the corresponding edge of
SLAVE TX_TCLK should be less than 0.4 ns + peak-to-peak value of jitter

waveform on MASTER TX_TCLK when filtered by a high pass filter, Hiﬂ':ﬂ.

H.IFE(.f:'= - 2

S Y 47
i+ 32000 %

Note: J denotes the square root of -1.

Jitter (without TX_TCLK

ACCESS) Purpose:

To provide an analysis of the Transmitter Timing Jitter test method defined in
Clause 40.6.1.2.5 of IEEE 802.3-2002, and to propose an alternative method that
may be used in cases where a device does not provide access to the TX TCLK
signal.

Reference:

1. |EEE standard 802.3-2002, subclause 40.6.1.1.1 — Test channel
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Reference to Standards

16-4

Ibid., subclause 40.6.1.1.2, figure 40-20 — Test modes

Ibid., subclause 40.6.1.1.3, figure 40-25 — Test fixtures

Ibid., subclause 40.6.1.2.5 — Transmitter Timing Jitter

Test suite appendix 40.6.A — L000BASE-T transmitter test fixtures

arwn

Note: The references mentioned here are proposed, and not part of a standard.
This is an alternate test method for jitter measurement being proposed, when
TX_TCLK is not accessible. This is an informal test method.

Transmitting Timing Jitter (Alternate Method):

Jitter Master Unfiltered — The peak-to-peak value of jitter waveform on data
in Test Mode 2 relative to unjittered reference should be less than 1.4 ns (pass).

The peak-to-peak value of jitter waveform on data in Test Mode 2 relative to
unjittered reference should be more than 1.4 ns (inconclusive).

Jitter Master Filtered — The peak-to-peak value of jitter waveform on data in
Test Mode 2 relative to unjittered reference, when filtered by a high pass filter,

Hin(£) with the transfer function below should be less than 0.3 ns (pass).

The peak-to-peak value of jitter waveform on data in Test Mode 2 relative to
unjittered reference,

when filtered by a high pass filter, HatE) \with the transfer function below should
be more than 0.3 ns (inconclusive).

_r
Jf + 2000
Jitter Slave Unfiltered — The difference between the peak-to-peak value of
jitter waveform on data in Test Mode 3 relative to unjittered reference and the

peak-to-peak value of jitter waveform on data in Test Mode 2 relative to
unjittered reference should be less than 1.4 ns (pass).

f m{f} = Jinfiz

The difference between the peak-to-peak value of jitter waveform on data in Test
Mode 3 relative to unjittered reference and the peak-to-peak value of jitter
waveform on data in Test Mode 2 relative to unjittered reference should be more
than 1.4 ns (fail).

Jitter Slave Filtered — The difference between the peak-to-peak value of jitter
waveform on data in Test Mode 3 relative to unjittered reference, when filtered
by a high pass filter,

Hin(f) with the transfer function below, and the peak-to-peak value of jitter
waveform on data in Test Mode 2 relative to unjittered reference,
when filtered by a high pass filter,
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Hin(f) with the transfer function below, should be less than 0.4 ns (pass).

The difference between the peak-to-peak value of jitter waveform on data in Test
Mode 3 relative to unjittered reference, when filtered by a high pass filter,

Hin(f) with the transfer function below, and the peak-to-peak value of jitter
waveform on data in Test Mode 2 relative to unjittered reference, when filtered
by a high pass filter,

Hin(f) with the transfer function below, should be more than 0.4 ns (fail).

_ i
Hnlf) i + 5000 itz

HJFE(f)= : 2ij

S Uy
i 32000°

Distortion  Purpose:
To verify that the peak distortion of the DUT is within the conformance limits.
Reference to the Standard:
Subclause 40.6.1.2.4 of IEEE standard 802.3-2002

What the Standard says:

The peak distortion of the Test Mode 4 differential signal, when sampled with the
symbol rate TX_TCLK at an arbitrary phase and processing this block of any
2047 consecutive samples, should be less than 10 mV.

CM Voltage Purpose:

To verify that the common-mode voltage of the DUT is within the conformance
limits.

Reference to Standard:
Subclause 40.8.3.3 of IEEE standard 802.3-2002
What Standard says:

The magnitude of the total common-mode output voltage, Ecm_out, on any
transmit circuit, shall be less than 50 mV peak-to-peak when transmitting data.
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Return Loss

100BASE-TX

16-6

Template

Differential Output
Voltage

Purpose:

To verify that the return loss of the device under test (DUT) is above the
conformance limit.

Reference to Standard:
Subclause 40.8.3.1 of IEEE standard 802.3-2002 ab
What Standard says:

At least 16 dB over the frequency range of 1.0 MHz to 40 MHz and at least 10 -
20log 10 (f/80)dB over the frequency range 40 MHz to 100 MHz (f in MHz).

Purpose:

To verify that the transmitter output fits the time domains transmit templates.
Reference to the Standard:

Annex J of ANSIX3.263-1995

What the Standard says:

According to standard, Active Output Interface (AOI) transmitting scrambled
Halt Line State should fit in the template.

Purpose:

To verify that the differential output voltage of the device under test (DUT) is
within the conformance limits.

Reference to the Standard:
Subclause 9.1.2.2 of ANSI X3.263-1995
What the Standard says:

According to standard, differential output voltage (Vo) should lie in the range of
950 mV to 1050 mV in both positive and negative excursion.
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Signal Amplitude Purpose:
Symmetry

To verify that the signal amplitude symmetry of the device under test (DUT) is
within the conformance limits.

Reference to Standard:

Subclause 9.1.4 of ANSI X3.263-1995

What Standard says:

The ratio of the + V,,, magnitude to — V,, magnitude shall be between the limits:

0.98 < [+V.| /|- V.| = 1.02

Rise and Fall Time Purpose:
To verify that the response times of the DUT are within the conformance limits.
Reference to Standard:
Subclause 9.1.6 of ANSI X3.263-1995
What Standard says:

Active Output Interface (AOI) rise and fall time shall be in the range of 3.0 ns
and 5.0 ns. Rise and fall times are defined as time difference between 10% and
90% voltage levels. Both positive and negative rise/fall times should be
validated.

The difference between the maximum and the minimum of all measured rise and
fall times should be less than 0.5 ns.

Waveform Overshoot Purpose:

To verify that the waveform overshoot of the DUT is below the conformance
limit.

Reference to the Standard:
Subclause 9.1.3 of ANSI X3.263-1995
What the Standard says:

According to standard, Overshoot is the percentage excursion of the differential
signal transition beyond V,,. Differential signal overshoot should not exceed 5%.
Both positive and negative overshoot are to be measured.
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16-8

Jitter

Duty Cycle Distortion

Return Loss

Purpose:

To verify that the peak-to-peak jitter of the DUT is within the conformance
limits.

Reference to the Standard:
Subclause 9.1.9 of ANSI X3.263-1995
What the Standard says:

According to standard, the peak-to-peak jitter should not exceed 1.4 ns.

Purpose:

To verify that the duty cycle distortion of the DUT is below the conformance
limit.

Reference to the Standard:
Subclause 9.1.8 of ANSI X3.263-1995
What the Standard says:

According to standard, duty cycle distortion should be measured at the 50%
voltage points on rise and fall transitions of the differential output waveform and
should not exceed +0.25 ns.

Purpose:

To verify that the return loss at the transmitter or receiver of the device under test
(DUT) is above the conformance limit.

Reference to Standard:

Subclause 9.1.5 and 9.2.2 of ANSI X3.263-1995

What Standard says:

Greater than 16 dB from 2 MHz to 30 MHz

Greater than (16—20log(f/30 MHz)) dB from 30 MHz to 60 MHz

Greater than 10 dB from 60 MHz to 80 MHz
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10BASE-T

MAU Ext  Purpose:
To verify that the transmitter output equalization meets standard specifications.
Reference to Standard:
Subclause 14.3.1.2.1 of IEEE standard 802.3-2002
What Standard says:

According to standard, the transmitter waveform should lie within the template
for all data sequences at the twisted-pair model’s output with 100 ohm
termination.

MAU Int  Purpose:
To verify that the transmitter output equalization meets standard specifications.
Reference to Standard:
Subclause 14.3.1.2.1 of IEEE standard 802.3-2002
What Standard says:

According to standard, the transmitter waveform should lie within the template
for all data sequences at the twisted-pair model’s output with 100 ohm
termination.

TP_IDL  Purpose:
To verify that the transmitter functions properly after a transition to the idle state.
Reference to Standard:
Subclause 14.3.1.2.1 of IEEE standard 802.3-2002
What Standard says:

According to standard, the TP_IDL pulse should lie within the template. This test
shall be done across each of the specified test loading Load 1, Load 2, and
Load 3 with and without twisted-pair model.
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16-10

Link Pulse

Differential Voltage

Harmonic

Purpose:

To verify that the link test pulse waveforms meet specification.
Reference to Standard:

Subclause 14.3.1.2.1 of IEEE standard 802.3-2002

What Standard says:

According to standard, the link test pulse should lie within the template. This test
shall be done across each of the specified test loading Load 1, Load 2, and
Load 3 with and without twisted-pair model.

Purpose:

To verify that the differential voltage of the DUT is within the conformance
limits.

Reference to Standard:
Subclause 14.3.1.2.1 of IEEE standard 802.3-2002
What Standard says:

Peak differential voltage of transmitter waveform when terminated with a
100 ohm resistor should lie between 2.2 V and 2.8 V for all data sequences.

Purpose:

To verify that the harmonic content of the DUT is within the conformance limits.
Reference to Standard:

Subclause 14.3.1.2.1 of IEEE standard 802.3-2002

What Standard says:

Harmonic test is done when the DO circuit is driven by all ones. Each harmonic
measured at the output of the transmitter shall be at least 27 dB below the
fundamental.
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Jitter  Purpose:
To verify that the jitter of the DUT is within the conformance limits.
Reference to Standard:

Subclause 14.3.1.2.3 of IEEE standard 802.3-2002
Annexure B.4.3.3 Note for 14.3.1.2.3 of IEEE standard 802.3-2002

What Standard says:

The transmitter output jitter when measured at the output of the twisted-pair
model should lie within £5.5 ns.

As per B.4.3.3 Note for 14.3.1.2.3 of IEEE standard 802.3-2002, failure of this
test does not demonstrate noncompliance.

The transmitter output jitter when measured without the twisted-pair model
should lie within £8.0 ns.

CM Voltage Purpose:

To verify that the common-mode voltage of the DUT is within the conformance
limits.

Reference to Standard:
Subclause 14.3.1.2.5 of IEEE standard 802.3-2002
What Standard says:

The magnitude of the total common-mode output voltage of the transmitter, Ecm,
shall be less than 50 mV peak.

Return Loss Purpose:

To verify that the return loss at the transmitter or receiver of the device under test
(DUT) is above the conformance limit.

Reference to Standard:
Subclause 14.3.1.2.2 of IEEE standard 802.3-2002 ab
What Standard says:

At least 15 dB over the frequency range of 5.0 to 10 MHz.
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Remote GPIB

About Remote GPIB

To enable Remote GPIB, click Utilities > Enable Remote GPIB.

With knowledge of the GPIB command syntax, you can design a GPIB program
to do the following tasks:

®  Start the TDSETS3 application

®  Recall the saved setup, either default or the user defined
" Select the technology (speed) and the test

=  Configure test parameters

®  Run the test

®  Retrieve the results for the conducted tests

®  Generate reports

®  Save the current setup

" Exit the application

Starting and Setting Up the Application Using GPIB

To start the TDSET3 application, you must send the oscilloscope the following
GPIB command:

application:activate "Ethernet Compliance Test
Software"

The application uses the GPIB VARIABLE:VALUE command with arguments
to execute the supported features.

You must continually query for application status. If the status indicates GPIB
disabled, you must manually enable Remote GPIB by clicking
Utilities > Enable Remote GPIB.
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GPIB Command Syntax

Description

This command accepts string arguments for a control or data variable and a value
to which to set the argument.

Syntax

VARIABLE:VALUE '"'<variable name>","'<variable value>"

Note:

The arguments <variable name> and <variable value> are required in the order

indicated.

VARIABLE:VALUE? <variable name> for query.

Note. Commands are case and space sensitive. All variables and values
supported by the application are in lower case and without any spaces in
between characters.

TDSET3 Application Command Arguments and Queries

Table 17-1: Command Arguments and Queries

Group / Name Value Function Query Returns
Application
recall The setup file name which consists | Recalls the settings for the Query is not valid.
of any string from 1 to 40 characters | application from the mentioned file.
from Ato Zand, or 0to 9 or special | The directory location of the file is
characters like “." or “default”. the default
"default" refers to the default file (C:\TekApplications\TDSET3\setup.
name. If file extension not specified | If the file doesn’t have appropriate
, itis assumed to be .ini. setting values, the default settings
will override the same.
save The setup filename, which consists | Saves the current application Query is not valid.
of any string from 1 to 40 characters | settings in the filename specified.
from Ato Z and, or 0 to 9 or Special | The directory location of the file is
characters like “."If file extension not | the default (C:\TekApplications\
specified , it is assumed to be .ini. TDSET3\setup.
application exitwrecall, exitworecall Exits the application. Returns the value of application
variable.
application minimize Minimizes the active application. Returns the value of application
variable.
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Table 17-1: Command Arguments and Queries (cont)

Group / Name Value Function Query Returns

application hide Hides the active application Returns the value of application
variable.

application maximize Maximizes the active application Returns the value of application
variable.

application show Shows the application, which was Returns the value of application

earlier hidden. variable.

version Query only Returns the version number of the
application.

Speed

speed 1000-T, 100-TX, 10-T Sets the speed The value of the set speed.

run {on, offp** Runs the previously selected testif | The value of test variable, on, off.

value is ON.

Stops the currently running test, if
any, if the value is OFF.

Results and Status

getremblk {np*** where n >= 1 and n <=the Updates “resultrem” with the remark
value returned on querying for block asked for. Please read the
“remcounter” note on Retrieving Remarks for
further details.
processdone {no}** Indicates that a set command
follows. Please read note on
processdone command for further
details.
resultsum Query only Returns the summary of the last test
conducted, pass, fail.
resultstd Query only Standard field of the result details, for
the test queried.
resultmeas Query only Measured field of the result details, for
the test queried.
resultsts Query only Status field of the result details, for the
test queried.
resultrem {Query only}x*** Remark field of the result details, for
the test queried.
remcounter {Query only}** Returns a count of remarks block
available for the last test run.
status Query only Returns the error code or “Test

Stopped”, “Test running”,"Test
Complete”.
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Table 17-1: Command Arguments and Queries (cont)

Group / Name

Value

Function

Query Returns

report summary, detail Invokes the report generation, Query not valid.
summary or detailed.
repname The setup filename, which consists | Sets the report layout filename. Returns the filename of the report
of any string from 1 to 40 characters | Next report generation, will use the | layout file.
from Ato Zand, or 0to 9 or Special | layout from this file.
characters like “."
deviceid Any string from 1 to 40 characters Specifies the device ID field for Returns the specified DevicelDApplies
from Ato Z and, or 0 to 9 with valid | report generation. This field is to Compliance modules.
Windows, Dos format. visible in several locations
throughout the application
independent of the report
generations panelDefault setting is
setto“” 1 space character.
portid Any printable character from Sets the Port id. Returns the value of port id.
keyboard.
reppairid Any printable character from Sets the report pair id. Returns the report pair id.

keyboard.

devicedetails

Any printable character from
keyboard.

Sets the devicedetails parameter.

Returns the device details.

process Any printable character from Sets the value for the process. Returns the value of process.
keyboard.

volt Any printable character from Sets the value for the voltage report | Returns the value of voltage.
keyboard. config.

temp Any printable character from Sets the value for the temperature Returns the value of temparature.
keyboard. report config.

lastcaldate Any printable character from Sets the last calibration date. Returns the last calibration date.
keyboard.

imgport {true false} Sets the image port. Returns the status of image port.

lastrepdet Query only Returns the last saved (detailed) report

filename.
lastrepsum Query only Returns the last saved (summary)

report filename.

1000Base-T test values for "resultfor"” variable

resultfor

templatea, templateb, templatec,
templated, templatef, templateh,
peaka, peakb, peakc, peakd,
droopg, droopj, jitmasterfilt,
jitmasterunfilt, jitslavefilt,
jitslaveunfilt, distortionm,
returnloss1000, cmvolt1000

Sets the result variables with
appropriate result values for that
particular test.

17-4
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Table 17-1: Command Arguments and Queries (cont)

Group / Name

Value

Function

Query Returns

100Base-TX test values for "resultfor" variable

resultfor

templatepos, templateneg,
outputvoltpos, outputvoltneg,
ampsym, risetimepos, risetimeneg,
falltimepos, falltimeneg, rfsympos,
rfsymneg, rfsymmaxmin,

overshootpos, overshootneg, jitpos,

jitneg, dcdrand, dcd0101,
returnlosstx100, returnlossrx100

Sets the result variables with
appropriate result values for that
particular test.

10Base-T test val

ues for "resultfor" variable

resultfor

maunorm, mauinv, Ipload1wotpm,
Ipload2wotpm, Ip100wotpm,
Ipload1wtpm, Ipload2wtpm,
[p100wtpm, Iptiming,
tpidlload1wotpm, tpidlload2wotpm,
tpidl200wotpm, tpidlload1wtpm,
tpidlload2wtpm, tpidl100wtpm,
diffvoltmaxpos, diffvoltmaxneg,
diffvoltpos, diffvoltneg, harmonic,
jitwcablenorm, jitwcable8ht,
jitwcable85bht, jitwocablenorm,
jitwocable8ht, jitwocable85ht,
returnlosstx10, returnlossrx10,
cmvolt10

Sets the result variables with
appropriate result values for that
particular test.

harmonicres0 Query only Harmonic test's result measured.
Measured results from Harmonic2 to
Harmonic5 can be got from this
variable.

harmonicresl Query only Harmonic test's result measured.

Measured results from Harmonic6 to
Harmonic9 can be got from this
variable.
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Table 17-1: Command Arguments and Queries (cont)

Group / Name

Value

Function

Query Returns

harmonicres2

Query only

Harmonic test’s result measured.
Measured results from Harmonic10 to
Harmonic13 can be got from this
variable.

harmonicres3

Query only

Harmonic test's result measured.
Measured results from Harmonic14 to
Harmonic17 can be got from this
variable.

harmonicres4

Query only

Harmonic test’s result measured.
Measured results from Harmonic18 to
Harmonic21 can be got from this
variable.

harmonicres5

Query only

Harmonic test’s result measured.
Measured results from Harmonic22 to
Harmonic25 can be got from this
variable.

17-6

TDSET3 Printable Help Document



Remote GPIB

**Note on processdone command:

Set commands are of the format variable:value “<variable_name>",”<value>"
Get or query commands are of the format variable:value? “<variable_name>"
For TDSET3 versions later than 1.3.1, BEFORE every remote GPIB SET
command , you must send <variable:value ““processdone”,”’no’> and AFTER
every set command, you have to wait on "processdone” variable until it returns a
“yes”, that is, you have to keep polling for <Variable:value? “processdone”>
and only after it returns a ““yes™, the next command, either set or get can be
sent.

Please ensure that this order is followed for the command script to work
correctly. A sample script is listed here. It recalls a default setting, selects
TemplatePeakall test, runs the test, and query the result measured for peaka test.
variable:value “processdone”,”’no”

variable:value “recall”,”default™

variable:value? “processdone”

“no
..... keep polling until it returns a yes
variable:value? ““processdone”

“tyes”

variable:value “processdone”,”’no”
variable:value test”,”’templatepeakall™
variable:value? *““processdone”

“no
..... keep polling until it returns a “yes™
variable:value? “processdone”
“ryes”

variable:value ““processdone”,”’no
variable:value run’,”on”
variable:value? *““processdone”
“no
..... keep polling until it returns a ““yes™
variable:value? *““processdone”

“ryes”
variable:value“processdone’,”’no”
variable:value ““resultfor”,”’peaka™
variable:value? *““processdone”

“no
..... keep polling until it returns a ““yes™
variable:value? ““processdone”

“ryes”

variable:value? ““resultmeas”

*** Note on run command :

After issuing a run command , you should wait for processdone command to
return a “‘yes” and then query the*status”. Once the status returns ““Test
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Complete™ then query for the result details.

Sometimes after the run command is issued and if the processdone command
returns a “yes”, the test may not be complete. The test could be stopped because
of an error condition that caused the TDSET3 application to terminate the run
operation and indicate processdone as ““yes”. Thus it is advisable to always wait
on “processdone” before looking for results and ensure that the test is complete
to query the status. If status returned does not indicate any error or test stopped,
but that the test is complete then query for results.

****Note on Retrieving Remarks:

Result remarks for some tests is lengthy and can not be retrieved by one query.
Thus use the following code to retrieve all the remark blocks.

Each block is one chunk of remarks data.

variable:value? “remcounter”

g

//Returns the number of remark blocks available. This indicates there are four
blocks of remarks for the last test run. If you want to retrieve first and second
block of remarks, the following list of commands need to be sent.
Variable:value ““processdone”,”’no”

variable:value “getremblk™,”1”

//On receiving this command TDSETS3 fills ““resultrem” with the first block of
remarks.Wait on “processdone” to return *“yes”, then query for result remarks.
variable:value? *““processdone”

l‘yes!7
variable:value? ““resultrem”
"RMS = 1.48mV SNR = 53.59dB

Peak Distortion at symbol 1188 = - 5.427mV
Peak Distortion at symbol 1863 = + 4.855mV
Peak Disto"

[Ithis will return the first block of remarks data.
variable:value ““processdone”,”’no”
variable:value “getremblk™,”2”

//On receiving this command TDSETS3 fills ““resultrem” with the second block of
remarks

variable:value? “processdone”

“ryes™

variable:value? “resultrem”

"rtion at symbol 222 = - 4.785mV
TX_TCLK Freq = 125.0MHZ

TX_TCLK ppm = 0.000006% [0.057 ppm]
DC Offset Measured = -15.39mV"
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GPIB Commands for 1000BASE-T

Table 17-2:

1000BASE-T GPIB

Commands

Group / Name Value

Function

Query Returns

Selecting test parameters for 1000BASE-T

test templatea, templateb,
templatec, templated,
templatef, templateh

Selects the template test.

The value of test variable.

test peaka, peakb, peake, Selects the peak volt test. The value of test variable.
peakd
test templatepeakall Selects all the template and peak volt tests. | The value of test variable.
test droopg, droopj, droopall Selects the droop test. The value of test variable.
test jitmasterfilt, jitmasterunfilt Selects the jitter master test. The value of test variable.
test jitslaveunfilt Selects the jitter slave test. The value of test variable.
test distortion Selects the distortion test. The value of test variable.
test returnloss1000 Select the return loss test. The value of test variable.
test cmvolt1000 Select the CM voltage test. The value of test variable.

Configuring test parameters for 1000BASE-T

avgs:1000 n>=64 and n <= 10,000 Configures the number of averages for The number of averages.
template peak, and droop.

avgs4distortion n>=64 and n <= 10,000 Configuring the number of averages The number of averages set for
distortion 1000Base-T test. distortion test.

clkedge rising/falling Configures the clock edge for jitter tests. The type of clock edge - rising or

falling.

data:1000 {chl/ch2/ch3/cha}* Configures the source data for template, The channel chosen for source data.
peak, droop, jitter, distortion, and cmvoltage
tests.

disturber yes/no Configures the disturber for template, peak, | The status indicating if the disturber is
droop and distortion tests. included or not.

filter int/ext Configures the filter - internal or external - The type of the filter used, either
for template, and peak tests. internal or external.

masterclk {ch1/ch2 /ch3/ch4}* Configures the master clock for jitter The value of the channel chosen for
1000Base-T test. master clock.

meastype TIE/Histogram Configures the measure type for unfiltered The measure type.
jitter test.

slaveclk {chl/ch2/ch3/ch4}* Configures the slave clock for jitter slave The value of the channel chosen for
test. slave clock.

output:1000 {refl/ref2/ ref3/refa}* Configures the output for template, peak, The channel chosen for output.

droop and distortion tests.
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Table 17-2:

1000BASE-T GPIB

Commands (cont)

Group / Name

Value

Function

Query Returns

reclen 100K, 1 Meg, 4 Meg, Configuring the record length for jitter tests The value of record length previously
7.5 Meg, 8 Meg, 10 Meg, in 1000Base-T. This is not present for set.
16 Meg, 20 Meg unfiltered jitter test with measurement type
set to Histogram. Default value is max
memory available on the Oscilloscope.
resolution n>=2andn<=75 Configuring the resolution for the distortion The value of the resolution previously
test in 1000Base-T. set.
txtclksrc {ch1, ch2, ch3, ch4}* Configuring the clock, when distortion testis | The channel chosen for txtclock
selected and distclk is set to yes, for source.
1000Base-T.
txtclk yes, no The status indicating if txtclk is included or The status indicating if txtclk is
not. included or not
distclk yes, no The status indicating if the clock is included The status indicating if the disturber is
or not. included or not.
Ipfilter yes, no Status of the Low Pass filter for distortion The status of the Low Pass filter for
tests. distortion tests.
jitterlpfilter yes/no Status of the Jitter Low Pass filter for jitter Status of the Jitter Low Pass filter for

tests.

jitter tests.

rlsrc1:1000 {ch1, ch2, ch3, ch4}* Configuring the sources P1/P3/P5/P7 for the | The value of the sourcel for return
return loss test in 1000Base-T. loss.

rlsrc2:1000 {ch1, ch2, ch3, ch4}* Configuring the sources P2/P4/P6/P8 for the | The value of the source2 for return
return loss test in 1000Base T. loss.

rloutput:1000 {refl, ref2, ref3, refd}* Configuring the source for the return loss The value of the return loss for output
test in 1000Base-T. waveform.

rllimit:1000 {ref1, ref2, ref3, refa}* Configuring the source for the return loss The value of the limit for output
test in 1000Base-T. waveform of return loss.

avgtime:1000 n >=100 and n <= 10,000 Configuring the average time for return loss | The value of average time.
test for 1000Base-T.

smooth:1000 n>=00andn<=10 Configuring the average frequency for return | The value of average frequency.
loss test for 1000Base-T.

pairid a,bcd Configuring the pair id for return loss test for | The value of the pair id previously set.
1000Base -T.

load:1000 "load85/100/115","load100" | Configuring the load parameter for return The value of the load parameter.
loss test in 1000Base-T.

awg:1000 {awgselect,awgdxx/awg20 | Configure the AWG being used for Returns the AWG series being used

21/awg5xx/awgbxx/awg7xx | 1000Base-T return loss tests. for 1000Base-T return loss test.
}

datatm?2 {ch1, ch2, ch3, ch4}* Configuring the data test mode 2 source for | The value of the test mode 2 source
the jitter test in 1000Base -T. for jiiter test.

datatm3 {ch1, ch2, ch3, ch4}* Configuring the data test mode 3 source for | The value of the test mode 3 source
the jitter test in 1000Base-T. for jiiter test.

hysteresis {n}n>=5.0andn<=30.0 | Configuring the hysteresis value for jitter The value of hysteresis for jitter tests.
1000Base-T tests.
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Table 17-2: 1000BASE-T GPIB Commands (cont)

Group / Name Value Function Query Returns
Jig Match
jmmeas jmdistall, jmdutamp, Measure the jig match parameters. Query not valid.
jmprobeamp
jmdef jmdistall, jmdutamp, Set the jig match parameters to default. Query not valid.
jmprobeamp
jmlastjm Query only Returns the last jig match parameter
measured.
jmamp Query only Returns the value of the amp.
jmfreq Query only Returns the value of the freq.
jmdutamp Query only Returns the value of the DUT amp.
jmprobeamp Query only Returns the value of the probe point
amp.
jmatten Query only Returns the value of the atten.
jmstatus Query only Returns the Jig Match status, either
jmon/jmoff. ON indicates jig match
measure is in progress.
jmaction jmapply, jmcancel Applies the measured values or
cancels the same.

*Note on channel selections:

Channel 3 and Channel 4 can be chosen only on a 4-channel oscilloscope.
Ref 3 and Ref4 can be chosen only on a 4-channel oscilloscope.

Math3 and Math4 can be chosen only on a 4-channel oscilloscope.

GPIB Commands for 100BASE-TX

Table 17-3: 100BASE-TX GPIB Commands

Group / Name Value Function Query Returns

Selecting test parameters for 100BASE-TX

test template, templatepos, Selects the template test and the polarity. The value of test variable.
templateneg

test outputvoltboth, Selects the output volt test and the polarity. The value of test variable.
outputvoltpos,
outputvoltneg

test ampsym Selects the amp sym test. The value of test variable.
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Table 17-3:

100BASE-TX GPIB

Commands (cont)

Group / Name

Value

Function

Query Returns

test risetimeboth, risetimepos, | Selects the rise time test and the polarity. The value of test variable.
risetimeneg
test falltimeboth, falltimepos, Selects the fall time test and the polarity. The value of test variable.
falltimeneg
test rfsymboth, rfsympos, Selects the rfsym test, with the polarity. The value of test variable.
rfsymneg
test overshoothoth, Selects the overshoot test, with the polarity. | The value of test variable.
overshootpos,
overshootneg
test jitboth, jitpos, jitneg Selects the jitter test and the polarity. The value of test variable.
test dedrand, dcd0101 Selects the distortion test and pattern The value of test variable.
values.
test all Selects all the 100Base-Tx tests with polarity | The value of test variable.
as “both” and pattern as “random”.
test returnlosstx100, Select the return loss test. The value of test variable.
returnlossrx100
Configuring test parameters for 100BASE-TX
acq:100 sample, avg Configures the acquisition to sample or The type of acquisition.
average for all 100Base-Tx tests except
template and jitter.
data:100 {ch1, ch2, ch3, ch4 }* Configures the source data for tests. The channel chosen for source data.
pulsewidth 16, 80 Configures the pulse width for rise, fall time The pulse width value.
test, R/F sym test.
maskscale norm,0.95,1.05 Configuring the template scale for template The value of template scale.
tests of 100Base-Tx.
rlsrc1:100 {ch1, ch2, ch3, ch4}* Configuring the sources P1, P3 for the return | The value of the sourcel for return
loss test in 100Base-Tx. loss.
rlsrc2:100 {ch1, ch2, ch3, ch4}* Configuring the sources P2, P4 for the return | The value of the source2 for return
loss test in 100Base-Tx. loss.
rloutput:100 {ref1, ref2, ref3, refd}* Configuring the source for the return loss The value of the return loss for output
test in 100Base-Tx. waveform.
rllimit: 100 {efl, ref2, ref3, refd}* Configuring the source for the return loss The value of the limit for output
test in 100Base-Tx. waveform of return loss.
avgtime:100 n>=100 and n <= 10,000 Configuring the average time for return loss | The value of average time.
test for 100Base-Tx.
smooth:100 n>=0andn<=10 Configuring the average frequency for return | The value of average frequency.
loss test for 100Base-Tx.
load:100 "load85, 100, Configuring the load parameter for return The value of the load parameter.
115" "load100" loss test in 100Base-Tx.
awg:100 awg4xx, awg2021, Configure the AWG being used for 100Base- | Returns the AWG series being used
awghxx, awgbxx, awg7xx Tx return loss tests. for 100Base-Tx return loss test.
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The following oscilloscope commands can be used to set or query the number of
waveforms, horizontal position, and vertical position for 100Base-Tx tests.

Table 17-4: Oscillscope GPIB Commands for 100Base-Tx

Group / Name

Value

Function

Query Returns

ACQuire:NUMAV( x x>=2 and x <= 10,000 Sets the number of waveforms for
100Base-Tx.
ACQuire:NUMAVg ? Queries the number of waveforms for | The number of waveforms.
100Base-Tx.
HORIZONTAL:POSITION x | x>=0and x <=99.9 Sets the horizontal position for 100
BaseTx.
HORIZONTAL:POSITION ? Queries the horizontal position for The value of the horizontal position.
100Base-Tx.
CHx:POSITION y x>=landx<=4 Sets the vertical position for the
y>= 0.0 and y <= 5.00 selected channel for 100Base-Tx.
CHx:POSITION ? Queries the vertical position for the The value of the vertical position for

selected channel for 100Base-Tx.

the selected channel.

*Note on channel selections:
Channel 3 and Channel 4 can be chosen only on a 4-channel oscilloscope.
Ref 3 and Ref4 can be chosen only on a 4-channel oscilloscope.

Math3 and Math4 can be chosen only on a 4-channel oscilloscope.
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GPIB Commands for 10BASE-T

Table 17-5:

10BASE-T GPIB Commands

Group / Name

Value

Function

Query Returns

Selecting test parameters for 10BASE-T

test mauboth, maunorm, Selects the mau test with both, normal or The value of test variable.
mauinv inverted.
test Ipload1wotpm, Selects the link pulse with load test. The value of test variable.
Ipload2wotpm,
[p100wotpm, Iploadlwtpm,
Ipload2wtpm, 1p100wtpm
test tpidlload1wotpm, Selects the tp idl with load test. The value of test variable.
tpidlload2wotpm,
tpidiZ00wotpm,
tpidlload1wtpm,
tpidlload2wtpm,
tpidI100wtpm
test diffvoltmax, diffvoltall Selects the diff volt test. The value of test variable.
test harmonic Selects the harmonic test. The value of test variable.
test jitwcableall, jitwcablenorm, | Selects the jitter test, with or without cable. The value of test variable.
jitwcable8ht, jitwcable85bt,
jitwocableall,
jitwocablenorm,
jitwocable8ht,
jitwocable85bt
test returnlosstx10, Select the return loss test. The value of test variable.
returnlossrx10
test cmvolt10 Select the CM voltage test. The value of test variable.
Configuring test parameters for 10BASE-T
acq:10 sample, avg Configures the acquisition to sample or The type of acquisition.
average for link pulse and tp_idl tests.
avgs:10 n>=2and n<=10,00,000 | Configures the number of averages for The number of averages.
harmonic test.
data:10 {ch1, ch2, ch3, ch4}* Configures the source data. The channel chosen for source data.
masksel both, head, tail Configures the mask selection section for The mask selection.
link pulse or TP_IDL tests.
mauscale norm, 0.9, 1.1 Configures the MAU scale for MAU template | The mau scale value, either normal or
test. 09o0r1.1.
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Table 17-5:

10BASE-T GPIB Commands (cont)

Group / Name Value Function Query Returns
mautype int, ext Configures the mau type for jitter with, The MAU type, either internal or
without cable (parameteric) and MAU external.
(template) tests.
timescale 10,1 Configures the time scale for harmonic test. | The time scale value.
linkseq norm, fast Configuring the sequence for Link Pulse test | The type of sequencing.
in 10Base-T.
testoptions both, template, timing Configuring the test options for the link pulse | The test option chosen for the link
test in 10Base-T. pulse test.
output:10 {mathl1, math2, math3, Configures the output for harmonic test. The channel chosen for output.
math4}*
rlsrc1:10 {ch1, ch2, ch3, ch4}* Configuring the sources P1, P3 for the return | The value of the sourcel for return
loss test in 10Base -T. loss.
rlsrc2:10 {ch1, ch2, ch3, ch}* Configuring the sources P2, P4 for the return | The value of the source2 for return
loss test in 10Base -T. loss.
rloutput:10 {ref1, ref2, ref3, refd}* Configuring the source for the return loss The value of the return loss for output
test in 10Base-T. waveform.
rllimit: 10 {ref1, ref2, ref3, refd}* Configuring the source for the return loss The value of the limit for output
test in 10Base-T. waveform of return loss.
avgtime: 10 n>=100 and n <= 10,000 Configuring the average time for return loss | The value of average time.
test for 10Base-T.
smooth:10 n>=0andn<=10 Configuring the average frequency for return | The value of average frequency.
loss test for 10Base -T.
load:10 "load85, 100, 111", Configuring the load parameter for return The value of the load parameter.
"load100" loss test in 10Base-T.
awg:10 awgaxx, awg2021, Configure the AWG being used for 10Base- | Returns the AWG series being used
awgbhxx, awgbxx, awg7xx T return loss tests. for 10Base-T return loss test.
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The following oscilloscope commands can be used to set or query the number of
waveforms, fail threshold, horizontal position, and vertical position for 10Base-T

tests.

Table 17-6: Oscillscope GPIB Commands for 10Base-T

Group / Name

Value

Function

Query Returns

ACQuire:NUMAVg x X >=2 and x <= 10,000 Sets the number of waveforms for
10Base-T.
ACQuire:NUMAVg ? Queries the number of waveforms for | The number of waveforms.
10Base-T.
MASK:TEST:THRESHOLD x | x>=1and n <=2147483647 | Sets the fail threshold for 10Base-T.
MASK:TEST:THRESHOLD ? Queries the fail threshold for The value of the falil
10Base-T. threshold.
MASK:TEST:WAVEFORM x x>=1and n<=2147483647 | Sets the number of waveforms for
10Base-T.
MASK:TEST:WAVEFORM ? Queries the number of waveforms for | The number of waveforms.
10Base-T.
HORIZONTAL:POSITION x x>=0and x<=99.9 Sets the horizontal position for
10Base-T.
HORIZONTAL:POSITION ? Queries the horizontal position for The value of the horizontal
10Base-T. position.
CHx:POSITION y x>=landx<=4 Sets the vertical position for the
y>= 0.0 and y <= 5.00 selected channel for 10Base-T.
CHx:POSITION ? Queries the vertical position for the The value of the vertical
selected channel for 10Base-T. position for the selected
channel.
*Note on channel selections:
Channel 3 and Channel 4 can be chosen only on a 4-channel oscilloscope.
Ref 3 and Ref4 can be chosen only on a 4-channel oscilloscope.
Math3 and Math4 can be chosen only on a 4-channel oscilloscope.
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GPIB Commands for AWG Automation

Table 17-7: AWG Automation GPIB Commands

Group / Name Value Function Query Returns
AWG Automation
automate gpib, manual Sets the AWG automation to GPIB mode or | Returns the current mode of
manual mode. automation.
boardtype GPIBO, GPIB1, GPIB2, Sets the GPIB board type to the specified Returns the board type being used for
GPIB3, GPIB4, GPIB5, value. This will be used if the AWG is automation of AWG.
GPIB6, GPIB7, GPIBS, automated.
GPIB9
priaddr n, where n =110 30 Sets the primary address to the specified Returns the primary address over
value. This will be used if the AWG is which the oscilloscope talks to the
automated. AWG if the automation mode is GPIB.
secaddr n, where n =110 30 Sets the secondary address to the specified | Returns the secondary address over
value. This will be used if the AWG is which the oscilloscope talks to the
automated. AWG if the automation mode is GPIB.
testconn start Initiates the connection testing process. No Query supported.
“status” can be queried to know the
result of test connection.

Program Example

The program example shows how to communicate to the TDSET3 application
using remote GPIB commands.

The oscilloscope hard disk and optional application compact disc both contain
the file, DefaultRun.c. On the hard drive, the file resides in the
C:\TekApplications\TDSET3\GPIBExamples directory.

The Program Example shows how a GPIB program executes the application to
do the following tasks:
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Recall the default setup
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In this example, you will recall the default setup. You can use the File > Save
function in the application to save setup files.

#ifdef _ cplusplus

extern "C"{

#endif

#include <windows.h>

#include <stdio.h>

#include <stdlib.h>

#include "decl-32_h"

#ifdef _ cplusplus

}

#endif

/* Forward Declarations */

int start_application(int Oscilloscope);

int exit_application(int Oscilloscope);

int recall_setup(int Oscilloscope, char* filename);

int recall_defaultsetup(int Oscilloscope) ;

int run_single_test (int Oscilloscope);

void query_results(int Oscilloscope) ;

void GPIBCleanup(int ud, char* ErrorMsg);

// parameters needed to access the device driver handler
#define BDINDEX O // Board Index

#define PRIMARY_ADDR_OF DMM 1 // Primary address of device
#define NO_SECONDARY_ADDR O // Secondary address of device
#define TIMEOUT T10s // Timeout value = 10 seconds
#define EOTMODE 1 // Enable the END message

#define EOSMODE O // Disable the EOS mode
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#define APP_NOT_RUNNING -1

#define RGPIB_ENABLED 1

#define RGPIB_DISABLED O

char ErrorMnemonic[21][5] = {"EDVR", "ECIC", "ENOL'", "EADR", "EARG",
"ESAC'"™, "EABO', "ENEB'", 'EDMA™, ',

“"EOIP'", "ECAP'", 'EFSO", ', "EBUS",

“ESTB'", "ESRQ™, ', ', "', “ETAB'"};

/*

* After each GPIB call, the application checks whether the call
* succeeded. If an NI-488.2 call fails, the GPIB driver sets the
* corresponding bit in the global status variable. If the call

* failed, this procedure prints an error message, takes

* the device offline and exits.

*/

int main()
{
int Dev;
char write_buffer[100];
int status;
int nAppStatus = -1;
Dev = ibdev (BDINDEX, PRIMARY_ADDR_OF_DMM, NO_SECONDARY_ADDR,
TIMEOUT, EOTMODE, EOSMODE);
if (ibsta & ERR)
{
GPIBCleanup(Dev, "Unable to open device");
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else

printf("'My device id - %i", Dev);
}
sprintf(write_buffer, "%s", "header off');
status = ibwrt(Dev, write_buffer, strlen(write_buffer));

nAppStatus = start_application(Dev);

if ( nAppStatus == RGPIB_ENABLED )

{
printfF("\nApplication started..\n"");

}

else if ( nAppStatus == RGPIB_DISABLED )

{
printf(""\nRGPIB is disabled, please enable it and then press
Enter to continue'™);
getchar();

}

else 1T ( nAppStatus == APP_NOT_RUNNING )

{
exit_application(Dev);
// leave the device back elegantly
printf("'Cleanup: Taking device offline\n');
ibonl(Dev, 0);
exit(0);

}

run_single_test(Dev);

printf(""\nRun single test complete now..\n");
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query_results(Dev);

printf(""\nQuery results complete now..\n");
recall_defaultsetup(Dev);

printf(''\nRecall Default complete now..\n"");
printf("'Cleanup: Taking device offline\n");
ibonl(Dev, 0);

printf("'Press any key to exit this sample application.._\n");

getchar();

/* Start Ethernet Compliance Test Software application */
int start_application( int Oscilloscope )
{

char write_buffer[100];

char read _buffer[100];

int status;

int timer = 1;

/* Start the application */

sprintf(write_buffer, "%s'", "Application:activate \"Ethernet
Compliance Test Software\"");

status = i1bwrt(scope, write_buffer, strlen(write_buffer));
if (ibsta & ERR)
{

GPIBCleanup(scope, "Unable to start the application™);

return O;

while (1)
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{
// Check whether application has started
sprintf(write_buffer, "%s", "Variable:value? \"application\'""");
status = ibwrt(scope, write buffer, strlen(write _buffer));
status = ibrd(scope, read buffer, sizeof(read buffer));
read_buffer[ibcnt] = *\0";
if ( strcmp(read_buffer,\"GPIB Enabled\'"\n'") == 0 )
{
return RGPIB_ENABLED;
}
else if (strcmp(read_buffer,”\"GPIB Disabled\'"\n") == 0 )
{
return RGPIB_DISABLED;
}
timer++;
it (timer >500)
{
return O;
}
Sleep(1000);
}
return APP_NOT_RUNNING;
}
Y e

int exit_application(int Oscilloscope)

{
char write_buffer[100];
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printf("Exit Application ..\n");

sprintf(write_buffer, "%s", "Variable:value
\"application\",\"exitworecal I\"""");

ibwrt(scope, write_buffer, strlen(write_buffer));

return 1;

int recall_setup(int Oscilloscope, char* filename)

{

char write_buffer[100];
int status;
/* recall setup */

sprintf(write_buffer, "%sWskhs'™, '"Variable:value \"recall\" ,\"",
filename, "\'");

status = ibwrt(scope, write_buffer, strlen(write_buffer));

if (ibsta & ERR)

{
GPIBCleanup(scope, "Unable to communicate with Oscilloscope™);
return O;

}

return 1;

int recall_defaultsetup(int Oscilloscope)

{

char write buffer[100];

int status;
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/* recall default setup */
sprintf(write_buffer, "%s"™, "Variable:value \"recall\",\"Default\""");
status = i1bwrt(scope, write_buffer, strlen(write_buffer));

if (ibsta & ERR)

{
GPIBCleanup(scope, "Unable to communicate with Oscilloscope™);
return O;
}
return 1;
}
Y e T

int run_single_test (int Oscilloscope)
{
char write_buffer[100];
char read_buffer[100];
int timer;
sprintf(write_buffer, "%s", "Variable:value \"run\",\"on\""");
ibwrt(scope, write_buffer, strlen(write_buffer));
printf("'Executing Test.._.\n");
Sleep(1000);
// Wait for application to come to Ready State
timer = 1;
while (1)
{
timer++;
if (timer > 500)
{
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printf(""******Tegt Time Out ******\n'");
return O;
}
sprintf(write_buffer, "%s', "Variable:value? \"run\"");
ibwrt(scope, write_buffer, strlen(write_buffer));
/* read the answer */
ibrd(scope, read_buffer, 99);
if (ibsta & ERR)
{
GPIBCleanup(scope, "Unable to write to device');

¥
read_buffer[ibcnt - 1] = "\0~;
if (strcmp(read_buffer, " \"off\'""") == 0)

{
printf("'Test Completed or stopped ..\n"");
return 1;
}
Sleep(1000);
}
}
/)~

void query_results(int Oscilloscope)

char write_buffer[100];
char read_buffer[100];
// Check for errors

sprintf(write_buffer, "%s'", "Variable:value? \"status\'"'");
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ibwrt(scope, write_buffer, strlen(write_buffer));
/* read the answer */
ibrd(scope, read_buffer, 99);
if (ibsta & ERR)
{
GPIBCleanup(scope, "Unable to write to device');
}
read_buffer[ibcnt - 1 ] = "\0";
it (strcmp(read_buffer,”\"Test Complete\'") = 0)
{

printfF(""Error has Occured. %s\n",read_buffer);
}
else
printf(""\nstatus i1s %s\n",read_buffer);
// 1T no error, check for results
//result summary
sprintf(write_buffer, "%s", "Variable:value? \"resultsum\'");
ibwrt(scope, write_buffer, strlen(write_buffer));
/* read the answer */
ibrd(scope, read_buffer, 99);
if (ibsta & ERR)
{
GPIBCleanup(scope, "Unable to write to device');
by
read_buffer[ibcnt - 1] = "\0";
printf("'Result summary : %s\n",read_buffer);

//result standard
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sprintf(write_buffer, "%s'", "Variable:value? \"resultstd\'""");
ibwrt(scope, write_buffer, strlen(write_buffer));
/* read the answer */
ibrd(scope, read buffer, 99);
if (ibsta & ERR)
{
GPIBCleanup(scope, "Unable to write to device™);
}
read_buffer[ibcnt - 1] = *\0";
printf(""Result standard : %s\n",read_buffer);
//result measured
sprintf(write_buffer, "%s", "Variable:value? \"resultmeas\'"");
ibwrt(scope, write_buffer, strlen(write_buffer));
/* read the answer */
ibrd(scope, read_buffer, 99);
if (ibsta & ERR)
{
GPIBCleanup(scope, "Unable to write to device');
}
read_buffer[ibcnt - 1] = *\0";
printf("'Result Measured : %s\n",read_buffer);
//result remarks
sprintf(write_buffer, "%s", "Variable:value? \"resultrem\'");
ibwrt(scope, write_buffer, strlen(write_buffer));
/* read the answer */
ibrd(scope, read buffer, 99);
if (ibsta & ERR)
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GPIBCleanup(scope, "Unable to write to device);
¥
read buffer[ibcnt - 1] = “\0~;
printf("'Result Remarks : %s\n",read buffer);
//result status
sprintf(write_buffer, "%s'", "Variable:value? \"resultsts\'""");
ibwrt(scope, write_buffer, strlen(write_buffer));
/* read the answer */
ibrd(scope, read buffer, 99);
if (ibsta & ERR)
{
GPIBCleanup(scope, "Unable to write to device');
}
read_buffer[ibcnt - 1] = "\0";

printf("'Result Status : %s\n",read buffer);

void GPIBCleanup(int ud, char* ErrorMsg)
{
printf("Error : %s\nibsta = Ox%x iberr = %d (%s)\n",
ErrorMsg, ibsta, iberr, ErrorMnemonic[iberr]);
if (ud 1= -1)
{
printf("’Cleanup: Taking device offline\n');
ibonl(ud, 0);
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Guidelines to GPIB Programming

The application includes an example file of a GPIB program. Your GPIB
program should comply with the following guidelines:
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You need to manually enable Remote GPIB by clicking Utilities > Enable
Remote GPIB. The Remote GPIB remains enabled or disabled until you
manually change it

You need to connect a separate GPIB cable between the PC and the
oscilloscope for GPIB to work. GPIB commands do not work through LAN

You need to ensure that the startup is complete before sending additional
GPIB commands to the application

After sending a GPIB command to activate the application, you can send a
remote GPIB command to query for application variable to check if the
application is activated or not and to know the GPIB status that is enabled or
disabled

If “processdone” command is not sent before every set command or waited
upon until it returns a “yes” before sending the next command, you need to
include delay between commands in the GPIB command script

You can query for test results after the test is run and complete

Before running the GPIB commands, you can query for *IDN? variable to
identify the oscilloscope and ensure that the oscilloscope is responding

You can query for the status variable to either know if the tests is complete
or ensure that an error has not occurred

Ensure that you are in the appropriate technology for which you are
selecting or configuring test parameters

You can query for lastrepdet variable to know where the last detailed report
is saved

You can query for lastrepsum variable to know where the last report
summary is saved
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You can query for jmstatus variable to know if the application is
compensating a disturber or test fixture. Do not query for Jig Match
parameters if the jmstatus variable is ON

You can query for variables harmonicres0 to harmonicres5 to view the
harmonic test results

Note on Guidelines to GPIB Programming

17-30

The application does not respond to commands that were sent before the
application was activated

GPIB commands do not work through LAN

Remote GPIB commands does not support the View Waveform
functionality

When the application processes remote GPIB commands, all the relevant
message boxes are disabled

If you are in the Select pane while sending GPIB commands to configure a
test parameter, the application does not display the configure pane. But if
you are in the Configure pane while sending GPIB commands to select a
test, the application will display the Select pane

While running a test, the remote GPIB commands are not processed until the
test is complete

Do not operate User Interface and Front panel of the oscilloscope manually

The application does not display the report irrespective of the preview
option being enabled or disabled

When a test is run, the results are available after the status indicates Test
Complete. When multiple tests are run, one test result is made available.
You can retrieve the results for other tests by setting “resultfor” with the test
name and querying for results. For example, if "outputvoltboth™ test is run
then the result for the test "outputvoltpos” is made available and if
1000Base-T "templatepeakall™ test is run then the result for the test
"templatea” is made available
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The following table gives the name of multiple tests the results of which are
made available soon after the test is complete:

Table 17-8: Default Test name and result details after

multiple run

Test Name Test Result
1000-T tests

templatepeakall templatea
droopall droopg
100-Tx tests

templateall templatepos
outputvoltboth outputvoltboth
risetimeboth risetimepos
falltimeboth falltimepos
rfsymboth rfsympos
overshootboth overshootpos
jitterboth jitterpos
jitwcableall jitwcablenorm
jitwocableall jitwocablenorm
10-T tests

mauboth maunorm
diffvoltall diffvoltpos
diffvoltmax diffvoltmaxpos
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Calibration for Return Loss

1000BASE-T Return Loss

Use TC1 of the test fixture for calibration. Make the connections as shown by the
following figure:

Tektronix Oscilloscope

Tektronix AWG —
' o)
] B
9 e 1EEE
==
T T I o aaaa
5@ @ @ | Marker 1/Sync l '::5:; Y T -
— Aux in - —
=l
=2
For Calibration ™"
e “a
= To Oscilloscope 1 =
. &
. ™ 3 | &
..' -\*
¥
TC 1 H = |z
— |8
To Channel 1 no"f2 wd 3
of AWG g b 1 | o
s Bil=— 2
To Channel 2 pe 232 — —
of AWG 2’ f3 3

Figure 18-1: Calibration for 1000BASE-T Return Loss
1. Click Tests > Select > 1000BASE-T from the menu bar.
2. Inthe Return Loss tab, select Return Loss.

3. Select Tests > Connect or Connect to display the Connect pane.
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File Tests Results Ltiities Help TDSET3 B X |

Connect: Return Loss

Select

i

¥ Result

Configure
Feport

I inect LUT 1o m Summaryl
Viewaml un Anply Cal Detail |

[1000-T--=Return Loss |Pair ID--=C PS--»Ch3 Pe-->Ch2 Avg->100 Smooth-->7 |

Figure 18-2: Connect pane of 1000BASE-T Return Loss

Note: The Open, Load and Short button are enabled only after you press New
Cal.

4. Click on New Cal.
5. Connect CATS5 cable to J200 of TC1 and J702 (OPEN).

6. Click Open. Once the open calibration is complete, the string Done appears
below the selected calibration. The following figure shows a typical
waveform for Return Loss Open Calibration.

Fef1 10.0cE 10.0MHz

Figure 18-3: Waveform of 1000BASE-T Return Loss Open Calibration
7. Connect CATS5 cable to J200 of TC1 and J703 (SHORT).

8. Click Short. Once the Short calibration is complete, the string Done appears
below the selected calibration.
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The following figure shows a typical waveform for Return Loss Short
Calibration:

03 Jul 99

Figure 18-4: Waveform of 1000BASE-T Return Loss Short Calibration
9. Connect CATS5 cable to J200 of TC1 and J704 (LOAD).

10. Click Load. Once the Load calibration is complete, the string Done appears
below the selected calibration. The following figure shows a typical
waveform for Return Loss Load Calibration:

Figure 18-5: Waveform of 1000BASE-T Return Loss Load Calibration
11. After all the calibrations are complete, the Apply Cal button is enabled.
12. Click Apply Cal. The calibration is complete.

13. To clear the calibrations and recalibrate, click on New Cal again.
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100BASE-TX Return Loss Transmitter

Tektronix ANG

)
]
i
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S EEeEmee 0]

CH1

Use TC1 of the test fixture for calibration. Make the connections as shown by the
following figure:
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Figure 18-6: Calibration for 100BASE-TX Return Loss

18-4

1. Click Tests > Select > 100BASE-TX from the menu bar.
2. Inthe Return Loss tab, select Transmitter.

3. Select Tests > Connect or Connect to display the Connect pane.

Note: The Open, Load and Short button are enabled only after you press New
Cal.

4. Click on New Cal.
5. Connect CATS5 cable to J200 of TC1 and J702 (OPEN).

6. Click Open. Once the open calibration is complete, the string Done appears
below the selected calibration.
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The following figure shows a typical waveform for Return Loss Open
Calibration:

03 Jul 989 12:49:31

Figure 18-7: Waveform of 100BASE-TX Return Loss Open Calibration
7. Connect CATS5 cable to J200 of TC1 and J703 (SHORT).

8. Click Short. Once the Short calibration is complete, the string Done appears
below the selected calibration. The following figure shows a typical
waveform for Return Loss Short Calibration:

Figure 18-8: Waveform of 100BASE-TX Return Loss Short Calibration
9. Connect CATS5 cable to J200 of TC1 and J704 (LOAD).

10. Click Load. Once the Load calibration is complete, the string Done appears
below the selected calibration.
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The following figure shows a typical waveform for Return Loss Load
Calibration:

Figure 18-9: Waveform of 100BASE-TX Return Loss Load Calibration
11. After all the calibrations are complete, the Apply Cal button is enabled.
12. Click Apply Cal. The calibration is complete.

13. To clear the calibrations and recalibrate, click on New Cal again.
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100BASE-TX Return Loss Receiver

Use TC1 of the test fixture for calibration. Make the connections as shown by the
following figure:

Tektronix Oscilloscope

Tektronix AWG
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Figure 18-10: Calibration for 100BASE-TX Return Loss
1. Click Tests > Select > 100BASE-TX from the menu bar.
2. Inthe Return Loss tab, select Receiver.

3. Select Tests > Connect or Connect to display the Connect pane.

Note: The Open, Load and Short button are enabled only after you press New
Cal.

4. Click on New Cal.

5. Connect CATS5 cable to J200 of TC1 and J702 (OPEN).
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6. Click Open. Once the open calibration is complete, the string Done appears
below the selected calibration. The following figure shows a typical
waveform for Return Loss Open Calibration:

Figure 18-11: Waveform of 100BASE-TX Return Loss Open Calibration
7. Connect CATS5 cable to J200 of TC1 and J703 (SHORT).

8. Click Short. Once the Short calibration is complete, the string Done appears
below the selected calibration. The following figure shows a typical
waveform for Return Loss Short Calibration:

mef1 10,008

Figure 18-12: Waveform of 100BASE-TX Return Loss Short Calibration
9. Connect CATS5 cable to J200 of TC1 and J704 (LOAD).

10. Click Load. Once the Load calibration is complete, the string Done appears
below the selected calibration.

The following figure shows a typical waveform for Return Loss Load
Calibration:
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Figure 18-13: Waveform of 100BASE-TX Return Loss Load Calibration
11. After all the calibrations are complete, the Apply Cal button is enabled.
12. Click Apply Cal. The calibration is complete.

13. To clear the calibrations and recalibrate, click on New Cal again.
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10BASE-T Return Loss Transmitter

Tektronix ANG
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Use TC1 of the test fixture for calibration. Make the connections as shown by the
following figure:
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Figure 18-14: Calibration for 10BASE-T Return Loss

18-10

1. Click Tests > Select > 10BASE-T from the menu bar.
2. Inthe Return Loss tab, select Transmitter.

3. Select Tests > Connect or Connect to display the Connect pane.

Note: The Open, Load and Short button are enabled only after you press New
Cal.

4. Click on New Cal.
5. Connect CATS5 cable to J200 of TC1 and J702 (OPEN).

6. Click Open. Once the open calibration is complete, the string Done appears
below the selected calibration.
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The following figure shows a typical waveform for Return Loss Open
Calibration:

mef1 10045

Figure 18-15: Waveform of 10BASE-T Return Loss Open Calibration
7. Connect CATS5 cable to J200 of TC1 and J703 (SHORT).

8. Click Short. Once the Short calibration is complete, the string Done appears
below the selected calibration. The following figure shows a typical
waveform for Return Loss Short Calibration.

Figure 18-16: Waveform of 10BASE-T Return Loss Short Calibration
9. Connect CATS5 cable to J200 of TC1 and J704 (LOAD).

10. Click Load. Once the Load calibration is complete, the string Done appears
below the selected calibration.
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11. The following figure shows a typical waveform for Return Loss Load
Calibration:

Figure 18-17: Waveform of 10BASE-T Return Loss Load Calibration
12. After all the calibrations are complete, the Apply Cal button is enabled.
13. Click Apply Cal. The calibration is complete.

14. To clear the calibrations and recalibrate, click on New Cal again.
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10BASE-T Return Loss Receiver

Use TC1 of the test fixture for calibration. Make the connections as shown by the
following figure:

Tektronix Oscilloscope
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Figure 18-18: Calibration for 10BASE-T Return Loss
1. Click Tests > Select > 10BASE-T from the menu bar.
2. Inthe Return Loss tab, select Receiver.

3. Select Tests > Connect or Connect to display the Connect pane.

Note: The Open, Load and Short button are enabled only after you press New
Cal.

4. Click on New Cal.
5. Connect CATS5 cable to J200 of TC1 and J702 (OPEN).

6. Click Open. Once the open calibration is complete, the string Done appears
below the selected calibration.
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The following figure shows a typical waveform for Return Loss Open
Calibration:

Figure 18-19: Waveform of 10BASE-T Return Loss Open Calibration

7. Connect CATS5 cable to J200 of TC1 and J703 (SHORT).

8. Click Short. Once the Short calibration is complete, the string Done appears
below the selected calibration. The following figure shows a typical
waveform for Return Loss Short Calibration:

Figure 18-20: Waveform of 10BASE-T Return Loss Short Calibration
9. Connect CATS5 cable to J200 of TC1 and J704 (LOAD).

10. Click Load. Once the Load calibration is complete, the string Done appears
below the selected calibration.
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The following figure shows a typical waveform for Return Loss Load
Calibration:

Figure 18-21: Waveform of 10BASE-T Return Loss Load Calibration
11. After all the calibrations are complete, the Apply Cal button is enabled.
12. Click Apply Cal. The calibration is complete.

13. To clear the calibrations and recalibrate, click on New Cal again.
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Appendix A: Specification Range

1000BASE-T

Each test result depends on whether the measured value is within the
specification range.

The specification range for 1000BASE-T are listed in the following table:

Table A-1: 1000BASE-T Specification Range

Test Specification Range
Template
A Fit the template
B Fit the template
C Fit the template
D Fit the template
F Fit the template
H Fit the template
Peak Voltage
A 670 mV to 820 mV
B 670 mV to 820 mV
% Difference between A & B Test | (1 - |Point AJ/|[Point B|) * 100 < 1%
C (1-(0.5* (|Point A] + |Point B|)/2)/|Point C|) * 100% <2%
D (1-(0.5* (JPoint Al + |Point B|)/2)/|Point D|) * 100% <2%
Droop
(Point G/Point F) *100% > 73.1%
J (Point H/Point J) *100% > 73.1%
Jitter
TX TCLK (Yes)
Master Filtered Master Filtered Pk-Pk Jitter + Jtxout < 0.3 ns
Master Unfiltered Master Unfiltered Pk-Pk Jitter <1.4 ns
Slave Filtered Slave Filtered Pk-Pk Jitter + Jtxout < 0.4 ns + Master Filtered Pk-Pk Jitter
Slave Unfiltered Slave Unfiltered Pk-Pk Jitter <1.4 ns
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Table A-1:

1000BASE-T Specification Range (cont)

Test

Specification Range

TX_TCLK
(No)

Master Filtered

Data (TM2) Filtered Pk-Pk Jitter < 0.3 ns - Inconclusive
Data (TM2) Filtered Pk-Pk Jitter > 0.3 ns - Fail

Master Unfiltered

Data (TM2) Unfiltered Pk-Pk Jitter < 1.4 ns - Pass

Slave Filtered

Data (TM3) Filtered Pk-Pk Jitter - Data (TM2) Filtered Pk-Pk Jitter < 0.4 ns - Pass
Data (TM3) Filtered Pk-Pk Jitter - Data (TM2) Filtered Pk-Pk Jitter > 0.4 ns - Fail

Slave Unfiltered

(TM2)
(TM2)
(TM2)
Data (TM2) Unfiltered Pk-Pk Jitter > 1.4 ns - Inconclusive
(TM3)
(TM3)
(TM3)

Data (TM3) Unfiltered Pk-Pk Jitter - Data (TM2) Unfiltered Pk-Pk Jitter < 1.4 ns -
Pass

Data (TM3) Unfiltered Pk-Pk Jitter - Data (TM2) Unfiltered Pk-Pk Jitter > 1.4 ns -
Fail

Distortion

<10 mVv

Return Loss

At least 16 dB over the frequency range of 1.0 MHz to 40 MHz and at least 10 -20log
10 (f /80)dB over the frequency range 40 MHz to 100 MHz (f in MHz)

Common Mode Voltage

<50 mV Pk-Pk

100BASE-TX
Each test result depends on whether the measured value is within the
specification range.
The specification range for L00BASE-TX are listed in the following table:
Table A-2: 100BASE-TX Specification Range
Test Specification Range
Template
AQI Template Fit the template
Differential Output Voltage
Output Voltage (+Vout) 950 mV to 1050 mV
Output Voltage (-Vout) -950 mV to -1050 mV

Signal Amplitude Symmetry

Signal Amplitude Symmetry | 0.98 to 1.02

Rise Time

Rise Time (+ve) 3.0nsto 5.0 ns

Rise Time (-ve) 3.0nsto0 5.0 ns

A-2
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Table A-2: 100BASE-TX Specification Range (cont)

Test Specification Range
Fall Time
Fall Time (+ve) 3.0nsto 5.0 ns
Fall Time (-ve) 3.0nsto0 5.0 ns
Rise/Fall Time Symmetry
Rise/Fall Symmetry (+ve) <500 ps
Rise/Fall Symmetry (-ve) <500 ps
Waveform Overshoot
Overshoot(+ve) <5%
Overshoot(-ve) <5%
Jitter
Transmit Jitter <l.4ns
Duty Cycle Distortion
Distortion <500 ps(+/- 250 ps)

Return Loss >16 dB from 2 MHz to 30 MHz
>(16 - 20log(f/30 MHz)) dB from 30 MHz to 60 MHz
>10 dB from 60 MHz to 80 MHz

10BASE-T

Each test result depends on whether the measured value is within the
specification range.

The specification range for L0BASE-T are listed in the following table:

Table A-3: 10BASE-T Specification Range

Test Specification Range
Template
MAU Ext Fit the Template
MAU Ext Inv Fit the Template
MAU Int Fit the Template
MAU Int Inv Fit the Template
Link Pulse Fit the Template
TP_IDL Fit the Template
Differential Voltage Positive peaks - +2.2Vto+2.8V
Negative peaks - -2.2Vto -2.8V
Harmonic <Fundamental - 27 dB
Jitter
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Table A-3:

10BASE-T Specification Range (cont)

Test

Specification Range

Note: Jitter values are according to the Internal MAU measurement.

with cable

Normal <11lns (+5.5ns)
8.0BT <22 ns (+ 11 ns)
8.5BT <22 ns (£ 11 ns)
without cable

Normal <16 ns (£ 8 ns)
8.0BT <40 ns (+ 20 ns)
8.5BT <40 ns (+ 20 ns)

Note: Jitter values are according to the External MAU measurement.

with cable

Normal <7 (+3.5ns)

8.0BT <14 (£7)

8.58T <14 (£7)

without cable

Normal <16 (8 ns)

8.0BT <32 (16 ns)

8.5BT <32 (%16 ns)
Return Loss At least 15 dB over the frequency range of 5.0 to 10 MHz
Common mode Voltage <50 mV Peak
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TDSET3 Error Messages
Table B-1: TDSET3 Error Messages
Code Error Message Description Possible Solution
E101 Few samples, edge finding failed. The application is not able to detect Ensure that the correct signal is
valid clock signal. connected and the configuration
parameters are correct.
E102 The selected input sources should be Data, Master CLK, Slave CLK cannot be | Ensure that the oscilloscope channels
mutually exclusive. configured to the same source. that you configure for the input sources
are mutually exclusive.
E103 Invalid signal. The estimated TX_TCLK for Distortion Ensure that the correct signal is
The measured clock is out of range. test is either very low or high. connected and the configuration
parameters are correct.
Ensure that the trigger level is adjusted
to get a stable trigger.
E104 The measured value is unstable. The application is not able to get stable | Ensure that the correct signal is
The previous values will be restored. measured values. connected and the configuration
parameters are correct.
E105 Not enough clock edges. The application is not able to find Ensure that the correct clock signal is
sufficient clock edges for Distortion test. | connected and the configuration
parameters are correct.
E401 Cannot connect to the instrument. The application is not able to Reboot the oscilloscope.
communicate with the oscilloscope.
E402 This application requires firmware The application works only with Download the latest firmware from
version 2.2.0 or above. Please install Firmware version 2.2.0 or above. Tektronix Web site.
the latest firmware available at the
Tektronix Web site. The application will
exit now.
E403 Default file does not exist. The application’s default settings file is Reinstall the application.
not found.
E404 Unable to set the mask. The Mask file is missing or corrupted. Reinstall the application.
E405 Enter a valid file name to generate a The file name in the report setup is not Go to Report Setup dialog box and
report. valid. enter a valid file name.
E406 Report data base file read failed. The application's system file is Reinstall the application.
missing/corrupted.
E407 System file exception. If the oscilloscope has a file exception, Reboot the oscilloscope.
this error is displayed at run time by the
operating system.
E408 System memory exception. If the oscilloscope has a memory Reboot the oscilloscope.

exception, this error is displayed at run
time by the operating system.
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Table B-1: TDSET3 Error Messages (cont)

Code Error Message Description Possible Solution

E409 Unknown exception. If the oscilloscope has an unknown Reboot the oscilloscope.

exception, this error is displayed at run
time by the operating system.

E410 Invalid signal. Check whether the DUT | The application is not able to detect a Ensure the correct signal is connected
is connected. valid signal. and the configuration parameters are

correct.

E411 This application has not been enabled. | The application is not purchased. Contact your Tektronix representative.
To enable the application, select
Utility>Option Installation to enter a
key. To purchase a key, contact your
Tektronix representative. Select
Help>Technical Support to contact
Tektronix representative.

E412 Calibration Data unavailable. Calibration is not complete for the Complete all three Load, Short, Open

selected test. calibration steps for the selected test.

E413 Unable to find crossover. Unable to find crossover to place the For 100BASE-TX tests, re-run the test.

histogram while 100BASE-TX, and For 10BASE-T tests, select the Show

10BASE-T Jitter tests. 10Base-T Jitter User Control check
box in the Preference dialog box and
then re-run the test. When the 10Base-T
Jitter User Control dialog box appears,
adjust the TiggerHoldOff parameter of
the oscilloscope.

E414 The selected oscilloscope sources are | The same channel is selected for Select separate channel for each input
mutually exclusive. multiple input sources which are not source.

allowed.

E415 The selected output sources are The same Reference source is selected | Select separate Reference waveform for
mutually exclusive. for output which is not allowed. output.

E416 External trigger unavailable. Check The sync/markerl of the AWG is not Connect the sync/markerl of the AWG
whether the ‘sync Out’ of the AWG is connected to the 'AUX IN' of the to the 'AUX IN' of the oscilloscope.
connected to the ‘AUX IN’ of the oscilloscope.
oscilloscope.

E417 System failure. There is a problem while allocating a Reboot the oscilloscope.

system resource.

E418 Unknown Error. If the application has an unknown error, | Reboot the oscilloscope.

this error message is displayed.

E419 Tekscope is not running. TDSET3 will This error message appears if you click | Launch the TekScope and then
now exit. on Run Test button in the TDSET3 TDSET3 from RunApplication menu to

application after you have exit fromthe | work with TDSET3 application.
TekScope.

E420 Change the probe attenuation to +10 Probe attenuation switch is set to +1 Set the attenuation switch of the probe

before continuing and the measured values may be to +10 before you run the test.
invalid.
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Remote GPIB Error Messages

Table B-2:

Note: The Error Message E419 appears only if you are running the TDSET3

application on a TDS5000B series oscilloscope.

Remote GPIB Error Messages

Code Error Message Description Possible Solution

E601 GPIB write failure The oscilloscope did not accept the Reboot the oscilloscope.
GPIB write command.

E602 GPIB read failure The oscilloscope did not accept the Reboot the oscilloscope.
GPIB read command.

E603 Unable to clear event queue The oscilloscope event queue was not Reboot the oscilloscope.
cleared.

E604 Invalid value set; variable reset to The value set was not within the The variable value has been reset.

nearest limit value acceptable range.

E605 Conversion error: value reset to the The value set characteristics do not The variable value has been reset.

old value match.

E606 Application setup file unavailable The setup file is missing. Resend the command with the

appropriate file name.

E607 Selected test to query the result Invalid test chosen for result details Resend the command with the

details is invalid query. appropriate test name.

E608 Selected test has not been run Querying for a result before the test is Run the test and then query for the
run. results

E609 Invalid value is set, old value will be The value set characteristics do not The variable value has been reset.

reset match.

E610 Test in progress, unable to retrieve Querying for a result before the test is Query for results after the test is

the results complete. complete.

E611 Character string too long The value field is too long. Resend the command with a value

within the acceptable range.

E612 Invalid test/configuration selected The test or configuration selected does Select the appropriate technology and
not correspond to the current then select the test or configuration
technology.

E613 Unable to save application settings The application settings could not be Resend the command with a different
saved to a default file. file name.

E614 You cannot set values for query only | You cannot set values for query only Do not set value for query only

commands commands. commands

E615 Unable to retrieve remarks, test name | You seem to have tried to query for a Query for remarks block between 1 and

unknown. remark block that does not exist. X where X is the response for
"remcounter".
E616 Unable to retrieve remarks for You are asking for remarks of some test | Set the "resultfor" and "getremblk"
specified block id that is not run yet. appropriately in that order only and then
query for "resultrem".
E700 GPIB Time Out GPIB command has timed ou. Reboot the oscilloscope.
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