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General Safety Summary

Review the following safety precautions to avoid injury and prevent damage to
this product or any products connected to it. To avoid potential hazards, use this
product only as specified.

Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of the system. Read
the General Safety Summary in other system manuals for warnings and cautions
related to operating the system.

To Avoid Fire or Personal Injury:

Connect and Disconnect Properly: Do not connect or disconnect probes or test
leads while they are connected to a voltage source.

Observe All Terminal Ratings: To avoid fire or shock hazard, observe all
ratings and markings on the product. Consult the product manual for further
ratings information before making connections to the product.

Do Not Operate With Suspected Failures: If you suspect there is damage to
this product, have it inspected by qualified service personnel.

Symbols and Terms: The following terms and symbols may appear in the online
help.

& WARNING: Warning statements identify conditions or practices that
could result in injury or loss of life.

&: CAUTION: Caution statements identify conditions or practices that could
result in damage to this product or other property.

Terms on the Product: The following terms may appear on the product:

®  DANGER indicates an injury hazard immediately accessible as you read the
marking.

®  WARNING indicates an injury hazard not immediately accessible as you
read the marking.

®  CAUTION indicates a hazard to property including the product.

Symbols on the Product: The following symbol (s) may appear in the product:

A

CAUTION Refer to Help
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Welcome to the RT-Eye® Serial Compliance
and Analysis Application

The RT-Eye product is an application that enhances the basic capabilities of
some high-performance oscilloscopes from Tektronix. The application
incorporates MATLAB run-time and uses it to display real-time graphical
representations of the measurement results in plot windows.

The Real-Time Eye (RT-Eye) application provides general compliance
measurements and analysis capabilities for emerging serial data standards, and
includes the following features:

" Selects and configures multiple measurements on one differential or two
single-ended probe inputs

®  Performs Timing, Amplitude, and Jitter measurements per industry standard
methods

®  Displays an RT-Eye rendering of the serial bit stream, and other plots such
as Waveform (with Bit Error Locator), Jitter Histogram, Jitter Spectrum, and
Jitter Eye Opening analysis

" Specifies configurable Limits for Pass/Fail analysis on waveforms and
measurements when a Limits file is enabled

" Performs "Plug-Fest" level compliance measurements defined by industry
working groups using optional Compliance Modules such as Fully Buffered
DIMM (FB-DIMM), InfiniBand, PCI Express, SAS, and Serial ATA.

B Exports analysis results to a .csv file for further analysis
®  Tracks and saves the worst case waveforms to .wfm files
®  (Creates, formats, and generates reports

®  Automates compliance tests for production

ol
¥Tip To return to the Table of Contents, select Help Topics from the Help menu
bar.
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Five-Time Free Trial

A five-time free trial is available for all applications in the "Applications on this
CD and Compatible Oscilloscope" table found in the Optional Applications
Software on a Windows-Based Oscilloscope Installation Manual. You can start
and exit an application up to five times to help you evaluate Tektronix software
solutions.

Note: To evaluate an application, first check that your TDS6000- or
TDS/CSA7000-series oscilloscope firmware version is consistent with the
version requirements mentioned in the application’s readme file. You can check
the firmware version number from the oscilloscope Help drop-down list (About
...). You can check the application’s firmware compatibility by referring to the
System Requirements section in the application’s readme.txt file.

If an application becomes available after you receive your oscilloscope, you can
download the application as described in the installation manual (Tektronix part
number 071-1078-xx) to obtain the free trial.

Related Documentation

Xviii

In addition to the online help, the application includes a Reference guide. Refer
to the

RT-Eye™ Serial Compliance and Analysis Quick Start User Manual (071-1769-
xx) for the following information:

®  The manual provides task-oriented procedures to explain the basic
operations that cover the set up of the application.

Refer to the Optional Applications Software on a Windows-Based Oscilloscope
Installation Manual for the following information:

B  Software warranty

" List of all available applications, compatible oscilloscopes, and relevant
software and firmware version numbers

®  Applying a new label
®  [Installing an application
®  Enabling an application

®  Downloading updates from the Tektronix Web site
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Note: You can view PDF file of the installation manual from the CD Installation
Browser and from the Documents directory on the Optional Applications
Software on a Windows-Based Oscilloscope CD-ROM.

GPIB Information

For information on how to operate the oscilloscope and use the application-
specific GPIB commands, refer to the following documents:

®  This online help provides a sample RT-Eye program that illustrates how to
set up and use remote automation

®  The user manual for your oscilloscope provides general information on how
to operate the oscilloscope

®  The online help for your oscilloscope can provide details on how to use
GPIB commands to control the oscilloscope if you install the GPIB
Programmer guide (and code examples) from the oscilloscope CD-ROM

®  The online help for Option SST Serial ATA and Serial Attached SCSI
Analysis module provides details on how to use GPIB commands for SAS
and SATA

Relevant Web Sites

You can also find useful information on serial data standards on the following
Web sites:

®  www.Infinibandta.org
" www.pcisig.com
" www.Tll.org

B www.tektronix.com/search RT-Eye.
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Application CD Contents

XX

The Optional Applications Software on a Windows-Based Oscilloscope CD-
ROM includes files for the following types of documentation:

Printable file of the RT-Eye Serial Data Compliance and Analysis online
help formatted to resemble a user manual

Printable file of the Option SST online help formatted to resemble a user
manual

Printable file of the Report Generator online help formatted to resemble a
user manual

PDF files of the Methods of Implementation (MOI) for serial data standards
as they apply to the corresponding compliance modules

RT-Eye™ Serial Compliance and Analysis Quick Start User Manual (071-
1769-xx)

Optional Applications Installation manual

POF file
@ ‘PDFfile

FDF file

Optional Applications CO

Reference  Cnline Help  Installation
form atted as Manual
a user manual

Figure i. Application CD Contents
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Access to PDF Files

You can use any of the following methods to view the various PDF files
associated with this application:

" Access a file in the Documents directory on the Applications CD from any
PC.

®  Access documents on the CD from the Installation Browser.

®  Note: The documents are available on Application CD at
Documents\TDSRT-Eye. The CD Installation Browser page for TDSRT-
Eye is accessed from "Serial Data Compliance and Analysis" and also
includes a link to "Browse the Documentation". This link opens a Microsoft
Explorer Window to the folder above.

B Select a file from the Start menu in the oscilloscope task bar; you may need
to first minimize the RT-Eve application

B Access a file from the Help drop-down list in the RT-Eye application

Note: If you do not have an Acrobat reader to view a PDF file, you can get a free
copy of the reader from the www.adobe.com/products/acrobat Web page.
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Conventions

XXii

Online help topics use the following conventions:

The terms "RT-Eye application”" and "application" refer to the RT-Eye
Serial Compliance and Analysis Application.

The term "oscilloscope" refers to any product on which this application runs.

The term "select" is a generic term that applies to the two mechanical
methods of choosing an option: with a mouse or with the Touch Screen.

The term "Compliance Module" refers to optional "plug-in applications"
from Tektronix used for compliance testing to specific serial data standards.

The term "Limits Module" refers to a formatted text file used to specify user
limits on mask geometry and measurement boundary conditions for
Pass/Fail testing.

The term "channel" is context dependent. It can refer to the transmit channel
of the device under test or to an oscilloscope channel.

The term "DUT" is an abbreviation for Device Under Test.

There may be minor differences in the display of user interface screen
graphics on other types of oscilloscopes such as TDS6000 or TDS7000.

When steps require a sequence of selections using the application interface,
the ">" delimiter marks each transition between a menu and an option. For
example, one of the steps to recall a setup file would appear as File> Recall.
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Types of Online Help Information

The online help contains the following types of information:

A Getting Started group of topics briefly describes the application, contains
connection procedures, and includes an optional deskew procedure.

An Operating Basics group of topics covers basic operating principles of the
application. The sequence of topics reflects the steps you perform to operate
the application and includes definitions for all menus and options.

A Tutorial group of topics teaches you how to set up the application to
acquire a waveform, take a measurement, view the results, view a plot, and
save data to a file.

A Serial Analysis Laboratory group of topics demonstrates how to use serial
analysis measurements to identify a problem with a serial data waveform
through the process of elimination. This should give you ideas on how to
solve your own measurement problems.

A Reference group of topics includes the parameters (range of values) for all
options and the default values.

A Measurement Algorithms group of topics includes information on
measurement guidelines and on how the application calculates each
measurement.

A GPIB Command Syntax group of topics contains a list of arguments and
values that you can use with the remote commands and their associated
parameters. The application includes a simple remote interface program to
show you how to operate the application using GPIB commands.

The application Help drop-down list includes a PDF Help menu item you can use
to access a PDF file of the help topics. The file is printable and is formatted to
resemble a user manual.

The Report Generator utility also has an independent online help system that you
can launch from the Report Generator window.
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Using Online Help

XXIV

Online help has many advantages over a printed manual because of advanced
search capabilities. You can select Help> Topics on the right side of the
application menu bar to display the Help file.

The main (opening) Help screen shows a series of book icons and three tabs
along the top menu, each of which offers a unique mode of assistance:

Table of Contents (TOC) tab - organizes the Help into book-like sections.
Select a book icon to open a section; select any of the topics listed under the
book.

Index tab - enables you to scroll a list of alphabetical keywords. Select the
topic of interest to display the corresponding help page.

Find tab - allows a text-based search. Follow these steps:

Type the word or phrase you want to find in the search box. If the word or
phrase is not found, try the Index tab.

Select some matching words in the next box to narrow your search.

Choose a topic in the lower box, and then select the Display button.

Note: The Find tab function does not include words found in graphics. Refer to
the Find Tab and Searches topic for more information.

To print a topic, select the Print button from the help topics menu bar.

Select Options from the menu bar for other commands, such as to annotate a
topic, to keep the help window on top, or to use system colors.

Select the Back button to return to the previous help window. Sometimes
you can jump from one topic to another through a hyperlink. If the Back
button is grayed out, or a jump is not available, choose the Help Topics
button to return to the originating help folder.

Browse buttons (Next >> and Previous <<) allow you to move forward and
backward through topics in the order of the Table of Contents (TOC).

A Note: in the topic text indicates important information.

Note: Green-underlined text indicates a Jump (hyperlink) to another topic. Select
the green text to jump to the related topic. For example, select the green text to
jump to the topic on Feedback to contact Tektronix.
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O . . . .
¥Tip You can tell when the cursor is over an active hyperlink (button, jump, or
popup), because the arrow cursor changes to a small pointing hand cursor.

i
¥Tip The light bulb icon and word Tip indicate additional information to help
you operate the application more efficiently.

Online Help for the Report Generator

The Report Generator utility is a separate program that allows you to create a
new test template or report layout, or edit an existing one. The online help for the

Report Generator explains how to use the utility.

Online Help for Compliance Modules

Each compliance module has its own help documents: online help or PDF
documents called as MOIs (Methods Of Implementation). To view compliance
specific help topics, refer to the Help menu in the module of interest.
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Find Tab and Searches

Many online help topics contain only tables. To retain vertical and horizontal
lines, the tables are graphical objects. The Find tab in the online help does not
recognize words in these tables.

The online help is extensively indexed with the proper names of all menus and
options as they appear in the application and in the left column of graphical
tables.

Note: If you conduct a Find tab search with no results, try the Index tab instead.

Feedback

Tektronix values your feedback on our products. To help us serve you better,
please send us suggestions, ideas, or other comments you may have about your
application or oscilloscope.

You can send us your feedback by e-mail to techsupport@tektronix.com, by
FAX at (503) 627-5695 (North America), or by telephone (See Contacting
Tektronix) . Please be as specific as possible and include the following
information:

General Information

" Oscilloscope model number and hardware options, if any
®  Probes used

B Serial data standard

" Signaling rate

®  Your name, company, mailing address, phone number, FAX number

Note: Please indicate if you would like to be contacted by Tektronix regarding
your suggestion or comments.
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Application-Specific Information
B Software version number

B Description of the problem such that technical support can duplicate the
problem

B If possible, save the oscilloscope waveform file as a .wfm file

" [fpossible, save the oscilloscope and application setup files from the
application to obtain both the oscilloscope .set file and the application .ini
file. Refer to Saving a Setup File.

Once you have gathered this information, you can contact technical support by
phone or through e-mail. If using e-mail, be sure to enter in the subject line "RT-
Eye Problem," and attach the .set, .ini, and .wfm files.

)

¥Tip To include screen shots, from the oscilloscope menu bar, select File>
Export. In the Export dialog box, enter a file name with a .bmp extension and
select Save. The file is saved in the C:\TekScope\lmages directory. You can then
attach the file to your email (depending on the capabilities of your email editor)

XXVil
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Getting Started

Product Description

The RT-Eye Serial Compliance and Analysis Application is a software product
that enhances basic capabilities of some high-performance oscilloscopes offered
by Tektronix. The RT-Eye application is a general analysis tool you can use to
test, debug, and verify serial-data based designs. The compliance applications are
specific tools you can use with device designs that must comply with serial data
standards, such as PCI Express, FB-DIMM, Serial ATA, Serial Attached SCSI,
or InfiniBand.

You can use this application to do the following tasks:

" Select and configure many amplitude and timing measurements on a serial
data signal

®  Conduct RT-Eye rendering and mask testing, Time Interval Error analysis,
Rj/Dj (random jitter and deterministic jitter) analysis, and display results as
a Bathtub plot

®  Locate bit errors (mask violations) on the acquired waveform

®  Display the results as eye diagram, histogram, spectrum, or bathtub curve
plots

®  Perform Pass or Fail limits testing based on waveform masks and based on
measurements that use Limits Modules

" Perform "plug-fest" level compliance tests for available compliance modules
that test against a specific standard

®  Save the statistical results to a file
B Save the worst case waveforms to files

" Generate reports

Note: There are no standard accessories for this product. Refer to Accessories
for a list of recommended probes.
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Analysis and Compliance Modules

Compatibility

You can use the RT-Eye (real-time eye) serial data analysis application and
industry specific compliance modules to characterize serial transmission signal
integrity. The applications were developed to help you perform analysis on the
following types of designs:

B General serial-data based designs
B Device designs that need to comply with a specific serial-data standard

The RT-Eye application is the foundation for current and for future compliance
modules. Each enabled compliance application shows at least two choices in the
Modules drop-down list; one will always be for Serial Analysis.

For information on oscilloscope compatibility, refer to the Optional Application
Software on Microsoft Windows Based Oscilloscopes Installation Manual,
Tektronix part number 071-1888-xx. The manual is available as a PDF file.
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Requirements and Restrictions

The Sun Java Run-Time Environment (JRE) and the Mathworks MATLAB Run-
Time Server are components of the RT-Eye application. When you install the
application, the InstallShield Wizard automatically installs the proper software
components.

MATLAB Server: The MATLAB server is dedicated to the RT-Eye application
and cannot be used for other purposes. Do not close the Matlab Server icon
in the oscilloscope task bar because this will disrupt the operation of the RT-Eye
application. The application will close the MATLAB sever when you exit the
application.

Oscilloscope: Maximum sampling rate of 20 GS/s with interpolation is often
necessary to ensure accurate results. Be sure to consider the following differences
in sampling rates before taking measurements:

®  The TDS6604 oscilloscopes sample at 20 GS/s on two channels and at 10
GS/s on four channels.

" The TDS7404 oscilloscopes sample at 20 GS/s on one channel and at 10
GS/s on two channels.

®  The TDS6000C oscilloscopes sample at 40 GS/s on two channels and 20
GS/s on four channels.

®  The TDS6000B oscilloscopes sample at 20 GS/s on two and four channels.

®  The TDS7000B oscilloscopes sample at 20 GS/s on one channel, 10 GS/s on
two channels, and 5GS/s on four channels.

When the Record Length of the oscilloscope is set to 4M or less, the application
can take all measurements. When the Record Length is set to 4M or 20M, the
RT-Eye application can take one TIE measurement.

Keyboard: You may need to use a keyboard to enter new names for some file
save operations.

Distiller Software: To convert an RTF file from the Report Generator utility to a
PDF file, you require distiller software, such as Adobe Acrobat 6.0 or freeware
such as CutePDF.
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Minimum Required System Configuration

Accessories

Table 1: Probes
Probe*

P73XX (Includes P7350,
P7380, P7313)

Before operating the RT-Eye application, check the readme.txt file to verify
whether the oscilloscope configuration meets the minimum requirements. If the
RT-Eye application is installed on the oscilloscope, select Start> Programs>
TekApplications> tdsRT-Eye> readme file. If the application is not installed, the
readme.txt file is in the same directory as the setup.exe file on the Optional
Applications CD.

There are no standard accessories for this product. However, you can refer to the
product datasheet available on the Tektronix Web site for information on
optional accessories relevant to your application. For example, Tektronix
recommends that you use the following probes:

Description
Z-Active ™ Differential Probe family.

P73XXSMA

SMA Input Differential Acquisition System.

*Check the www.Tektronix.com web site for an up-to-date list of probes and
information on standard-specific test fixtures.

Installation

Refer to the Optional Applications Software on a Windows-Based Oscilloscope
Installation Manual, Tektronix part number 071-1078-xx, for the following
information:

®  Available applications, compatible oscilloscopes, and relevant software and
firmware version numbers

" Using the free trials

®  Applying a new authorized Option Installation key label
®  Installing the application

®  Enabling an application

®  Downloading updates from the Tektronix Web site

The manual is also available as a PDF file.

RT-Eye ®Serial Compliance and Analysis Application
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Connecting to a Device Under Test (DUT)

Probe Information

Table 2. Probe Information

You can use any compatible probes to connect your DUT (Device Under Test)
with your oscilloscope.

There are four typical probing configurations for serial data links: two for Pseudo
Differential Waveforms and two for True Differential Waveforms. The method
of setting up your measurement channel(s) is dependent on your application and
what you want to measure.

WARNING: To avoid electric shock, you must ensure that power is removed
from the DUT before attaching probes to it. Do not touch exposed conductors
except with the properly rated probe tips. Refer to the probe manual for
proper use. Refer to the General Safety Summary in your oscilloscope
manual.

Proting Configuratons Captured Waveforms Typical System Specifications

Bresk N TD586041B ThEFTo4E= TOS68048 TOSE124L TDE61 540
Probe Sedial e | vema | et Baand = Band — Bared - Eand . Bard —
Link Ugad Mad Mok it | T2 s | 772 | iy | T | ey | Tme | | Time
(080} (2080} {20-80) L2080 (2030}
SMa A | 2 x TCA-SMA ¥ ] Pseudo AL BGHz | 53ps | TGHz | 43ps | BGHz | 385ps |13GHz| Mps | 15GHz | 19ps
Connection | B |1 < PT3805MA | Y 1 Trus M BGHz | 53ps | TGHE: | £3p= | BGHE | 35ps | 8GH= | 36ps | BGHr | 36ps
2xPT260 |Yer M 2 Fogudo | ACDC | BGHz | Sdps | G0Hz | o6ps | GOHz | S6ps | BGHz | Shps | BGHz | Ghps
ECB C 2xPT380  [Yor N 2 Peeuda | AC/DC | BGHr | 53ps | TGHz | 43ps | BGHZ | 35ps | BGHr | 35ps | SGH: | 36ps
Pad 2xPT331 [YorN 2 Pseuwdo | AC/OC | BGHz | 53ps | TGHz | 43ps | BGHz | 35ps |12GHz| 28ps |12 5GHz | 26ps
Connection o 1% PT3E0 Y oof N 1 Trus M BGHz | 53pa | TGHz | 43ps | BGHE 1 J5ps | BGHEz | 35ps BGHE 3hps
1xPT313 [YorH 1 True Ho BGHz | 53ps | TGHrz | 43ps | AGH=z | 35ps |123GHz| 28ps | 12 5GHz | 26ps

* Tyica!

" 1055 1 Peeudo-aiifemahal

)

#Tip When you are deciding what oscilloscope and probe combination to use,
the system bandwidth should be greater than 1.5 times the bit rate. This provides
adequate bandwidth for most of the measurements because most of the energy in
high-speed serial data signals is contained in the 1¥ and 3™ harmonic. To ensure
accurate Rise time measurements, 2.5 times the bit rate (Sth harmonic) is
required.
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Power Spectrum of a 2.5 Gb/sec Signal Example

Note: The 1% and 3" harmonics are the two highest peaks.

18 D60 02 14382
i1 1 aF

ARG b b i L LR

Figure 1: Power Spectrum of a 2.5 Gb/sec signal

Two TCA-to-SMA Adaptors, Diagram A

Oscilloscope
Sl Ay CH1CH3
Connectors SASISLS)
Caonnector \
g0
T | o Termination

Serdes - a0 0 SMA cables

i
D} ShaA
~dapters
ECE Test

fixture

Figure 2: Two TCA-to-SMA Adaptors, Diagram A

6 RT-Eye ®Serial Compliance and Analysis Application



Getting Started

One P73XX SMA Differential Probe, Diagram B

Dscilloscope
CH1
oCo0
Test SrBot s || VEEE =g 1

ECH

P

Oscilloscope
ground connection

Connector

Fhase-matched
Sh A cables

Figure 3: One P73XX SMA Differential Probe, Diagram B

Two P72XX Single-Ended or P73XX Differential Probes, Diagram C

ECE Cannector ECE Termination

Oscilloscope

T3

CHT
PORO0

VDIFF = CH1-CH3

Figure 4: Two P72XX Single-Ended or P73XX Differential Probes, Diagram C
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One P73XX Differential Probe, Diagram D

ECE Connector ECE

Oscilloscope

CH1
0000

YDIFF = CH 1

Figure 5: One P73XX Differential Probe, Diagram D

Deskewing Probes and Channels

When using two channels to perform pseudo-differential measurements, it is
important to deskew the probes. Be sure to use the proper deskew fixture and
procedure as described in the online help of your oscilloscope.

Note: The RT-Eye application relies on upsampled, deskewed data from the
oscilloscope to conduct math operations for differential and common mode
waveform measurements. Upsampling prior to deskew is required to ensure
accurate measurements.

Oscilloscope firmware V 2.4.0 and above implements sub-sampled deskew and is
required if you use the RT-Eye application for Single-Ended measurements.
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About Basic Operations

The topics in the Operating Basics book cover the following definitions and
tasks:

®  Application user interface

®  Basic oscilloscope functions

®  Saving and recalling

®  Setting up the application

®  Using a Limits file

®  Using User Masks

B Taking measurements

®  Saving the measurement results

" Viewing the measurement results as plots

B Using the plot window zoom and cursors

" Saving plots

®  Logging the worst case waveforms

B (Creating and generating a custom compliance report

RT-Eye ® Serial Compliance and Analysis Application 9
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Starting the Application

On the oscilloscope menu bar, select File> Run Application> RT-Eye Serial
Compliance and Analysis. View how to start the application. For B and C series
oscilloscopes, select App> RT-Eye Serial Compliance and Analysis from the
menu bar to run the application. For DPO series oscilloscopes, select Analyze>
RT-Eye Serial Compliance and Analysis.

The application starts and displays the Measurements> Select menu.

After the application initializes, the Welcome dialog box, if enabled, will appear.
If it is disabled, you can use File> Preferences to configure it to appear the next
time the application is launched.

KX RT-Eye Welcome x|

Fun hiyTest

Cancel

ﬂ shou this dialog at startup

Figure 6: RT-Eye Welcome dialog box

You can perform the following functions in this dialog box as shown in the table:

Table 3. RT-Eie Welcome dialoi box oitions

Run MyTest Recall the previously saved MyTest setup and automatically
start the sequencer. See also: Running MyTest.
Run Wizard Launch the RT-Eye Wizard. The application takes the

measurements and displays the results in the result
summary window. See also: About Serial data Wizard.
Cancel Close the RT-Eye Welcome dialog box and work directly
with the application.

Show this dialog | Enable or disable display of the RT-Eye Welcome dialog the
at startup next time when you launch the application.

10 RT-Eye ®Serial Compliance and Analysis Application
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Oscilloscope Menu Bar and Selected Application

For non-B series oscilloscopes, select File> Run Application> RT-Eye Serial
Compliance and Analysis to start the application.

File  Edik Yertical Horiz) Acq Trig  Display  Cursors Measure  Masks

Reference Waveforms »
Instrument Setup. ..
Recall Default Setup

Run Application %I Compliance Tesk Saolution
Jitter Analvsis 3

P Setup...
e!ge s pr Jitter Analvsis 3 Essentials
Prink Prewview
. Power Measurements 3
Print. .. Ckrl+P _ . "
ial Compliance and &na
Export Setup, .. I1SB2.0 Test Package
Select For Export »
Export...

1 CiTekScope)3etups) Test, set

Minimize Chrl-+1

Shutdowr. ..
Figure 7: Oscilloscope menu bar and selected application

For B/C series oscilloscopes, select App> RT-Eye Serial Compliance and
Analysis to start the application.

File Edit Vertical Horiz/Acg Trig Display Cursors Measure Masks Math m Utilities Help Buttons
Tek Run Sample Restore .ﬁpplicati:n

Protocol Trigger and Decode

Figure 8: B/C series oscilloscope menu bar and selected application

Application Interface

The RT-Eye application uses a Microsoft Windows based interface. Display the
definitions of the application user interface items, or view a menu labeled with
the user interface items.

Note: The oscilloscope application shrinks to half size and appears in the top
half of the screen when the application is running.
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User Interface Definitions

Table 4. User Interface Definitions

Item Description

Area Visual frame that encloses a set of related options.

Box Use to define an option; enter a value with the Keypad or
turn the Multipurpose knob to select a value.

Browse Displays a window where you can look through a list of
directories and files.

Button Use to define an option; not a command button.

Check box Use to select or clear an option.

Command button

Initiates an immediate action, such as the Start command
button in the Control panel.

Control panel

Located to the right of the application; contains command
buttons that you use often, such as to Start sequencing.

Keypad On-screen keypad that you can use to enter numeric
values.

List box Use to define an option from a list.

Menu All options in the application window (except the Control
panel) that display when you select a menu bar item.

Menu bar Located at the top of the application display and contains
application menus.

Option Any named button (other than a command button) or any
named box that defines a control or task.

Status bar Line located at the bottom of the application display that
shows the name of the current menu (location) and the
next step that you might take (action).

Tab Short cut to a menu in the menu bar or a category of

menu options; most tabs are short cuts.

Virtual keyboard

On-screen keyboard that you can use to enter
alphanumeric strings, such as for file names.

Scroll bar

Vertical or horizontal bar at the side or bottom of a
display area that you use to move around in that area.

12
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Menu With Application User Interface Items

Multipurpose knob Cormmand Hide Button
Manu Bar Tabs icon Button
r File Modules Measurements Plots Results Log Wilities Help EQA pr pve' ™ | X .
Souroe Fef = | Bmart Gating Clook F‘I{l;‘l'll'sl' Jitter Fapulation @eneral Config
Source J : Set Reference Level
Chi — Rise —— p—— Fall — Purtoset
High High L
S— S— L Setup
Area _: . Z00mV 200mV :_Cnntn:ul
Pid Fanel
e pid = o
J
enu: Meas->Config |
Status Bar Biox o defing Check box o List bax
an option set or clear an of options
aptian
Figure 9: Menu with application user interface items
® . . . .. 13
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Application Menu Bar and Drop-Down Lists

" Modules will not display on oscilloscopes with a bendwidthless then 6 GHz.

Figure 10: Application menu bar and drop-down lists

14

Using Basic Oscilloscope Functions

You can use oscilloscope controls and functions while running the application.
To do so, select a menu from the oscilloscope Menu bar (or Toolbar) and access

File Modules  Measurements Flots Resuls Log LNilties Help
I [ I
Recall Setup Salert Help Topics
Recal Configure PUF Help
Save.... Guick Starl Guide
Recall Recent About RT-Eye
Preferences g‘j:r;’r . ) —
Lo LinfitsghI Ref Levels ‘ hattis ‘
Ll Wizard. Smert Galing
er.-umize Run MyTes! Sl e Worst Case  p—— Corfigure
Exit Save MyTest dter File Names
Fopuaion
General Config
FB-DIMM
InfiniBand
PCl-Express Summary
SAST Details
serial ATAT
Serial Analysis

1 as-Ime

menus, or use the front-panel knobs and buttons. You can also use the

oscilloscope Help menu to access information about the oscilloscope and how to
use it. When you access some oscilloscope controls, the oscilloscope fills the

display.
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Returning to the Application

File  Edit  Wertical Horigfacg  Trig  Display  Cursors  Measure  Masks  Math  Utilities Help
3 12 Dec 07110

To return to the RT-Eve application,
choose the App button
Figure 11: Returning to the application

For B and C series oscilloscopes, select App> Restore Application to return to
the RT-Eye application.
Hiding the Application

The Hide function minimizes the application and the oscilloscope fills the
display. To hide and return to the application, follow these steps:

1. Select the M| command button in the application menu bar.
2. Use the oscilloscope.

3. Return to the application.

Minimizing and Maximizing the Application

To minimize the RT-Eye application, select File> Minimize in the application
menu bar.

To maximize the application, select %l in the task bar.

Exiting the Application

To exit the RT-Eye application, select File> Exit or the X (Exit) command
button in the application menu bar. When you exit the application, you can
choose to keep the oscilloscope setup currently in use with the application or to
restore the oscilloscope setup that was present before you started the application.
If you select the Save MyTest check box, the current setup of both the
oscilloscope and the application will be saved for convenient recall next time.
Refer to MyTest for more information.
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Exit RT-Eye x|

[l Save MyTest

Do you want to restore the oscilloscope settings

to the state prior to starting RT-Bye?

Figure 12: Exiting the application

Docking the Application

To Dock the RT-Eye application, select File> Dock in the application menu bar.
This positions the application at the default location.

|File Modules Measurements Plots Results Log Utilities Help KOU T Be™ B X
Recall Default ngle Ended ¥
Fecall...
Save.. Amplitude -----eeeee oo itber oo
Recall Recent » Jni Differential P
2 Waoltage Yaltage i BER . e e
Preferences. . Clear Results
: High AL CM Selec o
|:_ . 1
Rate amplitude [ woltage TIE Jitter ots
Undock
Minirrize Low De- Hede
Exit 21l Amplitude Emphasiz Sl Single Run W

Menu: Meas->Select
Figure 13: Docking the application

Undocking the Application

To Undock the RT-Eye application, select File> Undock in the application menu
bar. After you undock the application, you can click and drag the application tool
bar to position the application anywhere on the screen.
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File Modules MWeasurements FPlots Results Log  Utilities Help EQU RT.Bye™ B X

Fecall Default

rifferential
Fecall...
Save.., Amplitude —eeeeeee eeee itter -----
Recall Recent ¥ Ini Differantial [e- i T —

2 Waltage Emphasis 1
Preferences. .
Dok High TIE Jitt

Amplitude e
1
.. L hlade

Minirmnize D-W Configure
Bt Amplitude = Single Run

Menu: Meas->Select

Figure 14: Undocking the application

Application Directories

During installation, the application sets up directories for various functions, such as to save setup files, and uses
extensions appended to file names to identify the file types.

Table 5. Application directories
Default directory names* Directory use

\modules\SerialAnalysis Serial Analysis application home location.

\modules\SerialAnalysis\data Measurement results files.

\modules\SerialAnalysis\limits Limits files for Pass or Fail compliance
tests.

\modules\SerialAnalysis\masks Waveform mask files for plots and limits
testing.

\modules\SerialAnalysis\setup Setup files.

\modules\SerialAnalysis\waveforms | Log worst case waveforms and recall
waveform files.

\Masks Mask files for various serial data
standards.

\Examples\RemoteCtrl Sample remote control program.

\Examples\WFMS Waveforms for learning.

\images Plot files.

\temp Temporary files.

\ReportGenerator\modules\Serial Files created by the Report Generator

Analysis\Reports utility.

* All subdirectories are located in the C:\TekApplications\tdsrt-eye directory.
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Directory Structure for the Serial Analysis Application

-] TDsITave
-1 TDSPWRS

{:I Examples
{:I images
l:l Masks
{:I modules

Address | C:\Tekapplicationsitdsrt-eve j o
Folders * || Mame ¢ | Size | Type
{—:I QUARANTIME ﬂ D Examples File Falder
#-] Redwood [Jimages File Falder
{:I StressLog [ IMasks File: Folder
EH:I Tekapplications Cmodules File: Folder
H-0 TosowI (IReportGenerator File Folder
D TOSETS CJtemp File: Folder
D tdsijit3 E Warnings OFKE Text Document

{:| temp
+-{ ] TDSUSE: M | K1 | i
|? abjectis) (Disk free space: 794 ME) |IZI bytes |LEJI My Camputer o

Figure 15: Directory structure of serial analysis application
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File Name Extensions

Table 6. File name extensions

Extension Description

.bmp File that uses a “bitmap” format.

.CSV File that uses a "comma separated variable" format.

.dat File with binary format; stores waveform vectors.

fig Plot file with binary data.

gif File that uses a “graphics interchange format”.

Jani RT-Eye application setup file.

Jpg File that uses a “joint photographic experts group” format; also
known as JPEG.

Jim Limits file used with Pass/Fail compliance tests.

.mat MATLAB waveform vector header saved to the hard disk.

.msk Waveform mask file used with plots.

pdf File that uses a “portable data format”.

.png File that uses a “portable network graphics” format.

.rgt File that defines the report template.

.rpl File that defines the report layout.

.rpt File created by the Report Generator utility.

rif File that uses a “rich text format”.

.set Oscilloscope setup file saved that is recalled with an application
.ini file; both files will have the same name.

wfm Waveform file; can be recalled into Reference memory.

RT-Eye ® Serial Compliance and Analysis Application
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How to Enter Alphanumerical Values

Note: Press the FINE button on the oscilloscope to enter or select the smallest
values or units.

Note: Be sure to select the CLR button before you enter a value using the keypad.

Table 7. How to enter alphanumeric values
Method Description
E Keypad When you select the keypad icon, the virtual keypad

appears (looks similar to a calculator); use to enter a
value.

@ Multipurpose | When you select a knob icon, a line appears between the
knob* upper icon and the option box. This activates the upper
multipurpose knob on the front panel of the oscilloscope;

turn the knob to select a value.

Keyboard When you select the keyboard icon, the virtual keyboard
appears (looks similar to a physical keyboard); use it to
enter a file name.

Edit box* Type in a value from the physical keyboard and press the
Enter key.

* When selected twice, the Keypad appears.
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Virtual Keypad

Note: Select the n icon, and then use the virtual keypad to enter information,
such as reference voltage levels.

Bit Rate x|
Multpurpose =2
knob icaon
- -

""t'fi .': Multipliers

kb.l's
Minirmum val ue hdin +i-
hbis
button
M a=irnurm v al e BKSP J
button

Clears value --
Select before yvou enter a value

Figure 16: Virtual Keypad
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Virtual Keyboard

Note: Select the =] icon, and then use the virtual keyboard to enter
information, such as file names.

dapplicationsitdst-eyemodules\SerialAnalysisulimits\limits. lim

I i 1 I
iy T N u

CapSLGCk n--“
Z > 7

Figure 17: Virtual Keyboard
Using MyTest

About My Test

The MyTest feature allows you to save a single measurement configuration so
that it can be recalled and run at any time with a single click. This is similar to
the save/recall feature (which allows as many named configurations as you
want), except that MyTest is designed to be easily accessible and runs
automatically when selected.
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Saving MyTest

To save the current application and oscilloscope settings without closing the RT-
Eye application, select Measurements> Save MyTest.

File Modules | Measurements Flots Results Log  LHilities Help

Frobe T'!-"F""-' SEIEET

Configure

Limits Amplitude

Eve Width! Wizard. .. tial [re- Jitter
Eye Height Run MyTast e Emphasis i BER

Rizse !
i TIE Jitter
Time 0
Fall L
Time Amplitude

Figure 18: Save Mytest

You can also save your MyTest before exiting the RT-Eye application. When
you select File> Exit from the RT-Eye application, the application prompts you
to save the oscilloscope settings. If you select the Save MyTest check box, the
current setup will be saved as the new MyTest.

Running MyTest

Select Measurements> Run MyTest to run MyTest at any time.

File Modules | Measurements Flots Results Log Ltilities Help
Select

Frobe Type
Configure
-------------- Lirmits Amplitude —eeeeeee eeee

Eve Wfidths Wizard e Jittar
Ewe Height 1] Emphasis i BER

Rise
i TIE Jitter
Time

Fall
Time Amplitude

enu; Meas-=5elect

Figure 19: Run Mytest

The application takes the measurements from the saved MyTest and displays the
results in the Result summary window. You can also run MyTest directly from
the RT-Eye Welcome dialog. Refer to Starting the Application.
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Using Serial Data Wizard

24

About the Serial Data Wizard

The RT-Eye application Setup Wizard guides you through the process of setting
up, running, and displaying the results of a measurement using an intuitive
sequential process. The Wizard can be used for accurate measurements for a
single acquisition, or as a starting point for advanced configurations, or free-run
measurements.

Note: The statistical results for the Setup Wizard and RT-Eye application are
identical if the measurements and setups are the same.

Select Measurements> Wizard to open the Setup Wizard anytime. You can also
open the Setup Wizard during the launch of the RT-Eye application by clicking
Run Wizard in the RT-Eye Welcome dialog. Refer to Starting the Application for
more information.

The Setup Wizard takes you through the steps to configure the following
parameters:

" Probe type

®  Measurement Sources

" Standards

®  Measurement Categories

" Autoset Source Levels

®  Autoset Source Reference Levels

®  Plots

Note: You can exit the Setup Wizard without affecting any settings in the Serial
Analysis application by clicking Cancel anytime before clicking the Run button.

RT-Eye ®Serial Compliance and Analysis Application
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Probe type

In this step, you can select the type of probe. The default probe type is Single-
ended. In the single-ended probe configuration, you connect two probes or two
SMA cables to the unit under test and the application forms a pseudo-differential
signal by subtracting them. See Probe Diagrams A and C ". In the differential
probe configuration, you connect a single differential probe, as shown in Probe
Diagrams B and D.

Note that the currently selected step is always highlighted in the left column of
the Wizard.

Click Next to accept your probe type and proceed to Measurement Sources.

Setup Wizard x|

1. Select Probe Type

2. Measurement Sources

3. Standards

. hdeasurement Categaries Probe Type

Differantial bl

A, Autoset Source Scales

5. Autoset Sre Ref Lewels

“

Figure 20: Probe Type
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Measurement Sources

In step 2, you can select the Measurement sources. The available sources depend
on which probe type you have selected in the previous step. The selection in the
previous step is displayed in yellow text as shown in the following figure.

Click Next to proceed to Standards. Click Back if you want to change the probe
type.

Setup Wizard

2. Select Meas Source

1. Probe Type
Crifferential
2. Measurement 5
3. Standards
Ch & Ref

Refi

5. Autoset Sre Ref Lewvels

EE EEEE

Figure 21: Measurement sources

26 RT-Eye ®Serial Compliance and Analysis Application



Operating Basics

Standards Selection

In step 3, you select the Serial Analysis standards that guide clock recovery by
establishing the bit rate. The default standard is PCI-E : 2.5 G.

Click Next to proceed to Measurement Categories.

Setup Wizard x|

3. Select Standard

. Standards

4. Measurement Categories Standard: bis

IBAZE00 : 2.5

ource Scales

Figure 22: Standards
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Measurement Categories

In step 4, you select the Measurement that will be performed. Various
measurement parameters are grouped under these categories. You need to select
at least one measurement to advance to the next step. For more details, refer to
Selecting a Measurement.

If you select Jitter@BER measurement, you can set the pattern length by
selecting Repeating pattern and then entering the pattern length in the Pat Len
text box. The default value is 2500 unit intervals. If you have a non-repeating
waveform pattern or if the pattern length is unknown, select Arbitrary.

Note: The measurements that you select also determine which plot types will be
available in step 7.

Click Next to proceed to step 5, where you select whether to Autoset the source
scales.

Setup Wizard x|

1. Probe Type
Lifferential

2. Measurement Sources
Fef1

2. Standards

Figure 23: Measurement categories
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4. Select Meas Categories

m Timing
ﬂ Amplitude

[ TIE Jitter

[ Jitter@BER

g Arbitrany
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RT-Eye ®Serial Compliance and Analysis Application



Operating Basics

Autoset Source Levels

In step 5, you can choose to automatically adjust the horizontal and vertical
scaling before the measurement. This is similar to the Autoset feature of the
oscilloscope. The default of Yes is recommended unless you select a reference
source. If you select No, you will retain the current oscilloscope settings.

Click Next to proceed to Autoset the source reference levels.

Setup Wizard

5. Autoset Src Scales?

1. Probe Type

Lifferantial
2. Measurement Sources
R af1

3. Standards
arhrreznded)

Figure 24: Autoset source levels
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Autoset Source Reference Levels

In step 6, you can choose to automatically adjust the reference levels before the
measurement. The reference levels are the voltage thresholds that are compared
to the waveform to determine when timing events occur. The default of Yes is
recommended.

Click Next to proceed to Plot selection.

Setup Wizard

Steps 6. Autoset Src Ref Lev?

1. Probe Type
Drifferential

2. Meazurement Saurces
Refl

2. Standards

O ves (recommended)

4. Measurement Categaories

Ma
Timg, Amp, TIEJ WBER, Arb ... o

will retain the current

Cancel

Figure 25: Autoset source reference levels

Plots

In step 7, you can select the plot types that you want to display. Some plot types
may not be available depending on the measurements that you chose in the
Measurement Categories step. The default is to select all plot types. The types of
plots available are:

®  Eye Diagram—Default and is available for all measurements
" Spectrum—if TIE Jitter is selected
®  Bathtub Curve—if Jitter@BER is selected

" Jitter Histogram—if TIE Jitter is selected
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Setup Wizard

7. Select Plot Types

1. FProbe Type
Crifferential
easurement 5
Fafl
itandards

[ Eve Diagram

ﬂ Spectrum (TIE Jitter)

[ Bathiub C

ﬂ Jditter Hi ram [TIE Jitten
Mo

5. Autose

Figure 26: Plots

Click Run to start a single acquisition sequence using the selected settings. The
Plot waveform diagrams are displayed in the chosen order, as shown in the
following figure.
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Figure 27: Plot waveform diagrams
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File Menus

File Menu Definitions

Table 8. File menu definitions

Menu/function
Recall Default

Description or function
Recalls most default (startup) parameters for the active module.

Recall*

Browse to select an application setup (.ini) file to recall the setup

file. Recall restores the application to the values saved in the setup.

Save*

Save the current application settings in a .ini file.

Recall Recent

Select from a list of the four most recently accessed setup files
(saved or recalled) and recall that setup.

Preferences Displays the Preferences menu; settings apply until you exit the
application; saved setup files include the settings.

Dock Locks the RT-Eye user interface to its default position.

Undock Allows the RT-Eye user interface to be repositioned.

Minimize Minimizes the application.

Exit Exits the application; you can choose to retain the current

oscilloscope settings or restore the oscilloscope to settings prior to
starting the application.

*Save or Recall functions also save or recall the associated oscilloscope setup file (.set);
an oscilloscope file is recalled if the application finds a .set file with a matching name.

RT-Eye ® Serial Compliance and Analysis Application
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About the File menus

You can use the File menus to save and recall different application setups and
recently accessed files. Display the definitions of the file menus.

Note: The File> Save function saves application settings in an .ini file and the
settings of the oscilloscope application in a .set file with a matching name.

If an oscilloscope .set file with a matching name is found when you recall an
application setup file, then the oscilloscope settings are also recalled. If the .set
file is missing or cannot be opened by the oscilloscope, then the application
recalls the application settings and displays a message that the Recall of the .set
file failed.

CAUTION: Do not edit a setup file or recall a file not generated by the
application.

Saving a Setup File

To save the application and oscilloscope settings to a setup file, follow these
steps:

1. Select File> Save.

2. The Save dialog box appears. To view details about the file, such as size,
type, and modified date, select the Details tool.

3. In the file browser, select the directory in which to save the setup file or use
the current directory.

4. Select or use the keyboard to enter a new file name. The application appends
an ".ini" extension to the name of the application setup file.

5. Select the Zave command button.

Note: The application also saves the oscilloscope setup to a ".set" file when you
save an application setup. Both the application .ini file and oscilloscope .set file
have the same file name.
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File: Save Browser

To view details, such as file size, type, and modified date, select the Details tool.

- Cancel

Figure 28: Save Browser
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Recalling a Saved Setup File

To recall the application and oscilloscope settings from saved setup files, follow
these steps:

1.
2.

Select File> Recall.

The Recall dialog box appears. To view details about the file, such as size,
type, and date modified, select the Details tool.

In the Recall dialog box, select the directory from which to recall the setup
file.

Select a setup file name, and then select Open.

Note: The application recalls the .ini setup file and the associated oscilloscope
setup if the application can find a .set file with a matching name.

CAUTION: Do not edit setup files. If you try to recall a setup file that has
been edited, the recall operation fails.

CAUTION: If a matching .set file is not found or if the .set file does not recall
correctly to the oscilloscope, then a warning appears that says the
oscilloscope recall failed while the RT-Eye application recall succeeded.

RT-Eye ®Serial Compliance and Analysis Application



Operating Basics

File: Recall Browser

To view details, such as file size, type, and modified date, select the Details tool.

11:20 P

211:41 FM

- Cancel

Figure 29: Recall browser
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Recalling the Default Setup

To recall the default application settings, select File> Recall Default.

Note: Most of the settings for the active module are recalled to the default state.

Recalling a Recently Saved or Accessed Setup File

To recall a recently saved or accessed setup file, select File> Recall Recent and
then the file from the drop-down list of setup file names.

Note: The application also recalls the associated oscilloscope setup if the
application can find a .set file with a matching name.

& CAUTION: Do not edit setup files. If you try to recall a setup file that has
been edited, the recall operation fails.

A CAUTION: If a matching .set file is not found or if the .set file does not recall
correctly to the oscilloscope, then a warning appears that says that the RT-Eye
application recall succeeded but the oscilloscope recall failed.
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Recall Recent Drop-Down List Example

File Modules Measurements Plots EOU pT.Be™ B x

Fecall Default

Results Log Liilities Help

ngle Ended 7
Recall...
SAVE...  [EEEEELY) 1111 (TT. [ RSSRta [) JS
Fecall Recent » . Autoset
Freferences... Clear Results
High AL Ch Selec e
Dack TIE Jitt .
Amplitude Voltage Her “lats
LInd ek
Mlnlmlze ru1l:“j':-.
o li . i Configure
. 2y Amplitude Emphasis Single Run

Menu: Meas->Select

Figure 30: Recall recent drop-down list

Defining Preferences

The application includes options that you can set, and these options remain
applied until you change them. The options can help you to operate the
application more efficiently.

The File Preferences menu contains several check box options that you can set
(enable) or clear (disable). Saved setup files include the File> Preferences
settings. View the File Preferences menu.
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File Preferences Options

Table 9. File preferences options
Option Description

Show Welcome dialog at Start | Determines whether welcome dialog box is

up displayed whenever the application is launched.
Show Autoset Summary when | Determines whether a summary table of autoset
Autoset is selected values is displayed every time autoset is run.
Enable high-performance eye |When unchecked, all unit intervals (Ul) in the
rendering waveform(s) are included in the rendered eye.

This gives the highest fidelity eye rendering, but
can take considerable amount of time for long
records.

When checked, a statistically representative
subset of the Ul is rendered, so that eye diagrams
for long waveforms can be displayed in a
reasonable time.

The rules for high-performance rendering are as
follows:

1) If the waveform contains 15,000 or fewer Ul, all
the Uls in the waveform are rendered.

2) If the waveform includes more than 15,000 UlI,
it is subdivided into segments of 2000 Ul each.
The entire waveform is scanned to find the Ul,
which are the worst-case violators for six different
points around the eye. For each of these worst-
case violators, the entire segment of 2000 Ul in
which it lies is rendered. Depending on whether
multiple worst-case violators lie in the same
segment or not, as few as 2000 Ul but typically
from 8000 to 12,000 Ul will be rendered in the

final eye.
Cancel Discards changes and closes.
OK Accepts changes and closes.

File: Preferences Menu

Preferences

me dialog at startup

summary dialog when Autoset i=s

ﬂ Enable high-peformance eve rendering

Figure 31: File preferences menu
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Setting up the Application

About Setting up the Application for Analysis

You need to set up the RT-Eye application for serial data analysis or for serial
data standard compliance testing. To do so may require that you perform some or
all of the following tasks:

B Choose the probe configuration: differential or single-ended
B Select all desired measurements
®  Select the Autoset command button

®  This automatically sets the range of the vertical scale, sets the horizontal
resolution, and dynamically sets the waveform crossing thresholds based on
signal characteristics.

®  Configure measurement options manually in the Source, Ref Levels, Smart
Gating, Jitter, Population, and General Config menus.

" Select and configure all desired plots (up to four at one time)

After setting up the application, you can select the Start command button to take
measurements. The application displays the results as statistics and as plots if you
set up the Plots menus and enabled the Plots Display option.

Note: You can enable and adjust Measurement Limits checking to create a Pass
or Fail type of compliance test. You can also import industry standard masks and
modify or create your own masks files.

After taking measurements, you can do any of the following tasks:
" View the results as statistics

®  Save statistics in a .csv file

®  View the results as a plot
B Use the Zoom functions in a plot

" Use the Cursors functions in a plot

B Save a plot file

®  Print a plot

B Save the worst case waveforms as .wfm files
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®  Generate a report file

General Steps to Set Up the Application

Start
application Plots

, !

Select probe - Select -
type measurements

Start
Configure Bl
’ *

Y

Measurements

Source

Ref Levels
Smart Gating
Clock Recovery
Jitter
Population
General Config

1TEE005

Figure 32: Steps to set up the application
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Selecting an Analysis or Compliance Module

The RT-Eye application supports dedicated, technology-specific compliance
modules.

The application accepts Tektronix compliance modules for industry-specified
testing. These modules are available as options and require the RT-Eye software.
If the application does not detect a compliance module, only "Serial Analysis"
appears in the Modules drop-down list. If the application detects other
compliance modules, then multiple selections appear in the list.

The RT-Eye online help only discusses the "Serial Analysis" module operation.
However, the application also includes separate PDF files with Methods of
Implementation (MOI) for the InfiniBand and the PCI Express serial data
standards specific to the corresponding compliance module.

The Control Panel shows which module is active.

Selecting the Analysis Module

View the default Measurements Select menu.

| mModules  Measurem
FE-Dihih
InfiniBand
PCl Express
SAS
Serial ATA
Serial Analysis

Figure 33: Modules
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Selecting a Compliance Module

Note: The compliance module must be installed and enabled before you can
select it Compliance modules have static configurations and reporting formats
unique to a specific standard. In general, you can use these modules for design
verification and "Plug-Fest" testing.

File | Modules Measurements Flots
FB-Drlhdhd

InfiniBand

Results Log Liilities  Help

VO RT_Eye™ B X

= - Amplitude o e Jitter - - -
*
Differential [e- i Autoset
Waltage Emphasis T

Clear Results

Serial ATA

Serial Analysis High : T

TIE Jitter

TS Amplitude

=
. Canfigure
Amplitude Single Run ™

enu: Meas-=5elect

Figure 34: Selecting a compliance module

Choosing the Probe Configuration

Two of the four typical probing configurations discussed in Connecting to a
Device Under Test use two channels to make up the differential serial data signal.
Additional measurements are also available with these probing configurations.
To set the probing configuration (or if you have two reference waveforms), select
Single-Ended as the Probe Type option. If the signal is probed differentially so
that the differential signal is delivered to the oscilloscope on a single channel,
select Differential as the Probe Type option.

44 RT-Eye ®Serial Compliance and Analysis Application



Operating Basics

Probe Type Definitions

Table 10. Probe type definitions

Differential* Displays source selections and measurements suitable for
true differential probing (single connection to scope).
Single-Ended | Displays source selections and measurements suitable for
pseudo-differential probing (two connections to scope, with
difference operation performed in software).

* The default Probe Type for the RT-Eye serial analysis application.

Selecting a Measurement

You can use the Measurements> Select menu to select measurements for the
application to take. The application takes all selected measurements.

This is the default menu when you start the application. You can also access the
menu by selecting Measurements> Select in the menu bar.

The measurements will vary depending on the type of probe selected as the Probe
Type option.

Autozet

Use the button to automatically set the Horizontal and Vertical scales
of the Sources and the corresponding reference voltage levels. Refer to Autoset
Button in Measurements Select menu.

o
BWTip Use the button as a short cut to the Plots> Select menu.

o
WTip Use the
menus.

button as a short cut to the Measurements> Configure

o _
¥Tip Use the button as a short cut to turn on all the available
Measurements instead of selecting one measurement at a time.
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Measurement Definitions

Table 11. Measurement definitions

Area \Option Description Units
Timing* Eye Width/ Eye Width is the measured minimum horizontal eye |[sorV
Eye Height opening at the middle reference level as shown in the
eye diagram.
Eye Height is the measured minimum vertical eye
opening at the Ul center as shown in the eye
diagram.
Rise Time** Time difference between when the Hi reference level |s
is crossed and the Lo reference level is crossed on
the rising edge of the waveform.
Fall Time** Time difference between when the Hi reference level |s
is crossed and the Lo reference level is crossed on
the falling edge of the waveform.
Unit Interval Cycle duration of the recovered clock. s
Bit Rate Inverse of Unit Interval. Gbl/s
Differential Time delay between two single ended waveform s
Skewt sources.
Amplitude Differential Statistics for a differential waveform. \%
Voltage**
High Histogram mode of all differential waveform values \%
Amplitude greater than zero.
Low Amplitude | Histogram mode of all differential waveform values \Y
less than zero.
CM Voltaget | Statistics of the Common Mode voltage waveform. \%
AC CM AC statistics of the Common Mode voltage \%
Voltaget waveform.
De-Emphasis | Ration of any non-transition eye-voltage to its nearest | dB
preceding transition eye voltage.
Jitter* Jitter @ BER | Deterministic and random components of jitter. S
TIE Jitter Measured time difference between a data edge and a|s
recovered clock edge.
* Use the Time Units option (Results menu) to convert and display the results as Unit Interval.
** Use the File Preferences menu to restrict measurements to transition bits only.
t Added when Single Ended is the Probe Type option.
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Measurements: Select Menu for Differential Probes

Note: This is the default menu that appears when you start the RT-Eye
application.

File Modules Measurements Plots Results Log  Utilities Help EOURT.Be™ % X

Frobe Type Drifferential

-------------- Timing -------------- oo Amplitude -eeeeeeee e

Eye Widths Unit Differential Jitter Autoset
Ewe Height Intenral Waltage Emphasis i® BER
Rise Bit Rat High TIE Jitt
Time TR amplitude et
- -
. ali Configure
Time Amplitude Single Run

enu; Meas-=5elect

Figure 35: Measurement selections for differential probe

Measurements: Select Menu for Single-Ended Probes

Note: The application adds measurements when Single-Ended is selected as the
Probe Type option: Differential Skew, CM Voltage, and AC CM Voltage.

File Maodules Measurements Flots Results Log Utilities Help

KON RT.Eye B x

Frobe Type Single Ended -
-------------- Timing -------w------ ceeeeee- Amplitude -eeeeeeee e

Eve Wridths Unit Diffarential Jitter Autaset
Eve Height Intenral Waltage Waltage i BEFR

Clear Results

Rise = Rt High AL Ch 13 : qnn
Time RSN amplitude N voltage e lots
Dlﬁerentlal rl-l1l:“jE
: oli . ; Caonfigure
Time Sham Amplitude Emphasis Single Run

enu: Meas-=5elect

Figure 36: Measurement selections for single-ended probe
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Autoset Button in the Measurements Select Menu

Autoset

Select the button in the Measurements> Select menu to automatically
set the vertical scale, horizontal resolution, and reference voltage levels for all
active sources. Depending on the settings in the File> Preferences menu, either
the autoset operation will occur immediately or the application will display the
Autoset Summary menu and wait for you to choose the next action.

The Autoset Summary menu shows the current source autoset and reference level
autoset values and parameters in a brief outline view. No autoset operation is
performed until you select

Autoset

the command button.

HTip Use the BSMMEEEN button as a short cut to the Measurements™> Configure
menus.

Autoset Summary Menu Options

Table 12. Autoset summary menu options
Option/function Description

Autoset Performs the Source Autoset and the Ref Levels Autoset
functions; values update accordingly.

Configure Accesses the Configure Ref Levels menu.

Close Discards changes and closes the menu.

Do not show this | Defines whether or not the application displays the Autoset

menu again* Summary menu every time you select the Autoset
command button in the Measurements>Select menu.

*If set, usethe File Preferences menu to display the Autoset Summary menu.
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Autoset Summary Menu Example

_lojx

[ Dot : = BORLE AHain

Figure 37: Autoset Summary
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Configuring a Measurement

About Configuring a Measurement

Measurements may or may not require configuration. A quick way to configure
measurements is to select the Autoset button in the Measurements Select menu.

Corfigure

o
HWTip Use the button from the Measurements> Select menu as a short
cut to the Configure menus.

The application includes the following Configure menus:

Source | Ref Lewels Smart Gating  Clock Recoveny  Jitter Population  General Config

®  Source

®  Reflevels

"  Smart Gating

" (Clock Recovery
" litter

®  Population

®  General Confi
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Table 13. Configure Menu definitions

Source*

Configure Menu Definitions

Specify the source of the measurement as a channel (live) or
reference waveform, or a File; you can use the Autoset
functions (only for live sources) to change the vertical scale
or horizontal resolution of the waveform.

The automatic Vertical Scale function ensures that the entire
waveform occupies the full vertical space available in the
graticule.

The automatic Horizontal Resolution function ensures that
there are enough samples for accurate results.

Ref Levels

Set the reference voltage levels for the thresholds of the
rising and the falling edges as an absolute value

The automatic function sets the thresholds relative to the
minimum and maximum levels of the peak-to-peak values;
default percentages are 20% and 80%.

Smart Gating

Sets a gated region: Cursor gating, Smart Gating (Custom),
or no gating at all (Off).

Clock Sets clock recovery to an industry standard method: PLL

Recovery Standard BW, PLL User BW, Constant Clock Mean, or
Constant Clock Median.

Jitter Defines the analysis method, data pattern, and Bit Error Rate

threshold for Jitter@BER measurements. These parameters
are not required for TIE Jitter measurements.

Population**

Sets the required population for each measurement or
specifies the number of acquisitions.

General
Config

Sets whether Rise/Fall and Amplitude measurements are
limited to transition bits or performed for all bits. Enables
logging of worst case waveforms obtained during scan mode
in the waveform files directory.

* All sources must have the same Horizontal Sample Rate, Record Length, and
Position to assure that measurements function properly.

** In Free Run mode, sequencing stops when the population limit is met.
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Sources

About Configuring the Sources

The application takes measurements from waveforms or files specified as input
sources. You can select an oscilloscope channel input (live), a reference
waveform, or a saved waveform file as the source. The selections available for
Source Type depend on the Probe Type selected in the Measurements> Select
menu.

ol
HTip Use the M button as a short cut to the Measurements Select menu.

View the Configure Source menu for Differential probes

View the Configure Source menu for Single-Ended probes
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Configure Source Menu Options for a Differential Probe

Note: Differential probes do not provide common mode voltage components.

Table 14. Configure source menu for a differential probe
Area Option Description

Source Type |Live/Ref Lists channel or reference waveforms

for the Select Differential option.
File* Recalls the input from a single .csv or

.wfm file; enables the Select File area.

Select Ch1l, Ch2,Ch3,Ch4, |Use a channelor reference waveform

Differential* |Refl, Ref2, Ref3, Ref4 |from which to take Vp e
measurements.

Autosett Vertical Scale Sets the display of the waveform to the

full screen vertically based on the
amplitude of the source; the Peak-
Peak of the waveform is 80% of the
ADC full scale.

Horizontal Resolution |Sets the time base parameters to the
necessary horizontal resolution and
record length to ensure accurate
results.

Vertical & Horizontal Sets the vertical scale and the
horizontal resolution.

*Use the Browser to select a Differential File.

** Uses adifferential mode waveform as the source when Differential is the Probe
Type option. You can use a Math waveform, such as for a CH1-CH3 operation, if
you save the resultant waveform, recall the waveform to a reference memory
location (Refl, Ref2, Ref3, or Ref4), and then use the Ref waveform as a source.

T Only available for live (channel) waveforms.
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Configure Source Menu for Differential Probes

File Modules Measurements Plots Results Log  Utilities Help EQU pT. e ™ B X

Ref Le Smart Gating : r Jitter Population  General Confi

Source Type Select Autoset
LivelRoat E"""‘i"”'t'a' Vertical Horizantal (B verical &
Chi Scale Resolution Haorizontal

ferential =D+ - [- ode

Lemmonmade = (D Single Run ¥

enu: Meas->Config

Figure 38: Configure source menu for differential probes

Configure Source from a File for Differential Probes

File Modules Measurements Plots Results Log  Utilities Help KEOA Rt By ™ e

ce FefLewels Smart Gating Clock Re yw  Jitter Population  General Config

Source Type Select File

Live/Ret Differential File

Clear Results
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Single Run W
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Figure 39: Configure source from a file for differential probes
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Configure Source Menu Options for Single-Ended Probes

Note: You must use single-ended probes for common mode voltage

measurements.
Table 15. Configure source menu options for single-ended probes
Source Type Live Uses one of the following channel combinations
for the D+ and D- waveforms:
CH1, CH3
CH1, CH4
CH2, CH3
CH2, CH4
Ref Uses any combination of reference waveforms for
the D+ and D- waveforms.
File Enables the Select File area.
Select D+, D- | Selections are based on a Live or Ref Source Type option.
Autoset* Vertical Sets the display of each waveform to the full
Scale screen vertically based on the amplitude of the

source; the Peak-Peak of the waveform is 80% of
the ADC full scale.

Horizontal | Sets the time base parameters to the necessary
Resolution | horizontal resolution and record length to ensure
accurate results.

Vertical & |Sets the vertical scale and the horizontal
Horizontal |resolution.

Select Files** |Browse Recalls single-ended inputs from two .csv or .wfm
files, a D+ and D-.

*Only available for channel waveforms.

**Use the Browser to select the Differential File(s).
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Configure Source Menu for Single-Ended Probes

File Modules Measurements Plots Results Log  Utilities Help KEOU T Ry ™ B X

Smart <ating C w Jitter Population  &eneral Config

Source Type Select Autoset
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Figure 40: Configure source menu for single-ended probes

Configure Source from Ref Waveform for Single-Ended Probes

File Modules Measurements Plots Results Log  Utilities Help EOURT.Be™ B x

Source | Ref Lewels Smart Gating  Clock Re w  Jitter Population  General Config
Source Type Select
D+, [
Live
Refl, Ref2™
Clear Results
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Figure 41: Configure Source from Ref Waveform for Single-Ended Probes
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Configure Source from File for Single-Ended Probes

File Modules Measurements Plots Results Log  Utilities  Help EOU pT.Be™ B X
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Figure 42: Configure source from file for single-ended probes
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Autosetting Sources for Live (Channel) Waveforms

In most situations when you want to take measurements from a "live" (channel)
waveform, you can usually improve measurement accuracy by using the Autoset
options to optimize the vertical scale or horizontal resolution settings of the
oscilloscope.

To automatically define the vertical and horizontal settings for a source, follow
these steps:

1. Select Measurements> Configure> Source (or the [l tab).
. . LivelRef
2. For differential probes, select the | button.

g
3. For single-ended probes, select the ™ button.

4. In the Select area, choose the specific channel or channels that you are
using.

5. Select one of the Autoset area command buttons. Refer to the Configure
Source Menu Options for Single-Ended Probes topic for a description of
each option.

Note: The horizontal autoset in RT-Eye places the instrument in the maximum
sample rate available. If the 20-80% rise time of the signal is faster than 2X the
sample interval, interpolation is recommended to increase accuracy of rise time
and jitter measurements.
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Reference Voltage Levels

About Reference Voltage Levels

You need to set reference voltage levels so that the application can identify state
transitions on a waveform. Serial data timing measurements are based on state
transition times in waveforms. By definition, edges occur when a waveform
crosses specified reference voltage levels. There are two ways to set the reference
voltage levels: automatically and manually.

High, Mid, and Low Reference Voltage Levels
The application uses three reference voltage levels: High, Mid, and Low.

"  For most Time Interval and Jitter measurements, the application only uses
the Mid reference voltage level.

The Mid reference level defines when the waveform transition occurs at a given
threshold. For most NRZ AC coupled signals, you would set the Mid reference
level to Zero volts.

The Configure Ref Levels menu includes a "Mid = 0V" option which is set by
default. You can clear the check box to allow the Autoset function to calculate
the proper Mid reference level in the presence of common mode voltages
frequently encountered when using single-ended probes.

®  For Rise Time and Fall Time measurements, the High and Low reference
voltage levels define when the waveform is fully high or low.

Reference Voltage Levels Diagram

Hiah rd .:L\ 7

QP —=r—1F1y | L

P ] — {11 1
E g [}

Lo -..—-.; . LT

Figure 43: Reference voltage levels diagram

RT-Eye ® Serial Compliance and Analysis Application 59



Operating Basics

60

Rising Versus Falling Thresholds

The option to set separate thresholds for Rising edges vs Falling edges is
available in Ref Level Control panel, though the feature is not currently
implemented. The High, Mid and Low thresholds entered in the Rise column are
actually applied to both rising and falling edges. The values entered in the Fall
column are ignored.

Using the Hysteresis Option

The hysteresis option can prevent small amounts of noise in a waveform from
producing multiple threshold crossings. You can use a hysteresis when the rising
and falling thresholds for a given reference voltage level are set to the same
value.

The reference voltage level * the hysteresis value defines a voltage range that
must be fully crossed by the waveform for an edge event to occur. If the decision
threshold is crossed more than once before the waveform exits the hysteresis
band, the mean value of the first and last crossing times is used as the edge event
time.

For example, if the waveform rises through the Threshold - Hysteresis, then rises
through the Threshold, then falls through the Threshold, and then rises through
both the Threshold and the Threshold + Hysteresis, a single edge event occurs at
the mean value of the two rising crossings.

Example of Hysteresis on a Noisy Waveform

Threshold + Hysteresis == == === 3= = = — -

Threshold — — — — ===c

Threshold - Hysteresis — - — — &2 — - — — — — — -
Edge event tim e

— -+ Hysteresis

High —————
Mid ——— —} Hysteresis
Low — — —F— —F Hysteresis

Figure 44: Example of Hysteresis on a noisy waveform
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Cursor Gating and Reference Voltage Levels Autoset

You can use cursor gating with the reference voltage levels Autoset function. If
you enable and set up Cursors in the Configure Smart Gating menu, the
application uses the data within the gated region to automatically calculate the
reference voltage levels.

Configuring Reference Voltage Level Autoset

The Autoset Run button on the Ref Levels tab sets all reference voltage
thresholds and the hysteresis value to percentages of the base-top voltage
amplitude for the waveform. The Ref Level Autoset Setup menu allows you to
configure the percentages to define each threshold.
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Configuring Reference Voltage Autoset Percentages

The default Reference Level Autoset parameters should be appropriate for most
conditions, but you can adjust them for specific situations if you require different
behavior.

To configure the Ref Level Autoset Setup menu options, follow these steps:
1. Select Measurements> Configure> Ref Levels> Autoset Setup.

2. The Ref Level Autoset Setup menu appears. View the Ref Level Autoset
Setup menu.

3. For each reference voltage level you want to adjust, select the keypad icon
or multipurpose knob icon, and enter the percentage of the base to top span
of the waveform. The settings are based on the following definitions:

0% = mean(Veye y_rran (M)

100% = mean(Veye o rran (N))

4.  Select the OK button to update the values and close the Ref Level Autoset
Setup menu.

5. Select the Run command button in the Configure Ref Levels menu.

6. The application calculates the reference voltage levels based on the
percentages set in the Ref Level Autoset Setup menu.

7. If desired, you can manually refine the calculated values in the Configure>
Ref Levels menu to suit your analysis situation.
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Steps to Set the Reference Voltage Levels

Manual Eniny Automabc Calcwlation

File Modules Messuremenis Plois Results Log KA BT Fye

i Bman Gating Cleck Racewary Jiltar Fopulation Genaral Cenflg

Set Aeferenci: Level
Fa Ao

St Beferenos

1. Display the Ref Lavel Autoset Setup menu and
4. If necessarny, adjustvalues manually atjustvaluas
2, Belect OK 1o accept

3, Belect Run; the application caloulates refamnce
lewal values

Figure 45: Steps to set reference voltage levels
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Reference Level Autoset Setup Menu Options

Table 16. Reference level autoset setup menu options

Rise, High | Sets the high threshold level for the rising edge of the source.
Rise, Mid | Sets the middle threshold level for the rising edge of the source.
Rise, Low |Sets the low threshold level for the rising edge of the source.
Fall, High | Sets the high threshold level for the falling edge of the source.
Fall, Mid Sets the middle threshold level for the falling edge of the source.
Fall, Low Sets the low threshold level for the falling edge of the source.

Hysteresis | Sets the threshold margin to the reference level which the
voltage must cross to be recognized as changing; the margin is
the relative reference level plus or minus half the hysteresis; use
to filter out spurious events.

* Default settings are 80% (High), 50% (Mid), 20% (Low), and 3% (Hysteresis)
**\Where 0% = mean(vEYE.H|.TRAN(n)) and 100% = mean(vEYE.Lo.TRAN(n)).

Ref Level Autoset Setup Menu

& Ref Level Autoset Setup

Set Ref Level %o Relative to Base-Top
Rize High L5 Fall High & Hysteresis
200G L 200G L
Rize Mid L Fall Mid L

S0% S0%

Rize Low Fall Low

20% 20%

Figure 46: Reference level autoset set up menu

Manually Adjusting the Reference Voltage Levels

Whether or not you use the application to automatically calculate the reference
voltage levels, you may need to manually change the values. To set the reference
levels manually, follow these steps:

1. Select Measurements> Configure> Ref Levels> Source and choose a source
(channel or reference waveform) for which you want to set the reference
levels. If the Probe Type is differential, only one choice is available.

2. Inthe Set Reference Level area, adjust the values of the reference voltage
levels and the hysteresis. View the Configure Ref Levels menu.
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Table 17. Configure reference levels menu options
Area Option Description

Configure Ref Levels Menu Options

Source Differential | Selects the reference levels for the Differential
waveform or file.

DPlus* Selects the reference levels for the DPlus
waveform or file.

DMinus* Selects the reference levels for the DMinus
waveform or file.

Ref Level Setup Displays the Ref Level Autoset Setup menu.

Autoset Run Automatically calculates and sets the reference
levels according the settings in the Ref Level
Autoset Setup menu.

Set Reference | Rise, High | Sets the high threshold level, in volts, for both

Level rising and falling edges of the source waveform.

Rise, Mid | Sets the middle threshold level, in volts, for both
rising and falling edges of the source waveform.

Rise, Low | Sets the low threshold level, in volts, for the rising
and falling edges of the source waveform.

Fall, High |Reserved for future use.

Fall, Mid Reserved for future use.

Fall, Low |Reserved for future use.

Hysteresis | Sets the threshold margin, in volts, relative to the
reference level which the voltage must cross to
be recognized as changing; the margin is the
reference voltage level plus or minus half the
hysteresis; use to filter out spurious events.

Mid = OV** Set or clear | When checked, sets the middle threshold level to

0 Volts; when cleared (unchecked), sets the level
to the value calculated by the application.

* Only available when Single Ended is the Probe Type.

* Common mode voltages can be frequently found with single-ended probes.
Clear this option before you use the Reference Level Autoset function.

RT-Eye ® Serial Compliance and Analysis Application

65



Operating Basics
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Figure 47: Configure reference levels menu

Gating Measurements
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About Gated Measurements

Gating allows you to focus the analysis on a specific area of the waveform bound
by a gated region, which is a way to filter unnecessary information. To access the
Smart Gating menu, select Measurements> Configure> Smart Gating.

You can set up a gated region in one of the following ways:
®  Vertical Cursors
®  Smart Gating

The application uses the Smart Gating function when you select Smart Gating as
the Gating option. With Smart Gating, the application establishes a Clock
Recovery Window, part of the waveform on which the selected clock recovery
method is applied. An Analysis Window is the part of the waveform on which
measurements are taken and it is defined relative to the clock recovery window.
If you enable scanning, the clock recovery window (with its contained analysis
window) is scanned across the acquired waveform according to the scanning
parameters. In this case, the results from each scan increment contribute to the
population of measurements.

The population of measurement appears in the results panel and the associated
plots.
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Configure Smart Gating Menu Options

Table 18. Configure smart gating menu options

Option Description

Gating | Off No gating occurs; application takes measurements over
the entire waveform.

Cursors |Gates the waveform with Vertical cursors.

Smart Enables the Smart Gating function; refer to the Configure
Gating Gating Menu Options for Custom Gating topic.

Configure Smart Gating Menu with Gating Off

File Modules Measurements Plots Results Log  Utilities Help KO T Eye™ B %

Source  Ref Lewels Smart Gating | Clock Recovery  Jitter Population  &eneral Config

Aoy Gating Units | Unit Intervals

zating 5 an Incr

Len gth

) ® )
Cursars Length - Alignment

S Centared W%
— |
3 ating )
=L 3.5k ; ﬂ Lamz gz C 2zt Wrd c Single Run ™

Menu: Meas-=Config

Figure 48: Configure smart gating menu with gating off
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Configure Smart Gating Menu with Cursors Gating
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Figure 49: Configure smart gating menu with cursors gating
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Configure Smart Gating Menu Options for Smart Gating

Table 19. Configure smart gating menu options
Area Option Description

User Defined

Gating Units Unit Intervals | Gates the waveform by Unit Intervals.

Edges Gates the waveform by Edges.

Clock Recovery |[Length Number of Unit Intervals or Edges that defines
Window the size of the window over which the application
recovers the clock.

Start Specific Unit Interval or Edge within the record
where the application starts to recover the clock.

Stop Reports the Unit Interval or Edge on which the
application will stop the clock recovery.

Scan Incr Amount by which the Start and Stop values are
incremented for each new scan, if scan is
enabled.

#Scans Number of scans, if scanning is enabled and
scan-to-end is disabled.

Scan to End of | Causes scanning to repeat based on scan

Record increment, until the end of the record.

Enable Scan |Enables scan mode for the measurements.

Analysis Same as Enables or disables reusing the same settings for
Window Clock the Analysis Window as for the Clock Recovery

Recovery Window option.

Window

Alignment Centers the Analysis Window within the Clock

Centered Recovery Window.

Specifies the absolute position of the Analysis
Window within the Clock Recovery Window.

Length Number of Unit Intervals or Edges that defines
the size of the window.

Start Specific Unit Interval or Edge where the window
starts.

Stop Reports the Ul or Edge on which the window will

stop.
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Using Smart Gating

The Smart Gating control consists of a Clock Recovery (CR) window and an
Analysis window (Refer to the Smart Gating Diagram). The Clock Recovery and
Analysis window can be set to scan the waveform record. You can configure the
starting point and length of the CR window. The resulting Stop value (end point)
is calculated and displayed. You can also configure the scan increment. The
clock recovery method selected on the Clock Recovery tab will be applied to the
CR window to establish the reference clock edges for this portion of the
waveform.

The Analysis window is defined relative to the CR window using the Length and
Alignment controls. If the Alignment control is set to Custom, the Start control
defines where the Analysis window begins relative to the CR window. As a
convenience, you can select the "Same as Clock Recovery window" check box to
make the two windows coincide.

The following example shows how to apply a CR window of 3500 UI and an
analysis window of 250 UI, centered within the CR window:

In the CR window:
Start: 1, Length: 3.5k.

In the Analysis window:
Alignment: Centered

Length: 250

Configure Smart Gating Menu with Clock Recovery Window

File Modules Measurements Plots Results Log  Utilities Help KO RT.Eye™ B X

Clack w  Jitter Population  Feneral Config

Gating Units | Unit Intenvalzs ™

zating 5 Scan lner

Length
. * .
S Length - Alignment

. Cantered -
Stur.. e —
G ating :
=LAk 2.8k Er al . ﬂ Lame g5 T iy W Single Run ™

Menu: Meas-=Config

Figure 50: Configure smart gating menu with clock recovery window
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Configure Smart Gating Menu with Analysis Window
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Figure 51: Configure smart gating menu with analysis window
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Smart Gating Diagram
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Figure 52: Smart gating diagram
Clock Recovery Measurements
Clock Recovery Methods
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In serial data standards, jitter measurements are defined in several ways by
working standards groups. To make the Time Interval Error (TIE) measurement,
you need to first set the jitter reference clock (or ideal clock). All jitter
measurements are based on TIE. To comply with industry standards, the RT-Eye
application allows you to select various clock recovery methods, which can be
generally categorized as either Constant-Clock (mean-squared best fit straight
line) or PLL-based.

Whether the clock recovery method is PLL-based or not, you can specify a
nominal bit rate to help the clock recovery process. This is especially helpful, for
example, when the data pattern on the serial link can be interpreted as a different
pattern at a lower rate. A data pattern of 110011001100... at 5.0 Gb/s looks
exactly like a pattern of 101010... at 2.5 Gb/s. The application normally uses 2.5
Gb/s rate but you can also select the 5.0 Gb/s by enabling the Nominal data rate
control and setting the bit rate.
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About Constant (Straight-Line) Clock Recovery

Constant (straight line) Clock Recovery can be applied to the measurements by
selecting a Constant Clock Mean or Median method in the Clock Recovery tab.
In Constant Clock Recovery, the clock is assumed to be of the form A*sin
(2rnft+e), where the frequency (f) and phase (o) are treated as unknown constants.
Once a source waveform is acquired and the edges extracted, the clock frequency
is selected using linear regression, so that the recovered clock minimizes the
mean squared sum of the Time Interval Error (TIE) for that waveform.

If Constant Clock: Mean is selected as the clock recovery method, the phase @ is
also chosen to minimize the mean squared error. If Constant Clock: Median is
used, the phase is chosen so that the median error between the recovered and
measured edges is zero.

CC (linear regression)

t ©
EDGE—1—= = S oY - g— )

-HLU i*n

¥ o™t
" B & ™ CCLK
EST = | LI Index (n) i
. offsot Ao el ay
. -

*tCLK =UI*n + delay

Figure 53: Constant clock recovery diagram
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About PLL-based Clock Recovery

When PLL-based clock recovery is selected, the application simulates the
behavior of the hardware PLL clock recovery circuit. This is a feedback loop in
which the voltage-controlled oscillator (VCO) is used to track or follow slow
variations in the bit rate of the input waveform. Such loops are frequently used to
recover the clock in communication links that do not transmit the clock as a
separate signal. The PLL parameters in the application may be adjusted to
synchronize with the behavior of a receiver in such a link, with certain
guidelines.

EDGE —

Figure 54: PLL-based clock recovery diagram

PLL-based Clock Recovery Setup

If PLL-based clock recovery is selected, you can choose the loop bandwidth and
the loop order. If a second-order loop is chosen, you can specify the damping
factor. The loop bandwidth can be selected implicitly by specifying a data
communications standard, or it can be set explicitly.

To set the loop bandwidth automatically, based on a serial standard, select PLL:
Standard BW as the clock recovery method. From the Standard: b/s list box,
select the standard that matches your data link. For example, choose "PCI-E: 2.5"
to test a 2.5 Gbit/second PCI-Express link. The PLL bandwidth will be set to
1/1667 of the baud rate.

To manually control the loop bandwidth, select PLL: User BW as the clock
recovery method and use the User BW control to select the 3 dB bandwidth of
the loop, in Hertz.

You can use the PLL Order list box to choose between first-order and second-
order loop. More correctly, this is the loop type, where a type 1 loop has a
transfer function that approaches zero frequency with a slope of 1/s and a type 2
loop approaches zero frequency with a 1/s* slope. The term Order is used in the
application in line with popular usage. For a thorough discussion of loop type
versus order, see Frequency Synthesis by Phase Lock, by William Egan.
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If you choose a second-order loop, the Damping option is enabled. (The
Damping Factor does not apply to first-order loops.)

Note: Although it is possible to configure a second-order PLL with a bandwidth
as high as 1/10 of the baud rate, such a loop will have poor dynamic
performance. This is because second-order loops have less phase margin than
first-order loops.

Clock Recovery Menu Options

Table 20. Clock recovery menu options
Area Option Description

Clock Recovery Method Selects an industry standard clock
recovery method: Const Clk: Mean, Const
Clk: Median, PLL: Standard BW, or PLL:

User BW.
Nominal Data Rate | On/Off Enables or disables bit rate guidance to the
clock recovery algorithm.
Bit Rate Suggests the nominal bit rate. Helpful if

data rate is ambiguous due to the data
pattern (for example: “110011001100").

PLL Loop Bandwidth | Standard: b/s* | Implicitly sets the loop bandwidth of the
clock recovery PLL, based on selection of
the industry standard and data rate in
bits/second.

User BW** Explicitly sets the loop bandwidth of the
clock recovery PLL.

PLL PLL Order Selects between a first- or second-order
phase-locked loop.
Damping For only second-order loops, adjusts the

damping ratio of the loop.
* Only available when you use the PLL: Standard BW Method option.
** Only available when you use the PLL: User BW Method option.
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Configure Clock Recovery Menu
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Figure 55: Configure clock recovery menu

Jitter Measurements

Jitter Measurement Methods

The basic jitter measurement is the Time Interval Error (TIE) measurement. TIE
is a measure, on a cycle-by-cycle basis, of how far each edge differs in time from
where the edge ideally should have occurred. In this context, "Ideal" is
determined by the clock recovery method. Apart from choosing and configuring
the clock recovery method and reference levels, no specific setup is required for a
TIE jitter measurement.

The advanced form of jitter analysis is jitter separation, also known as Rj/Dj
analysis. This analysis breaks the timing jitter into various categories and uses
the results to predict the total jitter at a selected bit error rate (BER). The RT-Eye
application offers two methods of Rj/Dj analysis:

® A method based on spectral analysis that is appropriate for cyclic repeating
data patterns

® A method that works for any arbitrary data pattern
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Rj/Dj Analysis of Repeating Patterns Using a Spectral Approach

This method of Rj/Dj analysis uses a Fourier transform of the time-interval error
signal to identify and separate jitter components. It is described in the Fibre
Channel - Methodologies for Jitter and Signal Quality Specification (MJSQ) and
was the analysis method originally introduced with the RT-Eye application.

This method requires that the data signal be composed of a pattern of N bits that
are repeated over and over. The pattern length (N) must be known, although it is
not necessary to know the specific bits that make up the pattern.

RjDj Analysis of Arbitrary Pattern

When the data pattern is not repeating, or is unknown, a second method of Rj/Dj
analysis may be used. (It may also be used if the pattern is repeating, and
correlates well with the Spectral method in this case.) This method assumes that
the effects of Inter Symbol Interference (ISI) only last for a few bits. For
example, in a band-limited link where a string of ones follows a string of zeros,
the signal may require three or four bit periods to fully settle to the "high" state.

In this method, an analysis window with a width of K bits is slid along the
waveform. For each position of the window, the time interval error of the
rightmost bit in the window is stored, along with the K-1 bit pattern that preceded
it. After the window has been slid across all positions, it is possible to calculate
the component of the jitter that is correlated with each observed K-1 bit pattern,
by averaging together all the observed errors associated with that specific pattern.

In the configuration menu for the arbitrary-pattern method, the Window Length
field allows you to select how many bits are included in the sliding window. The
window should include enough bits to encompass the impulse response of the
system under test, usually 5 to 10 bits. A good practical test is to check whether
increasing the window length causes any appreciable change in the jitter results;
if not, the window length is effectively capturing all the ISI effects. The
disadvantage of increasing the window length is that it uses more memory and
slows the processing.

The configuration menu also includes a field for selecting what population of
each K-1 bit pattern must be accumulated before the TIE associated with that
pattern is considered accurate. Using a larger population means that more
observations are averaged together, so that the variance of the measurement is
reduced. Specifying a larger population has the disadvantage of requiring a
longer measurement period before results can be calculated.

It may be necessary to sequence the instrument several times before enough
statistics are accumulated to provide results.

The arbitrary pattern approach for measuring jitter may not be appropriate if
there are very-long-duration memory effects in your data link. An example would
be if there are impedance mismatch reflections that arrive long enough after the
initial edge to fall outside the analysis window.
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Configure Jitter Menu Options

Table 21. Configure jitter menu options
Option Description

Data Type Must be set to correspond to the
Pattern data pattern on the serial link. Use
Repeating for cyclically repeating
patterns, and Arbitrary for any data
content.

Pattern* Sets the repeating data pattern
length automatically for various
popular patterns.

Length* Sets the data pattern length
explicitly if the Pattern list box is
set to Custom.

Window Sets the number of history bits
Length** over which the effects of DDJ can
be monitored.

Population** Sets the required population of
observations of each DDJ pattern
that must be reached before the
TIE caused by that pattern is
deduced.

Rj/Dj BER=10-e? Sets the Bit Error Rate exponent,
thereby setting the statistical level
at which Total Jitter and Eye
Opening are reported.

* Only available when you use Type = Repeating.

** Only available when you use Type = Arbitrary.
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Configure Jitter menu for Repeating patterns
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Figure 56: Configure jitter menu for repeating patterns

Configure Jitter menu for Arbitrary patterns
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Figure 57: Configure jitter menu for arbitrary patterns
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Bathtub Curve: BER versus Decision Time

The Bathtub Curve plot shows the eye opening and total jitter values as functions
of the BER level. The plot is obtained from the Rj/Dj separation that is
automatically performed when a Jitter@BER measurement is executed.
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Figure 58: Bathtub Curve

Population for Measurements
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Setting the Population for the Measurements

The Population control allows you to limit the amount of waveform data that is
analyzed. This is often done in industry standards to make sure that there is
consistency between measurement techniques. You can use the Configure
Population menu to set a limit on a maximum population to obtain for all selected
measurements. View the Configure Population menu.

To define the maximum population for measurements, follow these steps:
1. Select Measurements> Configure> Population> On.

2. Select Limit By and choose a waveform characteristic on which to base the
population.

3. Select Limit and specify a population limit from one to one million.

If you use a population limit, Statistics individually accumulate for each
measurement that reports the Current acquisition statistic to the population limit.
A Free Run stops when all such active measurements reach the population limit.
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An acquisition population limit applies to all active measurements; statistics will
accumulate until the acquisition limit is reached.

You can use a population limit for a Single Run. If the limit is less than the
normal population for that Single Run then the measurement statistics will stop at
the limit.

Configure Population Menu Options

Table 22. Configure Population menu options
Area Option Description

Population Limit | On Enables or disables the application from using a
Off population limit while taking measurements.
Configure Limit By | Uses Acquisitions or Measurements to count
the population.
Limit Specifies the maximum number of Acquisitions
or Measurements the application takes before
sequencing stops.

Configure Population Menu
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Figure 59: Configure Population menu
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General Config

The General Config control allows you to set rise, fall, and amplitude
measurements either for transition bits or all bits. The transition bits refer to edge
transitions for which the preceding transition was only one unit interval away.
This may be important for signals with pre-emphasis, since the transition
following a string of two or more like bits has an intentionally low swing that
you may not want to measure.

You can also set the option to save maximum and minimum values of the worst
case waveforms obtained during scan mode to files in the waveforms directory.
File

Modules Measurements FPlots Results Log  Utilities Help EQU RT.Bye™ B x

Smart Zating Clock Re o ditter [Fapulation | eneral Config

Limit Fall measurements to transition bits anby

Limit Amplitude measurements to transition bits only

Enable worst-z ase logging while in scan mode
Single Run "W
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Figure 60: General config menu

Table 23. General config options
Option Description

Limit Rise/Fall Acquires and takes Rise Time/ False Time

measurements to transition | measurements only from transition bits; non-

bits transition bits are not acquired.

Limit Amplitude Acquires and takes amplitude measurements

Measurements to transition |only from transition bits; non-transition bits are

bits not acquired.

Enable worst case logging |Enables or disables saving the maximum and

while in scan mode minimum values of the worst case waveforms to
files for each source.
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Measurement Limits

About Using Measurements Limits File

Each serial data application provides a Limits file that includes combinations of
all measurements and statistical characteristics, and an appropriate range of
values for each combination. The application can use the Limits file and a mask
file to determine the Pass or Fail status for compliance tests.

To test against a Limits file, you need to enable measurements limits checking,
and enable a mask file in the Plots menus. View the Measurements Limits menu.

Creating a Measurements Limits File

You can use the Limits File Editor functions to create a Limits file. The editor
includes variable range options to suit your specific needs.

To create a Limits file, follow these steps:

1. Select Measurements> Limits.

M
2. Select - The Limits Editor window appears.

3. Select + The editor adds a measurement with None selected.

4. Inthe new row, select a Measurement, type of Statistic, a Lower Limit value
and an Upper Limit value as appropriate. View an example of a
Measurements Limits Editor window.

“alidate . A . L.
5. Select The application verifies that the limits for each

measurement are valid and that there are no duplicates.

Compact . 3
6. Select The application removes measurements where the

selection is None.

7. Select File> Show Summary. View an example of a Show Summary list
from the limits file.

¥

The next time you select the application compares the measurement
results against the Limits file and the mask file, and then displays the status as
Pass or Fail in the results menus.
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Editing a Measurements Limits File

You can use the Limits File Editor functions to edit an existing Limits file. To
edit a Limits file, follow these steps:

1. Select Measurements> Limits.

Current

2.  Select

and navigate to the directory where the Limits file resides.

3. Select a file, and then Open.

4. The selected file appears in the Limits Editor window.

5. Edit the file as necessary. To delete a measurement, select None.

Walidate
6. Select

The application verifies that the limits for each

measurement are valid and that there are no duplicates.

Compact

7. Select

to remove the rows where None is selected as the

measurement.

8.  Select File> Show Summary. View an example of a Show Summary list
from the limits file.

Measurements Limits Menu Options

Table 24. Measurement limit menu options
Area Option Description

Limits On Enables or disables the application from checking the
Off measurements limits; when enabled, the application

displays the results as Pass or Fail.

Limits File | Current | Edit the currently displayed Limits file.

Editor* New Create a new Limits file.

Limits File | Browse [|Locate the directory and select an existing Limits file;
you can use the virtual keyboard to enter a file name.

*Opens the Limits File Editor wind ow.
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Measurements Limits Menu
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Figure 61: Measurement Limits menu

Measurements Limits Editor Toolbar Functions

Table 25. Measurement limits editor toolbar functions
Tool/option Description

@ New Opens a new file.

Open Opens an existing file.

Add Adds a measurement and associated limits.
Clear All Deletes all measurements.

Measurements Limits Editor Menu Options

Table 26. Measurement limits editor menu options
Tool/option Description

Compact Removes measurements where None is selected.

Validate Verifies that limits are valid, such as an upper limit cannot be
lower than a corresponding lower limit.

Save As Opens a Save File dialog box.

Cancel Discards changes and closes the Limits Editor window.
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Measurements Limits Editor Menu
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Figure 62: Measurement limits menu
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Measurements Limits File Summary
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Figure 63: Measurement limits file summary
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User Masks

About Using Standard Masks

You can use masks based on serial data standards for compliance testing of
DUTs.

Industry standard masks are available from the file browser in the Plots
Configure menu (for an Eye Diagram plot). The mask files are selected from the
following directory:

C:/TekApplications/tdsrt-eye/Examples/Masks
The standards supported are as follows:
®  InfiniBand
®  PCI Express
®  Ethernet (Including XAUI)
" 1394B
®  Fibre Channel
®" FB-DIMM
" Serial ATA
" SAS (Serial Attached SCSI)

®  Serial Rapid IO

You can edit a mask file to create a custom user mask through one of the
following methods:

B Using the User Mask File Editor available in the Mask menu (if enabled) in
your oscilloscope

®  Manually using a text editor
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Using the User Mask File Editor

To edit a mask file with the User Mask File Editor of the oscilloscope, follow
these steps:

1.
2.

From the menu bar of the oscilloscope, select Masks> Mask Edit Setup.

Select the Recall button and navigate to the following directory:
C:\TekApplications\tdsrt-eye\modules\Serial Analysis\masks

Recall the user.msk file.

Follow the instructions in the online help of the oscilloscope to edit and save
the file.
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Mask File in the Oscilloscope Mask Editor
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Figure 64: Mask file in oscilloscope mask editor
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Import of User Mask
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Manually Editing a Mask File

If you do not have a Mask Editor available in your oscilloscope, you can use a
text editor to manually edit a mask file.

The User Mask File Opened in a Text Editor diagram shows an .msk file revised
using the Mask Editor in a TDS7000 series oscilloscope. The diagram shows the
fields used by the RT-Eye application in red boxes.

Note: The application ignores all other fields. The mask file must contain SEG1,
SEG2, and SEGS3 fields for proper operation.

To change the geometry of the mask, use a text editor to edit the following fields:

Table 27. Mask fields
MASK: USER: WID Defines unit interval.
MASK: USER: SEG1: POINTS |Defines 1% segment vertices in X,Y coordinates.

MASK: USER: SEG2: POINTS |Defines 2" segment vertices in X,Y
coordinates.

MASK: USER: SEG3: POINTS |Defines 3" segment vertices in X,Y coordinates.
*Where the X coordinate is in time (ps) and the Y coordinate is in amplitude (V).
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User Mask File Opened in a Text Editor

This diagram shows the fields used by the RT-Eye application in red boxes. You

can edit these fields to change the geometry of the mask.

& MyMask.msk - Notepad -10| x|
File Edit Format Help
IMASK D USER :AaMP 600, OD0O0E-3; |

:MASK USER 1 PATTERMNEITS 1;

tMASK :USER:PRESAMPEITS 0F
TMASE t USER twWID 400, OUOUE—1L23]
TMASKE : USER :HSCA Ge. GU0UE-12;
IMASK :USER :HTRIGPOS 500.0000E-3;
:MASK :USER:LAE "IBA 2.5GhbSs TP&";
(MASK tUSER :TRIGTOSAMF 0. 0000;
tMASE :USER IRECO 5000;

:MASK USER:VSCA 266, 0000E-3;
tMASK tUSER:1WPOS 0. 0000;

:MASEK :USER 1VOFFS 0. 0000;

IMASK tUSER:EITR 2. 5000E+9;

tMASK :USER:SERIALTRIG NRZ;

TMASK DUSERISEGLIPOINTS
LO000E-12,1.0640,-200,0000E-12,1. 0640,
TMASK DUSERISEGZ IPOINTS

60, 0000E-12,175.0000E-3;

TMASK DUSERISEGS IPOINTS

2,-B00,0001E-3,-200. 0000E-12, -B0O0, 0001E-3,;
PMASE DALUTOSET i STANDARD INFZ_5GE;

200. D000E-12 , 800, 0001E-5, 200, 0000E-12, 800, 0001E-3, 20

120, 0000E-12,0.0000,-60. 0000E-12, 175, 0000E-3, 0. 0000
=175, 0000E-3,120, 0000E-12, 0.0000, 0, 0000,175, 0000E-53,

200, 0000E-12,-1. 0640, 200, 0000E-12, 1. 0640, 200, 0000E

Figure 66: User mask file opened in text editor
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Creating a New User Mask File

If need be, you can create a new User Mask file using a text editor. This is an
alternative to editing an existing mask. To do so, follow these steps:

1. Create a new file using a text editor.
2. Enter User Mask information.
3. Save as a .msk file.

4. Recall the file in the Plots Configure menu.

Mask File Edited Using a Text Editor Example

i} MynewMask.msk.txt - Notepad =10 x|

File Edit Format Help

|:MaSK :USER :WID 400.0000E-12; |
IMASK DUSER:LAE "My New Mask";

IMASK IUSER:SEGL i POINTS

-200. 0000E-12, 800. 0001E-3, 200, 0O000E-12, 300, 0001E
-3, 200, 0000E-12,1. 0040, 200, 0000E-12,1., 064 0;
IMASK IUSER:SEGZ tPOINTS
-120.0000E-12, 0. 0000, -60. 0000E-12, -175. 0000E-3, 0
L0000, -1F5, 0000E-3,120. 0000E-12, 0. 0000, O, 0000, 17
5. 0000E-3, -60.0000E-12,175. 0000E-3;

IMASK :USER:SEGS tPOINTS

-200. 0000E-12, 1. 06840, 200, 0000E-12, -1. 0840, 200. 0
O00E-12, -B00. 0001E-3, -200. 0000E-12, -800. 0001E-3;
IMASK :AUTOSET : STANDARD INFZ_5GE;

Figure 67: Mask file edited using a text editor

Recalling a User Mask in the Plots Configure Menu

To recall a User Mask file to the RT-Eye application, follow these steps:

1. From the menu bar of the RT-Eye application, select Plots> Configure.
2. Select On in the Mask area.

3. Select User as the Standard option.
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Taking Measurements

About Taking Measurements

If you want to change trigger settings or localize the measurement, you should do
so before you take any measurements.

Note: If you select a reference waveform as the source, you need to recall and
display the waveform on the oscilloscope before the application can take a
measurement. To do so, refer to recalling a waveform file.

Note: If an error message appears because there are not enough cycles from
which to take a measurement, adjust the Horizontal setting on the oscilloscope to
increase cycles.

Localizing Measurements

By specifying the trigger position, the starting point, and the length of the
waveform, you can effectively filter out information that is not useful to analyze
before taking a measurement.

To focus the application measurement on a part of the waveform, you can use the
Configure Smart Gating menu. You can also adjust the Record Length, Scale, or
pre-trigger information in the oscilloscope Horizontal menu, or the trigger level
and slope in the Trigger menu.

You can also set up the File Preferences menu for the application to use only
transition bits.

About Sequencing

You use the Control Panel to start or stop the sequence of processes for the
application and oscilloscope to acquire information from a waveform. The
application then determines if the algorithm for the selected measurement can be
applied to the waveform information. Sequencing is the steps to acquire
waveform information, determine if the information is usable for the
measurement, take the measurement, and display the results.

There are three Sequencing modes: Single Run, Single No Acq, and Free Run.
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Acquiring Data

To acquire data from waveforms and take measurements, follow these steps:

1. In the Control Panel (on the right side of the application display), select a
Sequence mode.

2. The application uses the Sequence mode to acquire waveforms and take
measurements when you select the Start command button. The choices are:

Single Ru

3. Select the

Free Run, and Single No Acq.

F

button for continuous acquisitions or for measurements

on a new or existing acquisition.

4. Ifyou select the Single Run or the Single No Acq mode, the application
displays the results when the sequencing is complete.

If you select the Free Run mode or decide to stop sequencing,

select the

Stop button to stop the sequencing.

In Free Run mode, the sequencing also stops once the application has reached the
limit set in the Configure Population menu.

Note: The application displays a status bar when it is busy sequencing. The
status at the bottom of the Control Panel indicates Ready when the sequencing is
complete. It may also indicate Stopping before indicating Ready.

o 1n-
BWTip Use the J command button to delete all measurement results.
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Control Panel Functions

Table 28. Control panel functions
Command button Description

Start Start command button; use to start the sequencing based
on the selected Sequence Mode.

Stop Stop command button; use to stop the sequencing.

Clear Results Clear Results command button; use to clear all previous

results in the Results Summary menu, Results Details
menu, Plot Summary window, and Plot Details window;
data saved to files remains intact (.csv, .wfm files, etc).

Sequence Mode Option Definitions

Table 29. Sequence mode option definitions

Single Run Acquires a new waveform if the source is Chl, Ch2, Ch3, or
Cha4; for all sources, the application sequences until complete
and displays the results or plots (if set up).

Single No Acq |Recalculates the selected measurements without acquiring
new data and displays the results or plots (if setup).

Free Run* Continuously acquires waveforms and sequences until you
select the Stop command button.

*Sequencing stops when the sequencing reaches the population limit; plots
display (if set up and enabled) when you select Stop.

Chunking/Scan mode behavior of Eye Plot

In this mode, the waveform is analyzed from the Start value to the Stop value
configured in Smart Gating tab. The number of scans depends upon the scan
increment and size of the window values. For example, if an eye diagram is
selected, then the eye diagram plot keeps updating with new result for each
window.
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Figure 68: Scan mode behavior of eye plot

The RT-Eye application can be configured in different modes and the results vary
accordingly. The modes are:

®  Single shot, scan mode off
®  Single shot, scan mode on
®  Free run, scan mode on

®  Free run, scan mode off
Single shot, Scan mode off

The application acquires and analyzes the entire waveform and then holds with
the analyzed waveform on the oscilloscope display. The entire waveform (or the
gated portion of the waveform, if cursor or smart gating is employed) is analyzed
and the result is displayed in a single shot. For example, if an eye diagram is
selected, then each data bit in the gated portion of the waveform appears in the
center of the eye diagram exactly one time.
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Single shot, Scan mode on

The application acquires and retains the entire waveform, and then analyzes the
configured scan windows. After each scan window is analyzed, the results for
that window are added to the cumulative results and the eye diagram, if
displayed, accumulates the eye results from the latest window with all prior
windows. Depending on the gating and scanning parameters, some bits in the
waveform may not be analyzed or some may be analyzed two or more times. An
option is available to select worst case results, in which case, the worst of all the
scan windows analyzed is shown. An option is available to select worst case
results in which case the worst of all the scan windows analyzed is shown.

Free run, Scan mode off

The application acquires the waveform, analyzes it, accumulates the results with
any existing results, and refreshes all plots. The cycle repeats immediately. This
continues until the Stop button is clicked or the population limit is reached.

Free run, Scan mode on

The application acquires the waveform and performs one analysis cycle on each
scan window, thus updating the results and plots after each scan window. Once
the configured number of scan windows has been analyzed, a new waveform is
acquired and the measurement cycle is repeated. This continues until the Stop
button is clicked or the population limit is reached.

RT-Eye ® Serial Compliance and Analysis Application 99



Operating Basics

Control Panel
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Figure 69: Control Panel

About the Results

There are two ways to view the results after an analysis is complete: statistical
values or graphical plots.

If you enable the plots before taking measurements, the application shows the
selected plots in a separate window in the oscilloscope part of the display. The
application shows statistics in the application part of the display. When you use a
Limits Module, the application also shows the results as Pass or Fail.
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Statistical Results

About Viewing Statistics

There are two ways to view the statistical results of measurements: Results
Summary Menu and Results Details Menu.

Viewing Statistics

To view measurement statistics, select the Results Summary or the Results
Details menu. The application displays results for the measurements of all
acquisitions or for the current acquisition.

The Results Summary menu shows the current data and all acquisition data for
each statistical value.

The Results Details menu contains statistical values for the following
characteristics:

®  Population

®  Mean

®  Standard deviation (StdDev)
®  Maximum (Max)

®  Minimum (Min)

"  Pk-Pk

See the Results Summary menu for an example of the tabular listing of statistics
of selected measurements.

See the Results Details menu for an example of details of selected measurements.
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Results Summary Menu Options

Table 30. Result summary menu options
Option Description

Select View Bases the results summary on All Stats or Limits Status*.
(Table)
Measurement |Lists selected measurements.
Mean Lists a statistical value for the mean characteristic.
Min Lists a statistical value for the minimum characteristic.
Max Lists a statistical value for the maximum characteristic.
Pk-Pk Lists a statistical value for the peak-to-peak characteristic.
Status Displays if the measurement is Pass or Fail.
Show Plot Updates and displays the Plot window, if enabled.
Export to CSV | Displays the Export to CSV file dialog where you can locate
a suitable directory and enter an appropriate file name.
Details Shortcut to the Results Details menu.
Time Units Displays results in Unit Intervals, seconds, or the natural unit
for the measurement, such as mV.

* Only available when you enable measurement limits.

Results Summary Menu

File Modules Measurements Plots Results Log  Ukilities  Help FOURT.Eve™ | x|
Serial Anahlssis

Shovwr Flot Start Stop

fMezsuremeant e *|e-Pk: Status
Eye Height S04.04 S04.05m 0.0 ’ .

Ewe= Height: M-T Bit=
Clear Results

e o

Time Units Mode

Unit Interval ¥ Smgl= Fim

enu: Results-->5um... |Hint: You can see the Summary of the results.

Figure 70: Results summary menu
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Results Details Menu Options

Table 31. Results details menu options

Select View Displays details for the measurement selected as this
option.
Show Plot Displays the Plot window if enabled.

Export to CSV Displays the Export to CSV file dialog where you can locate
a suitable directory and enter an appropriate file name.

Summary Shortcut to the Results Summary menu.

Time Units Displays results based on Unit Intervals seconds, or the
natural unit for the measurement, such as mV.

Results Details Menu

File Maodules Measurements Ploks Results Log  Uklities  Help FOU RT v ™ Lol
Serial Anahysis

Result Detailz: Select Measurement Eye Height

: Start Stop
T ] . i Im Status

Height, Mezn S04 .05 ™

Clear Results

Surnmary 1

Time Units Mode

Unit Interval ™ Single Run ™

enu:Resulis-=Details |Hint: You can see the detailed results here

Figure 71: Results details menu
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Saving Statistics to a .CSV File

You can save the statistics to a "comma separated variable" file to import into a
text editor, a spreadsheet, or an analysis tool. View the Results Summary menu
or the Results Details menu.

To save the results summary or details to a "comma separated variable" (.csv)
file, follow these steps:

1. Select either Results menu.

2. For the Results Details menu, select the measurement whose details you
want to save from the Results Details Select View drop-down list.

3. For the Results Summary menu, Limits Status is only available if you
enabled measurement limits before taking measurements.

4. Set the Time Units option to Seconds or to Unit Interval. To save both types
of information, you need to save two .csv files.

5. Select the button. The Save browser opens.
6. Enter a file name. The application appends the .csv suffix to the name.
7. Select the Save button to save the file.

" [fthe oscilloscope is connected to a network, you can use the Explorer
to move the file.

" [fthe oscilloscope is not connected to a network, you can copy the file
to a floppy disk.
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Plotting the Results

About Plotting

The application can display the results as two-dimensional plots for easier
analysis. Before you take measurements, you can set up the Plots Select and Plots
Configure menus to define up to four plots. When enabled, the plots will display
when the application completes sequencing.

The application uses MATLAB-based windows to display plots.

Note: When taking measurements in the Free Run mode, you must stop the
sequencing before you use the Plots Select or Plots Configure menus.

Note: Be sure to configure a printer before you print a plot.
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Plot Type Definitions

Table 32. Plot type definitions

Eye Diagram | Represents data for the eye diagram based on the recovered
clock as the timing reference; used for mask testing.
Waveform Represents the acquired waveform. It is available for use with
with Bit Error | eye diagram mask tests to locate bit errors in the real-time
Locator waveform.

Histogram Represents measurements sorted by value as a distribution of
measurement values versus the number of times the value

occurred.

Spectrum Represents the frequency content computed using the FFT of
the Time Trend plot.

Bathtub Represents the Bit Error Rate versus the jitter eye opening for

measurements that include Rj/Dj analysis.

Measurements and Available Plots

Note: Measurements not listed are unsuitable for plots (Unit Interval,
Differential Skew, Differential Voltage, High Amplitude, Low Amplitude, CM
Voltage, and AC CM Voltage).

Table 33. Measurement and available plots

Measurement Eye Diagram Histogram Spectrum Bathtub Waveform
Eye Width/ Yes No No No Yes
Eye Height

Rise Time No Yes No No No
Fall Time No Yes No No No
Unit Interval No Yes No No No
Bit Rate No Yes No No No
Differential Skew |No Yes No No No
Differential No Yes No No No
Amplitude

De-Emphasis No Yes No No No
Jitter@BER No No No Yes No
TIE Jitter No Yes Yes No No
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Plot Window Layouts

1 Plat 2 Plats 4 Plaots

Figure 72: Plot window layouts

Eye Diagram Plot Usage

The clock recovery used for Real-Time Eye (RT-Eye) rendering is software
based. The ideal clock (jitter reference clock) is recovered from the serial bit
stream. The actual locations of the rising and falling edges of the acquired
waveform are then "rendered" with respect to the recovered clock, creating an
eye diagram. The clock is recovered from a single waveform acquisition which
means that trigger jitter is eliminated from the eye diagram.

If you use a CSA7000 series or a TDS6000/7000 series oscilloscope with Option
SM, hardware (HW) clock recovery is also available through the Masks menu in
the oscilloscope application. The HW clock recovery is based on phase-locked
loop (PLL).

Eye diagrams created using HW PLL are called Equivalent Time (ET) eye
diagrams and are susceptible to trigger jitter. The ET Eye diagram is useful as a
first check of signal quality and for debug purposes. RT-Eye rendering provides
high precision "de-jittered" eye diagram with a very small Jitter Noise Floor
(JNF) required for compliance testing.
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RT-Eye (Real Time) Rendering
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Figure 73: RT-Eye rendering
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ET-Eye (Equivalent Time) Rendering
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Figure 74: ET-Eye rendering
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Usage of Waveform with Bit Error Locator

You can find eye diagram mask failures on waveforms using the Bit Error
Locator feature. The white on the mask shows waveform mask violations. The
same violations can also be seen on pulse plot. The pulse plot shows the acquired
waveform data similar to the oscilloscope screen. You can correlate the failures
between the Eye Diagram and the waveform by looking at the red violations.
From the waveform plot, and whether it failed on the rising or falling edge of the
sample. This technique is useful for discovering data dependent behavior that
may be causing bit errors. The waveform plot can be used in conjunction with the
oscilloscopes waveform displays to time correlate failures due to crosstalk or
power supply noise. For instance, Ch2 can be used to acquire the suspected
offender signal and it can be compared to the serial data signal acquired on Chl
for time correlation.
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Figure 75: Waveform with bit error locator
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Histogram Plot Usage

Histogram plots display the results such that the horizontal axis represents the
measurement values and the vertical axis represents the number of times that the
value occurred. Unlike any other plot, a histogram plot accumulates
measurements over multiple acquisitions, up to a total population size of 2.1
billion.

Histograms are particularly useful in analyzing jitter. A histogram of the Time
Interval Error (TIE) represents the basis of jitter analysis using a histogram
approach. In a histogram, Deterministic Jitter (Dj) is bounded in a system and
shows up as a non-gaussian distribution. Random Jitter (Rj) is unbounded and
amplitude will continue to grow the more population is acquired. The TIE
histogram is a good first look analysis of jitter.

Spectrum Plot Usage

A spectrum plot is the Fourier transform of measurement values versus time.
This plot is useful in identifying frequency components that contribute to timing
errors, such as modulation of the measurements. An example of where this is
useful is plotting a "Jitter Spectrum". Jitter Spectrum is the FFT of the trend of
time interval error. This reveals the frequency components of the output jitter.

Further analysis on the Jitter Spectrum can be used to separate Random Jitter (Rj)
from Deterministic Jitter (Dj) as well as separate Dj components of Periodic Jitter
(Pj) and other Dj components such as ISI and DCD. The frequency of periodic
jitter spikes that do not correlate to frequencies contained in the data pattern can
be a clue that you should look at frequencies of different components in your
design as possible sources of jitter.
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Bathtub Plot Usage

Bathtub curves are the industry standard way of viewing the Jitter Eye Opening.
A Bathtub curve represents a plot of the eye opening versus the BER (Bit Error
Ratio). Most 8B/10B encoded copper standards call for Total Jitter to be
measured at 10> BER. The eye opening represented by the Bathtub Curve is
what is left of the unit interval after the total jitter measurement is subtracted. A
detailed discussion of bathtub analysis can be found in the MJSQ document at

www.tl1.org.

The Jitter Eye opening and the Total Jitter have the following relationship:

Total Jitter + Jitter Eye Opening = 1 Unit Interval

Selecting and Configuring Plots

Selecting Plots for Configuration
Before you take measurements, you can set up plots in the Plots Select menu.
To select a plot to configure, follow these steps:

1. Select Plots>Select.

2. Select the On button.

3. Select a measurement in the Select Measurement column.

4. Select a plot type in the Select Subplot column.

o
BWTip Use the
menu.

button as a short cut to the Measurements> Select

112 RT-Eye ®Serial Compliance and Analysis Application



Operating Basics

Plots Select Menu Options

Table 34. Plot select menu options

Select Measurement | Select an active measurement to plot.
Subplot Plot Type Select the type of plot to depict.
Plots Display | On Enables or disables the display of plots.
Off
Plots Refresh Updates the plot window when you deselect a
plot or when you reselect a plot.

Plots: Select Menu

Help KON R7_pve™ | x|

‘Configure Serial Anakysis

File  Modules Measuremenks  Ploks  Results  Log  Ukilikizs

Select Subplot Start Stop
I Measurement I Plot Type A LAy s

Exe Width - Eye Dizgram
Clear Results

MHorne bl MHorne

Ao

Mare 7 Mare

Hare - Hore ens Mode

Single Run W

ﬁenu: Plots-=Select Hint: Select desired plot for the selected measurements

Figure 76: Plots select menu
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Configuring Plots

After you select the plots, you can further configure each measurement and plot
combination. The options are relative to the selected plot type in the Subplot
column.

To configure a plot, follow these steps:

7.

Coarfi =
Select the Iaakii=kl tab.
Select a measurement in the Select Measurement column.

Select a plot type in the Select Subplot column. Plot options depend on the
type of selected plot.

For the Eye Diagram plot, masks are available for many standards and you
can create your own custom designed mask. For more information on User
masks, refer to the About Using User Masks topic.

Configure the plot.
Select the tab.
Refraesh
Select the command button.

The Plot Summary Window updates and displays the selected plots. View an
example of the Plot Summary Window.
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Plots Configure Menu Options for an Eye Diagram

Note: For more information, refer to Eye Diagram Plot Usage.

Table 35. Plots configure menu options for an eye diagram
Area Option Description

Bit Type |Transition Renders an Eye Diagram only for transition bits.
Non Transition | Renders an Eye Diagram only for nontransition
bits.
All Renders an Eye Diagram for all bits.
Mask On Enables or disables the display and mask testing.
Off
Standard Specifies a User-defined* mask or a mask based
on a serial data standard, such as InfiniBand or
PCI Express.
Type** Selects a type of mask specific to the selected
standard; See list (receivers, cables, test points).
* Browse for a mask file to import from the tdsrt-eye/Examples/Masks directory.
** Available when you select a serial data standard as the Standard option.

Plots Configure Menu for an Eye Diagram

Note: For more information, refer to Eye Diagram Plot Usage.

File Modules Measurements FPlots Results Log Utilities Help EQU RT.Bye™ B X

act [ Configura

Configure

e asurement Subplot

Clear Results
Mane

gt

Nane

HNone | ases\P Cl ExpressiPCETxThit.msk bode

Single Run

enu: Plots-=Config

Figure 77: Plots configure menu for an eye diagram
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Plots Configure Menu Options for a Histogram

Note: For more information, refer to Histogram Plot Usage.

Figure 36. Plots configure menu options for a histogram
Option Description
Vertical Axis Sets the vertical axis in a linear scale (default) or in a

logarithmic scale.
Bin Resolution | Defines resolution by time.

Plots Configure Menu for a Histogram

Note: For more information, refer to Histogram Plot Usage.

File Modules Measurements Ploks Results Log  Lkilities  Help FOU RT.Eve™ B x|
: orfonre | Serial Analysis
Select Configure Start Stop

SUrE mer Subplot Vertical Axis Bin

MNome

wlas

Resolution % Clear Results

2480 PREETS

.l

None Log
Hore Mode

Single Run W

ﬁenu: Plots-=Select Hint: Select desired plot for the selected measurements

Figure 78: Plots configure menu for a histogram
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Plots Configure Menu Options for a Spectrum

Note: For more information, refer to Spectrum Plot Usage.

Table 37. Plots configure menu options for a spectrum
Option Description

Vert. Scale | Depicts the vertical axis in a linear scale (default) or in a
logarithmic scale.

Horiz. Scale |Depicts the horizontal axis in a linear scale (default) or in a
logarithmic scale.

Plots Configure Menu for a Spectrum

Note: For more information, refer to Spectrum Plot Usage.

File Modules Measurements Plobs  Results Log  Utilities  Help FOURT.Eve™ | ¥

"Configure Serial Anakysis

Select Configure Start Stop

Vert. Scale Horiz. Scale

L

None
Liong Laog

Nome Mode

Single Run ™

ﬁenu: Plots-=Select Hint: Select desired plot for the selected measurements

Figure 79: Plots configure menu for a spectrum
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Plots Configure Menu Option for a Bathtub

Note: For more information, refer to Bathtub Plot Usage.

Table 38. Plots configure menu option for a bathtub

Option  Description

Scale Depicts both axes in logarithmic scale (default) or in linear scale.

Plots Configure Menu for a Bathtub

Note: For more information, refer to Bathtub Plot Usage.

File Modules Measurements Plots Results Log  Ukilities  Help FOURT.Eve™ | x|

Configure Serial Analysis

Select Configure : Stop

Subplot Scale

|
Cur...

Clear Results
LDQ 1 gt

Mome MﬂdE

Single Run ™

MNome

ﬁenu: Plots-=Select Hint: Select desired plot for the selected measurements

Figure 80: Plots configure menu option for a bathtub
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Viewing Plots

About Viewing Plots

There are two windows you can use to view and analyze plots: Plot Summary
and Plot Details. The application includes tools to help you size and position the
window, display either window, and display the details of another plot directly
from the details window.

¥*

After you select and configure a plot, select the command button. When
sequencing is complete, the Plot Summary Window appears with up to four plots.
View an example of a Plot Summary Window.

If you reconfigure a plot and want to view the updated plot, follow these steps:

1. Select the button.

Refresh
2. Select the command button.

The plots window updates according to any changes you made to the Plots Select
or Plots Configure menus.

The Plot Details tools represent the plots by quadrant in the Plot Summary
Window. View Show Plot Details tools. For example,

you can select the & tool to display details for the plot in the upper left quarter
of the Plot Summary window. View an example of a Plot Details Window.

i
¥Tip If you have a keyboard, you can use the alt-tab Window shortcut to quickly
select a window for viewing.

o . .

WTip Ifyou have a second monitor, you can select and drag the title bar of the
y y g

plot window to position it in the other monitor.
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Using a Separate Monitor to View Plots

If your oscilloscope setup includes a second monitor that extends the Windows
desktop, you can select and drag the title bar of the plot window to position it in
the second monitor. This allows you to simultaneously display a waveform on
the oscilloscope, the RT-Eye measurement results, and the plot for easy viewing.

Toolbar Functions in Plot Windows
The Plot Summary window includes the following toolbar:
HESE MO EE BF S
The Plot Details window includes the following toolbar:
EETR= AR AR AR

Some functions are specific to the Plot Summary window and others are specific
to the Plot Details window. The next table lists the available functions in each
type of plot window.

Table 39. Plot details window options
Tool icon Function Summary Details

HEEZ 222w

EH & Save Yes Yes
=1 Print Yes Yes
B F 51 [ | View Details Yes No
= & Size and position window | Yes Yes
&/ ® 2 m: |Zoom No Yes
E=ETs Cursors No Yes
i Grid No Yes
B Return to Summary No Yes
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Plot Summary Window Example

This plot window includes save, print, view details, and size and position
window functions.

} RT-Eye Plot Summary =10 x|

HEE AEHAER EF S

100 |13

Figure 81: Plot summary window
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Plot Details Window Example

This plot window includes save, print, zoom, cursors, grid, view summary, and
size and position window functions.

-[0x|
HEE 28 2w x| o B F &

Vert Cursor
t,: -138.3ps
t,: 133.3ps

At: 291.7 ps

Horiz Cursor
"-J’1 : 406.8mY
"-J’z: 385.5mv
AV 0.7923V

-200ps -100p= Op= 100p= 400ps

Figure 82: Plot details window
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Plot Summary and Details Window Example

J RT-Eye Plot Summary =10 x|

HEE AEHAER EF S

-400ps -200ps Ops= 200ps 400ps

100

TIE Jitter
Hiztogram , hits

E|.

0
-100ps Ops= 100ps 05 ]

HEa| ®2a 8wz 7 &

Vert Cursor
ty: -232ps
t,: -138.3ps

At: 113.7 ps

Horiz Cursor
"-J’1 : A8.8myY

"-J’z: 235.3mv
AV: 0.4841V

-100ps Op= 400ps

Figure 83: Plot summary and details window example
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Viewing a Plot in the Whole Display or in Half the Display

You can change the plot size to the whole display of the oscilloscope, or to half
the display. When viewing a plot in half the display, you can position the plot in
the upper or lower half.

u enlarges the plot to fill the entire display

=
T reduces the plot to half the display, if need be, and positions it in the
upper half

+
1 reduces the plot to half the display, if need be, and positions it in the
lower half

Returning to the Plot Summary Window

'
To return to the Plot Summary window, select the BH tool.
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Using Zoom and Cursors in a Plot

You can use the zoom and the cursors functions simultaneously in the Plot
Details window. To do so, follow these steps:

B Select the '@ tool and draw a box around the area bound with the cursors.
B Use the cursors to take measurements.

" Repeat the previous steps if need be. You can zoom in by a magnification of
20X.

" Select the ™= and the W tools to display the horizontal and the vertical
Cursors.

" Move the cursors to bound the area you want to view more closely.
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Removing Plots

To remove a plot from a plot window, follow these steps:
1. Select Plots> Select.

2. Select None for the measurement in the Select Measurement column.

Refrezh
3. Select the command button.

The plot window updates and does not display the deselected plot.

Using Zoom in a Plot

About Using Zoom in a Plot

Once you have created a plot, you can use the Zoom tools in either plot window
to examine the data at various scales. View the Plot Zoom tools.

o
¥Tip You can quickly restore the view to display all the data. To do so, select
the W% tool.

T . . .
¥Tip If you prefer to move the cursors in the plot window with your finger, you
can activate the Touch Screen on the oscilloscope.

Plot Zoom Definitions

Table 40. Plot zoom definitions

Zoom type Description

& n Expands part of the plot; the data appears in more detail.

2 out Contracts part of the plot; the data appears in less detail.

2 v axis Expands the horizontal axis only and retains the vertical axis.
= 100% Restores the plot to display all the data.
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Changing the Scale of Data in a Plot (Zoom)

To change the scale of the data in a Plot Details window, select one of the
following plot zoom tools:

- A zooms in to expand the scale

u *@ zooms out to contract the scale

. 2

zooms in to expand the horizontal axis only

= W% 7650ms in to restore all the data

When you select the e tool, you can use a select-drag-release action to expand
part of the waveform (zoom in) by an arbitrary amount on both axes. After you
select (touch with a finger or click with the mouse) and begin dragging, a
bounding box shows what part of the waveform will be expanded upon release.

Select any part of the plot to expand the data by a factor of two (2X) equally on
both axes. Double selecting expands the data to the maximum factor.

To contract an expanded part of the data (zoom out), select anywhere on the data.
The view contracts to the values that existed before the most recent expansion of
the data. Selecting multiple times will restore successively earlier views.

To expand the scale of the horizontal axis only by a factor of two (2X), click a
part of the waveform. The plot retains the scale of the vertical axis.

- . . .
¥Tip You can quickly restore the view to the entire waveform. To do so, select
the W% tool.
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Using Cursors in a Plot

About Using Cursors in a Plot

Cursors allow you to view numerical values associated with a plot based on
cursor locations. There are two cursor modes: Horizontal-paired and Vertical-
paired. Each mode displays two cursors. View the Plot Cursor tools.

Plot Cursors Definitions

Table 41. Plot cursors definitions

Cursors type

= Horizontal

Description

Displays the vertical coordinate where each cursor touches
the plot and the difference (delta) between the cursors.

W Vertical

Displays the horizontal coordinate where each cursor
touches the plot and the difference (delta) between the
Cursors.

= Reset

Brings the cursors into the visible part of the plot.

128

Using Cursors in a Plot

You can use cursors to read the coordinate where each cursor (line) touches the
plot and also view the difference (delta) between the two cursors.

To use cursors in the Plot Details window, follow these steps:
1. Select one of the following cursor tools:

a. ™ to use Horizontal cursors

b. W' to use Vertical cursors

C. = to bring the cursors into the visible plot

2. Select and drag either cursor to move the cursor to the desired part of the
plot.

The cursor readout changes value to reflect the cursor position.

Note: You can drag cursors only when the Zoom functions are disabled.

G . . .
¥Tip If you prefer to move the cursors in the plot window with your finger, you
can activate the Touch Screen on the oscilloscope.

RT-Eye ®Serial Compliance and Analysis Application



Operating Basics

Using Grid Points in a Plot

To display or remove cursor points in a Plot Details window,

select the i tool. Grids are not available in eye diagrams.

Horizontal and Vertical Cursors in a Plot Example

=101 x|
HEE 28 2w x| o B F &

Vert Cursor
t,: -138.3ps
t,: 133.3ps

At: 291.7 ps

Horiz Cursor
"-J’1 : 406.8mY
"-J’z: 385.5mv

400p= AV 0.7923V

Figure 84: Horizontal and vertical cursors in a plot example
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Saving Plots to Files

About Saving Plot Files

Both plot windows include the save plot file tools. However, the contents of
saved plot files are dependent on the type of plot window: Summary or Detail.
View the Save Plot to a file command buttons.

Save Plot Files Definitions

Table 42. Save plot files definitions

File type Description
|E Graphic Saves the contents of the plot window in the format you select
from the list.

& pata Saves the contents of the plot window as a binary .fig file.

Saving Plot Files
To save a plot file, follow these steps:
1. Set up the plot window.

2. Select one of the following save plot file tools:
u | & o save the plot as graphic file

010
" el to save a data file
3. Select the B™*=2 button to select a directory and then enter a file name.

4. Selectthe 22  button to save the plot file. The application saves the
file.
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Printing Plots

About Printing Plots
To send a plot to a printer, follow these steps:
1. Verify that a printer is configured.

2. Set up the plot window (with the zoom, cursor, or grid points functions).

3. Select the Pl tool.

4. The Plot Print dialog appears. View the Plot Print Preview window.

5.  Select the LI button and set up the options.

6. To customize the print of the plot, select the ml tool.

7. The Page Setup menu that is a part of the MATLAB software appears. View
the Page Setup window

Note: The online help topics for the RT-Eye application do NOT describe how to
use the MATLAB Page Setup menu. Refer to the MATLAB documentation for
more information.

Select the Print button to print the plot file. If you selected Print

Brovwse

to File, use the button to select a directory and then enter a file name.
The application saves the file.
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Plot Print Preview Window

J Print Preview - RT-Eye Plot Details

Frint... |F'age Setup...l Zoom |n | oo DLt | Cloze |

Figure 85: Plot print preview window
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Plot Page Setup Window

Page Setup - RT-Eye Plot Summary ﬂ

Size and Position | Paper | Lines and Text | Axes and Figure |

~Mode
" lge screen =ize, centered on page

&+ se manual size and position

~hanual size and positian
Sampk

Top: ||:|.|:u:| 3:
Llge defaults

Left: ||:|.25 3: [OF
Fill page

Width: .00

L L

Fix aspect ratio

Height: |a.|:u:| i’

Unita:linches LI

Center

Qi Cancel

Figure 86: Plot page setup window

Logging Worst Case Waveforms

Saving Worst Case Waveforms from a Live Source

You can use the Log Worst Case menus to save the acquired waveforms
whenever a selected measurement exceeds the highest or lowest prior value.
When enabled, the waveforms are saved to a set of .wfm files.

The application also exports the contents of the files to a worstcasetable.csv file
located in the Log directory.

To log worst case waveforms, follow these steps:

1. Select Log> Worst Case> Configure.

o
2. Select the " button to enable logging.

Erowrse

3. Select the button to select a directory.
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¥

4, Select the command button in the Control Panel.

5. The application saves the waveforms with the worst case maximum and
minimum values for all selected measurements in the
tdsrteye\modules\Serial Analysis\waveforms directory.

ot
6. To disable logging, select the button.

P
Note: Use the ki button to delete all the .wfm files in the selected

directory.

Log Worst Case Configure Options

Table 43. Log worst case configure options
Option Description

Log Enables or disables saving the maximum and minimum
values of the worst case waveforms to files for each
source.

Choose Directory |Browse to select the directory in which to save the
waveforms when the log worst case waveforms function is
enabled.

Purge Deletes all waveform files from the selected directory.
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Log: Worst Case Configure Menu

File Modules Measuremenks Plots Results Log  Ukiities  Help FOURT.Eve™ | x|

|.m.|::-:-r|fi!;| “File Narmes Sl A rlinsts

Worst Case Waveforms Start Stop

Log Loqg Directory
Select i‘.’
n “ 5] Eimekapplicationstdsrt-eyeimod. Clear Results

Purge the log files in the selected directory 100

Mode

Single Run W

enu: Log->Worst Case |Hint: Turn Worst Case logging OniOff. Specify directory if heeded

Figure 87: Log worst case waveform menu

File Names of Worst Case Waveforms

The application automatically names the files for you. The file names include the
following information:

" Type of measurement
®  Whether the file is a maximum or minimum value waveform
®  Date and time that the file was saved

File names appear after sequencing is complete and measurement results display.

Log: Worst Case File Names Menu

File Modules Measurements Ploks Resulks  Log  Uklities  Help EOA BT o Th E]Ll
|""'|::.:.r.fi!;| T — Serial Analysis
Start Stop

Clear Results

Mode

Single Run ™

ﬁenu: Log-=Worst Case | Hint: Find the Worst Case file nhames for selected measurements

Figure 88: Log worst case file name menu
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Generating a Report

About Generating a Report

You can use the Report Generator utility to customize and generate a compliance
report to view later or to share with others. The utility is independent from the
RT-Eye application, yet is accessible from the application.

Note: The utility yields a .rpt file that can be viewed only from the Report
Generator. You can select to export to an .rtf format file.

Report Generator File Directories

Table 44. Report generator file directories
Directory Description
Reports Default location where the utility stores reports.

Templates | Each .rgt template file defines the contents and layout of one
page in the report; you can use existing page templates, edit
templates or create new templates.

Layouts Each .rpl layout file defines all the pages (template files) to
include in a report; you can use an existing report layout, edit
layouts or create new layouts.
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Directory Structure for the Report Generator Utility

BN C:\ TekApplications' tdsrt-eye - | Ellil

File Edit ‘iew Faworites Tools  Help ﬁ

= Back - = - | Dhsearch | [ Folders £ | iy QE > | e

Address |_] :\Tekapplicationsitdsrt-eye j @G0
Folders X Mame £ | Size | Type
- bdsiita - [ JExamples File Folder
H-0 TOSIIT3ve (Jimages File Folder
-1 TDSPWRS (I Masks File Falder
E‘E tdsrt-eve Cmodules File Falder
: &1 Examples [ IreportGenerator File Falder
-1 images temp File Folder
{:| Masks 2| warnings OKE Text Docu
{:I modules
{:I ReportGensrator
=] Tpsusez
&[] TekScope

D Tekkronix 1.

{:I Temp

-0

@ vasu-fbd

r\-l wBiook al ﬂ I _.’I
|? object(s) (Disk free space: 725 ME) |I:I bytes |@. Iy Computer o

Figure 89: Directory structure for the report generator utility
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Starting the Report Generator and Accessing the Online Help

The online help for the Report Generator utility contains all the information you
need to design and produce compliance report files. To start the report generator
utility from the RT-Eye application and access the online help, follow these

steps:

1. Select Utilities> Reports.

2. Select the Define Test Template or the Define Report Layout tab.

3. Select the command button.

4. From the menu bar in the Report Generator window, select Help> Help

Topics. The Help system for the utility appears.

You can refer to the online help topics for the Report Generator utility for
information on how to do the following tasks:

Use an existing test template or report layout
Edit an existing test template or report layout
Create a new test template or report layout

Add Fields: Native, Oscilloscope, Serial Analysis
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Setting Up a Test Template and Layout for a Report

The Report Generator utility allows you to design the contents and layout of a
report that reflects your unique needs. In addition to a predefined template for
each page, there is also a predefined report that includes all the predefined pages.
Generating and Printing a Report

To generate and print a report, follow these steps:

1. Select Utility> Reports.

2. Select the Mk

Do not touch the screen. Wait while the Report Generator creates the report. The
oscilloscope fills the display while the application takes a screen print. When
complete, the oscilloscope display shrinks to half size and automatically the RT-
Eye application reappears.

The report displays when it is complete. You may need to use the Alt+Tab key
combination to bring the Report Generator window to the front.

3. Youneed to save the report to retain the file. To save the report, select File>
Save from the menu bar of the Report Viewer. The report file is in a .rpt
format and can only be viewed with the Report Viewer.

Later, you can use the Browse and View buttons in the Generate Report menu to
open your saved report file.

4.  To use a different file, edit a file, or create a new report layout (or test
template) file, refer to the Report Generator online help.

5. To print the report, first verify that a printer is configured from the
oscilloscope task bar.

6. From the Report Generator menu in the RT-Eye application,

Frirt
select the button.

You can also navigate to the saved file in the Report Generator window and send
the file to a printer without having to open the file in the Report Viewer. To share
a report with others, you may want to generate a smaller file. To do so, refer to
the Creating a PDF File of the Compliance Report topic.

7. To export the report as an .rtf file, select File> Export to RTF from the menu
bar of the Report Generator window. You can transfer the .rtf file to a
personal computer, and view or print the file from a word processing
program.

RT-Eye ® Serial Compliance and Analysis Application 139



Operating Basics

Acrobat Distiller

Feady

Caomment:

Creating a PDF File of the Compliance Report

You can send a report file to a "virtual" printer to create a smaller and more
portable PDF file of your compliance report. To create a PDF file, follow these
steps:

1. Verify that a distiller program (for example, Adobe Acrobat Distiller 6.0) is
configured from the oscilloscope task bar.

2. From the Report Generator menu in the RT-Eye application,

Frirt
select the button.

3. Select the Distiller from the Printer Name selection menu.

Pnnt Setup BEE

Orientation

Source; OnlyOne - J ® Landzcape

Figure 90: PDF creation of Compliance report

4.  Send the report to the distiller (select OK).

Printing
Feport

Figure 91: Print report status

140
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5. When the PDF file is complete, you can use other features of the distiller to
further enhance the report, such as add watermarks if available.

Test Template Menu

Note: Refer to the online help topics for the Report Generator utility for
information on how to create a new test template or on how to edit an existing
test template.

File Modules Measurements  Plots  Results Log  Ukiities  Help KA RT B ™™ E] HI
Report Generator

Serial Analysis
| Define Test Template [ Oefine Repart Layout |
Start Stop

. Clear Results
Edit Template

100

Mode

Single Run W

ﬁenu: Litil->Reports Hint: Design and generate the reports

Figure 92: Test template menu
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Report Layout Menu

Note: Refer to the online help topics for the Report Generator utility for
information on how to create a new report layout or how to edit an existing
report layout.

File Maodules Measurements Plaks Results Log  Utliies  Help FOART.Eve™ LGl
Report Generator Serial Analysis

|"'..Elefir|e Test Template “Define Report Layout
Start Stop

: Clear Resulis
Edit Layout

port SeneratoriLay ==.rpl

Ao

Mode

Single Run ™

ﬁenu: Liil->Reports Hint: Design and generate the reports

Figure 93: Report layout menu

Report Generate Menu Options

Table 45. Report Generator menu options
Option Description

Browse Select a directory in which to save the report file and enter a
file name; select a file for the template or layout and edit as
needed.

Generate Create a report.

View View a report.

Print Print a report.
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Report Generate Menu

File Modules Measurements Floks Resulks Log  Ukiities  Help FOART.Eve™ | x|
Report Generator Serial Analysis
|"".I:Iefine Test Termplate [ Define Report Layout [

Start Stop

L]
|_ -eye\Report Generatorilayouts'sa.

Clear Results

1nn

Mode

Single Run W

ﬁenu: Litil->Reports Hint: Design and generate the reports

Figure 94: Report generator menu

Report Generator Fields

You can use the fields in the report generator utility to customize the contents
and layout of a report. The utility has the following groups of fields:

" Oscilloscope
" Application

®  Native
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Application Fields General Information List

This is an example of the fields available for the general oscilloscope information
in the report.

ﬁ Template Editor - [SA_Pagel.rgt]
=l

Test Report for Serial

T ¥YYY

Figure 95: Application fields-general information
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Application Fields Configuration List and Ref Levels Example

This is an example of the fields available for the configuration information. This
example also shows the expanded list of fields available for the Ref Levels in the

report.

Senalhnalpsiz Fislds | 0zciloscope 1

General Information

Seralbnalysis Fields | Dsciloscope 4

Bl Ref Levels

El Serial Analyziz

Ref Level Autazet Source

& Configuration

Ref Level Autozet Setup

Rize High Ref Lewvel

Rize Mid Ref Level

[3 ating Rize Low Ref Level
Plots Fall High Ref Lewel
Source Fall Mid Ref Lewel

Ref Levels

Fall Low Ref Level

Jitter

Hysteresziz

Population

=l diter

Whorgt caze wavefarms

Clock Recovery bMethod

[Gating State

PLL Loop B - Standard...

Figure 96: Application Fields Configuration List and Ref Levels Example
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Application Fields Results List and Specific Measurements Example

This is an example of the fields available for the measurement results
information. This example also shows the expanded list of fields available for an
EyeWidth/Eye Height measurement and for a Rise Time measurement in the
report.
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Figure 97: Application Fields Results List and Specific Measurements Example
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Oscilloscope Fields and Native Fields Lists

This is an example of the fields available for the oscilloscope controls and other
miscellaneous features in the report, such as lines.
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Figure 98: Oscilloscope Fields and Native Fields Lists
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Introduction to the Tutorial

This tutorial teaches you how to set up the application, take measurements, and
view the results.

Before you begin the tutorial, you must do the following tasks:
" Set up the oscilloscope
" Start the Application

®  Recall the tutorial waveform

Note: The screen captures shown are from a TDS7000 oscilloscope; there may
be minor differences in the screens from other types of oscilloscopes.

Setting Up the Oscilloscope

To set up the oscilloscope, follow these steps:

1. In the oscilloscope menu bar, select File> Recall Default Setup to set the
oscilloscope to the default factory settings.

2. Press the individual CH1, CH2, CH3, and CH4 buttons as needed to remove
active waveforms from the display.

Starting the Application

In the oscilloscope menu bar, select File> Run Application> RT-Eye Serial
Compliance and Analysis.

The application starts up and displays the Measurements Select menu.

Waveform Files

The application includes a waveform file to use with this tutorial. The file is from
a PCE Express signal and is named RT-EyeTutorial. wfm.
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Recalling a Waveform File

To recall a waveform file, follow these steps:

1. In the oscilloscope menu bar, select File> Reference Waveforms> Reference
Setup. Refl is the default memory location to recall a waveform file.

2. Select the button for Recall Refl from File.

3. Navigate to the C:\TekApplications\ tds-rteye\examples\WFMs directory.

4. Select the RT-EyeTutorial.wfm file and then .

5. The oscilloscope recalls the waveform file to reference memory and
displays the waveform when the recall is complete.

6. To return to the application, select the [ﬁpp_i button in the oscilloscope
menu bar.
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Oscilloscope Reference Memory Setup Menu

File Edit YWertical
02 .Jul 03

Horiz/ Ao Trig Display  Cursors Measure  Masks  Math

Utlities  Help

Ref1 Position
0.0y

Refl Scale

FPefl 200wy

Save Wim to Refl

Position [® au
[ 3 -

0. 0diy m Save
Save Wim to File

Scale Manim
Ref1

Horz Pos
Oelete —
BI.0%,

Figure 99: Oscilloscope Reference memory set up menu
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Taking an Eye Width Measurement

In this lesson, you will learn how to use the application to take an Eye Width/Eye
Height measurement and view the results. This lesson teaches you how to do the
following tasks:

B Select a measurement

®  Configure a measurement

®  Take measurements

®  View the measurement results
®  View a Real-Time Eye diagram
®  Stop the application

®  Return to the application

To perform these lessons, the application must be installed and enabled on the
oscilloscope. See Installation.

Setting Up an Eye Width Measurement

To set up the application to take an Eye Width/Eye Height measurement, follow
these steps:

1. To set the application to default values, select File> Recall Default. The
tutorial uses the default measurement and probe type. The measurement
selections vary depending on the Probe Type option: Differential or Single
Ended.

2. Select the BN button.

3. The Configure Source menu appears with tabs for other Configure menus.

[ [ Jitter | [

4. Select Refl as the source. View the waveform recalled to Refl and selected
as the source.

E: ource

5.  Select the #ll tab. The Configure Ref Levels Menu appears.

Rurn
6. Select the command button. The application automatically

calculates the appropriate reference voltage level values. View the reference
voltage level values as calculated by the application.
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Refl Selected as the Source
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Figure 100: Refl as source
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Figure 101: Using autoset for reference voltage levels
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Taking a Measurement and Viewing as an Eye Diagram

The default setup for the application includes an Eye Diagram plot. To take
measurements and view the results as statistics and as a plot, follow these steps:

¥

1. Select the command button in the Control Panel. The application
displays a real-time eye diagram that shows the characteristics of the
waveform in a Plot Summary window.

2. You can view details of the results and details of the plot.
Ea.......
To do so, select the command button in the

Results Summary menu and the o in the Plot Summary window. View
the details of the results and of the Eye diagram plot.

3. You can use the Results Details: Select Measurement option to view details
of other measurements.

154 RT-Eye ®Serial Compliance and Analysis Application



Tutorial

Results Summary and Plots Summary Window Example
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Figure 102: Results summary and plots summary window example
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Results Details and Plot Details Window Example
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Figure 103: Results Details and Plot Details Window Example

Ending a Tutorial Lesson

If you need more than one session to complete the tutorial lessons, you can stop
the tutorial and return to it later. Refer to Stopping the Tutorial and Returning to
the Tutorial.

Note: The purpose of this tutorial is to familiarize you with the basic functions of
the application, menus, and steps you may need to take if the quick method does
not yield expected results.
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Stopping the Tutorial

If you need more than one session to complete the tutorial lessons, you can stop
the tutorial and return to it later.

To save the application setup and stop your session, refer to Saving a Setup File
and to Exiting the Application.

Returning to the Tutorial

To return to the tutorial setup, you can start the application and then recall the
saved setup. To recall the application setup, refer to Recalling a Saved Setup File.

Quick Method Concept

There is a quick method you can use to take measurements that may yield
reasonable results for your situation. The results from the quick method should
indicate whether or not the setup is adequate. If it is not, then you can set up the
application manually as shown in the first lesson.
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Quick Method to Take Measurements

You can use the quick method to take measurements from channel (live)
waveforms. To quickly take measurements, follow these steps:

6.

Start the application (also clears previous results), and make your Probe
Type and measurement selections in the Measurements> Select menu.

Select

In the Autoset Summary menu, select

. The Autoset Summary menu appears

Autoset

The application calculates

and applies appropriate settings for the vertical scale and horizontal
resolution of the source and values for the reference voltage levels.

If the values are acceptable, select

If need be, select
Configure Ref Levels menu.

Select the

Clase

Corfigure

to adjust the reference voltage levels in the

*

command button to take measurements.

When sequencing is complete, the application displays statistical results and a
real-time eye diagram that shows the characteristics of the waveform. View the
results of the Eve Width measurement as an Eye Diagram.
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Taking a TIE Jitter Measurement

In this lesson, you will learn how to use the application to take a TIE Jitter
measurement on the waveform already recalled to the Refl location. This lesson
teaches you how to do the following tasks:

B View the results as a Histogram, and a Spectrum plot
" Save statistical results to a .csv file
B View a .csv file with Wordpad or in a spreadsheet

®  Generate a simple report
Clearing Results
Before taking more measurements, be sure to clear the results.

PREFTY

To do so, select the command button in the Control Panel.

RT-Eye ® Serial Compliance and Analysis Application 159



Tutorial

160

Setting Up a TIE Jitter Measurement and Plots

To set up, take, and plot a TIE Jitter measurement, follow these steps:

1.
2.

Clear any previous results.

Select Measurements> Select and deselect the Eye Width/Eye Height
measurement (from the previous lesson). When you deselect a measurement,
the application discards the corresponding options in the Plots menus.

TIE .itter
Select the measurement. The vertical scale, horizontal resolution

and reference voltage levels were set for the source (Refl) in the previous
lesson.

Select the button.

In the Select Subplot table, select TIE Jitter in the Measurement column and
Histogram in the Plot Type

¥*

column. Select the command button. The application displays the
Results Summary menu and the Histogram plot. View the results of the TIE
Jitter measurement.

Select Plots> Select.

In the second row of the Select Subplot table, select TIE Jitter in the
Measurement column and Spectrum in the Plot Type column.

Refresh .
Select to update the plot window.
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TIE Jitter Results with Histogram Example
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Figure 104: TIE jitter results with Histogram example
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TIE Jitter Histogram and Spectrum Plot Example
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Figure 105: TIE Jitter Histogram and spectrum plot example
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Examples of Plot Details

Here are details from the plots in this lesson.
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Figure 106: Example of plot details
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Saving Statistical Results to a .CSV File

To save the statistical results to a .csv (comma separated variable) file, follow
these steps:

1. Select the command button. The Save dialog appears.

2. Use the 2% | command button to select a directory in which to save the

.csv file in.

3. Enter a file name and select Save

4.  Start the Wordpad program on the oscilloscope and select File> Open.

5. Navigate and select the file you just created. View the .csv file with
Wordpad.

6. Close the Wordpad program.

7. Copy the file to your PC, start a spreadsheet or other analysis program, and
open the .csv file. You can customize the results to suit your analysis needs.
View the .csv file as a spreadsheet.
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.CSV File Viewed with Wordpad Example

= EveaRistats. cov - WerdPad '
[Fe Edt View Inset Format Hen
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Figure 107:.CSV file viewed in wordpad

.CSV File Viewed in a Spreadsheet Example

@Ewﬁll!hh.csv
A B G ] E F
1 (A1 Stats |wied Jul 23 16:39:58 POT 2003
2 | Measurement Mean Min A Pk-Pk Status
3 | Eye Width OT9TIUL O.F97IUL O.F97U1 O.0000aUI
4 | Eya Height 503.63my S03.63my S03.63my 00000V
5 | Eye Hesght N-T Bits  503.63m\ 503.63my 503.63m 00000V
6 | Eye Height T Bits B39 85m\ B39 85m\ B3D.85m\ O D000
7

Figure 108:.CSV file viewed in spreadsheet

Generating a Simple Report

To generate a simple report, follow these steps:

1. Select Utilities> Report. The Report Generator menu appears and is set to
use the default Define Test Template and Define Report Layout definitions.

2. Select the command button.

3. The application generates and displays the report. View the simple report.

Prirt
4. To print the report, select the command button.

Note: Before the application can send the file to a printer, you need to check if
the printer is set up from the Start menu (in the oscilloscope task bar).
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Simple Report Example Page 1
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Figure 109: Simple report example Page 1
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Simple Report Example Page 2
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About the Serial Analysis Laboratory (Lab)

The Serial Analysis Laboratory presents a typical application example that
highlights the compliance and analysis capabilities of the RT-Eye application,
and will give you ideas on how to use the application to solve your own test
problems. This lab covers and explores the following areas:

B Using the Serial Data Wizard to perform serial analysis on a 2.5 Gb/s serial
bit stream

B Performing jitter measurements that are compliant to the T11.2 MJSQ using
the spectrum approach to jitter analysis

B Saving and using MyTest
B Creating Limits Module File for custom Compliance Test
®  Creating a Compliance Report

®  Performing a PCI Express Compliance test (PCI Express Compliance
Module required)

Note: To use this lab, you must have the RT-Eye application installed, enabled
and running on the oscilloscope. For information, see Installation and Starting
the application.

Requirements:

= TDS/CSA7000 series oscilloscope (1.5 GHz and above) or TDS6000 series
oscilloscope if you use a reference waveform.

Optionally, the Training Board 2 (P/N 020-2460-00) or Training Board 3 by
Tektronix. A minimum bandwidth of 4 GHz is required for a live signal.

®  RT-Eye Serial Data Compliance and Analysis software (Opt. RTE)

Note: If your oscilloscope setup includes a second monitor, you can select and
drag the title bar of the online help window to position it in the second monitor.
This allows you to simultaneously display these lab exercises in the second
monitor, the waveform (or a plot) on the oscilloscope, and the RT-Eye
measurement results for easy viewing.
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Recall Default Settings and Run RT-Eye SW

To ensure that your lab results match the results shown in these lab exercises,
you will recall the default settings to the oscilloscope and to the RT-Eye
application. To do so, follow these steps:

Push the DEFAULT SETUP front-panel button to start from a known setup.

From the oscilloscope application menu, select File> Run Application> RT-
Eye Serial Compliance and Analysis on non-B models, or Applications >
RT-Eye Serial Compliance and Analysis on B/C models

Will you be using a Reference Waveform File or a live signal from the Training
Board?

Reference Waveform File Setup

170

This lab uses a 2.5 Gb/s differential signal saved to

C:\TekApplications\tds-
rteye\modules\Serial Analysis\waveforms\examples\2 5Gbps PRBS.wfm.

You can recall the waveform to reference memory, view the waveform, and
analyze it with any RT-Eye compliance and analysis application. To recall the
waveform file to reference memory, follow these steps:

Click the DEFAULT SETUP button on the front panel.

Push the CH1 front-panel button to turn off the Channel 1 waveform Push
the CH1 front-panel button to turn off the Channel 1 waveform.

From the Oscilloscope application menu, select Reference Waveforms>
Recall Wfm

Select Recall Refl from Wfm File

Browse to and select:
C:\TekApplications\tdsrteye\modules\Serial Analysis\waveforms\examples\2
_5Gbps_PRBS.wfm as the waveform file.

Use the Zoom control to zoom in and view individual bits.

Select Measurement> Wizard, to run the Serial Data Wizard.
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Figure 111: Select measurement wizard

8. Make Wizard Selections as shown in the yellow text in the following figure.
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Setup Wizard

7. Select Plot Types

Crifferential

2. Measurement Sources
Ref1

3. Standards

PCLE:2.56

4. Measurement Categories ﬂ Spectrum (TIE Jitter)

ﬂ Bathtub Curve (Jitterf@BER

ﬂ Jditter Histogram (TIE Jitten

Figure 112: Plots selection

9. Proceed to Run the Analysis and View the Results.

Training Board 2 - Live Signal Source

You can use the Training Board 2 or Training Board 3 to work through these
exercises. To do so, use the 2.5 Gb/s PRBS signal. This signal has rise times of
<100 ps, and thus needs full sample rate (20 GS/s) to perform measurements
accurately. You can use the following configurations:

®  TDS7000 Series (TDS7404): Use P7380SMA with CH1 as the Differential
Source for Analysis.

®  TDS6000 Series: Use P7380SMA with CH1 as the Differential Source for
Analysis or Use TCA-SMA Adapters on CH1 and CH3 as Single-Ended
Sources for Analysis.
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Use P7380SMA with CH1 as the Differential Source for Analysis

1. Use the phase-matched SMA cables (provided with the P7380SMA probe)
to connect the positive and negative leg of the 2.5Gb/s signal on the training
board and CH 1 on the oscilloscope.

2. Connect the other end of the phase-matched cables to the "D+" and "D-"
connections of the P7380SMA probe input.

3. Connect the TekConnect end of the P7380SMA probe to CH1 of the
oscilloscope.

4. Push the AUTOSET front-panel button to view the differential signal.

5.  Select Measurement> Wizard, to run the Serial Data Wizard.
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Figure 113: Select Wizard

6. Make Wizard Selections as shown in the yellow text in the following figure.
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Setup Wizard

7. Select Plot Types

ﬂ Eve Diagram
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Figure 114: Plots

7. Proceed to Run the Analysis and View the Results.
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Use TCA-SMA Adapters on CH1 and CH3 as Single-Ended Sources for Analysis

1. Useal Meter SMA cable and TCA-SMA adapter to connect between "D+"
on the training board and CH1 on the oscilloscope.

2. Use another 1 Meter SMA cable and TCA-SMA adapter to connect between
"D-" on the training board and CH3 on the oscilloscope.

3. Push the CH3 vertical channel button to display Ch3.
4. Push the AUTOSET front-panel button to view both signals.

5. Adjust both Chl and Ch3 to 200 mV/div to get a better view of the
waveforms.

6. Select Measurement> Wizard to run the Serial Data Wizard.
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Figure 115: Measurement wizard screen

7. Make Wizard Selections as shown in the yellow text in the following figure.
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Setup Wizard
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Figure 116: Types of plots selected

8. Proceed to Run the Analysis and View the Results.
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Run the Analysis and View the Results

Run

1. Run the Analysis by clicking in the Wizard.

2. The result of the analysis is displayed as shown in the following figure.

=Tk
e BEAR EF

[ SN 5 e e

* 500

-400p=s 200p=z 200ps 400p=
200

FARLE

(10}
100

1]
-100ps 100p=

File Modules Measurements FPlots Results Log  LHilities Help

t Summany: L] All Stats

Show Plot Start Sto p

Measurement I hean I hdin Il 3
- & I:I .tl -I I : : LI I : E

Clear Results

Ewe H: Trans Bits
Rise Time

Aovn

Details

Fall Time -
Unit Intenval Time Units —

Bit R ate c 2 Unit Interral ™ Single Run ™

enu: Meas-=Select
Figure 117: Analysis results

Statistics of measurement results are shown in the lower half of the oscilloscope
display. The RT-Eye diagram and Mask are shown in the upper half of the
oscilloscope display. You can change the Time units from Uls to seconds
depending on what the standard calls for. The magenta dots in the Eye diagram
represent the recovered clock. The Eye diagram shows statistical representation
of the Eye diagram in an accumulated waveform database display. Multiple jitter
plots (the TIE Jitter Histogram, Spectrum, and Bathtub curve) are also displayed.
Click the Details button to view the details of each measurement.

3.  Proceed to MJSQ Jitter Analysis.
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MJSQ Jitter Analysis

This section describes how to perform jitter analysis compliant with the T11.2
MIJSQ methodology using the Spectrum Approach to Jitter Analysis. In the
previous section, the default method (Arbitrary Pattern) was used as the Jitter
method. To perform analysis consistent with T11.2 MJSQ "spectrum approach"”,
a repeating pattern is used. The signal being used in this lab is a 127 bit PRBS
repeating pattern. To change to the repeating pattern method, follow these steps:

1. Select Measurements> Configure> Jitter
2. Select Type> Repeating
3. Select Pattern> Custom

4. Input 127 Ul into the Pattern Length Control.
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Figure 118: Jitter
5. Click Clear Results.
6. Click Start to perform the Analysis.

7. Select Jitter (@ BER from the Results Details: Select Measurement pull-
down.
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J RT-Eye Plot Summary
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J RT-Eye Plot Summary
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Figure 120: Results details

The three views of Jitter and the measurements provide a good way to see how
Jitter measurements are made with the Spectrum Method of Rj/Dj separation.
The TIE Histogram (lower left plot) is the traditional way of measuring jitter on
an oscilloscope. This method is limited by the amount of statistical certainty that
can be achieved in a reasonable amount of time. Thus, more advanced DSP
methods are used to determine the Jitter Eye Opening, Total Jitter, Random Jitter,
and Deterministic Jitter.

The TIE measurements are transformed into the frequency domain by performing
an FFT on the raw TIE data, thus creating the jitter spectrum shown in the upper
right plot. The spikes in the frequency domain represent Deterministic jitter.
Further analysis can be done to determine which spikes are Duty Cycle
Distortion (DCD) or Data Dependent (DDJ-also known as ISI), and which are
Periodic (PJ). Once these values are removed (DJ), then what is left is a noise
floor which represents the Random Jitter (RJ). These values are used to create the
Cumulative Distribution Function (CDF), commonly known as the Bathtub
Curve, shown in the lower right hand plot. The magenta line at 10-12 BER
represents the Jitter Eye Opening measurement.

The following equation can be solved using the measurement results:

Jitter Eye Opening + Total Jitter = 1UI

8. Proceed to Using MyTest.
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Using MyTest

MyTest allows you to save your favorite test and run it automatically when you
start the application. For example, now that you have performed the MJSQ jitter
test, you can use the following procedure to save and run the MJSQ jitter test as

MyTest.

1. Select Measurements> Save MyTest

2. Select File> Exit

3. Select No when the dialog asks if you want to save oscilloscope settings.

4. Push the DEFAULT SETUP front-panel button to start from a known setup.
5. From the Oscilloscope application menu, select File> Run Application> RT-
Eye Serial Compliance and Analysis on non-B models, or Applications>

RT-Eye Serial Compliance and Analysis on B or C models.
6. After you launch the RT-Eye application, select Run Mytest from the

KX RT-Eye Welcome x|

welcome dialog box. In this example, the MJSQ test is run automatically.

Fun hiyTest

Cancel

ﬂ shou this dialog at startup

Figure 121: RT-Eye Welcome

The RT-Eye MyTest feature allows you to run your favorite test with a single
click.

Defining a Limits Module

This section demonstrates how to apply a limit to a measurement and create a
custom Pass/Fail condition on the TIE jitter measurement described in the
previous section.

1.
2.
3.

Select the Measurement> Limits menu.
Select New under Measurement Limits Editor.

Select TIE Jitter as the Measurement.
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4.  Select Min as Statistic and Enter —60ps for limit.
5. Select the + button to add a measurement limit.
6. Select TIE Jitter as the Measurement.

7. Select Max as Statistic and Enter +60ps for limit.

Figure 122: Measurement limits

8.  Click the Save As button.

9. Save file as Jitter.lim.

10. Close Limits Editor.

11. Select Limits> Browse.

12. Select Jitter as the Limits File.
13. Click Open.

14. Select Limits> On.

15. Return to Results> Details menu.
16. Click the Clear Results button.

17. Click the Start button.

Figure 123: Results details

18. The defined Pass/Fail status appears in the Status column of the Results
panel. Proceed to Creating a Compliance Report.
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Creating a Compliance Report

This section demonstrates how to create a compliance report based on the
previous analysis.

1.

Select Utilities> Reports.

Click Generate. The resulting report can be exported to an RTF file format
and read by other applications such as Microsoft Word. The report can also

be printed to a PDF file if a PDF distiller is installed on the instrument.
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Figure 124: Report in PDF format

3.
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PCI Express Compliance Tests

This section demonstrates how to perform a PCI Express Compliance Test. The
PCI Express module must be present to complete this part of the lab. If your
instrument does not have a PCI Express Compliance Module installed, proceed to
Serial Analysis Lab Conclusion.

1. Select Modules> PCI Express from the RT-Eye menu.
2. Click the Select Required button.
3. Select Test Point> Driver.

4. Select the correct Probe Type (Single Ended or Differential) depending on
your probe configuration.

5.  Click the Autoset button.
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Figure 125: PCl express compliance test

6. Click the Start Button.
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Figure 126: Results of PCI express Add in card compliance test

In this example, the signal under test fails the PCI Express compliance test. This
is because the PCI Express specification calls for 3-4dB of De-emphasis on the
nontransition bits (or pre-emphasis on transition bits). Since the signal does not
have the proper level of de-emphasis, it fails the transition bit mask. The number
of mask hits shows up in the compliance results as a mask failure.

7. Click the Clear Results button.
8. Return to the Measurement> Select menu.
9. Select Receiver as the Test Point.

10. Click the Select Required button.
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Figure 127: PCl express compliance test

11. Click the Start button.
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Figure 128: Results of PCI express compliance test
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In the PCI Express Receiver test, there is a single Receiver Mask. This test is
performed by probing a device close to the receiver pins of a SerDes. This signal
passes the receiver compliance test.

12. Proceed to Serial Analysis Lab Conclusion.
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Serial Analysis Lab Conclusion

Congratulations! You have completed the RT-Eye Serial Analysis Lab. We hope
that this has been helpful in understanding the capabilities of the RT-Eye
software solution and will help you in the validation and compliance testing of

your devices.

188 RT-Eye ®Serial Compliance and Analysis Application



Parameters

About Application Parameters

This section describes the RT-Eye application parameters and includes the menu
default settings. Refer to the user manual for your oscilloscope for operating
details of other controls, such as front-panel buttons.

The parameter tables list the selections or range of values available for each
option, the incremental unit of numeric values, and the default selection or value.

Refer to the GPIB topics for a complete list of the GPIB Command Syntax. The
topics include a complete list of the GPIB commands along with the arguments,
variables, and variable values that correspond to the RT-Eye parameters.

Note: Unit values shown are valid when the FINE button is enabled on the
oscilloscope.
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File Menu Parameters
The File drop-down list includes the following command buttons:
" Recall Default

®  Minimize

= Exit
Table 46. File menu parameters
Recall <Browser> Default directory*
Save <Browser> Default directory*
Recall Recent |Lists up to five most recently saved or Default directory*

accessed setup files:
. <setup file name>
. <setup file name>
. <setup file name>
. <setup file name>
. <setup file name>

Preferences | See File Preferences Menu Parameters topic, next
* Refer to the Application Directories and Usage topic for default path names.

G wWwN B

File Preferences Menu Parameters

The File Preferences menu includes the following command buttons:
" Cancel

" OK

Table 47. File preferences menu parameters

Parameters Default setting

Show Welcome Dialog at Startup Set, Clear Set
Show Autoset Summary when Autoset is Set, Clear Set
selected

Enable high-performance eye rendering Set, Clear Set
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Control Panel Parameters
The Control Panel menu includes the following command buttons:
®  Start
=  Stop

B (Clear Results

Table 48. Control panel parameters

Parameters Default setting
Mode Single Run, Single No Acqg, Free Run Single Run

Measurements Select Menu Parameters

Available measurements in the Measurements Select menu are dependant on the
selection for the Probe Type option. Measurements available by area are as
follows:

®  Timing area: Rise Time, Fall Time, Unit Interval, Bit Rate, Eye Height, Eye
Width, and Differential Skew

®  Amplitude area: Differential Voltage, High Amplitude, Low Amplitude, CM
Voltage, AC CM Voltage, and De-Emphasis

" Jitter area: Jitter@BER and TIE Jitter

Note: The Differential Skew, CM Voltage, and AC CM Voltage measurements
are added when you select Single Ended as the Probe Type option.
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Autoset Summary Menu Parameters
The Autoset Summary menu includes the following command buttons:
®  Autoset
= Configure

B Close

Table 49. Autoset summary menu parameters
Option Parameters Default setting
Do not show this menu again Set, Clear Clear

Measurements Configure Menus

The application includes the following Measurements Configure menus:

B Source for Single Ended Probes or Source for Differential Probes

®  RefLevels

"  Smart Gating

®  Clock Recovery
= Jitter Method

®  Population

B General Config

Note: These menus are generally referred to as the Configure menus.

The application automatically calculates parameters for reference voltage levels
in the Ref Level Autoset Setup menu. Display the Ref Level Autoset Setup menu

parameters.
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Configure Source Menu Parameters for Differential Probes

The Configure Source menu includes the following command buttons in the
Autoset area:

®  Vertical Scale
®  Horizontal Resolution

®  Vertical & Horizontal

Table 50. Source menu parameters for differential probes
Option Parameters Default setting

Live/Ref
Select Differential | Ch1, Ch2, Ch3, Ch4, Refl, Ref2, |Chl
Ref3, Ref4
File
Differential File <Browser> Default directory*
* Refer to the Application Directories and Usage topic for default path names.

Configure Source Menu Parameters for Single-Ended Probes

The Configure Source menu includes the following command buttons in the
Autoset area:

®  Vertical Scale
®  Horizontal Resolution

®  Vertical & Horizontal

Table 51. Source menu parameters for single-ended probes
Option Parameters Default setting

Live
Select D+, D- |Chl, Ch3 Chi, Ch3
Chil, Ch4
Ch2, Ch3
Ch2, Ch4
Ref All combinations of two Ref waveforms |Refl, Ref2
File
Select File D+ |<Browser> Default directory*
Select File D- | <Browser> Default directory*
* Refer to the Application Directories and Usage topic for default path names.
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Configure Ref Levels Menu Parameters

The Configure Ref Levels menu includes the following command buttons in the
Autoset area:

®  Setup

® Run
Table 52. Reference level parameters
Source Differential, DPlus*,DMinus* Differential
Rise, High 10.00 V to0 -10.00 V in units of 1 mV 400 mV
Rise, Mid 10.00 V to -10.00 V in units of 1 mV oV
Rise, Low 10.00 V to0 -10.00 V in units of 1 mV -400 mV
Fall, High 10.00 V to0 -10.00 V in units of 1 mV 400 mV
Fall, Mid 10.00 V to -10.00 V in units of 1 mV ov
Fall, Low 10.00 V to0 -10.00 V in units of 1 mV -400 mV
Hysteresis 0V to 10.00 V in units of 10 mV 30 mV
Mid = QV** Set, Clear 0V (set)
* Only available when Single Ended is the Probe Type option.
**50% (VRef,, ) of signal swing if the option is clear.

Configure Ref Level Autoset Setup Menu Parameters

The Configure Ref Level Autoset Setup menu includes the following command

buttons:

B OK

®  Cancel
Table 53. Reference level autoset set up menu parameters
Option \Parameters* Default setting
Rise, High 0 to 100% in units of 1% 80%
Rise, Mid 0 to 100% in units of 1% 50%
Rise, Low 0 to 100% in units of 1% 20%
Fall, High 0 to 100% in units of 1% 80%
Fall, Mid 0 to 100% in units of 1% 50%
Fall, Low 0 to 100% in units of 1% 20%
Hysteresis 0 to 50% in units of 1% 3%
*Where 0% = mean(vEYE.H|.TRAN(n)) and 100% = mean(vEYE.Lo.TRAN(n)).
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Configure Smart Gating Menu Parameters

Table 54. Smart gating menu parameters

Parameters Default setting

Gating Off, Cursors, Smart Gating Off

Configure Smart Gating Menu with Smart Gating Parameters

The value that displays under Stop shows the sum of the Length and Start options.

Table 55. Smart gating menu with smart gating parameters

Parameters Default setting
Gating Off - Off
Cursors
Smart Gating
Clock Recovery |Length 1to50 M 3.5k
(CR) Window Start 1to 50 M 1
Stop - -
Scan Incr 1to50 M 1
#Scans 1to50 M 1
Scan to End of - Selected
Record
Enable Scan - Cleared
Gating Units Unit Intervals, Edges | - Unit Intervals
Analysis Window | Same as Clock Select, Clear Selected
(Relative to CR | Recovery Window
Window) Alignment* Centered, User Centered
Defined
Length* 1to 50 M in 250
increments of 1
Start*** 1to 50 M in 1.626k

increments of 1
Stop - -
* Available when you clear the Same as Clock Recovery Window check box.
** Available when you select User Defined as the Alignment option.

Configure Clock Recovery Menu Parameters

Table 56. Clock recovery menu parameters
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Area
Clock Recovery

\ Option
Method

Parameters

Const Clk: Mean,
Const Clk: Median,
PLL: Standard BW,
PLL: User BW

\Default setting

PLL: Standard
BW

Nominal Data
Rate

On

Off

Off

Bit Rate*

1 to 10 e’ bits/second

2.5 Gb/s

PLL Loop BW

User BW**

10 kHzto 1 GHz

15 MHz

Standard:
bis'

PCI-E: 2.5 G,
100BaseT: 125 M,
1394b S400b: 491.5 M,
1394b S800b: 983.0 M,
1394b S1600b: 1.966 G,
FC133: 132.8 M,
FC266: 265.6 M,
FC531: 531.2 M,
FC1063: 1.063 G,
FC2125: 2.125 G,
FC4250: 4.25 G,
FC8500: 8.5 G,
FBD1: 3.2 G,

FBD2: 4.0 G,

FBD3: 4.8 G,

GB Ethernet: 1.25 G,
IBA2500: 2.5 G,
IBA_GENZ2: 5.0 G,
OC1:51.8 M,

OC3: 155 M,

0OC12: 622 M,

0OC48: 2.488 G,
PCI_E_GEN2: 5.0 G,
RI0125: 1.25 G,
RI0250: 2.5 G,
SAS3: 3.0 G,

SAS6: 6.0 G,
SAS15:1.5G,
SerATAG1: 1.5 G,
SerATAG2: 3.0 G,
SerATAG3: 6.0 G,
USB FS: 12 M,

USB HS: 480 M,
XAUI: 3.125 G,
XAUI_GEN2: 6.25 G

PCI-E: 25 G

PLL

PLL Order’

First, Second

First

Damping

05t01.0

0.7

* Available only when Nominal Data Rate is On.

** Available only when Method is PLL: User BW.

TAvailable only when Method is PLL: Standard BW.

*Available only when Method is PLL: User BW or PLL: Standard BW.

Damping is only available for Second Order PLL.
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Configure Jitter Menu Parameters

Table 57. Jitter menu parameters
Area Option Parameters Default setting

Data Pattern | Type Repeating, Arbitrary Repeating
Pattern B2BTS1, CIJTPAT, CITPAT
CSPAT, PCE-CTP, FBD-
IBIST, Custom
Length* 1 to 200 k unit intervals 2.5k Ul
Window 2 to 16 unit intervals 5Ul
LengthJr
PopulationT 5 to 5000 samples 100 samples
Rj/Dj BER=1e”* |[2t0 15 (le?to 1e™) 12 (BER = 1e™)
* Available only when Type is Repeating.
** Available only when Type is Repeating and Pattern is Custom.
TAvailable only when Type is Arbitrary.
*Available only when the Jitter @BER measurement is selected.

Configure Population Menu Parameters

Table 58. Population menu parameters
Arealoption Parameters Default setting

Population Limit | On, Off Off
Configure
Limit By Acquisitions, Measurement | Acquisitions
Limit 1to 10 T in units of 1 1K

Configure General Config Parameters

Table 59. General config parameters
Option Parameters Default setting

Limit Rise/Fall measurements to transition Yes, No No
bits only

Limit Amplitude measurements to transition Yes, No No
bits only

Enable worst-case logging while in scan Yes, No Yes
mode
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Measurements Limits Menu Parameters

Table 60. Measurement limits parameters

Parameters Default setting
Limits On, Off Off
Limits File Editor | Current, New none
Limits File <Browser> Default directory*
* Refer to the Application Directories and Usage topic for default path names.

Results Menus

The application includes the following Results Menus:
®  Summary

B Details

Results Summary Menu Parameters
The Results Summary menu includes the following command buttons:
®  Show Plot

®  Export to CSV

Table 61. Results summary menu parameters
Option Parameters Default setting

Select View All Stats, Limits Status* All Stats
Time Units Unit Intervals, Seconds Unit Intervals
* Available only when Measurements Limits is enabled.
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Results Details Menu Parameters
The Results Details menu includes the following command buttons:
®  Show Plot

®  Export to CSV

Table 62. Results details menu parameters
Option Parameters Default setting

Select View <list of all selected measurements> <first selected>
Time Units Unit Intervals, Seconds Unit Intervals

Plots Select Menu Parameters

The Plots Select menu includes the following command button:

®  Refresh

Table 63. Plots select menu parameters
Option \Parameters Default setting

Measurement |<any selected measurement> Eye Width
Plot Type See Measurement and Available Plots topic | Eye Diagram
Plots Display | On, Off On
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Eye Diagram Configure Menu Parameters

Table 64. Eye diagram configure menu parameters

Area/option \Parameters Default setting
Bit Type All, Transition, Non Transition All

Mask On, Off Off

Standard InfiniBand, PCI Express, User* InfiniBand
Type Receiver

for InfiniBand Receiver, Cable, TP1, TP2, TP3, TP4,
TP5, TP6, TP7, TP8, TP9, TP10

for PCI Express |Receiver, Transmitter Thit, Transmitter | Receiver
NTbit

* When you select User, a file browser displays; refer to the User Mask topics.

Histogram Plot Configure Menu Parameters

Table 65. Histogram plot configure menu parameters

Option \Parameters Default setting
Vertical Axis Linear, Log Linear
Bin Resolution 1 to 50 K in units of 1 250
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Spectrum Plot Configure Menu Parameters

Table 66. Spectrum plot configure menu parameters

Default setting

\Parameters
Vert. Scale Linear, Log Linear
Horiz. Scale Linear, Log Linear

Bathtub Plot Configure Menu Parameter

Table 67. Bathtub plot configure menu parameters
Default setting

Linear

‘Parameter
Scale Linear, Log
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Log Worst Case Configure Menu Parameters

The Log Worst Case menu includes the following command button:

" Purge

Table 68. Log worst case configure menu parameters
Option \Parameters Default setting

Log On, Off Off
Choose Directory <Browser> Default directory*
* Refer to the Application Directories and Usage topic for default path names.

Utilities Report Generator Menus Parameters

There are no parameters for the Report Generator utility menus.

Help Menu

There are no parameters for the Help menu.
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About Measurement Algorithms

The RT-Eye application can take measurements from one or two serial data
waveforms. The number of waveforms used by the application depends on the
probe selected in the Probe Type option of the Measurements> Select menu.

- . . .
¥Tip The Algorithms book includes Field Notes that you may use to ensure
good measurement results.

Oscilloscope Setup Guidelines

For all measurements, use the following guidelines to set up the oscilloscope:
1. The signal is any channel, reference, or math waveform.

2. The vertical scale for the waveform must be set so that the waveform does
not exceed the vertical range of the oscilloscope.

3. The sample rate must be set small enough to capture sufficient waveform
detail and avoid aliasing.

4. Longer record lengths increase measurement accuracy (though at the same
time decrease measurement speed)
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Test Methodology

The application performs the measurement according to the following steps:
1. Imports the current waveform.

2. For timing measurements, checks that there are a minimum number of edges
in the waveform to calculate the measurement as follows:

" Single edge: Rise Time, Fall Time
" Two cycle-start edges: Unit Interval
B Three cycle-start edges: TIE

B Jitter measurements require at least 50 pattern repeats for RjDj
analysis; accuracy may be degraded for fewer than 100 pattern repeats

®  Two edges on each of two waveforms: Differential Skew
3.  Performs the measurement.
4. Displays the results as statistics where you can save the results to a .csv file.

5. Displays the results as a plot if defined and enabled.
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Measurements

Table 69. Measurements

Button name

Measurement names

Applicable module test

Timing
Eye Width/ Eye Width Eye Height: All
Eye Height Eye Height Eye Width: Infinband-Cable
Eye Height: Transition Bits | Assembly, PCI Express, Serial
Eye Height: Non-Transition | Analysis.
Bits
Rise Rise Time All. Applied to Vp: and Vp. in
Time PCI Express w/ Single-Ended
Probes.
Fall Fall Time All. Applied to Vp. and Vp. in
Time PCI Express w/ Single-Ended
Probes.
Unit Unit Interval Infiniband-Driver, PCI-
Interval Express, Serial Analysis.
Bit Rate Bit Rate Serial Analysis.
Differential Differential Skew Serial Analysis.
Skew*
Amplitude
Differential Differential Amplitude Infiniband-Driver/Receiver,
Voltage Serial Analysis.
Differential Peak Voltage PCI Express.
Differential PCI Express-Driver.
Average
High High Amplitude Serial Analysis.
Amplitude
Low Amplitude | Low Amplitude Serial Analysis.
CM Voltage* CM Voltage Infiniband-Driver/Receiver,
PCI Express, Serial Analysis.
AC CM AC CM Voltage Serial Analysis.
Voltage* AC CM RMS Voltage InfiniBand and PCI-Express
Driver.
AC CM Pk Voltage PCI-Express Receiver
De-Emphasis | De-Emphasis PCI-Express Driver, Serial
Analysis.
Jitter
Jitter @ BER Jitter @ BER Infiniband-Driver/Receiver,
Jitter: Eye Opening Serial Analysis
Jitter: Total (TJ) RJ onl)_/ available in Serial
Jitter: Deterministic (0J) | AnaYSis:
Jitter: Random (RJ)
TIE Jitter TIE Jitter Infiniband-Cable Assembly,
PCI Express, Serial Analysis.

* Available only when Single Ended is the Probe Type option in the

Measurements Select menu.
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Notation in Algorithms

About Notation in Algorithms

All measurements are made on one of several voltage waveforms. Timing
measurements are based on edge locations in the waveform or on clock edge
times derived from the waveform edge locations. Amplitude measurements are
made on the entire waveform or on waveform values based on recovered clock
times. To represent measurements as formulas, the algorithm descriptions follow
notational rules.

Notational Rules

Table 70. Notational rules

Notation Use \

Lower case | Reserved for fundamental signals or measurements. For

character instance, sampled waveforms are of the form v(i) and edge
times are of the form t(n). The character is indicative of the
units of the quantity, such as v for a voltage and t for a time.
They are always indexed.

Upper case | Used for a quantity that is fixed or for a measurement. The

character character is indicative of the units of the quantity, such as V
for a voltage and T for a time.

Subscripts Used to identify the variable, measurement or quantity.

Indices Indices for variables or measurements have multiple values

variables over the course of an acquisition. The indices are between
parentheses. If the index is a measurement, it will have
statistics for both the current acquisition and all acquisitions
(accumulated). Non-indexed measurements that have a
single result for the entire waveform will only have all
acquisition statistics.
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Summary Definitions of Fundamental Signals and Measurements

The next several topics list the annotation of the signals and measurements as
they appear in the algorithm specific to each measurement. The algorithms

comprise the following types of annotation:

e Waveforms

e Edge Time Threshold Voltages

e Crossing Times

e Recovered Clock Times

o Eye Center Voltages

Waveforms

Table 71. Waveforms

Waveform  Definition
i Index into sampled voltage waveforms
Vp+(1) Positive conductor (D+) voltage acquired with a single ended

probe

vp-(i) Negative conductor (D-) voltage acquired with a single ended
probe

Vpirr(i) Differential voltage signal acquired with either a differential
probe or calculated from two single ended probe signals:
= Vo+(1) = Vo(1)

vem(i) Common mode voltage calculated from two single ended probe

signals:
= (Vp+(i) + vp(i))/2
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Edge Time Threshold Voltages

Table 72. Edge time threshold voltages
Edge Time
Threshold Voltage Definition

VREE-HI High level reference voltage

VREF-MID Mid level reference voltage

VREE-LO Low level reference voltage

Vhyst Hysteresis voltage; minimum voltage swing required at
any threshold before a crossing is recognized

Crossing Times

Table 73. Crossing times
Crossing Time  Definition

n Index into array of crossing times
t Interpolated time when Vpgr crosses a Vger
thi(n) When Vpjrr(t) crosses VRer-Hi
tpat(n) When Vpjrr(t) crosses Vrer-mip
tLo(n) When Vper(t) crosses VRer-Lo
to+hi(N) When Vp.(t) crosses Vp+Rrer-Hi
to+mip(N) When Vp+(t) crosses Vp+rer-miD
tp+Lo(N) When Vp(t) crosses Vp+Rrer-Lo
to_Hi(N) When Vp_(t) crosses Vp_rer-Hi
to_mip(N) When Vp_(t) crosses Vp_rer-mip
to-Lo(N) When vp_(t) crosses Vp_rer-Lo
208

RT-Eye ®Serial Compliance and Analysis Application



Algorithms

Recovered Clock Times

Table 74. Recovered clock times

Recovered Clock

Time Definition
tr-cLk(N) Recovered clock edge times referenced to the Ul
boundaries:
= PLL(tmip) for PLL based clock recovery
= CCR(tmip) for Constant Clock based clock recovery
lui-Tran(N) List of transition Uls immediately following a transition
Tui-nTRAN(D) List of non-transition Uls not immediately following a
transition
tr-pat(N) Recovered data edge times:
= tr-cik(lui-TraN(N))
Ul(n) Unit Interval (Ul):
= trcik(N+l) —trcik(n)

Table 75. Eye center voltages
Eye Center Voltage \Definition

Veve(N)

Eye Center Voltages

Voltage at middle of a Ul:
= Vpirr(tr-cLk(N) + Ulave/2)

Veve-Tran(N)

Voltage at middle of a transition UI*:
= Veve(lui-Tran(N))

Veve-NTRAN(N)

Voltage at middle of a non-transition UI*:
= Veve(iur- nTran(N))

Veve-Hi(N) High voltage at middle of a UI*:
= subset(VEYE(n) >= ()
Veye-Lo(N) Low voltage at middle of a Ul*:

= subset(Veye(n) < 0)

VEYE-HI-TRAN(N)

High voltage at middle of a transition UI*:
= Veve-Hi(iui-ran(N))

VEYE-HI-NTRAN(N)

High voltage at middle of a non-transition UI*:
= Veve-Hi(iur- nTran(N))

VevE-Lo-TRAN(I)

Low voltage at middle of a transition UI*:
= Veve-Lo(lui-Tran(N))

VevE-LO-NTRAN()

Low voltage at middle of a non-transition UI*:
= Veve-Lo(lui- nTrRan(N))

* A subset of Veye(N).

RT-Eye ® Serial Compliance and Analysis Application

209



Algorithms

Timing Measurements
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About Timing Measurements

Timing measurements are all based on either Crossing Times or Recovered
Clock Times. Crossing times are dependent on Ref Level thresholds. Recovered
Clock Times are affected by the clock recovery method specified in Clock
Recovery and Jitter Configuration.

Eye Width Measurement

The Eye Width measurement is the measured minimum horizontal eye opening
at the zero reference level as shown in the eye diagram.

Teve wiorh =Ulave — TIEp
Where:

Ul

AVG s the average Ul

TIEpcpi i5 the Peak-Peak TIE
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Rise Time Measurement

The Rise Time measurement is thQ/time difference between when the Veer -
reference level is crossed and the ~ REF-LO reference level is crossed on the rising
edge of the waveform.

tase (M) =ty (D=t ()
Where:
t

RISE {5 a Rise Time measurement

t t

Hi+ is a set of "HI for rising edges only
bo. is a set of to for rising edges only
i and j are indexes for nearest adjacent pairs of bo. and Ui

n is the index of rising edges in the waveform

Rise time can be limited to only rising edges of consecutive transitions in the File
Preferences menu. In the PCI-Express module, Rise Time is taken independently
on each single-ended waveform sources when you use two single-ended probes
as the signal source.

Rise Time for Vo. (V) 1s as follows:

tD+RISE (n)= tD+H|+(i) - tD+LO+( )

and for Vp_ (1)
to_mse (M =15 4. () —tp 0. (D)
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Fall Time Measurement

The Fall Time measurement is the\}ime difference between when theVREF—H'
reference level is crossed and the = REF-LO reference level is crossed on the
falling edge of the waveform.

tFALL(n) = tLO—(i) -t ( J)

Where:

teact is a Fall Time measurement

t t

Hi- is a set of "HI for falling edges only
to- is a set of bo for falling edges only
i and j are indexes for nearest adjacent pairs of bo- and G-

n is the index of falling edges in the waveform

Fall time can be limited to only falling edges of consecutive transitions in the File
Preferences menu. In the PCI-Express module, Fall Time is taken independently
on each single-ended waveform source when you use two single-ended probes as
the signal source.

Fall Time for Vo. (D) is as follows:

tD+FALL(n) = tD+LO—(i) - tD+HI—( J)

and for VD—(t)
tD—FALL(n) = tD—LO—(i) - tD—HI 7( J)
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Rising Edge Measurement

The Rising Edge measurement or Risin%/Edge Rate measurevent is defined as
the ratio of voltage difference between = REFCLK-DIFF-IH apd " REFCLK-DIFF-IL {q
the time differe(l;;e between the crossing of ~ REFCLK-DIFF-IH reference level and
the crossing of * REFCLK-DIFF-IL reference level on the rising edge of the
waveform.

ER (n) — VREFCLKfDIFFle _VREFCLKfDIFFflL
RISE

tRISE—IH (') - tRISE—IL ( J)
Where:

ER

RISE is a rising edge rate measurement

\Y

REFCLK-DIFF-IH ig a predefined high voltage reference level

\Y

REFCLK-DIFF-IL g a predefined low voltage reference level

t . . V )
RISE-IH 5 a set of time when = REFCLK-DIFF-IH reference level is crossed
on rising edges

t . . V . .
RISE-IL g a set of time when = REFCLK-DIFF-IL reference level is crossed on rising
edges

. L . . t
i and j are indexes for nearest adjacent pairs of RISE-IH and Lruse 1
n is the index of rising edges in the waveform

The rising edge measurement is required for reference clock measurements in
PCI-Express and FB-DIMM modu{?s. In these two mod{}les, rising edge is taken
on differential signal, the value of ~ REFCLK-DIFF-IH and " REFCLK-DIFF-IL {g
specified as 150mV and -150mV respectively as shown in the following diagram.

EHnErnLu_nrr_nﬂE ERpercuk owr rFavs

5

4 N
Veercox owem=150mV .SV N ——
Vigrews o s = 150 MY ==mmemnrmmm et e e

Figure 129: Rising edge measurement
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Falling Edge Measurement

The Falling Edge measurement or FalliQﬁ Edge Rate measurvnent is defined as
the ratio of voltage difference between = REFCLK-DIFF-IH apd * REFCLK-DIFF-IL {q
the time differe(l;;e between the crossing of * REFCLK-DIFF-IL reference level and
the crossing of ~ REFCLK-DIFF-IH reference level on the falling edge of the
waveform.

ER (n) — VREFCLKfDIFFle _VREFCLKfDIFFflL
FALL

tFALL—IL (') - tFALL—IH (J)

Where:

ER

FALL is a falling edge rate measurement

\Y

REFCLK-DIFF-IH ig a predefined high voltage reference level

\Y

REFCLK-DIFF-IL g a predefined low voltage reference level

t . . \ .
FALL-IH is a set of time when = REFCLK-DIFF-IH reference level is crossed on
falling edges

. . \Y .
Ueaci-ic is a set of time when = REFCLK-DIFF-IL reference level is crossed on
falling edges

i and j are indexes for nearest adjacent pairs of Lean and Lea-m

n is the index of falling edges in the waveform

The falling edge measurement is required for reference clock measurements in
PCI-Express and FB-DIMM modu{?s. In these two mod{}les, falling edge is taken
on differential signal, the value of ~ REFCLK-DIFF-IH apnd " REFCLK-DIFF-IL {g
specified as 150mV and -150mV respectively as shown in the Rising Edge
Measurement diagram.
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Unit Interval Measurement

The Unit Interval measurement calculates the cycle duration of the recovered
clock.

Ul(n) =t i (N+1D) =tz ¢ (M)
Ul ,,c = Mean(Ul (n))

Where:

t .
R-CLK is a recovered clock edge

n is the index to Ul in the waveform
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Bit Rate Measurement

The Bit Rate measurement calculates the baud (such as frequency) of the
recovered clock.

BR(n) = 1/UI(n)
Where:
Ul is the associated Unit Interval measurement

n is the index to Ul in the waveform

Differential Skew Measurement

The Skew measurement is the time delay between the two single-ended
waveform sources.

Lskew (n)= tD+MID(n) - tD—MID(n)

Where:

t .
SKEW  is the Skew measurement

t

D+MID i the mid level crossing time of Vo,
t

D-MID is the mid level crossing time of Vo

n is the index to edges in the waveform
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Amplitude Measurements

About Amplitude Measurements

Some amplitude measurements can be limited to only the high or only the low
amplitude of consecutive transitions in the File Preferences menu.

Eye Height Measurement

The Eye Height measurement is the measured minimum vertical eye opening at
the UI center as shown in the plot of the eye diagram. There are three types of
Eye Height values.

Eye Height:
VEYE—HEIGHT =\/EYE—HI—MIN _VEYE—LO—MAX
Where:

V,

EYE-HI-MIN {5 the minimum of the High voltage at mid Ul

V,

EYE-LO-MAX' {5 the maximum of the Low voltage at mid UI

Eye Height — Transition:

VEYE —HEIGHT -TRAN = VEYEf HI-TRAN-MIN — VEYEf LO-TRAN —MAX
Where:

V
at mid Ul

EYE-HI-TRAN-MIN {5 the minimum of the High transition bit eye voltage

V
at mid Ul

EYE-LO-TRAN-MAX g the maximum of the Low transition bit eye voltage
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Eye Height — Non-Transition:

VEYE—HEIGHT—NTRAN = VEYE—HI —NTRAN -MIN _VEYE—LO—NTRAN -MAX

Where:

Veve-i-nTran -min is the minimum of the High non-transition bit eye voltage at
mid Ul

Veve-Lo-nTRan -max is the maximum of the Low non-transition bit eye voltage at
mid Ul
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Differential Amplitude Measurement

The Differential Amplitude measurement calculates the change in voltage level
across a transition in the differential waveform.

Voirr—awe (M = Vo _teve () = Voirr_eve (1 +1) |

Where
n is the index of transitions of interest

i is the index of UI (bit) locations preceding/following the transition

VoirF-Lever is the state level of the unit interval (bit period)

VDIFF—LEVEL = mean(VDIFF (J))

Where
J is the sample index; in the previous equation, j spans the samples that fall in the
center 30% of Uls i or i+1.

VoI s the differential voltage.

Note: Eligible transitions are all transitions (Blue and Red) or consecutive
transitions (Red only). This is set in the File Preferences menu.

[ |

Voltage  Edge times

N

Ky ; YD IFF-AMP ¥ LIFF-LEVEL

»Tim e

Figure 130: Differential voltage
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Differential Peak Voltage Measurement

The Differential Peak Voltage measurement returns two times the larger of the
Min or Max statistic of the differential voltage waveform.

Voire_pk =2 * Max(Max(Vp,ee (1)); Min(Vp e (1))

Where:
i is the index of all waveform values

VoirF s the Differential voltage signal

Differential Average Measurement

The Differential Average measurement returns the Mean of the differential
voltage waveform.

VDIFF—AVG = Mean(VDIFF ('))

Where:
i is the index of all waveform values

VoiIFF s the Differential voltage signal

High Amplitude Measurement

The High Amplitude measurement calculates the mode of all differential
waveform values greater than zero.

Vi = Mode(Vpee (1) > 0)

Where:
VoiFF is Differential voltage signal

i is the index of all waveform values
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Low Amplitude Measurement

The Low Amplitude measurement calculates the mode of all differential
waveform values less than zero.

Vo = Mode(Vpee (i) < 0)

Where:

VoiFr s Differential voltage signal

i is the index of all waveform values

CM Voltage Measurement

The Common Mode Voltage measurement (also called DC Common Mode)
calculates the mean of the Common Mode voltage waveform.

Veu = Mean(v, (1))

Where:

Vem s the Common Mode voltage signal

Veu is the Common Mode voltage signal

i is the index of Common Mode waveform values
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AC CM Voltage Measurement

The AC Common Mode Voltage measurement calculates the AC statistics of the
Common Mode voltage waveform with the DC value removed.

Vac-cm (') =Vem (') _VCM
Where:

i is the index of all waveform values

Vac-cm s the AC Common Mode voltage signal

Vem s the Common Mode voltage signal

CM s the DC Common Mode voltage signal

AC CM RMS Voltage Measurement

The AC Common Mode RMS Voltage measurement calculates the RMS statistic
of the Common Mode voltage waveform with the DC Value removed.

VAC—RMS—CM (') = RMS(VAcfcm ('))
Where:
i is the index of all waveform values

Vac-ws-cm is the RMS of the AC Common Mode voltage signal

Vac-cm is the AC Common Mode voltage signal
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De-Emphasis Measurement

The De-Emphasis measurement calculates the ration of any non-transition eye
voltage (2", 3", etc. eye voltage succeeding an edge) to its nearest preceding
transition eye voltage (1* eye voltage succeeding an edge). In the accompanying
diagram, it is the ratio of the Black voltages over the Blue voltages. The results
are given in dB.

Voltage
&

T

Fecovered edge times

S

Figure 131: De-emphasis measurement

DEEM (m) = dB(VEYE—Hl-NTRAN (m)j

VEYE—HI —TRAN (n)

or

DEEM(m) = dB(VEYE—LO—NTRAN (m)]

VEYEf LO-TRAN (n)

Where:

VEvE-HI-TRAN g the High voltage at mid UI following a positive

transition

VEVE-LO-TRAN {5 the Low voltage at mid Ul following a negative

transition

VEVE-HI-NTRAN g the High voltage at mid UI following a positive

transition bit

VEVE-LO-NTRAN 5 the Low voltage at mid Ul following a negative

transition bit
m is the index for all non-transition Uls

n is the index for the nearest transition Ul preceding the Ul specified by
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About Jitter Measurements

In the context of this RT-Eye analysis package, the term Jitter is used solely in
relation to timing errors between data signal edges and recovered clocks. The two
measurements in this category are TIE Jitter and Jitter @ BER. TIE Jitter is a
direct measurement of the time difference (error) between data edges and
associated clock edges, which is recovered from the data signal edges. Jitter @
BER is the label for Random and Deterministic Jitter analysis (Rj/Dj) on a TIE
Jitter measurement.

The purpose of the Rj/Dj analysis is two fold: to decompose the TIE into
component elements and to extrapolate jitter measurements (Total Jitter or Eye
Opening) @ BERs that would require very large data sets for direct
measurement.

TIE, and therefore Jitter @ BER, correlates to Eye Diagram statistics. A time
Histogram at the eye crossing (at the mid reference voltage level) is the same as
Histogram Plot of the TIE Jitter measurement on the same signal.

The method of clock recovery has a big impact on Jitter results.
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Jitter @ BER Measurement

The Rj/Dj measurement calculates the deterministic and random components of
jitter. The jitter is obtained from the TIE measurements. Rj is the random jitter
and is assumed to be Gaussian having flat spectrum. The Rj measurement
calculates the RMS value of the random jitter.

Dj is the deterministic jitter. It is predictable and can be generated consistently
under known circumstances. Dj has a spectrum of impulses when the data signal
has a repeating pattern. The Dj measurement calculates the peak-to-peak value of
the deterministic jitter. Tj is the total jitter, which is composed of Dj and Rj. The
Tj measurement calculates the peak-to-peak value of the total jitter at the
specified BER.

Dj comes from multiple sources:

B Periodic jitter (PJ) from periodic interference that is not correlated to the
data

®  Data dependent jitter (DDJ) from interference of nearby edges (also called
ISI or Inter-Symbol Interference)

®  Duty Cycle Distortion jitter (DCD) from slew rate differenced between
rising and falling edges.

Two methods of jitter measurements are supported. The first method is a
spectrum analysis based approach (default) when the data pattern is repetitive. A
clock waveform is always repetitive. Other repetitive testing data patterns are
used, such as the CITPAT data pattern.

The second method is Rj/Dj separation method is arbitrary pattern analysis based
approach when the data pattern is not necessarily repetitive. It is useful for long
PRBS data patterns. The data is virtually non-repetitive within a single
acquisition for extremely long data pattern.
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Spectrum Analysis based Rj/Dj Separation on Repeating Pattern

Dj components can be identified in a jitter spectrum under a set of conditions. PJ
will appear as spectral impulses regardless of the conditions. DDJ and DCD will
appear as spectral impulses provided that the data signal is a repeating pattern.
The frequencies of DDJ and DCD spectral impulses are at harmonics of the (Bit
Rate / Pattern length). The remaining spectral energy is attributed to Rj. Dj
components are spectrally separated from Rj.

The Dj measurement is the peak-to-peak value of the inverse fourier transform of
the deterministic jitter spectral components. Tj is the total jitter, which is
composed of Dj and Rj. The Tj measurement calculates the peak-to-peak value of
the total jitter. Rj is assumed to be near Gaussian. The Rj measurement is the
calculated RMS value of random jitter.

A Jitter PDF is formed by convolving Gaussian distribution of Rj and Histograms
of Dj. A Bathtub curve is calculated from the left and right s1deTCDFs of the
Jitter PDF. The Bathtub curve will yield TJ and Eye Opening ( ~ EYE-OPEN ) View
the Bathtub Curve: BER versus Decision Time Diagram.

The application calculates the measurements using the following equation:

Dj = Max(Dj"™) — Min(Dj ™)
Rj = RMS|tie - Dj™)
TJ .o = normalizedHistogram(Dj) * GaussianPDF (Rj)

TI =TI = T

Max

TEYE—OPEN =Ul-TJ
Where:

Dj

is the Deterministic jitter

Rj

is the Random jitter

TJ is the Total jitter

TJpor is the PDF of the Total jitter

TJ

MIN is the minimum value at the Bathtub curve at a given BER
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TJ

Max is the maximum value at the Bathtub curve at a given BER

DJ Time

is the is the time domain record of the Dj component of

jitter obtained by performing an inverse FFT of the D components of the TIE

spectrum.

tIe s the time domain record of measured TIE jitter.

Additionally, Dj is further decomposed as follows:

PJ = Max(PJ"™) - Min(PJ ™)

Rise

DCD = ‘Mean(DCDDDJ Aime) — Mean(DCDDDJ L)

DDJ = Max(DCDDDJ ™) — Min(DCDDDJ ™) — DCD

Where:

PJ is the periodic jitter

DCD s the duty cycle jitter

DDJ s the data dependent (or ISI) jitter

-
PJ ™™ is the time domain record of the PJ component of jitter obtained by
performing an inverse FFT of the PJ components of the TIE spectrum.

DCDDDJ "™

is the time domain record of the
DCD . DDJ component of jitter obtained by performing an

DCD inverse FFT of the DCD + DDJ components of the TIE spectrum.

DCDDDJ/™ . DCDDDJ™ .
1€ s on rising edges only.

Time Time
DCDDDJ is DCDDDJ on falling edges only.
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Arbitrary Pattern Analysis based Rj/Dj Separation

When the data pattern is non-repeating, Pj still has a spectrum of impulses while
DCD+DDJ no longer has a spectrum of impulses. Therefore, Dj no longer has a
spectrum of impulses.

The DCD+DDJ value is obtained through the arbitrary data pattern analysis
method, which is based on the assumption that any given bit is affected by a
finite number of preceding bits. By averaging all events where the current bit is
preceded by a particular bit sequence, for example, the current bit is preceded by
the bit sequence 1001101, the DCD+DDJ with such a pattern is obtained because
PJ and RJ are not correlated to a particular data sequence and thus are averaged
out.

If each bit is assumed to be affected by N preceding bits, there are a total of 2"
possible data sequences. The sequence length N is a configurable parameter. To
get statistically sound average values, a population limit is the other configurable
parameter that prevents using an average value without enough population. Only
DCD+DDJ values obtained from data sequences with a population above the
limit are used to calculate DCD+DDJ values.

After each edge is associated with a DCD+DDJ value, with known total jitter, the
PJ+Rj value for each bit is then obtained by subtracting DCD+DDJ from TJ.

Separation of DDJ and DCD from DCD-+DDJ is the same as that in the spectrum
based Rj/Dj separation method.

PJ and Rj are then separated from PJ+Rj using the spectrum analysis method. PJ
has a spectrum of impulses. Rj has a flat spectrum. Not all of the edges
DCD+DDJ can be determined because of their associated data sequences, which
have low populations and are treated as if there are no edges when performing PJ
and Rj separation.

The histogram of Dj is a convolution of the histogram of DCD+DDJ and the
histogram of PJ.

All other aspects of the arbitrary pattern analysis based Rj/Dj separation are the
same as those of the spectrum analysis based Rj/Dj separation.
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Rj/Dj Separation based on Dual-Dirac Model

The Dual-Dirac model based Rj/Dj separation method fits the Bathtub curve to a
theoretical model of Rj and Dj where Rj has a Gaussian distribution and Dj has a
distribution of two Dirac impulses with the same height. Curve fitting at different
BER levels in Bathtub curve yields the standard deviation value of Rj and peak-
to-peak value of Dj. The Bathtub curve is obtained from the spectrum analysis
based or the arbitrary pattern analysis based Rj/Dj separation methods. Rj and Dj
based on the Dual-

DJ

Dirac model can be denoted as RJ 9 and Tdd,

R . . . .
After J 9 and Dy are obtained, Tj can be calculated using this formula:

TJ(BER)= 2Q(BER) x RJ,, +DJ

Where Q is the function of BER that has a value of about 7 when

-12
BER=10"" Tphe Eye opening is computed in the same way as it is computed
in the spectrum analysis based Rj/Dj separation.

The Dual Dirac model based Rj/Dj separation method is used in PCI-Express and
FB-DIMM modules.

Dj does not usually have a pure Dual-Dirac distribution. So the

value of RJ 9 is often greater than the value of Rj obtained from the spectrum
analysis based or the arbitrary pattern analysis

based Rj/Dj separation. The value of DJg is often less than that of D;.

Refer to www.T11.org for a detailed description of Rj/Dj separation based on
Dual-Dirac model.
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Jitter Measurements Field Notes

Data pattern generation techniques vary from one serial data standard to another.
Refer to the Standards Methods Of Implementation (MOIs) documents for
specific details on how to set up those system-to-broadcast testable data/test
patterns.

Both PCI Express and InfiniBand serial data traffic test patterns are interspersed
with Skip Ordered Sets (SOSs) on regular intervals. When conducting jitter
measurements that require repeated data sets (such as for Jitter @ BER), you will
need to set up the acquisition system to acquire between these non-deterministic
Skip Characters. Refer to the Standards MOIs documents for specific details on
how to set up the system to work under these conditions.

TIE Jitter Measurement
The measured time difference between a data edge and a recovered clock edge.
tie(n) =tg_par (N) = tpar ()
Where:
t

DAT is the original data edge

tr-oar is the recovered data edge (for example, the recovered clock edge
corresponding to the UI boundary of "DAT

n is the index of all edges in the waveform
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TIE Jitter Filtering Measurement

TIE lJitter Filtering measurement is used to apply a pre-defined filter to TIE jitter
to get filtered TIE jitter measurement.

TIEREFCLKfFILTERED (S) = H (S) 'TIEREFCLK (S)

Where:

TIE

REFCLK-FILTERED js the frequency domain representation of a

filtered TIE jitter ('SREFOLK-FILTERED

H is the transfer function of a pre-defined filter

TIE

REFCLK s the frequency domain representation of a TIE jitter

before filtering Urercik

The TIE jitter filtering measurement is required by PCI-Express and FB-DIMM

modules for reference clock measurements. In these two modules, the filter is

used to emulate the effects of variation of the jitter transfer function of PLLs

between transmitters and receivers; transport delays between them; differences in

the propagation delays in the devices, and the phase tracking| lea dwidth of the
L . S) .

clock phase recovery circuitry. One such transfer function is defined as

2 2
H(s) = 286,00, + o, 05T _ 28¢,0, + w; S
s* +2s¢,0, + @/ s’ +2s¢,0, + @] | S+,

Where the parameters %i , @; and " are pre-defined. An H(s) has a magnitude
frequency response as follows:
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Attenuation (dB)
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Figure 132: Frequency response of H(s)
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Statistics

About Statistics

The application calculates statistics for all selected measurements. The
application displays the following statistics in the Results menus:

®  Maximum value

®  Minimum value

®  Mean value

®  Standard deviation value
®  Peak-Peak value

®  Population

Maximum Value

The application calculates this statistic using the following equation:

Max(x) = Highest value of x

Minimum Value
The application calculates this statistic using the following equation:

Min(x) = Lowest valueof x

Mean Value

The application calculates this statistic using the following equation:

Mean(x) =X = ﬁf x(n)
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Standard Deviation Value

It may seem odd that the equation for the estimate of the Standard Deviation
contains a 1/(N-1) scaling factor. If you knew the true mean of X and used in
place of the estimated mean A, then you would, in fact, scale by1/N. But, A s
an estimate and is likely to be in error (or bias), causing the estimate of the
Standard Deviation to be too small I scaled by 1/N. This is the reason for the
scaling shown in the equation. (Refer to Chapter 9.2 in A. Papoulis, Probability,
Random Variables, and Stochastic Processes, McGraw Hill, 1991.)

The application calculates this statistic using the following equation:

LS xmy-%y°

StdDev(x) = o, = \/(N -1 1=

Peak-to-Peak Value

The application calculates this statistic using the following equation:

PkPk(x) = Max(x) — Min(x)

Population Value

Population is the total number of data points applied to the displayed statistics.
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About the GPIB Program

An example of a GPIB program that can execute the RT-Eye application is
included with the application. The oscilloscope hard disk includes the example
file, rt-eyectrl.c. On the hard drive, the file resides in the
C:\TekApplications\tdsrt-eye\Examples\RemoteCtrl directory.

The example shows how a GPIB program executes the application to do the
following tasks:

B Start the application
B Recall a setup

®  Take a measurement
®  Check for an error

®  Exit the application
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Guidelines to GPIB Programming

The application includes an example file of a GPIB program. Your GPIB
program should comply with the following guidelines:

®  The application startup must complete before sending additional GPIB
commands to the application; query the variable application; it will return
"TDSRT-EYE" when the application startup is complete

B  Recall a setup file from GPIB to select measurements and set up the
application

®  The measurements cycle must complete before data is queried; query the
variable SequencerState; it will return "Ready" when sequencing is
complete

®  The resultFor and resultAcq variables must be set before querying results;
pause a second after setting each variable

®  The error variable should be checked to ensure that an error has not occurred
because of a measurement command problem; the measError variable
returns errors specific to the measurement selected by resultFor

236 RT-Eye ®Serial Compliance and Analysis Application



GPIB

Program Example

The program example shows how to communicate to the RT-Eye application
using remote GPIB commands. The program includes the following steps:

®  Start up the application
®  Recall a setup

®  Take a measurement

" Display results or errors
®  Exit the application

In the example, you will recall a setup file named rt-eyectrl.c (setup). You can
use the File> Save function in the application to save setup files according to
your own needs.
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GPIB Commands

Introduction to GPIB Command Syntax

With knowledge of the GPIB command syntax, you can design a GPIB program
to do the following tasks:

®  Start the RT-Eye application

B Recognize an active application with GPIB protocol
®  Program and read application setup parameters

®  Sequence measurements

®  Read measurement results

®  Generate reports
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GPIB Reference Materials

To use GPIB commands with your oscilloscope, you can refer to the following
materials:

" The rt-eyectrl.c file on the oscilloscope hard drive (located in the
c:\TekApplications\tdsrt-eye\Examples\RemoteCtrl directory) for an
example of a GPIB program that can execute the application

®  The GPIB Program Example topic for guidelines to use while designing a
GPIB program

" The Parameters topics for range of values, minimum units and default
values of parameters

®  The programmer information in the online help of your oscilloscope

Starting and Setting Up the Application using GPIB

To start the RT-Eye application, you must send the oscilloscope the following
GPIB command:

application:activate "RT-Eye Serial Compliance and Analysis"

Note: The name of the application in the previous string is identical to the name
of the application from the oscilloscope Run Application list.

The application uses the GPIB VARIABLE:VALUE command with arguments
to execute some features. The set of GPIB commands does not include the
variable names and variable values necessary to select and configure the
measurements in the GPIB program.

You must manually set up the application and oscilloscope, selecting and
configuring the measurements that you want to use with your GPIB program, and
save them in a setup file in the default setup folder for that module. To save a
setup file, refer to Saving a Setup File. Use the name of the saved setup file as
the value for the "recallName" variables in your GPIB program.
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Variable: Value RT-Eye Command

240

A

Description

This command accepts string arguments for a control or data variable and a value
to which to set the argument.

Syntax

VARIABLE:VALUE "<variable name>","<variable value>"

Note: The arguments <variable name> and <variable value> are required in the
order indicated.

VARIABLE:VALUE? <variable name> for query.

CAUTION: Commands are case and space sensitive. Your program will not
operate correctly if you do not follow the capitalization and spacing
precisely.
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Table76. Variable value RT-eye command arguments and queries

Group/name

Variable: Value RT-Eye Command Arguments and Queries (Part 1)

Value

partl
Function

Query returns

application {exit} Terminates the active Returns TDSRT-EYE when
application the application is active
version Query only Returns the version number
of the application
Sequencer
sequencerMode | {SingleNoAcq, Sets the sequencer mode | Returns the sequencer mode
FreeRun, Single}
sequencerState |{Stop, Sequencing} Sends the Measurement | Returns {Most recent setting,
Sequencing command Ready}; Ready indicates that
the value was processed
reset {Results} Clears the active Returns {Most recent setting,

measurement results and
plots

Ready}; Ready indicates that
the value was processed

Active module

module

{SerialAnalysis,
InfiniBand,
PCIExpress,SATA,SAS
,FB-DIMM}

Switches to the specified
module **

Returns the active module

Recall setup

setup*

{Default, Recall}

Performs the Recall
Default setup function

Returns {Most recent setting,
Ready}; Most recent setting
indicates that the value is
being processed; Ready
indicates that the value was
processed

recallName

Any string from 1 to 40
characters: Ato Z,0to
9, or special characters
like “.”

Sets the Recall setup file
name; file name
extension of .ini is
optional

Returns the name of the set
up file to be recalled (without
an extension)

recallDirectory

Query only

Returns the current setting
(determined from module
command) of recall directory
default, such as
InfiniBand\setup

*Query may return an error code if command fails.
**Refer to the online help in the SATA and SAS modules for their Variable:Value commands and queries.
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Table 77. Variable value RT-eye command arguments and

Variable:Value RT-Eye Command Arguments and Queries (Part 2)

Group/name Value Function Query returns

Source scaling

sourceAutoset*** | {Vert, Horiz, Starts the automatic scaling if | Returns {Most recent setting,

vertAndHoriz} the sources are channel Ready}; Ready indicates that

waveforms the value was processed

Source ref levels

refLevelAutoset*** | {Run} Performs Ref Level Autoset | Returns {Most recent setting,
for the for all active sources; |Ready}; Ready indicates that
Active sources are Differential | the value was processed
when Differential is the Probe
Type or Differential, Dplus
and Dminus when Single-
Ended is the Probe Type.

Report generator setup

reportGen* {Now} Exports content from current | {Most recent setting, Ready}
measurements into a report Ready indicates report has
template/layout where the been created and saved.
template/layout are default or
as specified in the recalled
setup file; concatenates the
Template name and a
timestamp for the file name

Compliance module only

reportDevicelD

Any string from 1 to
40 characters: A to
Z,0t0 9, or special

“wn

characters like “.

Specifies the device ID field
for report generation

Returns the specified
DevicelD; applies to
compliance modules only

Result variables

result group as the most
recent acquired or as an
accumulation of all the
measurements in the current
session

resultFor {Measurement Specifies the measurement Returns the selected
Name} that is the source for detailed | measurements for the queries
results queries; refer to the associated with the resultFor
tables between this one and |command
the error codes table
resultAcq {All, Current} Specifies the measurement Returns the current value

* Query may return an error code if command fails.

** Serial Analysis module only.
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Measurements

Results Queries

& CAUTION: Before you query for the measurement results, be sure to insert
a one second delay after the resultFor and the resultAcq commands to allow

the statistics variables to refresh.

You need to use the VARIABLE:VALUE? form to enter measurement results
queries in your GPIB program. Before you can do this, you must first set the
measurement with the resultFor command. You can select the current or all

acquisition statistics with the resultAcq command.

The next several tables list the measurement results queries for the measurement

selected in the resultFor variable.

Measurements Results Queries Variable Names (Part 1)

Table 78. Measurement results queries variable names (part 1

Variable name

Query returns for measurement

Statistics for all measurements selected with resultFor

max Returns the maximum measurement value.

mean Returns the mean measurement value.

min Returns the minimum measurement value.

pkpk Returns the peak-to-peak measurement value.

population Returns the number of measurements used to the current
statistics.

stdDev Returns the standard deviation measurement set.

Other for non-statisti

cal information that appears in the Results menus.

value

Returns a generic message for measurements with no
statistical results, such as for amplitude measurements.

maskUIControl

Returns the number of Uls examined for mask hits.

maskHits Returns the number of Uls containing one or more mask
hits.

Limits

statusMax Pass or Fail status; Pass when the measurement is below
the maximum limit or Fail.

statusMin Pass or Fail status; Pass when the measurement is above
the minimum limit or Fail.

status Pass or Fail status; Pass when the measurement passes
the compliance test or Fail; also applies to the RT-Eye
analysis with limits defined.

Misc

measUnits Returns a units string for the measurement, such as s for

seconds.
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Measurements Results Queries Variable Names (Part 2)

Table 79. Measurement results queries variable names (part 2
Variable name Query returns for measurement

Jitter@BER only

dataDependent Returns the data dependent jitter component of the TIE
measurement.
dutyCycle Returns the duty cycle jitter component of the TIE

measurement.

deterministic

Returns the deterministic jitter component of the TIE
measurement.

periodic Returns the periodic jitter component of the TIE
measurement.

random Returns the estimated random jitter component of the TIE
measurement.

totalJitter Returns the estimated total jitter component at the BER of
the TIE measurement.

eyeOpening Returns the estimated eye opening at the BER of the TIE
measurement.

Population Returns the population when resultAcq variable is set to

"A”".

Messages return strings if there are problems; refer to the Error Codes tables.

resultForStatus

Returns one of the following strings:

“Active” when the value of resultFor is an active
measurement.

“Inactive” when the value of resultFor is a known
measurement that's not active.

“Unknown” when the value of resultFor is an unknown
measurement.

Any of the results specified in this table are not valid
unless this variable is “Active”.

error Returns a general error.
warning Returns a warning from the most recent measurement.
measError Returns a measurement specific error.
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Serial Analysis Measurement Names for the resultFor Variable

Table 80. Serial analysis measurement names for the resultFor variable
Results when resultAcq=

Measurement All Current

Names Stats And ... Stats

Eye Width Yes Yes

Eye Height Yes maskUICount, Yes maskUICount,
maskHits maskHits

Eye Height Yes maskUICount, Yes maskUICount,

Transition Bits maskHits maskHits

Eye Height Non- Yes maskUICount, Yes maskUICount,

Transition Bits maskHits maskHits

Rise Time Yes Yes

Fall Time Yes Yes

Unit Interval Yes Yes

Bit Rate Yes Yes

Differential Skew* |Yes Yes

Differential Yes Yes

Amplitude

High Amplitude Yes Yes

Low Amplitude Yes Yes

CM Voltage* Yes Yes

AC CM Voltage* Yes Yes

De-Emphasis Yes Yes

Jitter @ BER Jitter @ BER Jitter @ BER
variables; see variables; see
previous topic previous topic

Eye Opening Yes eyeOpening Yes eyeOpening

Total Jitter Yes totaljitter Yes totalJitter

Deterministic Jitter |Yes deterministic Yes deterministic

TIE Jitter Yes Yes

* Added when the Probe Type option is Single Ended.
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InfiniBand Driver Measurement Names for the resultFor Variable

Table 81. Infiniband driver measurement names for the resultFor variable
Results when resultAcq=
Current

Measurement
Names

All
Stats

And ...

Stats

Eye Height Yes maskUICount, Yes maskUICount,
maskHits maskHits

Eye Height Transition |Yes maskUICount, Yes maskUICount,

Bits maskHits maskHits

Eye Height Non- Yes maskUICount, Yes maskUICount,

Transition Bits maskHits maskHits

Rise Time Yes Yes

Fall Time Yes Yes

Unit Interval Yes Yes

Differential Amplitude |Yes Yes

CM Voltage* Yes Yes

Eye Opening Yes Yes eyeOpening

AC CM RMS Voltage* | Yes Yes

Jitter @ BER Jitter @ BER Jitter @ BER
variables; see variables; see
previous topic previous topic

Total Jitter Yes Yes totalJitter

Deterministic Jitter Yes Yes deterministic

* Added when the Probe Type option is Single Ended.
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Table 82. Infiniband receiver measurement names for the resultFor variable

Measurement
NEINES

Results when resultAcqg=
Current

All
Stats

And ...

Stats

Value

Eye Height Yes maskUICount, Yes maskUICount,
maskHits maskHits

Differential Yes Yes

Amplitude

CM Voltage* Yes Yes

Eye Opening Yes Yes eyeOpening

Jitter @ BER Jitter @ BER Jitter @ BER
variables; see variables; see
previous topic previous topic

Total Jitter Yes Yes totalJditter

Deterministic Jitter Yes Yes deterministic

* Added when the Probe Type option is Single Ended.

InfiniBand Cable Assembly Measurement Names for the resultFor Variable

Table 83. Infiniband cable assembly measurement names for the resultFor variable
Results when resultAcq=

Measurement All Current

INETNIE] Stats And ... Stats Value And ...

Eye Width Yes Yes

Eye Height Yes maskUICount, Yes maskUICount,
maskHits maskHits

TIE Jitter Yes Yes

* Added when the Probe Type option is Single Ended.
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PCI Express Measurement Names for the resultFor Variable for any Test point
except Reference clock

Table 84. PCI Express measurement names for the resultFor variable for any test
Results when resultAcq=

point except reference clock

Measurement All Current

NEES Stats %nd Stats Value And ...

Eye Width Yes Yes

Eye Height Yes maskUICount, Yes maskUICount,
maskHits maskHits

Eye Height Transition |Yes maskUICount, Yes maskUICount,

Bits maskHits maskHits

Eye Height Non- Yes maskUICount, Yes maskUICount,

Transition Bits maskHits maskHits

Rise Time* Yes Yes

Fall Time** Yes Yes

Unit Interval Yes Yes

Differential Peak Yes Yes

Voltage

Differential Average |Yes Yes

Voltage

De-Emphasis Yes Yes

AC CM RMS Yes Yes

Voltaget

TIE Jitter Yes Yes

* For Single Ended two measurements: Rise Time D+ and Rise Time D-.

** For Single Ended two measurements: Fall Time D+ and Fall Time D-.

T Added when the Probe Type option is Single Ended.
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PCI Express Reference Clock Measurement Names for the resultFor Variable

Table 85. PCI Express measurement names for the resultFor variable
Results when resultAcq=

Measurement All Current

INETGIES Stats And ... Stats Value And ...

High Voltage Yes Yes

Low Voltage Yes Yes

Differential Peak Yes Yes

Voltage

Rising Edge Yes Yes

Falling Edge Yes Yes

Period Yes Yes

Duty Cycle Yes Yes

Jitter @ 6 BER Jitter @ BER Jitter @ BER
variablest variablest

Jitter @ 12 BER Jitter @ BER Jitter @ BER
variablest variablest

TIE Jitter Yes Yes

* All measurements are available only for differential probe.

Names Part 2

T Jitter @ BER variables are defined in the topic Measurement Result Queries Variable
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FBDIMM Transmitter Measurement Names for the resultFor Variable

Table 86. FBDIMM transmitter measurement names for the resultFor variable
Results when resultAcq=

Measurement All Current

INETN[ES Stats  And ... Stats Value And ...

Eye Width Yes Yes

Eye Height Yes maskUICount, Yes maskUICount,
maskHits maskHits

Eye Height Transition | Yes maskUICount, Yes maskUICount,

Bits maskHits maskHits

Eye Height Non- Yes maskUICount, Yes maskUICount,

Transition Bits maskHits maskHits

Bit Rate Yes Yes

Rise Time Yes Yes

Fall Time Yes Yes

Differential Peak Yes Yes

Voltage

De-Emphasis Yes Yes

AC CM Pk Voltaget |Yes Yes

CM Voltagett Yes Yes

Jitter @ BER Jitter @ I§ER Jitter @ @ER
variables variables

TIE Jitter Yes Yes

T Available only If Probe Type option is Single-Ended.

Tt Available only If Probe Type option is Single-Ended and Swing Type selection is

Large or Small.

" Jitter @ BER variables are defined in the topic Measurement Result Queries Variable

Names Part 2.

250 RT-Eye ®Serial Compliance and Analysis Application



GPIB

FBDIMM Receiver Measurement Names for the resultFor Variable

Table 87. FBDIMM receiver measurement names for the resultFor variable
Results when resultAcq=

Measurement All Current

Names Stats And ... Stats Value And ...

Eye Width Yes Yes

Eye Height Yes maskUICount, Yes maskUICount,
maskHits maskHits

Bit Rate Yes Yes

Rise Time Yes Yes

Fall Time Yes Yes

Differential Peak Yes Yes

Voltage

AC CM Pk Voltaget |Yes Yes

CM Voltaget Yes Yes

Jitter @ BER Jitter @ I§*ER Jitter @ @ER
variables variables

TIE Jitter Yes Yes

T Available only if Probe Type option is Single-Ended.

Names Part 2.

" Jitter @ BER variables are defined in the topic Measurement Result Queries Variable

RT-Eye ® Serial Compliance and Analysis Application

251



GPIB

FBDIMM Reference Clock Measurement Names for the resultFor Variable

Note: All measurements are available only for differential probe.

Table 88. FBDIMM reference clock measurement names for the resultFor variable
Results when resultAcq=

Measurement All Current

Names Stats And ... Stats Value And ...

High Voltage Yes Yes

Low Voltage Yes Yes

Rising Edge Yes Yes

Falling Edge Yes Yes

Frequency Yes Yes

Duty Cycle Yes Yes

Jitter @ BER Jitter @ BER Jitter @ BER
variablest variablest

TIE Jitter Yes Yes

T Jitter @ BER variables are defined in the topic Measurement Result Queries Variable

Names Part 2.

GPIB Commands Error Codes

Table 89. GPIB commands error codes

252 RT-Eye ®Serial Compliance and Analysis Application



GPIB

Code Description

E101 No measurements have been selected; select a measurement.

E103 Record length changed in between.

E105 Unable to initialize measurement sequence.

E107 Unable to enable and display requested signal source.

E108 Reduce record length or number of measurements, sequencing
stopped.

E109 Setup file is corrupted or there is another problem with recall.

E151 Level too high for primary Vref High - Autoset Ref Level.

E202 Upper range should be more than Lower range.

E300 Oscilloscope signal acquisition failure due to PC memory limitation.

E301 Sequencing was stopped; a timeout occurred while acquiring signal
from the oscilloscope; check the signal or trigger level.

E302 Waveform Math operation failed.

E400 Measurement failed to complete successfully.

E408 Missing data file or crossing times file.

E410 Number of edges is not sufficient for a measurement.

E417 Not enough Record Length for required analysis window.

E420 Could not complete RjDj separation; less than 50 pattern repeats
detected.

E424 No edges or Ul of required type are found in waveform; check the
Vref threshold or record length.

E425 Not enough good bits to perform arbitrary RjDj separation. Increase
the record length or make more acquisitions.

E430 Invalid Pattern Length.

E435 Not enough edges to perform arbitrary RjDj separation. Increase
record length.

E440 Signal is unstable. Clock Recovery failed.

E471 Time constant to remove the data edges is not correct. Adjust time
constant within the range or acquire more data edges.

E702 File not found; stopping sequencer.

E703 I/O Error; stopping sequencer.

E704 Unable to write worst case file; stopping sequencer.

E800 File not found.

E801 File already exists.

E802 Cannot create the file.

E803 lllegal character(s) in the file name.

E804 Cannot create the directory.

E805 Application .ini file successfully recalled, but the .set file was not
recalled because it was not found or was corrupted.

E806 Invalid CSV File/Incompatible CSV Files.

E807 Invalid wifm File.

E999 A recognized error has occurred.

E1001 | Process did not complete; no signal.

E1002 | Process did not complete; signal exceeds top of scale.

E1003 | Process did not complete; signal exceeds bottom of scale.

E1004 | Process did not complete; signal removed.

E1005 | Process did not complete; failed to measure rising and falling edge
speed.

E1006 Process did not complete; Horizontal resolution at maximum.
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GPIB Commands Warning Codes

Table 90. GPIB commands warning codes
W999 | An unspecified warning has occurred.

w410 Number of edges is not sufficient for a measurement.

w402 RjDj separation accuracy not guaranteed; less than 100 pattern
repeats detected.

w701 Worst case waveform logging timed out while saving; stopping the
sequencer.
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